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Mellel Guide
Mellel is an advanced word processor for Mac OS X, combining innovative 
features such as multiple note streams, style sets, auto-titles, and more. 

What does “Mellel ���” mean?
The word “Mellel” is a word in Hebrew meaning “Text” or “Words”. 

How to use this guide
This guide is organised to help you find what you need to find easily and 
quickly. Each chapter in the guide contains a short description of the chapter’s 
content, and a Should I read this? box, that will help you decide if you you need
to read this chapter. This is followed by a table of Stuff You can do, containing 
the various functions that are available with each feature. Last, but not least, 
there is a comprehensive listing of all the features and options relevant to that 
section. 
If you’re new to Mellel, it would benefit you to read at least the first chapters of 
the guide. Otherwise, simply skip directly to the functions that have changed 
with the recent version.

How to find things in the guide
The Table of Contents at the beginning of this guide allows you to browse 
through all the chapters and sections of this guide. If you cannot find what you 
want in the guide, try to search for a keyword using the Find option in Adobe® 
Acrobat® Reader or Apple’s Preview. The latter is a very effective tool if you 
want to browse through all the occurrences of a word or a phrase in the 
document.
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System Requirements
• A Macintosh computer capable of running Mac OS X 10.5 or later

• An Intel processor

• Mac OS X 10.5 or later

• A monitor with at least 800x600 resolution



Trial version limitations
Mellel is a shareware product. This means that anyone can download the latest 
official version from the RedleX site and try it before buying it. 
The trial version (sometimes called “Demo” version) will run for a period of 30 days
with the following limitations:

1 When you launch Mellel a “Please Register” dialogue box will appear. 
2 When printing from Mellel to an output device (including saving to PDF) a large 

“Unregistered” watermark will be stamped across each printed page. 

Once the trial period is over, a third limitation will be added: You will not be able 
to export or copy content from Mellel to a file or to other applications.



Download, install and Run Mellel
This chapter explains how to download, install run Mellel, and what 
to do when things go wrong

Should I read this chapter?
You should read this chapter if you‘re not sure how to download or install 
Mellel, or if you’re having problems downloading or installing Mellel

Downloading Mellel
To install Mellel or to update to a newer version you need to download it from the
Internet. 

To download Mellel:
1 Open your web browser and go to http://www.mellel.com/.
2 Click the Download button in the home page to start the download. 
3 Wait while the download is in progress. You can usually follow the download 

progress via the download window in your browser.

Figure 1: Download progress in the Safari browser

Installing Mellel
Once the download is over, different browsers will handle the downloaded file a 
bit differently. 

Safari
Once the download is over, the zip file will automatically decompress and open a 
window on your desktop that will allow you to install Mellel.



Figure 2: The Mellel DMG window

Firefox
When you click to download, Firefox will ask you what to do with the Mellel dmg 
file. Select “Save to Disk”:

Figure 3: Save to disk with Firefox

Firefox will download the file and save it to a designated folder. The name of the 
default folder will be displayed at the bottom of the download window (the 
default folder is your desktop).
Once the download is finished, double-click the downloaded file to open the 
installation window.
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Figure 4: Opening in Firefox

To install or update Mellel:
1 In the Mellel window that opened after the download is complete, click the “Show

toolbar” button at the top right corner of the installation window.

Figure 5: The Show toolbar button

2 The window will now display a list of places in your hard disk. Click the Mellel Icon
in the window, drag it over the Applications folder and release. The operation will 
look something like the following:

Figure 6: Dragging Mellel into the Applications folder

3 If you already have a copy of Mellel installed in your Applications folder, Mac 
OS X will ask you if you want to replace it with the new copy.
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Figure 7: To install or not to install, that is the question

4 Click Replace to replace the old version of Mellel with the new one. Click Stop to 
avoid replacing it and return back to the Mellel window. 
That’s it. You’re done, and all you need to do now is go into the Applications folder
and double-click Mellel to launch it.

Running Mellel
You can run Mellel very easily from your Applications folder

To run Mellel:
1 Open your Applications folder located at the top level inside your hard disk. 

Figure 8: This is how the Applications folder looks under 10.5.x

2 Locate Mellel inside that folder and double-click on its icon. Mellel will launch.

Note: While Mellel starts up, its icon will “bounce” in the Dock at the bottom of your screen. 
When Mellel finishes the launching process, a small bright dot will appear under the Mellel 
icon in the Dock, indicating that Mellel is one of the applications running on your 
computer. 
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Updating Mellel
Once you’ve downloaded and installed Mellel, updating it is very easy. All you’ve 
got to do is:

1 Choose Mellel > Check for Updates....
2 Several things can happen now. 

• If you have the latest version of Mellel installed, you’ll be so informed with the 
following dialogue box:

Figure 9: Your version of Mellel is up to date!

• If there is a newer version Mellel will display the following dialogue box: 

Here you'll find 
information

about the latest 
version

Read this carefully:
The information here 

will tell you if the 
update is free for you 

or not! Don't want to 
update? press here

Want to update?
Press Here

This is the latest 
version

And this is the version 
you have

The Install Upgrade dialogue box
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Here you’ll be find details about the update and install it directly (or not). Once 
the latest version gets downloaded into your disk, it will be installed 
automatically, replacing your existing version. 

Note: you can always take it back—even if you’ve gone through the whole update process 
and decided, at the end, not to upgrade you can always press the Cancel button and revert
to the previously installed version.

Check for updates automatically
Mellel allows you to automate checking for updates by setting the desired time 
intervals in the Preferences. 

To automatically check for updates:
1 Choose Mellel > Preferences....
2 Under the General tab open the Automatically Check for Updates pop-up menu and 

choose one of the options. 

Adding Mellel to the Dock
If you use Mellel regularly, you can add it to your Dock so you can launch it 
without having to open the Applications folder.

To add Mellel to the dock:
Do one of the following:

• Drag Mellel’s icon from the Applications folder to the Dock, dropping the icon to 
the left of the line in the Dock. Or,

• Run Mellel. Then press its icon in the Dock and choose Keep in Dock.

To move Mellel in the Dock:
• Drag Mellel’s icon in the Dock to a different location.

To remove Mellel from the Dock:
• Quit Mellel. Then drag Mellel’s icon out of the Dock.

Uninstalling Mellel
You can uninstall Mellel in a matter of seconds by simply removing Mellel from 
your Applications folder.
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To remove a copy of Mellel from your hard disk:
1 Quit Mellel if it is running, open your Applications folder, and locate the Mellel 

application file in it. 
2 Select Mellel’s icon and drag it to the Trash. 

Note: You will not be able to empty the Trash completely if Mellel is still running. 

To remove Mellel’s preferences:
Mellel stores all the information needed to run the application in its Preferences 
file and in the Mellel folder in your Applications Support folder. Those files do not 
alter or affect your system in any way. However, if you need to remove either of 
them for some reason reason, follow the steps below.

1 Open the Library folder inside your user folder, and then open the Application 
Support folder. 

2 Select the folder named Mellel and move it to the trash.
3 Open the Library folder inside your user folder, and then open the Preferences 

folder.
4 Select the file named “com.redlex.mellel.plist” and move it to the trash.

Common installation problems
Sometimes, the installation does not go so smoothly. Here are some tips to solve 
common installation problems.

What window? I just see a Hard Disk icon
Sometimes, instead of the installation window, you just see a “hard disk” icon on 
your desktop. 

Figure 10: The mellel “hard disk”

This is not a problem, nothing went wrong and the fix is quick and easy: 
1 Go to your desktop, locate the “hard disk” icon and double-click it. 
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2 The Mellel installation window will open, and you’ll be able to proceed with the 
installation process as described above.

I just see a file with a small hard disk icon
Sometimes, after you’ve downloaded Mellel, the disk image file doesn’t open 
automatically. The result is a file looking like this:

Figure 11: The file with a small hard disk icon

The solution for this problem is simple: 
1 locate the file (it’s usually on your desktop) and double-click it. 
2 The file will now open and you’ll see the Mellel installation window. From 

there, proceed with the installation process as described above.

How do I get rid of the Mellel “hard disk”?
Once you’ve installed Mellel, the virtual “hard disk” created on your desktop 
becomes a nuisance. You can remove it using the normal process for ejecting 
discs and CD-ROMs in Mac OS X.

To remove the virtual disk from the desktop:
Do any of the following:

• Locate the Mellel “hard disk” icon (not the Mellel dmg file!), select it, and press 
the Control key. From the Contextual Menu select Eject “Mellel”. Or,

• Locate the Mellel disk icon on your desktop (not the Mellel dmg file!), select it, 
and drag it to the trash. Or,

• If the Mellel virtual disk is opened, click in it (not on the Mellel application 
icon) and press the Control key. From the Contextual Menu select Eject 
“Mellel”. Or,

• In a Finder window, locate the Mellel disk and click the small Eject button to 
its right.
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Buying and Upgrading
This chapter explains how to purchase and upgrade Mellel

Should I read this chapter?
You should read this chapter if you‘re you want to learn how to buy Mellel 
or if you need to upgrade Mellel

If you run Mellel in Demo (unregistered) mode, you’ll be presented, once the 
launching process is over, with the Registration Prompt window.

Figure 12: Mellel’s Registration Prompt window

The Registration Prompt offers you three options:

• Buy Now...: Press this button to purchase Mellel and fully enjoy all its 
advantages.

• Enter Code...: If you’ve already purchased Mellel, press this button to enter 
the registration code. 

• Not yet: Press this button to run Mellel in Demo mode for up to 30 days. To 
learn more about the trial version, read the Trial version limitations section. 

Buying Mellel
You can buy and register Mellel in a matter of minutes.



Step One: Start the purchase process
To start the purchase process, click the Buy Now... button or choose Mellel (menu) > 
Buy Mellel...

Figure 13: The Buy Now... button

Step Two: The Buy Mellel Window
The Buy Mellel window presents you with several purchase options for Mellel. The 
first three can be bought from within Mellel (that is, without leaving the 
application). Others are available only from our store. 

Figure 14: The Buy Mellel window
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Clicking any of the option will lead you straight into the purchase process.
Buying from within Mellel—That is, without leaving the application—is quick, 
convenient and safe: You’ll get Mellel registered automatically within a minute, 
without having to enter a registration code. 

Note: Some types of purchases of Mellel need to be handled manually (e.g., the Five Pack), 
and this can only be done via our store. For more information about purchase options, go 
to our buying information page: http://www.mellel.com/supportpurchase.html.

Step Three: Confirmation
After the buying process is complete, you’ll receive a registration confirmation 
note by email. The confirmation note will include the purchase info and the 
registration code. 
The registration code will be needed for registering Mellel (or re-registering it) but
even if you’ve registered automatically, keep the code in a safe place and print it 
as a record of the purchase for future use. 

Registering Mellel
You can register (or re-register) Mellel quickly and easily. 

To register Mellel:
1 Do one of the following:

• Click the Enter Registration Code... button in the Registration Prompt window. Or,
• Choose Mellel (menu) > Registration Code...

2 Mellel will display a dialogue box with text fields in which you can enter (or, 
better, paste from the email message) the User Name and the Registration Code 
you received.
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Figure 15: The Registration Code dialogue box

3 Press the Register button. 

Note: If the registration doesn’t work properly and you get a message that the registration 
code or user name are incorrect, make sure that you’ve entered both correctly (both the 
User Name and the Registration Code are case sensitive).

Upgrading Mellel
Upgrading Mellel should be a painless process. to see if you need to upgrade and 
what are the benefits of upgrading, simply do the following:

1 Choose Mellel > Check for Updates...
2 If you have a pre-2.6 version of Mellel: you’ll be taken to an html file which will tell 

you if your version is up-to-date or not, and what you need to do about it.
If you have the latest version of Mellel installed, you’ll be so informed with the 
following dialogue box:

Figure 16: Your version of Mellel is up to date!

If you have version 2.6 or later of Mellel Mellel installed, but not the latest version 
available, Mellel will display the following dialogue box:
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Here you'll find 
information

about the latest 
version

Read this carefully:
The information here 

will tell you if the 
update is free for you 

or not!

Don't want to 
update? press here

Want to update?
Press Here

This is the latest 
version

And this is the version 
you have

The Install Upgrade dialogue box

Here you’ll be able to make up your mind and install or skip installing the latest 
version. 
If you need to purchase an upgrade—that is, if this is not a free update for you—
you’ll see a clear notification that this is not a free update and that you’ll be 
required to purchase an upgrade to update to the latest version.

Note: you can always take it back—even if you’ve gone through the whole process and de-
cided at the end not to purchase an upgrade, for example, you can always press Cancel 
and revert to the previously installed version.
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Check for updates automatically
Mellel allows you to automate checking for updates by setting the desired time 
intervals in the Preferences. 

To automatically check for updates:
1 Choose Mellel > Preferences....
2 Under the General tab open the Automatically Check for Updates pop-up menu and 

choose one of the options. 
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An introduction to Mellel
This chapter includes an introduction to the most important features 
and concepts of Mellel

Should I read this chapter?
If you only intend to read one chapter of this guide—This is the chapter you
should read. It includes all the essential information about Mellel, and a 
reference to additional info about its main features

The basics
Mellel is a word processor. It allows you to write text, edit it, style it, format some 
text as lists or tables, lay it out, and later on print the text to paper or export the 
text for further use with other applications. 

The document
A document is a series of pages into which you can enter text, tables, images, and 
so on. A document can be saved. That is, you can order Mellel to dedicate some 
space on your hard disk where it will keep all the details about the document: the 
text you’ve entered into it, and every formatting you’ve made. 

Characters
The most basic unit in a word processor document is the character—That is, a 
single letter, number, space, and so on. Every character has attributes like the font 
and font face applied to it, size, fill colour, etc.
Mellel several tools to control the way characters appear in your documents. The 
changes you make to selected text will only affect the selected text. However, if 
you save the changes you’ve made into the style, they will affect any piece of text 
to which this style is applied. 
A brief review of the main character formatting options:

• Character Palette Attributes: allows you to change the font, the font face 
(e.g., to set a text with a Bold or Italic face), and the font size. With this palette 
you can also set every character attribute, including underline, colour, 
background colour, superscript, upper- and lower-case, and more. 



• More: the More tab of the Character palette attributes control several options, 
mostly related to language and text directionality such as the font, the font 
face, and relative size for a second font, and the character direction. 

• Character Styles tab: of the Character palette allow you to quickly apply, edit, 
save, change character variations, add, or delete styles. 

• The Character menu (Styles > Character Style): allows you similar options to 
those available via the Character Styles tab.

The Character palette and the Character menu are reviewed in detail in the 
Character Attributes chapter.

Paragraphs
Paragraphs are strings of characters separated by a Return character. Every 
paragraph in Mellel has several attributes, such as alignment, line spacing, space 
above and below it, tabs, and more. 
You can control almost all the options related to paragraph styles via the 
Paragraph palette. Hyphenation, Keep with, Next paragraph style, And Associated 
character style options are controlled via the Edit Paragraph Style dialogue box.
Those palettes, menus and tools are reviewed in detail in the Paragraph Attributes
chapter. 

Sections and columns 
Sections are blocks of text, spanning one or more paragraphs. Within a section, 
you can create text columns and set the options for arrangement of text in 
columns. 
You can set the options for sections using the Section palette or the Edit Section 
style dialogue box. Options for handling Sections styles are available via the 
Section palette Styles tab or the Styles > Section Style sub menu.
The palette, dialogue box and menu are discussed in depth in the Section 
(Column) Attributes chapter.

Pages
Mellel allows you to set individual pages or page ranges with their individual 
headers and footers, numbering schemes and so on. To control those options, 
open the Page palette and use the options there. 
Page options are discussed in depth in the Page Attributes section.
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Tables
Tables are handled mainly via the Tables palette. All the table options appear in 
the Table palette. Using this palette, you can set the line and fill colour, line weight 
and type, padding and alignment, and also select, split, equalise, add, and delete 
cells. To insert a table, you can use the Insert table button or choose Insert > Table....
For all the details about tables in Mellel, see the Tables chapter.

Lists
A List is a special paragraph attribute that allows you to create a series of 
paragraphs preceded by a numbering or a bullet. You can create an unlimited 
number of such lists in a document, stop and continue lists, copy and paste list 
styles, and so on. You can customise the list appearance, numbering, or bullet 
type, change their position in the list and also set and change their formatting.
You can learn more about lists in the chapter Lists.

Auto-titles (headings, captions)
Auto-titles are special elements (or ‘objects’) you can insert into your document to
serve as headings or as captions for graphs or images. Once entered, via the Auto-
title palette, you can style the auto-titles and design their format. 
Another important thing you should know about auto-titles is that they are used 
with other features in Mellel. The auto-titles you enter into your document are 
displayed in the Outline pane, serve as the basis for the Table of Contents, appear 
in changing headers (Mentions), and so on. 
You can learn more about auto-titles in the chapter Auto-titles (headings).
Footnotes and endnotes
Footnotes and endnotes are special types of comments that you can add to the 
document. You can enter a footnote or an endnote by creating a link (reference) in
the text to the footnote or the endnote, and then enter the footnote or endnote 
text. 
You can learn more about auto-titles in the chapter Notes (footnotes, endnotes).
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Working with Mellel
This chapter includes a practical basic guide to working with Mellel, 
including open and save, basic actions, selection, navigation, and 
more

Should I read this chapter?
If you’re new to word processing, or want to get to working with Mellel 
without reading the whole guide, you’d do fine reading just this chapter 
first

Opening and Saving
In this section you’ll learn how to create, open and save documents, how to open 
templates and how to set the defaults for new documents. 

Creating documents
When you create a new document, Mellel opens an empty window, allowing you 
to enter text, format it, change it and, of course, save it. You can always re-open 
the document you’ve created and make some more changes. 

Stuff you can do
To... Do this Keyboard Shortcut

Create a new 
document

1 Run Mellel. A new document will automatically be 
created. Or,

2 Choose File > New.

Cmd+N

Open an existing 
Mellel document from 
within Mellel

1 Choose File > Open... 
2 In the Open dialogue box, navigate to the 

document you want to open, select it, and press 
the Open button or double-click the file you want 
to open. 

Tip: To select multiple files in the Open dialogue box, hold 
down the Command key and click to select the files you 
want to open; or hold down the Shift key to select several 
sequential files.

Cmd+O

Open a document 
from the Finder

1 Locate a Mellel document in the Finder.
2 Double-click the document to open it.
Tip: dragging the file (or files) over Mellel’s application icon 
in the Finder or in the Doc will also open them.



Open a document 
saved to iCloud

1 Choose File > iCloud > “the file you want to open”. 
Note: This option is only available to users who’ve 
purchased Mellel via the Mac App store. 

Open a recently used 
document

1 Choose File > Open Recent and from the sub-menu 
select the desired document. 

Save a document 1 Choose File > Save. 
2 If this is the first time you have saved the 

document (that is, if it is an unsaved document), 
Mellel will ask you to name the file and select 
where to save it. 

Cmd+S

Save a document to 
iCloud

1 Choose File > Move to iCloud. 
Note: This option is only available to users who’ve 
purchased Mellel via the Mac App store. 

Remove a document 
from iCloud

1 Choose File > iCloud > “the file you want to open”. 
2 Choose File > Remove from iCloud. 
Note: This option is only available to users who’ve 
purchased Mellel via the Mac App store. 

Save a document 
under a different name

1 Choose File > Save As.... 
2 In the Save drop sheet, give the file a new name 

and navigate to the place where you want it saved. 

Cmd+Shift+S

Activate Automatic 
Save (auto-save)

1 Choose Mellel (menu) > Preferences... and click the 
Open & Save tab.

2 Do one of the following under Automatic save:
• Choose System Standard if you’re using Mac OS 

10.7 or later, and if you wish to save/backup your
files using the Method used with 10.7 or later. 

• Click Save Every and set the desired default value.

Activate Automatic 
backup

1 Choose Mellel (menu) > Preferences... and click the 
Open & Save tab.

2 Check the Every check-box under Automatic backup 
and set the desired default value (in minutes).

Save a document as a 
template

1 Choose File > Save as template... and set the name, 
description, location and preview. 

Open a template 
document

1 Choose File > Open Template... and select a template 
from one of the templates categories.

Set Mellel’s running 
and switching 
behaviour

1 Choose Mellel (menu) > Preferences... and click the 
Open & Save tab.

2 Select one of the Start-up & Switch options.

Cmd+,

Set a template for new 
documents

1 Choose Mellel (menu) > Preferences... and click the 
Open & Save tab.

2 Navigate to ~/library/application support/Mellel/
Templates, choose one of the template files and OK. 

Cmd+,
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Set Mellel to ignore or 
not to ignore changes 
to styles.

1 Choose Mellel (menu) > Preferences... and click the 
Open & Save tab.

2 Choose one of the options under If styles have 
changed.... 

Cmd+,

Save files in a 
compressed file format
(as a zip file)

1 Choose Mellel (menu) > Preferences... and click the 
Open & Save tab.

2 un-check the option Save documents as packages. 

Cmd+,

Switch a compressed 
document into a 
package

1 Choose the document in the Desktop and change 
the filename extension from “.mellel” to “.zip”

2 De-compress the file as you would with a simple 
zip file.

View a Mellel 
document from the 
finder

1 In the finder, navigate to the file you wish to view 
and press the Space Bar, and do any of the 
following:
• Press the Space Bar again to exit the OuickView 

view (or press Cmd+Y)
• Press the Up/Down/Left/Right Arrow keys to 

navigate between files.
• Press the Arrow buttons that appear when you 

hover above the document (in Cover Flow view) 
to move to the next page. 

• With the document open in QuickView, scroll the
document (using the scroller or scroll keys), 
switch into and out of Full Screen mode, and use 
the resize handle (bottom-right corner of the 
QuickView window) to change the window size. 

Cmd+Y

Set the number of 
pages viewable with 
QuickView

1 Choose Mellel (menu) > Preferences.... 
2 Under the General tab, do one of the following:

• Uncheck the Limit QuickView previews check-box 
to view all the pages in a document (not 
recommended). 

• Set the number of pages viewable with 
QuickView. 

Use a Service from 
within Mellel

• Choose Mellel (menu) > Services > [any service].

Open and save defaults
Mellel offers you several useful options to set the defaults for documents. This 
section will detail those options that are relevant to opening and saving files.

Start-up options
The Start-up & switch options (in the Preferences, under the Open & Save tab) allow 
you to determine what will happen when you launch Mellel or switch to it from 
another application. 
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Figure 17: Start-up options

• Do nothing: tells Mellel not not open a new untitled document when you 
launch it or switch to it from another application. 

• Open a new document: tells Mellel to open a new untitled document when 
you launch it or when you switch to it from another application (this is the 
default, Apple-recommended, behaviour for applications). 

• Open template browser: tells Mellel to open the template browser at launch 
time. Afterwards, the behaviour with this option selected will be identical to 
choosing the option Do nothing. 

• Default template: When this option is checked, Mellel will allow you to select 
a default template to be used when you open a new document. This selected 
template will open regardless of your choice regarding the opening 
behaviour of Mellel. 

Opening older documents
Mellel allows you to control (in the Preferences, under the Open & Save tab) the way 
existing document will be formatted when re-opened. 

Figure 18: Keep or update existing styles

• Preserve document styles: When this option is selected, Mellel will keep your
documents looking exactly as they were saved, and will ignore updates to the 
styles.
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• Change document styles: When this option is selected, Mellel will format an 
opened document to conform with changes you’ve made to the styles. 

The option Preserve document styles will best suit situation where you do not wish 
changes made to one document propagated to all other documents using those 
styles. The option Change document styles is meant to be used in situations where 
you want all your documents to conform to changes you’ve made to the styles. 

Compressed file format
Mellel uses a file format based on XML, short for Extensible Markup Language. 
With this file format, Mellel files are saved as a special folder (a ‘package’ in the OS 
X parlance) that contain the document and the images. For most intents and 
purposes, you may treat a Mellel document package as if it was a simple file. You 
can, however, determine if you want Mellel to save the document compressed as 
a zip file or not (you can see Here how to do that). 
Saving your files compressed can help reduce the size of some files, but the main 
advantage of saving files this way is that it will enable you to send Mellel 
documents via email, upload them to online storage services (such as iDisk) or 
retrieve documents from disks without the problems that are involved with 
package documents. 

Important: We recommend that you save your files compressed. This will not limit your abili-
ty to retrieve the content of the file, if you so wish to do, in the future, while enabling you to 
enjoy the advantages of a zipped file right now.

Saving to iCloud
If you’ve purchased Mellel on the Mac App store you can save files, retrieve files, 
move files into, and move files from the iCloud—a remote hard disk you can 
access from your Mac. Saving, opening and moving files to and from iCloud is 
done simply, similar to saving, moving and opening files. 

Using QuickView
Mac OS X’s QuickView allows you to view the content of Mellel documents in the 
Finder without having to open them. Mellel supports accurate display of the 
content (e.g., tables, notes, columns, images, pagination), just as you would have 
them seen in a PDF. 
Mellel also allows you to set the number of pages that will be displayed with 
QuickView (in the Preferences).
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Using Services
Services in Mac OS X, according to Apple’s help on Using Services, allow you to 
“quickly use content in one application with another application. The content may
include text, graphics, pictures, or movies.” Often, you will be required to log out 
and then log in again to use a service you’ve installed, but many services come 
with Mac OS X, and can be used immediately. 

Using Mail services—An example
The following short “round-trip” from Mellel to Mail and back can serve as an 
example to the way Services can be used:

1 Select text in a Mellel document.
2 Choose Mellel (menu) > Services > Mail > Send Selection. 
3 Mail will open and include the text you have typed in the body of a new message. 

Mail the message to yourself.
4 After the message is sent, go to the Sent folder in Mail, open the message you’ve 

sent and select the text in it.
5 Choose Mail > Services > Open with Mellel. Voilà! You are back in Mellel with the text 

intact.

Automatic Save and Backup
Mellel allows you to save and backup your documents. The Automatic Save option 
is turned off by default, but can activate it easily. The Automatic backup option, on 
the other hand, is turned on by default, but you can de-activate it whenever you 
want.

Automatic save
The Automatic save option (auto-save) in Mellel’s preferences allows you to save 
any open document periodically. This option is turned off by default. If you’re 
using Mac OS 10.7 or later you can save files automatically as ‘versions’. Otherwise,
you can set Mellel to auto-save documents periodically.

Automatic backup
The Automatic backup option in Mellel will save a copy of any active document 
periodically into a special folder. This option is turned on by default, so you do not
need to activate it. The backup files are saved into ~/library/application support/
Mellel/Backup/ using the document name and a tilde (~). 
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Note: Mellel backs up any open document, including unsaved documents, overwriting old-
er copies of the document with the same name. 

Basic text editing
In this section you’ll learn how to perform some basic text editing tasks: Cut, copy 
and paste, dragging and dropping and undoing and re-doing.

Stuff you can do
To... Do this Keyboard Shortcut

Cut content from a 
document

1 Select the content you want to cut from the 
document.

2 Choose Edit > Cut. The content will be removed 
from the document and placed in the clipboard. 

Note: To perform a ‘smart’ cut—removing redundant 
spaces before and after the content you cut—select the 
content in step 1 by double or triple clicking it. 

Cmd+X

Clear content 1 Select the content you want to remove from the 
document.

2 Choose Edit > Clear. The content will be removed 
from the document.

Copy content from a 
document

1 Select the content you want to copy.
2 Choose Edit > Copy. The content will be copied to 

the clipboard

Cmd+C

Copy content as plain 
text

1 Select the content you want to copy.
2 Choose Edit > Copy Special > Plain Text. The content 

will be copied to the clipboard as plain text. 

Cmd+Option+Shift+C

Copy character 
attributes

1 Select content including the character attributes 
you want to copy.

2 Choose Edit > Copy Special > Character attributes. The 
character attributes will be copied into the 
clipboard.

Cmd+Shift+C

Copy paragraph 
attributes

1 Place the insertion point in a paragraph whose 
attributes you want to copy.

2 Choose Edit > Copy Special > Paragraph attributes. The
paragraph attributes will be copied into the 
clipboard. 

Copy list attributes 1 Place the insertion point in a paragraph whose 
attributes you want to copy.

2 Choose Edit > Copy Special > List attributes. The list 
attributes will be copied into the clipboard. 
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Paste the content of 
the clipboard into the 
document

1 Place the insertion point where you want the 
content of the clipboard to be pasted, or select text
you wish to apply copied paragraph or character 
attributes. 

2 Choose Edit > Paste.

Cmd+V

Paste the content of 
the clipboard into the 
document as plain text

1 Place the insertion point where you want the 
content of the clipboard to be pasted.

2 Choose Edit > Paste Special > Plain Text. The text will 
be pasted as plain text and will be formatted based
on the formatting at the insertion point.

Cmd+Option+Shift+V

Paste character 
attributes

1 Copy some text and then select the text you want 
to apply character attributes to. 

2 Choose Edit > Paste Special > Character Attributes.

Cmd+Shift+C, Cmd+V

Paste paragraph 
attributes

1 Copy some text and then select the text you want 
to apply paragraph attributes to. 

2 Choose Edit > Paste Special > Paragraph Attributes.

Paste list attributes 1 Copy some text in a list and then select the text 
you want to apply paragraph attributes to. 

2 Choose Edit > Paste Special > Paste List Attributes.

Undo an action • Choose Edit > Undo. Cmd+Z

Re-do an action • Choose Edit > Redo. Cmd+Shift+Z

Drag text from one 
place to another

1 Select the text you want to drag, and do one of the
following:
• Quickly drag the text. While being dragged, the 

dragged text will become semitransparent. 
• Press the mouse button inside the selected text 

until the selection changes its colour slightly. 
While being dragged, the dragged text will 
become semitransparent. 

2 Drag the text to the destination location. An I-
beam cursor will appear where the text is to be 
placed.

3 Release the mouse button. The text will be cut 
from its original location and pasted at the 
destination location.
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Drag and copy text 1 Select the text you want to drag, and perform one 
of the following:
• Quickly drag the text. While being dragged, the 

dragged text will become semitransparent. 
• Press the mouse button inside the selected text 

until the selection changes its colour slightly. 
While being dragged, the dragged text will 
become semitransparent. 

2 Drag the text to the destination location. An I-
beam cursor will appear where the text is to be 
placed.

3 Hold down the Option key and release the mouse 
button. The text will be copied.

Drag text to the 
Desktop or to another 
application

1 Select the text you want to drag and do one of the 
following:
• Quickly drag the text. While being dragged, the 

dragged text will become semitransparent. 
• Press the mouse button inside the selected text 

until the selection changes its colour slightly. 
While being dragged, the dragged text will 
become semitransparent. 

2 Drag the text outside the document window to the
Desktop or to another application and release the 
mouse button.

Note: When you drag text to the Desktop or to the Trash, it 
is always copied (that is, it is not cut from the document), 
and a clipping is created on the Desktop or in the Trash.

Drag a clipping from 
the Desktop or 
another application:

1 From the Desktop or another application, drag the 
text into Mellel’s window.

2 Drag the text to the destination location. An I-
beam cursor will appear where the text is to be 
placed.

3 Release the mouse button. Text dragged to or from
the Desktop is always dragged as a copy.

Note: Drag and drop works in a similar manner for both 
text and graphics. For example, you may drag a graphic 
element from the Desktop into a Mellel document.

Drag text to or from a 
header or footer

1 Select the text you want to drag and do one of the 
following:
• Quickly drag the text. While dragged, the text 

will become semitransparent. 
• Press the mouse button inside the selected text 

until the selection changes its colour slightly. 
While being dragged, the dragged text will 
become semitransparent. 

2 Drag the text to or from the header or footer. Text 
dragged to or from headers and footers is always 
dragged as a copy.
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Drag text to or from a 
footnote or an 
endnote

1 Select the text you want to drag and do one of the 
following:
• Quickly drag the text. While being dragged, the 

dragged text will become semitransparent. 
• Press the mouse button inside the selected text 

until the selection changes its colour slightly. 
While being dragged, the dragged text will 
become semitransparent.

2 Drag the text to or from the note. Text dragged to 
or from notes is always dragged as a copy.

Note: When you drag text that contains a reference to a 
note into a note, it will be kept intact, but the note 
reference will not be visible. However, if you drag the text 
that contains the invisible note back into the text, the note 
reference will reappear, and a new note, identical to the 
dragged note, will be added to the note stream.

Cut, copy and paste
Copying, pasting, and cutting and clearing are some of the most basic editing 
options available in a word processor (and not just word processors). Mellel offers,
in addition to the standard copy and paste options, an option to copy just the 
character or paragraph attributes, list attributes, or to copy the text without any 
attributes (plain text). 

Undo and redo
Undo and Redo are useful operations, through which you can undo editing of text
or a change you’ve made to the text. There is an unlimited number of undo and 
re-do actions, but the undo ‘memory bank’ is reset when you save your 
document.

Drag and drop
Dragging and dropping text in Mellel (and in Mac OS X in general) is a useful way 
to move, remove, or copy content inside, from, or to a document. Drag and drop 
is similar to cut, copy, and paste operations (depending on the type of drag and 
drop you perform), the difference being that the dragged content is not placed 
into the clipboard. 

Selection
Almost every action in Mellel involves two parts: selecting the element you want 
to change, and applying the change by choosing the appropriate action. You can 
make a selection in Mellel using one of two methods:
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• Using the mouse.

• Using the keyboard.

Selecting with the mouse
Making a selection using the mouse is very simple and straightforward: All you 
need to know is how to click the mouse button and where the Shift key is located. 
The following table details the types of selections you can make using the mouse.

Table 1: Selecting with the mouse
To... Do this

Select a graphic element Click the element

Edit a graphic attributes Double-click the graphic

Select a word Double-click the word

Select a paragraph Triple-click in the paragraph

Select a section of the text Click where you want the selection to start, hold down the mouse button. 
and drag to the desired end of the selection

Select a wide range of the text Click where you want the selection to start, scroll to where you want the 
selection to end, hold down the Shift key, and click the mouse button

Selecting with the keyboard
Many people find that selection with the mouse, although convenient, is 
sometimes slow compared to selection using keyboard strokes. The following list 
details the types of selections you can make using the keyboard.

Table 2: Keyboard selection
Key Selection extended

Shift+Right Arrow One character to the right

Shift+Left Arrow One character to the left

Shift+Up Arrow To the line above, to the nearest character boundary at the same 
horizontal location

Shift+Down Arrow To the line below, to the nearest character boundary at the same 
horizontal location

Shift+Option+Right Arrow To the end of the current word, then to the end of the next word

Shift+Option+Left Arrow To the beginning of the current word, then to the beginning of the 
previous word

Shift+Option+Up Arrow To the beginning of the current paragraph, then to the beginning of the 
paragraph before it
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Shift+Option+Down Arrow To the end of the current paragraph, then to the end of the next paragraph
(including the blank line between paragraphs in Cut, Copy, and Paste 
operations)

Shift+Cmd+Right Arrow To the end of the current line

Shift+Cmd+Left Arrow To the beginning of the current line

Shift+Cmd+Up Arrow Upward to the beginning of the document

Shift+Cmd+Down Arrow Downward to the end of the document

Table 3: Keyboard delete
Key Delete

Backspace One character to the left

Delete One character to the right

Option+Backspace One word to the left

Option+Delete One word to the right

The Document window
The document window in Mellel allows you to edit the document and offers tools 
through which you can change the way the document is displayed and monitor 
the document status.
The next few pages contain a review of the options available to you through the 
document window. A more detailed review of certain features, such as the Outline 
or editing styles, appears in the relevant chapters dealing with those features. 
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Figure 19: The work area in Mellel

Stuff you can do
To... Do this Keyboard Shortcut

Change the size of the 
document window

• Grab the size control at the bottom-right corner of 
the document window and drag the control until 
the window is the size you want it. 

Change the page size 
of the document

1 Choose File > Page Setup….
2 Choose a paper size from the Paper Size pop-up 

menu.
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Change the document 
orientation

1 Open the Page palette, and click Margins and 
Orientation...

2 Choose Portrait or Landscape from the Orientation 
pop-up menu.

Change the size of the 
printable area (set 
page margins)

1 Choose Window > Palettes > Page to open the Page 
palette, and click Margins and Orientation...

2 Enter the appropriate value for the top, left, right 
or bottom page margin. 

Set the defaults for the
printable area (page 
margins)

1 Choose Mellel (menu) > Preferences…. 
2 In the Document setup tab set the default Page 

Margins. 

Show or hide the page 
margins

• Select Page Margins from the Show pop-up menu.

Set the defaults for the
display of page 
margins

1 Choose Mellel (menu) > Preferences….
2 Check or uncheck the option in the Document setup

tab
3 [Optional] Check or uncheck the Facing pages 

option. When this option is checked, the left and 
right margins will change to Inside and Outside 
(mirrored pages)

Change the document 
view from Compact 
view to Mellel view

• Choose View > Mellel view or Compact view. 

Set the document 
background

1 Choose Mellel (menu) > Preferences...
2 Under the General tab choose a background from 

the Document Background pop-up menu, or choose 
Custom to set your own colour via the Colour well. 

Cmd+,

Enter Full screen mode • Choose View > Full Screen. Cmd+Ctrl+F

Exit Full Screen mode • Press the Esc key or press Cmd+Option+S again. Cmd+Ctrl+F, Esc

Set the background for
Full Screen mode

1 Choose Mellel (menu) > Preferences...
2 Under the General tab choose a background from 

the Fullscreen Background pop-up menu, or choose 
Custom to set your own colour via the Colour well. 

Cmd+,

Access menu options 
in Full Screen mode

1 Move the cursor to the top of the screen. The 
menus will appear and allow you to choose from.

Zoom in and out when
working in full screen 
mode without using 
the menus

• Press Cmd++ or Cmd+- to zoom in and out. Cmd++, Cmd+-
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Work with a reversed 
colour scheme in Full 
Screen mode (or 
generally)

1 Do one of the following:
• Choose File > Document Setup… and change the 

background colour to a darker colour, then 
change the colour of the text you’re entering to a
lighter colour. 

• Choose File > Open Template… and then choose 
one of the default templates with a reversed 
colour scheme.

Work with a 
completely reversed 
colour scheme

• Open the Universal Access panel in System 
Preferences, then open the Seeing panel and click 
the White on Black radio button. You can easily 
activate and deactivate this option with the 
keyboard shortcut Cmd+Option+Ctrl+8.

Note: you can also experiment with the system zoom 
option in the Seeing panel. Pressing Cmd+Option+8 will 
activate or deactivate it. Pressing Cmd+Option+= or 
Cmd+Option+- will zoom in and out of the text.

Set the preferences for 
document view

• Choose Mellel (menu) > Preferences... and under the 
Appearance tab set the preferable view mode. 

To maximise the 
viewable area of the 
document without 
entering Full screen 
mode

• From the View menu choose Show Toolbar, Show 
Ruler, or Show Bottom Bar.

Show or hide special 
characters

• Press the Show button pop-down menu and select 
one of the items in it to check (show) or uncheck 
(hide) it. Or, 

• Select All Invisible Characters to toggle the display of 
all the hidden characters at once.

Show or hide 
document elements

• Press the Show button pop-down menu and select 
one of the items at the bottom of the pop-up 
menu to check (show) or uncheck (hide) it.

Change the 
magnification (zoom) 
level

• Press the Zoom pop-up menu and select a zoom 
level.

Cmd++, Cmd+-

Fit width (zoom level) • Press the Zoom pop-up menu and select Fit Width. Cmd+Option+W

Fit Page (zoom level) • Press the Zoom pop-up menu and select Fit Page. Cmd+Option+G

View document in One
up view

• Press the Zoom pop-up menu and select One up.
Note: this only applies to situations where you want to 
change back from a Two up, Four up or Spread view. One 
up is the default view. 

View document in Two 
up view

• Press the Zoom pop-up menu and select Two up.
Note: Choosing this view will not affect any other zoom 
choice, except other ‘up’ views. 
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View document in Four
up view

• Press the Zoom pop-up menu and select Four up.
Note: Choosing this view will not affect any other zoom 
choice, except other ‘up’ views. 

View document in 
Spread view

• Press the Zoom pop-up menu and select Spread.
Note: Choosing this view will not affect any other zoom 
choice, except other ‘up’ views. 

The document area
The document area is where you can enter and edit text. enter and edit the 
content of the document. When you first create a document in Mellel, it appears 
as a blank white square. Into this page you can enter text, tables, images and so 
on and, once you reach the end of one page, Mellel will automatically add 
another page at the end of the document. 
The pages in Mellel appear as either blank white pages over a background or 
without a background. Within the white area every page is divided into a 
printable area and a non-printable area. Text, images, and any other element in 
the document can only appear within the printable area of the page. 

Print 
margin

Non printable 
area

Grey 
background

Printable 
area

Figure 20: Printable and non-printable area

The toolbar
Mellel’s toolbar allows you to control many of the display option, enter items into 
the document and manipulate the document text. Mellel’s toolbar is 
customisable. That is, it allows you to add, change and remove its content as you 
wish. 
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To customise the toolbar:
• Right click (mouse) or Ctrl+Click over the toolbar and choose any of the options in

the pop-up menu to change the size or appearance of the items on the toolbar or 
choose Customise toolbar... to customise the toolbar. 

Display
Through various options in the document window, the View menu, the Window 
menu and the Preferences you can control and change the way the document is 
displayed.

Document views
Mellel allows you to set the document view to one of two: Mellel view and 
Compact view.

• Mellel view: is the default view. It displays the printable and non printable 
area over a background (which you can set and change). The main advantage 
of the Mellel view is that it allows you to view the document as it will be 
printed. 

• Compact view: hides the non-printable area. The Compact view allows you to 
fit the same amount of text in a much narrower window.

Note: with Mellel view you can set the background pattern or colour via the Preferences. 

Full Screen
Mellel’s Full Screen mode allows you to work with Mellel with the document 
window stretched to cover the entire screen, automatically hiding the Dock and 
the menus. You can set the Full Screen mode to be ‘clean’ by hiding the palettes, 
the Ruler, the toolbar (which is always hidden with versions of Mac OS X prior to 
10.7) and switching to Compact view—but you can also use it as a normal work 
mode, with the palettes, toolbar and bottom bar displayed. Another option with 
Mellel’s Full Screen mode allows you to set the full screen background. 

Show menu
The show button pop-down menu, in the toolbar, allows you to show or hide 
hidden characters and various document window elements. All the changes 
made apply only to the front-most document and will not affect other opened 
documents.
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Figure 21: The Show pop-down menu

Zoom in and out
The Zoom pop-up menu allows you to set the document page magnification to 
one of several levels between 10 percent and 1600 percent, and also choose some
option for automatic fitting of the display.

• Zoom levels: from 10 percent to 1600 percent, allowing you to change the 
zoom level to the selected zoom level. 

• Fit width: sets and changes the zoom level so that the width of the 
document’s page will fit within the document window. 
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Note: With the Outline pane open, Mellel will automatically change the zoom level to ac-
commodate the change in the width allocated to the document text. 

• Fit page: sets and changes the zoom level so that the entire page is displayed 
in the document window.

• Other: allows you to set the zoom level (in per cent) manually. 

Note: Changing the zoom level only changes item appearance on screen, not their size.

Up views and Spread
The Zoom pop-up menu allows you to access multiple page views. You can set 
Mellel to view pages in Two up, Four up and Spread views (and, of course, return to 
One up, which is the regular view).
The following table will exemplify some typical cases:

Spread with Fit Width Two up with Fit Width Four up with fit width Spread special cases

The image on the right, Spread special cases, deserves a note. When you view a 
document in Spread view, Mellel orders the pages in facing pages. As page 1 does 
not have a facing page, it stands alone, while the rest of the document is ordered 
by facing pages. However, if you change the numbering of a page range, or the 
Range Start settings for a page, Mellel may display it also standing alone, as it does 
not have a facing page. 

Status
Mellel offers several options to monitor the document status, including the page 
you are in, page numbering unit, the current page, paragraph and character styles
used, their status, and more. 
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Document and page status
At the bottom of the document window, you will find the page and document 
status line.

Figure 22: The page and document status line

This status line displays the following details (from left to right):

• Current page style (in this case, “Default”) in the page you are currently 
viewing.

• Current page style status: nothing if the style has not changed, a plus (+) 
sign if it contains unsaved changes. 

• Current page number in the unit format selected for the current page style. 
In this example, the page number is in Arabic numerals format, but the format
can be one of many other number formats Mellel offers.

• (In parenthesis) The current page number (in absolute terms) and the Total 
number of pages in the document. 

Paragraph and character style status
At the centre of the tool bar at the top of the document window, you can find the 
paragraph and character style status area.

Figure 23: Paragraph and character style status area

The paragraph and character style status area contains the following information:

• The style currently used (paragraph or character style).

• The style status: nothing if the style has not changed, a plus (+) sign if it 
contains unsaved changes (paragraph or character style).

• The style variation (character style). 

Tip: Clicking the style’s status line will open its Edit Style dialogue box.

Navigation
Mellel offers several tools for navigating the document. The simplest tools appear 
at the bottom right of the document window. Those tools allow you to move a 
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page up or down, to the end or the beginning of a document, or to any page in 
the document you want to move to. For more details see the Navigation section 
Below

Tab well
The tab well (at the top-left corner of the document window) allows you to drag 
tabs into the Ruler.

Figure 24: The tab well

For more information about tabs, creating tabs, and manipulating tabs, see the 
guide section Ruler and Tabs.

Align and direction buttons
The align and direction buttons allow you to set and change the paragraph 
alignment (left, centre, right, and justify) and also to set and change the 
paragraph direction.

Figure 25: Align and direction buttons

For more information about alignment and direction, see the guide section about
Paragraph Attributes.

Ruler
With the Ruler, you can change the paragraph start margin, end margin, indent, 
add tabs, and edit tabs. The Ruler always displays the currently used measurement
unit.

Figure 26: The Ruler

For more information about the Ruler, see the guide section about Ruler and Tabs, 
and Paragraph Attributes. 
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Palettes
Palettes are small windows with buttons and text fields, that allow you to manage
your work, format, edit and style text with ease. Mellel also offer you several 
options for organising and changing the display of palettes. 

How palettes work
Mellel offers you the option to open palettes, close them, group them, arrange 
palettes within a group, and so on. All the palettes in Mellel are the same height 
and width so they offer both flexibility and expectability: you can combine all or 
any of them together any way you like, but when you click one, the options are 
always displayed where you expect them to be, regardless of the palette position 
within a palette group. 

Stuff you can do
To... Do this Keyboard Shortcut

Open a palette or a 
palette group

• Choose Window > Palettes > <the palette name>.
Mellel will open the palette or the palette group 
the palette is in. If the palette is already open, 
Mellel will select it.

Close a palette or a 
palette group

• Do one of the following:
• Click the Close button at the top-left edge of the 

palette or the palette group. Or,
• Click the Palette management button at the right 

edge of the Palette group and choose the 
palette from the Remove Palette sub-section. 

Note: When you close a palette, every other palette in this 
group will also close. To close an individual palette, first 
detach it from its group.

Close all the palettes • Do one of the following:
• Click the Close button at the top-left edge the 

top palette group.
• Choose Window > Palettes > Toggle Palettes. Or,
• Press the Show/Hide Palettes button in the 

document window.

Show or hide all 
available palettes

• Do one of the following:
• Choose Window > Palettes > Toggle Palettes. Or,
• Press the Show/Hide Palettes button in the toolbar.

Cmd+*

Reset palettes • Choose Window > Palettes > Reset Palette. 
Mellel will reset the palette to their default 
positioning and display. 

Bring a palette to the 
front

• Click on the palette tab in the palette group.
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Change the position of
a palette within a 
group. 

• Click and drag a palette’s tab to a new position 
within the group.

Add a palette to a 
palette group

• Do one of the following:
• Click and drag the palette’s tab into the tab ‘rail’ 

at the right of the desired palette group. 
•  Click the Palette management button at the right 

edge of the Palette group and choose the 
palette from the Add Palette sub-section. 

Move a palette from 
one group to another

• Do one of the following:
• Click and drag the palette’s tab into the tab ‘rail’ 

at the right of the desired palette group. 
•  Click the Palette management button at the right 

edge of the Palette group and choose the 
palette from the Add Palette sub-section. 

Move a palette outside
a palette group

• Click and drag the palette tab outside the tab ‘rail’ 
at the right of the palette group. 

Attach a palette or a 
palette group to 
another palette or a 
palette group

• Click and drag the palette or the palette group 
until it is ‘magnetised’ to the bottom of another 
palette or palette group.

Control the display of 
the palette’s tabs

•  Click the Palette management button at the right 
edge of the Palette group and choose one of the 
options:
• Icon and text: to display both icons and palette 

names.
• Icon only: to display only the icon. 
• Text only: to display only the text. 
• Use small size: to display the palette tabs with 

small icons.

Navigation
Mellel allows you to navigate through a document in four different ways: using 
the keyboard, using the navigation bar at the bottom of the document window, 
using the scroll bar or using the Outline pane.
When Navigating, note that Mellel allows you to change the view (that portion of 
the document you see) without moving the insertion point, or change the view 
and move the insertion point.
One navigation option is set in the preferences. Under the Appearance tab you can
set how pages will be scrolled up and down when pressing the Page Up or Page 
Down keys (or buttons). 
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• Top of page: When pressing the Page Up or Page Down keys, Mellel will scroll 
to the top of the previous or next page. 

• Screen length: When pressing the Page Up or Page Down keys, Mellel will scroll
one screen length up or down. This is the default with most word processors. 

Stuff you can do
To... Do this Keyboard Shortcut

Scroll through a 
document in small 
increments

• Click the up, down, left, or right scroll arrow as 
appropriate. 

Scroll through a 
document one 
window length at a 
time

• Click in the scroll area above, below, to the right, or
to the left of the scroller as appropriate. 

Quickly browse a 
document

• Click and press the mouse button over a scroller 
and drag it upwards, downwards, to the right, or to
the left as appropriate.

Navigate using the 
navigation buttons

• Press any of the four buttons to go to the 
beginning, one page up, one page down, or to the 
end of the document. Every click on the Page Up or
Page Down button will move you to the top of the 
previous or next page, respectively.

Go to a specific page in
the document

1 Press the Go to Page button.
2 In the Go to Page dialogue box, enter the page 

number you wish to go to. 
3 Press the Go button.
Note: When going to a specific page using the Go to Page 
option, the insertion point will move to the designated 
page too. 

Change the 
preferences for page 
up or page down 
navigation

1 Choose Mellel (menu) > Preferences....
2 Under the Appearance tab, choose one of the 

options from the Page Up/Down keys.

Navigating with the scroll bar
The scroll bar in Mellel can be used to scroll a document backwards or forwards in
small increments or, alternately, to browse a document quickly.
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Scroller

Scroll area

Scroll arrows

Figure 27: Navigating with the scroll bar

Navigating with the Navigation buttons
The small navigation panel at the bottom of the document window allows you to 
quickly navigate within a document, one page (or one window length) at a time 
upwards or downwards, to jump to the top or to the bottom of the document, 
and to move to any desired page in the document.

Figure 28: The navigation buttons

Navigating with the keyboard
Mellel’s keyboard navigation options allow you to navigate through the text using
simple keyboard shortcuts and combinations. These options work according to 
Apple’s guidelines.

Table 4: Basic Navigation
Key Navigate

Page Up Scrolls to the top of the previous page or one screen length up (depending
on your choice in Preferences/Appearance)

Option+Page Up Scrolls to the top of the previous page or one screen length up (depending
on your choice in Preferences/Appearance)

Page Down Scrolls to the top of the next page or one screen length down (depending 
on your choice in Preferences/Appearance)

Option + Page Down Scrolls to the top of the next page or one screen length down (depending 
on your choice in Preferences/Appearance)

Home Scrolls to the top of the document

End Scrolls to the end of the document
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Option+Delete Deletes to the end of the word

Option+Backward Delete Deletes to the beginning of the word

Right Arrow One character to the right

Left Arrow One character to the left

Up Arrow To the line above, to the nearest character boundary at the same 
horizontal location

Down Arrow To the line below, to the nearest character boundary at the same 
horizontal location

Option+Right Arrow To the end of the current word, then to the end of the next word

Option+Left Arrow To the beginning of the current word, then to the beginning of the 
previous word

Option+Up Arrow To the beginning of the current paragraph, then to the beginning of the 
preceding paragraph

Option+Down Arrow To the end of the current paragraph, then to the end of the next paragraph

Cmd+Right Arrow To the end of the current line

Cmd+Left Arrow To the beginning of the current line

Cmd+Up Arrow Upward to the beginning of the document

Cmd+Down Arrow Downward to the end of the document

Measurement units
Measurement units are used to measure the size of items and elements. Their 
main use in Mellel is to set the page margins and various paragraph style 
properties.
Mellel allows you to use three different measurement units: Points, Centimetres, 
and Inches. A point is the smallest unit, measuring 1/72 of an inch (about 0.03528 
cm). A centimetre measures about 28.3465 points (about 0.3937 of an inch). An 
inch measures 2.54 centimetres (72 points).

Stuff you can do
To... Do this Keyboard Shortcut
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change the 
preferences for 
measurement units

1 Choose Mellel > Preferences…
2 In the Appearance tab, select the desired 

measurement unit from the Measurement Units 
pop-up menu.

Note: When you change the measurement unit in the 
preferences, the change is reflected immediately in all the 
places where measurement units are used. This may cause 
a round number (for example, 1 cm) to become 
unrounded under a different measurement unit.

change the 
measurement unit on 
the fly

1 Click in a text field where such units are used. 
2 Enter the value you want and then enter “cm” (for 

centimetres), “in” (for inches), or “pt” (for points) 
and press the Tab or Return keys to confirm your 
change. Mellel will calculate the value you have 
entered using the measurement unit you have 
selected, and display it using the measurement 
unit selected in the preferences.

Special characters
Mellel allows you to enter special characters, such as unique types of hyphens, 
break characters, and so on. There are two ways by which you can enter special 
characters:

• Via the Special Characters palette: This palette is provided by OS X and 
accessible via the Edit menu or the Input (flags) system menu. The Character 
palette allows you to access the full Unicode range.

• Via the Insert menu: The options here will be discussed below. 

Stuff you can do
To... Do this Keyboard Shortcut

Insert a character from 
the Insert menu

• Choose file > Insert > Special character (or any other 
category under the Insert menu).

Insert a character via 
the Character palette

1 Choose Edit > Character palette....
2 Locate a character and double-click it to enter it 

into the document.

Cmd+Option+t

The Insert menu
There are several sections in the Insert menu that allow you to enter special 
characters:

• Page Variables: allows you to enter the current Page Number and Total Number
of Pages. You can enter those into headers and footers. 
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• Document Variables: allows you to enter variables. For more information 
about variables, see here.

• Breaks: allows you to enter break characters such as a Return, Page break, Tab, 
and so on. 

• Special Characters: allows you to enter special characters that are not 
commonly used or hard to reach via the keyboard. The characters are divided 
into categories (such as Currency, Mathematical, Quotation, Accents, etc.) 

All the characters inserted using the Insert menu contain only one symbol 
(glyph), even if they seem to contain several characters. For example, if you insert 
the Author variable (Insert > Document Variables > Author), it will behave (in editing, 
copying, styling, etc.) as a single glyph.
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Character Attributes
This chapter explains what characters are, what are the tools to 
control and apply character attributes, and how to use them

Should I read this chapter?
You should read this chapter if you want to learn how to style and format 
text in your document, and to learn how to use character styles

What are character attributes
The most basic unit in Mellel is the character. Every Mellel document is composed 
of a long string of characters—that is, single letters, numbers, spaces, question 
marks, etc.—to which you can apply attributes like font, size, colour, and so on.
Mellel allows you to control the appearance of character via several palettes and 
menus, and also allows you to create, save and change character styles.

Stuff you can do
To... Do this Keyboard Shortcut

Set the Font • Open the Character palette and choose a Font from 
the Font pop-up menu.

Set the font size • Open the Character palette and choose a Font size 
from the Size pop-up menu.

Set the font face • Open the Character palette and choose a font face 
size from the Face pop-up menu.

Cmd+i for Italic, 
Cmd+b for Bold

Underline text • Open the Character palette and from the Line pop-
up menu choose Underline.

Cmd+u

Set the text colour • Open the Character palette, and click the Colour 
picker widget for Fill & Highlight.

Set text as superscript 
or subscript

• Open the Character palette and select the 
appropriate option from the Position pop-up menu.

Change the case to All 
Caps or Small caps

• Open the Character palette and select the 
appropriate option from the Case pop-up menu.

Set background colour
for text

1 Open the Character palette, and click the 
background in the Character widget.

2 Select Solid from the Fill & Highlight menu and then 
set the colour.



Set an outline (stroke) 
for text

1 Open the Character palette, and click the character 
in the Character widget.

2 Select a stroke type from the Stroke pop-up menu, 
and proceed to set the weight and colour.

Set overline, 
Strikethrough, Double 
Strikethrough and 
Overline and 
Underline

• Open the Character palette and from the Line pop-
up menu choose the appropriate option.

Shift text from its 
baseline

• Open the Character palette and change the value 
for Baseline shift.

Turn Ligatures on and 
off

• Open the Character palette and check or un-check 
the Ligatures check-box.

Use OpenType features • Open the Character palette and select one of the 
features in the OpenType pop-up menu. You can 
also choose a language where those features are 
applied. 

Write bilingual text 1 In the Character palette set the font, size, etc. for 
the main language in the text.

2 In the Secondary Font palette choose the script 
system from the Script pop-up menu, and then set 
the font, size, etc. for the secondary language in 
the text. 

Apply Kashida • Open the Character palette and under the More tab 
check or un-check the Kashida check-box.

Change text direction • Open the Character palette and under the More tab 
select an option from the Direction pop-up menu 
(for experts only!).

Character palette
Mellel offers one palette to style and format characters. The Attributes tab of the 
palette allows you to control formatting, while the Styles tab allows you to 
handle the styles.

Character Attributes
The Character palette includes options to control the way your text will look in the 
document.
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Size

Figure 29: The Character palette

Font options
• Font: allows you to set the main font (e.g. Helvetica, Times, or Courier).

• Face: allows you to set the font face (e.g. Italic, bold, bold-italic, etc.). The font 
face options depend on your font. Some fonts have many faces, but other 
fonts may have but a single, regular face. 

• Size: allows you to set the font size, either choosing from the list of suggested 
sizes, or setting the size on your own by choosing Other...

The Character widget
The Character widget allows you to manipulate various character attributes and 
view an approximation of the results of the manipulation. 
When you select a part of the (e.g. the line the A, the background or the character 
itself ) the relevant pop-up menus and colour buttons will become enabled.

Fill & Highlight
The Fill & Highlight pop-up menu, and the adjacent Colour button allow you to 
control the fill or background colour of the selected characters in the text. The 
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Colour button will be enabled only if you choose Solid from the Fill & Highlight pop-
up menu. 
The Fill & Highlight pop-up menu is context sensitive. That is, it will affect the part 
of the character selected in the Character widget. If the background is selected, 
your selections will change the background. If the character is selected, it will 
affect the character fill. 

Stroke
The Stroke pop-up menu, and the adjacent Weight and Colour buttons allow you to 
set the outline, underline, overline, and strikethrough options. 
The Stroke pop-up is context sensitive. That is, it will only affect the selected part 
in the Character widget. If the character is selected, changes will affect the 
character outline, and when the underline is selected, changes will affect the 
underline, overline, or strikethrough options.

• The Stroke pop-up menu allows you to select the type of stroke you want to 
use (None, Regular, or various dotted lines). 

• The Weight pop-up menu allows you to set the weight of the stroke or line in 
absolute measurements (e.g., 1 point) or relative ones (e.g. 125 percent). The 
Other... option allows you to set an arbitrary value in either absolute (points) or
relative (percent) weight.

• The Colour button allows you to select a colour for the stroke. Use the Swatch 
drawer at the bottom of the Colours palette to store frequently used colours.

Line
The Line pop-up menu allows you to set various line options. If an option other 
than None is selected, a line will appear below the character in the Character 
widget. Selecting this line will enable you to choose options from the Stroke pop-
up menus to change the type, weight, and colour of the line. 
The table below illustrates the various types of lines you can create via the Line 
pop-up menu (all options are shown with a blue dotted line).

Table 5: Line options
Underline Overline Strikethrough Double

Underline
Double

Strikethrough
Overline and

Underline
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Background colour
To change the background colour of a character, click the background area in the 
Character widget, select Solid or None from the Fill & Highlight pop-up menu, and 
then select a colour via the Colour button. 

Outline
You can set the outline for any selected text. You can do that independently of the
fill or background colour. 
The table below shows some examples of the stroke options available to you. 

Table 6: Some Stroke and Fill options
Fill: Solid; Stroke: dotted; 
Weight: 2 pt; Stroke 
Colour: Yellow

Fill: None; Stroke: 
Regular; Weight: 100%; 
Stroke Colour: Blue

Fill: Turquoise; Stroke: 
Regular; Stroke colour: 
Black; Weight: 400%

Fill: Teal; Stroke: Small 
lines; Weight: 2 pt; Stroke 
Colour: Red

Baseline shift
The Baseline shift option allows you to shift characters (or images, figures, etc.) 
upwards or downwards from the baseline. 

Case
The Case pop-up menu allows you to set the case for characters. The default is 
None (no change). All Caps will change all the letters to uppercase letters. Small 
Caps will change lower case letters to ‘fake’ small caps letters. 

Position
The position pop-up menu allows you to set a character as subscript or 
superscript. The default is Normal (no change).
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OpenType
This pop-up menu gives you access to various OpenType options available in 
some fonts. These options will create a change only if the font you’re using is an 
OpenType font and if the text to which the changes apply include the relevant 
options. 
OpenType
This pop-up menu allows you to select the language to be used with certain 
language-dependent options in OpenType (only). For example, if a font contains 
special ligatures that should be displayed only when writing in German, then 
selecting “Deutsch” in the language pop-up menu will cause Mellel to display this 
special ligature.

Ligatures
When this check-box is checked, Mellel will recognise and display special 
ligatures, if such ligatures exist in the font you’re using. Common ligatures are, for 
example, combinations like fl, fi or ffl, etc. With the option turned off, the letters 
will be displayed separated. For example: fl, fi or ffl. Accented characters (such as 
ü, é, ç, etc.) are not considered ligatures. 

Tip: If you’re using Mellel to write text that use a monospaced font (e.g., Courier or Monaco),
you should turn Ligatures off to avoid the creation of undesired ligatures (such as fl, fi, ffl, 
etc.) with those fonts.

More tab
The More tab offers several options to control some additional character 
attributes.

Secondary font options
The Secondary Font options allow you to set a secondary font using a different 
language, set the face, the relative size of the font and the languages script. 

• Font: allows you to set the secondary font for the style.

• Face: allows you to set the font face (e.g. Italic, bold, bold-italic, etc.). The font 
face option is dependent on your font selection and the font faces it contains.

• Script: allows you to set the script for the secondary font. Your choice here 
determines which font will be selected when you switch between script 
systems. For example, if you set the script to Arabic (and set the appropriate 
font, of course), when you switch to an Arabic keyboard layout, Mellel will 
automatically select and use the font, face, and size set for the secondary font.
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• Size: allows you to set the font size in relation to the main font. You can drag 
the slider right or left to set the relative size of the font between 0 and 200 
percent of the main font. You can also use the text box to manually enter the 
desired size.

Direction
This option emulates the insertion of directional embedding around the style. The
default is Default and you should leave it so, unless you need to solve some 
specific neutral direction characters problems.

Kashida
The Kashida option is only useful when writing in languages that use the Arabic 
script. It is turned on by default, but will have no effect on non-Arabic text. With 
Arabic scripts, the option will activate a special justification method for such 
languages.

Tip: To learn more about multilingual features in Mellel, read the chapter Multilingual 
support.

Character Styles tab
The Character Styles tab palette, allows you to add, delete, apply, edit, and save 
changes to character styles. You can also use this tab to view the status of the 
styles in the document. 

Note: For a detailed discussion of the options related to styles see the sub-chapter Charac-
ter Styles. 
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Figure 30: The character style palette

• Add a style: adds a new character style.

• Delete a style: Deletes the currently selected character style. 

• Edit a style: opens the Edit Character style dialogue box and allows you to edit 
the style’s attributes.

• Apply a style: applies the selected style to the text selection in the document.

• Save a style: saves the changes to the first changed style within the selection 
in the document. 

• Variation: allows you to choose one of the variations of the currently selected
style.

• Language: The language pop-up menu allows you to view and set the 
language used for spelling for a selection in the text. 
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Character Styles
What is a character style?
A Character Style is a set of formatting attributes that determines how text in your
document will look. A character style is a type of shortcut: it allows you to apply 
several character attributes all at once. To make things more convenient, 
character styles can be added, edited, deleted and arranged according to your 
needs. 

Style variations
Every character style contains 8 sub-styles called Variations, which allow you to 
include several variations within the style. For example, you can use variations to 
create a bold, bold-italic, underlined, etc. variations to the style. 
Variations support inheritance. That is, changes you make to attributes of the base
variation will also be automatically applied in all the other variations, unless 
you’ve changed this attribute in a variation. 

For example, if you change the text colour for the base variation to red, the colour
for all the other variations will change to red, unless there is a variation where you
have changed the text colour to another colour before. 

Stuff you can do
To... Do this Keyboard Shortcut

Apply a character style 1 Select text.
2 Click the Apply Style button in the Character Style 

palette, or choose a style from the Styles > Character
style sub-menu.

Note: when you apply a character style, Mellel performs a 
smart match of attributes. For example, if with the text 
you’re applying the style to contains text in bold or italic 
face, Mellel will look for style variations with similar 
attributes and use them when applying the new style. If 
you do not want Mellel to do this, press Option which 
applying the character style and Mellel will do a ‘dumb’ 
application of the style. 

A keyboard shortcut if 
one is assigned to a 
style
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Apply a different 
character style

1 Select text.
2 Choose a style from the Styles > Character style sub-

menu or select a style in the Character Style palette 
and press the Apply button (you can also double-
click the style’s name).

Note: when you apply a character style, Mellel performs a 
smart match of attributes. For example, if with the text 
you’re applying the style to contains text in bold or italic 
face, Mellel will look for style variations with similar 
attributes and use them when applying the new style. If 
you do not want Mellel to do this, press Option while 
applying the character style and Mellel will do a ‘dumb’ 
application of the style. 

Check what style is 
currently used

• Open the Character palette, view the styles well in 
the toolbar, or the Styles > Character style sub-menu 
to see which style has a check mark next to it. If the
selection in the text contains multiple styles, a 
minus (-) sign will appear next to each of them.

Apply only the 
character style 
attributes (not the 
style itself )

1 Select some text with attributes you want to copy 
and choose Edit > Copy Special > Character attributes.

2 Select text with different character attributes and 
choose Edit > Paste.

Cmd+Shift+C

Create a new character
style

• Do one of the following:
• Click the Add button in the Character palette 

Styles tab. Or,
• Choose Styles > Character > Create New Character 

Style... (Thus duplicating the currently used 
character style). Or,

• Choose Style Set > Edit Style Sets... and in the 
character area of the dialogue box, click the 
Duplicate button (Thus duplicating the currently 
used character style). Or,

• Choose Style Set > Edit Style Sets... and in the 
character area click the Add button. Mellel will 
create a new character style with default 
attributes.

Edit a character style 
from within the 
document

1 Select some text and apply attributes from the 
various character palettes. A plus (+) sign will be 
appended to the style’s name in the Status area and
in the Character menu. 

2 Do one of the following:
• Click the Save button in the Characte palette. Or,
• Choose Character > Save changes to “Style Name” 

(where “Style name” stands for the actual style’s 
name). To discard, choose Styles > Character > 
“Style Name” (where “Style name” stands for the 
actual style’s name).

Note: The changes you make will be applied to the style 
variation currently selected. You will have to repeat the 
process for every style variation.
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Edit a character style in
the Edit Character 
Style dialogue box

1 Do one of the following:
• In the Character palette, select a style and click 

the Edit button (you can also press the Option key
and double-click the style’s name.

• Choose Styles > Character > Edit “Style name”... 
(where “Style name” stands for the actual style’s 
name). Or, click the style’s name in the Status 
area.

• Choose Style Set > Edit Style sets... and in the Style 
set dialogue box under the character area, select 
the style you want to edit and double-click it or 
press the Edit button. 

2 Edit the character style using the options in the Edit
Character style dialogue box. Click Save to save your 
changes or Cancel to discard.

Option-Double-click 
the style’s name

Cmd+Option+Shift+T

Edit a character style 
variation

1 Choose a variation in the Edit Character Style 
dialogue box or from the Character palette. 

2 Edit the attributes and click the Save button. 

Reset a variation • Choose a variation in the Edit Character Style 
dialogue box and press the Reset Variation button.

Note: You cannot reset the base variation without 
resetting all the other variations.

Reset all variations • in the Edit Character Style dialogue box press the 
Reset All Variations button.

Set style variation 
names

1 Choose Mellel (menu) > Preferences....
2 In the Preferences dialogue box, under the Styles 

section, double-click any of the variation names to 
change it.

Set the default 
character style for new 
documents

1 Choose Mellel (menu) > Preferences....
2 In the Preferences dialogue box, under the Styles 

section, Select the character style you want as the 
default character style with all new documents.

Note: The options offered in the character style pop-up 
menu depend on the style set selected. 

Edit a character style’s 
name

Use any of the following methods:
• Open a style for editing and edit its name in the 

Style name field. Or,
• Choose Style set > Edit style set... and in the Character 

area select the desired style and then click again to
start editing it.

Delete a character 
style

1 Choose Style set > Edit style set....
2 In the Character area select the desired style and 

then click the Delete button

Assign a keyboard 
shortcut to a style

1 Choose Style set > Edit style set....
2 In the Character area click to the right of the style 

name and select one of the available shortcuts.
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Change the position of
a style in the character 
menu

1 Choose Style set > Edit style set....
2 In the Character area select the desired style and 

drag it up or down the style list.

Add a separator line 
(divider) to the 
Character menu

1 Choose Style set > Edit style set....
2 In the Character area click the Add button and name

the style to a hyphen (“-“). 
3 Drag the hyphen up or down in the list to the 

desired position.

Editing and Managing character styles
You can edit character styles by changing the attributes of text and then saving 
the changes into the currently used style (a follow-me approach); or by accessing 
the Edit Character Style dialogue box via the Styles > Character sub-menu, the 
Character palette, or the Style Set dialogue. 
You can manage your character styles via the Style Set dialogue, which will allow 
you to arrange the Character styles list, add keyboard shortcuts to styles, edit, 
delete, duplicate, and add styles. 

Character Style sub-menu
The Character Style menu (Styles > Character Style) allows you to see which style is 
currently used (at the insertion point), apply a character style, create a new 
character style, save changes you’ve made to a character style (in the document 
area), or start editing a style (in the Edit character style dialogue box). 
The Character Style menu contains three parts:
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Figure 31: The Character menu

• Style list: contains the list of available character styles for the selected style 
set. 

• Document styles: contain the list of character styles used in the document, 
but do not exist in the style set.

• Menu options: allow you to save changes to the character style, create a new 
character style, or edit it. 

Edit character style dialogue box
The Edit character style dialogue box is where you can find and use all the character
style editing options. This dialogue box allow you to edit and change every 
element in a character style. The Edit character style dialogue box is identical in 
most of its features to the character palettes, with a few important additions. 
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Figure 32: The Edit Character Style dialogue box

Style name
The Style name field allows you to name and rename a style whenever you open 
the Edit Character Style dialogue box for editing a style. 

Style Variations
The style variations list includes the list of variations available for each style and 
two control buttons:
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Figure 33: Style variations

• Style variations list: Includes a list of the eight style variations available for 
every style. If a variation includes an attribute that is different from that of the 
base variation (e.g., if the base variation font size is 12 points and variation A is
using a font size of 13 points), the variation name will appear in boldface. 

• Reset variation: Pressing this button will reset the selected variation to the 
attributes of the base variation. 

• Reset all variations: Pressing this button will reset all the variations to the 
attributes of the base variation. 

Preview area
The preview area in the Edit Character Styles dialogue box enables you to see how 
your style will look. You can change the sample text at any time to fit your 
purposes.
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Paragraph Attributes
This chapter explains what paragraphs are, what are the tools to 
control and apply paragraph attributes, and how to use them

Should I read this chapter?
You should read this chapter if you want to learn how to style and format 
paragraphs in your document, and to learn how to use paragraph styles

What are paragraph attributes
Paragraphs are strings of characters separated by a Return character. Every 
paragraph in Mellel has several attributes, such as alignment, line spacing, space 
above and below it, tabs, and more. 
Mellel offers several palettes, menus and tools to control the way paragraphs 
look, and also allows you to create, save and change paragraph styles.

Stuff you can do
To... Do this Keyboard Shortcut

Align text to the left, 
right, centre or fully 
justify text

• In the Toolbar or in the Paragraph palette, press the 
appropriate button.

Set and change the 
line spacing

• In the Paragraph palette or in the Edit Paragraph Style
dialogue box, under Line spacing, set the line 
spacing amount and measurement unit.

Set the spacing above 
and below a paragraph

• In the Paragraph palette or in the Edit Paragraph Style
dialogue box, set the desired values under 
Paragraph spacing.

Ignore space above at 
top of page or column

• In the Paragraph palette or in the Edit Paragraph Style
dialogue box uncheck the option Also at top of pg/
col.

Indent a paragraph • Do one of the following:
• In the Ruler drag the Indent triangle beyond the 

Start margin or click it to set its value numerically. 
Or,

• Use the Paragraph palette or the Edit Paragraph 
Style dialogue box to set the Indent value 
numerically. 



Outdent a paragraph • Do one of the following:
• In the Ruler drag the Start margin beyond the 

Indent margin or click it to set its value 
numerically. Or,

• Use the Paragraph palette or the Edit Paragraph 
Style dialogue box to set the Start margin value 
numerically. 

Adjust paragraph 
margins

• Do one of the following:
• In the Ruler drag the Start, End and Indent widgets

or click them to set their value numerically. Or, 
• Use the Paragraph palette or in the Edit Paragraph 

Style dialogue box to set their position 
numerically.

Hide or show the Ruler • Choose View > Show Ruler.

Set Mellel to always 
show or hide the Ruler 
with new documents

1 Choose Mellel (menu) > Preferences....
2 Check or uncheck the option Paragraph Ruler under 

General/Show Options.

Push text to the next 
tab

• Press the Tab key (or choose Insert > Breaks > Tab).

Add a tab stop to the 
Ruler

• Do any of the following:
• Click in the Ruler where you want the tab to be, 

then click elsewhere to OK the addition of the 
tab. Or,

• In the Ruler click and drag to position the tab 
where you want to position it. Or, 

• Click in the Ruler and then, in the positioning 
‘tooltip’ enter the value to set the tab position. 
Or, 

• Click and drag a tab from the Tab well to the Ruler 
and release the mouse button.

Delete a tab • Hover over a tab in the Ruler until the cursor 
changes (and looks like to arrows pointing in two 
directions) and drag it upward or downward 
outside the Ruler.

Move a tab • Do any of the following:
• Hover over a tab in the Ruler until the cursor 

changes (and looks like to arrows pointing in two
directions) then click and drag it to the desired 
place. Or, 

• Hover over a tab in the Ruler until the cursor 
changes (and looks like to arrows pointing in two
directions) then in the positioning ‘tooltip’ enter 
the value to set the tab position.

Note: Tabs cannot be moved beyond the start or indent 
margins

Deselect a selected tab • Press somewhere else on the ruler or in the 
document area.
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Add a lead to a tab • Select a tab and then select one of the options in 
the Tab Lead pop-up menu in the Paragraph palette.

Clear (delete) all tabs 
from the Ruler

• Do any of the following:
• Right click (mouse) or Ctrl+Click over the Ruler and 

from the contextual menu choose Remove all Tab 
Stops. Or, 

• Press the Option key and drag any tab from the 
Ruler.

Add several tab stops 
at once (populate the 
Ruler with tabs)

1 Do any of the following:
• Double click the Tab Well. Or, 
• Right click (mouse) or Ctrl+Click over the Ruler 

and from the contextual menu choose Add Tab 
Stops...

2 Set the position of the first tab, the distance 
between tabs and so on and OK to add the tab 
stops.

Hide or show the tabs 
in the text

• Select Tabs from the Show button pop-down menu.

Change the defaults 
for showing tabs

1 Choose Mellel > Preferences….
2 Under the Appearance tab, check or uncheck the 

Tabs check-box.

Set the measurement 
unit for margins and 
tabs on the fly

• In the appropriate palette enter the desired value, 
followed by the measurement unit: “cm” if you 
want the value to be measured in centimetres, “in” 
if you want the value to be measured in inches, 
and “pt” if you want the value to be measured in 
points.

Set the Decimal Align 
On character

1 Click and drag a Decimal tab into the Ruler.
2 Select the Decimal tab and enter the desired Align 

On character in the Paragraph.
Note: If you always use the same Decimal Align On 
character, it might be a good idea to change the 
preferences for this character. 

Change the Decimal 
Align On preferences

1 Choose Mellel (menu) > Preferences.
2 Under the Typography tab, click in the Default 

Decimal Tab Character text field and change the 
default.

Set and adjust the 
Combo tab

1 Click and drag a Combo tab into the Ruler.
2 Click and drag either (or both) hand(s) of the 

Combo tab to the desired position.

Change paragraph 
direction

• Click the Direction button in the toolbar or in the 
Paragraph palette.

Cmd+Left/Right Arrow

Use hyphenation in a 
paragraph

See Hyphenation.

Paragraph Attributes84



Prevent widows and 
orphans in the text

• In the Edit Paragraph styles dialogue box check the 
Keep lines together option and choose an option 
from the Options pop-up menu and/or set the 
desired value in the Line at start and Line at end text 
fields. 

Prevent orphaned 
headings.

• In the Edit Paragraph styles dialogue box set a value 
of 2 or more for the Keep with next text field. 

Set the next paragraph
style (after pressing 
Return)

• In the Edit Paragraph styles dialogue box choose a 
style from the Next Paragraph style pop-up menu. 

Set an associated 
character style

• In the Edit Paragraph styles dialogue box choose a 
style from the Associated character style pop-up 
menu. 

Prevent applying a 
character style when 
applying a paragraph 
style

• In the Edit Paragraph styles dialogue box choose 
None from the Associated character style pop-up 
menu. 

Ruler and Tabs
The Ruler and the tabs in Mellel allow you to set the general appearance of your 
paragraphs. You can edit the Ruler and the tabs using the Ruler in the document 
window, through the Paragraph palette or in the Edit Paragraph Style dialogue box. 

The Ruler
The Ruler contains several components that allow you to set and change the 
appearance of paragraphs:

Start 
margin

Indent
End 
marginTab

Selected 
tab

Figure 34: The Ruler

• Start margin: sets the normal position where the lines in the paragraph start. 

• Indent: sets the position for the first line in a paragraph. When it is positioned 
after the Start margin, the paragraph will be indented. 
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• End margin: sets the position where all the lines in the paragraph will break 
and flow to the next line. 

• Tabs: are stop points you can add to the Ruler, to which text can be aligned. 

Tabs
Tabs are special stop points you can add to the Ruler to which you can align text in
your paragraph. 
When you press the Tab key on your keyboard, all the text in the paragraph, after 
the insertion point, is moved (pushed forward) to the next tab stop. If there is no 
tab stop in the Ruler, the text will be moved to the next line.

TabInsertion
Point

Tab

Insertion
Point

Figure 35: Before (left) and after (right) pressing the tab key

Tab well
Mellel offers six different types of tabs, each with its unique options. You can 
choose and change the type of tab you wish to use via the Tab well or directly via 
the Ruler. 

Figure 36: The tab well
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Types of tab stops
Regular tab
The Regular tab in Mellel serves as a jump point in the text. This is probably the tab
you’ll be using in most normal circumstances when a tab is needed. 

Figure 37: The Regular tab in the Ruler (selected)

Reverse tab
The Reverse tab serves as a jump point from which the text is aligned in reverse to 
the text direction. 

Figure 38: The Reverse tab

Centre tab
The Centre tab in Mellel serves as a jump point to text that will be centred around 
the tab point. 

Figure 39: The Centre tab

Decimal Tab
The Decimal tab serves as an aligning point for numbers, based on a special 
aligning character set in Dec. Align On in the Paragraph palette. 
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The Align On character should be the character used in your country as a decimal 
separator. Thus, in English speaking countries, text will be aligned to a dot (.):

Figure 40: The Decimal tab with English

In most other countries, the Decimal Align On point will be a comma (,):

Figure 41: The Decimal tab with other languages

The Indent tab
The Indent tab allows you to align the text of the entire paragraph to the tab point.
It is very useful in cases where you want to align text without creating a list or 
indent text without starting a new paragraph.

Figure 42: A paragraph aligned with the Indent tab

The Combo tab
The Combo tab allows you to set the start and indent point for a tab. In other 
words, it can be used to set a margin-within-the-margin in a paragraph.
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The Combo tab consists of two adjustable “hands”: The Start hand (looks like a 
small arrow) sets the alignment position of the text after the tab; The Indent hand 
(looks like a smaller arrow) sets the alignment position of the remainder of the 
text.
The Combo tab allows you to create indented or outdented paragraphs in your 
text (e.g., for quotes) with their own indention. 
For example, in the following figure the Indent hand of the Combo tab is 
positioned at 1.5 centimetres. This is the position to where the first line of text text
will align. The Start (arrow) hand is positioned at 2 centimetres. This is where all 
the other lines in the text will be aligned:

Figure 43: The Combo tab in action

You can also use the Combo tab to also outdent text:

Figure 44: An outdented paragraph using the Combo tab
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Add tab stops
The Add tab stops dialogue box allows you to enter several tab stops at once. 

Figure 45: The Add Tab Stops dialogue box

• Tab type: allows you to select the type of tab stops you wish to insert.

• First tab at: allows you to set the position of the first tab.

• Between tabs: allows you to set the distance or gap between the tabs after 
the first tab.

• Combo tab indent: If the Combo tab is the tab selected in the Tab type pop-up
menu, you’ll be able to set the indention for this tab. 

• Decimal tab align on: If the Decimal tab is the tab selected in the Tab type 
pop-up menu, you’ll be able to set the character for aligning for this tab (e.g., a
dot or a comma). 

• Tab lead: If you want the tabs to also have a lead (e.g., a string of dots or 
hyphens), you can select a lead from this pop-up menu.

• Clear tabs of this type: allows you to clear all the tabs of the type you’re 
using in the Ruler before placing the new ones. 

Paragraph palette
You can edit paragraph attributes such as line spacing, margins, tabs, and more 
via the Paragraph palette. The palette also allows you to view set, delete, change, 
and apply paragraph styles. Some additional options are available only through 
the Edit Paragraph Style dialogue box.
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Figure 46: Paragraph palette

• Alignment: The alignment buttons allow you to set the alignment 
(justification) of text in a paragraph. You can align text to the right, to the 
centre, to the left or set the text as as fully justified (block alignment). 

Table 7: Alignment options

This text is aligned to the 
left and to the left it is 
aligned.

This text is aligned to the
centre, it is centred just

fine.

This text is aligned to the
right, it is right aligned.

And that is true.

This text is block justified.
It is aligned to the right
and to the left.

• Direction: The Direction button allows you to set the general flow of the text in
a paragraph from right to left or left to right. It’s of little use if you’re not using 
bi-directional text. 

• Paragraph spacing: Allows you to set the spacing above and below a 
paragraph, beyond the set line spacing. 
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Space above 
and below 
set to 0

Space below or 
above one of 
the paragraphs 
set to 12 pt

Figure 47: Space above or below

Note: Spacing between paragraphs is calculated based on the larger value. For example, if 
paragraph A has space below of 5 points, while paragraph B following it has a space 
above of 8 points, the spacing between the two paragraphs will be 8 points, not 13 points. 

• Also at top of pg/col: When this option is checked, Mellel will add space 
above a paragraph even when this paragraph is at the top of a page or a at 
the top of a column. Normally, this option should be unchecked.

• Line spacing (sometimes called “leading”): This is the distance between the 
ascents of two lines of text. It can be measured in two ways: as lines or an 
exact measurement unit like points or inches. When measured in lines, the 
line spacing is a multiplication or s division of a set line spacing value. When 
the line spacing is measured in points, centimetres, or inches, you can set it to 
any value you desire.

• Strart, End and Indent Margins: Here you to set the start, end, and indent 
margins for a paragraph. The values here define the rightmost and the 
leftmost points of the paragraph, relative to the point of origin of the Ruler.

• Tab Lead: allows you to set the repeating character or ‘lead’ to be entered 
between the end of the text and the tab location. 

• Position: allows you to set the position of any tab selected in the Ruler.

• Dec. Align On: allows you to set a character on which decimal tabs will be 
aligned. This option is only active when a decimal tab is selected.
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Paragraph styles
What is a paragraph style?
A paragraph style is a set of formatting attributes that determines how 
paragraphs in your document will look. A paragraph style is a type of shortcut: it 
allows you to apply several paragraph attributes at once. To make things more 
convenient, paragraph styles can be added, edited, deleted and arranged 
according to your needs.

Stuff you can do
To... Do this Keyboard Shortcut

Apply a paragraph 
style

1 Position the insertion point anywhere within a 
paragraph.

2 Click the Styles tab in the Paragraph palette, and 
then click the Apply Style button, or choose a style 
from the Styles > Paragraph menu.

A keyboard shortcut if 
one is assigned to a 
style

Apply a different 
paragraph style

1 Position the insertion point anywhere within a 
paragraph.

2 Choose a style from the Styles > Paragraph Style 
menu, or Click the Styles tab in the Paragraph 
palette, and then click the Apply Style button (you 
can also double-click the style’s name).

Check what style is 
currently used

• Do any of the following:
• Open the Paragraph palette. Or,
• View the styles well in the toolbar. Or,
• View the Styles > Paragraph Style menu to see 

which style has a check mark next to it. 
Note: The selected style will have Check mark next to it. If 
the selection contains multiple styles, a minus (-) sign will 
appear next to each of them.

Apply only the 
paragraph style 
attributes (not the 
style itself )

1 Position the insertion point anywhere within a 
paragraph you wish to copy, and choose Edit > 
Copy Special > Paragraph attributes.

2 Position the insertion point within another 
paragraph and choose Edit > Paste.

Cmd+V
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Create a new 
paragraph style

Do one of the following:
• Click Styles tab in the Paragraph palette and then 

click the Add button in the . Or,
• Choose Styles > Paragraph Style > Create New 

Paragraph Style... (Thus duplicating the currently 
used paragraph style). Or,

• Choose Style Set > Edit Style Sets... and in the 
paragraph area of the dialogue box, click the 
Duplicate button (Thus duplicating the currently 
used paragraph style). Or,

• Choose Style Set > Edit Style Sets... and in the 
paragraph area click the Add button. Mellel will 
create a new paragraph style with default 
attributes.

Note: When you duplicate or create a paragraph style, if 
the style that the new style is based on has an associated 
character style set, Mellel will ignore that setting, allowing 
you to set the associated character style of your choice. 

Edit a paragraph style 
from within the 
document

1 Position the insertion point within a paragraph and
apply attributes from the various paragraph 
palettes. A plus (+) sign will be appended to the 
style’s name in the Pargraph palette, in the Status 
area in the toolbar, and in the Styles > Paragraph 
Style menu. 

2 Do one of the following:
• Click the Save button in the Paragraph palette. Or,
• Choose Paragraph > Save changes to “Style Name” 

(where “Style name” stands for the actual style 
name). To discard changes, choose Paragraph > 
“Style Name” (where “Style name” stands for the 
actual style name).

Edit a paragraph style 
in the Edit Paragraph 
Style dialogue box

1 Do one of the following:
• In the Paragraph palette, select a style and click 

the Edit button (you can also press the Option key
and double-click the style’s name.

• Choose Styles > Paragraph Style > Edit “Style name”... 
(where “Style name” stands for the actual style’s 
name). Or, click the style’s name in the Status 
area.

• Choose Style Set > Edit Style sets... and in the Style 
set dialogue box under the paragraph area, 
select the style you want to edit and double-click
it or press the Edit button. 

2 Edit the paragraph style using the options in the 
Edit Paragraph style dialogue box. Click Save to save 
your changes or Cancel to discard

Option-Double-click 
the style’s name

Cmd+Option+Shift+P
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Set the default 
paragraph style for 
new documents

1 Choose Mellel (menu) > Preferences....
2 In the Preferences dialogue box, under the Styles 

section, Select the paragraph style you want as the 
default paragraph style with all new documents.

Note: The options offered in the paragraph style pop-up 
menu depend on the style set selected. 

Edit a paragraph style’s
name

Use any of the following methods:
• Open a style for editing and edit its name in the 

Style name field. Or,
• Click a the Paragraph style’s name in the Status area

in the Toolbar. Or, 
• Choose Style set > Edit style set... and in the Paragraph 

area select the desired style and then click again to
start editing it.

Delete a paragraph 
style

• Do any of the following:
• Choose Style set > Edit style set.... and in the 

Paragraph area select the desired style and then 
press the Delete button.

• In the Paragraph palette, click a style’s name and 
press the Delete button.

Assign a keyboard 
shortcut to a style

• Choose Style set > Edit style set....
1 In the Paragraph area click to the right of the 

style name and select one of the available 
shortcuts.

Change the position of
a style in the 
paragraph menu

1 Choose Style set > Edit style set....
2 In the Paragraph area select the desired style and 

drag it up or down the style list.

Add a separator line 
(divider) to the 
Paragraph menu

1 Choose Style set > Edit style set....
2 In the Paragraph area click the Add button and 

name the style to a hyphen (“-“). 
3 Drag the hyphen up or down in the list to the 

desired position.

Editing and Managing paragraph styles
You can edit paragraph styles by changing the attributes of paragraphs and then 
saving the changes into the currently used style (a follow-me approach); or via the
Edit Paragraph Style dialogue box you can access via the Styles > Paragraph Style 
menu, the Paragraph palette, or the Style Set dialogue. 
You can manage your paragraph styles in via the Style Set dialogue, which will 
allow you to arrange the Paragraph menu, add keyboard shortcuts to styles, edit, 
delete, duplicate, and add styles. 
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Paragraph menu
The Paragraph menu (Styles > Paragraph styles) allows you to see which style is 
currently used (at the insertion point), apply a paragraph style, create a new 
paragraph style, save changes you’ve made to a paragraph style (in the document
area), or start editing a style (in the Edit paragraph style dialogue box). 
The Paragraph style menu contains three parts:

Style
List

Document
Styles

Menu
Options

Figure 48: The Paragraph menu

• Style list: contains a list of available paragraph styles in the style set. 

• Document styles: contains the list of paragraph styles used in the document, 
but no part of the style set.

• Menu options: allow you to save changes to the paragraph style, create a 
new paragraph style, or edit a paragraph style. 
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Paragraph Palette styles list
The Paragraph palette, allows you to add, delete, apply, edit, and save changes to 
paragraph styles. This palette also allows you to view the status of the styles in the
document. 

The style listStyle status

Add a style

Delete a style

Edit a style

Apply a style

Save a style

Figure 49: The Paragraph palette

• Add a style: adds a new paragraph style.

• Delete a style: Deletes the currently selected paragraph style. 

• Edit a style: opens the Edit Paragraph style dialogue box and allows you to edit 
the style’s attributes.

• Apply a style: applies the selected style to the paragraph where the insertion 
point is. 
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• Save a style: saves the changes to the first changed style within the selection 
in the document. 

Edit Paragraph style dialogue box
The Edit Paragraph style dialogue box is where you can find and use all the 
paragraph style editing options. This dialogue box allows you to change every 
element in a paragraph style. The Edit paragraph style dialogue box is identical in 
most of its features to the paragraph palettes, with a few important additions, 
that will be reviewed below. 

Figure 50: The Edit Paragraph style dialogue box

Style name
The Style name field allows you to name and rename a style whenever you open 
the Edit Paragraph Style dialogue box for editing a style. 
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Hyphenation
Mellel’s Paragraph styles support several advanced hyphenation options, which 
will be reviewed here briefly. For a more in-depth review, see the chapter about 
Hyphenation. 

• Enable: Check this option to activate automatic hyphenation for this 
paragraph style. You have to check this option edit other hyphenation 
options.

• Dictionary: allows you to select a hyphenation dictionary. 

• Customise minimum: allows you to change the minimum options for 
hyphenation, overriding the settings in the hyphenation dictionary. The 
options available are:
a Minimum word length: The minimum length (in letters) for a word to be 

hyphenated. The default is the value set in the hyphenation dictionary 
(normally, 5).

b Minimum before hyphen: The minimum length (in letters) of the first 
part of an hyphenated word. The default is the value set in the 
hyphenation dictionary (usually, 2).

c Minimum after hyphen: The minimum length (in letters) of the second 
part of an hyphenated word. The default is the value set in the 
hyphenation dictionary (usually, 2).

• Hyphenation limit: The value you enter here will determine how many 
consecutive lines will be hyphenated. The default is 3. 

• Hyphenation zone: This option allows you to set the amount of “white space” 
allowed at the end of a line. A higher value will reduce hyphenation and allow 
more white space. The default is 0. 

Keep options
Keep options are advanced layout tools, used to control the way text will be laid 
out at the beginning and end of pages. 

Keep lines together
The Keep lines together option, sometimes called “widows and orphans” control, 
allow you to determine what will happen when a paragraph spills over from one 
page to the next. When the Keep lines together check-box is checked, you can 
choose one of two options from the Options pop-up menu:

• All lines in a paragraph: If this option is selected, the paragraph will be kept 
as a unit, and will not be split across pages. For example, a split paragraph:
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Figure 51: A split paragraph...

Will be moved in its entirety to the next page:

Figure 52: ...is moved to the next page

• At start/end of paragraph: allows you to set set how many lines will be kept 
together at the beginning or the end of a paragraph. This option is useful to 
prevent a situation where only the first or the last line in a paragraph is 
displayed at the top or at the bottom of a page (widows and orphans).
a Lines at start: A value of 2 or more will force Mellel to keep two or more 

lines together at the beginning of a paragraph. A value of 1 or less means 
that the option will have no effect. 

b Lines at end: A value of 2 or more will force Mellel to keep two or more 
lines together at end of a paragraph. A value of 1 or less means that the 
option will have no effect. 

Keep with next
The Keep with next option allows you to keep the current paragraph style tied to 
one or more lines of the next paragraph. This option is especially useful to keep 
headings tied to sub-headings and to body text at the bottom of the page, and is 
usually activated only with headings. Setting the value to 2 or 3 lines will yield an 
optimal result. A value of 1 will have no effect and a value of 4 or more lines will 
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usually force Mellel to move headings near the bottom of the page to the top of 
the next page. 

Note: It is important to bear in mind that you should usually use the Keep with next option 
only with headings. 

Next paragraph style
The Next paragraph style option allows you to set the paragraph style that will 
follow the current paragraph style after pressing the Return key at the end of a 
paragraph. This option is useful when you want a heading or a special style to be 
followed by a body style. If you don’t want the current paragraph style to change 
when you press the Return key, choose the option Same style. 

Associated character style
The Associated character style option enables you to associate (link) any paragraph 
style to any character style. Associating styles is helpful in several cases:

• As a shortcut: you can apply a paragraph and character style to a block of 
text at once.

• To work in the traditional way: where paragraph and character styles 
function as one entity.

• To achieve more flexibility (1): you can associate several paragraph styles to 
the same character style.

• To achieve more flexibility (2): you can change an association or the 
associated styles without having to create a new style.

Note: You cannot associate a paragraph style and a variation within a character style.

Preview area
The preview area displays the style as it will look in the document. It allows you to 
conveniently adjust options like tabs and indentation. The character style 
appearance in the preview area is determined by the associated style. If there is 
no character style associated with the style, a generic default character style is 
selected.
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Section (Column) Attributes
This chapter explains what columns and sections are, and how to use
them

Should I read this chapter?
You should read this chapter if you intend to use columns or sections in 
your document

What are sections
A section in Mellel is a block of text, spanning over one paragraph or more, which 
starts and ends with a section break (the beginning and the end of a document 
are also considered section breaks). 
The example below shows a page with four sections, but a page may include 
more than four sections, and a single section can span several pages and 
sometimes the entire document.
Mellel offers a palette, a sub-menu, a dialogue box and other tools that will allow 
you to control how your sections will look. You can also use section styles, which 
allow you to set the appearance of the section with a single menu selection.



Section breaks

Figure 53: A page with sections

Stuff you can do
To... Do this Keyboard Shortcut

Create columns • Click in the text where you want to create columns,
open the Section palette and in the Count text fields
set the number of columns.

Create a section 1 Select text you want to include in a section. 
2 Choose Edit > Make Section from Selection.

Cmd+Option+Shift+S

Set the start or end of 
a section

• Click in the text where you want the section to 
start or end and choose Insert > Breaks > Section 
break.

To hide or show the 
Section palette

• Choose Window > Palettes > section.

Set the background 
colour for columns

1 Click within a section. 
2 In the Section palette choose Solid from the 

Background pop-up menu, click the Colour button 
and choose a colour.

Set the columns order 1 Click within a section with columns.
2 In the Section palette choose an option from the 

Order pop-up menu.
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Set the space above 
for a section

1 Click within a section.
2 In the Section palette enter the desired space above

value in the Space above text field.

Balance columns 1 Click within a section with columns.
2 In the Section palette check the Balanced check-box.

Set gutter options 1 Click within a section with columns.
2 In the Section palette set the options in the Gutter 

section of the palette.

Add line numbers See the chapter about Line Numbering on page 277.

Section palette
The Section palette allows you to set and change the appearance of a section. 
These options include setting the number of columns, their order, background, 
space above, and various options related to the gutter.

Figure 54: The section palette

Columns options
• Column count: allows you to set and change the number of columns in the 

section. You can set an unlimited number of columns, although the practical 
limit is probably less than 100 columns.

• Order: allows you to set the order or flow of text in columns: from right to left,
or from left to right. The last would probably be the best option for all Roman 
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scripts. The first would serve scripts running from right to left, such as Arabic 
or Hebrew or script that runs vertically and then from right to left, such as 
Japanese or Chinese.

• Background: allows you to determine whether the section will have a 
background colour (Solid) or not (None).

• Colour: allows you to set the background colour for the section. This option is 
available only if the Background option is set to Solid. 

• Space above: allows you to set the space above the section. This option is 
useful when you wish to set sections apart vertically. 

• Balanced: When this option is checked, Mellel will try to balance columns—
that is, it will try to lay them out so they end at exactly the same position 
vertically. 

Gutter options
• Width: allows you to set the width of the gutter—namely, the space between 

the columns. 

• Line type: allows you to select what type of line, if at all, will be used. The line 
will be centred horizontally within the gutter. 

• Line weight: allows you to set the weight (thickness) of the gutter line. 

• Line colour: allows you to set the colour of the gutter line. 

• Space above line: allows you to set the vertical space above the gutter line. A 
value of 0 indicates that the gutter line will start at the top of the column. 

• Space below line: allows you to set the space, vertically below the gutter line.
A value of 0 indicates that the gutter line will end at the bottom of the 
column. 

Line Numbering
Mellel offers rich options for manipulating line numbers and line numbering. You 
can read all about those in the chapter titled Line Numbering on page 277.

Styles tab
The Styles tab allow you to add, delete, open for editing, apply and save changes 
to styles. The styles list contains three sections:

• Style list: The list of available section styles with the used Style set. 

• Document styles: A list of section styles used in the document, that do not 
exist in the style set (they are marked by a diamond). 
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• Control buttons: Those allow you to perform manipulations over the selected
style.

Note: the various things you can do with styles are discussed here. 

Section styles
What is a section style?
A section style is a set of formatting attributes that determines how sections and 
columns in your document will look.

Stuff you can do
To... Do this Keyboard Shortcut

Apply a section style 1 Position the insertion point within a section.
2 Choose a style from the Section sub-menu.

Apply a different 
section style

1 Position the insertion point within a section.
2 Choose a style from the Section sub-menu.

Check what style is 
currently used

• Open the Styles tab of the Section palette or choose 
Styles > Section Style to see which style has a check 
mark next to it. If the selection in the text contains 
multiple styles, a minus (-) sign will appear next to 
each of them.

Create a new section 
style

• Do one of the following:
• Open the Styles tab of the Section palette and 

click the Add button. Or,
• Choose Styles > Section Style > Create new section 

style... (Thus duplicating the currently used 
section style). Or,

• Choose Style Set > Edit Style Sets... and in the 
sections area of the dialogue box, click the 
Duplicate button (Thus duplicating the currently 
used section style). Or,

• Choose Style Set > Edit Style Sets... and in the 
sections area click the Add button. Mellel will 
create a new section style with default attributes.
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Edit a section style 
from within the 
document

1 Position the insertion point within a section and 
apply attributes from the Section palette. A plus (+) 
sign will be appended to the style’s name in the 
Section palette and in the Section Style sub-menu. 

2 Do one of the following:
• Open the Styles tab of the Section palette and 

click the Save button. Or, 
• Choose Styles > Section Style > Save changes to 

“Style Name” (where “Style name” stands for the 
actual style name). 

3 [optional] To discard changes, choose another style
from the Section palette or the Styles > Section Style 
sub-menu.

Edit a section style in 
the Edit Section style 
dialogue box

1 Do one of the following:
• In the Section style palette, select a style and click 

the Edit button (you can also press the Option key
and double-click the style’s name.

• Choose Styles > Section Style > Edit “Style name”... 
(where “Style name” stands for the actual style’s 
name). 

• Choose Style Set > Edit Style sets... and under the 
sections area, select the style you want to edit 
and double-click it or press the Edit button. 

2 Edit the section style using the options in the Edit 
Section style dialogue box. Click Save to save your 
changes or Cancel to discard

Set the default section 
style for new 
documents

1 Choose Mellel (menu) > Preferences....
2 In the Preferences dialogue box, under the Styles tab,

Select the section style you want as the default 
section style with all new documents.

Note: The options offered in the section style pop-up menu
depend on the style set selected. 

Edit a section style’s 
name

Use any of the following methods:
• Open a style for editing and edit its name in the 

Style name field. Or,
• Choose Style set > Edit style set... and in the Section 

area select the desired style and then click again to
start editing it.

Delete a section style 1 Choose Style set > Edit style set....
2 In the Section area select the desired style and then 

click the Delete button.

Change the position of
a style in the Section 
Style sub-menu

1 Choose Style set > Edit style set....
2 In the Section area select the desired style and drag 

it up or down the style list.
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Add a separator line 
(divider) to the Section
Style sub-menu

1 Choose Style set > Edit style set....
2 In the Section area click the Add button and name 

the style to a hyphen (“-“). 
3 Drag the hyphen up or down in the list to the 

desired position.

Editing and Managing section styles
You can edit section styles by changing the attributes of sections and then saving 
the changes into the currently used style (a follow-me approach); or via the Edit 
Sections Style dialogue box you can access via the Styles > Section Style sub-menu, 
the Section palette, or the Style Set dialogue. 
You can manage your section styles in via the Style Set dialogue, which will allow 
you to arrange the Section Style sub-menu, edit, delete, duplicate, and add section 
styles. 

Section style sub-menu
The Section style sub-menu under the Styles menu allows you to see which section 
style is currently used (at the insertion point), apply a section style, create a new 
section style, save changes you’ve made to a style in the document area, or start 
editing a style (in the Edit Section style dialogue box). 
The Section style sub-menu contains three parts:

Style
List

Document
Styles

Menu
Options

Figure 55: The Section sub-menu

• Style list: contains the list of available section styles. 

• Document styles: contain the list of section styles used in the document, but 
do not exist in the style set.

Section (Column) Attributes108



• Menu options: allow you to save changes to the section style, create a new 
section style, or edit it. 

Edit section style dialogue
The Edit Section style dialogue box is your central hub for editing section styles. 
Here, you can edit and change every element in a section style. The Edit Section 
style dialogue box is functionally almost identical to the Section palette. For more 
info about the options here, see Above.

Figure 56: The Edit Section style dialogue box

Style name
The Style name field allows you to name and rename a style whenever you open 
the Edit Page Style dialogue box for editing a style. 
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Page Attributes
This chapter explains what page attributes are, what are the tools to 
control and apply page attributes, and how to use them

Should I read this chapter?
You should read this chapter if you intend to use headers and footers or 
background images in your documents, or if you need to change page 
margins or orientation in your document

What are page attributes
Pages in Mellel are frames that can contain text an graphics. Pages in Mellel are 
arranged in page ranges—a series of pages that begin and end with a Page Style 
Break (the beginning and the end of the text are also considered Page Style Breaks). 
Page attributes are the options that can be applied to page ranges, such as 
headers, footers and numbering.
Mellel offers a palette, a sub-menu, a dialogue box and other tools that will allow 
you to control how your pages will look. You can also use page styles, which allow
you to set the appearance of the page range with a single menu selection.

Stuff you can do
To... Do this Keyboard Shortcut

Create headers or 
footers

1 Place the insertion point in the document, at a 
page you want to have headers or footers.

2 Choose Window > Palettes > Page to open the Page 
palette.

3 Check Header and/or Footer to display the header or
footer. 

Insert page number 1 Choose Window > Palettes > Page to open the Page 
palette.

2 In the Page palette check Header and/or Footer to 
display the header or footer. 

3 Click within the header or footer and from the 
Insert element pop-up menu choose Page number.

Note: With the default template, there is already a page 
number inserted into the header or footer.



Insert page number 
and total number of 
pages (Page x out of Y)
into the header or 
footer

1 Choose Window > Palettes > Page to open the Page 
palette.

2 In the Page palette check Header and/or Footer to 
display the header or footer. 

3 Click within the header or footer and from the 
Insert element pop-up menu choose Page number, 
and then Total number of pages.

Insert a table or a date 
into the header or 
footer

1 Choose Window > Palettes > Page to open the Page 
palette.

2 In the Page palette check Header and/or Footer to 
display the header or footer. 

3 Click within the header or footer and from the 
Insert element pop-up menu choose Table... or 
Dage....

Start a new page range 1 Click at the end of the page where you want a 
page range to end. 

2 Choose Insert > Breaks > Page Style break.

Cmd+Shift+Enter (for a
page style break)

Create a different first 
page

1 Choose Window > Palettes > Page to open the Page 
palette.

2 Check the option Different first page. 

Set different headers 
or footers on Even and 
Odd pages

1 Choose Window > Palettes > Page to open the Page 
palette.

2 Check Different odd/even pages.
3 Click either the Odd or Even tab in the Page selector 

and check the Header or Footer check-boxes to 
display the header or the footer for editing.

Insert a page break 1 Choose Insert > Breaks > Page break. Shift+Enter

Hide the page number,
header or footer on 
the first page

1 Choose Window > Palettes > Page to open the Page 
palette, and then click the First Page tab with the 
Page selector. 

2 Do one of the following:
• In the document, click the Close button in the tab

that will appear above or blow the header or the 
footer. Or,

• Under the First Page tab in the Page selector un-
check Header or Footer.

Set the header of 
footer height

1 Do one of the following:
• Drag the resize handle for the header or footer. 

Or,
• Set the height of the header or the footer in the 

Page Selector tab view.

Snap the header or 
footer height to the 
optimum.

1 Do one of the following:
• Drag the resize handle for the header or footer 

until it snaps to position. Or,
• Double-click the resize handle.
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Apply or cancel 
changes to the header 
or footer

• Click the Apply or Cancel buttons at the top or 
bottom of the edited header or footer. 

Set the page range to 
start on an even or on 
an odd page

1 Choose Window > Palettes > Page to open the Page 
palette.

2 Choose Even page or Odd page from the Page Range 
Starts pop-up menu.

Create a running 
header (mention) in 
the header or footer

1 Click inside the header or the footer. 
2 Choose a heading (auto-title) from the Insert 

mention pop-up menu that will appear above or 
below the header or footer. 

Set the page range to 
have mirrored margins

1 Choose Window > Palettes > Page to open the Page 
palette.

2 Click the Margins and Orientation button and check 
the option Facing pages. 

Set the numbering 
unit for a page range

1 In the Page palette, choose a numbering unit from 
the Numbering pop-up menu. 

Set the start number 
for a page range

1 In the Page palette, check the Start at check-box, 
and in the text field next to the check-box enter 
the start number.

2 Press the Tab key to OK your change and exit 
editing. 

Set the background 
colour

1 Choose Window > Palettes > Page to open the Page 
palette.

2 Click the colour well at the Background section and 
set the colour (you may need to do the same for 
Even pages, if the option Different odd/even pages is 
checked.

Set the background 
image

• Check the Image check-box under the Background 
section and select an image, and then select an 
image from the Open dialogue box.

Set the background 
image positioning

1 Check the Image check-box under the Background 
section and select an image. 

2 Choose one of the options from the Position pop-
up menu under the Background section.

Set the background 
image opacity

1 Check the Image check-box under the Background 
section and select an image. 

2 Set the opacity via the Opacity slider or text area.

Set the page range 
orientations

1 Choose Window > Palettes > Page to open the Page 
palette.

2 Click the Margins and Orientation button and in the 
Margins and Orientation dialogue click the Portrait 
or Landscape button. 
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Set the margins for the
page range

1 Choose Window > Palettes > Page to open the Page 
palette.

2 Click the Margins and Orientation button and in the 
Margins and Orientation dialogue the top, bottom, 
left, and right margins.

Show or hide header 
and footer frames

1 from the Show button pop-down menu choose 
Header/footer frames.

Move to the first page 
in a page range

1 [if the Different first page check-box is checked], click
the First page tab in the Page palette. 

Move to the first even 
or odd page in a page 
range

1 [if the Different odd/even pages check-box is 
checked], click the Odd or Even tab in the Page 
palette. 

Set the defaults to 
show or hide header 
and footer frames for 
all new documents

1 Choose Mellel (menu) > Preferences....
2 In the Appearance tab check or un-check Header/

footer frames.

Page palette
The Page palette contains several attributes you can set and change. Among 
them are the page type, different first page, different odd and even pages, 
displaying or hiding the headers or footers, setting the page numbering unit, the 
start page, and more. The Styles tab of the Page palette allows you to add, save, 
delete, edit and apply page styles. 

Figure 57: The Page palette
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Different first page
Checking this option will set Mellel to have the first page (e.g., a title page) in the 
page range different than all the other pages in the document. When the check-
box is un-checked Mellel regards the first page as a regular page or as an even/
odd page (if Different Odd/Even pages is checked). 

Different Odd/Even pages
Checking this option will set Mellel to have different odd and even pages in the 
page range. When the check-box is un-checked Mellel treats all the pages in the 
page as regular pages.

Page type selector
This page type tab view allows you to view each type of page in your page range. 
Mellel will also try, when possible, to skip to the first page of this type available in 
the current page range. The tab view for each page type includes options that 
apply to this page type. 

Header
Checking this option will display the header for the current page range. You can 
also set the header height (or directly manipulate it in the document). 

Footer
Checking this option will display the footer for the current page range. You can 
also set the footer height (or directly manipulate it in the document). 

Note: The height of a header or footer is limited to a third of the page’s size. If the header or 
footer extend beyond a third of the page’s size, the upper part of the header or footer will 
be ‘scrolled out’ of display and Mellel will display an Overflow Indicator at the bottom/top 
of the header/footer to indicate that some of the content cannot be displayed.

Background
The Background options allow you to set the background colour, and the 
background image, to set the positioning of the background image, and to set its 
opacity.

• Background colour: This option allows you to assign a background colour to 
all the pages or, if Different Odd/Even pages is checked, to set a different 
background colour for odd and even pages. 
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• Image: When checked, allows you to place a background image to all the 
pages or, if Different Odd/Even pages is checked, to set a different background 
image for odd and even pages. 

• Position: allows you to set the positioning of a background image. The 
various options are fairly self explanatory from the icons in the pop-up menu, 
and are illustrated with the following table.

Table 8: Background image positioning options
Top Left Top Centre Top Right Middle Left Centre Middle Right

Bottom Left Bottom Centre Bottom Right Tile Fit to page

• Opacity: allows you to set the opacity of the background image, either by 
entering the value (in percent) or by dragging the opacity slider. 

Page range starts
This option allows you to set the page range to start with the next even or odd 
page, or start at any page. This option is useful if, for example, you want to divide 
your document into chapters, always starting a chapter on an odd page or an 
even page.

• Any page: When this option is selected, Mellel will start the page range at any 
page, odd or even. 

• Odd page: When this option is selected, Mellel will start the page range with 
the next odd page. For example, if page range A starts at page 1 and ends at 
page 16, Mellel will start the current page range at page 18, creating page 17 
as a blank page. 

• Even page: When this option is selected, Mellel will start the page range with 
the next even page. For example, if page range A starts at page 1 and ends at 
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page 15, Mellel will start the current page range at page 17, creating page 16 
as a blank page. 

Numbering
The numbering option allow you to set the page numbering unit that will be used
in the header or the footer. You can apply separate numbering to any page range 
in the document.

Note: The Numbering option appears only in the Page palette, as it allows you to set ad-hoc
changes to a page style. Changes to the Page numbering will not affect the page style.

Start at 
This option allows you to set the start number for the page range. The default is 
the current number (i.e., no change from previous page range). This option is 
useful if you need to start the document at a number other than 1, or to change 
the numbering scheme for different parts of a document. If you do not set a 
number here, the numbering will continue from the previous page range. 

Note: The Start at option appears only in the Page palette, as it allows you to set ad-hoc 
changes to a page style. Changes to the Page numbering will not affect the page style.

Margins and Orientation
Clicking the Margins and Orientation button will open a utility dialogue that will 
allow you to change the page range margins and orientation. 
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Figure 58: Margins and Orientation dialogue box

Orientation
You can set the page range orientation to Portrait (vertical) or Landscape 
(horizontal). 

Note: you can have both portrait and landscape pages in a document, but a single page 
range can only have one orientation. 

Page margins
Page margins are the distance from the edge of the page to the text area. You can 
set the top, bottom, left and right margins. 

Note: Although you can set the page margin values to 0 (that is, no page margins), you 
should consider that most printers cannot print to the edge of the page and require a page
margin of at least 0.15 inches (0.4 cm) on each end of the page. For the minimum margin 
size, consult your printer documentation.

Facing Pages
This option, when checked, sets even and odd pages to mirror each other—that 
is, to share the Inner (closer to the fold) and outer margins. 

Editing page attributes in the document
Mellel allows you to edit the header or footer attributes directly from the 
document window.
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Figure 59: Manipulating the header and footer from the document

If a header or a footer is displayed, you can enter editing it by clicking in it, and 
enjoy several options to easily manipulate the header or footer (in addition to the 
controls and options available from the Page palette):

Apply and Cancel buttons
When you enter editing the header or the footer, the Apply and Cancel buttons will
appear above the header or the footer. 

• Apply: pressing this button will apply the changes to the entire page range, 
and exit editing the header or the footer. 

• Cancel: pressing this button will hide the content of the header or footer (it 
will not erase them). 

Insert element
This pop-up menu allows you to quickly enter:

• The page number

• The total number of pages

• A Table

• A Date stamp

Insert Mention
This pop-up menu allows you access enter auto-titles as mentions (running 
headers) into the header or the footer. 

Resizing behaviour
• Overflow indicator: The overflow indicator appears as a pale red + sign near 

the bottom or the top of the header or the footer, to indicate that the header 
or footer contains additional content that cannot be displayed. You cannot 
make the indicator ‘go away’, but it will vanish automatically once the header 
or footer entire content can be displayed. 
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• Resize handle: The resize handle can be dragged up or down. It will snap to 
its position once you’ve dragged the handle to the optimal height—i.e., the 
height where the entire content of the header of footer is displayed. 

• Auto-snap: double clicking the resize handle will snap it to the optimal 
height. 

• Auto-resize: as you add or delete content to or from the header or footer, 
they will expand or contract automatically. If you’ve set the header or footer 
height to a size that does not allow displaying the entire content of the 
header or footer, Mellel will resize it (i.e., snap-out of the settings in the Page 
palette. You can always set the size again in the Page palette or by dragging 
the Resize handle. 

Page styles tab
The Styles tab allows you to see which style is used at the insertion point, apply a 
page style, create a new page style, save changes you’ve made to a style, or start 
editing a style (in the Edit page style dialogue box). 
The Styles tab contains three parts:

• Style list: contains the list of available page styles. 

• Document styles: contain the list of page styles used in the document, but 
do not exist in the style set.

• Buttons: Those allow you to save changes to the page style, apply it, create a 
new page style, or edit it. 

Note: for a more detailed discussion of styles, see the Page Styles section. 

Page styles
What is a page style?
A page style is a set of formatting attributes that determines how page ranges in 
your document will look. Editing page styles in Mellel is simple and, for the most 
part, self explanatory. 

Stuff you can do
To... Do this Keyboard Shortcut

Apply a page style 1 Position the insertion point within a page range.
2 Open the Style tab in the Page palette or choose a 

page style from the Styles > page sub-menu.
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Apply a different page 
style

1 Position the insertion point within a page range.
2 Choose another page style from the the Style tab in

the Page palette or from Styles > page sub-menu.

Check what style is 
currently used

• Do one of the following:
• At the bottom of the document window, view 

the style name. Or,
• Open the Style tab in the Page palette or choose 

Styles > Page Style to see which style has a check 
mark next to it. If the selection in the text 
contains multiple styles, a minus (-) sign will 
appear next to each of them.

Create a new page 
style

• Do one of the following:
• Open the Style tab in the Page palette and click 

the Create New Page style button. Or,
• Choose Styles > Page Style > Create new page style... 

(Thus duplicating the currently used page style). 
Or,

• Choose Style Set > Edit Style Sets... and in the pages 
area of the dialogue box, click the Duplicate 
button (Thus duplicating the currently used 
page style). Or,

• Choose Style Set > Edit Style Sets... and in the pages 
area click the Add button. Mellel will create a new
page style with default attributes.

Edit a page style from 
within the document

1 Position the insertion point within a page range 
(and in the header or the footer there, if you wish 
to edit those), and apply attributes from the Page 
palette.
Once you’ve edited the page style, a plus (+) sign 
will be appended to the style’s name in the Style 
tab of the Page palette or with the Page Style sub-
menu. 

2 Open the Style tab in the Page palette and click the 
Save Changes to Style button. Or, Choose Styles > 
Page Style > Save changes to “Style Name” (where 
“Style name” stands for the actual style name). 

3 [Optional] To discard all changes open the Style tab 
in the Page palette and click on the style’s name in 
the styles list or choose Styles > Page Style > “Style 
Name” (where “Style name” stands for the actual 
style name).
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Edit a page style in the 
Edit Page style 
dialogue box

1 Do one of the following:
• Open the Style tab in the Page palette, select a 

style and click the Edit Page Style button. Or, 
• Choose Styles > Page Style > Edit “Style name”... 

(where “Style name” stands for the actual style’s 
name). 

• Choose Style Set > Edit Style sets... and under the 
pages area, double-click the style you want to 
edit, or press the Edit button. 

2 Edit the page style using the options in the Edit 
Page style dialogue box. Click Save to save your 
changes or Cancel to discard.

Set the default page 
style for new 
documents

1 Choose Mellel (menu) > Preferences....
2 In the Preferences dialogue box, under the Styles tab,

Select the page style you want as the default page 
style with all new documents.

Note: The options offered in the page style pop-up menu 
depend on the style set selected. 

Edit a page style’s 
name

Use any of the following methods:
• Open a style for editing and edit its name in the 

Style name field. Or,
• Choose Style set > Edit style set... and in the Page area 

select the desired style and then click again to start
editing it.

Delete a page style 1 Choose Style set > Edit style set....
2 In the Page area select the desired style and then 

click the Delete button.

Change the position of
a style in the Page 
Style sub-menu

1 Choose Style set > Edit style set....
2 In the Page area select the desired style and drag it 

up or down the style list.

Add a separator line 
(divider) to the Section
Style sub-menu

1 Choose Style set > Edit style set....
2 In the Section area click the Add button and name 

the style to a hyphen (“-“). 
3 Drag the hyphen up or down in the list to the 

desired position.

Editing and Managing page styles
You can edit page styles by changing the attributes of page ranges in the 
document, and then saving the changes into the currently used style (a follow-me
approach); or via the Edit Page Style dialogue box, accessible via the Page palette, 
the Styles > Page Style sub-menu, or the Style Set dialogue. 
You can manage your list of page styles in via the Style Set dialogue, which will 
allow you to arrange the Page palette styles list and the Page Style sub-menu, edit 
styles, delete styles, duplicate styles, and add new page styles. 
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Page style sub-menu
The Page style sub-menu under the Styles menu allows you to see which page style 
is currently used (at the insertion point), apply a page style, create a new page 
style, save changes you’ve made to a style (in the document area), or start editing 
a style (in the Edit page style dialogue box). 
The Page style sub-menu contains three parts:

Style
List

Document
Styles

Menu
Options

Figure 60: The Page menu

• Style list: contains the list of available page styles. 

• Document styles: contain the list of page styles used in the document, but 
do not exist in the style set.

• Menu options: allow you to save changes to the page style, create a new 
page style, or edit it. 

Edit page style dialogue
The Edit page style dialogue box is your central hub for editing page styles. Here, 
you can edit and change every element in a page style. The Edit page style dialogue
box is similar, in its features, to the Page palette, but allows you to design your 
page range much more comfortably. 
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Style name Change edit area Change header 
and footer height

Change 
margins

Resize 
handle

Add 
image

Hide 
footer

Background 
Colour

Figure 61: Edit page style dialogue

Important: for details about Different first page, Different Even/Odd pages, Numbering, 
facing pages, and Orientation please see the section about the Page palette on page 113.

Style name
The Style name field allows you to name and rename a style whenever you open 
the Edit Page Style dialogue box for editing a style. 

Navigation tabs
The navigation tabs, at the bottom of the page editing area, allow you to navigate
between editing the first page (if the Different first page option is checked) and all 
the other pages or the Odd/Even pages (if the option Different Even/Odd pages is 
checked). 

Direction
The Direction button allows you to change the direction of the page flow within 
the page range: from left to right (as with English, German, French, etc.) or right to
left (as with Arabic or Hebrew, for example). 
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Page editing area
The main area in the Page Style edit dialogue box is occupied by the page editing 
area. 
Checking and un-checking the Different first page and Different Even/Odd pages 
check-boxes will change the tabs available under the page editing area. 

The Page height bars
To the right of the page itself you can see two vertical bars. The Blue bar indicate 
the total height of the edit area in the page range—that is, the page height minus
the top and bottom margins. The height is indicated in points and you can 
manipulate the edit area height by clicking and typing a new value or by clicking 
the number and dragging up (to shrink the top and bottom margins) or down (to 
expand the top and bottom margins). 
The Green bar indicates the page editing area minus the header and footer 
height. The header/footer bar will be identical to the page bar if there are no 
headers or footers for this page type.

The page margin bars
The red T bars at the top, bottom, left and right end of the page allow you to 
change the size of the page margins. The size is indicated in points and you can 
manipulate the margin size by clicking and typing a new value or by clicking the 
number and dragging up (to grow the margins) or down (to shrink the margins). 

The resize handles
At the top, bottom, left and right margins, as well as at the top or bottom of the 
header and footer there you’ll find resizing handles you can drag up, down, left or 
right (as fits the case) to resize the margins, the headers or the footers. 

Adding image area
Through the area at the centre of the page you can add background images, by 
clicking on the Add image icon or by dragging them on top of it. Once added, you 
can manipulate the background image attributes by pressing the Edit button 
(bottom right of the image) or eliminate it by clicking the Delete button (top left of
the image). 
The editing options for background image are identical to those available with 
the Page palette.
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Hiding headers and footers
If you’ve created a footer or a header for a page, you can always hide it by clicking 
the Hide header/footer button.

Background colour buttons
At the bottom-left of each page you design there is a Background colour button 
you can click to set the background colour. 

Header and footer edit area
Clicking in the header or the footer of a page in the Page Editing area you can start 
editing the header or the footer of the page. The options here are identical to 
those you will find when editing with the Page palette.
The header and footer edit areas allow you to edit the header and footer content 
of the page style. 
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Document attributes
This chapter contains information about document attributes and 
how to use them

Should I read this chapter?
You should read this chapter if you intend to use or apply document 
attributes

What are document attributes
Document attributes are sets of attributes that affect the document as a whole. 
Mellel’s preferences contain several options for applying attributes that will affect 
any new document. Those options, however, are overridden when an attribute is 
applied separately to a document. For example, you can set the default 
background colour for all new document in the Preferences, but if you set the 
background colour for a document via the Document setup sheet, the setting there
will override any general preference. 

Stuff you can do
To... Do this Keyboard Shortcut

Set the page size for a 
document

1 Choose File > Page Setup...
2 From the Paper Size pop-up menu choose a paper 

size. 

Cmd+Shift+p

Set the document 
orientation

1 Do one of the following:
• Choose File > Page Setup... Or,
• Choose Window > Palettes > Page to open the 

Page palette, and click Margins and Orientation....
2 Click the desired Orientation, or Choose Portrait or 

Landscape from the Orientation pop-up menu (with 
the second). 

Cmd+Shift+p

Set printing options 1 Choose File > Page Setup...
2 Choose from the options in the Page Setup 

dropping sheet. 

Cmd+Shift+p

Set the document 
page margins

1 Choose Window > Palettes > Page to open the Page 
palette, and click Margins and Orientation...

2 Enter the desired values for top, left, right and 
bottom margin. 

Note: this option has moved to the Page palette. It is 
kept here for legacy reasons. 



Set the default page 
margins for all new 
documents

1 Choose Mellel (menu) > Preferences....
2 In the Document setup tab and enter the desired 

values for top, left, right and bottom margin.

Set the default for 
mirrored margins for 
all new documents

1 Choose Mellel (menu) > Preferences....
2 In the Document setup tab check the Facing pages 

option.

Set the background 
colour (on screen)

1 Choose File > Document Setup....
2 Check the Background (on screen) check-box and 

click the colour button to set the background 
colour. 

Set the default for 
background colour (on
screen) for all new 
documents

1 Choose Mellel (menu) > Preferences....
2 In the Document setup tab check the Background (on 

screen) check-box and click the colour button to set
the background colour. 

Set the binding 
direction for the 
document

1 Choose File > Document Setup....
2 Choose an option from the Binding Direction pop-

up menu. 

Set the default for 
background colour (on
screen) for all new 
documents

1 Choose Mellel (menu) > Preferences....
2 In the Document setup tab choose an option from 

the Binding Direction pop-up menu. 

Show or hide page 
margins

1 from the Show button pop-down menu choose 
Page margins.

Set the default show or
hide preference for all 
new documents

1 Choose Mellel (menu) > Preferences....
2 In the Appearance tab check or un-check Page 

margins.

Set the keywords for a 
document

1 Choose File > Document info... and under the General
section enter the keywords into the available text 
fields. 

Set or change the 
value for a variable

1 Choose File > Document info... and under the 
Variables section enter the value for the variable.

Enter a variable into 
the document

1 Click in the document where you want to enter the
variable.

2 Choose Insert > Document Variables > [variable]. 

change the default 
Value of a variable

1 Choose Mellel (menu) > Preferences....
2 In the Document setup tab, double-click a variable’s 

Default Value field and set its value.
Note: Any changes you make to variable defaults will take 
effect when you open a new document and will not affect 
any currently open document.

change the Title of a 
variable

1 Choose Mellel (menu) > Preferences....
2 In the Document setup tab double-click a variable’s 

Title field and change its name. 
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Set the default 
document styles

1 Choose Mellel (menu) > Preferences....
2 In the Styles tab choose the default styles from the 

various pop-up menus. 

Page setup attributes
Your page setup options depend on your printer and the printer drivers installed 
in your system. Mac OS X offers several default options that are available even if 
you do not have any printer drivers installed: page size (from a predetermined list 
or customised), page orientation (portrait, landscape from right-to-left, and 
landscape from left-to-right), and scale.
The Page Setup dialogue box offers several options:
Settings: this pop-up menu allows you to switch between the different settings 
you’ve saved.

• Format for: allows you to select a printer driver and access the Fax and Printer
System Preference, and create and save custom paper size. 

• Paper Size: allows you to select the paper size from a list of paper sizes. 

• Orientation: allows you to choose the print orientation—portrait, 
landscape facing right, or landscape facing left.

• Scale: allows you to scale the printed page in order to fit the selected paper 
size. 

• Custom Paper Size: allows you to set a custom paper size. 

Note: Margins set here are ignored by Mellel.

• Summary: displays a summary of the page setup settings.

Document Setup attributes
The Document Setup dropping sheet includes options to set the binding direction, 
and to set the non-printing background colour. 
Options set in the Document Setup dropping sheet apply only to the currently 
used document. You can apply those attributes for any new document via the 
preferences. 
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Figure 62: Document setup dropping sheet

Binding direction
The binding direction pop-up menu allows you to set the general direction of the 
text in the document: from left-to-right or from right-to-left. The binding 
direction affects, for example, the default paragraph direction, and the direction 
of new notes (footnotes or endnotes) you create.

Background colour
The background colour option allows you to set the background colour for the 
document. This background colour is a non-printing background. If you want to 
set a printing background colour, which is a page attribute, set it through the Page
palette or the Edit Page Style dialogue box. 

Document Info attributes
The Document Info dropping sheet allows you to set some general document 
options, such as keywords, variables, markers, and so on. 
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Figure 63: The Document Info sheet

Keywords
The General section of the Document Info sheet displays the Keywords, Category, 
and Comments fields. The fields serve as general info about the document, and 
are not enterable (that is, you cannot enter them into the document text).

Variables
Document variables are a set of 20 variables you can insert (through the Insert 
menu) into the document. There are two fields in the variables list: Label and 
Value. In the Preferences, you can set both the label (e.g., Author, email, receipt 
number, etc.) for the variable, and the variable itself. The setting in the preferences
will hold for every new document created after the change. Through the 
Document Info you can change the value of a variable, overriding the default 
setting in the Preferences. 
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Document variables are useful when you wish to re-use information. For example,
you can use variables with telephone numbers or addresses, so that when those 
change, you will only need to change the variable, and the change will be 
reflected in all documents using this variable. 

Document Defaults
Document defaults are various options available via the Preferences. Those 
options are available under the Appearance, Open & Save, Document Setup and Styles
tabs. Relevant here, especially, are the default styles settings under the Styles tab, 
which allow you to set the various defaults for styles used in the document.
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Notes (footnotes, endnotes)
This chapter explains what notes (footnotes and endnotes) are and 
how to use them

Should I read this chapter?
You should read this chapter if you intend to use footnotes or endnotes in 
your documents

What is a note?
Footnotes, endnotes, and other types of notes, are special types of comments 
that you can add to the document. The notes typically appear at the bottom of 
each page (as with footnotes), or at the end of the document (endnotes), and are 
linked via a special link (reference symbol) inserted into the document text. 
Notes have include several elements:

• Reference symbol: A link from the document text to the note. The reference 
symbol is usually numbered (e.g. as 1, 2, 3, etc., or A, B, C, etc.)

• Separator: A line separating the main document text from the notes. 

• Note symbol: A symbol at the beginning of the note. The numbering of the 
note usually coincide with the reference symbol numbering.

• Note text: The text of the note. 

Note 
symbol

Reference 
symbol

Note text

Separator

Figure 64: Elements in notes



Note streams
Note streams are a unique feature in Mellel, allowing you to enter numerous 
‘streams’ (sequences) of footnotes and endnotes. 
The example below illustrates the way note streams work in Mellel:

Figure 65: Note streams

Mellel here allows you to have three different ‘streams’ of footnotes: One with 
Arabic numbering, a second with Greek numbering, and the third with symbols. 
The ability to enter concurrent note streams is very useful in cases where notes to 
the text come from more than one source, such as in the case of translator notes 
and author notes, or adding personal notes to the text while writing, without 
them interfering with the regular run of notes. 

Stuff you can do
To... Do this Keyboard Shortcut

Insert a footnote • Choose Insert > Note > Footnote.
Note: this (the instruction and the shortcut) are true by 
default, but can be altered. 

Cmd+Shift+N

Insert an endnote • Choose Insert > Note > Endnote.
Note: an endnote stream of notes will be available if it is 
part of a template or if you’ve created such a stream. 

Can be set by user

Jump from a reference 
to its note

• Double-click the note reference (number or 
symbol in the text).
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Jump from the note to 
its reference

• Double-click the note number or symbol. Or,
• Press the Escape key.

Esc

Delete a footnote or an
endnote

• Select the notes reference (number or symbol in 
the text) and press the Delete button. The note will 
be removed (deleted).

Move a note to 
another location

Select the note reference (number or symbol in the 
text).
1 Choose Edit > Cut.
2 Place the insertion point where you want to move 

the note reference to.
3 Choose Edit > Paste. The note reference and the 

note itself will be moved to the new location.

Move a note from one 
stream to another

1 Select the note in the text and do one of the 
following:
• Choose Edit > Change and select a different 

stream. Or,
• Ctrl-click to open the contextual menu. From the

Change sub-menu, select a different stream. 

Switch a note stream 
from footnotes to 
endnotes and vice 
versa

1  Choose Insert > Note > Edit Note Attributes.
2 In the Edit Note Attributes dialogue box, select the 

note stream.
3 Do one of the following:

• In the placement area, select a placement from 
the Position pop-up menu. Or,

• From the Note style pop-up menu, select a style 
which places the notes according to your wishes.

Assign or change a 
keyboard shortcut to a 
note stream

1 Choose Insert > Note > Edit note attributes....
2 Select (click) the note stream to which you wish to 

add a shortcut.
3 Click in the right end of the note stream list and 

select a shortcut.

Create a new stream 1 Choose Insert > Note > Edit Note attributes....
2 In the Edit Note attributes sheet, click the Add stream 

button and name the stream.
3 Set the style attributes or select a style from the 

Note style pop-up menu.

Delete a stream 1 Choose Insert > Note > Edit Note attributes....
2 Select a stream from the Stream list and click the 

Delete stream button. You will be prompted to 
decide if you want to delete the notes completely 
or attach them to an existing stream. 

Note: Streams are document specific (because they 
contain document-specific data).
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Change the name of a 
stream

1 Choose Insert > Note > Edit note attributes....
2 Double-click the stream’s name in the stream’s list 

and enter the new name for that stream.

Change the position of
a stream

1 Choose Insert > Note > Edit note attributes....
2 Click on a stream and drag it up or down to the 

desired position. When a horizontal bar appears 
above the desired position, release the mouse 
button.

Note: The position (hierarchically) of the note stream is 
important. When multiple streams reside in the same 
location (e.g. two streams of footnotes), Mellel will order 
the streams at the bottom of the page based on their 
position in the stream list.

Set the start number 
for the note stream

1 Choose Insert > Note > Edit Note attributes....
2 Set the value for Start at number. 
Note: for more details about Start At attributes, see the 
section about Start at.

Highlight notes in the 
text

1 Choose Insert > Note > Edit Note attributes....
2 Check the option Highlight notes on screen and (or) 

Highlight notes in print.

Set the height limit for 
notes

1 Choose Insert > Note > Edit Note attributes....
2 Under Height Limit set the height limit. 
Note: for more details about Height limit, see the section 
about Height limit.

Set the placement of 
notes (at the bottom of
the page, end of 
document, etc.)

1 Choose Insert > Note > Edit Note attributes....
2 Under Placement choose the appropriate option 

from the Position pop-up menu. 
Note: for more details about placement of notes, see the 
section about Placement of notes.

Set the resetting 
options for note 
numbering

1 Choose Insert > Note > Edit Note attributes....
2 Under Placement choose the appropriate option 

from the Numbering pop-up menu.
Note: for more details about numbering and resetting of 
notes, see the section about Placement of notes.

Set of note reference 
and notes must reside 
on the same page

1 Choose Insert > Note > Edit Note attributes....
2 Under Placement un-check the appropriate option 

from the Numbering pop-up menu.
Note: for more details about splitting of notes, see the 
section about Placement of notes.

Set of splitting rules for
note text

1 Choose Insert > Note > Edit Note attributes....
2 Under Placement choose the appropriate option 

from the May split pop-up menu.
Note: for more details about splitting of notes, see the 
section about Placement of notes.
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Assign a note style to a
note stream

1 Choose Insert > Note > Edit Note attributes....
2 Select the note stream to which you wish to apply 

a note style.
3 Select a note style from the Note style pop-up 

menu.
Note: You can apply the same style to several note 
streams.

Set the note reference 
(in the text) attributes

1 Choose Insert > Note > Edit Note attributes....
2 In the Reference symbol area choose the desired 

options from the Type pop-up menu (numbering of
note), the Format pop-up menu (the note reference
format), the Character style pop-up menu, and 
check or uncheck the Superscript check-box.

Note: for more details about reference symbol, see the 
section about Reference symbol.

Set the note symbol 
attributes (in the 
notes)

1 Choose Insert > Note > Edit Note attributes....
2 In the Note symbol area choose the desired options 

from the Type pop-up menu (numbering of note), 
the Format pop-up menu (the note format in the 
notes area), the Character style pop-up menu, and 
check or uncheck the Superscript check-box.

Note: for more details about note symbol, see the section 
about Note Symbol.

Set the note text style 1 Choose Insert > Note > Edit Note attributes....
2 In the Note text style area choose the desired 

options from the Paragraph pop-up menu or the 
Character style pop-up menu.

Note: for more details about note symbol, see the section 
about Note Text style.

Set the appearance of 
the separator

1 Choose Insert > Note > Edit Note attributes....
2 In the Separator area choose the desired options 

from the Alignment, the Weight, the Width, the Line, 
the Colour, the Space Above, and Space below pop-
up menus, widgets and text fields.

Note: for more details about note symbol, see the section 
about Separator.

Note menu
The note menu (Insert > Note) allows you to view and select the stream under 
which you wish to insert the note. It also allows you to edit note stream and note 
attributes.
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List of 
streams

Edit note
options

Figure 66: Note menu

• List of streams: displays the streams used in a document.

• Edit note options: allows you to open and edit all stream and note options. 

Edit note attributes sheet
The Edit note attributes sheet allows you to edit both the streams, the streams list 
and the note attributes. 

Figure 67: Edit note attributes sheet
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The Note Streams list
The Note Streams list displays the streams available with the current document. 
You can add, delete and assign keyboard shortcuts to streams for quick entry. 

Keyboard 
shortcut

Stream 
name

Add a new 
stream

Delete a 
stream

Figure 68: Note streams area

• Note name: displays a list of the note streams that can be used in the 
document. 

• Keyboard shortcuts: displays the keyboard shortcut assigned to a note 
stream.

• Add stream: will add a new stream to the stream list.

• Delete stream: will delete the selected stream. 

Height limit
The Height limit option determines the amount of space, as percentage of the 
page, that the notes may occupy. The setting here may have far reaching 
influence on your document, as you can see in the following table
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Table 9: Various height limit settings

20 per cent 50 per cent 100 per cent

When the height limit is set very low, some of the text linked to notes may flow to 
the next page. This is suitable when you want to avoid a situation where a long 
note covers the bulk of a page, or when you have very few notes. If your 
document contains many notes but they are relatively short, you should opt for 
setting the height limit to around 50 or 60 per cent. In all other situations, use the 
default setting (100 per cent). 

Highlight Notes
The Highlight Notes attributes enables you to determine if you want to highlight 
the reference to notes in the document window and in print. Highlighting notes 
makes them easier to spot, especially if your notes appear in superscript. 

Start at
The Start at attribute allows you to set the starting number for notes for every 
stream. Note that if you select the numbering option “Restart Every Page” and 
“Start at” to a number other than 1, this number will be used as the start number 
on each page.

Placement of notes
The Placement attribute allows you to set where the notes of a certain stream will 
be placed, their type of numbering, and position of notes versus note references.
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Figure 69: Placement options

• Position: This option determines where the notes will be placed: at the 
bottom of the page (footnotes), directly below the text on each page, or at the
end of the document (endnotes).

• Numbering: determines if the note numbers will be contiguous or will restart 
with every page, every section, or every page range. If the option selected is 
Restart every page/section/page range, the attribute May separate from reference 
will be disabled.

• May separate from reference: when the note reference and the note itself 
cannot reside on the same page (for example, when you have a very long 
paragraph that cannot be split and a very long note) you can allow Mellel to 
split note references from their notes.

Table 10: May split from reference or not

May split from reference May not
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When May split from reference is checked, with a long paragraph and a long note,
Mellel moves the note to the next page, separating it from the note reference. 
When the option is not checked, Mellel moves the note and the note reference to 
the next page (and thus creating a wider ‘block’ of white space at the bottom of 
the page). 

Tip: If the value for “Height Limit” is set to less than 100 per cent and “May separate from ref-
erence,” is checked, Mellel will not be forced to create a white ‘block’ between the notes and
the text, but may flow some notes to the next page. Use this option sparingly and only 
when you know what you’re doing.

• May Split: allows you to choose where notes may be split, if they need to be 
split.

Table 11: May split from reference or not

Split anywhere Between paragraphs Nowhere

With Split anywhere, Mellel will split the note between pages, with the main focus 
on nice, even layout of the document. Split between paragraphs will avoid splitting 
between paragraphs, which may cause the text too be laid out less nicely, but will 
keep the paragraphs in the notes as one whole. With Nowhere selected, Mellel will 
ignore any consideration for the sake of keeping the note as one unit.

Reference symbol
The reference symbol section of the Edit note attributes sheet contains several 
attributes related to the way the note reference symbol appearance in the text. 
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Figure 70: The Reference symbol area

• Type: allows you to set the type of note reference numbering scheme to use. 
There are 11 different options here: Arabic numerals, asterisks, Roman small 
and capital, Latin small (a) and capital (A), symbol, Hebrew numbering, Greek 
numbering, Arabic numbering, and Persian numbering.

• Format: sets the format of the note reference symbol. For example, if you 
have selected Roman numerals as the note reference type and (#) as format, 
the note reference will appear in the text as (i), (ii), (iii), etc.

• Character: allows you to set the character style for the note. Through the pop-
up menu, you can access all the character styles you have created. In addition, 
you have the option to select Use surrounding text, which will make the note 
reference adopt the character style of the text surrounding it.

• Superscript: allows you to determine if the note reference will appear in 
superscript letters or not.

Note Symbol
The note symbol area contains several attributes related to the way the note’s 
symbol will appear in the notes. 

Figure 71: The Note symbol area

• Type: allows you to set the type of note symbol numbering scheme to use. 
There are 11 different options here: Arabic numerals, asterisks, Roman small 
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and capital, Latin small (a) and capital (A), symbol, Hebrew numbering, Greek 
numbering, Arabic numbering, and Persian numbering.

• Format: sets the format of the note symbol. For example, if you have selected 
roman numerals as the note symbol type and (#) as format, the note symbol 
will appear (i), (ii), (iii), etc.

• Character: allows you to set the character style for the note symbol. Through 
the pop-up menu, you can access all the character styles you have created.

• Superscript: allows you to determine if the note symbol will appear in 
superscript letters or not.

Note Text style
The Note text style area allows you to set the default paragraph and character 
style for the note text.

Figure 72: The Note text style area

• Character: allows you to select the character style for the text of the note.

• Paragraph: allows you to select the paragraph style for the text of the note.

Separator
The Separator area allow you to set all the attributes related to the separator and 
space above and below it. 
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Figure 73: The Separator area

• Alignment: allows you to set the separator line alignment.

• Weight: allows you to set the separator weight (thickness). Note that any line 
weight below 1 point may look grey and not black on the screen; however, it 
will look fine in print.

• Width: determines the width of the separator line, in percentage, relating to 
the page width. This value should update when you change the document 
margins via the Page palette.

• Line: The type of line you would like to have with the separator. 

• Colour: allows you to set the colour of the separator line.

• Space Above and Space Below: allow you to set the space above and below 
the separator, that is, the space between the last line of text in the page and 
the separator line, and between the separator line and the first note at the 
bottom of the page or the end of the document.

Note: The space above and below the separator is measured using the currently selected 
measurement unit.

Tip: To have the endnotes start on a page of their own, at the end of the document you 
should place the insertion point at the end of the text and choose Insert > Control Charac-
ters > Page Break. The endnote will appear on a separate page after the main text, with an 
empty line where you will be able to insert a title (such as “Work Cited”).

Note Style area
The Note Style area (top part of the Edit Note Attributes sheet) contains the note style
list and options to create new styles, delete them, and save them.
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• Note style menu: includes all the note styles available with the currently 
selected style set. 

• Save style: allows you to save the changes to a style. This button is initially 
disabled, until you change the style. 

• New style: allows you to create a new note style. 

• Delete style: allows you to delete the currently selected style. 
For more info about note styles see the Note styles section.

Note styles
What is a note style
A note style is a set of formatting attributes you can apply to a note stream, in 
order to set how it will appear in the document text. Note styles can be applied to
any note stream (or note streams).

Stuff you can do
To... Do this Keyboard Shortcut

Create a new note 
style

:Use any of the following methods:
1 Choose Insert > Note > Edit Note attributes... and click 

the New style button. A new style, based on the 
selected style, will be created. Or,

2 Choose Style Set > Edit Style Sets... and in the Note 
area click the Add button. Mellel will create a new 
note style. Or,

3 Choose Style Set > Edit Style Sets... and in the Note 
area click the Duplicate button. Mellel will create a 
new note style based on the currently selected 
note style.
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Start editing a note 
style

1 Do one of the following:
• Choose Insert > Note > Edit Note attributes... Or,
• Choose Style Set > Edit Style Sets..., then double-

click a style in the Style area.
2 Edit the style’s attributes, and do one of the 

following:
• If you’re editing in the Edit Note attributes sheet, 

click the Save style button to save, or select the 
style from the Note style pop-up menu to discard. 

• If you’re editing in the Edit Note style dialogue 
box, click the Save button to save your changes, 
or Cancel to discard. 

Note: Any saved changes will affect all documents using 
this style. 

Assign or change a 
note style

1 Choose Insert > Note > Edit Note attributes....
2 Select the note stream to which you wish to apply 

a note style.
3 Select a note style from the Note style pop-up 

menu.
Note: You can apply the same style to several note 
streams.

Save changes to a note
style

1 Choose Insert > Note > Edit Note attributes....
2 Make changes to the note attributes and then click 

the Save style button. 

Delete a note style 1 Choose Insert > Note > Edit Note attributes....
2 Choose a style from the Note style pop-up menu 

and click the Delete style button. 

Edit a note style’s 
name

Use any of the following methods:
• Choose Style set > Edit style set... and in the Note area 

select the desired style and then click again to start
editing it, or Double-click the style’s name.

Note Style area
The Note Style area (top part of the Edit Note Attributes sheet) contains the note style
list and options to create new styles, delete them, and save them.

• Note style menu: includes all the note styles available with the currently 
selected style set. 

• Save style: allows you to save the changes to a style. This button is initially 
disabled, until you change the style. 

• New style: allows you to create a new note style. 

• Delete style: allows you to delete the currently selected style. 
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For more info about note styles see the Note styles section.

Editing note styles
You can create and edit note styles either through the Edit note attributes sheet or 
through the Edit Note style dialogue box. The options offered by either are 
identical, as regarding note styles. As the Edit note attributes sheet also contains the
stream list, it will probably be easier and more straightforward to work with it.

Edit note style dialogue box
The Edit Note style dialogue box is your central hub for editing note styles. Here, 
you can edit and change every element in a note style. The Edit Note style dialogue 
box is identical in most of its features to the Edit note attributes palette, and its 
attributes are reviewed with the Edit note attributes sheet section.

Style name
The Style name field allows you to name and rename a style whenever you open 
the Edit note Style dialogue box for editing a style. 
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Lists
This chapter explains what lists are and how to use them

Should I read this chapter?
You should read this chapter if you intend to use lists and numbered lists in 
your documents

What is a list
A List is a special paragraph attribute that allows you to create a series of 
paragraphs preceded by a numbering or a bullet. You can create an unlimited 
number of such lists in a document, stop and continue lists, copy and paste list 
styles, and so on. You can customise the list appearance, numbering, or bullet 
type, change their position in the list and their formatting.

The List palette
The list palette includes options to start, manage and reset a list, a pop-up menu 
to select the type of list you want, delete and create new lists, and options to 
control the appearance of the list. 
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Figure 74: The List palette

List control buttons
The list control buttons at the top of the List palette allow you to start, move up or
down a level, and reset a list. 

Table 12: The list control buttons
Button What does it do?

• Decreases the list by one level. 
• If the list is at the base level, it resets the list.

• Starts a list if there is no list. 
• Increases the list by one level. 

• Resets the list.

Note: The list control buttons change when you change the paragraph directionality. 
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List styles tab
The List Style tab of the List palette allow you to change list styles, create list 
styles, duplicate styles, delete style, and discard changes to styles. The tab 
contains three parts:

• Style list: contains the list of available list styles. 

• Document styles: contain the list of list styles used in the document, but do 
not exist in the style set.

• Buttons: which allow you to save changes to the list style style, create a new 
list style, delete the selected list style, or start editing it in the Edit list styles 
dialogue box.

List options
Mellel offers a rich set of options to manipulate the appearance and behaviour of 
a list. Those options include setting the symbol type and format, the start number,
the character style and variation, the symbol position, indent, and margin. Any 
selection or change you make will be applied to the level you’re currently at, not 
to all the levels in the list. All the options are saved with the List style.

• Symbol type: Allows you to select the numbering scheme or symbol to be 
used with the current level in the list. This menu includes all the numbering 
schemes available in Mellel and adds several bullet symbols you can choose 
from. 

• Start at: Allows you to set the number at which the list will start. The setting 
here does not affect the appearance of the list if you’re using a bullet symbol, 
but if you decide to apply a numbering scheme at a later date, your list will 
start at that set number. You can set a different start number for every level.

• Symbol format: Allows you to append common punctuation marks to the 
symbol at the current level. 

• Char. style: Allows you to select the character style that will be used with the 
symbol at the current level. If you change this character style in the future, 
your changes will be immediately reflected in the lists using that style.

• Char. variation: Allows you to select the variation for the selected character 
style that will be used with the symbol at the current level. 

• Margin: Allows you to set the distance of the next level from the current level.
For example, if you set the Margin to zero, then the next level will start at the 
same level as the current one. The Margin marker will also appear in the Ruler 
if you position the insertion point inside a list. 
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• Symbol position: Allows you to set the distance of the symbol from either the
page margins (with the initial level) or the preceding level margin (for the rest 
of the levels). The Symbol position marker will also appear in the Ruler (it will 
look like a small dot) if you position the insertion point inside a list. 

• Indent: Allows you to set the distance of the text from the symbol. For 
example, if you set the Symbol position to 3 points and the Indent position to 
15 points, then the distance between the symbol (start) position and the text 
(start) position will be 12 points. The Indent marker will also appear in the 
Ruler if you position the insertion point inside a list. 

Figure 75: The symbol position, indent and margin in the Ruler

Edit list style dialogue
The Edit list style dialogue box is your central hub for editing list styles. Here, you 
can edit and change every element in a list style. The Edit list style dialogue box is 
identical in most of its features to the List palette, but allows you to edit the list 
style with more comfort, seeing the list style as a whole, and not in bits and parts 
in the document.
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Figure 76: List style dialogue

Style name
The Style name field allows you to name and rename a style whenever you open 
the Edit List Style dialogue box for editing a style. 

The list levels area
The list levels area displays all ten levels of a list at once, allowing you to edit them
separately while viewing the impact of a change over the look of the list as a 
whole. You can navigate between the various levels in the list with the up/down 
arrow.

Replicate to all
The Replicate to all button allows you to replicate the Margin, Indent, and Symbol 
positions, as well as the character style and character variation to all the levels in 
the list. Its main purpose is to save time when creating a new list, assuming that in
most cases you would want all the levels in that list to use the same character 
style and distance between list levels. 
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Using lists and list styles
Lists are very easy to use and manipulate. 

To start a list:
Do one of the following:

• In the document area, press Cmd+]. Or,

• Choose Edit > List > Increase one level. Or, 

• Press the Increase one level button.

To create a new list item:
• In a list, press the Return key. 

To increase the list:
Do one of the following:

• In the document area, press Cmd+]. Or,

• Choose Edit > List > Increase one level. Or, 

• Press the Increase one level button.

To decrease the list:
Do one of the following:

• In the document area, press Cmd+[. Or,

• Choose Edit > List > Decrease one level. Or, 

• Press the Decrease one level button.

To reset a list:
Do one of the following:

• In the document area, press Cmd+\. Or,

• Choose Edit > List > Reset list. Or, 

• Press the Reset list button. Or,

• Press the Decrease one level button until the list is reset.

To apply list attributes to another list:
1 Choose Edit > Copy Special > List attributes.
2 Place the insertion point anywhere in another list.
3 Choose Edit > Paste. 
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To resume an interrupted list:
1 Start a new list.
2 In the List palette, change the Start at number to the number where the earlier 

list stopped at + 1 and press the Return key.

To split a list into two lists:
1 Place the insertion point where you want the split to occur.
2 Press the Reset button in the List palette. The list will break into two separate 

lists. 
To turn text into a list:
1 Select some text and click the Start list button in the List palette. 

To change the style for the whole list:
1 Place the insertion point anywhere in the list.
2 In the List palette, select another style from the List style pop-up menu.

To copy one item with its list attributes to another list:
1 Triple-click the paragraph you wish to copy.
2 Choose Edit > Copy.
3 Place the insertion point where you want the paragraph pasted.
4 Choose Edit > Paste.

To copy an item without its list attributes to another list:
1 Do one of the following:

• Select the text you want to copy without triple-clicking. Or,
• Select the text and choose Edit > Copy Special > Plain text. 

2 Place the insertion point where you want the paragraph pasted.
3 Choose Edit > Paste.

To discard ad-hoc changes to a list:
• Choose any style from the List style pop-up menu.

Editing List styles
There are two ways to create and edit list styles: by example (follow-me), saving 
changes via the List palette Styles tab; and by using the Edit List Styles dialogue box. 
These two ways are not mutually exclusive; that is, you can change your mind and
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finish a style you have created by example in the Edit List Styles dialogue box and 
vice versa.

Creating a list style
Mellel offers you several convenient ways to create list styles.

To create a new list style:
Use one of the following methods:

• In the document area, create a list and then click the Create new list style button
in the Styles tab of the List palette. In the New list style dialogue box, name the 
new style and click the OK button. Or, 

• Choose Style Set > Edit Style Sets... and in the List area click the Add button. 
Mellel will create a new list style.

Note: The first method will create a duplicate of an existing style (the one currently used). If 
you want to create a completely new list style, use the second method. 

Editing in the Edit List style dialogue box
Editing a list style in the Edit List style dialogue box is simple and straightforward. 

To start editing a list style in the Edit List style dialogue box:
1 From the Styles tab of the List palette select a list style you wish to edit. 
2 Click the Edit list style button. 
3 In the Edit List style dialogue box, edit the style, then click the Save button to 

save your changes or Cancel to discard. 

Note: Any saved changes will affect all documents using this list style. 

Editing from the document area
Editing a list style from the document area is straightforward and easy, and much 
easier than editing the style in the Edit List style dialogue box, especially when you 
only need to make small changes.

To start editing a list style from within the document:
1 Start a list and apply the style you wish to edit via the List palette. 
2 Edit the list level using the List palette and the Ruler. 
3 Create another list item, increase its level, and repeat step 2. Repeat for levels 

3-10. 
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4 When done with editing click the Save changes to style button in the List 
palette. 

Note: Any saved changes will affect all documents using this list style. Unsaved changes will
affect only the list range where the changes were made. 

Ad-hoc editing
You can edit and change list styles on ad-hoc basis, that is, make changes without 
using the regular list style options. 

To make ad-hoc edits to a list style:
1 Position the insertion point in a list. 
2 Use the List palette and Ruler to make changes to the list style attributes. 

Note: Ad-hoc changes will affect only the list range where the changes were made. It will 
not affect other lists using this style or other documents. 

List style management
Mellel offers several powerful options for list style management, including setting
the default list style for new documents and manipulating the list style menu.

List of 
list styles

Style
management
options

Figure 77: List style management

To set the default list style for new documents:
1 Choose Mellel (menu) > Preferences....
2 In the Preferences dialogue box, click the Styles section.
3 Select the list style you want as the default list style with all new documents. 

Note: The options offered in the List style pop-up menu depend on the style set selected. 

To edit a list style’s name:
Use any of the following methods:
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• Open a style for editing and edit its name in the Style name field. Or,
• Choose Style set > Edit style set... and in the List area select the desired style and 

then click again to start editing it.

To delete a list style:
Do one of the following:

• To delete a list style via the Edit Style Sets dialogue box:
a Choose Style set > Edit style set... 
b In the List area of the Style Sets dialogue box, select the style you wish to 

delete and press the Delete button.

• To delete a style set from the List palette:
a Select the style you want to delete from the List style pop-up menu.
b Choose Delete list style from the List style pop-up menu.

To change the position of a style in the list menu:
1 Choose Style set > Edit style set... 
2 In the List area of the Style Sets dialogue box, select the desired style and drag 

it up or down the style list.

To add a separator line (divider) to the style list in the list menu:
1 Choose Style set > Edit style set... 
2 In the List area of the Style Sets dialogue box, click the Add button and rename 

the style from “untitled style” to a hyphen (“-“). 
3 Drag the hyphen up or down in the list to the desired position.
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Styles and Style Sets
This chapter explains what styles are, what they’re good for, and how 
to use them efficiently

Should I read this chapter?
You should read this chapter if you intend to use styles extensively in your 
documents, and especially if you wish to do that methodically

What are styles
A style is a set of formatting attributes that defines the appearance of an element 
(e.g., a piece of text or an image) in the document. A character style, for example, 
will contain font or font face attributes; and a paragraph style will contain 
paragraph alignment and line spacing attributes.
At heart, styles are no more than ‘shortcuts’ to applying attributes to text. You can 
work without using them at all, and with notes, letters or short documents you’d 
probably be doing the smart thing. But with longer documents, or where 
consistency in styling is required, styles will prove to be an invaluable tool.

Types of styles
Mellel offers several types of styles, each determining the appearance of a 
different type of element in your document:

• Character styles are used to set the appearance of characters in the text. 

• Paragraph styles are used to set the appearance of entire paragraphs.

• Page styles are used to set the appearance of pages and page ranges.

• Section styles are used to set the appearance of sections (mainly, columns).

• List styles are used to set the appearance of bulleted and numbered lists.

• Note styles are used to set the appearance of footnotes and endnotes. 

• Auto-title setups: Although not styles in the strict sense of the word, for most
practical purposes the auto-title setups are used to set the appearance and 
behaviour of Auto-titles, ToC, Mentions, the Outline and Cross references (with
the Auto-title Format element).

Every type of style in Mellel has different, non-converging, attributes. That is, 
attributes set for one type of style are not not also set by another type of style. 
Every style is managed individually in its own dialogue box, while general options
(such as adding or deleting styles) are managed via the Style Sets dialogue box. 



Mellel also supports the use of Formats. Those are not styles, but they do serve the
purpose of a shortcut to some canned format you’ve created. Among those are 
the Find and Replace Actions and Sets, and the Cross Reference formats).

The style menu
Style menus in Mellel contain three parts: 

Style
List

Document
Styles

Menu
Options

Figure 78: The Style menu structure

• Style list: contains the list of styles for this type of style in the style set. 

• Document styles: list styles used in the document that do not exist in the 
style set.

• Menu options: allow you to save changes to the style, create a new style, or 
edit the existing style. 

The Style menu uses several symbols to indicate the status of the style:

Table 13: Status indications in style menus
Symbol Indicate

✔ The currently selected style

+ The style has changed

- The currently selected style when several 
styles are selected (multiple styles)

! The style uses a missing font

◆ A document style
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Document styles
Document styles are styles that are used in a document, but are not included in 
the selected style set. Document styles exist, for example, when you delete a 
style, but there is still text in the document that use it (i.e., refer to it), or when the 
styles used in a document were changed since you’ve last opened it.
The existence of document styles is not an indication that something is ‘wrong’ 
with the document—it simply indicates that it uses styles that are different from 
those you have in the style set.

Changes in styles
Handling changed styles
When you change and save a style, the changes are applied to all currently open 
documents and saved into the Style set. When you open another document using 
the same style set, Mellel needs to know how to handle this document: to change
the document so it reflects the changes you’ve made to the styles it uses; or not 
to change the document, so the changes you’ve made to the style will not be 
reflected in the document. 
Mellel’s Preferences, under the Open & Save section, allow you to make your choice:

Figure 79: Keep or update existing styles

• Preserve document appearance: Choose this option to keep the original 
appearance of the document. Mellel will ignore changes made to the styles 
and display the old, pre-change styles, as document styles (marked with a ◆ 
next to its name).

• Change document appearance: Choose this option to adjust the documents
you open to changes you’ve made to styles. 

Deleted styles
When you delete a style, it is removed from the style list in the style set. Further 
on, when you open a document that uses this style set, if the deleted style is used 
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in the document, Mellel will add the deleted style’s name to the style list as a 
document style (marked with a ◆ next to its name).

Moving a document to another Mac
When you move a document to another computer, the styles in the document 
will appear normally, if the other computer already has the same style set, or as 
document styles (marked by a diamond shape (◆) next to their name) if it doesn’t.

Importing files
When you import documents, Mellel will create document styles for all the styles 
used in the imported document. You can replace those new styles with your 
existing styles by choosing File > Replace Styles... and replacing those styles with 
your own. 

Non existing font
When you remove a font from the fonts folder or when you receive a document 
using a fonts that you do not have, Mellel will indicate the missing font or missing 
font face with a warning sign (!) next to the style’s name in the styles list. The font 
or font face name will appear in parenthesis. The text in that style will look 
different, but the style itself will not change. Once the missing font becomes 
available, the warning will disappear.
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Style sets
Style sets are compilations of page, paragraph, character, note, and list styles. 
Style sets allow you to combine various types of styles to perform specific tasks. 
For example, you can create a style set to use when writing letters, another for 
articles, a third for books, and so on. 
Style sets can be compared to ‘play lists’ in a music player: they offer the option to 
display and use only part of the available styles and make it easier to categorise 
and manage the styles. 
Style sets are saved to a special folder to make them available with every 
document, but the style set you’ve used with a certain document is also saved 
into the document itself. That means that if someone opens this document on a 
different machine she will be able to view the style set (in the Style sets menu), and
change the styles. 

Stuff you can do
To... Do this Keyboard Shortcut

Change a style set 1 Choose Style set > <any style set>
2 Choose one of the options in the Change style set 

sheet and press OK. 

Edit a style set • Choose Style Set > Edit Style Sets.... Cmd+Shift+A

Edit a style in a style 
set

1 Choose Style Set > Edit Style Sets....
2 Choose a style set from the Style set list and double-

click any of its styles to start editing the style.

Cmd+Shift+A

Create a new style set 1 Choose Style set > Edit Style sets... The Edit Style sets 
dialogue box will open.

2 Do one of the following:
• To create a blank set, click the Add button at the

bottom of the style sets list. 
• To duplicate an existing set, click the Duplicate 

button at the bottom of the Style set list. 
3 A new set will be created, with its name open for 

editing. Edit the name, then do one of the 
following:
• Click another style set on the Style set list and 

from its styles drag at least one style of each 
style type into the new style set. You can drag 
styles from any available set. 

• Click the Add button at the bottom of the styles 
list to create at least one style of each style type. 

4 Click Save to save your changes.

Delete an existing style
set

1 Choose Style set > Edit Style sets... The Edit Style sets 
dialogue box will open.

2 Select the style set you want to delete in the style 
set list and click the Delete button at the bottom of 
the style sets list. 



Rename an existing 
style set

1 Choose Style set > Edit Style sets... The Edit Style sets 
dialogue box will open.

2 Select the style set you want to rename and click 
again to open it for editing. 

Make a document set a
global set

1 Choose Style set > Edit Style sets... The Edit Style sets 
dialogue box will open.

2 Click the document style set at the bottom of the 
style set list. 

3 Click the Make Global button.

Style set menu
The Style set menu allows you to view the currently available style sets and 
document specific style sets, move between style sets, and edit the style sets. 

Style set
List

Document
Set
Edit
Style sets

Figure 80: The Style set menu

• Style set list: lists the available style sets alphabetically.

• Document set: If the document contains a style set you do not have, it will be 
displayed here.

• Edit Style sets...: opens the Edit Style sets dialogue box. 

Edit Style sets dialogue box
The Edit style sets dialogue box is the main hub for editing styles. From here you 
can manage and edit all your style sets, manage styles, and edit them. 
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Figure 81: Edit Style set options

• List of style sets: lists all available style sets.

• Locking and unlocking: Clicking on the lock next to the style set allows you 
to lock or unlock it for changes. This is mainly a safety measure.

• Add: adds a blank (empty) new style set.

• Duplicate: duplicates the currently selected style set. 

• Delete: deletes the currently selected style set. 

• Make set global: If a document style set is selected, allows you to turn a 
document set into a regular (global) set. 

Changing style sets
Mellel allows you to change the style set used with a document. This feature is 
useful , for example, to switch between different sets of styles using the same 
style names, thus changing the appearance of the entire document in one fell 
swoop; to streamline documents to certain styles; or to switch from a style set 
used with a document you’ve received. 
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Change style set sheet
When you change from one style set to another, Mellel will drop the Change style 
set sheet to prompt you to decide which style-matching method to use when 
switching sets.

Figure 82: The Change style set sheet

There are three options for matching the document styles:

• Match identical styles: Mellel will match styles that are identical in name and 
attributes. Non-identical styles will become document styles.

• Match by style name: Mellel will match styles by their names, ignoring their 
attributes. Styles without a matching name will become document styles.

• Match by style attributes: Mellel will match styles by their attributes, 
ignoring their names. Styles with attributes that have no exact match in the 
new style set will become document styles. 

When to use which? Matching identical styles is the best choice if you want to 
switch between sets with minimal ‘repercussions’: styles that are identical in every
way will replace the styles in the old style set, and the rest will become document 
style—the document appearance will not change. This option is very useful in 
cases where you’ve created a new set, based on an existing set, and want to move
to the new set smoothly.
Match by style name is a useful choice when maintaining the appearance is not 
an issue. A typical case can be one where you have a ‘work set’ and a ‘print set’. 
Both sets have styles with the same name, but with different attributes. The ‘work 
set’ may have larger text that is easier to work with when writing, and the ‘print 
set’ may have the text set to look better in print.
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Match by style attributes is a powerful streamlining option. It checks to see the 
attributes used in the text and minimise the number of styles used as much as 
possible.
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Tables
This chapter explains what tables are and how to use them

Should I read this chapter?
You should read this chapter if you intend to use tables in your documents

What are tables
The tables option in Mellel was developed with one aim in mind: to offer the most
advanced features without losing simplicity and ease of use. To achieve this task, 
Mellel organises all table options in one concise and clear table palette, thus 
saving the need to switch between a dozen or more different dialogue boxes to 
apply all the options. 
To save space and simplify things, Mellel examines the selected range (the cell or 
cells you have selected) to determine which options will be available, which 
options will be disabled, and what would actually happen when you click or 
select an option. For example, if you select one cell, the Border Selector will 
enable only the four borders of this cell, since those are the only border options 
applicable here. 
If you select two cells vertically, the Border Selector will also show a line 
representing the horizontal line between two (or more) cells selected vertically. As
you will notice, the Line, Weight, and Colour options remain enabled and are 
reusable. That is, they are available and applicable to whichever range of cells you 
have selected. 

To create a table:
1 Do one of the following:

• Choose Insert > Table. Or,
• Click the Insert Table button in the toolbar. 

2 In the sheet that appears, you can change the number of rows and columns in
the table and the table’s direction.

3 Click “Insert Table.”

Note: You can create a table in the document text area, header, footer and in notes.

Note: The table direction determines the table directionality (to the right or to the left), direc-
tion, and its behaviour when changing columns width. You can change the table direction
at any time through the Table direction pop-up menu in the Table palette.



To change the height or width of a row or column:
• Hover above a row or a column border until the cursor changes its shape to a 

two-headed arrow and drag upwards, downwards, to the right, or to the left.

To open the Table palette:
• Choose Window > Palettes > Table

Navigating in a table
Navigation within a table in Mellel is easy and simple. The options are detailed 
with the following table.

Table 14: Table navigation
Key Navigate

Tab Skip from one cell to another

Tab (at the end of table) Adds one row to the table

Shift+Tab Skip one cell back

Option+Tab Jumps to the next tab stop within a cell

Right Arrow (when at the end of the text in a cell) Jumps to the cell to the right

Cmd+Right Arrow Jumps to the next cell and select its content

Left Arrow (when at the beginning of the text in a cell) Jumps to the cell to the left

Cmd+Left Arrow Jumps to the previous cell and select its content

Down Arrow Jumps to the cell below. If at the bottom cell in a table, jumps to the line 
below the table. 

Down Arrow
(when above a table)

Enter the table cell below that best correspond to the insertion point 
position

Cmd+Down Arrow Jumps to the cell below and select its content. If at the bottom cell in a 
table, jumps to the line below the table

Up Arrow Jumps to the cell above. If at the top cell in a table, jumps to the line above 
the table

Up Arrow
(when below a table)

Enter the table cell abvoe that best correspond to the insertion point 
position

Cmd+Up Arrow Jumps to the cell above and select its content. If at the top cell in a table, 
jumps to the line above the table

Shift+Up/Down/Right/Left 
Arrow key

Will extend the selection of cells corresponding to the arrow key
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The Table palette
The Table palette contains all the options to manipulate tables in Mellel. Those 
options include setting the table direction, selecting cells, changing cell borders, 
alignment, padding, fill, and options to add, delete, join, split, and equalise cell 
width.

Figure 83: The Table palette

Table direction
Tables in Mellel are bi-directional. That is, they can run from left to right or from 
right to left. The table editing behaviour when dragging cell borders, adding or 
deleting borders, adding diagonal lines, etc. changes when you change the table 
direction. For example, if you create a Left to Right table that looks like this:
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Figure 84: Left to Right table

when you change the table direction to Right to Left, it will look like this:

Figure 85: Right to Left table

Note that the diagonal line has also changed its direction to accommodate the 
change in the table direction.

Note: Changing the table direction does not affect the text direction within the cells. 

To change table direction:
• Place the insertion point within a table and select “Left to Right” or 

“Right to Left” from the Table Direction pop-up menu.

Selecting Cells
You can select cells in a table using two different methods: manual selection and 
the Select set of buttons.

To select cells manually:
1 Place the insertion point inside a table, then click and drag in any direction 

until all the cells you want to select are displayed as selected (with a grey 
background). 
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2 Release the mouse button. 

Figure 86: Selecting cells manually

To select cells using the Select buttons:
• Place the insertion point inside a table and click the Select Row, 

Select Column, or Select Table buttons to create a selection.

Figure 87: Selecting cells using the Select buttons

Table lines and border selector
The table lines section of the table palette allows you to select and change the 
line type, weight, and colour of cells, cell borders, and diagonal lines in cells. 

Figure 88: Table lines and border selector
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Border Selector
The border selector is used to determine which cell borders will be affected by 
the changes you make in line type, line weight, and line colour. The border 
selector changes contextually depending on the range of cells selected in the 
table. For example, if you have selected just one cell (that is, if you placed the 
insertion point within a cell), the border selector will look like this:

Figure 89: Border Selector

Because only a single cell is selected, only its four borders (drawn in blue) can be 
changed using the border selector. However, when you select two cells vertically: 

Figure 90: Selecting two cells vertically

The border selector will change to look like this:

Figure 91: The border selector after selecting two cells vertically

The added border in the middle indicates that there are horizontal lines between 
cells that can be manipulated. If you further extend the selection:
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Figure 92: When changing the selection

the border selector changes to fit the extended selection and also shows a 
vertical line: 

Figure 93: The border selector reflects the change

There are three different options to change the appearance of a line:

• Line Type: allows you to select between none (no line) and Solid. 

• Weight: allows you to set the width (weight) of the border.

• Colour: allows you to set border colour.

Selecting lines with in the border selector
Mellel offers several options to make border selection very easy and efficient.

To select or deselect borders in the Border Selector:
• Click on the desired border. 

Figure 94: Clicking on the desired border
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To select or deselect adjacent borders:
• Click on the junction between the borders.

Figure 95: Clicking the junction between the borders

To select only one border and deselect the rest:
• Press the Option key and click on the desired border.

To select only adjacent borders and deselect the rest:
• Press the Option key and click on a junction between the borders.

Figure 96: Clicking the junction between the borders with Option pressed

To change the appearance of cell(s) borders:
1 Select the borders you wish to change.
2 Select the type of line (solid or none), the line width, and the line colour (the 

last two are active only if you have selected Solid as line type).
3 To change other borders or to override the changes you have made before, 

simply repeat steps 1 and 2. 

Creating diagonal lines
When a single cell is selected, you can add a diagonal line from top-right to 
bottom-left, or from top-left to bottom-right.

To create a diagonal line:
1 Click in a cell where you wish to create a diagonal line.
2 Option-click on one of the diagonal lines in the Table palette.
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3 Select Solid from the Line Type pop-up menu. 
4 Change the Weight and Colour options as needed.

To create text labels in a cell with a diagonal line:
1 Create the diagonal line as explained above.
2 Click anywhere in the cell containing the diagonal line.
3 In the Table palette, set Alignment: Justify.
4 Type your two labels (for example, “Numbers” and “Letters”) on two different 

lines (separated by Return). 
5 Place the insertion point within the first label (in this example, “Numbers”).
6 In the Paragraph palette, click the Align right button.
7 You can now set the font, size, colour, etc. of your text.

To delete an existing diagonal line:
1 Click to place the insertion point in a cell where a diagonal line exists.
2 Press the Option key and click on the diagonal line in the border selector.
3 Select None from the Line pop-up menu.

Vertical Alignment
The Alignment pop-up menu allows you to change the vertical alignment of text 
within a cell. This option is useful when you want to give your tables an orderly 
appearance, or when you want to improve the appearance of merged cells when 
placed alongside unmerged cells. 

To change the vertical alignment of text:
1 Select a range of cells for which you wish to change the alignment.
2 Select one of the options from the Alignment pop-up menu.

Figure 97: Cell with text aligned to the top
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Figure 98: Cell with text aligned to the middle

Figure 99: Cell with text aligned to the bottom

Figure 100: Cell with text justified vertically (Justified)

Cell Padding
Cell padding determines the minimal distance from the innermost edge of the 
border to the content of the cell. In Mellel, this distance is measured in points 
from None (no padding) to 5 points. The padding is maintained even if you 
change the border weight (i.e., the borders would not overlap the text). The 
default padding value is 2 points, and it is advisable not to change this value 
unless you are absolutely sure you know what you are doing.

To change the padding of a cell:
1 Select a range of cells for which you wish to change the padding.
2 Select one of the options from the Padding pop-up menu.
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Background (colour)
You can set the background colour for a single cell or a selected range of cells. 
Each time you set the background colour for a cell, this setting will override any 
existing fill setting. 

To change the background colour of a cell:
1 Select a range of cells for which you wish to change the background colour.
2 Choose Solid from the Background pop-up menu and click the colour button. 

The standard colour change window (“Colours”) will open. Select the desired 
background colour and close the “Colours” window.

Options
In this section of the Table palette, you can use options to add rows and columns, 
merge cells, split cells, equalise cell width, and delete cells.

Table 15: Table options
Option Image

Add Row

Add Column

Split horizontally

Split Vertically

Merge Cells

Equalise Column Width

Delete Cells, rows, columns

Adding rows and columns
The Add Row and Add Column options are necessary when you need more rows 
or columns to contain all the content you want to include in a table.
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To add a row to a table:
1 Place the insertion point anywhere within a table.
2 Click the Add Row button. The row will be added below the bottom row in the

table and will inherit the attributes of the last row in that table. 

To add a column to a table:
1 Place the insertion point anywhere within a table.
2 Click the Add Column button. The column will be added to the right or left 

end of the table (depending on the table direction), and it will inherit the 
attributes of the end column in that table.

Note: Sometimes you will need to add a row or a column not at the end of the table but just
above or below a certain point. To do that, you will need to use the Split Horizontally or 
Split Vertically options:

To add a row in place:
1 Select the entire row below which you wish to add another row.
2 Click the Split Horizontally button.

To add a column in place:
1 Select the entire column to the right or left of which you wish to add another 

column.
2 Click the Split Vertically button.

Tip: You might want to consider selecting the columns you have added alongside other 
columns and use the Equalise Width option to equalise their width.

Merging Cells
Cell merging allow you to create a cell that will stretch over or next to other cells. 
This option is useful, for example, when your table need to contain categories and
sub-categories as in the small example shown below:

Figure 101: Example with merged cells
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Here, the cells for “This Year” and “Next Year” need to stretch over all four quarters, 
a task best achieved using merging of cells. Cell merging can be performed on 
any selected range of cells, including the whole table. When you merge cells, 
Mellel also merges the cells content in the joined cells.

To merge cells:
1 Select the range of cells to merge.
2 Click the Merge Cells button in the Table palette. 

Splitting cells
When you split table cells in Mellel, you create two or more cells, rows, or columns
in the space of one. This option is useful for much the same purposes as cell 
merging, but the other way around. For example, the example table above was 
created from an 8 columns table by merging the top eight cells into two 
expanded cells. The same table can be created from a 2 columns table by splitting
and re-splitting the bottom two cells. 

To split cells:
1 Select the cell or cells to split.
2 Click the Split Cells Horizontally or Split Cells Vertically button in the Table 

palette. 

Tip: You can use the split options to add a column or a row.

To add a row using Split Horizontally:
1 Select the entire row below which you wish to add another row.
2 Click the Split Horizontally button in the Table palette. 

To add a column using Split Vertically:
1 Select the entire column to the right or left of which you wish to add another 

column.
2 Click the Split Vertically button in the Table palette. 

Equalising cell width
The equalising cells option allows you to equalise the width of columns in a 
selected range. This option is useful when you want to give your table an orderly 
appearance, or as a quick fix to various unneeded changes in cell width.
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To equalise cell width:
1 Select two or more cells horizontally. 
2 Click the Equalise Width button in the Table palette.

Deleting entire rows or columns from a table
Mellel offers two types of deleting in tables: deleting an entire row or column 
(that is, deleting the actual cells and all the content in the cells), and deleting only 
the content within the cells (leaving the cells intact, but empty).
The Delete Cells option (the right-most button) in the Table palette enables you to
delete one (or more) entire row or column. For example, suppose you have a table
with 3 columns and 6 rows. If you use the Delete Cells option to delete a row, you 
will have only 5 rows left in your table.
In order to delete one (or more) entire row or column, the entire row or column 
must be selected (highlighted). If only some of the cells in a row or column are 
selected, the Delete Cells option in the Table palette will be disabled.

To delete a single row:
1 Place the insertion point in the row you wish to delete.
2 Click the Select Row button and then click the Delete Cells button in the Table 

palette.

To delete a single column:
1 Place the insertion point in the column you wish to delete.
2 Click the Select Column button and then click the Delete Cells button in the 

Table palette.

To delete multiple rows or columns:
1 Select any entire row(s) or column(s) you wish to delete.
2 Click the Delete button in the Table palette.

Copy, cut, paste, and delete table content
Standard text manipulations such as copy, cut, paste, and delete are very useful 
when editing a table. Mellel makes them very easy to understand and use by 
clearly differentiating table and text manipulations. 
The simple rule is: Any editing done using the table palette will affect the table 
and not its content. Any editing done using standard text manipulation options 
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(Cut, Paste, Select All, etc.) will affect the content of the table but not the table 
itself.
If you are familiar with the basic editing commands in a word processor 
application, you will have no problem applying them to table content editing as 
well. Here we will review only those aspects that are slightly different when 
editing table content versus editing “regular” text in a document.

To select the content of one cell:
• Place the insertion point within the cell whose content you wish to select and 

choose Edit > Select All.

To select the content of the entire table:
• Place the insertion point anywhere in the table and click the Select Table 

button.

To copy text in a table (or in the text):
Do one of the following:

• Select the cells that contain the content you wish to copy and choose 
Edit > Copy. All the text in those cells will be copied. Or,

• Select the cells that contain the content you wish to copy from another table 
and choose Edit > Copy. All the text in those cells will be copied. Or,

• Select text from the document and choose Edit > Copy. All the text in the 
selection will be copied.

Note: The copy procedures also apply to copying images, and to a copying of a combina-
tion of image(s) and text.

To cut text from a table (or from the text):
Do one of the following:

• Select the cells that contain the content you wish to cut and choose Edit > Cut. 
All the text in those cells will be removed. Or,

• Select the cells that contain the content you wish to cut from another table 
and choose Edit > Cut. All the text in those cells will be removed. Or,

• Select text from the document and choose Edit > Cut. All the text in the 
selection will be removed.

Note: The cut procedures also apply to cutting images, and to cutting of a combination of 
image(s) and text.
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To paste text in a table:
• Place the insertion point inside a cell and choose Edit > Paste. The text will be 

pasted into the cell and any other adjoining cell(s), depending on the nature 
of the copied text. For example, if you have copied the content of three cells in
a row:

Figure 102: Text copied in a table

 Mellel will try to paste the content of those cells horizontally, starting with the 
cell where the insertion point is located. 

Figure 103: When text is pasted into a table

• If you select a range of cells that matches the range of the copied content, 
Mellel will paste it without any further changes (that is, the result will be 
identical to pasting text at the insertion point). 

• If you select a range of cells that is different in range (number of cells selected)
or orientation (that is, vertically instead of horizontally), Mellel will paste only 
the content that suits the selected range or orientation. For example, with 
only two horizontal cells selected, you would get:

Figure 104: Pasting with different ranges of cells selected
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• If you paste text from another table, text in the document, or from a different 
application, Mellel will treat it one of two ways, depending on the selected 
range in the table. If you paste at the insertion point (that is, in a cell), Mellel 
will interpret this as trying to paste the entire text into that cell. If you select a 
range of cells, Mellel will interpret this as trying to paste the text into that 
range and will try to organise the text accordingly. For example, this random 
text copied from TextEdit:

Figure 105: Copying text from TextEdit

 When pasted into a cell, this will produce the following result:

Figure 106: Initial result of text pasted

 But when the same text is pasted into a selected range of cells, Mellel will read
the standard delimiting characters (tab = move to next column; Return = 
move to next row), and the table will look like this:
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Figure 107: Improved result with text pasted

Note: Mellel will automatically insert tabs when you paste text that contain tabs. Also, Mel-
lel will never add, delete, or otherwise change the table following a paste operation.

Converting text to table
Mellel offers an option to automatically convert any tab-delimited text that is 
imported, pasted, or created in Mellel itself into a table.

To convert text to table:
• Select the text you wish to convert to a table and choose Edit > Convert Text to 

Table.

Applying text attributes to cells
Applying styles and other text attributes to text and images in tables is very easy 
and is identical in every respect to applying such attributes to any other block of 
text. You can apply paragraph and text styles to text in multiple cells, change the 
paragraph and line spacing, adjust the start and end margins, adjust the indents, 
etc.

Manipulating images within cells
Images in cells can be treated in much the same way as images in other places in 
the document. When you paste or drag and drop an image into a cell, it is scaled 
to fit into the cell. There you can change its size, move it around, copy it, apply a 
style to it, and other regular operations you can do with images.

Moving and copying tables
Moving tables around a document and copying tables within a document is very 
easy. If you have mastered the art of drag and drop, then you already know all you
need to know about moving and copying tables in Mellel.
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To copy or cut a table:
1 Double-click outside the page margins beside a table. The table will be 

selected and a grey selection box will appear behind the table. The cursor 
should remain an arrow as it was before making the selection.

Figure 108: Copying a table

2 Choose Edit > Copy or Edit > Cut as applicable.

To copy or cut a table with text before or after it:
1 Do one of the following:

• If the selection starts with the table, place the cursor outside the page 
margins beside the table and drag downwards or upwards to include the 
additional text you want to select. 

• If the selection starts before or after the table, place the insertion point 
where you want the selection to start and drag downwards or upwards. 

2 Choose Edit > Copy or Edit > Cut as applicable. 

To paste a table:
1 Copy or cut a table (as shown above). 
2 Place the insertion point where you want the table to be placed
3 Choose Edit > Paste.

To move a table:
1 Double-click outside the page margins beside a table. The table will be 

selected and a grey selection box will appear behind the table. 
2 Drag the table to the place you want to move it and release the mouse 

button. If you press the Option key while dragging, Mellel will create another 
copy of the table rather than move it. 
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Note: The same method will work when dragging and dropping between Mellel docu-
ments. This method will not work with clippings or when dragging the table directly into 
other applications.
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Templates
This chapter explain what templates are and how to use them

Should I read this chapter?
You should read this chapter if you intend to use template documents

What are templates
Templates are ‘dummy’ pre-formatted documents, intended to speed up the 
creation of often used types of documents such as letters, fax forms, or envelopes.
Templates are also used as forms or general guides to preparing documents with 
a certain format (for example, a document in a format suitable for admission to a 
magazine).
Templates in Mellel are simple Mellel files with a unique filename extension. This 
filename extension (.meltem) tells Mellel that those files are templates, so it 
knows to open them as such.
When you open a Mellel template, Mellel creates a new untitled document which 
is a duplicate of the template. This way, you can change the document and save it,
without affecting the template, which will remain unchanged for future use. 

Stuff you can do
To... Do this Keyboard Shortcut

Open a template 1 Do one of the following:
• Choose File > Open Template and then navigate 

the sub menu to the template you wish to open 
and choose it. Or,

• Choose File > Open Template > Browse...
1 In the Open Template dialogue box, select a 

template category from the Categories list.
2 From the templates offering, select a template

and click the Open button or double-click the 
template. 



Save a document as a 
template

1 Choose File > Save as template...
2 Name the template in the Template Name field. 
3 Choose into which Category (folder) you wish the 

template to be saved with the Category pop-up 
menu. You can also create a new category, if you so
wish, or save the template outside the templates 
folder. 

4 Optional: add a description for the template in the
Description field. 

5 Optional: Set the preview for the template. By 
default, Mellel creates a preview using Page 1 of 
the template, but you can use any other page, a 
custom image or, simply, not use any. 

6 Click the Save button. 

Set Mellel to use a 
template as the default
file

1 Choose Mellel (menu) > Preferences....
2 Click to open the Open & Save section.
3 Check Default Template and from the Open dialogue

box select the template you want to use as default 
from now on. 

4 Click Open. 

Change or update a 
template

1 Open the template you wish to change and 
change it.

2 Choose File > Save as Template.... 
3 Mellel will place you within the same Category and

will default to the same name the template had, so 
you only need to press the Save button and save 
over the existing template.

Remove a template or 
a templates folder

1 In the Finder, navigate to ~/Library/Applications 
Support/Mellel/Templates/

2 Move the template(s) and/or folder(s) you wish to 
remove to the Trash.

Note: With 10.7 (Lion) or later you’ll need to perform this 
task via the Terminal app.

Using templates
Using templates in Mellel is simple and easy. All you need to know is how to use 
the File menu. 

Creating templates
Creating templates in Mellel is as easy as saving files, and also allows you to set 
where the template will be saved, set the preview and add a description for the 
template. 
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Images and Graphics
This chapter contains explanations about graphic elements and 
images in Mellel

Should I read this chapter?
You should read this chapter if you intend to use graphic elements and 
images in your files

Mellel allows you to insert graphic elements such as images, graphs or equations, 
and place them anywhere you want in your documents. You can insert graphics 
into Mellel by drag and drop or via the Insert menu, and edit their attributes via 
the Image dialogue box, and control the way text flows around images via the 
Wrap palette.

Graphic attributes
Inserted graphic elements in Mellel can be placed into a document as either as 
inline or as floating objects. The graphic elements can cause the text to wrap 
around them (if you so choose), and you can also add a frame to the image 
(frames are initially transparent and invisible). 

Supported graphic formats
Mellel supports the insertion of files using any graphic format supported by 
Mac OS X, preserving both pixel and vector data (where it exists). Among those 
formats are: BMP, EPS, GIF, JPEG, PDF, PICT, PNG, PSD (Photoshop), TARGA, TIFF, 
and more. 
In most cases, even if a specific format is not ‘officially’ supported, once inserted 
into Mellel it will be converted to an acceptable graphic file format. For example, 
you may copy or drag graphics directly from applications such as Adobe 
Illustrator®, Macromedia FreeHand®, OmniGraffle®, and others, and the 
illustrations will be placed in Mellel preserving both pixel and vector data.

Stuff you can do
To... Do this Keyboard Shortcut



Insert an image into 
Mellel

• Do one of the following:
• Drag the image into an open Mellel document 

window. Or,
• Open the document containing the graphics in 

an application that supports displaying it, copy it
and then move to Mellel and choose Edit > Paste.

• Choose Insert > Image and then navigate to that 
image, select it and click OK. 

Replace an inserted 
graphics

1 Click the graphic you want to replace to select it. 
2 Choose Insert > Image...
3 Select the graphic you want to insert instead of the

existing graphic and press OK. 
Note: when replacing a graphic element the Scaling and 
Frame attributes of he replaced graphics are preserved. 

Edit graphic attributes • Double-click an graphic element.

Edit text wrap • Do one of the following:
• Double-click a graphic element.
• Select a graphic elements, and open the Wrap 

palette.

Resize a graphic 
element

• Do one of the following:
• Click the graphic element to select it and drag 

the handles at the four corners of the graphic 
element to change its size. Press the Shift key to 
resize the graphics maintaining its original 
aspect ratio. 

• Double-click a graphic and in the Image dialogue
box, set the Horizontal and Vertical scale values

Set a graphic element’s
wrapping placement

• Select the graphic element, and do one of the 
following:
• In the Wrap palette set its placement to either 

Inline or Floating. 
• Double-click the element, and in the Image 

dialogue box set its placement to either Inline or 
Floating.

Set a graphic element’s
wrapping options

1 Select the graphic element, and do one of the 
following:
• In the Wrap palette check the option Image 

Causes Wrap. 
• Double-click the element, and in the Image 

dialogue box check the option Image Causes 
Wrap.

2 Click any of the wrap buttons, or set the Extra space 
around the wrapped image. 

Set the size of a 
graphic element

• Double-click a graphic and in the Image dialogue 
box, set the Width and Height for this graphic
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Move a graphic 
element within its 
frame

1 Double-click a graphic, and in the Image dialogue 
box, select Float in frame from the Fitting method 
pop-up menu, and press OK.

2 Press and hold the Option key while dragging the 
graphic around inside the graphic frame. 

Retrieve missing 
images

1 Follow the instructions for Replacing an image 
Previous Page.

Image dialogue box
The Image dialogue box allows you edit, change and control all the attributes 
related to a graphic element. 

Frame 
attributes

Scaling 
attributes

Cross 
reference 
attributes

Image Wrap 
attributes

Figure 109: The Image dialogue box

• Fitting method: determines how the graphic will be fitted in its frame.
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a Scale to fit: With this method, the graphic element is resized to fit the 
frame size.

b Float in frame: With this method, the graphic element is not resized; only 
the portion of it that can be viewed within the graphic element frame will 
be displayed. 

Figure 110: An image scaled to fit (left) and floating in frame (right)

• Horizontal and Vertical scale: determines the graphic scaling within the 
graphic frame (in percent). 

• Width and Height: determines the graphic scaling within the graphic frame 
using the currently selected measurement unit.

• Maintain original proportions: allows you to enable (check) or disable (un-
check) constraining of the graphic frame proportion. If Scale to fit is the 
selected Fitting method, the graphic would be proportionally resized. If not, 
this attribute will only apply to the graphic frame. 

• Frame type: allows you to set the graphic frame type to none or Solid. If none is
selected, there will be no visible graphic frame. If Solid is selected, you can also
set the Weight, Line colour, and Fill colour of the frame. 

• Weight: allows you to set the width of the graphic frame. 

• Line colour: allows you to set the colour of the graphic frame line. 

• Fill colour: allows you to set the fill colour for the graphic frame. The fill colour
will be visible only if the graphic contains transparency, or if it is smaller than 
the graphic frame. 

• Vertical position: allows you to set the vertical shifting of a graphic elements. 
This is mainly useful if you need to have an inline image set higher or lower in 
relation to the position in the text to which it is anchored. 

• Adjust fixed line spacing to image: With inline images, if checked, Mellel will
position images in a text laid out with fixed line spacing as a multiplication 
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the line spacing. For example, if the line spacing is 14 points, and the image 
height is 53 points, it will be positioned as if it resides inside a line whose line 
spacing is 56 points (14 x 4). 

• Image title: allows you to name the image. You can refer to that name in a 
reference. 

• Cross Reference Target ID: allows you to enter a unique name identifier for 
the image, thus turning it into a target you can refer to with a reference. 

• Assign Virtual Target: Allows you to assign the image to a virtual target (if 
there is one in the text).

• Placement: You can choose to position a graphic element as an inline or 
floating item. For more details, see Wrap text around graphics.

• Image causes wrap: toggles between causing wrap (checked) or not 
(unchecked). For more details, see Wrap text around graphics.

• Wrap options (button): allows you to access various wrap text around images 
options. For more details, see Wrap text around graphics.

• Extra space: sets the space around the images when wrapping.

Wrap text around graphics
Any graphic element in Mellel exists as either an inline element or a floating 
element. An inline element is tied to a certain position in the text. When it does 
not cause wrap it appears as a large letter in the text (see Adjusting non-wrapping
inline images). When it causes wrap, it forces the text around it to wrap around it 
in the selected wrapping manner. 

Table 16: Inline image with and without wrap
Inline image, no wrap Inline image, with Both sides wrap (the red 

arrow points to the point to which the image is 
anchored)
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When a graphic element is floating, it is not tied to any specific point in the text 
but ‘hovers’ above it. A floating graphic element can also cause the text to wrap 
around it. 

Types of wrap
Mellel allows you to use different types of wrap, depending on whether the image
is an inline image or a floating image. 

Wrap around floating elements
There are several wrap options for a floating element. They are summarised with 
the following table. 

Table 17: Floating element wrapping options
No wrap Wrap to right Both sides Wrap to left Wrap to bigger Skip

• No wrap: The graphic elements floats above the text and does not cause it to 
wrap. 

• Wrap to right: The text is wrapped to the right of the image (blank space to 
the left). 

• Both sides: The text is wrapped to the left and to the right of the image. 

• Wrap to left: The text is wrapped to the left of the image (blank space to the 
right). 

• Wrap to bigger: The text is wrapped to the right or to the left, depending on 
the horizontal width of the area left for the text to wrap. 

• Skip: The text skips the area where there it a graphic element. 

Wrap around inline elements
There are several wrap options for a inline element. They are summarised with the
following table. 

Table 18: Inline element wrapping options
Wrap the right Both Wrap to left Skip and left Skip and centre Skip and right
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• Wrap to right: The element is at the left end, with the text wrapping to its 
right.

• Both sides: The text is centred and the text wraps on the right and on the left.

• Wrap to left: The element is at the right end, with the text wrapping to its left.

• Skip and left: Text skips the graphic element. The element is aligned to the 
left. 

• Skip and centre: Text skips the graphic element. The element is aligned to the
centre. 

• Skip and right: Text skips the graphic element. The element is aligned to the 
left. 

Adjusting non-wrapping inline images
The Adjust fixed line spacing to image and Vertical position attributes change the way 
inline images without wrap are positioned in the text. The following table 
exemplifies various positioning. 

Table 19: Images in the text
Situation How this looks in Mellel

Paragraph spacing in points, Adjust fixed line spacing
to image checked, Vertical position=0

Paragraph spacing in points, Adjust fixed line spacing
to image not checked, Vertical position=0

Paragraph spacing in points, Adjust fixed line spacing
to image not checked, Vertical position=-8
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Paragraph spacing=1 line, Adjust fixed line spacing to
image checked, Vertical position=0

Paragraph spacing=1 line, Adjust fixed line spacing to
image not checked, Vertical position=0

Paragraph spacing=1 line, Adjust fixed line spacing to
image not checked, Vertical position=-8

Missing Images
Mellel stores images in a special folder within the Mellel document . This means 
that you can, at any point, open the package and remove any of the images from 
the package. 
When this happens Mellel will display a special “Missing Image” icon:

Figure 111: Missing Image icon

Important: If you’ve saved the file compressed as a zip file, you can always retrieve its content
by changing the filename extension from “.mellel” to “.zip” and then de-compress the file as 
a simple zip file. 

Working with equations
Mellel can import equations from almost any equation editor by drag and drop or
copy and past. Equations can be manipulated just like any other graphic element. 
The main difference between regular graphic elements and equations is that 
when equations are pasted, they usually come with the proper vertical 
positioning shift so that you can position them inline properly.
In some special cases, equations can be used differently, as “live” objects. 
Currently, pasting and using equations as live objects is possible with the 
equation editor MathMagic. 
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To use MathMagic equations as “live” objects:
1 Create an equation in MathMagic and copy it.
2 Paste the equation into a Mellel document.

Figure 112: Equation pasted in a Mellel document

3 Copy the equation again, move to MathMagic and paste it. The equation should 
function as a “live” equation (namely, it will be editable). 
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Object
This chapter contains explanations about graphic and text objects in 
Mellel

Should I read this chapter?
You do not need to read this chapter

Mellel allows you to manipulate objects inserted into it. Currently, the only object 
of this type are images. In the near future Mellel will be able to manipulate other 
types of objects such as text boxes and shapes. Currently, all the relevant 
information is included in the Images and Graphics chapter of this guide.



Find and Replace
This chapter contains details about the Find and Replace feature in 
Mellel and explains how to use it

Should I read this chapter?
You should read this chapter if you intend to find anything in Mellel

Mellel’s Find and Replace allows you to perform simple and complex searches 
within the text of a document. The most common method of searching in the text
is via the Find and Replace dialogue box, but for quick searches in the text, you can 
also use several keyboard shortcuts from within the document text. 

The Find and Replace dialogue box
Mellel’s Find and Replace dialogue box allows you to create and execute both 
simple and complex searches within the document text or within selected parts 
of it. 



Element 
menu

Main find and replace controls

Loading and saving 
Find Actions

Find and 
Replace fields

Remove 
formatting

Search 
areas

Search 
Options

Group and 
Ungroup

Figure 113: The Find and Replace dialogue box

Find field
The Find field is where you can enter a string or an expression you want to find in 
the text. You can enter into this field elements from the Element menu, from the 
first four sub-menus on the Insert menu, or simply enter (type) text in this field. 

Replace field
The Replace field is where you can enter the expression that will replace the found 
range—that is, replace what you’ve found. In this field, you can enter (type) text, 
select an item from the Element menu above the field, or use any of the first four 
sub-menus on the Insert menu.
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Element menus
There are two element menus in the Find and Replace dialogue box, one above 
the Find field and the other above the Replace field. 

To enter an element:
• With the insertion point (cursor) in the Find or Replace fields, choose an item 

from the Find or Replace fields (you can only enter an item from the elements 
list into the field beneath it). 

Find and Replace commands
Mellel’s Find and Replace offers several commands that allow you to determine 
what Mellel will do when searching the text. 

• Find Next (Cmd+G): is used to look for the next instance of a find expression 
in the text. If there are no more instances of the find expression to find from 
the end of the selection to the end of the document, Mellel will sound a beep. 
The next time you press the Find Next button, the search will start again from 
the top of the document. 

• Find Previous (Cmd+D): is used to look for the previous instance of a string in
the text. If there are no more instances of the string to find from the start of 
the selection to the start of the document, Mellel will sound a beep. The next 
time you press the Previous button, the find operation will start from the 
bottom of the document.

• Replace: is used to replace a range with the string in the Replace field.

• Replace All: replaces all the strings that match the found expression with the 
replace expression. 

• Replace & Find: replaces the last matched (found) expression and searches 
for the next matching expression.

Additional commands
There are also two Find commands that are not represented with controls in the 
Find and Replace dialogue box, but appear on the Find sub-menu under the Edit 
menu.:

• Use Selection for Find (Cmd+E): will cause Mellel to copy the selection in the 
text into the Find field. 

• Scroll to Selection (Cmd+J): will cause Mellel to scroll to the current selection
in the text.
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Group and Ungroup
The Group and Ungroup buttons allow you to create groups around selected 
elements in the Find field or delete those groups. 

To create a group:
1 Select any number of items (elements and text) in the Find field. 
2 Click the Group button. 

To ungroup:
1 Select a group.
2 Click the Ungroup button. 

An alternative method for ungrouping:
1 Position the insertion point right after a group. 
2 Press the back-space key. 

Search Inside
Mellel’s Find and Replace allows you to specify where the search will be 
performed. You can check any or all of the Search Inside options. By default, all the 
options are checked, except Selection. 

• Selection: The search will be limited to a selection in the text. 

• Main text: The search will be will be performed within the main body of the 
text. 

• Footnotes: The search will be performed within the footnotes, endnotes, and 
any other notes stream. 

• Auto-titles: The search will be performed within the Auto-titles. 

• Headers and Footers: The search will be performed within headers and 
footers.

Options
Mellel’s Find and Replace allows you to set some general rules for the search. 

• Ignore case: When this option is checked, Mellel will ignore the case 
(uppercase or lowercase letters) of the matching strings. For example, if you 
want to find the string “Mellel”, the strings “mellel” and “Mellel” will both be 
matched.
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• Whole words: When this option is checked, Mellel will search for strings that 
are words and not just part of words. For example, if the search expression is 
“find”, Mellel will match “find” but not “finder”.

• Ignore Diacritics: When this option is checked, Mellel will ignore accents and 
diacritical marks in the text. For example, if you search for “fruit” both “fruit”, 
“fruït”, and früit” will be matched. This also applies to vowel marks in Arabic, 
Hebrew, or any other language that uses them. 

• From beginning: When this option is selected, Mellel will search from the 
beginning of the document, instead of from the insertion point forward. 

Simple searches
The most common use of the Find and Replace dialogue box is to perform simple 
searches where you find a string in the text and replace it with another string. 

To Launch the Find and Replace dialogue box:
• Select Edit > Find > Find... or press Cmd+F

To do a simple search:
1 Select Edit > Find > Find... or press Cmd+F
2 Enter the string you want to find in the Find field. and then perform any or all 

of the following:
• If you want to replace that string with another string, press the Tab key to 

move to the Replace field and enter the replace string. 
• If you want to limit or expand your search, check or uncheck the 

appropriate Search Inside check-boxes. 
• If you want to use special options, check or uncheck the appropriate 

Options check-boxes. 
3 Press any of the controls to perform the find and replace actions. 

Find and Replace style and format
Mellel offers you an easy way to find and replace formatting and styles in the text. 
You can use this feature to replace a specific attribute in the text.
Formatting or style attributes can be assigned only to the entire Find or Replace 
fields. That is, you cannot assign different attributes to different parts of the text in
each field. 
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To Find and Replace a formatting or a style for a specific expression:
1 Open the Find and Replace dialogue box. 
2 Enter the expression (e.g., a string) in the Find field .
3 Do one of the following:

• From the Character palette, choose attributes you want to look for in the 
text. For example, if you want to look for text using the Times New Roman 
font, select this font from the Font pop-up menu.

• Select a style from the Character palette Styles tab. 
• Select a text in the document with the desired character attributes and 

choose Edit > Copy Special > Copy Character Attributes, move back to the Find 
field and choose Edit > Paste.

4 Move to the Replace field and from its Element menu enter the Found element. 
5 Repeat step 3 with the Replace field, using the formatting attributes you want 

to use. 
6 Press the suitable command button at the bottom of the Find and Replace 

dialogue box.

Note: If you just want to find an expression using certain attributes, you can 
skip steps 4 and 5.

To Find and Replace a formatting or a style:
1 Open the Find and Replace dialogue box. 
2 From the Element menu, insert the element Anything ( ).
3 Do one of the following:

• From the Character palette, choose attributes you want to look for in the 
text. For example, if you want to look for text using the Times New Roman 
font, select this font from the Font pop-up menu.

• Select a style from the Character palette Styles tab. 
• Select a text in the document with the desired character attributes and 

choose Edit > Copy Special > Copy Character Attributes, move back to the Find 
field and choose Edit > Paste.

4 Move to the Replace field and from its Element menu enter the Found element. 
5 Repeat step 3 with the Replace field, using the formatting attributes you want 

to use. 
6 Press the suitable command button at the bottom of the Find and Replace 

dialogue box.

Find and Replace204



To view formatting and style attributes applied in the Find or Replace 
fields:
• Hover over the Find or Replace field until a tool-tip appears with the details 

about the formatting applied.

To apply formatting to text and elements:
• With the insertion point in the Find or Replace area, select attributes from the 

Character palette Attributes or Styles tab. 

To clear formatting applied to text and elements:
• Click the Clear Formatting button. 

An example
Let’s say you’ve imported some text that has text in the footnotes underlined 
instead of italicised. To remedy this, you can do the following:
1 Insert an Anything element from the Element menu into the Find area. 
2 From the Character palette, choose Under from the Line pop-up menu. 
3 Move to the Replace area and choose Found expression from the Replace area 

Element menu. 
4 From the Character palette, choose None from the Line pop-up menu, and then

choose Italics from the Face menu. 
5 Uncheck all the options under Search Inside except Footnotes. This will prevent 

Mellel from searching for this attribute where you do not want it to be 
searching (e.g., in the main text).

6 Press the Replace All button. Mellel will replace every occurrence of an 
underlined text in the footnotes with an italicised text, and will display the 
results in the Find and Replace dialogue box.

Find Expressions
Mellel’s Find and Replace allows you to create descriptions of a piece of text using 
a special language called Find-Expressions (or “findex” for short). With a simple 
find and replace, you can find a character or a string and replace it with another 
character or string. With Find Expressions, you can define your searches more 
broadly and generally to find almost any textual pattern or combination of 
characters. For example, you can use findex to find any email address, phone 
number in a given format, a paragraph containing a certain character, a word in 
different spellings, or every permutation of a given word. 

Find and Replace205



The findex language can use several types of elements: 
1 Literal text: simple text strings. 
2 Special elements: such as Any Character, Word boundary, Digit, or White-

space.
3 Groups: that can include other elements. 
4 Or: the special token Or.

How Find-Expressions work
The engine behind findex looks in the document text for a character that matches
the first character in the find field. If it finds a match, it continues to the next 
character in the find field, trying to match it too. If it finds a perfect match, it will 
select it in the document text. If not, it will retract to one of the preceding 
elements in the Find field. If it fails completely and there is no match in the text, it 
will notify you that it failed.

A findex example
Let’s say you’re searching a document that contains the following text:

“If your dog is grey and your cat is gray, then all dogs and cats are grey or 
gray.”

The simplest form of find is matching literal text. For example, if you enter “cat” in 
the Find field, the word will be matched and selected:

Figure 114: Cat is matched

That is, of course, a very simple thing to find, but suppose you want to find either 
“cat” or “dog.” and replace them with the word “grass.” To do that with simple find, 
you’d have to look separately for every instance of “dog” and replace it, and than 
repeat this procedure with “cat.” Using findex, however, you can find all instances 
of “dog” or “cat” and replace them with one stroke. 
The simplest way to do this is by using an Or element:
1 In the Find field, enter “cat” and then, from the Element menu, select Or. 
2 Enter “dog” after the Or element. 
3 Enter “grass” in the Replace field. 
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4 Press the Replace All button. 
The Find field should look like the following:

Figure 115: Cats or dogs

And the end result will probably be:

Figure 116: All grass

That’s an excellent result, although the second part of the sentence, full of “grasss” 
as it is, might seem a tinge questionable. 
To fix that grammatically iffy sentence, we’ll need a way to locate “cat,” “cats,” “dog,” 
and “dogs” at the same time. We can do that by using the Or element exclusively. 
For example:

Figure 117: Three times Or

Here, we’ll be able to locate all for instances of the words, but that is a 
cumbersome way of doing things. A more elegant solution would be to use the 
Group element:
1 Select the expression “cat dog” and click the Group button. 
2 Enter “s” after the group, select only the “s”, and group it. 
3 Double-click the edge of the “s” group to open the group dialogue box. 
4 Select Optional from the Repetition pop-up menu and check the option Greedy. 

Choosing Optional here is meant to instruct the findex engine to accept cases 
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of “cat” and “dog” but also optionally “cats” and “dogs.” The Greedy option tells 
the engine to try and match the longer expression (with “s” at the end) if such 
a match can be made. Combined, the two choices here tell the findex engine: 
find “cats” and “dogs,” if possible, but settle for “cat” and “dog” if that’s all you 
can find. 

The end result in the Find field should look like the following:

Figure 118: Two groups

When we repeat the Replace All action, the result is improved:

Figure 119: Better grass

For additional findex examples see the tutorial at the end of this chapter. 

Findex vocabulary
Literal text
Literal text is plain text entered into the Find or Replace fields. You cannot assign 
any attributes to literal text, but you can group it and assign such attributes to the
group. For example, if you want to find any case of “a”, “aa” or “aaa” in the text, you 
can enter “a” as literal text in the Find field, group it, and assign the attributes 
Greedy and Repetition=Once or more to the group. 

Character matching elements
Elements of this type in findex match characters or types of characters. Character 
matching elements have several common attributes. You can access those 
attributes by double-clicking the element to open its attributes dialogue box. 
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Common attributes of character matching elements
Repetition
The Repetition menu in the character matching elements dialogue boxes offers 
several options:
1 Once: Matches the elements once. The element will be considered matching if

the text contains a single match for it. E.g., if you look for “e” in “beet” the first 
and then the second “e” will be matched, but not both at once. This is the 
default selection for the repetition menu.

2 Optional: Matches the element once or not at all. The element will be 
considered matched if the text contains a single match or no match. 

3 Zero or more: Matches the element zero times or more. The element will be 
considered matching if the text contains a single, multiple, or no match for it. 

4 Once or more: Matches the element once or more. The element will be 
considered matching if the text contains single or multiple matches. 

5 Exactly: Repeats matching the element exactly as specified. The element will 
be considered matching if the text contains as many matches as specified. For 
example, if you search for “e” and the minimum value is set to 2, the “ee” in 
“meet” will be matched, but the “e” in “met” will not. 

6 This much or more: Matches the element at least as many times as set. The 
element will be considered matching if the text contains the minimum 
number or any number above it of matches. For example, if you enter “2” in 
the Minimum field, Mellel will try to match two or more repetitions of the 
element. 

7 Range: Repeats matching the element between (and including) the minimum
and maximum setting. The element will be considered matching if the text 
contains the minimum, maximum, or any number in between of matches. 

Greedy
An important attribute of all elements is their “greediness” or “laziness.” If the 
option Greedy is checked, the findex engine will act ‘greedily’—that is, it will try to 
match the maximal number of characters that match before moving on. If the 
option is not checked, the findex engine will act lazily—that it, it will match only 
the minimal number of characters that match. In both cases, if there is no match 
later on, the findex engine will retract and will try to fit less (when greedy) or 
more (when lazy) and then move on. 
For example, let’s say we have the following text:

To <b>boldly</b> go where no <colour>person</colour> has gone before
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If we use the following expression (Any Character element, Greedy, Zero or more 
repetitions):

Figure 120: Greedy

then the findex engine will match all the text from the first open tag to the last 
close tag:

Figure 121: Too greedy

The same expression, with greediness turned off, will match only one complete 
HTML tag at a time:

Figure 122: Lazy

The first element in this expression is the open tag (“<“). After findex engine 
matches this element (e.g., with “<“ in “<b>”), it continues to the next element in 
the expression, Any character. Since this element is Greedy, Mellel will match the 
text to the end, since every character in the text (including the “>” character) up to
“before” is considered an Any character. 
Once the engine ‘exhausted’ “Any Character,” it will move to the next element in 
the expression, the close tag (“>”). Since the last character in the text is the end of 
the sentence or the Return character, there will be no match and the engine will 
go back to the greedy Any character and will subtract the number of repetitions by
one, and will try to find a match again. This process of subtraction will continue 
until there is a match or until there are no repetitions. In the case above, this will 
continue until it reaches the last closing tag (with “</colour>”).
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When Any Character is lazy (that is, Greedy is turned off), Mellel will match the first 
open tag, move to Any character, and—since Any Character is now lazy—it will 
suffice itself with the minimum number of matches (which is zero) and move on 
immediately to the last element. In our case, since the character following the first
“<“ is “b” and not “>” the findex engine will retract to the Any character element, 
add one, and try to find a match again. In this case, it will match “b” and will 
continue to the next element. Here, again, it will find a match and the first found 
match will be “<b>.” 

Negated
A findex element can be negated. If the option Negated is checked, findex will 
match any character that is not defined by the element. For example, when 
Negated is checked for the Character Set “abc”, findex will match any character that
is not a, b, or c (that is, d, e, f, etc.). 

Any Character
The Any Character element in findex matches any character, including variables 
and line breaks, but excluding break characters (such as Return, Page Style Break, 
etc.). 

To create an Any Character element:
1 Choose Any Character from the Element menu in the Find dialogue box. 
2 Double-click the Any Character element to edit its attributes. 

Letter
The Letter element in findex matches any letter character in the text. For example, 
a or ü or δ.

To create a Letter element:
1 Choose Letter from the Element menu in the Find dialogue box. 
2 Double-click the Letter element to edit its attributes. 

Digit
The Digit element in findex matches any digit character from 0 to 9.

To create a Digit element:
1 Choose Digit from the Element menu in the Find dialogue box. 
2 Double-click the Digit element to edit its attributes. 
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Alphanumeric
The Alphanumeric element in findex matches any digit or letter character.

To create an Alphanumeric element:
1 Choose Alphanumeric from the Element menu in the Find dialogue box. 
2 Double-click the Alphanumeric element to edit its attributes. 

Whitespace
The Whitespace element in findex matches any type of space character, tabs and 
breaks.

To create a White space element:
1 Choose Whitespace from the Element menu in the Find dialogue box. 
2 Double-click the Whitespace element to edit its attributes. 

Character Set
A Character Set is a findex element which allows you to match any of several 
characters. For example, if you want to find either spelling of the word “grey”, you 
can use the following find expression:

Figure 123: Grey or Gray

The character set includes the text “ae” which means either “a” or “e” and so, both 
“gray” and “grey” will be matched. 

Note: Character set will only match one letter at a time. For example, with a 
character set of “ae” the letter “a” will be matched first, followed by “e” but not 
both of them at one. 

To create a Character Set element:
1 Choose Character Set from the Element menu in the Find dialogue box. 
2 Double-click the Character Set element to edit its attributes. 
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Set
The Character Set element supports the set attribute. In the set field, you can enter 
a series of characters, either of which can be matched. For example, if the set 
includes “abc”, either a, b, or c will be matched. 

Character Range
A Character Range is a findex element which allows you to match a character 
within a given character range. For example, from “a” to “z” or from “e” to “g.”

To create a Character Range element:
1 Choose Character Range from the Element menu in the Find dialogue box. 
2 Double-click the Character Range element to edit its attributes. 

Unicode Range
This attribute allows you to set the start and end points of the character range. For
example, setting the start point to U+0531 (you can simply enter 0531) and the 
end point to U+058A will set a character range suitable for all the characters in 
the Armenian code range. 

String
This attribute allows you to set the start and end points of the character range by 
entering the character directly. For example, entering “a” as the start point and “z” 
as the end point will set the character range to find any letter from “a” to “z.”

Note: the Unicode Range and the String attribute compliment each other and are essential-
ly two different ways to enter the same information. Any change you make to one of the 
fields in either of the two will be reflected in the other.

Citation
A Citation element is a findex element which allows you to match a citation object 
in the text. 

To create a Citation element:
1 Choose Citation from the Element menu in the Find dialogue box. 
2 Double-click the Citation element to edit its attributes. 

Group
A group in findex is any number of characters or elements that are separated from
other items in the Find field by special brackets (the group mark). You can group 
together any element and any number of other elements, even a single character. 
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Usually, though, groups are used to isolate several elements you wish to match or 
apply some options to separately. 
For example, suppose you want find words with a different spelling in American 
and British English such as grey or centre. The following example Find would do 
the job:

Figure 124: Finding your centre

The group in this example includes “re” and “er” with an Or element between 
them. When you press the Next button Mellel’s findex will look for any word with 
the sequence “cent”. If it succeeds in finding a match, it will then try to match 
either “re” or “er.” 
You will also notice that the group in the screen shot above is numbered (the little
number near the bottom of the left bracket). The number of the group indicates 
that the capturing attribute is turned on for this group. See below for more 
information about capturing. 
Groups can be useful in more complex cases. For example, when you want to find 
grey in both spellings and with different permutations:

Figure 125: Two groups

The expression here will match any instance of the following strings: grey, gray, 
grayish, greyish, graying, and graying. Note that the second group has the 
attributes Repetition=Zero or more and the option Greedy turned on. Zero or 
more repetitions means that the endings “ish” and “ing” will be part of the match if
found (e.g., with “greyish”) but they don’t have to be part of the match (otherwise 
“grey,” for example, will not be matched). The Greedy option tells the findex 
engine to look for those endings and match them too, if possible, so that findex 
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will not suffice itself with finding “grey” when there might be something else to 
match further (such as an ending like “ish”). 
The following permutations tree illustrate the options covered by the expression:

gr

a

e

y
ish

ing

y

ish

ing

Figure 126: Expression options

Expanding the expression by adding more options (e.g., for “ly” at the end”) will 
further expand the number of permutations covered. 

To create a group:
1 In the Find dialogue box, select any number of characters and/or elements in 

the Find area.
2 Press the Group button.
3 Double-click the group boundary (the parenthesis) to edit the group 

attributes.

To ungroup a group:
• In the Find dialogue box do one of the following:

a Select a group in the Find area and press the Ungroup button. Or,
b Place the insertion point (cursor) after a group and press the Backspace 

key.

Group attributes
Repetition
The Repetition menu in the Group dialogue box offer several options:
1 Once: Matches the elements once. The element will be considered matching if

the text contains a single match for it. E.g., if you look for “e” in “beet” the first 
and then the second “e” will be matched, but not both at once. This is the 
default selection for the repetition menu.
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2 Optional: Matches the element once or not at all. The element will be 
considered matched if the text contains a single match or no match. 

3 Zero or more: Matches the element zero times or more. The element will be 
considered matching if the text contains a single, multiple, or no match for it. 

4 Once or more: Matches the element once or more. The element will be 
considered matching if the text contains single or multiple matches. 

5 Exactly: Repeats matching the element exactly as specified. The element will 
be considered matching if the text contains as many matches as specified. For 
example, if you search for “e” and the minimum value is set to 2, the “ee” in 
“meet” will be matched, but the “e” in “met” will not. 

6 This much or more: Matches the element at least as many times as set. The 
element will be considered matching if the text contains the minimum 
number or any number above it of matches. For example, if you enter “2” in 
the Minimum field, Mellel will try to match two or more repetitions of the 
element. 

7 Range: Repeats matching the element between (and including) the minimum
and maximum setting. The element will be considered matching if the text 
contains the minimum, maximum, or any number in between of matches. 

Greedy
An important attribute of all elements is their “greediness” or “laziness.” If the 
option Greedy is checked, the findex engine will act ‘greedily’—that is, it will try to 
match the maximal number of characters that match before moving on. If the 
option is not checked, the findex engine will act lazily—that it, it will match only 
the minimal number of characters that match. In both cases, if there is no match 
later on, the findex engine will retract and will try to fit less (when greedy) or 
more (when lazy) and then move on. 
For example, let’s say we have the following text:

To <b>boldly</b> go where no <colour>person</colour> has gone before
If we use the following expression (Any Character element, Greedy, Zero or more 
repetitions):
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Figure 127: Greedy

then the findex engine will match all the text from the first open tag to the last 
close tag:

Figure 128: Too greedy

The same expression, with greediness turned off, will match only one complete 
html tag at a time:

Figure 129: Lazy finding colour

The first element in this expression is the open tag (“<“). After findex engine 
matches this element (e.g., with “<“ in “<b>”), it continues to the next element in 
the expression, Any character. Since this element is Greedy, Mellel will match the 
text to the end, since every character in the text (including the “>” character) up to
“before” is considered an Any character. 
Once the engine ‘exhausted’ “Any Character” it will move to the next element in 
the expression, the close tag (“>”). Since the last character in the text is the end of 
the sentence or the Return character, there will be no match and the engine will 
go back to the greedy Any character and will subtract the number of repetitions by
one, and will try to find a match again. This process of subtraction will continue 
until there is a match or until there are no repetitions. In the case above, this will 
continue until it reaches the last closing tag (with “</colour>”). 
When Any Character is lazy (that is, Greedy is turned off), Mellel will match the first 
open tag, move to Any character and—since Any Character is now lazy it will 
suffice itself with the minimum number of matches (which is zero) and move on 
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immediately to the last element. In our case, since the character following the first
“<“ is “b” and not “>”, the findex engine will retract to the Any character element, 
add one, and try to find a match again. In this case, it will match “b” and will 
continue to the next element. Here, again, it will find a match and the first found 
match will be “<b>.” 

Negated
A findex element can be negated. If the option Negated is checked, findex will 
match any character that is not defined by the element. For example, when 
Negated is checked for the Character Set “abc”, findex will match any character that
is not a, b, or c (that is, d, e, f, etc.). 

Capturing
The capturing option allows you to set whether the results (match) of the group 
will be remembered by the findex engine, so you could refer to it and use the 
results later on with the Backreference element. When a group is capturing, it is 
numbered (a small number at the bottom of the left bracket). 

Name
The Name option allows you to set a name for a group and, by checking the 
option Display Name, set it to appear in the Find area instead of its content. This 
option is especially useful with custom find expressions, as it allows you to give a 
meaningful name to a group of elements whose purpose may not be evident at 
first glance. 

Boundary elements
Boundary elements are elements that match a position in the text, rather than a 
concrete element in the text. For example, the Text Start element will match the 
position before the start of the text in the document. Since boundary elements 
only mark a position, they are useful mainly as aids to find something that resides 
near them.

Word Boundary
The Word Boundary element matches a position in the text called “word boundary.”
Such a boundary exists before and after a word in the text and between word 
characters and non-word characters. 
A word character is defined as any letter (e.g., a, b, c), number (e.g., 1, 2, 3), or the 
underscore character, but excluding characters such as punctuation marks, 
parenthesis, exclamation mark, question mark, etc. 
For example, these are the word boundaries in the following short string:
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Press to start
Figure 130: Word boundaries

To create a Word Boundary element:
• Choose Word Boundary from the Element menu in the Find dialogue box. 

Negated Word Boundary
The Negated Word Boundary element matches any position in the text that is not a 
word boundary. 

To create a Negated Word Boundary element:
• Choose Negated Word Boundary from the Element menu in the Find dialogue 

box. 

Paragraph boundary
The Paragraph boundary element matches a position between any two paragraphs
in the text. That position is right after the Return character, at the beginning of 
the text, and at the end of the text. 

Note: Do not confuse the Paragraph boundary element with the Return character. The 
Paragraph boundary simply points to the position after the Return character. 

To create a Paragraph Boundary element:
• Choose Paragraph Boundary from the Element menu in the Find dialogue box. 

Negated Paragraph boundary
The Negated Paragraph boundary element matches any position in the text that is 
not a paragraph boundary.

To create a Negated Paragraph Boundary element:
• Choose Negated Paragraph Boundary from the Element menu in the Find 

dialogue box. 
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Text Start
The Text start element matches the position at the start of the text in the 
document.

To create a Text Start element:
• Choose Text Start from the Element menu in the Find dialogue box. 

Text End
The Text end element matches the position at the end of the text in the document.

To create a Text End element:
• Choose Text End from the Element menu in the Find dialogue box. 

Backreference
A Backreference element is a reference to a matched capturing group in the Find 
field. A capturing group is a group for which the option Capturing is checked in 
the Group dialogue box. Backreference elements are useful when you want to 
reuse some parts of an expression, or to organise them differently. 
For example, suppose you want to find and eliminate cases in the text where a 
word was typed twice in a row by mistake (e.g. “find find” or “a a”). One way of 
doing it is by using an Alphanumeric element that repeats once or more and is 
terminated by a word boundary:

Figure 131: Finding a word

Adding a Whitespace element will help locate every such word followed by a 
space:
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Figure 132: Word followed by space

The problem now is how to tell Mellel to find cases where the word matched 
(found) in group 1 is repeated again. Here, adding a Backreference can be very 
useful:

Figure 133: Adding the Backreference element

The Backreference element is referring to the capturing (numbered) group 1. The 
whole expression would be an instruction to Mellel to find any word, followed by 
a space, followed by the same word we’ve already found earlier on. 
Typically, with such a find expression, our target is to replace it with just one word,
eliminating the space between the word. Entering a Backreference element in the 
Replace field would do the job just fine:

Figure 134: Just a Backreference

Pressing the Replace All button will transform all cases two words in a row in the 
text. For example, this:
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Figure 135: Text before

Will change to this:

Figure 136: Text after

Another typical case where a backreference is useful comes when you need to 
keep the content, but change the order of element. Let’s say, for example, that 
you wish to change the date format in a document from a UK date format 
(31/05/2007) to a US format (05/31/2007). Your find expression might look like the
following:

Figure 137: Finding a date in Mellel

That is, you will find any string using the following format: <two digits>/<two 
digits>/<four digits>. In the Replace field, you will need to enter the following:

Figure 138: Replacing a date

What you have here is the same exact thing, but in a different order, with group 1 
(the day in the UK format) and group 3 (the month) trading positions. This way, 
the following dates:
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Figure 139: UK dates

Will change to:

Figure 140: US dates

To create a Backreference element:
1 Choose Backreference from the Element menu in the Find dialogue box. 
2 Double-click the Backreference element to edit its attributes. 

To create a backreference in the Replace area:
Do one of the following:

• Choose Backreference from the Replace area Element menu, and then double-
click the Backreference element to edit its attributes. Or,

• Select the group you want to reference in the Find area, and drag it into the 
Replace area. 

Group Index
The Backreference element supports one attribute, available from the Backreference 
dialogue box. The group index attribute allows you to choose to which group the 
Backreference element will refer.

Anything
The Anything element is a special element created for the purpose of allowing you
to easily create Find and Replace actions for formatting and style. It will match any
text and, if formatting or style attributes are applied to the Find field, will match 
any text using those attributes. 
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An Anything element is different from other elements in that with all other 
elements, Mellel tries to match the find expression in the text. With the Anything 
element, no comparison or matching is made for the text. 

To create an Anything element:
Choose Anything from the Element menu in the Find dialogue box. 

Using the Anything element: An example
Suppose you have the following text:

“Anything you can do I can do better.”
You want to change all the places where the text is underlined to italics. 
1 Open the Find and Replace dialogue box. 
2 From the Elements menu choose Anything.
3 In the Character palette, choose Under from the Line pop-up menu. 
4 Move to the Replace field and from the Elements menu there choose Found. 
5 In the Character palette, choose None from the Line pop-up menu.
6 In the Character palette set the Face menu to Italic.
7 Press the Replace All button. 
The end result should be something like the following:

Figure 141: Italics, not underline

Or
The Or element allows you to find a match of any of two alternatives. That is, it 
defines an “either or” relationship between two strings and elements. For 
example, the following expression:
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Figure 142: Dogs or Cats

Will be matched if the string “dogs” or the string “cats” is in the text. You can, of 
course, add another Or after “dogs” to match additional strings and elements. 

To create an Or element:
• Choose Or from the Element menu in the Find dialogue box. 

Found Expression
The Found element (available in the Replace field) allows you to refer a selection 
created after a Find action. In contrast with the Backreference element, the Found 
element relates to the whole found range. The found element is especially useful 
when you need to find and replace styles and formatting. 

To create a Found element:
• Choose Found from the Element menu in the Replace area of the Find dialogue 

box. 

Using the Found element: An example
Suppose you have the following text:

“Anything you can do I can do better.”
You want to change all the places where the text is underlined to italics. 
1 Open the Find and Replace dialogue box. 
2 From the Elements menu choose Anything.
3 In the Character palette, choose Under from the Line pop-up menu. 
4 Move to the Replace field and from the Elements menu there choose Found. 
5 In the Character palette, choose None from the Line pop-up menu.
6 In the Character palette set the Face menu to Italic.
7 Press the Replace All button. 
The end result should be something like the following:
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Figure 143: Italics, not underline

Special and invisible characters
Mellel offers you easy access to entering several special or invisible characters you
will possibly need to when creating find expressions.

Note: Do not confuse this with the Special Character item on the Edit menu. 

To find and replace invisible or document info elements:
1 Select Edit > Find > Find... 
2 Choose Insert > Page Variables/ Document variables/ Breaks/ Special Characters > 

[the desired special character]. The selected character will be inserted into the 
Find or Replace fields.

Custom Expressions
Mellel offers you the option to save any part of a find expression as a custom 
expression. The main purpose of saved expressions is to save time and effort 
recreating common or often used expressions. 

To save a custom expression:
1 Select any portion of the text in the Find area in the Find and Replace dialogue 

box. 
2 From the Element menu, choose Add Selection to Menu.
3 In the Save Custom Find Expression dialogue box, enter a name for the 

expression. 

To insert a custom expression:
• With the insertion point in the Find or Replace area, choose an expression from 

the Custom sub-menu in the Element menu.

To update or overwrite a custom expression:
1 Enter a custom expression and change it, or create an expression from scratch.
2 From the Element menu, choose Add Selection to Menu.
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3 In the Save Custom Find Expression dialogue box, enter a name identical to the 
name of the expression you want to update or overwrite and OK to replace it. 

To have the custom expression name displayed (instead of its content):
1 Insert a custom expression. 
2 Double-click the enclosing group border to open the Group dialogue box. 
3 Check the option Use name for display. 

To delete a custom expression:
• In the finder, go to ~/Library/Application Support/Mellel/Find Expressions/ 

and move the expression you want to delete to the Trash.

Note: You will need to restart Mellel in order for the changes to take effect. 

Find Actions
Find actions are saved find and replace actions, including the entire content of 
the Find field, the Replace field, Search Inside and Options selections. Mellel allows 
you to save find and replace actions, load them when you want to reuse them, 
edit those actions, overwrite them, and even create FindSets—sets of find and 
replace actions you can run sequentially. 

To save a find action:
1 In the Find dialogue box, click the Save Find Action... button. 
2 In the Save Find Action dialogue box, name the Find Action and click OK to save 

it. 

To load a Find action:
1 In the Find dialogue box, click the Load Find Action... button. 
2 In the Load Find Action dialogue box, select an action and click the Open button

to open it. 
3 The Find and Replace options set for this action will be displayed in the Find 

and Replace dialogue box where you’ll be able to edit it.

To overwrite (save over) an existing action:
1 In the Find dialogue box click the Load Find Action... button. 
2 In the Load Find Action dialogue box select an action and click the Open button 

to open it. 
3 Edit the Find and Replace options and then click the Save Find Action... button. 

Find and Replace227



4 In the Save Find Action dialogue box, give the Find Action the same name as 
the Find Action loaded, and click OK to save it. Press “Replace” to overwrite the 
existing Find Action.

To delete a Find Action:
• In the finder, go to ~/Library/Application Support/Mellel/Find Actions/ and 

move the action you want to delete to the Trash.

FindSets
FindSets are collections of Find Actions that you can run sequentially. That is, 
when you run a FindSet, you run any number of Find Actions that were included 
in it. Mellel allows you to create FindSets, save them, and run them. 
There are three important things to note about FindSets:
1 FindSets are run sequentially: That is, when you run a FindSet, it starts with the

first Find Action in the list of Find Actions it includes, proceeds to the next, 
and so on, to the last Find Action. This means that if you run a FindSet with 
two actions, the first changing every “a” to “b” and the second changing the 
style used with every ”a“, the second Find Action will fail to find any ”a“ in the 
text. If you reverse the order in the FindSet list, however, you’d be able to 
avoid this problem. 

2 FindSets are always run in Replace all mode: In order to complete a Find 
Action, it must run its course, so that the next Find Action in the sequence can
begin. To do that, it must run as if you’ve pressed the Replace All button for all 
the Find Actions in the FindSet. 

3 Changes to Find Actions will change the FindSet: If you edit, change, or delete 
a Find Action, the changes you’ve made will be reflected in the FindSet and 
might change the way it runs. 

Editing and running FindSets
You can edit and run FindSets via the Edit FindSet dialogue box. 
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Figure 144: Edit FindSet dialogue box

To run a FindSet:
1 Choose Edit > Find > FindSet (or press Cmd+Shift+F)
2 In The Edit FindSet dialogue box, choose a FindSet from the FindSet list (on the 

right) and press the Run FindSet button.

To create, edit and save a Findset:
1 Choose Edit > Find > FindSet (or press Cmd+Shift+F)
2 In The Edit FindSet dialogue box, choose a Find Action and press the Add 

button in the middle (or simply drag the Find Action into the FindSet Contents 
on the right. 

3 Do one or all of the following:
• To add Find Actions to the FindSet: repeat step 2. 
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• To delete a Find Action from the FindSet: select the Find Action in the 
FindSet Contents list and click the Delete button. 

• To change the order of Find Actions in the FindSet: select the Find Actions 
you want to move and drag it up or down in the list to the appropriate 
place. 

4 When you’re done with editing the list, press the Save FindSet... button and 
name the FindSet. 

To overwrite (save over) an existing FindSet:
1 In the Edit FindSet dialogue box, click the Load FindSet... button to load the 

FindSet you want to edit and overwrite. 
2 Edit the FindSet (if you so wish) and then press the Save FindSet... button to 

save it. 
3 Give the FindSet the same name as the one you wish to overwrite and OK to 

overwrite it. 

To delete a FindSet:
• In the finder, go to ~/Library/Application Support/Mellel/Find Set/ and move 

the FindSet you want to delete to the Trash.

To Edit a Find Action from the FindSet dialogue box:
• Double-click the Find Action in the Edit FindSet dialogue box. The Find and 

Replace dialogue box will open and there you may edit the Find Action and 
save it (or overwrite the existing Find Action).

Find Expressions tutorial
The following short tutorials are designed to provide you with some initial hands-
on experience with the way Mellel’s findex work.

Example A: Finding the right Colour
Let’s say, for example, that you want to find every occurrence of the word “colour” 
or “colour” in the text and change them to “black.” 
Normally, you’d have to do this by first finding and replacing every instance of 
“colour” with “black” and then repeat this with “colour.” With Mellel’s findex engine,
you can use the following simple search pattern:
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Figure 145: Color or Colour

The structure of this expression is simple, as the following illustration shows:

Literal text

Group 
boundaries

Or element

Figure 146: Find Expression structure

Mellel’s findex engine will read the expression as meaning: find every string that 
begins with “col”, with “o” or “ou” following it, and ending with an “r”. Strings like 
“column” or “calamity” will not be matched (that is, Mellel will ignore them), and 
only the strings “colour” or “colour” in the text will be found. 
That creates a little problem, of course, because the findex engine will find and 
replace every matched string with “black,” so we’ll get some pretty strange results 
like “Colorado” being turned to “Blackado” and “Colourful” becoming “Blackful.” 
To prevent that, we can improve the expression by adding a “Word Boundary” 
element to the search pattern. Adding a word boundary element before and after 
the pattern will tell the findex engine that “colour” or “colour” must be whole 
words, not just parts of words. 

Figure 147: Find whole words

Find and Replace231



Now, when you search with the word boundary element placed before and after 
the search pattern, findex will ignore words such as “multicoloured”, “Colorado”, 
“Colourful”, “Colorise”, and so on. 

To create the findex in the above example:
1 Activate the Find by choosing Edit > Find > Find... or pressing the Cmd+F 

keyboard shortcut. 
2 Choose Word Boundary from the Elements’ list. 
3 Enter “col” in the Find text area. 
4 Enter “o” in the Find text area.
5 Choose Or from the Elements’ list. 
6 Enter “ou” in the Find text area.
7 Choose the text from the first “o” to “ou” and click the Group button. 
8 Enter “r” in the Find text area.
9 Choose Word Boundary from the Elements’ list. 

Example B: Finding “permutations”
Let’s say you want to find every permutation of the word “permute”. For the sake 
of brevity, we’ll pretend there are only three of those: permutate, permuted, and 
permutation. The search string will be quite simple to prepare: 

Figure 148: Permutate

The first part of the expression, “permut” is common to all the words we look for. 
The variations occur later on, so we enter them all and group them with an “Or” 
symbol between them. 
This is quite simple to do. However, suppose we get greedy and want to find each 
and every permutation of permute. That’s also very simple to do:
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Figure 149: Every permutation

To create the findex in the above example:
1 Activate the Find by choosing Edit > Find > Find... or pressing the Cmd+F 

keyboard shortcut. 
2 Enter “permut” in the Find text area. 
3 Choose Letter from the Elements’ list. 
4 Choose the Letter element and click the Group button. 
5 Double-click the Letter element and in the dialogue box choose Once or more 

from the Type pop-up menu, and check the Greedy check-box. 
6 Click the OK button.

To HTML and back
In this short tutorial you will learn how to utilise Mellel’s findex to convert HTML 
tags into regular Mellel styles, and then get back to HTML. To simplify the tutorial, 
we will show here how to change the bold tag (<b>) into bold text and back.

From <b> to bold
To create the material for this tutorial, create a new document and enter the text 
“to <b>boldly</b> go!”:

Figure 150: Going boldly

1 Choose Edit > Find > Find… (or press Cmd+F).
2 In the Find dialogue box, within the Find area, enter the text “<b>” and group 

it. 
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Figure 151: <b> grouped

What you did so far is to enter the typical opening tag for bold text in HTML, and 
group it. 
3 From the Element menu enter the element Any Character. 
4 Double-click the Any Character element and from the Repetition menu choose 

Once or more. 
5 Group the element.

Figure 152: Two groups

What you did here is enter a findex expression that will fit any word or number of 
words, so that anything within the two bold tags will be selected. 
6 Again within the Find area, enter the text “</b>” and group it. 

Figure 153: Closing tag

What you did so far is to enter the typical closing tag for bold text in HTML, and 
group it. 
Just to make sure that everything works just right, press the Next button. The bold 
tags should be selected, as well as anything within the tags. 
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Figure 154: Selecting boldly

7 Select the second group (numbered 2) in the Find area and drag it into the 
Replace area (you can also copy and paste it or insert a Backreference element 
and then set its group reference to 2). 

What we did here is to create a backreference only to the content within the tags. 
The result would be that while the content will be maintained, the tags will be 
erased. 
8 With the insertion point in the Replace area, choose Bold from the Face menu in

the Character palette. Alternately, you can choose a character style from the 
Styles tab of the Character palette set the style variation in the Attributes tab to 
whatever you’ve set as the “bold” variation. 

What we did here is to set the formatting of the text within the tags to be in bold 
face. 
9 Press the Replace All button. The end result should be something like the 

following:

Figure 155: All’s bold that ends bold

From Bold to <b>
Changing formatting to HTML tags is the reverse of the process of turning HTML 
to Mellel formatting. In this part of the tutorial, we’ll use the text converted in the 
first part of the tutorial, and convert it back.
1 Choose Edit > Find > Find… (or press Cmd+F).
2 From the Element menu of the Find field, select the element Anything. Entering 

this element as an expression will cause Mellel to skip searching in the text 
and simply locate all instances of the formatting in the text.
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Figure 156: Anything

3 From the Character palette, choose Bold from the Face menu. 
4 Move to the Replace field. Enter “<b>” and then select Found Expression from 

the Element menu. Finally, enter “</b>.” 

Figure 157: <b> and </b>

5 While still in the Replace field, from the Character palette, choose Regular from 
the Face menu. 

6 Press the Replace All button. The end result should be something like the 
following:

Figure 158: The end result

Find Actions and FindSets tutorial
The following tutorial will teach you how to create FindSets and run them. It will 
also teach you a bit more about findex and Find Actions. The object of this tutorial
is to create a FindSet that will replace every lower key character in a certain 
character style into a small cap character, appropriate for use with screenwriting. 
In preparation for this tutorial, create a new character style and name it 
“Character”. Set the base variation font to Courier and the font size to 13 points. 
Set the second variation (“B”) to Courier 11.5 points. Save the style. 
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Note: If you really dislike working with styles, skip this preparatory stage. Bear in mind, 
though, that in real practice, this will prevent you from telling if the text you want to 
change is really the character name or not.

1 Create a new document and enter some dummy text in it, for example, like 
this:

Figure 159: Steve gets excited

2 Set the character style of the character name to “Character” and set another 
character style for the rest of the text (for our purpose, the style can be 
identical to “Character”, so you can simply duplicate it).

3 Open the Find and Replace dialogue box and enter “a” in the Find field and “A” in 
the Replace field. 

4 Uncheck the option Ignore Case in the Options area. 
5 Move to the Find field, and and from the Character menu (or the Character Style 

palette) select the style “Character”.
6 From the Character Style palette, select the base variation. 
7 Move to the Replace field, and from the Character menu (or the Character Style 

palette) select the style “Character”.
8 From the Character Style palette, select the second variation (the one you’ve set

to Courier 11.5). 

Note: if you did not use styles earlier on, there’s your chance, instead of following steps 5-8, 
to set the options manually. 

9 Click the Save Find Action... button and save the action under the name 
“Script aA”

10 Move to the Find field and enter “b” instead of “a” and then move to the 
Replace field and replace “A” with “B”. Save this action under the name “Script 
bB.” 

11 Repeat for the rest of the alphabet (or for as many letters as you like). 
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12 When done, choose Edit > Find > Edit FindSet to open the Edit FindSet dialogue 
box. 

13 From the Available Find Actions list drag all the actions you’ve created into the 
FindSet contents list on the left. 

14 Click the Save FindSet... button and name the FindSet (e.g., “Small Caps”). 
15 Click the Run FindSet button. All the Find Actions will now run sequentially, 

with the number of replacements noted and the actions run. The end result 
should be something like the following:

Figure 160: Steve in small-caps

Note that the character name style changed, but the capitalisation was 
maintained and the rest of the text remained unchanged.
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Auto-titles (headings)
This chapter explains how use auto-titles to enter headings, captions 
and more into your documents

Should I read this chapter?
You should read this chapter if you’re writing longer documents, with 
headings, figures, captions, and so on

What is an Auto-title
Auto-title is a feature that allows you to create structural headings in your, add 
captions to tables, images, figures and the like, and more. Auto-title attributes are 
saved to a setup file that contains all the headings, captions and their formatting. 
Every auto-title in a document is an object objects, that can contain several 
elements, such as titles, numbering, tabs, and more. Take, for example, the 
following auto-title:

Figure 161: An “Article” Auto-title

If you examine this Auto-title in the Edit Numbering Flows dropping sheet, you will 
see that it is composed of three separate elements (“Curr#,” “Title” and “Tab,” and 
some free text:

Figure 162: The elements in “Article”

Every auto-title belongs to a title flow—a sequence of Auto-titles of a certain 
type, like chapters, headings, small heading, and so on. Belonging to a title flow 
means that all the headings of a certain flow will have the same format and 
contain the same components. For example, every heading at the “Article” flow 
level displayed above will include the same “Curr#,” “Title” and “Tab” elements, the 
same formatting, and so on. 



Auto-titles that belong to a certain flow, are numbered according to their position
in the sequence of auto-titles in the document. A simple sequence of “Chapters” 
flow may look something like the following:

C1

C2

C3

C4

Figure 163: A simple flow

When you enter a “Chapter” auto-title, for example, Mellel will enumerate all the 
headings in the “Chapter” flow there are in the document, and number or 
renumber all the headings according to its position in the sequence. For example, 
if you add a new “Chapter” heading between the first and the second, the heading
will be numbered ‘2’ and the second heading (now the third) will be numbered ‘3’.
Title flows (or headings) are part of a hierarchy of title flows. For example, the 
“Chapter” title flow may be the top flow in the hierarchy, “Heading” might come 
next, then “Sub-heading,” and so on. A simple hierarchy of flows is visualised in 
the following simple diagram:
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Figure 164: A simple hierarchy of flows

In this diagram you can see three flows: Blue is the top level, Yellow is the second, 
and Green is the third. Whenever a blue flow item heading is entered, the 
numbering of the Yellow flow is reset, and the same is true for the Green flow, 
whenever a Yellow flow item is entered.
Mellel’s job is to keep things in order: count all the flows, at every level, and 
number them according to their position in the flow, and vis-à-vis flows that are 
higher in the hierarchy. 

Types of flows
There are two types of flows you can use to insert Auto-titles in Mellel: structural 
flows and tag flows. Each type of flow has its own special usage and unique 
attributes. 

• Structural flows are hierarchical flows. There are 10 such flows in every set of 
flows.

Auto-titles (headings)241



Figure 165: Structural flows in the Edit Title flows sheet

Note: You cannot add, delete, or move a structural flow. 

• Tag flows are flows you can locate under any structural flow, and use to insert 
captions or unnumbered headings. You can have up to 99 tag flows. You can 
also delete tag flows, and move them around.
Tag flow are reset when the structural flow underneath which they are located
is reset. For example, if you locate a tag flow under Flow 6, its numbering will 
be reset whenever an auto-title belonging to Flow 6 will be entered into the 
document. Following that logic, if you locate a tag flow under Flow 1, it will 
not be reset at all (as the top level flow is never reset).

Figure 166: Tag flows with structural flows

Note: You can tell Mellel to avoid re-numbering a flow when a higher level heading is en-
tered by un-checking the option Reset with a higher level flow. 

Stuff you can do
To... Do this Keyboard Shortcut
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Enter an auto-title 1 Choose Window > Palettes > Auto-titles to open the 
Auto-title palette (the palette may already be open).

2 Do one of the following:
• Choose Insert > Auto-title > <any title flow>. Or,
• Select a title flow in the Auto-title palette and 

click Insert. Or,
• Double-click a title flow in the Auto-title palette.

3 If the option Prompt for title when inserting is 
checked for this auto-title in the Edit title flows setup
dialogue box, Mellel will prompt you to enter it. If 
the option is un-checked, the auto-title will be 
entered with a dummy title (“Untitled”). 

Edit an auto-title • Do one of the following:
• Click the auto-title to select it, then click again to 

enter editing it. Or, 
• Option+Click an Auto-title to enter editing 

directly. Or,
• Double-click the Auto-title to edit in the Title 

dialogue box. Or,
• Double-click the auto-title in the Outline pane. 

Note: You can edit an Auto-title’s title even if not prompted
to enter one when you enter it, if the title is invisible or even 
completely missing from the title flow format.

Delete an auto-title • Do one of the following:
• Place the insertion point immediately following 

the auto-title and press the Backspace key.
• Place the insertion point immediately before the 

Auto title and press the Delete key.
• Select the auto-title and press the Backspace or 

Delete key.

Duplicate an auto-title 1 Select the auto-title and choose Edit > Copy. 
2 Place the insertion point where you want the 

duplicated auto-title and choose Edit > Paste. 

Move an auto-title 1 Select the auto-title and choose Edit > Cut. 
2 Place the insertion point where you want the 

moved Auto-title to appear and choose Edit > Paste.
Note: When you delete, duplicate, or move an Auto-title, 
the numbering of all the Auto-titles coming after this Auto-
title may change, depending on its hierarchical location.

Start editing title flows • Do one of the following:
• Open the Auto-title palette and press the Edit Title 

flows button. Or, 
• Choose Insert > Auto-title > Edit Title flows...
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Change the selected 
auto-title setup:

• Do one of the following:
• Choose a setup from the Setup pop-up menu in 

the Auto-title palette.
• Click the Edit title flows button in the Auto-title 

palette and in the Edit title flows dropping sheet 
select a setup from the Selected setup pop-up 
menu.

• Choose Insert > Auto title> Edit title flows... and 
select a setup from the Selected setup pop-up 
menu.

Important note: When you change the Auto-titles setup, 
the format and appearance of all the Auto-titles in the 
document will change to fit the formatting attributes of 
the new setup.

Set the default auto-
title setup

1 Choose Mellel (menu) > Preferences....
2 Under the Styles section, select the Auto-title default 

setup.

Change the formatting
of an auto-title (from 
the document)

1 Enter editing the auto-title (using one of the 
methods shown here.

2 Format using the relevant palettes.
Note: To keep the way your document looks consistent, 
you might find it useful to use styles rather then ad-hoc 
changes. 

Change the display 
direction of auto-title 
setups

• In the Edit title flows dropping sheet, choose Left to 
right or Right to left from the Display direction pop-up
menu. 

Note: the Display direction pop-up menu changes the 
display in the Edit title flows dropping sheet but have no 
effect on the setup or the way it functions. 

To create a new auto-
title setup

1 Select any of the setups in the Selected Setup pop-
up menu. 

2 Press the Save As... button. 
3 Give the setup a name of your choice and click OK. 

Delete a setup • Do one of the following:
• Select any of the setups in the Selected Setup pop-

up menu and press the Delete Setup button. Or,
• In the Finder, navigate to your user folder/

Library/Application Support/Mellel/AutoTitles 
Setups and remove the setup you wish to delete.

Add a setup (from the 
Finder)

1 Copy the setup(s) you wish to add.
2 Navigate to your user folder/Library/

Application Support/Mellel/AutoTitles Setups and 
choose Edit > Paste.
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Save changes to a 
setup:

1 Press the Save As... button.
2 Remove the added “(Changed)” from the setup 

name and click OK.

3 Mellel will ask you whether you want to replace the
existing setup with the new one. Press OK.

Revert a changed 
setup to the last save

1 Select the setup name from the Selected Setup pop-
up menu.

Save a setup under a 
different name:

1 Press the Save As... button.
2 Enter the new name for the setup and click OK.

Change the name of a 
setup (from the Finder)

• Navigate to your user folder/Library/
Application Support/Mellel/AutoTitles Setups, 
select the setup and change its name (but keep the
“asup” filename extension.

Select a title flow • Click on the flows’ name in the title flows list. 

Change a title flow’s 
name

1 Double-click the title flow name in the Title flows 
list. 

2 In the Level Name dialogue box, enter a new name 
and press OK. 

Add a tag title flow • Press the Add button. An “Untitled Stream” tag flow 
will be added to the Title flows list.

Delete a tag flow • Select the tag title flow in the title flows list and 
press the Delete button. 

Change the position of
a tag flow

• Press and hold the tag title flow and drag it to the 
desired position. A thin black line will appear to 
indicate under which title flow it will reside. 

Change the 
numbering unit for a 
title flow

• Select one of the options from the Numbering pop-
up menu. 
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Set the initial number 
for a title flow

• Do one of the following:
• Select the number in the Start at text box and 

enter a new value. 
• Press the stepper up or down arrows to change 

the start value. 

Set the numbering 
increment for a title 
flow

• Do one of the following:
• Select the number in the Increment text box and 

enter a new value. 
• Press the stepper up or down arrows to change 

the increment value.

Be prompted to enter 
a title when inserting 
an auto-title

1 Select a title flow from the Title flows list.
2 Check the option Prompt for title when inserting.

Include or exclude a 
title flow from the 
Table of Contents:

1 Select a title flow from the Title flows list.
2 Check the option Include in TOC.

Be prompted to enter 
a title when inserting 
an auto-title

1 Select a title flow from the Title flow list.
2 Check the option Prompt for title when inserting.

Include or exclude a 
title flow from the 
Table of Contents

1 Select a title flow from the Title flow list.
2 Check the option Include in TOC.

List figures, tables, 
charts as a separate 
ToC section. 

• In the Edit title flows dropping sheet, choose a tag 
flow and check the option List as separate section in 
TOC. 

Insert an element into 
the format area

• Select the element you wish to insert from the 
Elements pop-up menu. 

Remove an element 
from the format area

• Select the element and press the Delete key (or use 
any other conventional method for removing text 
(e.g., cut, back-space). 

Enter, change, select or
delete text into the 
format area

• Click or select the text and use any conventional 
method for editing text. 

Change the position of
an element in the 
format area

• Select the element and then cut and paste it into 
the desired location. 

Edit the Prev# element 
flow

1 Select a Prev# element.
2 Click the ‘stepper’ at the right end of the Prev# 

element and select the desired flow level.

Change the paragraph 
attributes of the 
format

• Click inside the format area and choose a 
paragraph style or any attribute from the 
paragraph palettes.
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Change the character 
attributes of text or 
elements in the format
area

• Select the text or elements you want to change 
and choose a character style or any character 
attribute from the character palettes. 

Force an auto-title to 
use the paragraph 
attributes of the 
surrounding text in the
document

• Click inside the format area and do one of the 
following:
• Choose Paragraph > <Use Surrounding>.
• Double-click <Use Surrounding> in the Paragraph 

palette.

Force an auto-title to 
use the character 
attributes of the 
surrounding text in the
document

• Select text or elements and do one of the 
following:
• Choose Character > <Use Surrounding>.
• Double-click <Use Surrounding> in the Character 

palette.

Have a chapter begin 
at the top of the next 
page

• In the Edit title flows dropping sheet select from the 
Insert before pop-up menu the option Page Break (or 
Page style break). 

Create a ToC with both 
numbered and un-
numbered items at the
same level

It is often required to create auto-titles which are 
numbered (e.g., chapter 1, 2, 3, etc.) and un-
numbered (e.g. Forward, Bibliography, Table of 
Contents), that should be listed in the Table of 
Content as items at the same level. Here’s how to do 
it:
1 In the Edit title flows dropping sheet select the level 

at which you wish to have the heading (usually the 
top level) and press Add to add a tag flow at that 
level. 

2 Apply all the attributes used with the auto-title 
heading, except for the numbering, of course. 

3 Un-check the option List as separate section in ToC. 

The Auto-title palette
The Auto-title palette allows you to enter headings and captions and edit the 
setup for all the flows.
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Structure 
levels

Insert Auto-title

Edit title flows

Tag levels

Select a Setup

Figure 167: The Auto-title palette

• Title flows list: lists all the title flows available in the currently selected auto-
title setup. The list contains both Structure levels and Tag levels. 

• Insert Auto-title: allows you to insert the selected title flow (in the Title flows 
list) into the document text.

• Edit title flows: opens the Edit title flows dropping sheet, allowing you to edit 
all the options and settings for the current auto-title setup.

• Setup: allows you to select an existing setup from the pop-up menu. 

The Auto-title sub-menu
The Auto-title sub-menu, available via Insert > Auto-title, includes the same options 
offered by the Auto-title palette. 

The Edit title flows sheet
The Edit title flows dropping sheet allows you to edit all the attributes of an auto-
title setup, and set the appearance of your table of contents, mentions, outline 
and cross references. 
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The Edit title flows dropping sheet can be divided into four main areas, as displayed
in the following illustration:

Setup selection, 
saving, and editing

The title flows list

Title flow general 
options

Format area

Figure 168: The Edit title flows dropping sheet

• Setup selection, saving, and editing: In this section of the sheet you can 
create, load, save or delete setups. 

• The title flows list: allows you to add and delete tag flows, rename title flows 
and change the position of tag flows in the hierarchy. 

• Title flow general options: allows you to set and change some general title 
flow options such as the numbering unit, inclusion in Table of contents, listing
in the Table of contents, prompting for titles, and more. 

• Format area: Here you can edit the title flow format, its styling and change 
the format for the table of contents, mentions, cross-references, and so on.
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Auto-title setup area
The setup options allow you to create, save, delete, add, or remove title flows 
setups. Through the Selected setup pop-up menu you can also switch setups, thus 
switching the entire document from one set of auto-title formatting to another.

• Selected setup: pop-up menu allows you to select any of the existing auto-
title setups. 

• Save setup...: Choosing this option you’ll be able to choose save the currently
used setup (or overwrite the existing one). 

• Delete setup: allows you to delete the currently selected setup. 

Title flows list
The title flow list allows you to select title flows, add tag flows, delete tag flows, 
change the name and position of tag flows, and change the name of title flows. 

• Delete: deletes the currently selected tag flow.

• Add: Adds a new, untitled tag flow to the title flows list.

General options
The general options area contains options that allow you to manipulate the 
numbering used with the selected title flow, control its inclusion or exclusion 
from the Table of Contents and its title. 

Numbering options
There are several numbering options to control the numbering of a title flow. 

• Numbering unit: allows you to set the numbering unit for a title flow. Every 
flow must have a numbering unit, even if no numbering is included in the 
flow format or displayed. 

• Start at: allows you to set the initial number where a series of Auto-titles in a 
flow will start. The default value is 1, and unless you have a very specific 
numbering scheme in mind, you should leave it unchanged. 

Note: The start number can be a negative number or zero, but bear in mind that some 
numbering schemes do not allow for negative values or zero. If you set the Numbering unit
to Greek and the Start at value to -2, for example, the result would be that the first three 
Auto-titles in the flow will contain the first available value, not a non-existent negative 
value.
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• Increment: This option allows you to set the flow’s numbering increment. The 
default value is 1. Unless you have a very specific reason to use a different 
increment, you should leave it unchanged. 

Insert before
The Insert before attribute allows you to set what would precede the auto-title. The 
default is Return. The options in the pop-up menu are:

• None: the auto-title will not be preceded by anything. This is useful if you 
want the heading or the tag flow to appear in mid-line. 

• Return (the default): Insert a Return sign before the auto-title. 

• Column break: Insert a Column break before the auto-title. If the section have 
just one column, the auto-title will be at the top of the next page.

• Page break: Insert a Page break before the auto-title.

• Page style break: Insert a Page style break before the auto-title. 

Inclusion options
The inclusion options let you set if a title flow will be included in the Table of 
Contents or if you will be asked to enter a title for the title flow. 

• Prompt for Title when inserting: When this option is checked, when 
entering an auto-title into the document text you’ll be asked to enter a title.

Note: when Prompt for Title when inserting is checked, you will be asked to enter a title even 
if the title flow format does not include a title option. In such cases, the auto-title will in-
clude a hidden title.

Tip: Entering a title even when the title is not visible in the document text can be useful as a 
means to add comments. It can also be helpful as a way to display meaningful titles with 
a numbered numbering scheme (e.g. 1.1.1,). Those titles may be included in a Table of Con-
tents or in the Outline. 

• Include in TOC: When this option is checked, all auto-titles in the currently 
selected flow will be included in the Table of Contents (ToC). 

• List as separate section in TOC: This option is only applicable to tag flows 
that are included in the ToC. When this option is checked, the tag flow will be 
listed separately in the ToC. When the option is not checked, the tag flow will 
be listed as part of the ToC. 
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Reset numbering with higher level flow
This attributes allows you to control whether the numbering of a flow will be reset
when you enter an auto-title of a higher level flow. The following table 
exemplifies the difference between the two states.

Reset numbering checked Reset numbering un-checked

The format area
The format area allows you to set and design your title flows appearance, set the 
options for the Table of Contents, Mentions, Outline and Cross reference. The 
auto-title Format tab contains the basic formatting for the heading or tag level, 
and the Table of Contents, Mentions, Outline and Cross reference tabs help you design 
and forma the way the heading or caption will look when used in the outline, the 
Table of contents, and so on. 
The format edit area contains four main areas:

• Elements list: This pop-up menu allows you to select an element you wish to 
insert into the formatting area. 

• Ruler and tab well: allows you to visualise, as well as design the format. 

• Format area: allows you to edit the elements, add text, apply formatting and 
styles, and so on. 

• Preview: The preview displays a preview of the way the auto-title will look in 
the text. 

Element list
The list of elements you can use in formatting your title flow includes several 
elements:
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breakTitleTab

Current 
level

Previous 
level

Figure 169: A typical auto-title format

• Title: allows you to enter a title for the auto-title.

• Current Level # (Curr#): allows you to enter the level number of the current 
title flow. 

• Previous Level # (Prev#(1)): allows you to enter the level number of any title 
flow on a higher level than the currently selected title flow. You can select the 
level you wish to refer to from the pop-up menu appended to the element. 
Once entered the Prev# element will inherit the numbering and the 
numbering unit of that level. For example, if you enter a Prev# referring to a 
Level 1 auto-title with the numbering unit Latin, it will display in the text as “a” 
(or “b” or “c,” etc., depending on the actual numbering of this auto-title). 

• Tab: allows you to enter a tab as part of the title flow format. 

Note: If there is no tab in the Ruler (or if you’ve selected a paragraph style that contains not 
tabs), any part of the auto-title following that tab will be flowed to the next line. If you 
want to flow an element to the next line, use the Line break element . 

• Line break: Use this element to insert a line break.

• Variable (Var): allows you to insert a document variable from the Document 
variables list. I is useful if you use document-specific variables such as the 
document title, subject, author, and so on. 

• Page #: This element, available only for mention and ToC editing, allows you 
to insert a reference to the page in which the Auto-title appears.

Auto-titles (headings)253



Ruler and Tab well
With the Ruler and the Tab Well you can add and remove tabs and to change the 
Start, end and Indent positions. The results of your changes can be viewed in the 
Preview area. 

The format area
The format area is a simply text editing area, where you can add text, insert 
elements from the Elements pop-up menu, and apply various character and 
paragraph options and styles from the Character and Paragraph palettes. 

The Preview area
The Preview displays the formatted auto-title as it would appear in the text. The 
numbering of the titles is dependent on their actual position in the text, and in 
the Preview area they will be displayed as if they were the first of their type (for 
example “1.a.1”).

TOC Editing
For information about Table of Contents and Table of Contents editing, see the 
guide section about Table of Contents.

Mention Editing
For information about Mentions and Mention editing, see the guide section 
about Mentions.
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Outline
This chapter explains tells you what the outline is, and how to use it 
to view and change the document structure

Should I read this chapter?
You should read this chapter if you write long or ordered documents and 
want to make the most out of the outline feature in Mellel

What is the Outline
The outline is a special skeleton view of the entire document contents, displaying 
only the most important elements: headings, captions, bookmarks, and so on—
displayed as a hierarchical list or, alternately, as a hierarchical list of the headings, 
with bookmarks, captions and the like displayed separately.

Document structure view
The Outline pane display the document’s structure—a hierarchical list of all the 
headings entered as Auto-titles in the document. The figure below exemplifies 
this correspondence between auto-titles in the document and the outline:

Figure 170: Auto-titles and corresponding outline items



The Outline pane will not display just the main headings: every heading in the 
document will be displayed as well.

Figure 171: A hierarchical outline

The headings displayed in the outline are connected not only to the headings in 
the text, but also to the content following those headings. For example, when you
select headings in the outline, you also select the content following them up to 
the next heading at that level.
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Figure 172: Heading in the outline and related content

Non-structural elements view
The Outline pane also displays non-hierarchical (i.e., non-structural) elements in 
the document, such as captions for tables and figures, or bookmarks. Non-
structural elements are based on a special type of auto-title flows called Tags (see 
Auto-titles).
You can view tags in their place within the structure of the document (Combined 
view) or separated, at the bottom of the structural list (Separated). 

Stuff you can do
To... Do this Keyboard Shortcut

Show or hide the 
Outline pane

• Press the Show/Hide Outline button.
Note: you can also close the open Outline pane by 
Double-clicking the Outline pane separator.

Toggle combined/
separate view for Tags

• Press the Toggle combined/separate view button at 
the bottom of the Outline pane.

Change the width of 
the Outline pane

• Do any of the following:
• Press the Outline pane button in the toolbar. Or,
• Click and drag the Outline pane separator to the 

left or to the right.
Note: There is a minimum width limit to the Outline pane 
when it is visible. 
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To add an outline item 
from the outline

1 Select an item in the Outline pane after which you 
want to add an item. 

2 Ctrl-click (in the Outline pane) to open the 
contextual menu, and from the Insert menu select 
the type of heading you want to add.

3 Enter the heading title (if needed) and press the OK
button. 

Note: If you enter a new item, Mellel will expose it in the 
Outline pane. For example, if you enter a fourth-level item 
in the document, the outline pane will expose it (by 
“disclosing” the levels above it in the Outline pane) even if 
the disclosure triangle was initially closed. 

To add an outline item 
from the document

1 Place the insertion point in the document.
2 In the Auto-title palette double-click the type of 

heading you wish to add. 
3 Enter the title for the item (if you need to), and 

press the OK button.

Delete an outline item • Click to select the outline item in the Outline pane, 
and press the Delete key.

Important: When you delete an outline item, you also 
delete the text and other auto-titles in the document itself 
to the next item at the same level. 

Edit an existing outline
item

1 Do one of the following:
• Double-click the item in the Outline pane. Or,
• Click an item in the Outline pane and press the 

Return key.
2 Edit the Title content, and click the OK button. 
Note: If the Outline item setup does not include a Title 
element or does not prompt you to enter a Title, it may not 
be displayed or may be displayed as “Untitled” until you 
edit it. 

Move content within 
the document

• Select a heading in the Outline pane and drag. 
• To extend the selection: Press the Shift key and 

click another item (All the items between the 
initially selected item and the clicked item will be
selected. 

Note: You can also collapse or expand the items display in 
the Outline pane to make selecting items easier. 
Note: You cannot move a tag item in the Outline pane on 
its own. 

Remove content from 
the document

• Select a heading in the Outline pane and press the 
Delete button. The entire content of the document 
from that point to the next heading at that level 
will be removed. 

Promote or demote an 
item

• Select the item to promote or demote and press 
the Demote or Promote buttons.

Note: You cannot promote or demote a tag flow item, as it
is not part of the hierarchy. 

Cmd+Right/Left arrow
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To change a heading 
level

1 Select an outline item in the Outline pane or an 
auto-title in the document. 

2 Do one of the following:
• Ctrl-click to display the contextual menu and 

select an item from the Change sub-menu. Or,
• Choose Edit > Change and select an item from the

Change sub-menu. 

Change the 
appearance of outline 
items

1 Open the Auto-title palette and click the Edit title 
flows button. 

2 Select a title flow from the Title flows list on the left 
and click the Outline format tab. 

3 Check the check-box Use a different format for 
Outline. 

4 Edit the format and then save the changes for the 
format or OK (so changes will be applied to the 
currently open document only). 

Go to a certain point in
the document

• Click an outline item in the Outline pane. 

Jump to the head of 
the document

• Click on the Structure heading at the top of the 
Outline pane. 

Move to the next or 
previous item in the 
outline

• Click the item above or below the currently 
selected item in the Outline pane. Or,

• Press the Arrow Up or Arrow Down keys. 

Collapse or expand an 
item’s sub-levels in the 
Outline pane

• Press the disclosure triangle next to the desired 
item.

Collapse or expand an 
entire hierarchy of 
items

• Press the Option key and then the Disclosure 
triangle next to the desired outline item.

Move from the Outline 
pane to the main 
document area

• In the Outline pane, press the Tab key. The insertion 
point will move to a position next to the selected 
outline item. 

Note: If not item was selected in the Outline pane, the 
insertion point will be at the last place you’ve entered text 
in the document.

Move from the 
document area to the 
Outline pane

• Click an item in the Outline pane. 

Navigating via the outline
One of the main functions of the outline is to allow you to view the document as a
whole, ‘summarising’ its content to headings, and to navigate it with ease. You can
navigate the document via the Outline pane by simply clicking on outline items or 
via the arrow keys.
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Editing outline items
Mellel allows you to change the appearance of items in the Outline pane by 
changing the Outline format attributes in the Edit title flows dropping sheet (see 
Auto-titles). Changing the appearance of outline items can be beneficial if you 
want to add or subtract information about the outline items. For example, you 
can shorten some words, eliminate item numbering or eliminate the titles from 
the outline display. 

Charts section 
of the outline

Equations section 
of the outline

Document text

Figure 173: Unneeded information removed

The Outline pane
The Outline pane, located on the left side of the document window consists of 
three parts:

• Structure section: is at the top of the Outline pane, listing all the headings in 
the document.

• Tags section: appears below the Structure and lists tag flows such as captions
or bookmarks. The Tags section is optional and can be hidden.

• Buttons section: is at the bottom of the Outline pane, and allows you to 
control and change the outline display and items hierarchy.
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Editing the document structure
In addition to its function as a structural view of the document, the outline can be
a very useful tool for editing the document structure. By simple drag and drop, 
you can move entire sections and chapters from one place to the other, change 
the position of items in the document hierarchy, add and delete items, and more. 

Changing, promoting, and demoting items
The outline allows you to easily change the position of headings (auto-titles) in 
the document hierarchy. For example, let’s you create a document with chapters 
and sub-chapters, but later decide that all the sub-chapters should really be 
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chapters as well. Instead of sipping through the headings and changing them, 
you can simply ‘promote’ the sub-chapters in to the same level as the chapters, 
without changing anything else in the document. 
Another option available via the Outline pane (as well as via the document itself, 
of course) is to change the level of a heading. Promoting/demoting and changing
are similar in what they do to the selected heading, but are very different in the 
implications of the change. 
When you change an item in the document or the Outline pane, only that item 
will change. When you demote or promote an item, you will also change the 
position in the hierarchy of all the items below it, down to the next heading at the
same level. 
For example, let’s say we have the following situation:

Figure 174: Only three levels here

If we change the selected item to that of a Level 2 item, no other heading will be 
affected:

Figure 175: Nothing changed in what follows this item

If, on the other hand, we’ll demote the heading, the result will be completely 
different:
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Figure 176: A completely different result: other headings changed their level too
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Track Changes
This chapter explains tells you what track changes is, and how to use 
it make changes and to track them

Should I read this chapter?
You should read this chapter if you or others edit your documents and 
make changes to them, or if you need to collaborate with people who use 
track changes

What is Track Changes
Track Changes (TC) allows you to record (‘track’) changes in your document, so 
that you or others can review those changes and decide if they want to accept 
them (that is, incorporate them in the document) or reject them (discard the 
change). TC is a useful feature if you work in collaboration with others and need to
view changes made by them before deciding whether those changes are 
acceptable to you.

What changes are tracked
Not all the changes you make in a document are tracked. As a useful rule of 
thumb: Mellel will track just about any editing or styling but it will not track 
changes to saved styles. Following is a table that will help you figure out what 
type of changes are recorded, and which are not recorded by TC.

Table 20: Tracked Changes
Change Tracked

Editing changes in the text ✔
Paragraph attributes ✔
Character attributes ✔
Page attributes ✔
Search and replace ✔
Tables Only changes in text in the tables

Auto-titles ✔
Citations ✔



Style sets ✖
Replace Styles ✔
Note style changes ✖
Auto-title setup ✖
Scan/unscan bibliography ✖
Changes in floating images ✖

Stuff you can do
To... Do this Keyboard Shortcut

Activate Track Changes • Press the Track Changes button in the toolbar.

Exit Track Changes 1 Press the Track Changes button (when the button is 
depressed). 

2 Choose if to Accept all changes, Reject all Changes, or 
Cancel (return to Track Changes mode). 

Show the Track 
Changes pane.

• With the Track Changes activated, press the Show 
Track Changes button.

Hide the Track 
Changes pane

• With the Track Changes activated and the Track 
Changes strip visible press the Hide Track Changes 
button.

Change the Track 
Changes display mode

• With the Track changes strip displayed, press the 
Display mode pop-up menu and choose one of the 
options. 

To pause track changes • Press the Pause button ( ).

To resume tracking 
changes when paused

• Press the depressed Pause button ( ).

To accept or reject a 
change

• With the Track changes strip displayed, click a 
change ‘bubble’ and then click the Accept or Reject 
buttons. 

To view different 
authors changes

• With the Track changes strip displayed, press the 
Author pop-up menu and choose one of the 
options. 

To move between 
changes

• With the Track changes strip displayed, press the 
Next ( ) or Previous ( )buttons to move to the 
next or previous change.

To move between 
changes of a particular
author

1 With the Track changes strip displayed, press the 
Author pop-up menu and choose the author’s 
name.

2 Press the Next or Previous buttons to move to the 
next or previous changeץ 

Track Changes265



To view the next set of 
changes (when they 
cannot all be displayed
in the pane)

• With the Track Changes pane displayed, press the 
Next or Previous button at the bottom of the Track 
changes pane. 

To change the author 
name and/or colour

1 Choose Mellel (menu) > Preferences...
2 Under the Document setup tab change the User 

Name or the User Colour.

The Track Changes Strip
The TC pane allows you to scroll between changes, change the way they are 
displayed in the text, show or hide the TC pane, pause and continue tracking 
changes, and view a particular author of changes, or all the changes.

Show/Hide Track Changes Pane
The Show/Hide TC pane button appears at the left end of the strip. 

• Show Track Changes pane: will display the TC pane. When the TC pane is 
open, changes will be displayed in the pane. 

• Hide Track Changes pane: will hide the TC pane. When the TC pane is closed, 
changes will be marked by a gray vertical line (for style changes) or a black 
vertical line (for text changes). 

Display Mode
The Display mode pop-up menu allows you to change the way changes are 
displayed in the document.

Original
With this display mode the text is displayed in its original form, before any 
changes were made. 

Figure 177: Original display mode
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As you can see, changes such as deleted or replaced text are not displayed, but 
are marked (if the TC pane is visible) but styling changes (and changes to such 
things as sections (columns) settings are always displayed, even when in original 
mode.

Note: when you make a change to the text in Original mode the display mode automati-
cally switches to Show Changes mode. 

Show changes
With this display mode the text is displayed with all the changes visible. 

Figure 178: Show Changes display mode

As you can see, deleted, replaced or attributes changes are displayed. This is the 
preferred display mode when you want to see all the changes you’ve made. 

Final
With this display mode the text is displayed in its final mode, marking the place 
where deletions, additions or other changes were made. 

Figure 179: Final display mode

As you can see, deleted, replaced or attributes changes are not displayed but 
marked.
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Final with markup
With this display mode the text is displayed with additions marked. 

Figure 180: Final with Markup display mode

As you can see additions are marked with the user colour. Deletions are marked 
but not displayed, of course.

Author
The Author pop-up menu allows you to choose which author changes will be 
displayed in the TC pane. 

Pause
The Pause button allows you to halt the recording of changes. When the button is 
pressed the changes you make will not be tracked (‘recorded’). 

Next and Previous change
The Next and Previous change buttons allows you to scroll the changes in the 
document. The scrolling is done for the displayed changes only (e.g., if you have 
some changes hidden, they will not be included in the scrolling). 

The Track Changes pane
The TC pane allows you to view the changes in ‘bubbles’. A line from each bubble 
points to the change made in the text.

Bubbles
The bubbles contain information about the change and allow you to accept it 
(that is, incorporate it in the text) or reject it (that is, eliminate the change from 
the text). Each bubble has a distinct colour, indicating a distinct author. 
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The bubble includes four important items: the Accept/Reject buttons, which 
allow you to accept or reject a change, the Author’s name, the Date, and 
information about the change, including the beginning of the content deleted (in
case of a delete), the text replaced (with a replace), the character or paragraph 
attributes changed (with such a change), and so on. 

Next or Previous Set of changes
When some of the changes made in a page cannot be displayed in the TC pane, 
Next/Previous buttons appear at the bottom of the pane. You can use the Next or 
Previous buttons to view the next set of changes at the bottom of the page, or the 
previous set, if you’ve already viewing the next set of changes. 

The preferences options
In the Preferences, under the Document setup tab, you can manipulate two options: 
the User Name for Track Changes, and the User Colour. Changes to either will only 
be in effect the next time you open the document or with a new document. 
The Preferences options allow you to change your own identification from session 
to session and from one document to the other. This may be useful, for example, 
when you perform several separate iterations of changes to the same document.

Collaborating and other tips
Track Changes is a tool for collaboration, and the main features of Track Changes 
in Mellel are tailored to working in collaboration with others and adhere to the 
accepted ‘lingo’ and terms of Track Changes elsewhere. 
A couple of things worth noting, though, in this respect:
1 If you’re used to making changes in your document via changing styles in

Mellel, you should consider the fact that changes to style are not tracked. 
Perform stylistic manipulations directly (i.e., change the text to bold manually 
instead of switching styles). 

2 Changes in floating images, or changes in the table (except for the text in 
the table) are not recorded. If you make changes to those, make note of the 
change so your collaborator will know what happened.

3 If you’re working with someone using Mellel, than you can proceed as 
usual. You can even collaborate making changes to the same manuscript 
saved on a remote disk—your respective changes will be saved under your 
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name and you’ll be able to ‘filter’ out your changes while working on changes 
made by the other party.

4 For editors: If you prefer to make changes without seeing them (a method 
common to manny editors) simply hide the Track Changes pane and work in 
Final display mode. This will keep the visual hassle of tracking changes to a 
minimum. 

5 Working with MS Word: When sending a manuscript with changes to a 
person working with MS Word, save the file as RTF or in Word Format and 
request the person at the other end to save them as RTF before sending you. 
It’s also a good thing if that person makes the changes in styling ad-hoc.
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Sort
This chapter explains tells you what sorting in Mellel is, and how to 
sort items smartly

Should I read this chapter?
You should read this chapter if you ever have the need to sort items in 
Mellel, in the text or in tables

What is Sorting
Sorting is a simple feature that allows you to select text and order it. You can use it
to simply sort paragraphs in ascending or descending order. You can also, as you’ll
see, perform complex and delicate sorting tasks. 

Stuff you can do
To... Do this Keyboard Shortcut

Sort paragraphs in 
Ascending order

• Choose the paragraphs you wish to sort and 
choose Edit > Sort > Sort Ascending

Sort paragraphs in 
Descending order

• Choose the paragraphs you wish to sort and 
choose Edit > Sort > Sort Descending

Sort a table (by 
columns) in ascending 
or descending order

• Select a column (or the entire table) and choose 
Edit > Sort > Sort Ascending or Sort Descending

Sort a table (by rows) 
in ascending or 
descending order

• Select a row and choose Edit > Sort > Sort Ascending 
or Sort Descending

Sort part of a table in 
ascending or 
descending order

• Select part of a row or part of a column and choose
Edit > Sort > Sort Ascending or Sort Descending

Sort words 1 Select text in a paragraph and then choose Edit > 
Sort > Advanced Sort...

2 In the Advanced Sort dialogue box choose the 
relevant options to set the sort order, method, and 
so on. 

Sort paragraphs or 
sections

1 Select paragraphs or sections and then choose 
Edit > Sort > Advanced Sort...

2 In the Advanced Sort dialogue box choose the 
relevant options to set the sort order, method, and 
so on. 



Sort paragraphs or 
sections with sub-
sorting

1 Select paragraphs or sections and then choose 
Edit > Sort > Advanced Sort...

2 In the Advanced Sort dialogue box check the 
Secondary sort check-box and from the Secondary 
sort prefix pop-up select the prefix character you’ve 
used in the text (tab, space, #, or a custom 
character).

Repeat an Advanced 
Sort

• Choose Edit > Sort > Repeat Last Sort.

Ignore words when 
sorting

1 Select paragraphs or sections and then choose 
Edit > Sort > Advanced Sort...

2 In the Advanced Sort dialogue box check the Sort 
ignoring check-box and add or delete words to 
ignore.

Ignore enclosed text 1 Select paragraphs or sections and then choose 
Edit > Sort > Advanced Sort...

2 In the Advanced Sort dialogue box choose one of 
the options in the Ignore text enclosed by pop-up 
menu and check or uncheck the Remove after sort 
check-box.

The Sort sub-menu
Under the Edit menu, the Sort sub menu offers you several sorting options.

• Repeat last sort: if an advanced sort was performed earlier in a session, you 
can choose this option to perform it again. 

• Sort Ascending: will sort paragraphs in ascending order. 

• Sort Descending: will sort paragraphs in descending order. 

• Advanced Sort: will open the Advanced Sort dialogue box. 

The Sort Dialogue box
The Sort Dialogue box allows you to perform complex sorts. 
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Figure 181: The Advanced Sort dialogue box

Sort Order
The Sort order can be ascending or descending. The selection here is 
remembered from the last sort you’ve performed. 

Sort by
The Sort by pop-up menu allows you to sort text in various ways. 

Sort by Words
When sorting by words, all the characters in the selection are ordered 
alphabetically. For example, let’s say you have this list of words:

Mellel is a wonderful application
Sorting this list by words (in descending order) will result in this ordered list of 
words:

a application is Mellel wonderful
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Sort by Paragraphs
When sorting by paragraphs, all the paragraphs in the selection in the text are 
ordered alphabetically or numerically. 

Sort by Sections
When sorting by sections, all the selected sections in the selection in the text are 
ordered alphabetically or numerically. 

Sort by tab delimited items
When sorting by tab delimited items, the selected text is oredred alphabetically 
or numerically, using tab as a delimiter.

Sort by comma delimited items
When sorting by comma delimited items, the selected text is oredred 
alphabetically or numerically, using comma as a delimiter.

Custom
When sorting text with Custom delimiter a field will appear next to the pop-up 
menu, allowing you to enter the delimiter. 

Table Rows
If the selection is within a table, this option will allow you to order the selected 
cells by rows. 

Table Columns
If the selection is within a table, this option will allow you to order the selected 
cells by columns.

Sort Method
You can sort items alphabetically (by language) or numerically. When sorting 
itmes alphabetically, the languages list is set by the lanaugages list you have set 
in your System Preferences > Language and text. 

Secondary sort
The Secondary sort is a unique feature that allows you to order items separately at
the first level, the secondary level, the tertiary level, and so on.
For example, let’s say you have the following list of items:

Food
Oranges
Apples
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Bananas
Houses

Westminster Abby
Buckingham Palace
Eiffel Tower

Astronauts
Neil Armstrong
E.T.
Buzz Aldrin

When sorting this list of items, you will naturally prefer to have Food, Houses and 
Astronauts ordered alphabetically, but you want the list of items under each of 
those items to be sorted, but to remain attached to their parent. 
Secondary sort allows you to do just that. Using the sort prefix “tab” (as the items 
were indented by a tab) you get this result:

Astronauts
Buzz Aldrin
E.T.
Neil Armstrong

Food
Apples
Bananas
Oranges

Houses
Buckingham Palace
Eiffel Tower
Westminster Abby

Here, both the primary items (Astronauts, Food, Houses) and the secondary items 
are sorted, but Buzz Aldrin stays under its proper ‘heading’, Apples are still under 
Food, and the Eiffel Tower keeps under Houses. 

Important note: the sorting is recursive. That is, items prefixed by two tabs will be considered 
(and sorted as) items of the third level, items prefixed by three tabs will be considered third 
level items, and so on. 
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Sort Ignoring
Sort Ignoring allows you to set a list of words to be ignored when sorting. You can
add or delet words from the list. The list is useful when you have common words 
you wish to ignore when shorting. For example, let’s say you have this list of 
words:

The Price of milk
On deleting notes
A week in heaven
An Apple a day

If you’ve set your list of words to ignore to include “the,” “On,” “A,” and “An” you’ll 
receive this result:

An Apple a day
On deleting notes
The Price of milk
A week in heaven

(we’ve highlighted the letter actually used when sorting.)

Ignore text enclosed by
This feature allows you to set the sort so text within parenthesis, square brackets, 
curly brackets or bigger/smaller than characters will be ignored when sorting. You
can also check the Remove after sort check-box, so that the parenthesis or the 
brackets are removed after the sort. 
This option is useful in two important cases:

• When you want a word that you usually do not ignore when sorting to be 
ignored, as a special case, when sorting. 

• With some languages, a prefix letter (or letters) is common, but the letter may 
also double as a part of a word.
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Line Numbering
This chapter explains tells you about line numbering in Mellel, and 
how to use it

Should I read this chapter?
You should read this chapter if you need to number lines in Mellel

What is Line Numbering
Line numbers, as the name implies, are numbers that appear next to lines of text 
in the document. Line numbers, which are part of the section style, appear 
outside the page margins, and do not affect the layout of the document. Line 
numbers are frequently used to number lines in transcripts, legal documents, 
interviews, and so on.

Stuff you can do
To... Do this Keyboard Shortcut

Activate Line 
numbering

• Do any of the following:
• Open the Sections palette and choose Restart with

Page, Restart with Section, or Continuous from the 
Line Numbering pop-up menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Restart with Page, Restart with Section, 
or Continuous from the Line Numbering pop-up 
menu. Or, 

• Open the Sections palette and choose Edit 
Attributes... from the Line Numbering pop-up 
menu, and in the Line Numbering dialogue box 
choose Restart with Page, Restart with Section, or 
Continuous from the Line Numbers pop-up menu.

Deactivate line 
numbering 

• Use any of the methods described for activating 
line numbering to choose None from the Line 
Numbering pop-up menu.

Edit Line numbering 
attributes

• Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 



Set the Start number, 
the Increment or the 
Numbering type

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Under the Numbering Method section set the Start 
number, the Increment, or the Numbering type 
options. 

Set or change the 
character attributes for
line numbers

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Click the Character Attributes Well and change the 
options in the Character palette. 

Change between 
displaying line 
numbers per 
paragraph or per line

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Under the Number What section choose Lines or 
Paragraphs from the Count pop-up menu.

Control the frequency 
of line numbering 
appearance. 

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Under the Number What section set the number of 
lines or paragraphs with the Display every text box.

Set line numbering to 
appear for the first or 
last line in a page

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Check the option Always display for first line or Always
display for Last line Under the Number What section.
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Only count numbered 
lines

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Check the option Only count numbered lines Under 
the Number What section.

Ignore empty lines 1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Check the option Ignore empty lines Under the 
Number What section.

Set the position of line 
numbers relative to 
the text

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Under the Position section, choose one of the 
options from the Relative to text pop-up menu.

Set the distance of line 
numbering from the 
text

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Under the Position section, set the distance (in 
points) with the Distance from text text field.

Set the line numbering
alignment in the 
margins

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Under the Position section, choose one of the 
options from the Alignment pop-up menu.
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Set the options for the 
separator line for line 
numbering

1 Do one of the following:
• Open the Sections palette and choose Edit 

Attributes... from the Line Numbering pop-up 
menu. Or,

• Choose Styles > Section Style > Edit <style name >... 
and choose Edit Attributes... from the Line 
Numbering pop-up menu. 

2 Under the Separator section set the Line Type, 
Weight, Colour, and Distance from Line options.

Set the numbering 
channel

1 Open the Sections palette and choose Edit 
Attributes... from the Line Numbering pop-up menu.

2 Choose a channel from the Numbering Channel 
pop-up menu.

The Line Numbering pop-up menu
With the Section palette, as well as under the Section style, you can choose any of 
the option to activate, deactivate or edit the Line numbering options. 
The Line Numbering pop-up menu includes 5 options:

• None: When this option is selected, Mellel will not display line numbers. 

• Restart with Page: Mellel will restart the line numbers count with every page.

• Restart with Section: Mellel will restart the line numbers count with every 
section. 

• Continuous: Mellel will number lines continuously. 

• Edit attributes: Will Open the Line Numbering dialogue box.

Line Numbering dialogue box
The line numbering dialogue box allows you to control every aspect of line 
numbering, from appearance, continue with numbering method and ending with
the position of the numbering next to the text.

Line numbers
The Line Numbers pop-up menu allows you to set if line numbers will appear and 
when the numbering will be restarted. 

• None: When this option is selected, Mellel will not display line numbers. 

• Restart with Page: Mellel will restart the line numbers count with every page.

• Restart with Section: Mellel will restart the line numbers count with every 
section. 
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• Continuous: Mellel will number lines continuously. 

Numbering Method
The Numbering Method options allows you to set the start number, the increment 
and the numbering type. 

• Start Number: sets the first line number count. Setting this to 1, will start the 
numbering at 1, setting this to 2, 3 or 4 will start the numbering at 2, 3 or four, 
and so on. 

• Increment: sets the incrementation. E.g., if the start number is 0 and the 
increment is 4, the first lines will be numbered 0, 4, 8, 12, 16, and so on. 

• Type: Sets the numbering type. E.g., Arabic (1, 2, 3, ...) or Roman Caps (I, II, III, 
...). 

Character attributes
The Character Attributes Well allows you to set the character attributes of the line 
numbers. When you press the Character Attributes Well the Character palette will be 
opened, to allow you to quickly edit the line numbers attributes. 
An information line below the Character Attributes Well will indicate the main 
attributes applied to the line numbers. 

Number What
This section of the Line Numbering dialogue box allows you to set what to count, 
how often to display the page numbers, and control other display options for line 
numbers. 

Count
This option allows you to set whether Mellel will display line numbers per line or 
per paragraph. 

Display every
This option allows you to set whether Mellel will display line numbers every line 
or paragraph, or only every 2, 3, 4, etc. lines or paragraphs. For example, if you set 
this to 3, Mellel will display the number 1 next to the first line, number 4 next to 
the fourth line, number 7 next to the seventh line, and so on. 
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Figure 182: Line numbering with a Display Every 3 lines setting

Always display for first line
When this option is checked, Mellel will always display a line number next to the 
first line in a page. This option is useful if you’ve

Always display for Last line
When this option is checked, Mellel will always display a line number next to the 
last line in a page. 

Only count numbered lines
This option allows you to set Mellel to only count numbered lines. For example, if 
you set numbering to be displayed every 3 lines (as shown with Figure 182 on 
page 282) and check Only count numbered lines you’ll get:

Figure 183: Only count numbered lines

This option is essential in cases where you only want to number general sections 
in a page (e.g., section A, B, C, D and E of a page in a legal document).

Ignore empty lines
This option, when checked, will cause Mellel to ignore empty lines when 
numbering them. This option is checked by default. 

Position
The set of options for positioning the numbers lets you determine where line 
numbers will appear and their proximity to the text. 
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Relative to text
This pop-up menu allows you to determine if numbers will appear before the text,
after the text, before and after, and so on. 

• Before: the numbering will appear before the text. 

• After: the numbering will appear following the text (e.g., the end of a 
column). 

• Before and After: the numbering will appear before and after the text. 

• Alternate before & After: display the numbering before column one, after 
column two, before column 3, and so on. This option is useful when there are 
two columns of text. 

• Before, after last column: display the numbering before the text, but also 
after the last. This option is useful for a symetrised appearance with 3 or more 
columns. 

Table 21: Relative to text

Before After Before and After Alternate before & 
After

Before, after last 
column

Distance from text
Allows you to set how far removed the numbering will be from the margin. 

Alignment
The alignment option allows you to set the alignment of numbers relative to the 
text. There are three options: Natural, Centre, and Next to text. 

Table 22: Alignment of numbering
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Natural Centre Next to text

Separator
The options here allow you to set the line type, the line weight, the line colour 
and the distance of the line from the document text. 

Note: the separator settings are independent of the Position and Distance from text options 
for the numbering. The can overlap. 

• Line Type: sets the separator line type (dots, lines, etc.) 

• Weight: sets the separator line thickness. 

• Colour: sets the separator line colour.

• Distance from Line: sets the distance of the line from the document text. 

Numbering Channel
This unique expert option allows you to set two or more numbering streams 
within a document. For example, let’s say that you wish to number two separate 
items, such as interviews, each with its own independent numbering. By 
assigning a different channel to each of the items, you can achieve this easily. For 
example:
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Figure 184: Using the Numbering Channel option

Here you can see that the indented section A and B are numbered continuously 
(1...7 and 8...15) whereas section C, belonging to a different channel, is numbered 
separately. 
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Table of Contents
This chapter explains what a Table of Content is and how to use it

Should I read this chapter?
You should read this chapter if you intend create a Table of Contents in your
documents

What is a Table of Contents
A Table of Contents (or ToC) is a list of the chapters, sub-chapters, headings, 
figures, or any other element in your document you have chosen to mark for 
inclusion in it. 
In Mellel, the ToC is based on auto-titles you’ve created in the document, that 
you’ve marked for inclusion in the ToC. Through the Edit title flows sheet you can 
edit the way the ToC appears in your document, and the elements it would 
include.

Stuff you can do
To... Do this Keyboard Shortcut

Generate a TOC 1 Place the insertion point where you want the ToC 
to be created.

2 Choose Insert > Table of Contents.

Update or re-generate 
a TOC

1 Delete the existing ToC.
2 Place the insertion point where you want the ToC 

to be created.
3 Choose Insert > Table of Contents.
Note: You cannot create a TOC when there is a text 
selection in the document.

Include a title flow in 
the ToC

1 In the Edit title flows sheet select a flow from the Title
flows list.

2 Check the option Include in ToC.

Use a special format 
with the ToC

1 In the Edit title flows sheet select a flow from the Title
flows list.

2 Press the ToC Format tab label and check the option
Use a different format for Table of Contents.



Create a ToC with page
numbers and a lead (...)

1 In the Edit title flows sheet select a flow from the Title
flows list.

2 Press the ToC Format tab label and check the option
Use a different format for Table of Contents.

3 Add a tab from the Elements list and then drag a tab
from the Tab well into the Ruler. 

4 With the tab you’ve dragged selected, open the 
Paragraph palette and choose a lead character from
the Lead pop-up menu.

List figures, tables, 
charts as a separate 
ToC section. 

• In the Edit title flows dropping sheet, choose a tag 
flow and check the option List as separate section in 
TOC. 

Generating a ToC
Creating a Table of Contents in Mellel is essentially a one-step process. All the 
details are taken care of in the Edit title flows dropping sheet. The ToC is 
generated as styled text, using the formatting you’ve applied in this sheet, and 
you can manipulate it later on just as you would with any other text.
There are two important things to note about TOC generation:
1 The ToC usually occupies several pages. Mellel tries to calculate the added 

number of pages beforehand and generate the correct page numbers. Check 
that they are indeed correct. Mellel will also automatically add a page style 
break after the TOC in order to keep everything neat and clean. 

2 Table of Contents generation is ‘cheap’: it takes about a second, so do not 
hesitate repeating the process several times until the ToC looks just right. 

Designing the ToC
In most cases, you will want to style your ToC differently from headings in the text.
Usually, whereas headings come in all shapes and sizes, the ToC items do not vary 
that much and may only differ slightly in size and font from one another. To 
design the ToC to suit your needs, you should use the Edit title flows dropping 
sheet.
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Cross Reference
This chapter explains what a cross reference is and how to use it

Should I read this chapter?
You should read this chapter if you use or intend to use cross references in 
your documents

What are cross references
References are pointers to a point in the document text. For example, you can 
refer to a page in the document (e.g. “see page 13”), to an footnote (“see note 2 on
page 13”) or to a heading in the text (e.g. “see heading 3.1: The hobbit”). 
Cross references are automatically managed references. Every reference you enter
in Mellel points to a target, and Mellel keeps record of all those targets and 
updates the reference depending on changes in the references. For example, if 
you’ve referred in one of your references to page 13, and then added several 
pages before page 13, so it is now page 17, Mellel will simply update “see page 
13” to “see page 17.” 

Stuff you can do
To... Do this Keyboard Shortcut

Create a Bookmark 1 Choose Insert > Cross Reference > Insert Bookmark... or 
click the Insert Bookmark icon in the Cross Reference 
palette.

2 In the Target ID text field enter the Bookmark’s 
name.

Edit a bookmark 1 In the document text, double click the bookmark 
icon ( ).

Create a reference 1 Choose Insert > Cross Reference > Insert Reference... or 
click the Insert Reference icon in the Cross Reference 
palette.

2 Choose the desired type of reference from the 
Reference type list.

3 Select a target from the Targets list. 
4 In the Target ID text field enter the target’s name (if 

there is none). 
5 Select a Reference format from the Reference 

formats pop-up menu or create and edit your own 
format in the edit area. 

6 Press OK

Edit a reference 1 In the document text, double click a reference.



Turn a potential target 
into a target

• Add an Auto-title or an Image, or double-click an 
existing one, and in the Cross reference target ID text 
field enter the target’s name.

Navigate between 
references

1 Open the Cross Reference palette.
2 Select the desired browsing option and click the 

Next Reference or the Previous Reference buttons to 
navigate through the reference. 

Navigate from a 
reference to its target

• Do any of the following:
• Hover over the reference and press 

Option+Double-click. Repeat, pressing 
Cmd+Double-click, to jump to the next 
reference to this target. Or, 

• Hover over the reference and press Ctrl+Click to 
select an option from the contextual menu.

Option+Double-click, 
Cmd+Double-click

Find a bookmark • Open the Find dialogue box and from the Elements 
pop-up menu choose Bookmark.

Navigate between 
bookmarks

1 Open the Outline pane.
2 If the Outline is in Combined mode ( ) you can 

scroll through the bookmarks in the Structure 
section of the outline. If the Outline is in Separate 
view ( ), scroll down to the Bookmarks section 
and view the bookmarks there.

Navigate from a 
bookmark to the first 
reference to it

• Do any of the following:
• Hover over the bookmark and press 

Option+Double-click. Or, 
• Hover over the reference and press Ctrl+Click to 

select options from the contextual menu.

Option+Double-click

Find a bookmark • Open the Find dialogue box and from the Elements 
pop-up menu choose Bookmark.

Reference an Auto-title 1 Choose Insert > Cross Reference > Insert Reference... or 
click the Insert Reference icon in the Cross Reference 
palette.

2 From the Reference type list choose Auto-titles.
3 In the Target ID text field enter the Auto-title’s name

(if there is none). 
4 Select a Reference format from the Reference 

formats pop-up menu or create and edit your own 
format in the edit area. 

5 Press OK
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Reference an Image 1 Choose Insert > Cross Reference > Insert Reference... or 
click the Insert Reference icon in the Cross Reference 
palette.

2 From the Reference type list choose Images.
3 In the Target ID text field enter the ID for the image 

(if there is none). 
4 Select a Reference format from the Reference 

formats pop-up menu or create and edit your own 
format in the edit area. 

5 Press OK.
Note: the image Target ID is not the same thing as the 
Image title. You can give an image a title that is distinct 
from its ID. 

Reference a note 
(footnote, endnote)

1 Enter a bookmark at the beginning of the footnote 
or endnote you want to refer.

2 Choose Insert > Cross Reference > Insert Reference... or 
click the Insert Reference icon in the Cross Reference 
palette.

3 In the Existing targets list choose the bookmark 
you’ve entered. 

4 From the Elements menu choose Note symbol. 
5 Press OK

Reference a page 
number

• Create a reference (see Above) with the Page 
Number element (from the Elements menu). 

Reference a page 
number with 
conditional text

1 Create a reference (see Above) with the Page 
Number element (from the Elements menu). 

2 Double-click the Page Number element to set its 
conditional attributes. 

Reference a page 
range

1 Do one of the following:
• Create a reference (see Above) using the Auto-

title range start and Auto-title range end elements 
to mark the first/last page in the range.

• Create a reference (see Above) using the Page 
number element, first for the first page in the 
page range, then for the last page in the page 
range.

Reference the title or 
its numbering only

1 Create a reference (see Above) with the Auto-title 
title element, the Auto-title current level number 
element, or the Auto-title previous level number 
element (or any combination of the three). 
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Create a virtual target 1 Choose Insert > Cross Reference > Insert Reference... or 
click the Insert Reference icon in the Cross Reference 
palette.

2 From the Reference type list choose Virtual target.
3 In the Virtual Target ID text field enter the Virtual 

target’s name. 
4 Select a Reference format from the Reference 

formats pop-up menu or create and edit your own 
format in the edit area. 

5 Press OK.

Assign a Virtual target 1 Create a bookmark, Auto-title or image or double-
click an existing one.

2 From the Assign Virtual Targets pop-up menu select 
one of the existing Virtual targets.

Show or hide 
Reference background

• From the Show button pop-down select or deselect
References

Change the 
preferences for 
Reference background

• Choose Mellel (menu) > Preferences and under the 
Appearance tab check or un-check References

Edit the reference 
format

1 Click inside the Reference format text field (in the 
Edit Reference dialogue box) and then do any of the 
following:
• Choose an element from the Elements pop-up 

menu.
• Choose a pre-prepared format from the Reference

formats pop-up menu. 
• Edit the format by direct entry of text, cut, copy 

and paste.
• Use the character attributes palettes to set the 

reference attributes. 
Note: the Direction button at the top-right corner of the 
Reference format area is meant to make it easier for you to 
edit the format. It does not change anything. 

Set or change the 
default reference 
format style

1 Choose Mellel (menu) Preferences....
2 Click the Styles tab and from the Default reference 

format pop-up menu select a style to your liking.

Edit the character 
attributes of references

• Do one of the following:
• Choose the reference in the document text and 

apply character attributes or styles.
• Double-click the reference and in the Reference 

Format edit area apply character attributes or 
styles.

Edit the Auto-title 
format element

See the Auto-title format section. 
Note: editing the Auto-title format element in the Edit title 
flows sheet will only affect the formatting of this element.
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Save a new reference 
format

1 Edit the reference format (see the Edit the 
reference format section above). 

2 From the Reference formats pop-up menu choose 
Save format..., name the style and save it. 

Open a saved 
reference format

1 From the Reference formats pop-up menu choose 
the format name you want to open. 

Locate problematic 
references

1 Open the Cross Reference palette.
2 Select the Ambiguous references browsing option 

and click the Next Reference or the Previous Reference 
buttons to navigate through the problematic 
references in the document. 

Change the display 
direction of format 
elements

• Press the Direction button.

Types of targets
Targets are any point in the text that is marked as a target for a reference. 

Bookmarks
Bookmarks are invisible points in the text that you’ve marked as bookmarks. Their 
sole purpose is to insert a mark in the text that you can later on refer to. 
Bookmarks have but one attribute: A Target ID or Name. 

Potential targets
Potential targets are elements in the text, such as Auto-titles or images, that are 
marked in advance as potential points for use as targets. Potential targets are 
marked to make it easier to refer to points in the text that are commonly used as 
targets. 

Virtual targets
Virtual targets, as their name implies, are targets that do not exist in the text. A 
virtual target may be, for example, a chapter that you did not yet write, but still 
want to refer to. 

Edit Reference dialogue box
The Cross Reference dialogue box allows you to enter references into the 
document text. Through this dialogue box you can reference any bookmark Auto-
title heading or tag, and any image in the document. You can also add a 
references to a Virtual target—that is, a target that does not exist (yet) in the text. 
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Figure 185: The Edit References dialogue box

• Reference type: lists all the reference types available to you. The Existing 
Targets item lists all the targets in the document; Auto-titles and Images list all 
the Auto-titles and images in the document; Virtual Target allows you to refer 
to a target that does not exist in the text. 

• Existing targets: lists the targets within the item selected with Reference type. 

• Preview: shows a preview of the target, in context, if it is a bookmark in the 
text. 

• Target ID: (if you’ve selected Auto-titles, Images or Virtual Target with Reference 
type) displays the Name (ID) of the target. If the target is not named yet, the 
text field will be enable and allow you to name it. 

Note: You must name a target in order to refer to it. If the target is not named, Mellel 
wouldn’t know how to identify it. 
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• Reference format: allows you to create and edit reference formats. 

Editing the reference format
Mellel allows you to create, edit and change the reference formats you can use in 
your document. This is meant, for the main part, to allow you to ‘recycle’ the 
reference format you’ve already used in other places. 

The Reference 
formats pop-up menu

The Direction button

The Elements 
pop-up menu

The reference 
format edit area

Figure 186: The Reference format section

• Elements pop-up menu: This pop-up menu allows you to choose an element 
you would like to enter into the edit area. 

• Reference formats: This pop-up menu includes several pre-prepared formats 
you can choose from. The menu also includes an option to save the format to 
the disk (into the Mellel folder within the Application Support folder). 

• The Edit area: is where you can add and edit elements to your format. 

• Direction: This option allows you to change the display direction of the 
elements in the format. It does not affect the format itself. 

Reference format elements
Mellel offers several format elements you can use when editing reference formats.

Page number
The Page number element will enter a reference to the page number where the 
target is. 
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Figure 187: Typical result when entering a Page number element

Double-clicking the Page number element you can access other options for 
formatting the page number. 

Figure 188: The Conditional Page Number Format dialogue box

The Conditional Page Number Format dialogue box offers several powerful options 
for conditional page numbering:

• Default number format: allows you to set the default number formatting. “#” 
means the page number and nothing else. 

• Above: allows you to set the string that will appear, instead of the page 
number, when the target is somewhere in the document above the reference. 

• Below: allows you to set the string that will appear, instead of the page 
number, when the target is somewhere in the document below the reference.
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• Above (same page): allows you to set the string that will appear, instead of 
the page number, when the target is above the reference, but on the same 
page. 

• Below (same page): allows you to set the string that will appear, instead of 
the page number, when the target is below the reference, but on the same 
page.

• On the next page: allows you to set the string that will appear, instead of the 
page number, when the target is on page following the page where the 
reference is.

• On the previous page: allows you to set the string that will appear, instead of
the page number, when the target is on page preceding the page where the 
reference is.

• Opposite page: allows you to set the string that will appear, instead of the 
page number, when the target is on page opposite the page where the 
reference is. For example, when you enter a reference on page 2, and the 
target is on page 3, an instance of Opposite page will be triggered. 

Note symbol
The Note symbol element will enter a reference to the note number where the 
target is. To reference a note, you must first enter a bookmark at the beginning of 
the note and then refer to this bookmark. 

Figure 189: Typical result when entering a Note symbol element

Auto-title format
The Auto-title format element allows you to enter a reference to auto-titles in the 
document. By default, the reference will use the auto-title formatting (e.g., font, 
font size or face), but you can change this in the Edit title flows dropping sheet. 
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The process is a bit more complex than with other elements, so a more elaborate 
explanation is probably in order.

Example—using the Auto-title format element:
1 Choose Insert > Cross Reference > Insert Reference... or click the Insert Reference icon in 

the Cross Reference palette.
2 From the Reference type list choose Auto-titles.
3 In the Target ID text field enter the Auto-title’s name (if there is none). 
4 From the Elements pop-up menu choose Auto-title format.
5 Press OK.

If this is the first time you use the Auto-title format element in a reference, the 
reference will probably include the Auto-title text with the style used with that 
Auto-title. To change this:

1 Open the Auto-title palette and click the Edit title flows button. 
2 In the Edit Title flows dropping sheet, select the level to which the auto-title 

selected earlier belong, and click the Ref Format tab and check the Use a different 
format for Cross Reference check-box. 

3 In the edit area, edit the format as you wish, until it looks the way you want it to 
look. Clicking the Use Surrounding list item in the Character Style palette will 
probably save you a lot of time, if you simply want the reference to look like 
‘normal text’. 

Auto-title title
The Auto-title title element allows you to refer to the auto-title title element alone. 
For example, if an auto-title appears in the text as “1.5. Mellel: Why it’s Great”—
referencing the Auto-title title element the reference would appear in the text as 
“Mellel: Why it’s great.” 

Auto-title current level number
The Auto-title current level number element allows you to refer to the current level of
a heading in the document. For example, if an auto-title appears in the text as 
“1.5. Mellel: Why it’s Great”—referencing the Auto-title current level number element 
the reference would appear in the text as “5” (the current level).

Auto-title previous level number
The Auto-title previous level number element allows you to refer to the previous level
of a heading in the document. For example, if an auto-title appears in the text as 
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“1.5. Mellel: Why it’s Great”—referencing the Auto-title previous level number 
element the reference would appear in the text as “1” (the previous level).

Auto-title range start
The Auto-title range start element allows you to refer to the page where an Auto-
title is located. 

Auto-title range end
The Auto-title range end element allows you to refer to the page where the range of
an Auto-title ends, that is, to the page where the next Auto-title at that level is 
located. 

Figure 190: A typical example of the Auto-title range start/end use

Note: using the Auto-title range start/end is a very convenient means to refer to a page 
range, but only if that page range is that of an Auto-title. When this is not the case, you’ll 
need to create two references: one for the first page in a range, and another for the last 
page in that range. 

Image title
The Image title element allows you to refer to the name (title) of an image in the 
text. You can only refer to an Image title of an image that has a title, of course. 
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Figure 191: A reference format using the Image title element

The Cross Reference palette
The Cross Reference palette is a handy tool to enter bookmarks and references 
and for browsing and fixing problems with references in your document. 

Previous 
Reference

Next 
Reference

Enter a 
bookmark

Browsing 
options

Enter a 
reference

Figure 192: The Cross Reference palette

• Enter Bookmark: enters a bookmark into the document.

• Enter Reference: enters a reference into the document.

• Browsing options: allows you to browse through the references in your 
document.
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a All References: browse through all the references in the document.
b Virtual target references: browse only through the virtual target 

references (targets that do not exist) in the document.
c Ambiguous references: browse through references that Mellel cannot 

resolve by itself and needs you to intervene manually. 

• Previous Reference: moves to the reference previous to the insertion point in
the document.

• Next Reference: moves to the next reference below the insertion point in the 
document.

Ambiguous references
Ambiguous references are references that Mellel cannot determine with certainty 
where their target is located. With such cases—which should be rare—you will 
need to come to Mellel’s aid and fix the problem manually.

Bookmark dialogue box
The Bookmark dialogue box allows you to enter bookmarks into the document 
and assign it to a Virtual target.

Figure 193: The Bookmark dialogue box

• Target ID: allows you to enter a name (which must be unique with this 
document) to the bookmark. 

• Assign Virtual Target: this pop-up menu allows you to assign the bookmark 
to a Virtual target. 
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Assigning Virtual Targets
When you create a reference to a Virtual target, you’re referring to a non-existing 
target. For example, you may want to refer to a chapter you did not yet write or to 
a section you intend to add later on. 
Once you’ve added the missing part, you will probably want to set things right, 
and assign this part to the Virtual target you’ve created later on. This is the 
purpose of the Assign Virtual Target pop-up menu you will be able to access with 
every Auto-title, bookmark, or image. 

Printing with cross references
Mellel’s sophisticated cross referencing system allows you to go from a 
manuscript to the printer, with your references all in place and pointing to where 
they should. 
However, sometimes you may need to take the text you’ve created in Mellel and 
import it into another application. In such cases, several things should be borne in
mind:

• References to figures, captions, headings, notes or segments of the text will 
transfer well to another application. References to page numbers will 
probably prove more problematic. 

• Mellel supports cross references exported to PDF as hot links. That is, clicking 
on them in the exported PDF will link the reader to the target set in the 
reference. 
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Mentions
This chapter explains what Mentions are and how to use them

Should I read this chapter?
You should read this chapter if you use or intend to use running headers 
(mentions) in your documents

What are Mentions
Mentions or ‘running headings’ are elements referencing a level of headings 
(auto-titles) that you can insert into the header or a footer. The mentions refer to a
level of headings, not to a specific heading, so they change dynamically to reflect 
the current heading. For example, this guide contains a footer with a mention 
referencing the chapter’s title (i.e. “Mentions”). If you skip a few pages forward or 
backwards, you’ll see that the footer mention changes to reflect the chapter’s title 
there. 

Stuff you can do
To... Do this Keyboard Shortcut

Create a mention 1 Open the Page palette (for more info, see the 
chapter about Page Attributes)and check the 
Header or Footer. Alternately, choose a page style 
with a header or footer.

2 Place the insertion point in a header or a footer, 
and do one of the following:
• Choose Insert > Auto-title > <any title flow>. Or,
• Select a title flow in the Auto-titles palette and 

click Insert. Or,
• Double-click a title flow in the Auto-titles palette.

Note: You can insert a Mention only into the header or the 
footer.

Create mentions to 
multiple levels in one 
header

1 Create mentions (see Above) to the headings you 
wish to refer to.

2 Create a table and insert the mentions into cells in 
that table.

Use a special format 
with the mentions

1 Select a title flow from the Title flow list.
2 Press the Mentions Format tab.
3 Check the option Use a different format for Mentions.
Important note: for details about editing mentions 
format, please refer to the section about Title flow format. 



Creating Mentions
Mentions can be created only in the header and the footer of a page. You can 
create only one mention per paragraph. That is, if you wish to refer to two 
headings simultaneously (e.g. “Mentions, sub-chapter “Creating Mentions”) you’ll 
need to refer to each in a separate paragraph. To place several mentions side-by-
side, create a table in the header or footer and enter the mentions into cells in 
that table. 

Formatting your mentions
You can design the format of your mentions via the Auto-titles flow sheet. Re-
designing the mention’s format is useful in cases you wish to refer to only a part of
the heading in the text (e.g., only to the title, but not to the numbering that that 
appear in the text).
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Hyphenation
This chapter explain what hyphenation is and how to use 
hyphenation in Mellel

Should I read this chapter?
You should read this chapter if you intend to use hyphenation in Mellel 
documents or want to learn about hyphenation

What is a Hyphenation
Hyphenation is the splitting a word in two at the end of lines, to divide the text 
into lines of approximately even length. To split the word in two, Mellel insert a 
hyphen (-) into the word at the end of the line, and moves the rest of this word to 
the next line. Hyphenation is often used with text in columns and when the text is
fully justified. 
The following figure depicts text that is not hyphenated. Without hyphenation, 
some lines have very large spaces between words.

Figure 194: Problematic text without hyphenation

With hyphenation activated, some words are hyphenated and the wide spaces 
vanish:

Figure 195: And after activating hyphenation



Hyphenation is not applied blindly, whenever a word is too long to fit in a certain 
line. The decision if to hyphenate or not to hyphenate follows certain rules that 
determine when and where to hyphenate.
Mellel supports hyphenation as part of the paragraph style attributes. To activate 
hyphenation, you need to choose an hyphenation dictionary (usually, the regular 
hyphenation dictionary for your language). Once activated, any piece of text 
using that paragraph style will be hyphenated. 

Stuff you can do
To... Do this Keyboard Shortcut

Start editing 
hyphenation options

1 Place the insertion point within a paragraph in the 
text for which you want to set the hyphenation 
options.

2 Choose Paragraph > Edit “<paragraph style name>”, 
click the paragraph style name in the status 
window in the document window, or choose Style 
Set > Edit Style sets, and double-click the desired 
paragraph style. 

Activate hyphenation 1 Do one of the following:
• Click in any block of text using the desired 

paragraph style and choose Styles > Paragraph 
Style > Edit “<paragraph style name>”, or click the 
paragraph style name in the status window in 
the document window. Or,

• Choose Style Set > Edit Style sets, and double-click 
the desired paragraph style. 

2 Check the Hyphenation check-box.
3 Choose a dictionary from the Dictionary pop-up 

menu. 

Change the 
hyphenation 
dictionary for a 
paragraph style

1 Do one of the following:
• Click in any block of text using the desired 

paragraph style and choose Styles > Paragraph 
Style > Edit “<paragraph style name>”, or click the 
paragraph style name in the status window in 
the document window. Or,

• Choose Style Set > Edit Style sets, and double-click 
the desired paragraph style. 

2 Check the Hyphenation check-box.
3 Choose a different dictionary from the Dictionary 

pop-up menu. 
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Set or change the 
hyphenation limit

1 Do one of the following:
• Click in any block of text using the desired 

paragraph style and choose Styles > Paragraph 
Style > Edit “<paragraph style name>”, or click the 
paragraph style name in the status window in 
the document window. Or,

• Choose Style Set > Edit Style sets, and double-click 
the desired paragraph style. 

2 Check the Hyphenation check-box.
3 Click in the text area next to the label Hyphenation 

limit and change the default value. 

Change the minimum 
word length or 
minimum before or 
after a hyphen

1 Do one of the following:
• Click in any block of text using the desired 

paragraph style and choose Styles > Paragraph 
Style > Edit “<paragraph style name>”, or click the 
paragraph style name in the status window in 
the document window. Or,

• Choose Style Set > Edit Style sets, and double-click 
the desired paragraph style. 

2 Check the Hyphenation check-box.
3 Check the Customise minimum check-box.
4 Click in the text area next to the appropriate label 

(Minimum word length, Minimum before hyphen or 
Minimum after hyphen) and change the default 
value.

Set or change the 
hyphenation zone:

1 Do one of the following:
• Click in any piece of text using the desired 

paragraph style and choose Styles > Paragraph 
Style > Edit “<paragraph style name>”, or click the 
paragraph style name in the status window in 
the document window. Or,

• Choose Style Set > Edit Style sets, and double-click 
the desired paragraph style. 

2 Check the Hyphenation check-box.
3 Change the value in the text area next to the label 

Hyphenation zone. 
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Edit the hyphenation 
user dictionary:

1 Choose Mellel (menu) > Preferences....
2 Click the Hyphenation tab. 
3 Click the Add button and do any of the following:

• To add a word that should not be hyphenated:
enter it in the new entry slot created in the user 
dictionary list. 

• To add a word that should be hyphenated 
differently: enter it in the new entry slot created
in the user dictionary list, adding a hyphen 
where it should be hyphenated. 

4 To edit a word in the user dictionary, locate the 
word and double-click it in the list and enter a 
revised version of the word. 

5 To delete a word from the hyphenation 
dictionary, simply locate the word, click it and 
press the Delete button. 

6 To refresh all open document to reflect the 
changes you’ve made, press the Refresh open 
documents button. 

Enter a Soft Hyphen • Choose Insert > Special Characters > Hyphen & Dash > 
Soft Hyphen.

Ctrl+- (the hyphen/
minus key)

Hide or show Soft 
Hyphens in the text

• Select Soft Hyphens from the Show button pop-
down menu in the bottom of the document 
window.

Set the default for 
showing or hiding Soft
Hyphens in the text

• Choose Mellel (menu) > Preferences, and in the 
General section check or uncheck Soft Hyphens.

Cmd+,

Hyphenation options
The Hyphenation section within the Edit Paragraph style dialogue box offers several
options for setting and editing the settings for hyphenation. 
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Figure 196: The Hyphenation section in the Edit Paragraph style dialogue box

Enable hyphenation
In most cases, you’d probably want to use the automatic hyphenation option in 
Mellel, using a hyphenation dictionary suitable for the main language used in the 
text. Mellel offers over 25 such dictionaries, covering most of the languages that 
require hyphenation (hyphenation is not required with CJK, Arabic, and 
Devanagari based language scripts). 

Hyphenation limit
The Hyphenation limit option allows you to set the number of consecutive lines 
which may end with a hyphenated word. The default is 3. A larger value (4 or 5) 
may be useful with text laid out in narrow columns. A smaller value is more 
suitable for situations where you wish to limit the number of consecutive lines 
ending with a hyphen (for example, when the text is laid out in one column). 

Customise minimum
Hyphenation dictionaries set their own minimum word length and minimum 
length before and after a hyphen. Those settings should suffice for most uses, but 
you can override them if you want to make the hyphenation rules more strict (less
hyphenating) or more lenient (more hyphenating).

• Minimum word length: allows you to set the minimum length (in letters) for 
a word to be hyphenated. For example, with a minimum length to 6 letters, a 
word such as “hippodrome”, which is longer than the minimum, may be 
hyphenated, but a word such as “apron” will not be hyphenated. The default is 
the value set in the hyphenation dictionary (normally 5).
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• Minimum before hyphen: sets the minimum length (in letters) of the first 
part of an hyphenated word. For example, setting the value here to 3 will 
allow the word “Semaphore” to be hyphenated as “Sem-aphore” but not as 
“Se-maphore.” The default is the value set in the hyphenation dictionary 
(usually, 2).

• Minimum after hyphen: sets the minimum length (in letters) of the second 
part of an hyphenated word. For example, setting the value here to 3 will 
allow the word “Semaphore” to be hyphenated as “Semaph-ore” but not as 
“Semapho-re.” The default is the value set in the hyphenation dictionary 
(usually, 2).

Hyphenation zone
The Hyphenation zone option allows you to set the amount of “white space” 
allowed at the end of a line. The “white space” is the horizontal area between the 
last character of the last word that can be included in full in a line, and the end of 
the line. 

White space

Figure 197: White spaces

With text justified to the left or to the right, the hyphenation zone determine the 
tolerance of Mellel for white spaces at the end of lines. That is, it tells Mellel how 
much of a white space is acceptable, and at what point is should start 
hyphenating the text. The larger the value set for hyphenation zone, the more 
tolerant Mellel will be, the larger the white spaces could become, and the less 
hyphenated the text will be. 
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With text that is fully justified the white space at the end of the line will be split 
and added to the spaces between the words. The hyphenation zone will 
determine the balance of spacing between words and hyphenation and, again, 
the larger the value, the more likely there will be larger spaces between words 
and a smaller amount of hyphenating. 

Figure 198: Hyphenation zone = 0 points

Figure 199: Hyphenation zone = 50 points

Hyphenation preferences
Mellel’s preferences contains a special tab for hyphenation. That tab includes two 
sub-tabs: one for creating and managing a user dictionary for hyphenation and 
another to display the copyright information about the dictionaries installed with 
Mellel. 
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Hyphenation user dictionary
The user dictionary allows you to add create a special dictionary, overriding the 
hyphenation dictionaries used in the document. It’s main use is to allow you to set
some words so that they are never hyphenated or, alternately, hyphenated in a 
particular manner you set. 

• Add: allows you to add a word to the dictionary. 

• Delete: deletes a selected word from the user dictionary.

• Refresh open documents: forces Mellel to start using all the latest additions 
to the user dictionary right away. 

A user dictionary example
For example, let’s take the text we’ve used earlier on as a platform for a little don’t 
and do differently experiment: 

Figure 200: The text before the experiment

Now, let’s take the two hyphenated words and change them. First, we’ll add the 
word “nonummy” to the user dictionary without any hyphens in it, which will 
instruct Mellel not to hyphenate it:

Figure 201: Just added nonummy

The result is clear, the word ceases to be hyphenated:
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Figure 202: No hyphenation for nonummy

As you can see, “nonummy” was delegated to the next line. Now, let’s delete the 
word we’ve added and hyphenate the word “suscipit” differently. Namely, we’ll 
add it as a word to the user dictionary like this: “su-scipit”:

Figure 203: And the result

The word is now hyphenated differently. 

Soft hyphen
Soft hyphens are hidden hyphenation marks (often called “discretionary 
hyphens”) you can add to any word in the text. A soft hyphen is an option for 
hyphenation. That is, it will remain invisible and will have no effect on the text, 
unless it is at the end of the line that can be hyphenated. 
Soft hyphens should be used sparingly and usually only where automatic 
hyphenation or the user dictionary cannot address a problem (e.g., when you 
want to hyphenate a word but don’t want this addition to be applied to all other 
documents). 

Mellel Hyphenation Lab
Some people have very specific and elaborate requirements regarding the way 
hyphenation should function. To serve those of you who have such requirements, 
RedleX created a special application called Mellel Hyphenation Lab (MHL). This 
application, which is offered as a free download from RedleX’s site, will enable you
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to create and edit hyphenation dictionaries. For more information, go to our site 
at: http://www.mellel.com.
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Spelling and Thesaurus
This chapter explains how to use the spelling and thesaurus options

Should I read this chapter?
You should read this chapter if you intend to use spelling or thesaurus in 
your writing

What is spell checking
Spell checking is the ability to scan the text in your document and point to 
spelling errors in it. Mellel allows you to check spelling in your documents using 
the spell checkers built into Mac OS X, third party spelling services and other spell
checkers. Mellel also work with a variety of third party free, shareware and 
commercial thesauri. 

Stuff you can do
To... Do this Keyboard Shortcut

Activate entry for 
citations from 
Bookends

• Choose Mellel (menu) > Preferences... and with the 
Bibliography section choose Bookends from the 
Bibliography Application pop-up menu.

Check spelling in a 
document

1 Choose Edit > Spelling > Spelling... The Spelling 
floating palette will open.

2 Use any of the options there to check the spelling 
in your document. 

Cmd+:

Check spelling in a 
document without the 
Spelling dialogue box

1 Choose Edit > Spelling > Check Spelling. Mellel will 
search the text from the insertion point to the next 
suspect spelling error and highlight it in the text.

2 Ctrl+Click over the highlighted word to open the 
contextual menu and view a list of suggested 
corrections and other spelling options. Note that if 
the word is already spelled correctly, you will not 
see a list of suggested words.

3 Select one of the suggested corrections if you want
to correct the word, choose Learn if you want Mellel
to learn the word, or choose Ignore to ignore this 
word during the current session.

Cmd+;



Use Check Spelling As 
You Type

1 Choose Edit > Spelling > Check Spelling As You Type. 
Mellel will now highlight with a light-red 
background every word you type that is not 
included in the spelling dictionary. 

2 Ctrl+Click over a highlighted word to open the 
contextual menu to view a list of suggested 
corrections and options to learn or ignore the 
highlighted word.

3 Select one of the suggested corrections if you want
to correct the word, choose Learn if you want Mellel
to learn the word, or choose Ignore to ignore this 
word during the current session.

Use Check Spelling Per 
Paragraph

1 Choose Edit > Spelling > Check Spelling Per Paragraph. 
When you press the Return key (that is, when you 
start a new paragraph), Mellel highlights with a 
light-red background every word you typed that is 
not included in the spelling dictionary in the 
preceding paragraph.

2 Ctrl+Click over a highlighted word to open the 
Contextual menu to view a list of suggested 
corrections and options to learn or ignore the 
highlighted word.

3 Select one of the suggested corrections if you want
to correct the word, choose Learn if you want Mellel
to learn the word, or choose Ignore to ignore this 
word during the current session.

Stop spell checking • Choose Edit > Spelling > Don’t Check Spelling. Mellel 
will remove the highlighting off suspect words, 
and will stop spell checking.

Use Check Spelling in a
Selection

1 Select some text.
2 Choose Edit > Spelling > Check Spelling in Selection. 

Mellel will highlight every word in the selection 
that is not included in the spelling dictionary.

3 Ctrl+Click over a highlighted word to open the 
Contextual menu to view a list of suggested 
corrections and options to learn or ignore the 
highlighted word.

4 Select one of the suggested corrections if you want
to correct the word, choose Learn if you want Mellel
to learn the word, or choose Ignore to ignore this 
word during the current session.
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Use Check Spelling in 
the whole document

1 Select some text.
2 Choose Edit > Spelling > Check Spelling in Document. 

Mellel will highlight every word that is not 
included in the spelling dictionary with a light-red 
background.

3 Ctrl + Click over a highlighted word to open the 
Contextual menu to view a list of suggested 
corrections and other spelling options.

4 Select one of the suggested corrections if you want
to correct the word, choose Learn if you want Mellel
to learn the word, or choose Ignore to ignore this 
word during the current session.

Set the language and 
associated keyboard 
layout for a language

• Choose Mellel (menu) > Preferences... and under the 
Language tab choose a language from the 
languages list and set the Spelling language and the 
Associated Keyboard Layout from the corresponding 
pop-up menus. 

Set the spelling 
dictionary for selected 
text in the document

1 Select the text. 
2 From the Character palette (with the Styles tab) 

choose a language from the Language pop-up 
menu. 

Synchronise language 
and keyboard layout

1 Choose Mellel (menu) > Preferences... and under the 
Language tab check Synchronize Language and 
Keyboard. Mellel will now synchronise the language
with a change in the keyboard layout. 

Set a customised 
language and spelling 
options

1 Choose Mellel (menu) > Preferences... and under the 
Language tab click the + button under the 
languages list. 

2 Set a name for the new, untitled language setting.
3 Set the Spelling language and the Associated 

Keyboard Layout from the corresponding pop-up 
menus. 

The Check Spelling Dialogue box
The simplest way to check the spelling in your document is to open the Spelling 
dialogue box, choose a spelling dictionary and then go through the text 
correcting errors. 
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Figure 204: The Check Spelling dialogue box

The Check Spelling dialogue box offers several options to scan the document for 
spelling errors and fix them:

• Change: Replaces the suspect word with the selected word from the Guess list,
then proceeds to the next suspect word. By default, the first suggested 
correction is selected for correction.

• Find Next: searches the text from the insertion point onward to the next 
suspect spelling error and highlight it in the text.

• Ignore: ignores the word currently highlighted as a spelling error and 
continues to the next suspect word. The word will be ignored during the 
current session, but will be spotted the next time you check spelling in that 
document. 

• Learn: When you press this button, the suspect word or term is entered into 
your user dictionary. 

• Define: Opens Mac OS X Dictionary looking for the marked word. 

• Guess: displays a list of the speller’s best guesses of the correct spelling of the 
suspect word. If the Guess list does not contain a suitable suggested 
correction, you can type a guess yourself and press the Guess button.

• Dictionaries: Allows you to switch between the different spelling dictionaries 
installed in your system. 
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Check spelling as you type
Mellel’s advanced spelling options include several options to mark (highlight) 
suspect words—as you type, when you create a new paragraph, for selected text, 
or for the whole document.

Setting and Changing spelling dictionaries
Mellel allows you to set and change spelling dictionaries based on the language 
and the language variant you’re using. 
For example, let’s say your text mixes English, German and French. Via the 
Language tab in the Preferences you can set Mellel to switch to the right spelling 
dictionary when you switch to each language, based on the associated keyboard 
layout. This way, when you change the language you use, Mellel will automatically
change the spelling dictionary (this option works if Synchronize Language and 
Keyboard is checked under the Preferences > Language tab. 
Mellel also allows you to set (and change) the spelling dictionary associated with 
any piece of text via the Character palette. This option is useful with text you 
paste from an external source (such as web page). 

Using a Thesaurus
Mellel supports a variety of thesauri, including the Mac OS X built-in Thesaurus 
Dictionary. You can access Dictionary via the contextual menu. Other third-party 
thesauri include several free thesauri based on Word-Net and several commercial 
thesauri.
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Bibliography and Reference
This chapter explains what bibliography and bibliographic references
are and how to use them

Should I read this chapter?
You should read this chapter if you intend to use bibliographic references 
and bibliographic databases with your document

Bibliography and Reference in Mellel
The bibliography feature in Mellel allows you to incorporate in your documents 
references (citations) to books, articles, essays, etc. stored in a Reference database 
application. Mellel also allows you to manage your citations, create a bibliography
of cited references, search for references, and more. 
Mellel can work with any reference application, but works especially well with two
prominent reference managers: Bookends from Sonny Software (http:/
/www.sonnysoftware.com) and Sente from Third Street Software (http:/
/www.thirdstreetsoftware.com/).

Stuff you can do
To... Do this Keyboard Shortcut

Activate entry for 
citations from 
Bookends

• Choose Mellel (menu) > Preferences... and with the 
Bibliography section choose Bookends from the 
Bibliography Application pop-up menu.

Activate entry of 
citations from Sente

• Choose Mellel (menu) > Preferences... and with the 
Bibliography section choose Sente from the 
Bibliography Application pop-up menu.

Activate Live 
bibliography

• Check the Live Bibliography check-box in the 
Bibliography palette. Mellel will verify your 
citations, and create a bibliography (or update it).

Note: This option is unique to Mellel<>Bookends 
collaboration.



Enter a citation from a 
reference manager 
application

1 Switch to the reference manager by using one of 
the following methods:
• Press the Switch to Reference Database button in 

the Bibliography palette. Or,
•  Choose Edit > Bibliography > Switch to Reference 

Database. Or,
• Switch to the reference manager application via 

the Finder.
2 Do one of the following:

• From the reference manager main window, 
select the citation(s) you wish to enter and 
Choose (Cite (in Sente) or Copy Selected citations 
(in Bookends)). 

• Select the citation you want to add, and drag 
and drop it into a Mellel document. 

• Copy the citation, switch back to Mellel and 
choose Edit > Paste (Cmd+P).

Note: When you drag and drop or paste a citation from 
Bookends or Sente, it is automatically converted into Mellel
Citation Object. When you drag and drop or copy a 
citation from any other reference manager, it will be 
pasted as it was formatted in the reference manager.

Cmd+Shift+Y

Cmd+Y

Cmd+P

Enter a group of 
citations from a 
reference manager

1 Switch to the reference manager by using one of 
the following methods:
• Press the Switch to Reference Database button in 

the Bibliography palette. Or,
•  Choose Edit > Bibliography > Switch to Reference 

Database. Or,
• Switch to the reference manager application via 

the Finder.
2 Do one of the following: 

• From the reference manager main window, 
select the citation(s) you wish to enter as a group
and Choose (Cite (in Sente) or Copy Selected 
citations (in Bookends)). 

• Select the citations you want to add, and drag 
and drop them into a Mellel document. 

• Select a citation you want to add, and drag and 
drop it into a Mellel document, then proceed 
with to other citations, placing them next to the 
first citation in the group.

• Copy the citations, switch back to Mellel and 
choose Edit > Paste (Cmd+P).

Cmd+Shift+Y

Cmd+Y

Cmd+P

Re-enter an existing 
citation

Do one of the following:
• Drag a citation from the Citations in document list in 

the Bibliography palette into the document. 
• Double click a citation in the Citations in document 

list in the Bibliography palette.
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Enter a new citation 
manually

1 Do one of the following:
• Press the Enter Citation Manually button in the 

Bibliography palette. Or, 
• Choose Edit > Bibliography > Enter Citation 

Manually. The Edit Citation dialogue box will open.
2 In the Edit Citation dialogue box enter the citation 

text, and press the OK button.
Note: you can access the Edit Citation dialogue box at any 
time by double-clicking the citation you've entered

Cmd+Option+M

Enter a group of 
citations manually

1 Do one of the following:
• Press the Enter Citation Manually button in the 

Bibliography palette. Or, 
• Choose Edit > Bibliography > Enter Citation 

Manually. The Edit Citation dialogue box will open.
2 Enter the citations in the group in sequence, 

separated by a semicolon (“;”), and press the OK 
button.

Enter a simple text 
(non-object) citation

• Place the insertion point where you want to add 
the citation, and enter the citation text. For 
example:

Note: It is recommended to use curly ({ }) or square ([ ]) 
brackets or tilde (~) as citation delimiters. Mellel will know 
how to automatically convert manually entered citations 
delimited by those characters to Mellel citation objects (via 
the option Convert Text to Citations...)

Scan a document and 
create a bibliography

1 Do one of the following:
• Click the Scan button in the Bibliography palette. 

Or,
• Choose Edit > Bibliography > Scan Document.

2 The reference manager will now let you select a 
bibliography and citations format for the final 
manuscript.

Add citations after a 
scan

• Add one or more citations. The citations will be 
added as temporary citations. 

Note: if Live Bibliography is turned on (only available with 
Mellel and Bookends) citations will be added in their final 
format and bibliography items will be added 
automatically. 
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Re-scan a document 1 Do one of the following:
• Click the Scan button in the Bibliography palette. 

Or,
• Choose Edit > Bibliography > Scan Document.

2 If you’re using Bookends, there will be no step 2. 
The process will be done quietly. With other 
reference managers you will need to select a 
bibliography and citations format for the final 
manuscript. 

Note: if Live Bibliography is turned on (only available with 
Mellel and Bookends) Scan and Unscan will not be 
available, as they are not needed with Live Bibliography 
turned on. 

Unscan all the citations • Do one of the following:
• Click the Unscan button in the Bibliography 

palette. Or,
• Choose Edit > Bibliography > Unscan Document). 

The bibliography content will be erased, and all 
the citations will revert to their pre-scan 
appearance.

Note: if Live Bibliography is turned on (only available with 
Mellel and Bookends) Scan and Unscan will not be 
available, as they are not needed with Live Bibliography 
turned on. 

Unscan a single 
citation 

1 Double-click a citation in the text to edit it in the 
Edit Citation dialogue box.

2 From the Display pop-up menu choose Temporary 
Citation and press the OK button. 

View the temporary or 
the scanned citation

• Double-click a citation in the text to edit it in the 
Edit Citation dialogue box. The citation will be 
displayed in its scanned and unscanned format.

Edit a citation Do one of the following:
• Option-Click a citation to enter it and edit the 

citation. Or,
• Double-click a citation in the text to edit it in the 

Edit Citation dialogue box.

Change the formatting
or style of a citation

1 Do one of the following:
• Option-Click a citation to enter it and edit the 

citation. Or,
• Double-click a citation in the text to edit it in the 

Edit Citation dialogue box.
2 Select the text you want to format and format it 

(e.g., by pressing F2 to move to the second 
variation in a style or pressing Cmd+b). 

Copy or paste a 
citation

• Select the citation in the text and choose Edit > 
Copy or Edit > Paste. 

Replace a citation • Select the citation in the text and enter another 
citation using one of the citation entry options. 
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Update a reference in 
the reference manager

1 Press Option + Double-click on the citation you 
want to update in the text or in the Citations List.

2 Update the reference in the reference manager. 
3 Copy the citation (Cite (in Sente) or Copy Selected 

citations (in Bookends)). This is not a necessary step,
as the citation will be updated automatically with 
Verify, Scan or a Live Bibliography.

Option+Double-click

View a citation details • Double-click the citation in the document. 

Verify citations • Do any of the following:
• Press the Verify button in the Bibliography palette. 

Or, 
• Choose Edit > Bibliography > Verify Citations.

Check if a citation is 
verified or not (and 
verify it)

1 Double-click a citation to open the Edit Citation 
dialogue box. If the citation is verified, you’ll see a 

 at the lower right hand of the dialogue box. If 
the citation is not verified, you’ll see a Question 
mark button ( ) at the lower right hand of the 
dialogue box.

2 To verify the citation, click the Question mark button
and follow to select the correct citation in your 
reference manager. 

Note: This option is unique to Mellel<>Bookends 
collaboration.

Refresh (update) the 
citations list

• Press the Refresh Citation List button in the 
Bibliography palette.

To find a citation in a 
reference manager

• Do one of the following:
• Press the Find in Reference Database button. Or, 
• Choose Edit > Bibliography > Find in Reference 

Database).
Note: If you want to use a specific piece of text in the 
document as the Find value, select it in the document 
window.

Cmd+Option+Sift+F

Go directly to a 
reference in a 
reference manager

• Press Option+double-click over a citation in the 
text or in the Citations List in the Bibliography 
palette.

Option+Double-click

Browse through 
citations in a 
document

1 Choose Edit > Find > Find...
2 Choose Citation ( ) from the Insert Element pop-up 

menu in the Find dialogue box.
3 Click “Next.”
Note: You may also use all the regular Find options (such 
as Cmd+G to jump to the next instance of the Find string). 

Cmd+F
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Jump between 
occurrences of a 
citation in the text

1 Place the insertion point where you want to start 
searching for the citation’s occurrences. 

2 Select the desired citation in the Citations List in the
Bibliography palette and press Cmd+double-click.

Note: If you want to find the first occurrence of a citation, 
place the insertion point in step 1 at the beginning of the 
document.

Cmd+Double-click

Temporarily turn the 
citation background 
colour on or off

• From the View> Show Hidden sub-menu, check or 
uncheck the option Citations.
For example, if the citation appears in the text like 
this:

When Citations is turned off, it will look like this:

 

Change the 
preferences for citation
background colour 
display

1 Choose Mellel (menu) > Preferences....
2 In the Appearance tab, check or uncheck the check-

box Citations.

Perform a proof-
reading scan (verify all 
the citations)

1 Press the Scan Document button in the Bibliography 
palette. Mellel will drop a sheet indicating that a 
scanning is in progress. This sheet will remain there
for the duration of the scanning.

2 Bookends or Sente will come to the foreground 
and display a dialogue box allowing you to choose 
the Bibliography format and other options. Act as 
instructed by the Reference manager.

3 If the reference manager will encounter an 
ambiguous citation (i.e., a citation it is not sure to 
what reference it refers), it will display a special 
dialogue box allowing you to match this citation 
with a reference in the reference database.
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Change the styles used
with the bibliography

1 Choose Mellel (menu) > Preferences... and click the 
Bibliography tab. 

2 Select the Style set you want to use to format the 
bibliography. 

3 Select a text style under the Replace list. and then 
select a paragraph style to be used with the 
bibliography. You can choose Don’t Replace to avoid
replacing. 

4 Repeat step 3 with all the other elements. 

Move the bibliography • Do one of the following:
• If the bibliography has an auto-title (e.g., 

“Bibliography”) above it, open the Outline pane 
and drag this auto-title to any desired location. 

• If the bibliography doesn’t have an auto-title 
above it (or if the above method is otherwise 
unsuitable), select the entire bibliography and 
choose Edit > Cut to cut it, then move to the 
desired location and choose Edit > Paste. 

Note: If you move the bibliography manually (i.e., not via 
the outline), you may have to ‘terminate’ it by inserting a 
Section break at the end of the bibliography. 

Synchronise the 
database

• Open a document with citations and choose Edit > 
Bibliography > Synchronise Database.

Convert text to 
citations

1 Choose Edit > Bibliography > Convert Text to Citations
2 Select the delimiter used in the text and press OK. 

Mellel will convert anything inside delimiter 
selected into citation objects.

Note: Converting plain text to Mellel citation objects does 
not remove the possibility of the existence of unmatched or
ambiguous citations. You may have to resolve such issues 
using your reference manager application.

Working with citations
Working with citations involves two steps: entering the citation (either as a 
temporary citation or in its final format), and creating the manuscript with a 
bibliography in their finished form. Other options related to references, such as 
the entry and management of your reference documents, is handled by the 
reference manager application. 
The first step to working with citations is easy—just switch to the reference 
manger and choose Copy Citation (Bookends) or Cite (Sente). The citation will 
appear in Mellel.
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Figure 205: A temporary citation in the document

Citations in Mellel are smart objects. That is, they are pieces of text that change 
dynamically—both in content and appearance—depending on their status 
(temporary or final), and their verification (verified versus unverified). 
Following are two tables detailing the appearance of citations in the text 
depending on their status:

Table 23: Bookends: Citations and their appearance
Citation Status

temporary citation

Final-form citation

temporary citation, unverified

Final-form citation, unverified

Table 24: Sente: Citations and their appearance
Citation Status

temporary citation

Final-form citation

Final-form citation, unverified

The Bibliography palette and menu
The command centre for all the options connected to citation entry and 
manipulation is the Bibliography palette. This palette, just like any other palette in 
Mellel, can be toggled on and off, moved, collapsed, combined with other 
palettes in a palette group, and so on. 
All the options available via the Bibliography palette are also available via the 
Bibliography sub-menu under the Edit menu. This sub-menu offers the equivalent 
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menu items for all the Bibliography palette buttons, except the Refresh button, and
contains several options that do not appear in the palette.

Note: For a detailed description of how palettes in Mellel work see the section about 
Palettes).

Figure 206: The Bibliography palette

Bibliography palette
The Bibliography palette buttons offer access to several important functions:

Live Bibliography
The Live Bibliography feature allows you to update your bibliography as you go 
along. Whenever you enter a citation, Mellel will automatically verify it and then 
update the citation to its final format and add the appropriate item to the 
bibliography. 

Note: This option is unique to Mellel<>Bookends collaboration.

Bibliography palette buttons
• Refresh: updates the list of citations in the Citation list. 

Bibliography and Reference327



• Enter Citation Manually: allows you to manually enter a citation into the text.
This option is also available via Edit > Bibliography > Enter Citation Manually. 

• Verify Citations: verifies all the citations in the document. Mellel will switch 
to the reference manager if there are problems you need to address (i.e., when
the reference manager cannot find and verify the citation). This option is also 
available via Edit > Bibliography > Verify Citations. 

Note: This option is unique to Mellel<>Bookends collaboration.

• Scan Document: replaces all the temporary citations in the document with 
their final manuscript format and adds a bibliography to the bibliography 
section. This option is also available via Edit > Bibliography > Scan Document.

• Unscan Document: reverts the citation to their temporary formatting, and 
removes the bibliography. This option is also available via Edit > Bibliography > 
Unscan Document.

• Find in Reference Database: switches to a reference manager, if applicable, 
opens the Find dialogue box in the reference manager. This option is also 
available via Edit > Bibliography > Find in Reference Database. 

• Switch to Reference Database: switches to a reference manager. This option 
is also available via Edit > Bibliography > Switch to Reference Database. 

The Citations List
The Citations in Document list in Mellel’s Bibliography palette is a handy tool to 
navigate, browse, enter, re-enter, and replace citations in a document. The list 
contains every citation you have used in the document, sorted alphabetically. The
Citation List is document specific and updated when you enter a citation into the 
document, either manually or from a reference database.

Bibliography menu
In addition to the options detailed above, there are two additional options that 
exist only in the Bibliography menu.

• Convert Text to Citations...: allows you to convert citations entered into a 
Mellel document into Citation objects. This option is useful when importing 
text.

• Synchronise Database: synchronises the citations in the document with the 
citations in the reference manager database. If the document contains 
citations that do not exist in the reference manager database, they will be 
added to it. If there are ambiguous citations, you’ll need to resolve those 
ambiguities. 
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Note: This option is unique to Mellel<>Bookends collaboration.

Entering citations
You can enter citations into a Mellel document in a multitude of ways, from 
entering them manually to a completely automated entry process, or any other 
combination in between.

Entering citations using a reference manager
Entering citations using a reference manager is just as easy as entering citations 
manually. All you need to do is switch to your reference manager and simply 
enter the citation or the group of citations. 

Entering citations from the Citations list
The citations list is a quick and simply way to enter once more citations you’ve 
already entered before. This option may seem superfluous with short articles, but 
for longer manuscripts, it becomes an indispensable tool.

Entering citations manually
If you do not use a reference manager application, or if you simply prefer to enter 
citations manually, you can enter a citation or a group of citations very easily, 
using the Bibliography palette or the Edit > Bibliography sub-menu.

Entering non-object citations
Mellel’s Citation object may not fit all your needs, and you’ll need to manually 
enter a citation that is not an Citation object. Doing this is as simple as adding any
text in Mellel. The one thing you will need to know is how to frame the citation—
That is, what delimiters you wish to have before and after the citation (e.g., curly 
({ }) or square ([ ]) brackets or tilde (~).

Editing citations
Mellel offers several options to edit citations in a document. Apart from the usual 
methods (copy and paste), there are also options for replacing and updating 
citations, grouping and re-arranging groupings of citations, and more. All the 
editing options are detailed under Stuff you can do. 
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Special citation options
There are several options that enable you to add, filter, and change the way 
citations will look in the final manuscript.

Special Citation options you can do
To... Do this Keyboard Shortcut

Exclude a citation from
the final document

• Double-click a citation to open the Edit Citation 
dialogue box and do one of the following:
• Check the option Exclude from Final Document 

button. Or,
• Enter “!” (without the quotation marks) at the 

beginning of the citation. 
Note: The next time you open the Edit Citation dialogue 
box, Mellel will automatically delete the “!” and check the 
option Exclude from Final Document. 

Prevent enclosing a 
formatted citation

This option will force Mellel to omit the enclosing 
character (such as parentheses marks) from the final 
form citation. This option is useful when you have 
citations in the text and in the footnotes too, but also
in other cases.
• Double-click a citation to open the Edit Citation 

dialogue box and do one of the following:
• Check the option Don’t enclose formatted citation. 

Or,
• Enter “*” (without the quotation marks) at the 

beginning of the citation. 
Note: The next time you open the Edit Citation dialogue 
box, Mellel will automatically delete the “*” and check the 
option Don’t enclose formatted citation. 

Suppress superscript This option allows you to prevent text from being 
superscripted, even if this is the normal way citations 
should appear in the final manuscript. This option is 
useful mainly with citation styles that use only 
numbers in final manuscript.
• Double-click a citation to open the Edit Citation 

dialogue box and do one of the following:
• Check the option Suppress Superscript. Or,
• Enter “_” (without the quotation marks) at the 

beginning of a citation. 
Note: The next time you open the Edit Citation dialogue 
box, Mellel will automatically delete the “_” and check the 
option Suppress Superscript. 
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Display date only in a 
citation

This option allows you to display only the date in the 
final manuscript. It is useful when you refer to a 
citation in the text, but wish to avoid referring to it in 
full. For example:

will look very cumbersome after scanning:

But if you add a percent character before the citation:

the text will look exactly right:

1 Double-click a citation to open the Edit Citation 
dialogue box.

2 Enter “%” (without the quotation marks) at the 
beginning of a citation.

Add a page number or 
page numbering to a 
citation

1 Do one of the following:
• Option-click a citation to enter it and edit the 

citation. Or,
• Double-click a citation in the text to edit it in the 

Edit Citation dialogue box.
2 Enter “@” (without the quotation marks) at the end 

of the citation. 
3 Enter the page number or page range (e.g, 30 or 

30-33). 

For example, the following addition to a citation:

will produce the following output:
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Add additional info to 
a citation

1 Do one of the following:
• Option-click a citation to enter it and edit the 

citation. Or,
• Double-click a citation in the text to edit it in the 

Edit Citation dialogue box.
2 Enter “\” (without the quotation marks) at the 

beginning or at the end of a citation, enter the 
additional info, and then enter another “\” to mark 
where it ends.

For example, the following addition to a citation:

will produce the following output:

Finding and navigating
Mellel offers several options for finding citations in the document text and in the 
reference manager. In addition, it offers some excellent tools to navigate among 
citations. All the options can be accessed easily, either from the document itself or
via the Bibliography palette. Find and navigation options are detailed under Stuff 
you can do.

Controlling citation appearance
Citations in Mellel behave like normal text in a document. That is, you can apply 
styles to them or to the surrounding text, and they will behave just like any other 
piece of text. The only apparent difference is that citations have a special bluish or
purplish background colour (which you can turn on and off). 

Producing the final manuscript
Once the document is prepared and all the citations are right where they should 
be, you would probably want to view the manuscript in its final form. With Live 
Bibliography turned on you probably have already, but if you only want to see the 
manuscript in it finished format when all the changes you can do that too. 
This stage of the work contains three steps: checking for possible errors 
(verifying), setting the format for the citations, and producing the final 
manuscript. 
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Verifying citations
When you enter a citation via a reference manager, it is automatically verified, and
if you have Live Bibliography turned on a bibliography item is automatically added. 
When you change the content of a citation, or when you enter a citation 
manually, the reference manager cannot tell if the citation is still valid—that is, if it
can still be mapped to a reference in the reference database. This is when 
verification is needed. 

Note: Verification is needed if you do not have Live Bibliography turned on. This option is 
available if you’re working with Mellel and Bookends.

Proof-reading scan
If you’re using an older version of Mellel and Bookends, or if you’re using another 
reference manager, you’ll need to perform a proof-reading scan to check for 
errors.

The bibliography appearance
Mellel lets you control the way your final manuscript will look. Since citations can 
be manipulated just like any other piece of text, most of the formatting options 
are related to setting the way your bibliography will look. 

Bibliography preferences
The bibliography created by Bookends or by Sente is appended to the end of the 
manuscript after a scan. Bibliographies are usually formatted within the reference 
manager using simple character formatting options such as bold, italic, and 
underline. Those formatting options usually work nicely enough, and if that’s 
good enough for your purpose then you need not bother with formatting the 
bibliography.
If the automated bibliographical formatting does not conform with the way you 
wish to format your text, you can use Mellel’s preferences to change the 
formatting. 

Scanning and unscanning
Now that you have verified and set the formatting for your manuscript, it’s time to
scan it, that is, to produce the final manuscript with the bibliography. 

Note: Scanning, unscanning and re-scanning are only needed if you do not have Live Bibli-
ography turned on. Those options are available if you’re working with Mellel and 
Bookends.
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The result of the scan process will be a document with citations in their final 
format, and a bibliography positioned at the end of the document. 

Figure 207: A scanned citation

Figure 208: The bibliography

As you will notice immediately, the bibliography has a grey gradient line to its left 
(or to its right, with text that runs from right to left). This line will not be printed 
or display in a PDF—Its sole purpose is to mark where the bibliography is. 

Rescanning
If you’ve added citations or changed citations, you will need to scan the 
document again, so that the changes will be reflected in the bibliography.

Note: Scanning, unscanning and re-scanning are only needed if you do not have Live Bibli-
ography turned on. Those options are available if you’re working with Mellel and 
Bookends.

Unscanning
Unscanning of a document means reverting to the document as it was before any
scans were performed. You may want (or need) to do that, for example, if you 
need to scan a document using a different bibliography formatting (e.g., to 
conform with the style guide of different publications). 

Note: Scanning, unscanning and re-scanning are only needed if you do not have Live Bibli-
ography turned on. Those options are available if you’re working with Mellel and 
Bookends.
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Moving the bibliography
The bibliography in Mellel is a special section, which can be changed and moved 
like any other section. The bibliography is initially positioned at the end of the 
document, but it doesn’t have to stay there. You can move it around and position 
it anywhere you want. 

Synchronise Database
Synchronise database, an option available with Mellel and Bookends, allows you 
to load all the citations in a document into a reference database, check if they 
already exist there, and remove ambiguities. This is useful, for example, when you 
receive a document containing citations that do not exist in your reference 
database. Synchronisation will add those missing references to your reference 
database. This option is also handy moving citations and references around with 
the document, serving as a mobile library of sorts. 

Note: This option is available now only with Mellel and Bookends.

Migrating to Mellel
You can easily migrate older documents that include citations to Mellel. For 
documents containing citations created by other reference managers, you would 
have to import the references into Bookends or Sente to proceed (for more 
details, see the manuals of Bookends or Sente).
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Advanced Typography
This chapter details the various advanced typography options in 
Mellel

Should I read this chapter?
You should read this chapter if you intend to use OpenType fonts in your 
documents

Mellel offers several advanced typography options. Most of these options 
depend, at this point, on Mellel’s support of the OpenType technology. Following 
is a review of some of these options.

Kerning
Kerning is an adjustment of the horizontal space between pairs of individual 
characters. The object of kerning is to create the visual impression that the space 
between characters in the text is equal, so that the text will look smooth when 
read.
Mellel supports automatic kerning of pairs of characters with OpenType fonts, 
based on tables of kerning pairs within such fonts. For example, this is how the 
text will look without kerning:

Figure 209: Without kerning

Note especially the distance between the Wa, Av and fig. And this is how the same
text looks with kerning:

Figure 210: With kerning

To use automatic kerning:
1 Select a piece of text.
2 Select an OpenType font. 



Small Caps
Small caps are an alphabet of small capital letters, approximately the size of lower 
case letters (i.e., about x-height). Small caps sets exist in special small caps fonts, 
where they simply replace lowercase letters, but are also supported by special 
font technologies and by applications that create “fake” small caps. Mellel 
supports small caps where they exist in OpenType fonts.
This is an example of small caps in Mellel:

Figure 211: Small caps example

The same text in an application that “fakes” small caps will look like the following 
(screen image taken from a different word processor:

Figure 212: “Fake” small caps

As you might note, whereas with the first example, Mellel is using a set of letters 
especially prepared to be used as small caps, including special kerning between 
capital letters and small caps (as with “To" and “Th") whereas the “fake” example, 
taken from another word processor, simply takes the capital letters and reduces 
their size. The end result in the second case is text that is less legible and looks 
crude. 

To use small caps:
1 Select a piece of text.
2 Select an OpenType font in the Character palette.
3 Select All small Capitals from the OpenType pop-up menu to have the text 

switched to small caps, while maintaining the capital letters as they are, or 
Small Capitals from Capitals to only change capital letters to small caps capitals 
in the Character palette. 

Advanced Typography337



Using “fake” small caps
There are some cases where you’ll have to use small caps with OpenType fonts 
that do not support this option or with a non OpenType font. Although the text 
will never look as good as when using true small caps and should not be used 
with documents intended for printing or typesetting, the results Mellel will allow 
you to achieve with “fake” small caps are quite acceptable. 

To use “fake” small caps with Mellel:
1 Create a character style using the font you would like to create “fake” small 

caps for. The method works best with fonts that offer a large number of faces. 
Assign one of the style’s variations for small caps and move to that variation.

2 Create a sample text with the same word twice—in lower caps and capital 
letters. Since small caps are usually the size of lower caps letters, use 
characters that do not go under the baseline or above the height of lower 
caps letters, as in this example:

Figure 213: This is the answer

3 Change the size of the sample text in capital letters to roughly the size of the 
lower caps letters (or a fraction smaller). Changing the text to about 70 per 
cent of the original size would normally do the trick:

Figure 214: A smaller answer

4 Change the face for the capital letters to a bold face (at any rate, bolder than 
the one normally used) and save the changes into the character style 
variation. 
The end result would never look the same as true small-caps, but it would 
look acceptable, as you can see in the following example:
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Figure 215: This is our final answer

Ordinals and fractions
Ordinals are automatic and context-sensitive switching of characters from regular 
type to superscripted type. Ordinals are usually used to denote numbering or 
person, like with the following example:

Figure 216: Ordinals example: segunda/segundo and No.

Fractions with Mellel are usually specially made fraction ligatures for common 
fractions and special superscripted numbers for non-common fractions. For 
example:

Figure 217: Fractions

To use ordinals or fractions in a font:
1 Select a piece of text and select an OpenType font in the Character palette.
2 Select Fractions or Ordinals from the OpenType pop-up menu in the Character 

palette. 

Note: with ordinals and fractions, it is better to apply the option on a specifically selected 
piece of text rather than globally because some ordinal combinations also occur in regular
text (e.g. “Nothing”).
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Swash
Swash characters are stylised versions of some letters, appearing mainly at the 
start or at the end of a word. Most OpenType fonts offer Swash alternatives only 
with the italics face of the font. 

Figure 218: Swash example

To use Swash letters in a font:
1 Select a piece of text.
2 Select an OpenType font in the Character palette.
3 Select Swash from the OpenType pop-up menu in the Character palette.

Note: The Swash option can be turned on at all times, in most cases. 

Titling alternates
Titling alternates are a set of characters especially designed for titles and 
headings. Titling alternates are rarely found in ordinary OpenType fonts. 

To use Titling alternates in a font:
1 Select a piece of text.
2 Select an OpenType font in the Character palette.
3 Select Titling alternates from the OpenType pop-up menu in the Character 

palette.

Stylistic alternates
Stylistic alternates are usually a different or second acceptable form of a character.
This option is most often used with cursive fonts and languages to enhance the 
hand-written look of the font or language. For example, this example in Arabic 
without stylistic alternates:
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Figure 219: No Stylistic alternates

And with them:

Figure 220: With Stylistic alternates

To use Stylistic alternates in a font:
1 Select a piece of text.
2 Select an OpenType font in the Character palette.
3 Select Stylistic alternates from the OpenType pop-up menu in the Character 

palette.

Justification alternates
Justification alternates are used mainly in cursive languages where justification is 
usually achieved not by extending the space between the characters but through 
extending the width of some characters. This option is common in Arabic 
OpenType fonts, but also exists in Hebrew OpenType fonts. 

Figure 221: No Justification alternates
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And with them:

Figure 222: With Justification alternates

To use Justification alternates in a font:
1 Select a piece of text.
2 Select an OpenType font in the Character palette.
3 Select Justification alternates from the OpenType pop-up menu in the Character

palette.

Using Justification alternates versus Kashida
When writing fully justified text in Arabic or Farsi, Kashida is most often used. 
Using Justification alternates instead seems like a viable alternative, but it is not. 
Text drawn using Justification alternates alone will not look good enough, and in 
many cases the space between characters will be stretched more than it should 
be. 
The text will look its best if Kashida is always activated (on) and justification 
alternates are used just “here and there” to embellish the text or add some special 
flavour to bits of text. Justification alternates are useful, however, when full 
justification is not activated (e.g., if the text is simply aligned to the right), so the 
text will look more “alive” in such situations.

Contextual alternates
Contextual alternates are substitute letter forms that occur only in certain 
contexts, depending on the preceding and following letters. This option is 
commonly found in some cursive fonts to achieve a more realistic effect. 

To use Contextual alternates in a font:
1 Select a piece of text.
2 Select an OpenType font in the Character palette.
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3 Select contextual alternates from the OpenType pop-up menu in the Character
palette.

Superscript and subscript
Superscript/superior and Subscript/inferior is an option providing specially 
designed letters and numbers that are smaller than regular letters and appear 
above or below the baseline. 
Superscripted characters are usually not supported for all characters but only for 
numbers and the following letters: A a b d e h i l m n o r s t. Subscript characters are 
usually supported only with numbers and punctuation marks. 

OpenType versus faux superscript and subscript
If you ponder whether to use the superscript and subscript options offered by 
Mellel (i.e., faux or “fake” superscript and subscript) or those offered in 
OpenType—simply don’t. Those options look much better in OpenType so, if you 
can use them (i.e., you have a suitable font)—use them. Take a look at the 
following example:

Figure 223: Two OpenType (left) versus faux superscript and subscript (right)

As you can clearly see, the OpenType version looks much better and also enjoys 
correct kerning. 

To use superscript and subscript characters in a font:
1 Select a piece of text.
2 Select an OpenType font in the Character palette.
3 Select Superscript/superior or Subscript/inferior from the OpenType pop-up 

menu in the Character palette.

Numerator and denominator
A special set of OpenType characters is used to display numerator and 
denominator characters. Those characters are different from superscripted and 
subscripted text in their vertical shift, with the numerator numbers usually 
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located slightly above the x height point and the denominator numbers laying on
the baseline. Numerator and denominator should be used only with 
combinations not supported by the Fractions option.

Figure 224: Numerator and denominator example

To use numerator and denominator characters in a font:
1 Select a piece of text.
2 Select an OpenType font in the Character palette.
3 Select numerator or denominator from the OpenType pop-up menu in the 

Character palette.

Figure types
The OpenType technology supports four types of figure (number) types: Tabular 
lining, Tabular old style, Proportional lining, and Proportional old style. Tabular 
means equal width, proportional means proportional width, lining means equal 
height, and old style means changing height, depending on the figure at hand. 
Following are four examples of how the different types of figure styles look in an 
OpenType font:

Figure 225: Tabular lining
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Figure 226: Tabular old style

Figure 227: Proportional lining

Figure 228: Proportional old style

To activate a figure type in a font:
1 Select a piece of text, and then select an OpenType font in the Character 

palette.
2 Select one of the figure options from the OpenType pop-up menu of the 

Character palette.
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Typographer’s Quotes
This chapter explains what typographer quotes are and how to use 
them

Should I read this chapter?
You should read this chapter if you intend to use typographer quotes in 
your documents

What are typographer quotes
Typographer’s Quotes (also known as “Smart Quotes” or “Curly Quotes”) is the use 
of stylish (curly, angled, rounded) open and close, primary and alternative 
quotation marks instead of the “straight quotes” found on a keyboard. 
Typographer’s Quotes are used in books, publications, magazines, and 
newspapers, but are less common in email messages, web pages, and letters.

Boring historical background…
The three common terms used when referring to Typographer’s Quotes are 
somewhat misleading: Typographer’s Quotes have little to do with typography or 
typographers, they are not necessarily “Curly,” and their application in most word 
processors hardly merits the title “Smart.”
The familiar “straight quotes” are actually not quotation marks at all. Due to the 
lack of space in typewriters (and later on, with the 128 ASCII characters), designers
decided to economise and used the Prime and Double Prime keys (used to mark 
time and length) as quotation marks too. After more than a century of using this 
“hack,” many people tend to believe that what is called “Typographer’s Quotes” is 
actually a stylish newfangled fashion. Nothing could be further from the truth. 
“Typographer’s Quotes” are the only quotation marks one should use, whether 
they have typographic tendencies or not. All other types of quotation marks are, 
simply put, an inherent mistake.
Calling quotation marks “Curly Quotes” is also a misnomer. In fact, in most 
European countries, the quotation marks are not curly at all. This also applies to 
the habit of considering double quotation marks as primary marks and single 
quotation marks as alternative. Often enough, the order is reversed.
Last, but by no means least, comes the misnomer of naming the application of 
“Typographer’s Quotes” in a word processor “Smart Quotes.” The application of 



this option in most word processors is simplistic enough to earn them the less 
flattering name “Stupid Quotes.”

Implementation in Mellel
Mellel sets to correct past wrongs on all three fronts: Mellel uses the correct 
terminology, offers true multilinguality with Typographer’s Quotes, and, of course,
makes them truly smart, easy to use, and flexible.
The various options used with Typographer’s Quotes in Mellel can be activated, 
changed, and edited via the Typography section ( ) of the Preferences.

Figure 229: Typographer’s Quotes options

To activate or deactivate Typographer’s Quotes:
1 Choose Mellel (menu) > Preferences....
2 In the Typography section ( ) of the Preferences, check or uncheck “Activate.”

To select a different type of quotation marks style:
1 Choose Mellel (menu) > Preferences....
2 In the Typography section ( ) of the Preferences, select one of the options 

from the Type pop-up menu.

To create a custom quotation marks style:
1 Choose Mellel (menu) > Preferences....
2 In the Typography section ( ) of the Preferences, click in one of the four 

available fields and enter a different primary or secondary, open or close 
quotation mark. When one of those fields is changed, Mellel automatically 
changes the quotation style Type to “Custom.”

To momentarily override Typographer Quotes:
1 In the document area, press Ctrl +’ or Ctrl +”
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Using Typographer’s Quotes
Mellel makes the distinction between primary and alternative quotation marks. 
Primary quotation marks are the quotation marks regularly used on both ends of 
a quote. Alternative quotation marks are usually used to mark a quote within a 
quote. For example:

Figure 230: Usage of Typographer’s Quotes

Mellel determines which quotation mark to use according to the quotation mark 
location in the text. It is not smart enough, however, to detect the correct 
quotation mark to be used in all cases. For example:

Figure 231: Typographer’s Quotes without editing

Left untended, Mellel (along with all other word processors) will get the quotation
mark all wrong. The usual “hack” here is to type two consecutive alternative 
quotation marks, copy the second, paste it over the first and hope that nobody 
will notice that this is also typographically wrong:

Figure 232: The problem at hand

With Mellel, all you have to do is press Ctrl +' to have Lewis Carroll chortle with 
joy:
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Figure 233: The simple fix to the problem

Another typical problem is when one needs to use special quotation marks to suit
a special output option (HTML, code, spreadsheet) or for any other reason. Here, 
the Custom quotation mark becomes extremely useful. Take the following 
example:

Figure 234: And another problem

Here you can see that the quotation marks are replaced by HTML character marks.

Replacing Straight Quotes
Many documents, such as e-mail messages or plain text documents, contain 
“straight quotes” instead of Typographer’s Quotes. You can replace those “straight 
quotes” quickly and efficiently by using Mellel’s Find and Replace feature. You can 
save the different Find Actions you will create to run them in the future, and you 
can even create a FindSet to run all the find actions automatically, one by one. 

To Replace Straight Quotes with Typographer’s Quotes:
1 Open the document containing the “straight quotes.”
2 Choose Edit > Find > Find (or press Cmd + F).
3 In the Find field, choose Whitespace from the Element menu. 
4 Select the Whitespace and click the Group button. 
5 Enter a straight quote (") character after the Group. In steps 4 and 5, you’ve 

instructed Mellel to find every open double quote that comes following a 
space of any sort. This is rather crude, but will fit almost all cases where an 
Open Double Quote is required. You can improve this by adding other cases 
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such as adding Em Dash as another place after which open quotation marks 
are required.

6 Move to the Replace field, and from the Element menu choose Backreference. 
7 Enter your preferred opening double quotation mark. 
8 Click the Save Find Action button and save the Find Action. 
9 Press the Replace All button. 
10 Repeat steps 3 to 9 for a single quotation mark. After replacing all the 

remaining instances of double straight quotation marks, you should have all 
the quotation marks in your document curled just as they ought to. 

11 For the close double and single quotation marks, simply enter " and ' as the 
strings to find, and enter ’ and ” as the strings to replace them. 

12 Optional: Choose Edit > Find > FindSet and create a FindSet with those four 
actions, in the same order they appear here and run them whenever you need
to curl your quotation marks. 
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Multilingual support
This chapter contains details about the multilingual support in Mellel

Should I read this chapter?
You should read this chapter if you intend to write text in a non-Roman 
language

Mellel provides excellent language support for more than 200 languages. The 
following chapter briefly covers some of the special options offered for some 
languages and language groups. 

Activating and switching languages
When you want to write in a certain language, you usually want to choose the 
keyboard layout or input method and start writing. Mellel language switching 
capabilities allow you to do just that, simply and efficiently. 

Activating your language
The first step to begin writing in a certain language is to activate entry of text in 
that language.

To activate languages:
1 In the Dock, click the System preferences icon to open the System preferences 

panel. 
2 Click the Language and Text system preference. 
3 Click the Input menu tab view. 
4 In the Input menu tab view, check the option Show input menu in menu bar. 
5 Check to select all the languages you want to activate, and check the options 

Character Palette and Keyboard Viewer. 
The following screen shot shows how to select a language from the languages 
list. 



Input tab

Hebrew 
keyboard layout

Should be 
checked

Figure 235: Selecting a language from the Input list

Switching between languages
After activating the languages you’ll want to use, you can now start to write using 
those languages. You only need to know how to switch between languages. 

To switch between languages:
1 Place the insertion point in the document. 
2 Go to the Input menu in the Finder (located at the top-right end of the menu bar, 

usually with a country flag at the top) and select the language you want to use. 
3 Start typing. Mellel will find a suitable font for your language.
4 When you want to switch to another language, repeat steps 2 and 3. 

Important tip: You can save yourself a lot of time by using the customary keyboard shortcuts 
for switching between languages. Pressing Cmd+Space bar will switch between the two 
recently selected languages (keyboard layouts). Pressing Cmd+Option+Space bar will 
switch between all the available languages in the Input Menu. 
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Bypassing Spotlight
With Mac OS X 10.4, Apple introduced Spotlight, which enables searching within 
files. The Spotlight shortcut is initially Cmd+Space, and you need to change that 
to be able to switch between languages.

To change Spotlight’s preferences:
1 In the Dock, click the System preferences icon to open the System preferences. 
2 Click the Spotlight system preference. 
3 Uncheck the option Spotlight Menu keyboard shortcut and Spotlight Menu Window 

Shortcut. 

Special input methods
When you want to enter just a word or two in a certain language, or wish to use a 
special character, using the regular keyboard layout for that language will be too 
complicated or even useless. In such cases, you may want to use two tools 
provided with Mac OS X: The Keyboard Viewer, which allows you to enter text by 
clicking the letters in a simulated keyboard; and the Character Palette, which 
allows you to select any character from any language to enter into your text. 

To use the Keyboard Viewer:
1 Place the insertion point in the document. 
2 Go to the Input menu in the Finder (located at the top-right end of the menu bar, 

usually with a country flag at the top) and select Show Keyboard Viewer. 
3 Go again to the Input menu and select the language you want to use. 
4 In the Keyboard Viewer, click the characters you want to use in your text. They will 

automatically be entered into your document. 

Tip: You can switch between languages with the Keyboard Viewer activated. 

To use the Character Palette:
1 Place the insertion point in the document. 
2 Go to the Input menu in the Finder (located at the top-right end of the menu bar, 

usually with a country flag at the top) and select Show Character Palette.
3 In the Character Palette, double-click any character you want to place into your 

document.

Tip: Mellel will allow you to enter only characters with a Unicode encoding. It will not allow 
you to enter characters in a font that are not Unicode encoded. 
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Automatic language switching
Mellel offers several special features for smooth writing and switching languages. 
One of the most important among those is the automatic language switching 
option. This option works it magic mostly behind the scenes, to minimise the 
hassle involved in using and switching languages. Still, if you want to be totally in 
control when using various languages, Mellel offers this option too.

How language switching works
When you try to use a certain language, every application looks for the characters 
you’ve entered in the currently used font. In most cases, it finds the character in 
the font and displays it in the text. The trouble begins when it cannot find the 
character you typed in that font.
The usual solutions to this problem are either not to display the text at all (show 
“squares”) or to switch to a different font either explicitly or discreetly. Mellel takes
a different route here by switching to an available font, but also allowing you to 
mark such cases of substitution easily, if you want to enjoy style and font 
consistency throughout your document.

Font substitution
Mellel offers the option to view any case where the original font was substituted 
by marking it with a special background colour. This special marking option can 
be activated from the preferences.

To activate highlighting font substitutions:
1 Choose Mellel (menu) > Preferences. 
2 Under the Typography section ( ), check the option Highlight Font substitutions.

Once you activate the Highlight Font substitutions option, Mellel will highlight with 
a special background colour cases where a substitution font was used. 
For example, let’s say you’ve entered some text using the default character style, 
and then switch to a language which is not supported in the default font. The 
result may look something like the following:
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Figure 236: Highlight font substitutions

Once you select the highlighted text and switch to the desired font, the 
background will disappear:

Figure 237: No background colour

Secondary font
Selecting and switching fonts manually is fine, but very tiresome if you need to 
switch between languages and fonts very often. In addition, you might prefer to 
use one font with a certain language and a completely different font with a 
different language. This is where the secondary font option comes to the rescue. 

To use the Secondary font option:
1 Create a new document, and type some text (preferably using the two languages 

you want to use in the text). 
2 Select the text and open both the Character palette. 
3 Set your preferred font, font face, and size for the main language to be used in the

text via the Attributes tab. 
4 Click the More tab and set your preferred font, font face, and relative size for the 

secondary language to be used in the text. 
5 Still in the More tab, select the language script for the secondary font from the 

Script pop-up menu. 
6 Optional: If you want the settings you’ve created to be useable with other 

documents, you will need to save the changes to the character style. To do that, 
click the Styles tab of the Character palette and then click the Save Changes button. 
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Using the example above, here’s how a setting for writing in a Roman script 
(English, French, German, etc.) as the main language and Japanese as the 
secondary language in a text:

Figure 238: Setting the main and secondary font

As you can see in the example, the secondary font setting can differ from those of 
the main font. For example, to use a bold face instead of a regular face, and to 
change the font size relative to the main font. 

Writing in Chinese, Japanese, and Korean
Mellel fully supports writing in CJK languages (Chinese, Japanese, and Korean), 
either exclusively or mixing Roman, Cyrillic, and different languages. Mellel fully 
supports the kinsoku line breaking rules that are useful to avoid having some 
characters appear at the beginning or the end of a line. 

To start writing in a CJK language: 
1 Position the insertion point in the text where you want the CJK text to appear. 
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2 Switch to a suitable keyboard layout or input method.
3 Enter the text. 

Mixing CJK and other languages
Mellel offers superior support for mixing text in CJK languages and other 
languages. This support typically manifests itself in two important cases: 
Spacing text and justifying text.
Mellel spaces text in CJK languages differently than it spaces text in Roman 
languages. For example, this is how mixed CJK and Roman text is usually spaced 
with most applications:

Figure 239: Spacing with most applications

As you can see, in this Katakana and Roman mix Roman characters are spaced as if
they were in Japanese, which may be confusing, since added spacing is 
sometimes used in Roman text as a means of emphasis, and, at any rate, 
unpleasant to read. 
Mellel, on the other hand, spaces the text differently, as you can see in the 
following example:

Figure 240: Spacing in Mellel
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The result here is more palatable and only the Katakana gains the extra spacing. 
The situation becomes even more difficult when dealing with Roman text with 
spaces between the words. This is the result you’ll get with most applications 
here:

Figure 241: Spacing with most applications with spaces

As you can see, when there is a space in a line of text, most applications ‘abandon’ 
spacing between characters and spaces the justified line by using the inter-word 
spacing. The result is not very pleasant and quite confusing.
With Mellel, on the other hand:

Figure 242: Spacing in Mellel with space between words

As you can see, the ‘burden’ of spacing is “shared” between the Roman and 
Japanese text, so there are no ‘holes’ in the middle of the line. 
Yet another difference between Mellel and some applications (especially those 
that use Apple’s text engine) manifests itself when you have a punctuation mark 
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or similar marks at the end of the line. This is how such text appears in most 
applications:

Figure 243: Comma at the end

As you can see, the comma at the end of the second line also gains spacing after 
the word, which makes the text look unjustified. This how the text appears in 
Mellel:

Figure 244: Comma at the end in Mellel

The text will look quite ugly with both methods, of course, but here you can see 
that Mellel avoids the pitfall of adding space after the comma, so the text 
maintains its justified appearance. 

Writing in Greek
Mellel fully supports writing in Greek, and provides support for a secondary font 
using a the Greek script. Other aspects of writing in Greek are identical in function
and application to those discussed earlier in this chapter. In addition to those 
options, Mellel also offers an option to number pages, notes, lists, auto-titles, 
outline items, and so on using Greek numerals. 
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Writing in Cyrillic languages
Mellel fully supports writing in Cyrillic languages (such as Russian or Bulgarian) 
and provides support for a secondary font using a Cyrillic script. Other aspects of 
writing in Cyrillic languages are identical in function and application to those 
discussed earlier in this chapter. 

Writing in Arabic and Persian
Mellel is the first and only Mac OS X native application to fully support writing 
Arabic and Persian. Mellel offers both excellent internal support for text written 
from right to left, and additional features designed especially for writing in Arabic 
and Persian.

Arabic and Persian options
The Arabic and Persian support includes, among others, the following features:

• Right-to-left and left-to-right paragraph direction: rulers, tabs, and every other
element changes depending on the writing direction.

• Support for secondary or main fonts in Arabic and Persian: enables you to 
create character styles with separate fonts, font faces, and sizes for Roman (or 
other script) and Arabic or Persian.

• Kashida support for full justification of Arabic and Persian texts.

• Full support for diacritical marks and ligatures.

• Support for OpenType fonts and special ligatures, justification alternates, 
swash ligatures and contextual alternates. 

• Unicode bidirectional support, with special enhancements especially for 
writing in Arabic and Persian.

• Relative font size for Arabic, Persian, and Roman fonts: enables you to adjust 
inherent font size differences between scripts.

• Support for Arabic and Persian fonts.

• File names, style names, etc. in Arabic and Persian.

• Arabic and Persian numbering schemes for numbers, headers, notes, etc.

• Import and export of Arabic and Persian as plain text and RTF.

• Import and export support for Arabic and Persian.

• Dynamic ruler, tab, and alignment: all paragraph elements are adjusted when 
you change the paragraph direction.
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• (Expert) Special Direction control per character.

• (Expert) Special Direction breaking space.

Special features for writing in Arabic and Persian
Most aspects of writing in Arabic and Persian are identical in function and 
application to those discussed earlier in this chapter. In addition to those options, 
Mellel also offers an option to number pages, notes, lists, auto-titles, outline 
items, and so on using Arabic-Indic or Persian numerals. 
There are several aspects unique to writing in Arabic and Persian, which will be 
discussed below. 

Paragraph direction
Paragraph styles in Mellel are bidirectional. The directionality option is not part of 
the paragraph style itself and can be set differently for the same style in different 
parts of a document. In other words, any style can be used in the same document 
for writing from left to right, and from right to left. 

To change the paragraph direction for a paragraph: 
• Click the Paragraph direction button in the toolbar or in the Paragraph palette. To 

properly write from right to left, the paragraph direction tool should look like this:

Controlling directionality
Mellel offers you some options to control directionality and how text will appear 
and behave with bidirectional text. 

Direction
The direction option in the Character palette, under the More tab allows you to 
emulate the insertion of directional embedding around the style. That is, it allows 
you to insert text with a directionality different than the one used in the 
paragraph. 

Direction Breaking Space
This option, available via Insert > Breaks > Direction Breaking Space or by pressing 
Control + Space keyboard combination will insert a direction breaking space at 
the insertion point. 
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Kashida
Kashida is a unique system of justification used in Arabic and Arabic languages. 
Using Kashida you can justify text (full justification) by lengthening the horizontal 
“base” line of characters while the spacing between words remains unaltered. For 
example, the following text is justified without using Kashida:

Figure 245: Text justified without using Kashida

In the above example, the spacing between the characters is expanded to justify 
the text correctly, but the result is quite ugly and breaks with the traditional way 
of justifying Arabic texts. 
The same text using Kashida will look like the following:

Figure 246: Text justified using Kashida

Using Kashida, the spacing remains unaltered (i.e., the spacing between words is 
not extended), but certain Arabic letters are extended (widened) using a special 
character called “tatweel” to provide a nice effect of an evenly justified text. You 
don’t have to use Kashida with all the text you want to justify, of course. Often, a 
better effect can be created by using Kashida only with some of the words. 
Another way to apply justification that can be even more elegant is by using 
OpenType options like “Justification Alternates.”
The Kashida option is available via the Character palette More tab. The option is 
part of the character style, and is turned on by default. When a text contains 
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Arabic, Kashida will be applied automatically. If your text contains mainly non-
Arabic text, with Arabic words spread here and there, you might want to turn off 
this option. 
You can also turn Kashida on and off for some segments of the text to create 
some nice effects. For example, if you turn Kashida off for all the text in the line 
except the last word, this word will stretch very nicely to compensate for the lack 
of Kashida with the other words.

To turn Kashida on or off:
• Check or uncheck Kashida under the More tab at the Character palette. 

OpenType support
Mellel is the only Mac OS X word processor to support writing in Arabic and 
Persian. With a proper OpenType font for Arabic, you can easily access all the 
spacial ligatures for Arabic and, in addition, access options such as special forms 
and justification. The support with OpenType for Arabic specific options far 
exceeds, at this point, any similar support offered by Mac OS X. 

Writing in Hebrew
Mellel is the only Mac OS X native application that offers the option to type 
Hebrew correctly. Mellel offers excellent internal support for text written from 
right to left and additional features designed especially for writing in Hebrew.

Hebrew options
The Hebrew support includes, among others:

• Right-to-left and left-to-right paragraph direction: the rulers, tabs, and every 
other element changes depending on the paragraph direction.

• Support for secondary or main font in Hebrew: enables you to create 
character styles with separate fonts, font faces, and sizes for any script and 
Hebrew.

• Full support for diacritical marks, niqud, and ligatures.

• Unicode bidirectional support.

• Improvements to Unicode bidirectional support. These include special 
attention to cases specific to Hebrew.

• Relative font size for Hebrew and Roman fonts: enables you to adjust inherent 
font size differences between scripts.
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• Support for Hebrew fonts.

• Support for special Hebrew characters (Insert menu).

• File names, style names, etc. in Hebrew.

• Hebrew numbering schemes.

• Import and export of Hebrew as plain text and RTF.

• Special import options for Hebrew (for example, correct import of numbers 
entered in ‘reverse’ under Mac OS 9).

• Dynamic ruler, tab, and alignment: all paragraph elements are adjusted when 
you change the paragraph direction.

• (Expert ) Special Direction control per character.

• (Expert ) Special Direction breaking space.

Hebrew support
Most aspects of writing in Hebrew are identical in function and application to 
those discussed earlier in this chapter. In addition to those options, Mellel also 
offers an option to number pages, notes, lists, auto-titles, outline items, and so on 
using Hebrew numerals. 
There are several aspects unique to writing in Hebrew, which will be discussed 
below. 

Paragraph direction
Paragraph styles in Mellel are bidirectional. The directionality option is not part of 
the paragraph style itself and can be set differently for the same style in different 
parts of a document. In other words, any style can be used in the same document 
for writing from left to right, and from right to left. 

To change the paragraph direction for a paragraph: 
• Click the Paragraph direction button in the toolbar or in the Paragraph palette. To 

properly write from right to left, the paragraph direction tool should look like this:

Controlling directionality
Mellel offers you some options to control directionality and how text will appear 
and behave with bidirectional text. 
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Direction
The direction option in the Character palette (under the More tab) allows you to 
emulate the insertion of directional embedding around the style. That is, it allows 
you to insert text with a directionality different than the one used in the 
paragraph. 

Direction Breaking Space
This option, available via Insert > Breaks > Direction Breaking Space or by pressing 
Control + Space keyboard combination will insert a direction breaking space at 
the insertion point. 

Typing in Hebrew
It is sometimes very difficult to remember where each Hebrew letter is. To help 
you locate a letter or a vowel mark, you can use the Keyboard Viewer. 

To use the Keyboard Viewer to type in Hebrew:
1 From the Input menu choose Keyboard Viewer. The Keyboard Viewer will open. 
2 Locate the desired letter in the Keyboard Viewer and enter it. 

If you do not want to use the Keyboard viewer, you can use the following keyboard 
layouts—Hebrew and Hebrew QWERTY—as reference:
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Figure 247: Regular keyboard layout for Hebrew
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Figure 248: Hebrew QWERTY keyboard layout for Hebrew

Entering Vowel Marks (Niqud)
Mellel makes it very easy to enter the Hebrew vowel marks (called “Niqud” in 
Hebrew).

To enter a vowel mark (Niqud):
1 Enter the letter and then press the keyboard combination to enter the vowel 

mark. 
The following table and figures will help you enter vowel marks easily. 

Table 25: Entering vowel marks in Hebrew
Character Vowel Keystroke with Hebrew 

keyboard
Keystroke with Hebrew 
QWERTY

אֲ Chataf-Patach Option+1 Option+1

אֳ Chataf-Qamatz Option+2 Option+2

אֱ Chataf-Segol Option+3 Option+3

אִ Chiriq Option+4 Option+4

אֵ Tsereh Option+5 Option+5

אַ Patach Option+6 Option+6
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אָ Kamatz Option+7 Option+7

אֻ Kubutz Option+8 Option+8

אֶ Segol Option+9 Option+9

אְ Shvah Option+0 Option+0

וּ Shuruk Option+u Option+u

אֹ Cholam-Chaser Option and + Option+o

וֹ Cholam-Maleh Shift+u Shift+o

שׁ Shin Shift+a Option+s

שׂ Sin Option+a Option+w

תּ Dagesh Letter, then Option+< Letter, then Option+>

Pressing the Option key
Pressing the Option key, you can enter many vowel marks. 
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Figure 249: Regular keyboard layout with the Option key pressed
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Figure 250: Hebrew QWERTY keyboard layout with the Option key pressed

Pressing the shift key
Pressing the Shift key, you can enter several important letters.
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Figure 251: Regular keyboard layout with the Shift key pressed
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Figure 252: Hebrew QWERTY keyboard layout with the Shift key pressed

Pressing the shift key
Pressing the Shift key, you can enter several important letters.
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Figure 253: Regular keyboard layout with the Shift key pressed
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Figure 254: Hebrew QWERTY keyboard layout with the Shift key pressed

Entering trope marks
Mellel supports entry and correct positioning of trope marks (Te’amim) in 
Hebrew. To make full use of this option, you’ll need to use an OpenType font 
(several free ones are offered on our site) and use the Character Palette or a special 
keyboard layout for entry of vowel marks. 

To enter trope marks:
1 From the Input (flag) menu choose Show Character palette.
2 The character palette will appear. Move to the Hebrew code table in the character

palette. 
3 Enter letters and vowel marks and then double-click a trope mark in the Character

palette to add it.

Note: In almost all cases, the correct entry order is: letter, then vowel mark, then trope mark. 
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Enter the letterAdd the vowel markAdd the trope markFinal result

Figure 255: Correct order of entry for trope marks

Using Hebrew fonts
The text coding system in OS X is based on Unicode (see The Unicode 
Organisation site http://www.unicode.org/ and explanations about Unicode 
below). The following table shows which fonts will function properly with Mellel 
and which will not:

Table 26: Fonts in Hebrew with Mellel
Font Type Usable in Mellel Where Can I find it?

Regular OS 7-8 Hebrew Type 1 fonts ✔ Various distributors

Regular OS 7-8 Hebrew TrueType fonts ✔
Various distributors; Older 
language kits

OpenType fonts such as SBL Hebrew, Cardo or 
Ezra SIL ✔ Internet

Roman fonts with Hebrew Letters* ✖ Various vendors

Lucida Grande (Default font on Mac OS X) ✔ Installed with Jaguar or later

Arial Hebrew, Raanana Hebrew, Peninim Hebrew, 
Corsiba Hebrew ✔ OS 9 Language Kit

WorldFont Hebrew fonts ✔ Adobe product installations

Windows PC fonts ✔ See our site for more info.

“Internet fonts” such as Ariela, Nave, etc. ✖ Various sites, including iDigital

Special free fonts such as Titus Cyberbit. ✔ Internet
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• Regular Roman fonts with Hebrew letters instead of regular Roman characters. The 
fonts may be used with Mellel, but they will behave like Roman fonts; that is, they will 
print from left to right.

Fortunately, the Windows OS also uses Unicode as its standard character 
encoding system. Because of that, many modern PC fonts can be used with Mellel
and OS X without any modification. Just put them into the Fonts folder inside 
your user directionry/Library/ and you are done.
Those fonts have several limitations: First, most of the free Hebrew fonts for 
Windows are of a quality that leaves a lot to be desired. Second, most of the fonts 
do not include Nikud. Worse, even when there is Nikud, it cannot be used.
That remembered, there’s a hefty number of free Hebrew fonts around the 
Internet. A comprehensive list of those is available at our web site font download 
section at: http://www.redlers.com/downloadfont.html.

Writing in Syriac
Mellel is the only Mac OS X native application that offers the option to write in 
Syriac correctly. Mellel offers excellent internal support for text written from right 
to left and additional features designed especially for writing in Syriac. Most of 
the details regarding writing in Syriac are discussed with regards to writing in 
Arabic and Persian above.
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Export and Import
This chapter contains details about exporting from Mellel and 
importing into Mellel

Should I read this chapter?
You should read this chapter if you intend to export Mellel document to 
other document formats, or to import text and documents from other 
sources into Mellel

Stuff you can do
To... Do this Keyboard Shortcut

Export a file from 
Mellel as Plain text

1 Choose File > Export > Plain Text... 
2 Select, check or uncheck the export options and 

then OK. 

Cmd+Shift+R

Export a file from 
Mellel as RTF

1 Choose File > Export > RTF... 
2 Check or uncheck the Export Markers option and 

then OK. 

Export a file from 
Mellel as Word format

1 Choose File > Export > Word Format... 
2 Check or uncheck the Export Markers option and 

then OK. 

Export a file from 
Mellel as OPML

1 Choose File > Export > OPML... 
2 Check or uncheck the Export Content as Notes option

and then OK. 

Export a file from 
Mellel as PDF

Do any of the following:
• Choose File > Export > PDF..., check or uncheck the 

Print Markers option and then OK. 
• Choose File > Print... and choose an option from the 

PDF button-menu (note that Mellel‘s option Print 
markers is under the Mellel pop-up menu item in 
the Print sheet).



Import a plain text 
document by drag and
drop

1 Choose Mellel (menu) > Preferences.... under the Open 
& Save tab, select the Default Plain Text Encoding for 
opening files by drag and drop. Your selection will 
now become the default encoding for opening 
such files.

2 Drag and drop the document(s) you wish to open 
onto Mellel’s application icon in the Finder or the 
Dock. 

Note: Mellel will recognise plain text documents as such 
only if they have the filename extension “.txt” (without the 
quotation marks). A filename may have an “extension” at 
the end—a dot followed by several letters—that identifies 
the file’s type. Extensions are usually hidden in Mac OS X. 
Whether extensions are set to visible or hidden, changing 
the name will not change its extension. To change the 
extension, select just the extension and type “.txt” (without 
the quotation marks). This will cause the file to open by 
dragging and dropping on Mellel’s icon.

Open a plain text file 
from within Mellel

Do any of the following:
• Choose File > Open... and navigate to the file you 

want to open. Or,
• Choose File > Import > Plain Text... When you select 

this method, the Import dialogue box allows you to 
select text encoding.

Set Mellel as default 
for opening plain text 
files

1 At the Finder, locate a file with a .txt filename 
extension. 

2 Select the file and choose File > Get info...
3 With the Open With pop-up menu, select Mellel and

click Change All...
4 Click OK to apply the changes globally. 

Open plain text files in 
Mellel by double-
clicking them (when 
Mellel is the default for
opening Plain text 
files)

• At the Finder, locate a file with a .txt filename 
extension and double-click it.

Import an RTF file by 
drag-and-drop

• Drag and drop the desired file on Mellel’s 
application icon. Mellel will try to detect the source
encoding automatically.

Note: Mellel may display the RTF font matching panel. 
For details about this option, see Here.

Import an RTF file from
within Mellel

Do any of the following:
• Choose File > Open... and Navigate to the file you 

want to open. Or,
• From within Mellel, select File > Import > RTF..., 

check, uncheck and select the desired options and 
then OK. 

Note: Mellel may display the RTF font matching panel. 
For details about this option, see Here.
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Set Mellel as default 
for opening RTF files

1 At the Finder, locate a file with a .txt filename 
extension. 

2 Select the file and choose File > Get info...
3 With the Open With pop-up menu, select Mellel and

click Change All...
4 Click OK to apply the changes globally. 

Open RTF files in Mellel
by double-clicking 
them (when Mellel is 
the default for opening
RTF files)

• At the Finder, locate a file with a .rtf filename 
extension and double-click it.

Note: Mellel may display the RTF font matching panel. 
For details about this option, see Here.

Import a Word file by 
drag-and-drop

• Drag and drop the desired file on Mellel’s 
application icon. Mellel will try to detect the source
encoding automatically.

Note: Mellel may display the RTF font matching panel. 
For details about this option, see Here.

Import a Word file 
from within Mellel

Do any of the following:
• Choose File > Open... and Navigate to the file you 

want to open. Or,
• From within Mellel, select File > Import > Word 

format... and OK. 
Note: Mellel may display the RTF font matching panel. 
For details about this option, see Here.

Set Mellel as default 
for opening Word files

1 At the Finder, locate a file with a .rtf filename 
extension. 

2 Select the file and choose File > Get info...
3 With the Open With pop-up menu, select Mellel and

click Change All...
4 Click OK to apply the changes globally. 

Open Word files in 
Mellel by double-
clicking them (when 
Mellel is the default for
opening Word files)

• At the Finder, locate a file with a .doc filename 
extension and double-click it.

Note: Mellel may display the RTF font matching panel. 
For details about this option, see Here.

Import an OPML file by
drag-and-drop

• Drag and drop the desired file on Mellel’s 
application icon.

Import an OPML file 
from within Mellel

Do any of the following:
• Choose File > Open... and Navigate to the file you 

want to open. Or,
• From within Mellel, select File > Import > OPML... and

OK. 

Set Mellel as default 
for opening OPML files

1 At the Finder, locate a file with a .opml filename 
extension. 

2 Select the file and choose File > Get info...
3 With the Open With pop-up menu, select Mellel and

click Change All...
4 Click OK to apply the changes globally. 
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Open OPML files in 
Mellel by double-
clicking them (when 
Mellel is the default for
opening OPML files)

• At the Finder, locate a file with a .doc filename 
extension and double-click it.

Exporting from Mellel
Export as Plain text
Exports the file to as plain text, without styling. There are several options to 
choose here. 

• Encoding: Choose from any of 30 different plain text encoding. 

• Default replacement character: If the selected encoding is not Unicode or 
UTF-8, some characters may not be available for exporting and must be 
replaced. Mellel allows you to select a special character to replace such non-
convertible characters. 

• Export Notes: when checked, Mellel will export all the notes in the document
in their current stream order. It will insert an asterisk both before and after a 
note reference for the first stream and will do the same for the note symbol at 
the end of the document. The second stream will get two asterisks before and 
after the note reference and the note symbol, and so on.

Export as RTF
When exporting a file to RTF Mellel export your file in the RTF standard, created 
and maintained by Microsoft™ Corporation. Mellel supports a wide range of RTF 
tags, covering most of the essential features supported by the standard, including
character, paragraph and page attributes, tables, headers and footers, footnotes 
and endnotes, images, columns and sections. 

• Export Markers: This option in the Export sheet allows you to choose whether
to export the markers in the text or not. 

Export as Doc format (Word format)
When exporting a file to Word format Mellel export your file in the RTF standard, 
created and maintained by Microsoft™ Corporation, using the ”.doc“ filename 
extension. The features supported with this type of export are the same as with 
exporting to RTF. 
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• Export Markers: This option in the Export sheet allows you to choose whether
to export the markers in the text or not. 

Export as OPML
OPML (short for Outline Processor Markup Language) is an XML format for 
Outliners. Exporting files to OPML will result in an XML file that is readable to all 
outliners. The headings in the text (i.e., the auto-titles) will serve as items in the 
outliner application. 

• Export Content as Notes: this option allows you to export the text under the 
various headings as a ’note‘, so the content of the document will be preserved 
in the outliner application. 

Export as PDF
PDF is a standard format (maintained by Adobe™ Corporation) for files which 
preserves the appearance of the text. This option is a short-cut to using the PDF 
option from the Print sheet.

• Print Markers: this option, checked or unchecked, determines whether the 
markers in the text will also appear in the PDF document. 

Importing into Mellel
Mellel offers you several import options, available both from the File menu or by 
simply dragging files over Mellel‘s icon or double-clicking them in the Finder (if 
you’ve set Mellel to be the default option for opening this type of files).

Import Plain text
Mellel allows you to import files as plain text using 30 different encodings. 

• Plain Text Import Options: the Encoding pop-up menu, appearing when you
import via File > Import > Plain Text... allows you to choose the encoding to be 
used when importing the file. 

Note: this option is not available if you import files by drag-and-drop or by double-clicking 
a file. 

Import RTF
Mellel supports a wide range of RTF attributes including character, paragraph and
page attributes, tables, headers and footers, footnotes and endnotes, images, 
columns and sections. 
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There are several RTF options, available when you import via File > Import > RTF....

• Source encoding: Allows you to choose the encoding for the imported file. If 
you do not know how the imported file was encoded, select Auto Detect.

• Font Matching panel: allows you to choose how to match fonts in the 
imported RTF with the fonts you have installed. See more about this option 
Here. 

Import Word files
Mellel offers an option to import MS Word (.doc) files by dragging and dropping 
.doc files over Mellel’s application icon in the Finder, double-clicking .doc files, or 
by opening them from Mellel itself. This support for MS Word .doc files relies on 
the built in support for such files in Mac OS X and is limited in this respect.
The .doc support in Mac OS X 10.3 or later is done in two stages: when a .doc file is
opened by Mellel, it is first converted from .doc format to RTF and then open the 
file. This means that Mellel will display the RTF Font Matching dialogue See more 
about this option Here). The features supported when importing via this option 
are listed in the following table.

Table 27: .doc import options
Option Support for

ansi, mac, pca, Standard encodings of text. Mac encoding is not supported for writing.

b Bold face text

cb, cf Background and foreground colour

colourtbl Colour (of text)

upn, dnn Subscript and subscript position

paperwn, fin, lin, margrn, margln Page width, First-line indent, Left indent, right margin, left margin

fonttbl, fsn, i, Font and font size

par, pard New paragraph, set to default. Supported just for reading

qc, ql, qr Text centred, left aligned, right aligned

sn Paragraph style, supported just for reading

tab Tab placement

Import OPML
OPML (short for Outline Processor Markup Language) is an XML format for 
Outliners. Importing files saved in this format will import the titles as auto-titles 
(headings) in Mellel, with the notes appended as the text below those headings. 
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Important note: when Mellel imports an OPML file, it will use the Auto-title Setup currently 
used in your document. You will need to choose the setup most appropriate for the OPML 
file (or change this after importing).

RTF font matching
Most of the RTF files you import to Mellel probably originated on another 
computer. Mellel can open those files, but because they don’t include the fonts 
used to create them, you are faced with a problem: How do you match the fonts 
used by the creator of the documents with the fonts you have in your system? 
Mellel’s Font Matching panel was designed to solve this problem. When you import 
an RTF document into Mellel, this special panel may pop up (depending on your 
Preference settings) and display a list of all the fonts used in the imported 
document. You can then match the original fonts with the best possible 
alternative you have available. 

Figure 256: The RTF font matching panel

The RTF font matching panel includes two important areas: the font and font 
matching list; and the font options area.
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• The font list: the left side of the panel displays a list of all the fonts used in the
RTF document (left) and a list of suggested replacement fonts drawn from the 
fonts available in your computer. The fonts in the list belong to three types:
1 Fonts you’ve matched: If you’ve already marked some font matches as 

the default, Mellel will not interfere and simply mark them with boldface.
2 Fonts matched algorithmically: If Mellel can find a probable match using

its ingenious algorithm, it will display those matches in regular face. Those 
matches are usually correct, but you should browse them briefly.

3 Fonts matched by type: If Mellel cannot figure out to which font it can 
mach the original font, it uses the information within the font to match it 
by general categories such as Roman, Swiss (sans-serif ), decor, and so on. 
Such font matches are displayed in RED. Review those very carefully, at 
least with the first few import actions.

• Font options: Here you can select the font and font face to change the 
suggested matching and even save the replacement as the default match for 
a certain font. 
1 Font: displays the replacement font currently used. You can change the 

replacement font at any point by selecting a match and then selecting a 
font from the Font pop-up menu.

2 Face: displays the replacement font face currently used. You can change 
the replacement font face at any point by selecting a match and then 
selecting a font face from the Face pop-up menu.

3 Make default: When you check this check-box the match is saved into a 
special font matching file.

To change the replacement font:
1 Select the RTF font name for which you wish to change the replacement font.
2 Select a different font and/or font face from the Font and Face pop-up menu.

To save the match as the default match:
1 Select the RTF font name for which you wish to change the replacement font.
2 Select a font and/or font face from the Font and Face pop-up menu.
3 Check the Make default check-box. 

To delete a default match:
1 Select the RTF font name for which you wish to change the replacement font.
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2 Uncheck the Make default check-box. You can uncheck the Make default check-box 
and delete the match at any time. 

When to show the RTF font matching panel 
The RTF Font Matching panel does not have to pop-up every time you import an 
RTF document. The display of this panel can easily be controlled to achieve the 
best result.
There are three options for displaying the RTF font matching panel:
1 Don’t show: Mellel will match as best as it can, but will never show the RTF 

font matching panel. 
2 Show if needed: Mellel will match as best as it can and will display the panel 

only if it is uncertain about some of the matches.
3 Always show: Mellel will display the panel even if it is absolutely sure that all 

the matches are correct.

To set the default for displaying the RTF font matching panel:
1 Choose Mellel (menu) > Preferences.... 
2 In the Open & Save tab, select the desired option from the RTF Font Matching 

panel pop-up menu. 

To change the choice for displaying the RTF font matching panel:
1 Choose File > Import > RTF...
2 From the Font Matching panel pop-up menu select the desired option. 

Tips for successful font matching
Mellel does a good job matching fonts used in RTF documents with the fonts you 
have in your computer. That said, with a little effort you can help it do an even 
better job. Following are a several useful tips for successful font matching.

• Think Windows: Most MS Word for Windows documents use a relatively 
limited set of fonts such as Arial, Tahoma, Courier, and Times New Roman. If 
you can create good matches for the basic set of fonts used in Windows, you 
will eliminate most of the font matching problems. For your purposes, there 
are three main types of fonts you have to match: Roman (serif ) fonts such as 
Times; sans serif fonts such as Helvetica, Tahoma, and Arial; and slab serif fonts
such as Courier. 

• Use Windows fonts: If you don’t like matching fonts, why not use the original 
ones? You can download and install the core set of fonts used in Windows and
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have the matches ready without being forced to make matches. Microsoft’s 
core fonts are available here: http://sourceforge.net/project/
showfiles.php?group_id=34153&release_id=105355. 

• Multilingual matching: “International” versions of MS Word use special 
versions of the core fonts such as Courier New CY or Tahoma Greek. Usually, 
although all the language versions of a font are listed, only one of them is 
actually used. If you know what language version the sender uses for the files 
you receive, you can match only that version, leaving the others untouched. 

• Big fonts cover everything: If you don’t like having Mellel replacing missing 
characters with characters from another font try to use one of the “big” 
Unicode fonts out there that will cover most of the Unicode range. 

• Auto-detect solves problems: When importing, it is advisable to let Mellel 
sort encoding issues on its own. That is, use the Auto-Detect option when 
opening files. Many of the problems that appear to be font matching 
problems are usually encoding problems.

Import and Export Tips
There are several common import problems you may face when trying to import 
files created in other applications to Mellel or migrate your files from an word 
processor to Mellel. The following set of tips will help you eliminate those 
problems. 

Using Replace Styles
The Replace Styles feature can be a powerful tool when migrating a large set of files
from your old word processor to Mellel. This option, accessible from the File menu,
allows you to replace a document style with a global style. In other words, it helps 
you replace the temporary paragraph and character styles created in files with the
styles you regularly use. 
If you intend to migrate a large set of your old files to Mellel, doing it in an orderly 
fashion will allow you to use the Replace Styles feature to the full and save yourself 
a lot of time in the process. Following are some handy rules to keep in mind while 
migrating:

• Create a set of styles: The most important part to a good migration path is 
creating a good set of styles that will match the styles you commonly used 
with your old word processor. Those styles will be used later on with Replace 
Styles. If you’re not the planning-ahead type, you don’t have to cover all the 
styles in advance—you can add them as needed. A good basic set will include
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three or four heading styles, two or three body text styles, and some special 
styles for notes, headers, footers, etc. 

• Minimise your font set: While working with your old word processor, you 
probably experimented with different fonts and font faces. This can be a 
problem when using Replace Styles because you will have to replace a lot of 
temporary styles every time you want to migrate a file to Mellel. To prevent 
this, you should utilise the RTF font matching panel to limit the number of fonts
in your imported files. For example, you can match similar fonts such as Times,
Times New Roman, New York, Gramond, Georgia, Gentium, and Palatino with 
a font such as Hoefler Text; or convert Helvetica, Arial, and Tahoma with 
Helvetica Neue, for example. 

Migrating from MS Word
Migrating MS Word files can be done fairly easily and quickly. You should divide 
your existing MS Word files into two sections: simple and complex. With the 
simpler files—for example, files that do not contain footnotes, or endnotes—all 
you’ll need to do is open them in Mellel and save. The files will be saved with their 
old name, but as Mellel files. With the more complex files, you’ll have to save them
first to RTF and then open them in Mellel. 

Migrating from Nisus Writer
You can migrate from Nisus Writer (Classic) following one of two routes: exporting
to RTF from Nisus Writer, or opening Nisus Writer files directly in Mellel.

• Exporting to RTF: This method should work fine in theory. In practice, 
however, it doesn’t work that well, especially when the text includes anything 
other then plain Roman text. 

• Opening from Mellel: Nisus Writer files are plain text files with a separate 
resource fork containing the styles. This means that you can open those files 
directly in Mellel as you would any other plain text files. All the styling is lost, 
of course, but the text is kept intact. 

Migrating from TextEdit and other editors
TextEdit and similar text editors (e.g., Nisus Writer Pro), as well as many other word
processors, save their files in RTF format or offer this option as an equivalent 
(native) format. Open such files as you would any RTF file. 
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Other import and export options
There are several other important applications that you might need to import files
from or export files to. Following are several examples to solve common import 
and export problems with such files.

Export and import—spreadsheet applications
Importing and exporting from and to spreadsheet applications is very simple and 
straightforward. 

To import from MS Excel and other spreadsheets applications:
1 Open the spreadsheet application and save the file as a tab-delimited text file. 
2 Open the file in Mellel.
3 Select the text and choose Edit > Convert text to table. 

To export to MS Excel and other spreadsheets applications:
1 Select the text in a table in Mellel and choose Edit > Copy. 
2 Move to the spreadsheet application and paste the text. 

Export and import—graphic applications
Importing and exporting from and to graphic applications is usually very simple. 
There are, however, some noted exceptions and workarounds with some 
applications.

To Export text to vector drawing applications:
1 Export the text as plain text with the suitable encoding.
2 Import the text back into the drawing application.

To Export text into a layout application:
Do one of the following:

• Export the text as plain text and then import it back into the layout application. 
Or,

• If the layout application is Unicode compliant, try using copy and paste.

To import text from a graphics or layout application:
Use one of the following methods:

• From within the graphics or layout application copy the text into the clipboard, 
move to Mellel, and paste it. If you want to copy a graphic element or part of it, 
simply copy it into the clipboard. Or,
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• Export from the graphics or layout application as plain text or RTF or save as PDF 
(as appropriate), and then open in Mellel or drag and drop into Mellel.

Copyright Notice: Windows, Microsoft, MS Excel, Adobe, Nisus, and Nisus Writer are all 
trademarks or registered trademarks of their respective owners in the United States and/
or elsewhere.
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Markers
This chapter explain what markers are and how to use them

Should I read this chapter?
You should read this chapter if you intend to mark your text (colour 
marking)

What are markers
Markers allow you to mark text or a note in your documents, similar to a real-life 
felt-tip marker. Markers are not part of the regular character attributes of text, nor 
are they an override. To use text highlighting as a character attribute, use the Fill & 
Highlighting feature in the Character palette to create a background to the text.

Stuff you can do
To... Do this Keyboard Shortcut

Mark text 1 Select text, and do one of the following:
• Press the Apply button in the Markers palette. Or,
• Double-click a marker in the Markers palette. 
• Ctl-Click (right mouse button) to open the 

contextual menu and choose a Marker. Or,
• Choose Edit > Marker > any marker. Use any of the 

methods described for activating line 
numbering to choose None from the Line 
Numbering pop-up menu.

Cmd+Ctrl+0... 8

Discard a marker 1 Select marked text.
2 Select None using any of the methods for applying 

a marker.

Discard (delete) all 
markers

1 Select all the text in the document.
2 Select None using any of the methods for applying 

or changing a marker.

Change marker names 
for the current 
document

1 Choose File > Document Info... and click the Markers 
tab. 

2 Double-click a marker and change its name. 

Change marker names 
for all new documents

1 Choose Mellel (menu) > Preferences.... 
2 Under the Document Setup tab double-click a 

marker and change its name. 

Find the next or 
previous marked text 
in a document

• Click the Find Next/Previous marked text button in the
Markers palette.
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Find the next or 
previous marked text 
with a specific marker

• To find the Next marked text, press the Cmd key, 
and Double-click the marker in the Markers list.

• To find the Previous marked text, press the 
Cmd+Option keys, and Double-click the marker in 
the Markers list.

Note: You can also use the Find and Replace dialogue box 
to find marked text.

Cmd+Double-click or 
Cmd+Option+Double 
click

Print a document with 
or without markers

1 Choose File > Print... 
2 From the Print drop-sheet pop-up menu choose 

Mellel and check or uncheck the option Print 
Markers. 

Export a document 
with or without 
markers

1 Choose File > Export > Word format or RTF... 
2 Check or uncheck the option Export Markers. 

The Markers palette
The Markers palette allows you to easily apply, change, track down and change 
markers.

Search 
marked text Markers list

The marker 
applied to 

selected text

Apply 
selected 
marker

Markers
Palette
Icon

Figure 257: The Markers palette

Markers387



Using markers
It is very easy to mark and unmark text using the Markers palette. If a selected text 
is marked, Mellel will indicate this with a checkmark next to the marker in the 
Markers list.

Changing marker names
The marker names in the Markers palette are just a starting point, and you can 
change them for all new documents via Mellel’s Preferences, or set them for the 
document you’re working with via File > Document Info.... 

Finding marked text
Having text marked in a document is a fine thing, but it isn’t of much use if you 
cannot easily locate marked text. The Find Next marked text option in the Markers 
palette will make this very easy. 

Printing and exporting markers
You can print and export markers (or set Mellel to avoid printing or exporting 
markers via the Print or Export features. 
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Date and Time
This chapter explain how to enter date and time stamps

Should I read this chapter?
You should read this chapter if you intend to insert date and time stamps

What is a Date and Time stamp
The Date and Time feature in Mellel allows you to insert a date or time stamp in a 
document. 
There are three types of date and time stamps available: 

• Document creation date: This variable stamp will insert the date or time 
when the document was first created.

• Document opening date: This variable stamp will insert the date or time 
when the document was last opened. This stamp will automatically update if 
you open the document at a later date.

• Current date (text): This stamp will insert a text string with the date or time 
of entry. This text will not change or update automatically. 

There are three types of date and time formats—Long Date, Short Date, and Time. 
The specific format depends on the settings you have under System Preferences > 
Language and Text > Formats.

Stuff you can do
To... Do this Keyboard Shortcut

Enter a date or time 
stamp

1 Place the insertion point in the document.
2 Choose Insert > Date...
3 Select a Date and Time type (the default would be 

your last selected option).
4 Select a format from the pop-up menu. (The 

default would be your last selected option), and 
press the Insert button.



Change the date or 
time format

1 Open the System Preferences and open the Language
and Text panel.

2 In the Language and Text panel, click the Formats 
tab.

3 Do one of the following:
• Select a region from the Region pop-up menu.
• Press Customise... and customise the date or time 

format.
• Select a region from the Region pop-up menu 

and then press Customise... and customise the 
date or time format.

Note: With Document creation date and Document 
opening date, Mellel will always use the currently available 
date and time format in the Language and Text panel. If 
you do not want the date or time stamp to change, use the
Current date (text) stamp instead.

Example: Creating a Date and Time Stamp
Date and time stamps in Mellel can be inserted as either a variable or as a simple 
text string. A text time stamp doesn’t change dynamically and is more suited to 
situations where you want the stamp to remain as it was inserted.
A variable stamps is a vary useful in a header or a footer, especially in conjunction 
with document variables. 
A good example of a more sophisticated use of variable stamps would be 
inserting a ‘control line’ in a page style’s header. In the short example below you’ll 
learn how to do that.
1 Open a new document and open the Page palette.
2 Check the option Header (if it isn’t checked already). The header should now 

be displayed with a light grey box around it. (If it isn’t, open the Show button 
pop-down menu in the toolbar and select the option Header/Footer frames.)

3 Enter editing the header by clicking in it. If it contains any content, delete it 
and align the paragraph to the left by clicking the Align Left button in the 
toolbar. 

4 Choose Mellel > Preferences... and in the Document Setup section change the 
label for two of the variables to Author and Department, and the Default Value 
to <Author> and <Department> respectively. (Enter your name or 
department as the Default Value only if you want them to be the default value 
with all new documents from now on.) Close the Preferences window.

5 Choose File > Document Info... and under the Document Info tab, in the Variable 
section, enter your name and the name of your department as the value. 
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When you enter your name and department here, they become variables that 
are attached to this document only. Click Save.

6 Back in the Header, enter the following text:
Creation Date: Time: 
Modification Date: Time: 
Author: 
Department: 
Your header should look something like the following:

Figure 258: The raw header

7 Place the insertion point right after the text “Creation Date: ” and choose 
Insert > Date... Select Document creation date as Type and Long Date as Format. 
Press Insert. The date stamp may appear in bold face, as it assumes the 
surrounding character style. Change this by selecting the date stamp and 
selecting a different character style or variation.

8 Repeat the same process for “Time: ”, using Time as the format. The result 
should look like this:

Figure 259: And after adding some of the data

9 Repeat the same process for “Modification Date:” and “ Time:” with Document 
opening date as Type.

10 Place the insertion point right after the text “Author: ” and choose Insert > 
Document Variables > Author. Repeat this for “Department: ” choosing Insert > 
Document Variables > Department. 

11 Place the insertion point right after the department’s name, press Return to 
create a new paragraph and enter “Page of pages”.

12 Place the insertion point right after “Page ” and choose Insert > Page Variables > 
Page Number. 
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13 Place the insertion point right after “of ” and choose Insert > Page Variables > 
Total Number of Pages. The final result should look like this:

Figure 260: The header: final state
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Replace Styles
This chapter explains what the Replace Styles option is and what it is 
good for

Should I read this chapter?
You should read this chapter if you wish to use some advanced 
streamlining options with styles and imported files

One of the most important tasks in text editing is maintaining a consistent 
appearance and styling of the text throughout the document. Replace Styles is an
option that enables you to replace every styling variation in a document with a 
style or a style variation of your choice. 
The Replace Styles option is fairly straightforward: you select the styling variation 
you want to replace, select the style and the variation you want to replace them 
with, move over to the next replacement, and so on, until you have replaced all 
the styling variations in the document.



Figure 261: The Replace Styles sheet

To open the Replace Styles sheet:
• Choose File > Replace styles... The Replace Styles sheet will open.

Replace Styles sheet
The Replace Styles sheet includes two tabs: Character and Paragraph to allow 
you to replace both character and paragraph styling variations. Each tab contains 
several sections:

• Used Styles: This section lists all the global styles, changed global styles, and 
document styles used in the document. Document styles are marked by a 
diamond shape (◆) before their name. Changed document styles are marked 
by a plus (+) character after their name, with a number indicating the number 
of overrides (changes to the global styles) applied with them.
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• Style Attributes: Lists all the style’s attributes. This list of attributes will be 
especially useful when importing text from another source (for example, 
when importing an RTF file, or after pasting text from another application).

• Overrides: Lists every override (unsaved change) to a global style. Overrides 
are often ad-hoc changes applied to global styles during the writing or 
editing process, and the Override list can give useful clues as to the most 
appropriate style to replace the override with.

• Replace With: Using the pop-up(s) here, you can select any style from the 
global styles list to replace the selected style. With the Character tab, you can 
also select the variation you want. With the Paragraph tab, you can select the 
paragraph direction. 

To see the details of a used style:
• Click on a style's name in the Used Styles list. Full information about the style 

will be displayed to the right, followed (below) by a list of all the overrides the 
style includes (if any). 

To replace a style with another style:
1 Click on a style’s name in the Used Styles list.
2 Select a style and a variation or paragraph direction (depending) to replace it 

with. Once you have selected a replace style, the style to replace will lose its 
bold-face emphasis. 

3 Select other styles to replace. 
4 Repeat steps 2-3 until done.
5 Click OK to apply your changes.

To replace several styles with one style:
1 Select the styles you want to replace in the Used Styles list. You can use Shift +

Click and/or Cmd + Click to extend your selection. 
2 Select a style and a variation or paragraph direction (depending) to replace it 

with. Once you have selected a replace style, the style to replace will lose its 
bold-face emphasis. 

3 Select other styles to replace. You can use Shift + Click and/or Cmd + Click to 
extend your selection.

4 Repeat steps 2-3 until done.
5 Click OK to apply your changes.
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Efficient style replacing
Replace Styles is an extremely powerful option and if used wisely can save hours 
of tedious style editing. Following are some “quick and dirty” rules of thumb to 
help you use this option efficiently right from the start:

• Design first, then replace: Often, it is tempting to start working on a 
document by replacing unwanted styles. This method will probably work just 
fine while replacing the document regular body text with your own body text,
but further on, when you get into the nitty-gritty stuff of titles and special 
styles, you will find yourself stuck in the middle, lacking the proper 
replacement style for some styles. It is better, therefore, to examine the 
document thoroughly and design your styles to cover all possible cases 
before you actually start the replacement process. 

• Use the source: If you plan to use the existing styles in a document (which 
may be the case with a Mellel document received from someone else), try to 
create new styles based on the existing document styles. If you stick with the 
original document style names, the replacement process will become much 
easier. 

• Associated styles: Many Mellel users associate paragraph and character 
styles. If you have created paragraph styles based on existing document 
paragraph styles, make sure that those paragraph styles are associated with 
your own styles, not the document styles, before you start replacing styles. 

• Character styles: Many Mellel users associate paragraph and character styles. 
If you do this, try to replace the character styles first and only then replace the 
paragraph styles. Otherwise, replaced paragraph styles associated with 
character styles will “flatten” your character styles so that they will all be using 
the “base” variation. 
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Word Count (statistics)
This chapter explains what the statistics palettes is used for and how 
to use it

Should I read this chapter?
You should read this chapter if you intend to see how many words or 
characters there are in your documents

The Statistics palette displays some important statistical details about the 
document you are currently working with. The statistics and count updates while 
you write (live update). 
The palette contains three tabs: 
1 General: including the total number of characters, words and paragraphs in 

the document and in a selection, and the total number of lines in the 
document.

In Selection

In total

Figure 262: The General Statistics tab

2 Notes: including the total number of notes in the document, and the total 
number of characters and words in the notes. 

3 More: including the total number of tables, images, citations and auto-titles in
the document. 

In the Preferences, you can refine your control of the character count by setting 
Mellel’s Statistics palette to include in the count or exclude from it counting of 
blank characters (such as space), break characters (e.g., Return or Page Break), and 
punctuation marks (e.g. (,.:?!|).



Important note: Mellel performs real-live count of words in a document. Mellel was optimised
so that displaying this info would not have an effect on performance. Still, with long docu-
ments, the live count might slow the typing performance somewhat. If you notice a slow-
down, close the Statistics palette.

Stuff you can do
To... Do this Keyboard Shortcut

Count words, 
characters, paragraphs,
etc.

1 Choose Window > Palettes > Statistics to display the 
Statistics palette.

Set the preferences for 
word count.

• Choose Mellel (menu) > Preferences....
• Under the General tab, check or uncheck the 

options under Statistics. 
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Keyboard shortcuts
This chapter explains how to create custom keyboard shortcuts

Should I read this chapter?
You should read this chapter if you intend to create custom keyboard 
shortcuts

Keyboard shortcuts are keyboard combinations (pressing several keys on the 
keyboard at the same time) that enable you to perform an action without having 
to use the mouse or make menu selections. 
There are three types of keyboard shortcuts available in Mellel:
1 Set keyboard shortcuts: shortcuts that are set for use in advance. For 

example, pressing the Command key and then the c key will be the equal of 
choosing File > Copy. 

2 Customisable keyboard shortcuts: shortcuts you can select from a given 
variety of shortcuts. For example, you can use the keyboard combination 
Cmd+1–0 (numbers from 1 to 0) to switch between character styles. The 
shortcuts you assign can be allocated and reallocated. Mellel allows you to 
assign a keyboard shortcut to paragraph styles, character styles, and note 
streams

3 Shortcuts assigned through the Keyboard & Mouse System Preference: 
shortcuts to almost any menu option in Mellel. Some examples of elements to
which you can apply shortcuts are detailed below.

To create a customisable keyboard shortcut (paragraph and character 
styles):

1 Open the Edit Style sets dialogue box.
2 Click the Paragraph or Character style to which you wish to apply the shortcut. 
3 Click the menu beside the style or stream and select a shortcut.

To create a customisable keyboard shortcut (Note style):
1 Open the Edit Note Attributes dialogue box.
2 Click the note stream to which you wish to apply the shortcut. 
3 Click the menu beside the style or stream and select a shortcut.

To create a special keyboard shortcut:
1 Run Mellel (if it isn’t already running).



2 Click the System Preferences icon in the Dock.
3 In the System Preferences main panel, select Keyboard & Mouse.
4 In the Keyboard & Mouse System Preference, click the Keyboard Shortcuts tab. 
5 In the list of options, scroll down until you reach the item Application Keyboard 

Shortcuts. 
6 Click to select the item, and click the small + button below.
7 A drop sheet will appear, allowing you to select an application. Select “Mellel” 

from the list and enter the menu title in the Menu Title field. 
8 Click in the Keyboard Shortcut field and press the keyboard combination you want 

to assign to the menu title.

Figure 263: Assigning a keyboard shortcut

10 Click the Add button.
11 Quit Mellel and re-run it, then check to see that the added command exists and 

works. 

What you can and cannot do
The number of keyboard shortcuts you can assign using the Keyboard Shortcut 
tab is almost unlimited. There are, however, limits to what things you can and 
cannot assign a shortcut:
1 You cannot reassign a set keyboard shortcut: That is, you cannot override 

an existing keyboard shortcut with your own. 
2 You can access options only that are in menus: That is, you cannot assign a 

keyboard shortcut to a text field, a stepper, or a button. 
3 You cannot properly assign a shortcut to two menu items with identical 

names: Mellel will always select the first. 
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There is, however, a surprising number of options to which you can assign a 
keyboard shortcut. The following table details some of them.

Table 28: Keyboard shortcuts options
Option How to do it?

Services Use the name of the service or command (if you want to 
use the command with other applications as well, assign
it as an “All Applications” command. 

Unassigned options in menus and sub menus Use the name of the option

Menus in the main document window Use the name of the option

Names of styles, auto-titles, list styles, and so on Use the style name
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Thanks!
We wish to thank the many people who added, asked for removal of parts, 
commented, advised, and corrected errors in this manual.

Special thanks are due to David Collett of Seattle, Washington, who diligently 
and thoroughly reviewed this manual, making many useful and insightful 
comments and corrections. All the grammatical, conceptual, and content errors, 
though, are entirely ours.
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