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 Anime Studio 
Tutorials

In this manual, we will walk you through various aspects 
of using Anime Studio. This is the perfect place to start if 
you’ve never used Anime Studio before. Even if you’re 
an experienced Anime Studio user, this version of Anime 
Studio has some big changes, so we recommend reading 
through the tutorials again.

The best way to get started is to read all the tutorials in the 
Basics section in order. Each of these tutorials builds on skills 
learned in the earlier ones, and one-by-one will get you up 
to speed with Anime Studio’s basic drawing and animation 
techniques. Once you’re comfortable working in Anime 
Studio, then you can move on to the other tutorial sections. 
You don’t have to read them all (although that probably 
wouldn’t hurt), but choose the ones that address the 
specific techniques you want to learn about.

When you first start Anime Studio, you will be 
prompted to create a Custom Content folder 

in a location that you specify. The tutorial files that 
are used in this tutorial manual will get installed in 
that Custom Content folder. You can find them by 
going to your Content folder, and looking for the 
Tutorials sub-folder. If you’re having trouble with a 
tutorial, try opening the corresponding Anime Studio 
file to see what it should look like.

If you did not create a custom content folder 
at startup, you can create one any time by 

choosing Help > Set Custom Content Folder.

Once you’ve finished the tutorials, you should be 
comfortable enough to continue on your own. However, 
the tutorials won’t teach you how to use every feature 
of Anime Studio - the rest of this manual is a reference 
that covers Anime Studio’s features in detail, and is 
recommended reading to be able to use the full power of 
Anime Studio.

Using the Embedded Media Files
This manual features some embedded media files to help 
you learn concepts that are more easily explained in video 
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format. To play the media files, click on the placeholder 
image. The videos will play in a separate window. You can 
close the window at any time by clicking the small X in the 
upper-right corner of the video window.

Please note that recent updates to Adobe Flash may, in 
some cases, display a notification that Acrobat cannot 
connect to the flashserver when you attempt to play the 
media. You can ignore the warning and click OK to display 
the video without issue.

However, if you want to prevent the message from 
occurring each time you play one of the embedded 
media files you can reset your Acrobat preferences as 
follows:

1.	 Open Acrobat, and choose Edit > Preferences.

2.	 Select Trust Manager from the left hand pane.

3.	 Click the Change Settings button under the Internet 
Access from PDF Files Outside the Web Browser section.

4.	 In the Web sites list, select adobe.com and click Delete.

5.	 To re-allow adobe.com, go to the top section of the 
Trust Manager, and choose the Custom Setting option. 
Enter www.adobe.com in the Specify Web Sites to 
Allow or Block field, and then click Allow. The Adobe 

web site will then appear in the trusted sites list, marked 
Always Allow.

6.	 Click OK to set the Preferences, and click OK again to 
exit the Preferences dialog.
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Quick Start

Tutorial 1.1: A Quick Run-through
This tutorial quickly runs through the major features of 
Anime Studio, without going into too much detail. The 
purpose here is more to give an overview of how Anime 
Studio works, rather than to teach you how to use any 
specific features. In this tutorial, we will draw and animate a 
very simple object.

Anime Studio has several groups of tools, used for different 
types of tasks. Some of these tools are used to create 
new objects, and others are used to modify and animate 
existing objects. The basic Anime Studio tool groups are: 
Draw, Fill, Bone, Layer, Camera, and Workspace.

This tutorial introduces a few of the Draw, Fill, and Layer 
tools, while the following tutorials focus specifically on each 
of the tool groups.

Drawing a Simple Shape
Launch Anime Studio by double-clicking the Anime Studio 
icon, or selecting the Anime Studio shortcut in the Start 

menu (Windows). When you create a new Anime Studio 
project, the application starts off looking something like this:

 The Anime Studio Interface

Choose File > New to create a new project, and then click 
the current tool icon (just beneath the File menu), to select 
Reset All Tools. This puts all tools at their default settings so 
that you can follow along with this tutorial.
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 Reset all tools.

Select the Draw Shape tool by clicking on it in the toolbar.

 Draw Shape

Select the Oval shape from the Draw Shape tool options.

 Oval

The Style panel on the right side of the Anime Studio 
interface allows you to select fill and stroke colors for the 
shapes you draw. To select a fill color, click the Fill color 
square to open a color palette, or click one of the color 
squares in the Swatches palette. Select the fill color you 
want to use, and click OK.

 Changing the fill color

Press the Shift and Alt keys while you drag from the center 
of the workspace to create a circle shape. The Shift key 
forces the shape to be a circle, rather than an oval; and 
the Alt key centers the circle around the point that you first 
clicked. Try to keep the circle within the blue rectangle (this 
rectangle represents the visible area of your project). Note 
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that the circle will automatically fill with color when the 
Auto Fill option is checked as shown in the previous figure.

If you’re not happy with your circle, just select the Edit > 
Undo command from the menu bar. Your circle should look 
something like this:

 Your first Anime Studio drawing

Changing the Color of Your Shape
If you want to change the fill color, choose the Paint Bucket 
tool from the Fill toolbar. The Fill option changes only the Fill 
color; the Stroke option changes only the Stroke color; and 
the Both option changes both the Fill and the Stroke color 
to those that you have selected in the Style window.

 Paint Bucket Tool

 Paint Bucket options

Select a new color from the Style panel, similar to the way 
that you selected the color in the previous steps. Then click 
inside the shape to change the color(s).

Simple Animation
When you animate in Anime Studio, you move objects 
around and set up keyframes - points in time at which an 
object has a certain position. At points in time between 
keyframes, Anime Studio automatically computes the 
position of all objects.
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Near the top of the Timeline window is a ruler that displays 
frame numbers in the animation. Click the number 36 to set 
the current time to frame 36.

 The Timeline

Next, choose Edit > Select None from the menu bar.

Pick the Transform Points tool from the toolbar.

 Transform Points

Click and drag the bottom point of the circle upward to 
distort the circle into a shape that looks like this:

 Moving a single point
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Now use the Transform Layer tool from the Layer section of 
the Tools panel to rotate the layer.

 Transform Layer

To rotate the object with the Transform Layer 
tool, click and drag in the area between the 

two bounding boxes that surround your object. 
Rotate the object into a position similar to the one 
below:

 Rotating an entire layer

Back in the timeline, click frame number 72 in the ruler to 
change the current time. Next, select Draw > Reset All 
Points from the menu bar to move all points back to their 
original positions. In the tool options area at the top of the 
main window, press the Reset button to reset the rotation of 
the entire layer.

 Click the Reset button to reset the rotation of the layer.
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Finally, we’ll shorten the length of the animation from its 
default length of 240 frames. In the Timeline window, enter 
80 in the second number field. This will shorten the length of 
the animation to 80 frames.

 Shorten the animation to 80 frames.

Congratulations, you’ve made an animation! Press the play 
button near the bottom of the main window to watch it 
go. When you’re done, press stop. OK, so it probably won’t 
win any film awards, but you’re off to a good start learning 
Anime Studio.

 Playback controls.

Here’s what your finished animation should look like 
(approximately). Press the Play button below to see the 
result.
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The final result. (MP4 File)

You’ve learned how Anime Studio has different groups of 
tools for different operations, and even how to use a few of 
those tools. You can experiment more on your own, maybe 
adding more keyframes. When you’re ready to learn more, 
move on to “Tutorial 1.2: Drawing Simple Shapes” on page 
9.

Tutorial 1.2: Drawing Simple 
Shapes
In this tutorial you will learn how to draw simple shapes in 
Anime Studio. The following tutorials will build on what you 
start drawing in this tutorial.

Creating a Background
Launch Anime Studio by double-clicking its icon. Or, if 
Anime Studio is already running, choose File > New to 
create a new project, which opens in a new document 
tab.

Click the current tool icon (just beneath the File menu), 
to select Reset All Tools. This puts all tools at their default 
settings.

 Reset all tools.
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In the Tools window, click the Draw Shape tool to activate 
it. Then select the Rectangle option.

 Draw Shape

 Rectangle

From the Style window, select a brown color for the Fill color 
as shown below.

 Select a brown fill color.

Click and drag in the working area to create the rectangle 
shown below:
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 Draw a simple rectangle.

This shape is going to be the start of some rolling hills. So far, 
these hills look kind of flat, so let’s fix that. Pick the Add Point 
tool from the toolbar.

 Add Point

Click on the top edge of the rectangle and drag the 
mouse upwards:

 How to add a point to an existing shape.
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You should have something now that looks like the picture 
below. If this isn’t what you got, select the Edit > Undo 
menu item and try again. Be sure to click on the line that 
forms the top of the rectangle and drag upwards from 
there.

 Drag the new point upward.

Let’s add another curve to the hills by clicking a little more 
to the right and dragging downwards:

 Add a second point and drag it downward.

To keep things organized, it’s a good idea to name the 
layers in an Anime Studio project. Double-click this layer 
(the only one so far) in the Layers window.

 Accessing a layer’s properties.
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In the dialog that appears, type in “Hills” for the layer name 
and click the OK button.

 Rename the layer.

After creating the hills, choose Edit > Select None to 
deselect any selected points. Then click the Select Shape 
tool in the Fill section of the Tools panel, and click the fill on 
your hills.

 Select Shape Tool

The Style window will display the settings for the fill: its color, 
its line width and color, and the styles used to display it. To 
remove settings that you have used in previous projects, 

click the Reset button to reset the fill colors to their default 
settings.

 Click the Reset button.
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Set the line width to 1. Then choose Gradient from the 
Effect menu to open the Gradient dialog.

 The Style Window

When you select the Gradient fill style, Anime Studio 
automatically opens up the gradient settings dialog. The 
Linear gradient type is automatically selected for you.

 Linear gradient.

If you want to change the gradient settings later, click the 
details button to the right of the pop-up menu.

To set the left gradient color, double-click the left square at 
the bottom of the gradient bar to open the Color Picker. 
Select a green color and click OK to return to the Gradient 
dialog.

To set the right gradient color, double-click the right square 
at the bottom of the gradient bar to open the Color Picker. 
Select a brown color and click OK to return to the Gradient 
dialog.
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When your colors are selected, the Gradient settings should 
appear as shown below. Click OK to return to the scene.

 Gradient settings.

To see the gradient preview more easily, click outside 
the hill to deselect the fill. You’ll notice a line with a filled 
circle at one end, which represents the start color of the 
gradient (green in our example). The empty circle at the 
other end represents the end color of the gradient (brown 
in our example). You can adjust this indicator to control the 
blending and direction of the gradient.

 Final result.

In our example, the gradient starts with brown on the 
bottom (empty circle) and ends with green on the top of 
the hill (filled circle). The angle tilts slightly toward the left as 
shown below.

Choose the File > Save As... command from the menu and 
save the project under the name “Tutorial 1.2”.

In “Tutorial 1.3: Drawing Complex Shapes” on 
page 16 we’ll continue working on this 

scene by adding more complex shapes.
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Tutorial 1.3: Drawing Complex 
Shapes
This tutorial follows on the previous one, and teaches 
you how to draw more complex shapes. You can either 
continue with the project you created in Tutorial 1.2, or 
you can open a file provided for you named “Tutorial 1.2”. 
This file can be found in the “Tutorials/1 - Basics” subfolder 
within your custom content folder. The file you’re starting 
this tutorial with should look something like the following:

 Starting point.

Creating a New Layer
Click the New Layer button in the Layer window to create 
a new layer. In the popup menu that appears, choose 
“Vector”.

 Create a Vector layer.

You can assign the name “Clouds” to the new layer when 
you create it, or double-click this new layer and rename it 
“Clouds” in the Layer Settings dialog.
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 Rename the layer Clouds.

Now select the Add Point tool.

 Add Point

Click the Reset button in the Style panel to reset the colors 
to their default. Set the line width to 1.

 Reset colors and set line width to 1.

Click to set the start point for a new line segment. Without 
releasing the mouse, drag the cursor and release the 
mouse to create the end of the segment. The finished 
segment is shown below.
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 Add a line segment.

Next, click on the end of the new line segment and drag to 
stretch the curve out like this:

 Add another segment to the end of the curve.

Do this a few more times until you have the curve below:

 Several more segments added.
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The key point to remember is in order to extend a curve, 
you need to click on one of its endpoints and then drag 
the mouse to where you want the new point to be. 
Remember, if you make a mistake at any time, just choose 
the Edit > Undo menu command.

Now we’re going to add a second puff to the cloud. Move 
your mouse to the point just before the end of the previous 
segment. The “Auto Weld” option for the Add Point tool 
should be turned on by default. When turned on, the node 
will turn green when you can automatically weld the new 
segment to the existing one. When Auto Fill is turned on, 
the cloud will automatically fill with color when the shape 
is closed.

 Add a new curve at this point.

Click on the second to last point in the curve, and drag 
down and to the right, as shown below. When you use 
the Add Point tool on a point that is in the middle of a 
curve, what happens is that you start a new curve that is 
automatically welded to that point in the first curve. These 
two curves are permanently joined at that point, which 
becomes important when we get to filling the shape with 
color. Here’s what your project should look like after adding 
the new curve segment:

 A new segment welded to an existing curve.

Add some points to the end of this new curve to get the 
shape below. Remember, to add a point to the end of a 
curve, click just on the last point of that curve.
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 More new points.

Finally, add two or three more points at the beginning of 
the original curve. When you add the last point, drag it 
over to the right and line it up with the next to last point of 
the second curve before letting go of the mouse. Anime 
Studio will automatically weld those points together and fill 
the cloud with color to get the final shape below:

 Finished cloud.

Sometimes it can be hard to follow this sequence of 
steps - let’s take a moment to watch a movie of the cloud 
being created in Anime Studio. Pay special attention to 
where the mouse is clicked in order to weld the two curves 
together.
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Click the video to watch how to draw the cloud.

We will add a line effect to make the cloud a bit softer. In 
the Style window, check the Advanced button to display 
the advanced style options. Select ‘Soft Edge’ from the 
Stroke Effect pop-up menu. Accept the default settings 
and click OK.

 Soft Edge effect.

Now would be a good time to select the File > Preview 
command to see what your final result looks like:
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 The rendered cloud.

A Second Cloud
Let’s make another cloud. With the Clouds layer selected, 
choose Edit > Select All from the menu. Now choose Edit 
> Copy, followed by Edit > Paste. Next, pick the Transform 
Points tool from the toolbar.

 Transform Points

In the working area, click and drag to the right to move 
the new cloud away from the original. (When you paste an 
object from the clipboard, it is positioned directly on top of 
the original.)
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 Duplicated cloud.

Use the Transform Points tool to resize this new cloud, 
making it smaller than the original.

 Transform Points

The Transform Points tool can resize an object both 
vertically and horizontally, and will scale whether or not 
the object is selected beforehand. In this case, we don’t 
really want to change the cloud’s shape like that. With 
the Transform Points tool active, click and drag inward on 
one of the corner handles that appears around the cloud, 
thus making it smaller without changing its overall shape. 
Continue using the Transform Points tool until you get the 
new cloud in a position you like.
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 Second cloud scaled down and positioned.

Next, use the Edit > Select None command (or press the 
enter key) to de-select all the points in the new cloud.

Now you can use the Transform Points tool to click and 
drag individual points to reshape the second cloud.

In this case, since only one point is selected at a time, the 
Transform Points tool is used to re-shape the cloud, not 
move the entire object. Just re-shape a few points here 

and there so that the two clouds don’t look exactly the 
same.

 Modify some points.

Plant a Tree
Good - we’re moving right along, but this scene needs 
some plant life. Add a new layer to the project by clicking 
the new layer button in the Layer window. Again, choose 
“Vector” from the popup menu. Name it “Tree”.
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 Rename the layer to Tree

Select a brown fill color from the Style panel.

 Select a brown fill color.

Using the Add Point tool, along with the welding feature, 
draw a shape that resembles the trunk of a tree.
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 Add Point

Here are a few things to remember as you go: First, you 
can always use the Edit > Undo command to back up if 
you make a mistake.

Second, you can switch to using the Transform Points tool 
to reshape part of the object, even if you haven’t finished 
drawing the whole thing yet.

 Transform Points

Third, the Transform Points tool lets you pick individual points 
by clicking on them - if you want to get rid of a point, but 
it’s too far back to use undo, select it with the Transform 
Points tool and press the backspace or delete key on your 
keyboard.

Feel free to be creative with your tree trunk, you don’t 
really have to stick to the sample below.

 Draw a tree trunk
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There are a few tools that may be useful when building 
your tree that haven’t been introduced yet. The Pan 
Workspace and Zoom Workspace tools can be used to 
move around the workspace.

 Pan Workspace Tool

 Zoom Workspace Tool

Note that these tools are not used to manipulate your 
drawing - they just let you move your view so that you can 
focus in on a particular area of interest. To reset your view 
to its original position, select the View > Reset command 
from the menu bar.

Another useful tool is the Curvature tool. Using this tool, 
you can click and drag on a point to adjust how round or 
pointy the curve is as it passes through that point.

 Curvature

The last thing we’ll add in this tutorial is some greenery to 
the top of the tree. The shape for the treetop will be similar 
to the clouds, so follow similar steps to create it, but there is 
one tricky part. Because the treetop overlaps the trunk of 
the tree, it can be easy to click on the wrong part and add 
a new point to the trunk instead of the treetop.

There are two ways to avoid this problem.

One, use the Pan and Zoom tools to move in close to the 
top of the tree so that it’s easier to avoid clicking on the 
wrong thing.

•	 The second approach is to draw the treetop off to the 
side where there’s plenty of empty space. Then, when 
the treetop is finished, drag it back into position at the 
top of the tree. For the second approach, when you’re 
ready to move it back into position, use the Transform 
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Points tool and click to select one point on the treetop. 
Then use the Edit > Select Connected command to 
select the rest of the treetop. Finally, drag the treetop 
into place, and use the Transform Points tool to resize it 
if necessary.

•	 Select a nice leafy green fill color in the Style panel. Set 
the line width to 4, you’ll see why later.

 Select a green fill color and set line width to 4.

Use the Add Point tool to draw your treetop. Here’s the kind 
of look we’re going for:
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 The treetop.

Choose File > Preview to see how the treetop looks. Notice 
how the ends of line segments look kind of squared off 
and blocky. We’ll fix that using Anime Studio’s variable line 
width feature.

Exit the render window and press Enter to de-select all 
points in the treetop.

Now, using the Line Width tool, click on each of the points 
in the treetop that is at the end of a line segment. The area 

that the Line Width tool affects is indicated by a semi-
transparent red circle. The default width is .5, which is quite 
large. Decrease the width to around .1 or less to obtain 
finer control over the area that you want to affect.

 Line Width Tool



Anime Studio Debut 10
Tutorials

30

Quick Start

 Changing line width.

Choose File > Preview again, and notice how the 
endpoints are now nicely tapered. This feature isn’t limited 
to endpoints - experiment with using it on other points 
along a curve. Also, try dragging the Line Width tool back 
and forth to make lines thinner or thicker.

 The completed background.

”Tutorial 1.4: Bone Setup” on page 31 will 
move into using bones to control a character, 

and you’ll learn how to set up some animation 
controls to make things move.
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Tutorial 1.4: Bone Setup
This tutorial builds on the results of the previous two, 
teaching you how to add bones to a character. You can 
either continue with the project you created in Tutorial 1.3, 
or you can open a file provided for you named “Tutorial 
1.3”. This file can be found in the “Tutorials/1 - Basics” 
subfolder within your custom content folder.

Bones are an important tool you can use in Anime Studio 
to help make animation easier. If you think of drawings in 
Anime Studio (like the ones you made in previous tutorials) 
as soft rubber, then bones can be thought of as stiff wires 
inside the rubber that help you move and position objects. 
Bones are never displayed in a final rendering, they’re just 
used as tools during the animation process.

Bones are not absolutely necessary for animation. They 
are very helpful for animating certain types of motion as 
we’ll show in this and the next tutorial, but there are other 
ways to animate in Anime Studio as well. As you gain 
experience using Anime Studio, you’ll learn when bones 
are appropriate and when they’re not.

Importing an Object
Launch Anime Studio and open the project from the last 
tutorial.

 Starting point for this tutorial.

As you build a Anime Studio project, there are times you 
may want to re-use objects you created before. There’s 
an easy way to do this, and we’ll use it now to add a 
character to the project.

Select the File > Import > Anime Studio Object... command. 
In the file dialog that appears, navigate to your Anime 
Studio installation folder.
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From your custom content folder, locate the Tutorials/1 – 
Basics folder and open the file “Tutorial Extras.” A dialog will 
open asking you which object you want to use from this 
project:

 Insert Object dialog.

Select the layer named “Frank” on the left side of the 
dialog. On the right side, you’ll see a preview of Frank. Click 
OK. A new layer will be added to your project. This layer is 
a copy of the layer Frank from the “Tutorial Extras” project. 
Frank is fully drawn and filled in - you can see what the 
scene really looks like now by selecting File > Preview.

 Frank added to the project.

Adding Bones
Lets give Frank some bones to make him easier to animate. 
In the Layers window, click the new layer button. In the 
popup menu that appears, choose “Bone”. Rename this 
new layer “Skeleton.”
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Drag the Frank layer upwards “into” the Skeleton layer. This 
step is very important - you will know that you’re dragging 
the Frank layer to the correct place when the Skeleton 
layer becomes highlighted. Finally, click the Skeleton layer 
to make sure it’s active. When this is done, the Layer panel 
should look like this:

 Frank inside a bone layer.

Make sure the layer “Skeleton” is selected in the Layer 
panel. While holding down the Alt key, click the eyeballs 
icon on the left side of the Skeleton layer to temporarily 
hide the other layers.

 Select the Skeleton layer and hide the other layers.

Finally, use the Pan and Zoom tools to zoom in on the 
contents of this layer. Your window should now show 
something like this:



Anime Studio Debut 10
Tutorials

34

Quick Start

 Zoomed in on Frank.

Add a bone to Frank by selecting the Add Bone tool and 
clicking and dragging upwards as shown below:

 Add Bone Tool

This will be the main control bone - you could think of it as 
Frank’s spine. It should look like this:
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 First bone added.

Click and drag out three more bones as shown below. It’s 
important that you draw these three bones in order from 
top to bottom: thigh, shin, and foot.

 Right leg bones.

When a bone is selected, it is drawn in the highlighted 
color, red.

When you add a new bone, it becomes the “child” of the 
currently selected bone. The parent-child relationship for 
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bones means that the child can move around without 
affecting the parent, but if the parent moves, the child 
will move with it. This is why it was important to draw the 
previous three bones in order: the thigh bone’s connected 
to the spine bone, the shin bone’s connected to the thigh 
bone, and the foot bone’s connected to the shin bone (at 
least in Frank’s body).

When a bone is selected, it’s displayed in red. Its parent 
also gets displayed differently: in blue. The parent is 
highlighted like this for your information - sometimes you 
may connect bones in the wrong order and looking for the 
blue parent bone can help determine where things went 
wrong.

 A current bone and its parent.

OK, let’s add bones to the other leg. But first, we need to 
select the spine again so that the second leg will also be 
attached to it. Use the Select Bone tool and click on the 
spine to select it.
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 Select Bone Tool

Next, use the Add Bone tool to add three bones to the 
other leg as shown below:

 Add Bone Tool

 Left leg bones.



Anime Studio Debut 10
Tutorials

38

Quick Start

Testing Bones
There’s a bone tool that lets you test how your skeleton 
structure is working. Let’s try that now. Select the 
Manipulate Bones tool and click and drag any of the 
bones you created. Try dragging several of the bones 
around to see what happens.

 Manipulate Bones Tool

 Moving Frank’s legs.

Notice that Frank automatically moves with the bones. You 
may have also noticed that Franks looks quite “squishy” - 
when you move either of his legs, his head changes shape 
as well. The next step is to clean this up a bit by telling 
Anime Studio which parts of Frank should move with which 
bones.



Anime Studio Debut 10
Tutorials

39

Quick Start

The Manipulate Bones tool doesn’t permanently move 
the bones. Click the Select Bone tool and all the bones will 
snap back into their original places.

 Select Bone Tool

Adjusting Bone Strength
When you use a bone layer to control a character, every 
bone in the skeleton has some influence on every part of 
the character. We saw that in Frank - when you move one 
of the legs, even the head moves a bit. This influence is 
strongest closest to each bone, so the head only moves a 
little bit, not as much as the leg itself.

We don’t really want to see Frank’s head move much at 
all when his legs move. Luckily, there’s a way to control 
this: bone strength. Each bone has a “strength” value that 
controls how large its region of influence is. What we’ll do 
next is adjust the strength of the bones that control Frank.

Select the Bone Strength tool and take a look at the bones.

 Bone Strength Tool

Each bone has a semi-transparent region highlighted 
around it. (You also saw these regions when using the 
Manipulate Bones tool.) These regions show you the 
influence of each bone in the skeleton. A bone has the 
most influence inside its shaded region.



Anime Studio Debut 10
Tutorials

40

Quick Start

 Regions of influence.

With the Bone Strength tool active, click and drag side-to-
side on each of the bones in Frank’s skeleton to adjust its 
strength. The goal here is to adjust the region of each bone 
so that it just encloses the corresponding section of Frank’s 
body. For example, the region around the shin bone should 

just enclose the shin, and not much more. Don’t worry 
about being too precise - pretty close is good enough. For 
Frank’s head, don’t make the bone region enclose the 
entire head - that would make the bone too strong. Adjust 
the bone strengths so that they look approximately like the 
following:

 Adjusted bone strengths.
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Testing Bones (Again)
Once you adjust bone strengths, it’s a good idea to test 
the skeleton again to make sure everything works correctly. 
Pick the Manipulate Bones tool from the toolbar and click 
and drag on Frank’s shin bones just above the ankle.

 Manipulate Bones Tool

If everything was set up correctly, Frank should be able to 
move like this:

 Bones in action.

Play around - move Frank’s bones around into various 
positions and get a feel for manipulating the skeleton. 
“Tutorial 1.5: Animation” on page 42 will cover 
animation, and you’ll learn how to make objects move 
around over time.
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Tutorial 1.5: Animation
This tutorial continues on from the previous three, moving 
into the animation features of Anime Studio. You can either 
continue on with your project from the previous tutorial, 
or you can use a file that has been created for you - it’s 
named “Tutorial 1.4” and it’s located in the “Tutorials/1 - 
Basics” subfolder within your custom content folder.

There are three basic ways to animate objects in Anime 
Studio:

•	 animating an entire layer,

•	 using bones to animate parts of an object,

•	 animating the individual points on an object

These three types can be combined to make very complex 
animations. This tutorial will walk you through all three types 
of animation.

Open your previous project (or the “Tutorial 1.4” file) in 
Anime Studio. Make sure all the layers are visible by clicking 
to turn on each layer in the Layers window.

 Turn on all layers.

Your window should look something like this:
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 Starting point for this tutorial.

Layer Animation
Layer animation is the most simple way to make objects 
move around in a Anime Studio animation. It’s limited in the 
way you can move the objects, but in some cases it’s all 
you need. Layer animation moves an entire layer around 
as if it were painted on a pane of glass.

Click the Clouds layer in the Layers window to activate it. 
Next, set the current time to frame 72. This is done in the 
Timeline window. To set the time, scroll the timeline panel 
sideways (if necessary) until you see the number 72 in 

the ruler at the top. Click on the number 72 and the time 
marker will jump to that frame, as shown below:

 Time set to frame 72.

NOTE: If you do not see multiple channels in the 
timeline, you may have Anime Studio set to collapse 
them. Choose Edit > Preferences, and uncheck 
the “Consolidate timeline channels” option in the 
Options tab. This displays all animation channels in 
the timeline.

In Anime Studio, an important concept is to learn the 
importance of frame zero. At the far left end of the timeline 
is a frame marked zero. When the time is set to zero, you 
are in Anime Studio’s creation mode. For now, you should 
only draw, add bones, or create other objects at frame 
zero. When Anime Studio is at any other frame, you are 
animating the objects you have created. As you get 
more comfortable with Anime Studio, you can choose 
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to draw objects at other frames, but for now it’s best only 
to create new objects when the time is set to frame zero. 
You can switch back to frame zero at any time by pressing 
the rewind button, or by clicking on the number 0 in the 
timeline. For now, leave the time at frame 72.

Select the Transform Layer tool from the toolbar.

 Transform Layer

Click and drag to the right in the working area to move 
the cloud layer to the right. You can press the Shift key, if 
desired, to constrain the movement to a straight line.:

 Moving the cloud layer.

Notice that a marker appeared in the timeline at frame 
72. (You may have to scroll downwards to see the marker.) 
This marker represents a keyframe - a point in time at which 
the layer has been given a position. There are several 
animation channels displayed in the Timeline panel. This 
keyframe appeared in the Layer Translation channel, 
because that’s what type of action you just performed - 
you translated (moved) a layer.
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 The new keyframe.

Try out the animation so far: press the play button at the 
bottom-left of the main window. The animation loops when 
it reaches the end (in this case frame 240). When you’ve 
seen enough, press the stop button.

If you prefer, you can shorten the length of the animation 
to 72 frames, so that it will loop back to the beginning 
once it reaches the last keyframe. Simply change the total 
number of frames to 72 as shown below.

 Shorten the length of the animation to 72 frames, if desired.

 Playback controls.

Bone Animation
Bone animation uses skeleton structures to move an object 
around. You got a good feel for how bones work in the 
previous tutorial when you used the Manipulate Bones tool. 
When animating bones you use very similar tools.

Activate the Skeleton layer by clicking its entry in the Layer 
panel.
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 Activate the Skeleton layer.

Set the time to frame 12 by clicking the number 12 in the 
Timeline window. (You may have to scroll the Timeline 
window before you can see the number 12.)

 Set current frame to 12.

Now, pick the Manipulate Bones tool in the toolbar.

 Manipulate Bones Tool

Click and drag the bones in Frank’s legs until they are 
positioned as shown below:
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 Move Frank’s legs.

Note that the Manipulate Bones tool works differently at 
frame 12 than it did at frame 0 in the previous tutorial. At 
frame 0, this tool is used to test a bone system, and doesn’t 
permanently modify the bones. However, when you are 
animating bones (at any frame other than 0), the bones do 
hold their new position.

Next, pick the Transform Bone tool. Click on Frank’s spine 
bone and drag it downwards a bit:

To transform the bone, drag from the bottom 
control point on the bone. For more 

information about the control points in the Transform 
Bone tool, see “Transform Bone” on page 68 in 
your Anime Studio Users Manual.

 Transform Bone Tool
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 Lower Frank’s entire body.

Next, set the time to frame 24 and choose the Bone > Reset 
All Bones menu command. Press the play button to watch 
your animation, and press stop when you’re done.

When you played back the animation, you probably 
noticed that after frame 24, Frank doesn’t move any more. 
You could add more keyframes by setting the time to some 
later frame and moving Frank’s bones some more, but let’s 
try out Anime Studio’s animation looping feature.

In the timeline, you should see a group of keyframes at 
frame 24. These keys represent bone movement (the 
spine bone moving up and down) and bone rotation 

(the bending legs). Drag a rectangle around these four 
keyframes to select them:

 Select bone keyframes at frame 24.

Next, right-click on one of these selected keys. A popup 
menu will appear. Select “Cycle...” from the popup menu.

 Select Cycle
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What you’re telling Anime Studio is that you want these 
keys to cycle back to an earlier point in the timeline. A 
dialog will appear asking you what frame to cycle back 
to - enter the settings shown below. You’re telling Anime 
Studio that on this keyframe, the bone movement should 
cycle back to frame 0.

 Cycle settings.

Click OK and press the play button to see the difference. 
An animation channel with cycling turned on will repeat its 
animation over and over indefinitely. Typically this would 
be used for some kind of background element, not a 
foreground character like Frank, but it’s a great time saver. 
In the timeline you can see an indication of the cycling in 
the bone channels:

 Cycling indicated in the timeline.

Point Animation
Using point animation, you drag around individual points 
(or groups of points) on an object. In theory, you could 
animate the same types of motion as with bone animation 
- bones just save you a lot of work. Point animation is more 
typically used when you want to change the shape of 
some object.

Click the Clouds layer in the Layer panel to activate it.
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 Activate the Clouds layer.

Pick the Transform Points tool from the toolbar.

 Transform Points

Press the enter key on your keyboard to make sure no 
points are selected. Finally, click the Jump to End button to 
jump to the end of the animation.

 Jump to End button.

Click and drag individual points on the clouds in small 
amounts, just to reshape the clouds a bit. This will cause the 
clouds to change their shapes slightly from the beginning 
of the animation to frame 72.
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 Point animation.

Use the play and stop buttons to see the result.

Importing Animation
Remember how the Frank layer was imported into the 
project in the previous tutorial? Well, imported layers can 
also contain animation.

First, return to Frame 0 in your animation.

 Return to frame 0.

Select File > Import > Anime Studio Object.... When 
prompted, locate the/Tutorials/1-Basics folder (in your 
custom content folder), and open the file “Tutorial Extras.”In 
the dialog that pops up, select the Beach Ball layer and 
click OK.
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 Import the beach ball.

A bouncing beach ball will appear in your project. Press 
the play button to watch it go. It bounces all right, but it’s 
not really in the right position.

Switch back to frame zero (press the rewind button in the 
timeline) to set the ball’s initial position.

Using the Transform Layer tool, drag the beach ball to a 
better location.

 Transform Layer

 Repositioned beach ball.

You can also use the Transform Layer tool to resize the ball. 
(Drag one of the corner handles of the scale control box 
to resize the beach ball the same amount in width and 
height.) Press the Play button to view the final animation.
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 Transform Layer

 Play the final animation.

You now have a pretty good grasp of how to draw, fill, set 
up bones, and animate in Anime Studio. Feel free to jump 
right in and start working with Anime Studio. Or, you can 
read more tutorials that dig deeper into specific topics.
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Tutorial 2.1: Welding
As you learned in the Quick Start tutorials, Anime Studio 
features an Auto Weld feature that automatically welds 
shapes and segments together when your cursor reaches 
a point that you can weld to. However, there are cases 
where you may want to manually weld points together.

When drawing in Anime Studio’s vector layers, the concept 
of “welding” points is very important. These tutorials will 
show you examples of how (and why) points can be 
welded, and will go on to show you some examples of 
good and bad welds you can do in Anime Studio.

When you weld two points together in Anime Studio, Anime 
Studio really is combining those two points into one. There 
are a couple reasons to do this: First, welding the two 
endpoints of a curve together creates a closed curve. 
Second, if two shapes join up at a particular point, and 
you want them to remain joined during an animation, then 
welding those points together will guarantee that those 
two shapes will remain joined.

How to Weld Points
There are two ways to weld points in Anime Studio: 
manually and automatically.

To manually weld two points together with the Transform 
Points tool, first uncheck the Auto-weld option for the tool.

 Transform Points

 Auto-weld option unchecked

Drag one point on top of the other and press the 
spacebar. Here’s an example of this method. Although you 
can’t see the keyboard in the example, keep in mind that 
the spacebar was pressed at the moment when the two 
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points overlap. After welding, notice how the two points 
move as one.

Welding Example 1. (Click to play movie)

 Before spacebar is pressed (left). After spacebar is pressed 
(right)

The second method of welding is automatic. For automatic 
welding to work, be sure that the Auto-weld checkbox 
is turned on in the tool options area when the Transform 
Points tool is active:

 Make sure Auto-weld is on

Using this method, when you drag a curve endpoint 
on top of another point , the point turns green when it 
can be welded automatically. Let go of the mouse to 
automatically weld the points together.
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Here’s an example of automatic welding. In this case, the 
spacebar was not pressed to initiate the weld - as soon 
as the mouse is released, the two overlapping points are 
automatically welded together.

Welding Example 2. (Click to play movie)

 Automatic welding

Here’s another example of automatic welding. Remember 
that only a curve endpoint can be automatically welded. 
However, the point that it is welded to does not need to be 
an endpoint:
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Welding Example 3. (Click to play movie)

Automatic welding also works with the Add Point tool.

 Add Point

When you add a new point, you can drag it around as 
if you were using the Transform Points tool. As long as 
the new point you added is a curve endpoint, it can be 
automatically welded to another point. If the new point 
is not an endpoint, you can still weld it to another point 
manually by pressing the spacebar when it overlaps 
another point.

 Add Point tool with Auto-weld option on

Besides welding two points together, Anime Studio can 
weld a point to the middle of a curve segment. This can 
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be done with either the automatic or manual welding 
methods. Here’s an example:

Welding Example 4. (Click to play movie)

 Welding to a curve segment

Why to Weld Points
OK, so that covers welding points, but why do you want 
to weld points again? The main reason is to create fillable 
shapes. In order to fill a shape with color, that shape should 
be completely closed, either by overlapping lines or by 
shapes that are welded together so that there are no gaps 
in the shape that you want to fill.
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 A non-closed shape

By welding the two endpoints together, we can create a 
closed shape that can then be filled:

 A closed shape that can be filled

Examples of Good Welding
Let’s look at some examples of good welding choices. 
First, the following two points could be welded to create a 
single, continuous curve:
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 Joining two curves

The next case shows the classic case of welding a curve 
closed to create a fillable shape:

 Closing a curve

Next, we show a shape made up of several curves. Notice 
that a closed, fillable shape does not need to be made up 
of a single curve. The shape below, after welding, is made 
up of three curve segments, but is still closed and can be 
filled with color:
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Joining multiple curves into a single closed shape  The welded and filled shape

Finally, the example below shows two circles lined up 
side-by-side. The two side points of the circles have been 
welded together so that when they move around during 
an animation they remain joined. If those points were not 
welded, moving them in sync like this would require a lot of 
extra work.

To maintain the separate colors in the two 
circles, Auto Fill is turned off before welding 

the two circles together at a common point.
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Joined Circles. (Click to play movie)

Examples of Bad Welding
Typically, when you weld together two points, one of them 
should be a curve endpoint. This isn’t always true, but 
most often it is. If you find yourself welding together two 
points and neither is an endpoint, take a moment to think 
whether the weld is appropriate. Here’s an example of a 
bad choice of welding. Suppose you had the following 

two shapes and you were considering welding the pairs of 
circled points:

 Before welding the marked points

Although Anime Studio will let you perform those welds, it 
isn’t really a good idea. What you would end up creating 
is a shape with lots of little holes in it. Along the section of 
curves that you welded together are little bubbles that 
make it impossible to fill the two main shapes:
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 Bad welding

Instead, a better approach is to just move the two shapes 
closer together without any welding at all. In this case, 
welding the two shapes together doesn’t have any benefit.

 Fill the shapes without welding them together

 Delete Edge

Another approach in this situation would be to cut the top 
shape apart with the Delete Edge tool and then weld the 
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remaining endpoints to the lower shape. First, cut the top 
shape apart:

 Cut the redundant curve away

Then, weld the newly-created endpoints onto the lower 
shape. With this approach you don’t end up with a double 
curve all welded together. The resulting shape is much 
cleaner and easier to work with:

 Weld the new endpoints

Tutorial 2.2: Drawing Shapes with 
Holes
Drawing shapes with holes is very easy in Anime Studio, but 
many new users don’t realize that this can be done. There’s 
really no trick at all - just follow the basic rules for creating 
a fill.
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Reminder of Fill Rules

 Create Shape Tool

As a reminder, let’s consider the rules for creating a fill 
shape: A fill must be composed of closed curves that 
define the border of the shape. So, as an example, below 
is a valid fill shape.

 A basic fill shape

Creating Holes
So a fill shape is defined by the curves on its border. If we 
want to create a hole, then all we need to do is create 
curves that outline the shape of the desired hole(s). Below 
we’ve added some extra curves before creating a fill 
shape:
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 New curves added

 Create Shape Tool

Once you’ve set up curves to define the shape of the 
hole, all you need to do is select the outline and the hole(s) 
using the Create Shape tool. Notice that Anime Studio 
automatically identifies the inner curves as borders of holes 

in the shape. There’s nothing in particular you have to do, 
just draw the holes and Anime Studio will know what to do 
with them. When you’ve selected all the correct points, 
press the spacebar to finalize the shape.

 Selected points for filling

Finally, here is the resulting shape. (The Line Width tool 
was used to narrow the width of the outline at the corner 
points.)
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 The finished shape

Here’s another example of a shape with a hole:

 Another shape with a hole

Tutorial 2.3: Hidden Edges
When drawing more complex objects like faces, you will 
often run into situations where you want an outline to 
only go partway around a shape. There’s an easy way to 
accomplish this in Anime Studio.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 2.3 and it’s located in the 
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Tutorials > 2 - Draw subfolder within your custom content 
folder. Open this file in Anime Studio and you should see 
something like this:

 Starting point for this tutorial

Hidden Edges
The drawing we’re working with could be the beginning 
of a character’s face. In this face, the nose and ear are 
separate shapes from the main head outline. The general 

shape looks OK, but where the separate parts join up 
we don’t want to have lines separating them. To fix this, 
activate the Hide Edge tool.

 Hide Edge Tool

There are two edges we want to eliminate from this 
drawing. Click on these two edges as shown below. If you 
don’t see an immediate result, try dragging the mouse 
across the lines in question to make sure you hit them.
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 Edges to click on

After clicking on these edges, they should disappear from 
view, and the result should be as follows:

 After hiding the edges

The Hide Edge tool works by simply hiding the selected 
edges of an outline. It does not affect the underlying 
curve - the curve is still there, you just can’t see the outline 
on that particular section of the curve. Because it works 
on the outline, and not the curve itself, be sure you only 
use the Hide Edge tool after you’ve created the outlines. 
Otherwise, with no outline, you would not see the result of 
hiding some edges.

The other thing to know about the Hide Edge tool is that 
you can also un-hide edges. If you change your mind, 
or hide the wrong edges, just click on a hidden edge to 
re-show it.
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Finishing Touches
If you hide the edges of a thicker line, you’ll often end up 
with abrupt ends to the outline. You can see this below:

 Blocky curve ends

 Line Width Tool

A nice way to finish off these endpoints is to use the Line 
Width tool. With this tool, click on the endpoints to set their 
width to 0. You can also click and drag to adjust the width 
of any other points you choose. After cleaning up the 
endpoints, you should get a result like this:

 Tapered endpoints

Tutorial 2.4: Varying Line Widths
Anime Studio allows you to change the width of a stroke at 
any point along the curve. Line width information is stored 
as a percentage value, rather than as an absolute value.
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You can use varying line widths to create outlined shapes 
that maintain consistency when they are bent and 
animated.

Start With a New Project
Create a new project. In the Style window, select a color 
that you want to use for the outline color. Set the width of 
the stroke to around 100. Use the Add Point tool to draw a 
three-point curve. Bend the curve slightly, like an arm.

 Add Point

 A simple three-point curve bent like an arm

Then use the Variable Line Width tool to increase or 
decrease the width at the points until you have a shape 
resembling an arm. Your arm should look similar to the 
figure shown below.

 Line Width Tool
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 The curve reshaped to look like an arm

Select the curve and copy it into your clipboard 
(Command/Ctrl+C). Then paste another copy directly on 
top of the existing curve (Command/Ctrl+V).

Now you have two strokes that are superimposed directly 
on top of each other. You can use the top stroke as a 
fill, but you’ll need to make some adjustments. With the 
second stroke selected, change the stroke color for the 
second stroke to the color that you want to use for the fill of 
the arm (such as yellow, shown here).

 Change the color of the top stroke

Reduce the width of the top stroke to a value between 90 
and 95 (depending on how thick you want your “outline” 
to be). Your project should now look similar to the figure 
shown below.
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 The curve reshaped to look like an arm

Remember that in this method, you are not working with a 
stroke and a fill. Instead, you are working with two strokes of 
different colors that are controlled by the same curve.

Now you can use the variable line width tool to adjust 
the width of both strokes at the same time, or make other 
transformations with the Transform Points tool to reshape or 
animate both curves at the same time. This allows you to 
quickly create character elements, such as arms or legs, 
which are easier to animate because they have fewer 
points to manipulate.

Line width and transformation changes made on the points or 
curves affect both strokes at the same time.

Tutorial 2.5: Shape Ordering
In an Anime Studio vector layer, shapes are ordered from 
back to front. This ordering determines which shapes will 
appear in front of or behind others. This tutorial will show 
you how to work with shape ordering.
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Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 2.4 and it’s located in the 
Tutorials > 2 - Draw subfolder within your custom content 
folder. Open this file in Anime Studio, and you should see 
something like this:

 Starting point for this tutorial

As you can see, there are four shapes in this file. By the way 
they overlap one another, you can also tell their ordering. 
From back to front, there is a red shape, a green shape, a 
blue shape, and a yellow circle.

Raising and Lowering Shapes

 Select Shape Tool

If you want to change the order of some shapes, the first 
thing you need to do is select a shape to work with. Using 
the Select Shape tool, click anywhere on the red shape. It 
will become highlighted with a checkerboard to indicate 
that it is selected. Notice that you can also see it faintly 
beneath the other shapes - this is so that you can see the 
entire selected shape, even if it is normally obscured by 
other shapes.
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 Selected shape highlighted

To raise the shape, press the Up arrow key on your 
keyboard. Notice that the red shape has now moved one 
step up in the layer order, above the green shape:

 Raised shape

Right now, press the enter key to de-select all objects in the 
layer. The red shape will switch back to normal to indicate 
that it is not selected:
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 De-select the shape

Next, use the Select Shape tool and click on the blue 
shape to select it.

 Select Shape Tool

Press the Down-arrow key twice to lower the blue shape 
below the red shape, and then below the green shape:

 Lowered blue shape

You can also raise a shape to the top (above all others in 
that layer) or lower it to the bottom (behind all others in 
that layer). Select the green shape and hold down the Shift 
key while pressing the Up-arrow key. With a single key press, 
the green shape moves all the way to the top of the layer’s 
shape order.

Selecting Hidden Shapes
If you now press the enter key, the green shape will be de-
selected. Notice that at this point the yellow circle is behind 
the green shape, and can’t be seen. You can still see the 
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curves that make up the yellow circle, but the shape itself, 
being behind the green shape, is not visible:

 Hidden yellow circle

Now we want to bring the yellow circle back to the front. 
Using the Select Shape tool, click on the yellow circle, even 
though it’s hidden.

 Select Shape Tool

As you may have expected, the green shape gets 
selected because it is in front:

 Selected green shape

Now comes the trick for selecting shapes lower in the 
ordering. Hold down the Ctrl key (Windows) or Cmd key 
(Mac) while pressing the down-arrow key. This tells Anime 
Studio to pick the next deeper shape in the layer ordering 
at the same point you just clicked. The yellow circle will 
now be selected. It will be kind of faint to remind you that it 
is actually behind other shapes in the layer:
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 Selected yellow circle

Finally, hold down the Shift key while pressing the up-arrow 
to bring the yellow circle all the way to the top of the layer 
ordering, making it fully visible once again:

 Raised yellow circle

Tutorial 2.6: Brushes
Anime Studio allows you to apply brush effects to outlines if 
you choose. It’s really easy to use brushes, and this tutorial 
will show you how.
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Draw Some Freehand Curves

 Freehand

Start with a new, blank file in Anime Studio. In the Style 
window, set the line width value to 16. Next, activate the 
Freehand tool. In the tool options area at the top of the 
main Anime Studio window, adjust the settings for the 
Freehand tool to match those shown below:

•	 Variable Line Width: Use Pen Pressure

•	 Width Variation: 75%

•	 Taper Start: Checked

•	 Taper End: Checked

 Freehand settings

Draw two or three curvy lines using the Freehand tool in the 
editing view:
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 Freehand curves

Because of the line width set in the Style window, these 
curves should be rather thick. The tapering settings in the 
Freehand options should make the ends of these lines 
taper down to narrow points. If you select File > Preview 
now, the result should look pretty much like what you see in 
the editing view:

 Rendered curves

Close the rendering window, and use the Select Shape tool 
to select one of the curves:

 Select Shape Tool
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 Selected curve

In the Style window, click on the box that currently says No 
Brush.

 No Brush

In the brush dialog that appears, select one of the brush 
shapes that interests you - you’ll see a preview of the brush 
at the bottom of the dialog:

 Brush Dialog

Click OK to close the brush dialog, and select File > Preview 
again. In the rendered result you can see the applied brush 
shape:
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 Rendered curves

Try applying other brush shapes and Stroke colors to the 
other curves:

 Different brush shapes
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Bones

Tutorial 3.1: Bone Binding
The purpose of bones in Anime Studio is to provide high-
level objects that are easy to manipulate in place of 
moving around lots of individual points. In order for bones 
to do their job, vector control points and other objects 
must first be bound to the bones. There are three ways to 
bind objects to bones: automatic binding, manual binding, 
and layer binding. This tutorial will show you the difference 
between the three.

Start With a Sample File
For this tutorial, we’ll start with a project file that contains 
some artwork to get started with. It’s named Tutorial 3.1 
and it’s located in the Tutorials > 3 - Bones subfolder within 
your custom content folder. Open this file in Anime Studio, 
and you should see something like this:

 Starting point for this tutorial

Automatic Binding
The most common method of binding objects to bones is 
also the easiest - automatic bone binding. Whenever you 
draw new artwork in Anime Studio (or import image files as 
image layers), those objects are set up for automatic bone 
binding. All you need to do is add the bones.



Anime Studio Debut 10
Tutorials

84

Bones

1.	 In the Layers window, click the New Layer button, and 
select Bone from the popup menu.

 Create a new Bone layer

2.	 Double-click the new bone layer to bring up the Layer 
Settings dialog. Name the new layer Arm Bones and 
click OK. Finally, drag the Arm vector layer upward to 
move it into the bone layer:

 Arm layer placed inside a bone layer

Make sure the bone layer is selected, then activate the 
Add Bone tool.

 Add Bone Tool

In the main editing view, create two bones: the first one 
starting at the shoulder and ending at the elbow, and the 
second starting where the first left off and ending in the 
hand. And that’s all it takes for automatic bone binding.

 Create two new bones
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Use the Manipulate Bones tool to try moving the bones 
around. The arm will move with the bones automatically, 
since it was, well, automatically bound to them.

 Manipulate Bones Tool

 Test moving the bones

This arm setup works pretty well as it is, but let’s try to refine 
it a bit. Double-click the bone layer to bring up the Layer 
Settings dialog. Go to the Bones tab, set the binding mode 
to Region binding, and click OK:
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 Turn on region binding

Flexible binding (the default for new bone layers) uses a 
method of bone binding where every bone has some 
influence over every point in a vector layer. The farther 
away a point is from a bone, the less influence that bone 
has over the point. However, you can still experience some 
rubbery movement where a moving arm can cause a toe 
to twitch a little bit.

With region binding, on the other hand, every bone has 
a cutoff radius, outside of which it will not affect the 
movement of vector points. This can be used for cleaner 
movement, but requires a little extra setup. Now that region 
binding is in effect, activate the Bone Strength tool.

 Bone Strength Tool

Around each bone you will see its region of influence. 
Vector points are controlled by the bone(s) whose regions 
overlap them. If a vector point is not within any region of 
influence, it will move with the closest bone. Using the Bone 
Strength tool, click and drag on each of the bones to resize 
its region of influence. The idea is to make the regions just 
large enough to contain the body part that the bone is 
meant to control:
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 Resized regions of influence

Don’t worry about the parts of the forearm that are outside 
the forearm bone’s region of influence - they will just move 
with the closest bone, which is in fact the forearm.

Use the Manipulate Bones tool again to try moving the arm. 
The movement should be a little cleaner than it was with 
flexible binding.

 Manipulate Bones Tool

Manual Binding
Manually binding points to bones is a process that exists 
mostly for compatibility with older versions of Anime 
Studio. Automatic binding, combined with bone regions 
of influence is the easiest way to work with bones in Anime 
Studio. However, there may be some times where you 
want more control over exactly which bones control which 
points.

To manually bind the arm points to bones:

1.	 Select the Arm vector layer.

 Arm Vector Layer

2.	 Use the Select Bone tool to select the upper arm bone:



Anime Studio Debut 10
Tutorials

88

Bones

 Select Bone Tool

 Select the upper arm

3.	 Activate the Bind Points tool.

 Bind Points Tool

4.	 Drag a rectangle around all the points in the arm 
to select them, and press the spacebar to bind the 
selected points to the selected bone:

 Bind all points to the upper arm

5.	 With the Bind Points tool still active, hold down the Alt 
key and click on the lower arm bone to select it. Notice 
the following:

�� When you select the lower arm bone, notice that 
no points are selected.

�� When you select a bone with the Bind Points tool, 
the points that are bound to that bone are also 
selected. Because there are currently no points 
bound to the lower arm bone, no points are 
selected.



Anime Studio Debut 10
Tutorials

89

Bones

6.	 Drag a selection rectangle around the points in the 
lower part of the arm, as shown below. Press the 
spacebar to bind the selected points to the selected 
bone:

 Select the lower arm bones

You’re done - you have manually bound points to both 
bones in the arm. Now test it out with the Manipulate Bones 
tool.

 Manipulate Bones Tool

Although this method does work for binding points to 
bones, we don’t really recommend it unless you have a 
special need to bind specific points to specific bones. You 
may have noticed that the arm doesn’t move so smoothly 
with manual point binding. This is because the points 
around the elbow only move with one bone or the other, 
and so stretch apart and get distorted. With automatic 
binding, on the other hand, the points around the elbow 
move under the influence of both bones, and so move 
more smoothly.

Manual point binding can also be very labor-intensive, 
especially when your artwork has lots of control points. 
Finally, automatic bone binding can be used to warp 
image layers, while manual binding can’t - another reason 
to stick with automatic bone binding (using either flexible or 
region binding mode).

Layer Binding
The last way to bind an object to a bone is to bind an 
entire layer to a single arm.

Make sure the Arm vector layer is still selected and activate 
the Bind Layer tool.
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 Bind Layer Tool

7.	 Click on the lower arm bone to bind the entire Arm 
layer to the lower arm bone.

 Bind the Arm layer to the lower arm bone

8.	 Select the Arm Bone layer and use the Manipulate 
Bones tool to try moving the bones around. Notice that 
the entire arm moves rigidly with the lower arm bone - 
the entire layer is bound to that one bone.
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 Manipulate Bones Tool

This isn’t very useful for this particular arm, but binding 
a layer to a bone is useful when you want to attach 
an object to a character. For example, a switch group 
containing multiple mouth shapes can be attached to a 
bone in the head. Or, if you want to make a character 
hold an object in its hand, you might bind that object to 
the character’s hand bone.

Go Back to Automatic Mode
Let’s undo all of this extra binding and go back to 
automatic mode.

1.	 Reselect the Arm layer in the Layers window.

2.	 With the Bind Layer tool, click on some empty space in 
the editing view - this tells Anime Studio to not bind the 
layer to any bone.

 Bind Layer Tool

3.	 Select the Edit > Select All menu command to select all 
the vector points.

4.	 Choose the Bone > Flexi-Bind Points menu command 
to flexibly bind the points, as they were at the very 
beginning.

5.	  Chose Bone > Flexi-Bind Points to flexibly bind points as 
originally set in the beginning.

6.	 Reselect the Arm Bone layer, and use the Manipulate 
Bones tool if you wish to confirm that the points are 
automatically bound again.
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 The arm under bone control.

Tutorial 3.1 Result. (Click to play movie)

Tutorial 3.2: Bone Constraints
This tutorial demonstrates Anime Studio’s bone constraint 
features. Bone constraints allow you to define limits on the 
way bones can move, simplifying your animation work. 
When used carefully, bone constraints can let the bone 
structures do some of the work for you.




Anime Studio Debut 10
Tutorials

93

Bones

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 3.2 and it’s located in the 
Tutorials > 3 - Bones subfolder within your custom content 
folder. Open this file in Anime Studio, and you should see 
something like this:

 Starting point for this tutorial

This file contains two skeleton layers that have no 
constraints set up. We’re going to add constraints to these 
skeletons to show how useful they can be.

Angle Constraints
The first type of bone constraint is angle limits. By limiting the 
angle that a bone can rotate, you can prevent arms and 
legs from bending backwards.

Make sure the Arm layer is selected.

 Select the Arm bone

7.	 Use the Select Bone tool to select the bone in the Arm 
as shown below:

 Select Bone Tool
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Select the lower arm bone.

8.	 When the Select Bone tool is active and a bone is 
selected, the Bone Constraints popup box will be 
available in the tool options area of the main Anime 
Studio window. Click the Bone Constraints popup to 
open it.

9.	 Adjust the settings as shown below. Specifically, turn on 
the Angle constraints checkbox, and set the min/max 
angle fields to -10 and 100.

 Set angle constraints

10.	 Click the Close button to close the constraints popup 
box.

11.	 Set the bone’s name to Forearm in the toolbar options.
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 Name this bone Forearm

12.	 Once you’ve set up angle constraints, you can see 
them in the working area as two lines around the bone 
that indicate the minimum and maximum angles 
the bone is allowed to rotate between. Try using the 
Manipulate Bones tool and move the forearm - notice 
how Anime Studio doesn’t allow you to move the bone 
beyond the minimum and maximum angles you set up.

 Manipulate Bones Tool

 Visual display of angle constraints

Here’s a handy little trick. Often, it can be 
hard to judge the correct numerical angles 

for bone constraints. There’s an easy way to adjust 
them if you have a mouse with a scroll wheel. Hold 
the mouse over the angle constraint you wish to 
change (in the Bone Constraints popup), and roll the 
mouse wheel up and down. The angle will change, 
and the display in the editing view will update to 
match. With this method, you can watch the display 
in the editing view and not worry so much about the 
actual numerical value.
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Control Bones
The next type of bone constraint allows one bone to 
control the motion of another. This is a way to set up simple 
automatic animation.

Use the Select Bone tool to elect the small bone above the 
upper arm:

 Upper forearm bone selected.

13.	 Bring up the Bone Constraints popup again, and select 
Forearm from the Angle control bone popup menu 
(this is why we named it earlier), and enter the value 
0.5 in the angle control field as shown below:

 Angle control setup

14.	 We’ll do something similar for the small bone below the 
upper arm. Select that bone, and set Forearm as the 
angle control bone, but this time set the angle control 
value to -0.5.
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Lower forearm bone selected.

15.	 Finally, use the Manipulate Bones tool again to move 
the forearm. Notice that now the muscles in the upper 
arm move automatically - this is what the Angle Control 
Bone does - it tells other bones to move automatically 
when it moves.
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 Manipulate Bones Tool

 Upper Arm bones move automatically

Bone Locking
The third category of bone constraint is bone locking. 
When you lock a bone, you’re telling Anime Studio that 
you don’t want it to move. Anime Studio will try to keep 
the bone still by moving its parents as necessary to keep 
the bone in place. This isn’t always possible (depending 
on what else is happening in the animation), but it is still an 
extremely useful feature.

Bone locking is often used to keep a character’s feet from 
moving around on the ground. To do this, Anime Studio 
needs to move the character’s legs automatically. Thus, 
it helps to use angle constraints to keep the knees from 
bending backwards.

1.	 Select the Frank w/Skeleton layer in the Layers window.

Select the Frank w/Skeleton layer.

2.	 Use the Select Bone tool to select Frank’s left shin bone 
as shown:
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 Select the left shin

3.	 Now set up angle constraints for this bone. The 
minimum angle should be -10, and the maximum 
should be 120:

 Angle constraints for left shin

4.	 Now select the right shin, and set its angle constraints 
to -120 and 10.
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 Angle constraints for right shin

5.	 Now that the legs are prepared, set the time to frame 
24. Use the Transform Bone tool to drag Frank’s spine 
bone around a small distance. Notice that his feet 
move around and don’t stay in place.

 Transform Bone Tool

6.	 Choose the Select Bone tool again. Go back to frame 
0 and select the left foot bone:
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 Select the left foot

7.	 In the tool options area, turn on the Lock bone 
checkbox for this bone. Next, select the right foot bone 
and turn on Lock bone for it as well.

 Lock both foot bones

8.	 Now that the feet are locked, go back to frame 24, 
and use the Transform Bone tool again to drag Frank’s 
spine around.

 Transform Bone Tool

9.	 Notice that now Anime Studio tries to keep Frank’s feet 
locked to the ground. If you lift Frank too high, his legs 
will completely straighten out and his feet will lift from 
the ground - there’s really no helping that, the same 
thing would happen to you if you were lifted off the 
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ground. You can try rotating the spine bone too and 
see how the skeleton reacts.

 Locked feet

Bone locking is an animated parameter. You 
can turn on and off bone locking as many 

times as you want during an animation. This is 
especially useful when making a character walk - 
lock a bone as soon as a foot hits the ground, and 
unlock it just before the foot is to leave the ground 
for its next step.

Tutorial 3.3: Bone Dynamics
Anime Studio’s bone dynamics system can be used to 
automatically move bones around in response to higher-
level movement. Anime Studio uses a physical simulation 
of springs to calculate dynamic bone movement, making 
it suitable for a wide range of movements, such as flabby 
body parts, bouncy hair, waving arms, etc.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 3.3 and it’s located in the 
Tutorials > 3 - Bones subfolder within your custom content 
folder.

1.	 Open the Tutorial 3.3 file in Anime Studio. You should 
see something like this:
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 Starting point for this tutorial

2.	 Play back the animation to see what we’re starting 
with. The entire structure will tilt side to side and bounce 
up and down, remaining rigid the whole time. Only the 
vertical bone in the center of the skeleton is animated 
- all the others move with it because they are its 
descendants. Rewind the animation to frame 0 when 
you’ve seen enough.

3.	 Use the Select Bone tool to select the top-left bone in 
the structure as shown below:

 Select Bone Tool
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 Select this bone

4.	 In the tool options area at the top of the main Anime 
Studio window, click the Bone constraints popup box to 
open it. In the popup box, turn on the Bone dynamics 
check box. This tells Anime Studio to move the selected 
bone automatically according to the spring simulation.

 Turn on bone dynamics

5.	 Select seven more bones (two in each of the arms), 
and turn on bone dynamics for each one.
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Here’s a tip: you can leave the Bone 
constraints popup box open the whole time, 

just click on each bone in turn, then turn on bone 
dynamics for each one. If the Bone constraints 
popup box covers up some of the bones, you can 
pan the editing view by dragging with the right 
mouse button to expose the hidden bones. At this 
point, you should have turned on bone dynamics for 
every bone in the structure except the vertical 
center bone.

 All eight leg bones set

Play back the animation to see the difference. Now as the 
structure tilts side to side, the arms will bounce around in 
response to the movement of the center bone.
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Adjusting Spring Parameters
So that shows the basics of how to use bone dynamics. 
Now let’s take a look at how you can make adjustments to 
the bounciness of the springs.

Select the top-left bone again, and re-open the Bone 
constraints popup box.

1.	 Below the Bone dynamics checkbox are three 
parameters that allow you to fine-tune the effect. Set 
as follows:

�� Torque force to 4,

�� Spring force to 2

�� Damping force to 2

 Adjusting dynamics parameters for both bones in the top left 
arm

2.	 Select the bone’s immediate parent (the second bone 
in the top-left arm), and apply the same dynamics 
parameters.
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A higher Torque force means that a bone 
moves more in response to its parent’s 

movement, Spring force determines how quickly it 
bounces back, and Damping force controls how 
quickly a dynamic bone stops moving (you can 
think of damping like friction). In this case, a high 
torque force means that the bone will move more 
strongly.

3.	 Next, select the two bones of the top-right arm (one at 
a time), and set the bone dynamics parameters to 2, 
2, 5 (Torque, Spring, Damping). These settings will cause 
these bones to slow down their dynamic movement 
quickly - a high damping value is like making the bone 
move through a thick fluid.

 Set a high damping force on these bones

4.	 Finally, select the two bones of the bottom-left 
arm (one at a time), and set the bone dynamics 
parameters to 2, 4, 1 (Torque, Spring, Damping). The 
high spring force will cause this arm to bounce back 
very quickly.
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 Set a high spring force on these bones

5.	 Try playing back the animation again. As you watch 
the final animation, note the differences between 

the four arms. The top-left arm swings in a wide arc 
because it has a strong response to the parent bone’s 
movement. The top-right arm’s movement is subdued 
because the damping force causes it to slow down 
more quickly. The bottom-left arm is very springy, and 
the bottom-right arm moves in accordance with the 
default bone dynamics settings.

Tutorial 3.3 Result. (Click to play movie)
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Tutorial 3.4: Character Setup
In this tutorial, you will learn how to set up the bone 
system for a complex character. This will involve splitting a 
character apart, creating bones, adjusting bone strength, 
and putting the character back together.

Start With a Sample File and Split Apart 
the Character
For this tutorial, we’ll start with a project file that already 
has the artwork for the character drawn - you’ll just set up 
the bones. It’s named Tutorial 3.4 and it’s located in the 
Tutorials > 3 - Bones subfolder within your custom content 
folder.

To begin:

1.	 Open the Tutorials > 3 - Bones > Tutorial 3.4 file in 
Anime Studio. There are six vector layers in this project, 
containing the body parts for this character. Although 
all the artwork could be drawn in one vector layer, it 
is often easier to draw a character in multiple layers, 
arranging the body parts from back to front, as shown 
below:

 Starting point for this tutorial
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 Starting point for this tutorial

2.	 In order to make bone setup easier, the first thing to do 
is split apart the character. Choose the Edit > Select All 
menu command. All the points in the right arm (your 
right, his left) should be selected.

3.	 Activate the Transform Points tool and drag the mouse 
to move the arm off to the side and up a bit:

 Transform Points
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 Arm moved off to the side

4.	 Select the Head layer, and select all of its points with 
the Edit > Select All command. Move all of its points 
upward.

5.	 Repeat the process for the R Leg, L Leg, and L Arm 
layers of the character (skip the Torso layer). Select all 
points on each of those layers, and move the body 
parts away from the center, as shown below:

The reason we split apart the character is so 
that we can add bones to each part, while 

keeping the bones independent of each other. 
Later in the tutorial we’ll put the character back 
together again.

 Body parts split apart
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Add Bones
The next step is to add bones.

Add a new Bone layer to the project. Name the new Bone 
layer Skeleton. Move the new Bone layer to the top of the 
list if necessary.

 Create a new Skeleton bone layer and move it to the top.

1.	 Move all the vector layers into the new Skeleton layer, 
keeping the same order they are in now:

 Move all of the body part layers into the Skeleton bone layer.

2.	 Double-click the Skeleton bone layer to open the Layer 
Settings palette. Switch to the Bones tab, and choose 
the Region Binding mode,

3.	 Using the Add Bone tool, add two bones going up 
through the torso, starting with the bottom one:

 Add Bone Tool



Anime Studio Debut 10
Tutorials

113

Bones

 Two new bones

4.	 Next, add two bones to one of the arms, starting at the 
shoulder and going down.

5.	 Before you add bones to the second arm, use the 
Select Bone tool to reselect the upper torso bone. Then 
switch back to the Add Bone tool to add two bones 
to the other arm. This parents the second arm to the 
upper torso bone instead of continuing from the first 
arm.

 Arm bones added

6.	 Use the Select Bone tool to select the lower torso bone. 
Then, select the Add Bone tool and add three bones to 
one leg, starting at the hip and moving down through 
the foot. Repeat the process for the other leg, making 
sure to reselect the lower torso bone first. The upper leg 
bones should be parented to the lower torso bone.
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 Leg bones added

7.	 Use the Select Bone tool to select the upper torso 
bone, and then use the Add Bone tool to add one 
bone to the head.

 Head bone added

8.	 The next figure shows the parenting of all the bones. 
The parenting arrows point from child bone to parent 
bone, and can be seen by activating the Reparent 
Bone tool:
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 Reparent Bone Tool

 All the bones added

 Manipulate Bones Tool

Adjust Bone Influence
At this point, feel free to try using the Manipulate Bones tool 
to see how the bone system works so far. The body parts 
should mostly move how you would expect, but not totally 
cleanly - the next step is to clean up the bones’ influence.

1.	 Double-click the Skeleton layer in the Layers window to 
bring up the Layer Settings dialog.

2.	 Go to the Bones tab and set the binding mode to 
Region binding:
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 Turn on region binding

When region binding is used, bones only 
move the points that lie in their region of 

influence. If a point is overlapped by multiple regions 
of influence, it will be affected by all the 
corresponding bones. If a point is in no bone’s region 
of influence, it will move with the nearest bone.

This is different from flexi-binding, where all bones 
affect all points. Flexi-binding can be quicker to set 
up, but leads to more rubbery motion, since moving 
a hand will always cause a little bit of movement in 
a foot. Region binding makes separate body parts 
truly separate.

3.	 For region binding to work, you need to adjust the 
region of influence for each bone. To do this, activate 

the Bone Strength tool to display the bones’ regions of 
influence:

 Bone Strength Tool
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 Initial regions of influence

4.	 Using the Bone Strength tool, click and drag on each 
bone in turn to adjust its region of influence. The correct 
adjustment for a region of influence it generally to 
surround the points along that section of bone. The 
most important regions are at the joints - the knees 
and elbows and such. Those are the areas where the 
regions of two bones overlap, and points will bend 
under the control of both bones. For parts like this 

character’s head, the region of influence isn’t very 
important - since there’s just one bone, the points 
outside the region of influence will still move with that 
bone. Here’s how you should adjust the regions of 
influence (don’t worry about matching this exactly, just 
try to get kind of close):Adjusted regions of influence.

 Adjusted regions of influence
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5.	 Try using the Manipulate Bones tool again to test the 
bone setup. The character should move much more 
cleanly now - when moving an arm, for example, only 
that arm should move, and you should see no extra 
movement in other body parts.

 Manipulate Bones Tool

Put the Character Back Together
The final step is to reassemble the character.

Activate the Offset Bone tool.

 Offset Bone Tool

6.	 Click and drag on the top bone of each body part to 
move that part back into position. When each part is 
moved back into place, the character should look as 
shown in the following figure:

�� Move each arm by the upper arm bone

�� Move each leg by the thigh bone

�� Move the head by its single bone.

 Re-assembled character



Anime Studio Debut 10
Tutorials

119

Bones

Frame 0 is considered the setup frame for 
bones. When the time is set to frame 0, the 

character will still appear split apart (unless you’re 
using the Offset Bone or Manipulate Bones tools). 
However, at other frames in the animation, the 
character will be re-assembled according to how 
you used the Offset Bone tool.

7.	 Try moving the character around again with the 
Manipulate Bones tool. The body parts will still move 
independently, even though they now overlap. 
Because the bones were set up on a split-apart 
character, that character could be re-assembled while 
still keeping the body parts independent.

 Manipulate Bones Tool

 Final character

If you’re interested in taking a look at the final 
Anime Studio file, it’s named Tutorial 3.4 Final 

and it’s located in the Tutorials > 3 - Bones subfolder 
within your custom content folder.



Anime Studio Debut 10
Tutorials

120

Bones

Tutorial 3.5: Flexi-Binding

Flexi-Binding

Anime Studio 9.5 introduced a new binding 
mode for bones, which is selected by default. 

If you have changed the binding mode for any 
reason, you can double-click the Bone group in the 
Layers palette, and switch back to Flexible binding in 
the Binding Mode section of the tab. “Bones Tab” on 
page 160 in your Anime Studio Users Manual.

For any layer that is a child of a bone group, you can 
select a subset of the bones in the bone group and then 
choose Bone > Use Selected Bones for Flexi-Binding. This 
allows you to isolate the influence of a set of bones from 
the rest of the skeleton (such as a Right Arm bone affecting 
only the right arm). This reduces the need for you to 
separate artwork on Frame 0 and then put it back together 
again with the Offset Bone tool.

To illustrate how this works, assume you have drawn a 
character in 2D format. The various body parts appear in 
separate layers in a layered Photoshop file that you have 
imported into Anime Studio.

Next, you create a bone layer and drag the layers for the 
character into the Bone layer. Then you use the bone tools 
to create a skeleton for the character so that you can 
animate it. An example for the character and skeleton are 
shown in the following figure.
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 A layered character and its bones.

If you try to animate this layered character using standard 
flexi-binding, you find that the drawing distorts and 
stretches all the artwork. In previous versions of Anime 
Studio, you could break apart the bones and spread 
the artwork and bones apart, and then use the Offset 
Bone tool to put the parts together again, as described in 
“Tutorial 3.4: Character Setup” on page 109. However, 
sometimes it can be difficult to set up your character this 
way and it may not end up looking the way you want it to 
look.

 The character distorts when the bones are manipulated.
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To set up the project so that the arm artwork is only 
affected by the arm bones:

1.	 Select the Arm layer in the Layers palette.

2.	 Use the Select Bone tool to select the bones you want 
to control the arm.

3.	 Choose Bone > Use Selected Bones for Flexi-Binding.

 Assigning selected bones for Flexi-Binding.

4.	 Repeat the above steps for each of the layers in your 
character. In other words, in this example we choose 
the Head layer and flexi-bind selected bones to it, then 

do the same for the Torso, Left Arm, Right Leg, and Left 
Leg.

 Assigning selected bones for Flexi-Binding.
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Tutorial 4.1: Image Layers
This tutorial introduces another type of layer in Anime 
Studio: Image Layers. Image layers are a way of including 
artwork created in other programs in a Anime Studio 
project. Any application that can produce image files can 
be used with Anime Studio: photo editors, 3D modeling 
programs, natural media painting programs, the list goes 
on...

An image layer in Anime Studio contains a single image 
file that can be used as a background, or combined with 
a bone layer to build a character. Although they’re called 
Image layers, an Image layer can also make use of a 
movie file as its source. Image layers and vector layers can 
be mixed and matched in the same project.

Alpha Channels
You’ll notice that the images used in this tutorial do not 
appear rectangular. This is because they make use of 
an alpha channel to mark some parts of the image as 
transparent. We recommend using PNG images with 

Anime Studio because they support full alpha channel 
transparency. You’ll need to use an image editing 
program (like Adobe Photoshop) to create images with 
transparency.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 4.1 and it’s located in the 
Tutorials > 4 - Images subfolder within your custom content 
folder.

Open the Tutorials > 4 - Images > Tutorial 4.1 file in Anime 
Studio. This project is almost complete as it is. The only thing 
that’s missing is the dancer’s left hand.

5.	 Expand the Hula Girl layer in the Layers window, and 
you should see something like this:
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 Starting point for this tutorial

6.	 Click on the layer named L Arm (we want the new 
layer to be just above the left arm).

7.	 Click the New Layer button in the Layers window to 
create a new layer. In the popup menu that appears, 
choose Image.

Create a new Image layer

8.	 Anime Studio will prompt you to select an image file. 
Choose the Anime Studio/Tutorials > 4 - Images > 
l_hand.png image in your custom content folder.

9.	 In the Layers window, double-click the new layer and 
rename it L Hand. At this point, your Layers window 
should look like this:
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 Left hand added

 The new hand

10.	 You’ll notice that new image layers are centered in the 
workspace, so the dancer’s hand is not yet properly 
aligned: To position the arm properly, use the Transform 
Layer tool to drag the left hand into position at the end 
of the left arm. Allow for a little overlap between the 
two parts at the elbow:
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 Transform Layer

 Left hand in position

11.	 The last step is to attach the new part to the dancer’s 
skeleton. Select the Bind Layer tool, and click on the 
lower arm bone on the dancer, as shown below:

 Bind Layer Tool

 Bind the image layer to the forearm
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You’re done! To see the animation in action, press the Play 
button. Of course, we skipped over the process of building 
and animating the skeleton, but the basics of working with 
skeletons were covered in previous tutorials - all of that 
information applies when using bones with image layers.

Tutorial 4.1 Result. (Click to play movie)

Tutorial 4.2: Image Warping
This tutorial demonstrates Anime Studio’s image warping 
feature. This feature allows you to use a skeleton to distort 

an image. In this way, you can animate photographs, 
hand-drawn artwork, or anything you can get into an 
image file in a flexible way.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 4.2 and it’s located in the 
Tutorials > 4 - Images subfolder within your custom content 
folder.

Open the Tutorials > 4 - Images > Tutorial 4.2 file in Anime 
Studio.

1.	 Expand the Skeleton layer in the Layers window, and 
you should see something like the following figure. The 
Skeleton bone layer contains two sub-layers: an image 
layer (statue.png) and a vector layer (vector sample).

 Starting point for this tutorial
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2.	 Click the Play button in the timeline to play back the 
animation. Notice that only the vector layer moves 
with the skeleton. The reason that the image layer isn’t 
moving is that it hasn’t been connected to the bones 
yet (as the vector layer has been).

 Only the vector layer moves

Using Image Warping
To warp the image layer with the skeleton, continue with 
the project as follows:

1.	 Double-click the statue.png layer, and go to the Image 
tab in the Layer Settings dialog. Turn on the checkbox 
marked Warp using bones and click OK.
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Turn on the Warp using bones option

2.	 In the Layers window, turn off the visibility for the vector 
sample layer (it is only an example, and we don’t want 
it in the final animation).

Hide the vector sample layer

3.	 Play back the animation again, and you should now 
see the image moving with the skeleton:
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 Image warping

Notice the horizontal bone at the base of the 
statue. This bone doesn’t move at all in the 

animation, so why is it even there? When using 
image warping, the image is distorted by all the 
bones in the skeleton, and the nearest bone to any 
part of the image has the most influence. We don’t 
really want the base of the statue to move, so an 
easy way to prevent this is to add a bone in the area 
we want to remain still, and not animate it. Another 
trick you might use when warping images is to break 
up an image into logical parts (for example, make 
the arms and legs of a person separate images from 
the main body). Then, use different skeletons to 
control the various re-assembled parts. This way, a 
leg bone can’t have any influence over an arm.

Tutorial 4.3: Image Textures
In this tutorial you will learn how to use images as textures to 
add detail to a character.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 4.4 and it’s located in the 
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Tutorials > 4 - Images subfolder within your custom content 
folder.

1.	 Open the Tutorials > 4 - Images > Tutorial 4.4 file in 
Anime Studio, and you should see something like this:

 Starting point for this tutorial

2.	 Play back the animation to see what’s going on.

3.	 Be sure to rewind the animation to frame 0 before you 
continue with the next section.

4.	 Paint the Textures

What you’re going to do is hand paint some texture details 
to go on this character. The first step is to paint some 
textures to go on this headless animal’s body.

1.	 Select the File > Preview menu command to create a 
full-quality view of the animal’s current state.

2.	 In the popup menu at the bottom of the Render 
window, select Copy To Clipboard.

 Rendered animal
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3.	 Start up your favorite image editing program (we 
recommend Adobe Photoshop) and create a new 
document the same size as the Anime Studio project 
(320x240 in this case). Paste the copied image into the 
new document.

4.	 Create a new layer in your image editing program and 
paint some kind of texture details onto the animal’s 
body parts. It’s very important that the texture be on 
a layer of its own. If you’re using Photoshop, the layer 
arrangement would look something like this:

 Layers in Photoshop

5.	 Paint whatever details you want. Here’s an example of 
something you might paint in your image editor. Don’t 
worry about painting outside the lines:

 Painted on texture

6.	 When your texture is finished, get rid of the background 
layers so that only the texture is left with a transparent 
background (you’re still working in Photoshop or similar 
program at this point):
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 Background removed

7.	 You need to save the texture as three separate files. 
For each version of the texture, delete the parts of the 
texture that are not attached to the corresponding 
body parts. Save the images in PNG format, since PNG 
properly stores the transparent background. Examples 
of the three textures are shown in the figures that 
follow.

�� Save an image for the back legs. Name the file 
back_tex.png.

�� Save an image for the torso. Name the file body_
tex.png.

�� Save an image for the front legs. Name the file 
front_tex.png.

8.	 After you save your images, you can close the image 
editor. It’s time to bring the textures back into Anime 
Studio.
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 Back legs texture. back_tex.png  Body texture. body_tex.png
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 Front legs texture. front_tex.png

If you’re having trouble creating the image 
textures, we have provided some files for you 

to examine. Look at the file Tutorial 4.4 Texture.psd, 
located in the Tutorials > 4 - Images subfolder within 
your custom content folder - this is the Photoshop 
file. Also, look at the files back_tex.png, body_tex.
png, and front_tex.png, which are the finished 
texture files.

Import Textures
To import your painted textures in Anime Studio, follow 
these steps:

1.	 In the Layers window, highlight the Back Legs layer. The 
image file that you import will be placed above this 
layer.

2.	 Create a new Image layer and select back_tex.png as 
the source image. The new image layer appears in the 
layers list.

3.	 Select the Body layer as the current layer. Create 
another image layer for body_tex.png . The new layer 
should appear above the Body layer.

4.	 And finally, select the Front Legs layer, and create 
a third image layer for front_tex.png. The new layer 
appears above the Front Legs layer. Here’s how the 
new image layers should be arranged:
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 Three new image layers

 Textures applied in Anime Studio

Use Masking for Clean Edges
At this point, the textures are finished and in place, but they 
are a little messy, and go outside the bounds of the actual 
body parts. The final step is to clean up the texture edges 
using layer masking.
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1.	 Double-click the Skeleton layer in the Layers window to 
bring up the Layer Settings dialog. Go to the Masking 
tab, and set the group mask to Hide all:

 Turn masking on for the group

2.	 Next, double-click the Back Legs vector layer to bring 
up the Layer Properties dialog for that layer. Go to the 
Masking tab, and set the masking mode to + Clear 
the mask, then add this layer to it. What this masking 
mode does is make all objects invisible, except where 
this layer has solid areas. So, the back_tex.png image 
layer will only be visible directly on top of the Back Legs 
vector layer, preventing the texture from going outside 
the lines of the back legs.

 Set the masking mode for the Body layer



Anime Studio Debut 10
Tutorials

138

Images

The Back Legs layer with mask

3.	 Repeat step 2 for the Body and Front Legs vector 
layers. Set the masking mode to + Clear the mask, then 
add this layer to it, just like you did for the back legs. 
At this point, all the textures should be forced to stay 
inside the lines:

 Textures cleaned up with masking

4.	 Play back the animation again and you’ll see the 
image layers warp along with the vector layers in 
response to bone movement.
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After all the preparation time drawing your objects, 
assigning fill colors, and setting up bones, you move on to 
animating them. This is where things actually start to move 
around.

Animating in Anime Studio is based on the concept of 
keyframes. A keyframe is a point in time where you position 
some object (either a point, a bone, or an entire layer). 
A keyframe tells Anime Studio exactly where that object 
should be and when. Keyframes are set up at important 
moments in time - typically where an object begins 
moving, stops moving, or changes direction. Between 
keyframes, Anime Studio automatically calculates how 
to move an object so that it gets from one keyframe to 
the next in the amount of time allowed between the 
keyframes.

To create a keyframe, just set the current time to whenever 
you want the keyframe to occur, then move the object 
to the desired position. Controlling the current time and 
working with keyframes after they’ve been created is 
discussed in “Chapter 16: The Timeline Window” on page 
213 in your Anime Studio Users Manual.

You can animate several types of motion in an Anime 
Studio project, and they can each be used alone or in 

combination. The first type is point motion. Point motion 
very basic - it just involves moving individual points around 
in time. Point motion is good for small distortions to an 
object where you want something to look soft and flexible 
(turning up the corners of a mouth into a smile, bulging out 
a belly, etc.). You can move a shape in any way you want 
with point animation, but it might require manipulating a 
lot of points - in many cases bone animation can simplify 
the job.

Bone animation involves setting up a skeleton system for an 
object and then moving the skeleton around. By carefully 
constructing a skeleton, you can easily move a character 
around like a puppet.

Layer animation is for very simple, large-scale motion. 
When you move a layer, everything in it moves together. 
This doesn’t give you a lot of flexibility as far as what you 
can animate this way, but it’s a good way to get certain 
effects. If you want an entire group of objects to pan side 
to side or zoom in or out, then layer animation is the tool to 
use.

The keyframes you define are visible in the Timeline, starting 
at frame 1. Frame 0 is a special frame in an Anime Studio 
project - the original placement of all your objects is stored 
at frame 0. If you want to modify an object’s original shape 
or position, or add new objects, this should be done at 
frame 0. Whatever you do to an object in later frames can 
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never affect an object’s original shape and position, so 
even if you think you really screwed something up, you can 
always delete some keyframes and get back your original 
drawings.

This chapter has a useful hands-on overview of how to 
animate in Anime Studio, using each type of motion (point, 
bone, and layer). Once you’ve mastered Anime Studio’s 
animation tools, animating is a simple job of repeatedly 
using the tools you already know, keyframe by keyframe.

Tutorial 5.1: Automatic Lip-Sync
This tutorial uses Anime Studio’s Switch layers to show you 
how to perform instant, automatic lip-syncing. A switch 
layer contains multiple sub-layers, but only one of the sub-
layers can be displayed at a time. This makes it very useful 
for lip-sync animation: each sub-layer can be a mouth 
shape for a different sound.

The method of lip-sync described in this tutorial is quick and 
easy, though not always super-accurate (but give it a try - 
it may be accurate enough for your animation).

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 5.1 and it’s located in the 

Tutorials > 5 - Animation subfolder within your custom 
content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.1 file in 
Anime Studio, expand the Mouth layer in the Layers 
window, and you should see something like this:

 Starting point for this tutorial

2.	 Examine the sub-layers in the Mouth layer. Notice that 
from bottom to top they range from closed to wide 
open. This is the basic setup for automatic lip-syncing. 
The number and names of the sub-layers don’t matter, 
as long as the lowest one is closed and the highest one 
is wide open.



Anime Studio Debut 10
Tutorials

141

Animation

 Layers in the Layers window

3.	 Next, add the audio file that will go along with the lip-
syncing. Choose the File > Import > Audio File menu 
command and select the Tutorials > 5 - Animation > 
MaryLamb-Man.wav file in your custom content folder.

4.	 Make sure that you select the File > Import > 
Audio File command from the lower section of 

the file menu. This differs from the File > Import > Audio 
command in the upper section of the menu, which is 
used to open files in the Anime Studio library.

 File > Import > Audio File command

5.	 Play back the animation now to hear the result. You’ll 
notice that the mouth doesn’t move yet. Stop the 
playback before proceeding.

6.	 Double-click the Mouth layer. When the Layer Settings 
dialog opens, click the Switch tab:
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 Layer settings for the mouth

7.	 Click the Select audio sync source button to select the 
file that will control the Switch layer. In the file dialog 
that appears, select the file MaryLamb-Man.wav. Click 
the dialog’s OK button.

That’s it! The audio file was analyzed and keyframes 
were attached to the Switch layer. When the audio is 
quiet, Anime Studio activates the lowest layer (the closed 
mouth), and when the audio is loudest, Anime Studio uses 
the highest layer (the wide open mouth). In between, 
Anime Studio switches on the in between mouths. Play 
back the animation to see and hear the result. In general, 
because automatic lip-sync is based on the actual sound 

in the audio file, it is important to use an audio file without 
background noise or music.

Tutorial 5.1 Result. (Click to play movie)

Tutorial 5.2: Phoneme Lip-Sync
This tutorial covers another method of animating lip-sync. 
With this method, the lip-sync is based on phonemes. 
Phonemes are the basic building block sounds that make 
up words. When you do lip-sync based on phonemes, it 
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requires you to break down the words of dialog into their 
basic sound elements.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 5.2 and it’s located in the 
Tutorials > 5 - Animation subfolder within your custom 
content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.2 file in 
Anime Studio.

2.	 Expand the Head layer in the Layers window, and you 
should see something like this:

 Starting point for this tutorial

3.	 This project is almost complete. The only thing 
apparently missing is the animation for the character’s 
mouth. Play back the animation. The mouth is there (it’s 
a switch layer), but no animation data has yet been 
assigned to it, so it doesn’t move.

4.	 Double-click the Mouth layer. When the Layer Settings 
dialog opens, click the Switch tab:

 Options in the Switch tab

5.	 Click the Select audio sync source button to select the 
switch data file that will control this switch layer. In the 
file dialog that appears, select the file vista.dat located 
in the Tutorials > 5 - Animation subfolder within your 
custom content folder.
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The Mouth layer contains all the mouth 
shapes needed to speak any phrase. You 

can examine the Mouth layer to see the sub-layers it 
contains. Each sub-layer is named after a different 
phoneme. You can use any set of phonemes you 
choose. The mouth shapes in this mouth are based 
on the same default set used by a great (and free) 
lip syncing program that we recommend: 
Papagayo (http://www.lostmarble.com/
papagayo/) is a good place to get started. To 
make the mouth speak a different phrase, just 
create a different animation data file in Papagayo, 
and select it into the mouth layer as we just did for 
the vista.dat example.

6.	 To hear the sound along with the animation, choose 
the File > Import > Audio File command from Anime 
Studio’s menu and select the vista.wav file located in 
the Tutorials > 5 - Animation folder.

7.	 Now, when you play back the animation in Anime 
Studio you will hear the audio that goes with the lip-
sync. Also, if you export the animation as a QuickTime 
or AVI movie, the audio will be included in the movie 
file.

If you plan to export your animations to Flash 
(SWF) format, you will need to use MP3 audio 

files instead of WAV audio files. In addition, if you 
plan to render to SWF format, you can only use a 
single audio file in the project.

Tutorial 5.2 Result. (Click to play movie)

http://www.lostmarble.com/papagayo/
http://www.lostmarble.com/papagayo/
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Tutorial 5.3: Cycling
It is possible in Anime Studio to automatically cycle a 
section of animation, repeating it over and over as many 
times as you wish. Cycling is a special type of keyframe 
interpolation, and this tutorial will show you how to set it up.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 5.5 and it’s located in the 
Tutorials > 5 - Animation subfolder within your custom 
content folder.

1.	 Open the Tutorials > 5 - Animation > Tutorial 5.5 file in 
Anime Studio.

 Starting point for this tutorial

2.	 In the timeline, you can see that the top layer, Red 
Blinker, has two keyframes in the Layer Visibility 
channel. The layer becomes invisible at frame 36, and 
visible again at frame 48. This is also shown by the red 
background in the timeline during the layer’s invisible 
period:
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 Starting point for this tutorial

3.	 You can play back the animation to see what’s going 
on. Basically, the red light starts off turned on, then it 
shuts off for a while and finally turns back on.

4.	 Using cycling, you can make the light blink over and 
over. Right-click on the second keyframe (the one 
at frame 48), and in the popup menu that appears, 
select Cycle.... You’re telling Anime Studio that after 
this keyframe, you want the animation to cycle back to 
an earlier point in the animation. A dialog will appear 
asking you the specifics of the cycling. Enter 12 as 
shown below:

 Cycle settings

5.	 When you click OK in the cycle dialog, the timeline will 
update to show the cycle. There are three changes 
you will see:

6.	 The keyframe in question will change to a left-pointing 
arrow to indicate that it cycles backwards.

�� A long red arrow will point back to the point in the 
timeline that the visibility channel is cycling back to.

�� Later in the timeline you will see other sections 
with red backgrounds to indicate that the layer is 
invisible during those periods:
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 Cycling reflected in the timeline

7.	 You can play back the animation again to see 
the result. The Red Blinker layer will flash on and off 
multiple times, even though you didn’t add any more 
keyframes - the Layer Visibility channel is just cycling 
back and repeating a section of animation over and 
over again.

8.	 Let’s try adjusting the cycle duration. In the Timeline 
window, hold down the Ctrl key (Windows) or Cmd 
key (Mac) while you click and drag on the second 
keyframe (the one that cycles). As you drag the mouse 
side-to-side, you’ll see that the cycle duration changes, 
as the arrow that points back from the cycling key gets 
longer and shorter. Adjust the cycle duration so that 
the keyframe cycles back to frame 24:

 Adjusted cycle duration

9.	 If you play back the animation now, you’ll see that the 
light blinks more quickly now, since the cycle duration 
is shorter.

10.	 Finally, to break a cycle, all you have to do is add 
another keyframe when you want the cycle to end. 
Set the current frame to 102, right click in the Layer 
Visibility channel, and select Add Keyframe from the 
popup menu that appears. The new keyframe will 
appear, and at that point the cycling will end. Play 
back the animation to confirm this.
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 New keyframe at frame 102

Conclusion
Cycling can be used in any animation channel in Anime 
Studio. Any keyframe can be made to cycle back in time 
by setting Cycle as the key’s interpolation method. You 
can cycle a channel all the way back to the beginning of 
an animation, or just back a few frames. Cycling will repeat 
itself forever or until a new keyframe is reached.
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Tutorial 6.1: Shadow Tricks
This tutorial shows you how the layer shadow options can 
be used to create visual effects other than shadows. Glows 
and outlines are the two possibilities we’ll look at.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 6.6 and it’s located in the 
Tutorials > 6 - Effects subfolder within your custom content 
folder.

Open the Tutorials > 6 - Effects > Tutorial 6.6 file in Anime 
Studio. Render this file to see what it looks like to start with:

 Starting point for this tutorial

Basic Layer Shadow
Before we try any tricks, let’s take a look at a basic layer 
shadow.

Double-click the only layer in this file, Layer 1, to bring up 
the Layer Settings dialog.
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1.	 Go to the Shadows tab, and leaving all the other 
settings alone, turn on the Shadow on checkbox. Click 
OK to dismiss the dialog.

 Default shadow settings

2.	 Try rendering the scene again, just to be sure that you 
have an idea what a regular layer shadow looks like in 
Anime Studio:

 Layer shadow

Layer Glow
Now we’ll change the shadow settings to create a glow 
effect.

Double-click Layer 1 again to bring up the Layer Settings 
dialog. Change the Layer Shadow settings to match the 
values below:
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 Glow settings

�� An offset of 0 means the shadow will be centered 
under the layer that is casting it. With an offset of 0, 
the shadow direction has no significance.

�� A high blur value of 16 gives the glow a nice soft 
edge.

�� The expansion parameter tells Anime Studio to 
expand the shadow, making it bigger than the 
layer itself. Without expansion, the glow would just 
barely extend beyond the edge of the layer.

�� The exact color you choose is not important - just 
be sure to make the color opaque (Alpha = 255). A 
transparent glow may be too faint to see.

�� Render the scene again, and it should look like this:

 Layer glow.
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Layer Outline
Let’s change the shadow options once again to create 
an outline effect. Some styles of animation use a heavier 
outline around the outside of objects than for interior lines. 
Adjusting the layer shadow values in the right way can 
make this style very easy to accomplish.

Double-click Layer 1 again to bring up the Layer Settings 
dialog.

1.	 Change the Layer Shadow settings to match the 
values below:

�� Again, we use an offset of 0 to keep the shadow 
centered under the layer.

�� A blur value of 0 is used to keep a hard edge on 
the shadow.

�� The expansion parameter is used in this case to set 
the width of the outline effect.

�� For this effect, it’s important to make the color 
totally black and totally opaque (Alpha = 255) to 
match the interior lines.

 Outline settings.

2.	 Render the scene again, and it should look like this:
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 Layer outline

Tutorial 6.2: Camera and Depth 
Effects
This tutorial demonstrates Anime Studio’s camera tools. 
These tools allow you to move an entire scene around as if 
you were pointing a camera at it. With a little setup work, 
you can even create different layers of depth in the scene.

Start With a Sample File
For this tutorial, we’ll start with a project file that’s almost 
finished. It’s named Tutorial 6.7 and it’s located in the 
Tutorials > 6 - Effects subfolder within your custom content 
folder.

1.	 Open the Tutorials > 6 - Effects > Tutorial 6.1 file in 
Anime Studio, and you should see something like this:

 Starting point for this tutorial

2.	 This file contains a few layers of simple scenery that 
we will move the camera across. To do this, select the 
Track Camera tool and drag the mouse around in the 
main editing area.

 Track Camera Tool
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3.	 Notice how all the layers move together, even though 
they aren’t grouped. When you move the camera 
around, it affects all the layers in a project. In the tool 
options area at the top of the main Anime Studio 
window, click the Reset button to reset the camera.

Creating Depth
Now we’ll introduce some depth into the scene.

1.	 Activate the Transform Layer tool and select the layer 
called Right Hill.

 Transform Layer

2.	 In the tool options area at the top of the main Anime 
Studio window, change the Z value to -1 and press 
Enter. Below you can see where to set the Z value for 
the layer.

Setting a layer’s Z value

3.	 Now select the Left Hill layer, and set its Z value to 
-2. Finally, select Sky, and set its Z value to -20. When 
you’re finished, your scene should look similar to the 
following figure.



Anime Studio Debut 10
Tutorials

155

Effects

 Right Hill, Left Hill, and Sky layers moved on the Z plane

4.	 Try dragging the Track Camera tool around again and 
notice the difference. It’s like driving in a car - nearby 
objects go by quickly, while distant objects seem to 
move slowly.

5.	 In the tool options area at the top of the main Anime 
Studio window, click the Reset button to reset the 
camera.

 Track Camera Tool

6.	 When you’ve seen enough, select the View > Reset 
menu command to go back to the default camera 
view.

Animating Camera Movement
Now we’ll try animating the camera.

1.	 Make sure the current frame is set to 0, and select the 
Track Camera tool.

 Track Camera Tool

2.	 Drag to the left in the main editing area until you set up 
a view that looks about like this:
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 Camera view at frame 0

3.	 Next, set the current frame to 72, and drag to the right. 
This will pan the camera to the left - keep going until 
you have a view that looks like this:

 Track to the left

4.	 Press the Play button in the timeline to play back this 
simple camera animation. Notice how the layers of the 
project seem to pass in front of and behind each other. 
This is a simple way in Anime Studio to create a sense 
of depth.
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Tutorial 6.2 Result. (Click to play movie)

Tutorial 6.3: Moon and Clouds 
Effect
This tutorial shows you how to create the effect of clouds 
moving in front of a moon. Layer masking and blurring is 
used to create an effect that is not only good for a moon 
and clouds, but may inspire you to think of new ways to use 
layer masking.

Examine a Finished Animation
For this tutorial, we’re going to examine an animation that 
is completely finished.

1.	 Open the Tutorials > 6 - Effects > Tutorial 6.9 file in 
Anime Studio. The layers in this file are arranged as 
shown below:

 Starting point for this tutorial

2.	 This animation relies on masking and blurring effects 
that aren’t apparent in Anime Studio’s editing view. To 
see what the final effect is, either export the animation 
as an AVI or QuickTime movie. (Because blurring is a 
key part of this effect, exporting to SWF is not an option 
- SWF export does not support blurs.)
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 The final result

Notice that the moon appears sharp until the cloud moves 
in front of it. Then, the parts of the moon obscured by the 
cloud become blurry. This effect is easy to achieve using 
layer masking.

How It’s Done
There are two parts to this effect. First, there are actually 
two moons in the animation:

•	 The Moon layer is the regular, sharp version of the 
moon you see in Anime Studio’s editing view.

•	 Two layers up is the Blurry Moon layer - this is a 
duplicate of the Moon layer, with some layer blur 
applied.

The trick is to control which moon is visible at which point 
in time in the final exported movie. To do this, we use layer 
masking.

Try double-clicking each of the layers in turn to bring up the 
Layer Settings dialog - then, go to the Masking tab. You’ll 
find that the Sky group has masking turned on - by default, 
all objects are invisible. The Moon layer is set to be immune 
to masking, while the Cloud layer adds to the layer mask.

The result of these mask settings is that first the Moon layer is 
drawn - this is the regular, sharp moon - and is not affected 
by any masking. Next, the Cloud layer is drawn on top of 
that. When the cloud moves in front of the moon, it covers 
up the moon. Finally, the Blurry Moon layer is drawn on top 
of the cloud. Because of the mask, the blurry moon only 
appears on top of the cloud, it is not visible outside of the 
cloud object. Even though the blurry moon is in front of the 
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clouds, the effect looks like the moon shining from behind 
the clouds.

Here’s another example of the same technique. In this 
case, we see a character who appears to be blurred by 
the smoke passing in front of him. The exact same blurring 
and masking trick is used as in the case of the moon:

 Another example of blurring and masking
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