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Installing Your Software

 

The following information is intended to get you up and running with Shake 4.1 as 
quickly as possible and covers the following topics:
Â

 

About the Contents of Your Shake Box (p. 2)
Â

 

About Onscreen Help (p. 3)
Â

 

Shake 4.1 System Requirements (p. 4)
Â

 

Installing Shake (p. 5)
Â

 

Registering Shake (p. 6)
Â

 

Installing and Licensing Shake for Render-Only Workstations (p. 7)
Â

 

Installing Apple Qmaster 2.1 (p. 7)
Â

 

About Installing Software and Saving Files (p. 11)

 

Important:  

 

Be sure to review the 

 

Before You Install Shake 4.1

 

 document on the Shake 4.1 
installation disc). For the latest information on Shake, go to the Shake website at
http://www.apple.com/shake.

http://www.apple.com/shake
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About the Contents of Your Shake Box

 

Your Shake box contains the following software and documentation.

 

Installation Disc

 

The Shake 4.1 installation disc:

 

  This is your installation disc. Use this CD to install the 
Shake and Apple Qmaster software and documentation.

 

Printed Documentation

 

The following printed instructional material is included in your Shake box:
Â

 

Shake 4 User Manual:

 

  Provides information on new features, the Shake user interface, 
image input and output, the compositing nodes and Node View, file formats and 
footage, keying, color correction and color space, using masks and transforms, 
working with the Curve Editor and the Time View, painting and rotoscoping tools, 
using filters, customizing Shake and making macros, and rendering.

Â

 

Shake 4 Tutorials:

 

  Provides step-by-step instructions for general Shake workflow and 
the user interface, basic color correction, using the Z channel, using local variables 
with expressions, color correction on premultiplied elements, using Keylight and 
Primatte, tracking, how to make a macro, and how to create a simple clean plate.

 

Note:  

 

Tutorial media for use with the 

 

Shake 4 Tutorials

 

 is included on the 

 

Shake 4.1 

 

installation CD, in the 

 

Tutorial_Media

 

 folder. 

 

PDF Documentation

 

The following PDF documentation is located in the Documentation folder on the 
Shake 4.1 installation disc.
Â

 

Shake 4 User Manual
Â

 

Shake 4 Tutorials
Â

 

Shake 4 New Features
Â

 

Installing Your Software
Â

 

Apple Qmaster User Manual
Â

 

Truelight User Manual
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About Onscreen Help

 

Onscreen help (available in the Help menu) allows you to access information 
onscreen while you are working in the Shake or Apple Qmaster application. Onscreen 
user manuals are available here, as well as links to other documentation and related 
Apple websites. 

 

Onscreen Documentation

 

The 

 

Shake 4 User Manual, Shake 4 Tutorials, Shake 4 New Features, 

 

and 

 

Late-Breaking 
News 

 

are accessible via the Help menu of the Shake application. The 

 

Apple Qmaster 
User Manual

 

 and Apple Qmaster 

 

Late-Breaking News

 

 are available in the Help menu of 
the Apple Qmaster application. Documentation for the bundled Truelight features is 
included in the Documentation folder of the Shake 4.1 installation disc. In Shake, there 
is also a Help button located in the Parameters tab of each function. This button 
opens an HTML page that describes the function. An additional HTML page that 
contains information on customizing Shake can also be accessed from the Help menu. 
These HTML pages (the function pages and the customizing section) include the same 
content as the 

 

Shake 4 User Manual.

 

To access Shake onscreen help:
m

 

In Shake, choose Shake User Manual, New Features, Tutorials, or another option from 
the Shake Help menu.

The onscreen PDFs are interactive and contain links for easy navigation. To quickly find 
a specific topic, use the bookmarks or the interactive index.

 

Note:  

 

The Shake documentation files are also available in two other places:

Â

 

In the Documentation folder of the Shake 4.1 disk image that you downloaded.
Â

 

In the /Applications/Shake/doc folder

 

To access onscreen help for a specific Shake function:
1

 

In the Node View, click the right side of the node to load its parameters.

 

2

 

In the Parameters tab, click the Help button.

Information about the currently selected node appears in your web browser.

 

Note:  

 

In the printed user manual, function information is included in its associated chapters. 

 

To access the onscreen help for customizing Shake:
m

 

Choose Help > Customizing Shake.

 

Note:  

 

In the 

 

Shake 4 User Manual

 

, extensive information on customizing is located in 
Chapter 14, “Customizing Shake.”
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To access Apple Qmaster onscreen help:
m

 

In Apple Qmaster, choose Help > Apple Qmaster Help; in Apple Qadministrator, choose 
Help > Apple Qmaster Help; in Batch Monitor, choose Help > Batch Monitor Help. 
(Batch Monitor is the utility installed with the Apple Qadministrator and Apple Qmaster 
Client components.)

 

Late-Breaking News

 

The Late-Breaking News option in the Help menu links to a PDF document that 
contains information about issues with third-party hardware and software, and other 
known issues.

 

To access Late-Breaking News:
m

 

In the Shake application, choose Help > Late-Breaking News.

m

 

In Apple Qmaster or Apple Qadministrator, choose Help > Late-Breaking News.

 

Note:  

 

You must be connected to the Internet to download the 

 

Late-Breaking News

 

 
document.

 

Shake 4.1 System Requirements

 

Before you install Shake 4.1, make sure that your Macintosh system meets the following 
minimum requirements.

 

Minimum Requirements for Desktop Hardware and Software
Â

 

Macintosh computer with 1 gigahertz (GHz) or faster PowerPC G4, PowerPC G5, 
or Intel Core processor

Â

 

Mac OS X v10.4.6 (or later)
Â

 

QuickTime 7.0.4 (or later)
Â

 

512 megabytes (MB) of random-access memory (RAM)—1 gigabyte (GB) RAM 
or more recommended

Â

 

1 GB of available disk space for caching and temporary files
Â

 

32 MB of video memory and OpenGL hardware acceleration
Â

 

Display supporting 1280 x 1024-pixel resolution and 24-bit color
Â

 

Three-button mouse
Â

 

Optional: 

 

 AJA Kona or Blackmagic DeckLink card required to preview composites 
on a broadcast monitor
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Minimum Requirements for Render-Only Workstations
Â

 

500 megahertz (Mhz) or higher PowerPC G4, PowerPC G5, or Intel Core processor
Â

 

Mac OS X v10.4.6 (or later)
Â

 

QuickTime 7.0.4 (or later)
Â

 

1 GB local disk space for caching and temporary files
Â

 

256 MB of RAM

 

Calculating RAM Requirements

 

Real-time playback is a function of RAM, processor, image size, clip length, and graphics 
card. In Shake, images are loaded into memory and then played back. Current systems 
cannot achieve real-time playback with 2K-resolution images. With sufficient RAM and 
a good graphics card, files of up to 1K resolution should play back in real time.

Use the following formula to determine the amount of required memory:

 

width * height * channels * bytes per channel * images = bytes

 

For example, a single 1024 x 768 RGB 8-bit (1 byte) per channel image is:

 

1024 * 768 * 3 * 1 = 2359296 bytes

 

Or, approximately 2.4 MB per frame.

∏

 

Tip:  

 

To convert from bytes to megabytes (MB), divide by 1024 two times (1024 equals 
the number of bytes per kilobyte). Thankfully, all operating systems come with 
calculators. For a rough approximation, drop the last 6 digits. 

An 8-bit image is 1 byte, a 10 or 16-bit image is 2 bytes, and a float image is 4 bytes.

 

Installing Shake

 

When you install Shake, its components are placed in the Applications folder of the 
hard disk, typically your startup disk. 

 

Important:  

 

Be sure to review “Shake 4.1 System Requirements” on page 4 before 
installing Shake. Also, turn off any virus protection and security software that you may 
have installed on your computer. 

 

To install Shake:
1

 

Insert the Shake 4.1

 

 

 

installation disc into your CD drive.

 

2

 

Double-click the Install Shake 4.1 icon.

 

3

 

Read the Welcome information, then click Continue.

 

4

 

Read the Software License Agreement, then click Continue and Agree.

 

5

 

Select the destination volume where you want to install Shake, then click Continue.

 

6

 

Click Install.
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Note:  

 

If you have previously installed other Apple Pro Applications, this button may be 
labeled Upgrade instead of Install.
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In the Authenticate dialog, enter your administrator name and password, then click OK.
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When the installer is finished, click Close.

By default, Shake is installed into a folder named 

 

Shake

 

 in the Applications folder on 
your hard drive. 

 

Shake Folder Contents

 

When Shake is installed, three icons appear within the Shake folder:  

 

shake

 

, 

 

shkv

 

,

 

 

 

and

 

 
shkqtv

 

. The shake icon represents the Shake application, and can be placed in the Dock. 
The shkv icon represents the Shake Viewer application (the Flipbook player for all 
platforms). The shkqtv icon represents the Shake Disk-Based Viewer application (the 
QuickTime Flipbook player). You cannot launch shkv

 

 

 

or

 

 

 

shkqtv

 

 

 

outside of Shake. When 
you create a standard or disk-based Flipbook in Shake, Shake Viewer is automatically 
launched and the 

 

shkv

 

 or 

 

shkqtv 

 

icon appears in the Dock.

 

To serialize and start Shake:
1

 

Double-click the Shake icon (if starting Shake from the Dock icon, single-click).

 

2

 

In the Licensing dialog, enter your first and last name.

 

Note:  Entering an organization name is optional.

3 In the Serial Number box, enter the Shake 4.1 serial number printed on the front of 
this document.

4 Click OK.

Registering Shake
The first time you start Shake, the application prompts you for registration information. 
By default, the Me card information in your Address Book is automatically entered in 
the appropriate fields.

To register Shake to a user other than the user listed in the Me card 
in your Address Book:

1 Fill out the Name, Address, Organization, and Email address fields.

2 If you want information about Apple news and software updates sent to your email 
account, select the checkbox.

3 If you want to review Apple’s Privacy Policy, click Privacy Policy.

4 When you are finished, click Register Now.

You are now ready to begin using Shake.

Note:  If you decide to click the Register Later button, you will be prompted to register 
again after opening the application five times.
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Installing and Licensing Shake for Render-Only Workstations
To install the render-only version of Shake, perform the installation as described in 
“Installing Shake” on page 5 on all systems intended for use as render workstations. 
Mac OS X render licenses are free, and do not require serial numbers or special licensing.

Installing Apple Qmaster 2.1
Apple Qmaster 2.1 is available via a separate installer on the Shake installation disc. 
For more information on the Apple Qmaster 2.1 components and installation, see the 
Apple Qmaster User Manual, located in the Documentation folder of the Shake 4.1 
installation disc.

Minimum Requirements for Apple Qmaster 2.1
Â Mac OS X v10.4.4 (or later) 
Â QuickTime 7.0.4 (or later)
Â 160 MB available disk space for application installation.

Apple Qmaster Installation Components
The Apple Qmaster 2.1 installer places Apple Qmaster and Apple Qadministrator 
application icons in the Applications folder, and the Batch Monitor application icon in 
the /Applications/Utilities folder. It also installs the Apple Qmaster Preferences pane. 

Each of these applications controls a different part of an Apple Qmaster distributed 
processor system:

Apple Qmaster 
Application/Utility Function Computers That Use It

Apple Qmaster 
application

Application used to submit jobs 
for distributed processing

Â Client computers 
(any computer from which 
you submit processing jobs)

Apple Qadministrator 
application

Application used to create and 
administer clusters of connected 
computers

Â Administrator computers 
(any computer you use to 
create and administer clusters 
of processing computers)

Batch Monitor 
application

Application used to adjust the 
status of processing jobs and 
batches

Â Client computers 
Â Administrator computers

Apple Qmaster pane 
in System Preferences

Settings that configure a 
computer to act as a node in 
a processing system or as a 
controller of a cluster of nodes

Â Service node computers 
(computers that perform the 
actual processing of jobs)

Â Cluster control computers 
(any computer that acts as the 
manager of a cluster–there is 
only one cluster controller 
per cluster)
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While one computer could act as a combination of client, service node, and cluster 
controller, keeping these functions on separate computers generally increases the 
speed and efficiency of processing.

Client computer
from which users work and 

send jobs to the cluster

Cluster controller 
manages the 

distribution of 
client’s jobs 

across the cluster

Service node
processes jobs

Service node
processes jobs

Service node
processes jobs

Service node
processes jobs

Cluster
(can contain multiple service nodes, but only one cluster controller)

Client Client Client Client

Example of a network setup for distributed rendering

Highspeed switches (chained together)

Rack of servers containing 
cluster controller and render-only Shake service nodes, 

plus rackmounted shared storage device.

LAN
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For more background information about the different parts of an Apple Qmaster 
system and how to prepare an Apple Qmaster network, see the Apple Qmaster 
User Manual included on the installation disc.

You can install both of the Apple Qmaster software components on any computer in 
your Apple Qmaster system, but you do not need to. The instructions that follow tell 
you how to install only the necessary components on each computer.

Important:  All the computers in a cluster need Read and Write access to any 
computers (or storage devices) that will be specified as output destinations for files.

Installing Apple Qmaster Applications on Client 
and Administrator Computers
You need to install Apple Qmaster Applications on any computer that you use to 
submit processing jobs with Apple Qmaster, and on any computer from which you 
create and administer Apple Qmaster clusters. Apple Qmaster is available from a 
separate installer.

Note:  When using Apple Qmaster, Shake is not required to be installed on client and 
administrator computers.

To install Apple Qmaster Applications on client or administrator computers:
1 Double-click the Install Apple Qmaster 2.1 icon.

2 Follow the onscreen instructions.

Using Apple Remote Desktop to Create and Administer 
Shake Cluster Computers Remotely
You can conveniently set up and control Shake service nodes and cluster 
controllers over a network or over the Internet, using Apple Remote Desktop. 
Apple Remote Desktop, using real-time screen sharing, lets you configure and 
administer Shake service nodes and cluster controllers that are running 
Mac OS X. For example, from one computer, you can turn services on and off 
and mount shared storage devices on cluster computers. You can also use 
Apple Remote Desktop to distribute or install the software, configure headless 
service nodes, and control desktops from anywhere on the network. For more 
information, see
http://www.apple.com/remotedesktop

For details on configuring and managing service nodes, cluster controllers, and 
clusters, see the Apple Qmaster User Manual.

http://www.apple.com/remotedesktop
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Installing Apple Qmaster Services on Cluster Computers
You need to install Apple Qmaster on cluster computers (service nodes and cluster 
controller computers). Keep in mind that while it is possible for each cluster to have 
multiple service nodes, you are only required to have one cluster controller per cluster.

On service nodes, you also need to install the application that will process batches 
submitted to Apple Qmaster. For Shake clusters, you can install Shake and the render 
license on the service nodes, since the only component of Shake that you need in a 
service node is its rendering capability. Shake 4.1 and Apple Qmaster 2.1 are available 
as separate installers. For more information on installing Shake 4.1 for rendering, see 
“Installing and Licensing Shake for Render-Only Workstations” on page 7. See the 
previous section for more information about installing Apple Qmaster 2.1.

When Apple Qmaster Services are installed, the Apple Qmaster icon appears in the 
“Other” group of System Preferences.

Note:  See “Special Installation Instructions for Extended Node Clusters” on page 10 for 
information about creating an extended node cluster. You do not need to install any 
Apple Qmaster software on extended service nodes, but an extended node cluster 
does require an intermediary node that needs Apple Qmaster Services.

Special Installation Instructions for Extended Node Clusters
There is a way to use computers as service nodes even if they do not have 
Apple Qmaster installed. To do this, you configure an intermediary node that 
executes Apple Qmaster commands on other computers, called extended nodes. The 
intermediary node runs UNIX commands on the extended nodes via the SSH (secure 
shell) UNIX program, so that the extended nodes can process batches without having 
Apple Qmaster installed. This type of cluster is called an extended node cluster.

Note:  For details on configuring and using an extended node cluster, see the 
Apple Qmaster User Manual on the Shake 4.1 installation disc.

You only need one intermediary node in an extended cluster. It can act as the cluster 
controller, or you can add it to another cluster that already has a cluster controller.

Important:  Macintosh computers running Mac OS X v10.4 Tiger cannot be used as 
extended nodes.
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To install Apple Qmaster 2.1 on the intermediary node:
m Double-click the Install Apple Qmaster 2.1 icon, then follow the onscreen instructions.

To install Apple Qmaster 2.1 on the extended nodes:
m Double-click the Install Shake 4.1 icon to install Shake on any computer that is 

intended for use as an extended node. There is no need to install Apple Qmaster 
software on extended nodes. Computers acting as extended nodes can operate as 
render-only workstations. See “Installing and Licensing Shake for Render-Only 
Workstations” on page 7.

About Installing Software and Saving Files
Mac OS X provides a multiuser environment so everyone has their own home directory 
where they can save files that aren’t accessible to others. If users are working on the 
same projects, they need to save or place these files in a location where others can 
access the files.

When installing or saving files, including project files, consider who needs access to 
these items. Use the following to help determine where to locate files:
Â Shared folder within the Users directory:  All users have access to this folder, making 

this a good location to save and store files that you want others to use.
/Users/Shared/

For example, if you want all users to have access to the tutorial media, drag the 
appropriate folder from the Shake 4.1 installation disc to the /Users/Shared directory.

Â Public folder within a user’s home directory:  The user must turn on file sharing in 
Sharing preferences so other users can access this folder.
/Users/username/Public/

Â Volume roots:  All users typically have access to the volume roots, which are all of the 
connected volumes or hard disks. If all users need access to specific applications, 
such as Shake, make sure you install these applications in an accessible folder on a 
volume root, such as the Applications folder.

Note:  For information on setting preferences and environment variables, see 
Chapter 14, “Customizing Shake,” in the Shake 4 User Manual.



 

Setting Up a Shared Working Directory for Apple Qmaster Jobs
When using Apple Qmaster for distributed processing, all computers in a cluster must 
have access to a common working directory—the folder where Shake saves a temporary 
script that specifies the rendering instructions. The easiest way to designate a common 
working directory is to enable Apple Qmaster within the Shake user interface, then 
change the default workingDir path in the Render Parameters window of Shake.

To enable Apple Qmaster within the Shake interface, you must create a .h preference 
file and save it to the Shake startup folder.

To create the .h preference file:
1 In TextEdit, open a new file, then type or paste the following text:

script.uncFileNames = 0; 

sys.useRenderQueue = "Qmaster";

2 Save the file as qmaster.h and place it in the /Users/username/nreal/include/startup folder.

When you start Shake, additional options now appear in the Render Parameters window 
when you choose the Render > FileOut Nodes command. These options allow you to 
specify a working directory that is accessible to all computers in a processing cluster.

To set the working directory:
1 In the Shake Node View, click the FileOut node you wish to render.

2 Choose Render > Render FileOut Nodes.

The Render Parameters window appears.

3 Expand the renderQueue subtree.

4 Turn on the useQueue button.

5 Click the folder icon next to the workingDir parameter, and navigate to a folder that all 
computers in the cluster can access.

6 Click Render.

Important:  All computers in a processing cluster must have access to the working 
directory. If they do not have access, your processing job will fail. 
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