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Veillard. All Rights Reserved.
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Before using this software or reading this 
document, make sure you have read, 

understood, and agreed to the license contained in 
“MotionArtist End User License Agreement (EULA) 
and Limited Warranty” on page iii.
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Chapter 1: Welcome 
to MotionArtist!

MotionArtist is a new product with a new approach to 
animation. While developing MotionArtist, we are really 
creating an animation and interactivity product with 
comic creators in mind. We’re not trying to reinvent the 
wheel. 

You won’t see any drawing, inking, or coloring tools 
here. What you will see is a powerful composition and 
presentation application that’s very intuitive. 

We’re also trying to bridge a gap between comic 
creators and their readers. You can export your comics or 
presentations in common file formats without being locked 
into a specific format or have to use a service. You can 
export as a common video format or (more importantly) 
HTML5!

What is MotionArtist?
MotionArtist easily allows you to tell a story in motion, 
whether it be a motion comic, a business presentation, 
or an animated slide show of your latest family picnic. 
You can easily integrate static assets into a full-blown 

presentation, and then share that presentation on 
FaceBook, YouTube, or to your own channel on Smith 
Micro’s MotionArtist community.

MotionArtist can work with many different types of content, 
and can solve the needs of many different workflows. Here 
are some examples of how you can use MotionArtist to 
create engaging and interactive presentations:

Determine the type of content you want to use. For 
example:

•	 You’ve drawn a comic and want to add motion and 
interactivity to that comic. Scan each page of the 
comic to prepare it for import into MotionArtist.

•	 You might also have digital assets such as photos, 
videos, and audio clips that have already been 
created in other software and want to combine them 
in a unique way.

•	 Create new assets in other applications such as 
Manga Studio, Anime Studio, Poser, or Photoshop and 
import those assets into the MotionArtist project.

•	 You want to create a simple animated presentation 
for business or for a family event ... complete with 
pictures, movies, music, voice narration, and text. 
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After you gather your content, here are some things 
that you can do in MotionArtist to create an engaging 
presentation:

•	 Place your scanned or imported assets on the 
artboard in MotionArtist. You can place them in virtual 
panels that mask out the areas that lay outside the 
panel boundaries.

•	 Move the virtual camera above the artboard to 
change the reader’s point of view and field of vision.

•	 Move the assets over time to create an animation.

•	 Overlay music, voice narration, and text.

•	 Render and export the project as a movie or other 
interactive digital format.

Key Features and Benefits

•	 MotionArtist is a composition and presentation 
tool that is primarily designed for comic artists. You 
can create typical panel-based comics and add 
animation to them. 

•	 You can create presentations that are built around 
comic panels and comic layouts, but they don’t have 

to be presented this way. The product is geared more 
toward creating HTML-based interactive digital comics 
and graphic novels. It is very versatile and the output 
is up to you!

•	 Your presentations can have animation, sound, and 
titling.

•	 You can export your projects as movies or in HTML 
format.

•	 Working modes and views are laid out with comic 
creators in mind.

•	 Comic style panel creation tools that allow you to 
create panels of just about any shape. You can go 
back and resize, duplicate, rotate, align, and cut the 
panels at any time.

•	 Word balloons and dynamic text are vector-based. 
You can easily add or edit thought bubbles, dialog 
boxes and text at any time.

•	 Photo shows are simple and easy to create, through 
automated object placement and camera 
movement.

•	 Import images, video, and audio of just about any size 
and type, including 1080p video and high-resolution 
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photographs and images. Layered Photoshop files and 
Anime Studio files are also supported.

•	 MotionArtist features a new approach to animation for 
non-animators. We’ve hidden the technical stuff, and 
brought the animation process forward in an intuitive 
visual manner. 

•	 Export standard video files and share them on 
YouTube and FaceBook, or save them out as HTML5 
with interactive animation. 

•	 Offers 64-bit support on both Mac and Windows 
computers.  

•	 Improved options for HTML5 export, vastly increasing 
the possiblilities within an interactive  HTML5 
environment.

•	 Supports Wacom touch tablets with multiple gesture 
support. 

•	 Navigation of the art board and timeline has 
gone through major improvements to standardize 
navigation with trackpad and gesture support. 

•	 Improved usabilty and function through multiple 
feature enhancements and bug fixes. 

Included Documentation
MotionArtist includes the following documentation:

•	 MotionArtist Reference Manual: This Reference 
Manual is included in electronic PDF format on your 
MotionArtist DVD. Choose Help > Help from within 
MotionArtist to launch this manual.

System Requirements
System requirements for MotionArtist installation are as 
follows:

Cross Platform Requirements

•	 1 Ghz (1.5Ghz recommended), SSE2 support

•	 512MB Memory (1GB recommended)

•	 250MB of available hard-disk space (cannot install on 
removable flash storage devices)

•	 OpenGL enabled graphics card recommended

•	 1024x768 display (1280x800 recommended) with 
256MB (512MB recommended of VRAM)
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•	 DVD-ROM drive (for physical copies)

Windows-specific requirements

•	 Windows 7 or 8

•	 Windows Internet Explorer 9 or newer

Macintosh-specific requirements

•	 Mac OS X 10.6, 10.7 or 10.8

•	 Intel processor 

When You Have Questions
As you begin using MotionArtist, you’ll undoubtedly have 
questions or want to network with other MotionArtist artists. 
You’re not alone! There are many resources available for 
you. Here are just a few:

Need Help?
MotionArtist includes the Help menu, which serves to 
answer most of your questions while using the application:

•	 MotionArtist Help: Choose Help > Help to open the 
MotionArtist Reference Manual in PDF format.

•	 Video Tutorials: Choose Help > Video Tutorials to 
open your browser to http://motionartist.smithmicro.
com/motionartist-videos.HTML, where you can find a 
number of movies that will help you to learn the basics 
of MotionArtist.

•	 MotionArtist Communities: Choose Help > Community 
to open your web browser to http://motionartist.
smithmicro.com/socialB.HTML.

•	 About: Windows users can select Help > About 
MotionArtist to display the MotionArtist version and 
copyright information. Macintosh users should look in 
the MotionArtist Application menu, and select About 
MotionArtist, to see this information. This option will be 
useful if you need to obtain technical support, since 
the Technical Support representative will need to know 
this information.

Smith Micro Software Resources

•	 Online Support: For technical support, customer 
service, downloads, and to visit the Smith Micro 

http://motionartist.smithmicro.com/motionartist-videos.html
http://motionartist.smithmicro.com/motionartist-videos.html
http://motionartist.smithmicro.com/socialB.html
http://motionartist.smithmicro.com/socialB.html
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MotionArtist community and gallery, visit us at https://
support.smithmicro.com/.

•	 Using MotionArtist: For updates, tutorials, and 
MotionArtist user stories, visit http://MotionArtist.
smithmicro.com/index.HTML.

•	 To Learn More: If you’d like to learn more about Smith 
Micro Software, visit us at http://my.smithmicro.com.

•	 Contacting Technical Support: If our Web Knowledge 
Base does not resolve your situation, please contact us 
through https://support.smithmicro.com/. Please refer 
to “Appendix A: Technical Support” on page 190 to 
view our technical support policy.

•	 Sales: You may reach our sales department via e-mail 
at: sales@smithmicro.com.

About Your Reference Manual
Smith Micro Software strives to provide documentation 
that is complete, accurate, informative, and friendly. 
Your feedback is always welcome. Please e-mail your 
comments to: techsupport@smithmicro.com.

The MotionArtist Reference Manual is for both Macintosh 
and Windows. By convention, Macintosh commands 

precede Windows commands in the text. The MotionArtist 
interface for Macintosh and Windows platforms is identical, 
unless otherwise specified.

For clarity, this manual uses several notational conventions 
to present information of special importance. Lists of items, 
points to consider, or procedures that do not need to be 
performed in a specific order appear in bullet format:

•	 Item 1

•	 Item 2

Procedures that must be followed in a specific order 
appear in numbered steps:

1.	 Perform this step first

2.	 Perform this step second

Specific keyboard keys appear in bold capitalized letters. 
For example: ESC. If more than one key should be pressed 
simultaneously, the notation appears as KEY1+KEY2, for 
example ALT+F4. When a modifier key differs between the 
Macintosh and Windows platform, the Macintosh modifier 
is listed first followed by a slash and the Windows modifier 
key. For example, COMMAND/CTRL+I is equivalent to the 
Macintosh COMMAND+I and the Windows CTRL+I.

Screen prompts, menu and window names, fields, buttons, 
boxes, etc. appear in bold type. Where you need to 

https://support.smithmicro.com/
https://support.smithmicro.com/
http://Ming.smithmicro.com/index.html
http://Ming.smithmicro.com/index.html
http://my.smithmicro.com
https://support.smithmicro.com/%20
mailto:sales%40smithmicro.com?subject=
mailto:techsupport%40smithmicro.com?subject=
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access a palette, command, or submenu, the syntax is 
Menu > Submenu. For example File > Save As means you 
should open the File pull-down menu and then select Save 
As to open the Save As dialog box.

Program and script code appears in standard Courier font, 
for example:

cd\letters\business\legal [ENTER]

Notes detail tips, tricks, and other important 
information.

Warnings alert you to potentially harmful 
consequences such as data loss.
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Chapter 2: Installing 
MotionArtist

Before opening your DVD holder, please take a moment 
to read, understand, and agree to the MotionArtist End 
User License Agreement (EULA). If you do not agree with 
the terms of the EULA, please return your entire MotionArtist 
package including the unopened DVD holder to Smith 
Micro Software or your place of purchase. Once you have 
read and accepted the EULA, you may proceed with 
installing MotionArtist on your system.

The Smith Micro online store will accept the 
return of either physical or electronically 

downloaded products purchased directly from 
Smith Micro within 30 days of the date of purchase. 
Products purchased in retail stores must be returned 
to the place of purchase and meet their specific 
return policy terms. Smith Micro reserves the right to 
change this policy at any time.

MotionArtist End User License 
Agreement (EULA) and Limited 
Warranty
PLEASE READ THIS END USER LICENSE AGREEMENT (“EULA”) 
CAREFULLY BEFORE INSTALLING AND USING THE SOFTWARE.  
BY CLICKING THE “AGREE” BUTTON WHEN INSTALLING THE 
SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE 
TERMS OF THIS EULA.  IF YOU DO NOT AGREE TO THE TERMS 
OF THIS EULA, CLICK ON THE “DISAGREE” BUTTON.  IF YOU 
DO NOT AGREE TO THE TERMS OF THIS EULA, YOU MAY NOT 
USE OR ACCESS THE SOFTWARE.  USING OR ACCESSING 
ANY PART OF THE SOFTWARE INDICATES THAT YOU AGREE 
TO THE TERMS OF THIS EULA..

TThis EULA is between you (both the individual installing 
the Software and any single legal entity on behalf of 
which such individual is acting) (“you” or “your”) and 
Smith Micro Software, Inc. and/or its affiliates (collectively 
or individually, “SMSI”).YOU MUST ACCEPT AND ABIDE 
BY THESE TERMS AS PRESENTED TO YOU, AND CHANGES, 
ADDITIONS, OR DELETIONS ARE NOT ACCEPTABLE.  
SMSI MAY REFUSE ACCESS TO THE SOFTWARE FOR 
NONCOMPLIANCE WITH ANY PART OF THIS EULA.
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1.  General
You agree to use the Software, Documentation and 
Content only for lawful purposes.  Any use of the Software, 
Documentation or Content other than as granted in 
this EULA must be by SMSI’s prior written consent.  SMSI 
maintains an ongoing EULA enforcement program.  
Violation of any provision of this EULA automatically 
terminates this EULA.  SMSI reserves all other rights that it 
may have for violation of this EULA.

2.  Definition
“Content” means animations, characters, clothing, faces, 
hair, geometries, images, documentation, materials, 
meshes, morphs, motion files, props, scripts, textures, bump 
maps, transparencies, and similar files and data created or 
modified with the intent of being used within the Software 
and/or third party applications. Content collectively refers 
to Restricted Content, Unrestricted Content and Other 
Content.

“Documentation” means all written material in any form 
for installation and use of the Software provided by or 
made available by SMSI, or its authorized representatives 
or agents.

“Legitimate Uses” means (a) creating tutorials, books, or 
other educational materials using images of the Software 
interface or Content for sale, distribution, public display, or 
public performance, provided such materials are intended 
to educate users as to use of the Software; (b) creating 
original Content for sale, distribution, public display, or 
public performance; (c) creating materials for use with 
either Restricted Content or Other Content; or (d) creating 
characters or props based on Restricted Content in 
proprietary file formats (meaning, MOHO, ANME and any 
subsequent/compressed formats), where the original (or 
modified) art, texture or other Restricted Content files are 
not distributed with such characters or props.

“Other Content” means Content that is not Restricted 
Content or Unrestricted Content.  Other Content may be 
subject to license terms imposed by the Other Content’s 
original creator.

“Restricted Content” means all Content included with 
or part of the Software that is not Unrestricted content, 
including without limitation mesh objects (geometry) 
in any format, files in proprietary file formats (meaning, 
MOHO, ANME, and any subsequent/compressed 
formats), images, materials, texture, transparency maps, 
Documentation, vector-based content, and SMSI’s 
proprietary data.  Except as otherwise expressly permitted 
by this EULA, Restricted Content extracted or exported 
from the Software remains Restricted Content.  Except as 



MotionArtist
Reference Manual 

10

Chapter 2: Installing MotionArtist

authorized in this EULA, Restricted Content may only be 
used exclusively on one (1) computer.

“Software” means the SMSI computer software and 
associated files (e.g., Content) delivered via the 
accompanying physical media or electronic media.  
“Software” means to also include any upgrades, updates, 
bug fixes or modified versions or backup copies of the 
Software supplied to you by SMSI or an SMSI authorized 
representative or agent (whether or not for a fee).

“Unrestricted Content” means Content included with 
or part of the Software that is specifically identified in 
the Documentation or listed in this EULA as Unrestricted 
Content.  This version of the Software contains no 
Unrestricted Content.

3. Software License 
A) Subject to the terms and conditions of this EULA and 
your payment of the license fee, as applicable, SMSI grants 
you a limited, personal, nontransferable and non-exclusive 
license (without right to sublicense): (i) to use a single 
copy of the Software (except as expressly permitted in the 
Documentation) solely for your own internal use on a single 
computer (as set forth in Subsection E below of this Section 
3) either loaded in the temporary memory (i.e., RAM) of 
a computer, or installed on the permanent memory of 

a computer (e.g., hard disk and compact disk) or, on a 
temporary basis, on a backup system if such equipment 
is inoperative, consistent with the limitations specified or 
referenced in this EULA and the Documentation; (ii) to use 
the Documentation provided with the Software in support 
of your authorized use of the Software; and (iii) to copy the 
Software to make one (1) archival copy of the Software 
for your personal archival or backup purposes, and to 
make sufficient number of copies for Legitimate Uses or the 
intended use described in the Documentation, provided 
that all titles and trademark, copyright and restricted rights 
notices are reproduced on all such copies.  Any other uses 
of the Software, including without limitation the Software 
interface, other than those granted in this EULA must be 
expressly pre-approved by SMSI in writing.

B) The Software is protected by copyright and other 
intellectual property laws and international treaties.  As an 
express condition of this EULA, you must reproduce on the 
backup copy the SMSI copyright notice in the following 
format: “(C) 2012-2013 Smith Micro Software, Inc.”  This 
express condition extends to any further updates, software 
patches, or bug fixes made available to you by SMSI, 
whether distributed on floppy disk, compact disk, or in an 
electronic format via download, BBS, forum, FTP, e-mail, 
etc.  The terms of this EULA will govern any upgrades 
and updates of the Software, unless accompanied by a 
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separate license agreement, in which case, the terms of 
that separate license agreement will govern accordingly.

C) The Software (not including the media on which the 
Software may be provided) is licensed to you, not sold.  
You expressly acknowledge that SMSI and/or its licensor(s) 
have a valuable proprietary interest in both the Software 
and the Documentation.  All title, ownership, interest 
and rights in and to the patent, copyright, trademark, 
trade secret and any other intellectual property rights in 
the Software (and any derivative works thereof) and the 
Documentation (and any derivative works thereof) not 
expressly granted to you by this EULA remain with SMSI 
and/or its licensor(s).  You do not acquire any other rights, 
express or implied, in the Software (and any derivative 
works thereof) and the Documentation (and any 
derivative works thereof) other than those rights expressly 
granted under this EULA.  Without limiting the generality of 
the foregoing, SMSI, Lost Marble, Inc. and/or its licensor(s) 
retain all title, ownership, interest and rights in and to the 
patent, copyright, trademark, trade secret and any other 
intellectual property rights in the copy of the Software 
contained on your archival media, and all of the terms 
of this EULA apply to such archival copy as if it were the 
original SMSI-produced copy of the Software that was 
furnished to you when you paid the licensing fee.

D) Portions of the Software include third party software 
and other copyrighted material (collectively, “TPS”).  

Acknowledgements, licensing terms, restrictions and 
disclaimers of such TPS are contained in the “About Box” of 
the Software and your use of such TPS is governed by such 
respective terms.  Any terms of this EULA that differs from 
the terms of any TPS are offered by SMSI alone, and not by 
any other licensor.

E) Except as otherwise expressly permitted in the 
Documentation, you will only use the Software on a single 
computer, meaning that you must treat the Software “like 
a book.” “Like a book” means that the Software may be 
used by any number of people and may be freely moved 
from one computer to another so long as no possibility 
exists of the Software being used at more than one 
computer simultaneously.  More than one person at a time 
cannot read the same copy of a book, and this restriction 
applies to the Software.

4. Restrictions 
A) You will not, and will not permit any third party to, 
use, copy, modify, derive, or transfer the Software or 
Documentation, or any copy, modification, derivation, 
or merged portion thereof, in whole or in part via any 
means or for any purpose whatsoever except as expressly 
permitted in this EULA or the Documentation.  You 
will not, and will not permit any third party to, modify, 
adapt, translate, rent, lease, loan, resell for profit, or 
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create derivative works based upon the Software or any 
part thereof.  The Software contains trade secrets in its 
human readable form and, to protect them, you will not, 
and will not permit any third party to, reverse engineer, 
decompile, disassemble, or otherwise reduce the Software 
to any human readable form without the express prior 
written consent of SMSI or except to the extent expressly 
permitted by applicable law.  You will not relicense, 
sublicense, rent, lease, or lend the Software for third-party 
training, commercial time-sharing or service bureau use.  
You will not, and will not permit any third party to, debug, 
bypass, circumvent or defeat any security features of, or 
interfere with the normal functionality and operation of the 
Software for any reason whatsoever without the express 
prior written consent of SMSI or except to the extent 
expressly permitted by applicable law.  If the Software 
is an upgrade to a previous version of the Software, you 
must possess and maintain a valid license to such previous 
version in order to use the upgrade.

B) You, your employees, and/or authorized agents must 
protect the Software’s confidentiality and act to enforce 
your obligations under this EULA.  You cannot distribute or 
otherwise make the Software or Documentation available 
to any third party via any means whatsoever, public 
or private, for any purpose, commercial or not, unless 
explicitly allowed by this EULA.

C) You assume full responsibility for your selection of the 
Software to achieve your intended results and for the 
installation, use, and results you obtain from the Software.  
SMSI has no obligation to provide support, maintenance, 
upgrades, modifications or new releases under this EULA.

D) You may not use the Software on any supported device 
that you do not own or control, and you may not distribute 
or make the Software available over a network where it 
could be used by multiple devices at the same time.

5.  Content License
A) Subject to the terms and conditions of this EULA and 
your payment of the applicable license fee, SMSI grants 
you a limited, personal, nontransferable and non-exclusive 
license (without the right to sublicense):

1) To reproduce, prepare derivative works based upon, 
distribute, publicly display and publicly perform the 
Unrestricted Content for any lawful purpose other than to 
create a product which is intended to compete with the 
Software or to create new content which is intended to 
compete with the Restricted Content.

2) To prepare derivative works based upon the Restricted 
Content solely for Legitimate Uses and lawful uses.
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3) To reproduce, prepare derivative works based upon, 
distribute, publicly display, and publicly perform content 
you create using Restricted Content, provided that such 
use of Restricted Content shall be solely for Legitimate Uses 
and lawful uses.

B) Notwithstanding the foregoing, nothing shall limit SMSI’s 
right to independently create, develop, own, market, 
distribute, license, sublicense, import, export, sell, or 
otherwise exploit any content or materials similar to any 
derivative works based upon the Content.

C) Other Content included with the Software and 
Documentation is subject to third-party rights and 
is copyrighted and owned by the Other Content’s 
original creator(s).  You may use the Other Content in 
accordance with all applicable license terms imposed 
by the Other Content’s original creator(s).  SMSI makes no 
representations as to the quality, suitability, functionality, 
or legality of the Other Content and you hereby waive 
any claim you might have against SMSI with respect to the 
Other Content.

D) You will not, and will not permit any third party to, use, 
copy, modify, derive, sell, distribute, transfer or sublicense 
the Restricted Content, the Unrestricted Content, or the 
Other Content or any copy, modification, derivation, or 
portion thereof, in whole or in part via any means or for 

any purpose whatsoever, except as expressly permitted in 
this EULA or the Documentation.

E) You expressly acknowledge that SMSI and/or its 
licensor(s) have a valuable proprietary interest in the 
Restricted Content and the Unrestricted Content.  All 
title, ownership, interest and rights in and to the patent, 
copyright, trademark, trade secret and any other 
intellectual property rights in the Restricted Content (and 
any derivative works thereof) and the Unrestricted Content 
(and any derivative works thereof) not expressly granted 
to you by this EULA remain with SMSI and its licensor(s).  
You do not acquire any other rights, express or implied, in 
the Restricted Content (and any derivative works thereof) 
and the Unrestricted Content (and any derivative works 
thereof) other than those rights expressly granted under 
this EULA.

F) Except as otherwise expressly permitted in the 
Documentation or unless otherwise provided for herein, 
you will only use the Content on a single computer, 
meaning that you must treat the Content “like a book.”  
SMSI is pleased to offer site licenses (“Site License”) for 
multiple simultaneous users.  Please contact SMSI at the 
address below for details.  If you purchased a Site License, 
you may distribute the Restricted Content between all 
computers containing valid copies of the Software, other 
SMSI products, and/or other software able to process 
Restricted Content.
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6. Collection and Use of Your 
Information
A) Upon launching the Software, you will have the option 
to register the Software with SMSI.  If you choose to register 
the Software with SMSI, you agree that SMSI and/or its 
affiliates may collect and process such information about 
you and the Software in order to enable SMSI to: (i) notify 
you of updates, bug fixes and/or modified versions of 
the Software; (ii) provide support and assistance of the 
Software; (iii) notify you of new version offerings of the 
Software; and (iv) comply with all applicable laws and/or 
regulations, or the requirements of any regulatory authority 
or government agency.

B) Your use of the Software constitutes consent by you 
to SMSI’s and/or its affiliates’ collection and use of such 
information and, if you are located in European Economic 
Area (EEA), to the transfer of such information to a location 
outside the EEA.  Any information collected is done and 
utilized in accordance with SMSI’s Privacy Policy.  Your 
election to use the Software indicates your acceptance of 
the terms of the SMSI Privacy Policy, so please review the 
policy carefully and check our website at the following URL 
to review updates:  http://www.smithmicro.com/. 

7. Term; Termination 
A) This EULA remains in full force and effect until 
terminated.  You may terminate this EULA at any time 
by returning or destroying both the Software and 
Documentation, together with all copies, modifications, 
and merged portions of the Software and the 
Documentation in any form.  SMSI is in no way obliged to 
issue refunds.  SMSI may terminate this EULA at any time 
upon your breach of any of the provisions hereof.

B) Upon termination, you will immediately cease all use of 
the Software, and you must return or destroy the Software, 
Documentation, and all copies, modifications, and 
merged portions of the Software and the Documentation 
in any form and certify in writing your compliance of this 
paragraph to SMSI.  Termination of this EULA for any reason 
in no way limits SMSI’s right to continue enforcing all rights 
provided by law and does not entitle you to a refund of 
your license fees, except as provided herein.  All provisions 
of this EULA that protect SMSI’s proprietary rights continue 
in full force and effect after termination.

8. Export Law Assurances 
Export and re-export of this Software and Documentation 
is governed by the laws, restrictions and regulations of 
the United States and applicable export and import laws, 

http://www.smithmicro.com/
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restrictions and regulations of certain other countries 
(collectively, “Export Laws”).  You will comply with all such 
Export Laws.  Export or re-export of this Software and/or 
Documentation (including any direct product thereof) 
to any entity on the Denied Parties List and other lists 
promulgated by various agencies of the United States 
Federal Government is strictly prohibited.  In addition, 
if the Software is identified as an export controlled item 
under the Export Laws, you represent and warrant that 
you are not a citizen of, or located within, an embargoed 
or otherwise restricted nation (e.g., Iran, Syria, Sudan, 
Cuba and North Korea) and that you are not otherwise 
prohibited under the Export Laws from receiving the 
Software.

9. Limited Warranty and Disclaimer 
A) SMSI warrants that any media on which the Software 
may be provided will be free from defects in materials 
and workmanship under normal use for a period of 
ninety (90) days from the date of original purchase.  Your 
exclusive remedy and SMSI’s entire liability under this 
limited warranty will be for SMSI, at its option, to replace 
the Software media or refund the purchase price of such 
Software media.  This limited warranty is offered solely 
by SMSI and does not apply to any third party product, 
software, content or service offerings.  THE ABOVE 

WARRANTIES ON MEDIA ARE EXCLUSIVE AND IN LIEU OF 
ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, AND SMSI 
EXPRESSLY DISCLAIMS ALL OTHER WARRANTIES, INCLUDING, 
WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF 
MERCHANTABILITY, SATISFACTORY QUALITY, FITNESS FOR A 
PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

B) TO THE EXTENT NOT PROHIBITED BY APPLICABLE LAW, 
THE SOFTWARE, RESTRICTED CONTENT, UNRESTRICTED 
CONTENT, AND DOCUMENTATION ARE LICENSED TO YOU 
“AS IS” WITH ALL FAULTS, WITHOUT WARRANTY, CONDITION 
OR REPRESENTATION, EXPRESS OR IMPLIED, OF ANY KIND, 
INCLUDING WITHOUT LIMITATION, MERCHANTABILITY, 
PERFORMANCE, SECURITY, SATISFACTORY QUALITY, NON-
INFRINGEMENT OF THIRD PARTY RIGHTS, OR FITNESS FOR A 
PARTICULAR PURPOSE.

C) YOU ACKNOWLEDGE THAT THE SOFTWARE MAY NOT 
(I) SATISFY ALL YOUR REQUIREMENTS, (II) BE FREE FROM 
DEFECTS, OR (III) OPERATE WITHOUT INTERRUPTION OR 
ERRORS.  IN ADDITION, DUE TO CONTINUAL DEVELOPMENT 
OF NEW TECHNIQUES FOR INTRUDING UPON AND 
ATTACKING NETWORKS, SMSI DOES NOT WARRANT 
THAT THE SOFTWARE WILL BE FREE OF VULNERABILITY TO 
INTRUSION OR ATTACK.

D) THE FOREGOING LIMITED WARRANTY IS NEITHER A 
SERVICE NOR A SUPPORT CONTRACT.  NO ORAL OR 
WRITTEN INFORMATION OR ADVICE GIVEN BY SMSI, ITS 
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EMPLOYEES, DISTRIBUTORS, DEALERS, REPRESENTATIVES 
OR AGENTS SHALL INCREASE THE SCOPE OF THE ABOVE 
WARRANTIES OR CREATE ANY NEW WARRANTIES.  YOU MAY 
HAVE ADDITIONAL WARRANTY RIGHTS UNDER LAW WHICH 
MAY NOT BE WAIVED OR DISCLAIMED.  SMSI DOES NOT 
SEEK TO LIMIT YOUR WARRANTY RIGHTS TO ANY EXTENT NOT 
PERMITTED BY LAW.  This Section 9 and Section 10, below, 
shall survive any termination of this EULA, howsoever 
caused, but this will not imply or create any continued 
right to use the Software after termination of this EULA.

10. Disclaimer of Liabilities
A) EXCEPT FOR THE EXCLUSIVE REMEDY OFFERED BY SMSI 
ABOVE AND REMEDIES THAT CANNOT BE EXCLUDED OR 
LIMITED BY APPLICABLE LAW, IN NO EVENT WILL SMSI 
OR ITS DEVELOPERS, SUPPLIERS, LICENSORS, DIRECTORS, 
OFFICERS, EMPLOYEES, OR SUBSIDIARIES OR AFFILIATES BE 
LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR 
INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF 
BUSINESS PROFIT, BUSINESS INTERRUPTION, LOSS OF DATA 
AND/OR BUSINESS INFORMATION, AND THE LIKE), WHETHER 
FORESEEABLE OR UNFORESEEABLE, ARISING OUT OF THE USE 
OR INABILITY TO USE THE SOFTWARE OR DOCUMENTATION, 
REGARDLESS OF THE BASIS OF THE CLAIM, EVEN IF SMSI 
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES 
OR FOR ANY CLAIM BY ANY OTHER PARTY.  IN NO EVENT 

WILL SMSI’S AGGREGATE LIABILITY (OR THAT OF ITS 
DEVELOPERS, SUPPLIERS, LICENSORS, DIRECTORS, OFFICERS, 
EMPLOYEES, OR SUBSIDIARIES OR AFFILIATES), UNDER OR 
IN CONNECTION WITH THIS EULA, EXCEED THE AMOUNT 
PAID BY YOU FOR THE SOFTWARE, IF ANY.  THIS LIMITATION 
WILL APPLY EVEN IN THE EVENT OF A FUNDAMENTAL OR 
MATERIAL BREACH OR A BREACH OF THE FUNDAMENTAL 
OR MATERIAL TERMS OF THIS EULA.

B) The above limitations will apply even if any warranty 
or remedy provided under this EULA fails of its essential 
purpose.  The above limitations will not apply in case of 
personal injury (including death) only where and to the 
extent that applicable law requires such liability.  Because 
some jurisdictions do not allow the exclusion or limitation 
of implied warranties or liabilities for consequential or 
incidental damages, the above limitations may not apply 
to you.

11. Indemnification
You will indemnify and hold harmless, and at SMSI’s request 
defend, SMSI and its affiliates, successors and assigns 
from and against any and all claims, losses, liabilities, 
damages, settlements, expenses and costs (including, 
without limitation, attorneys’ fees and court costs) which 
arise out of or relate to any third party claim or threat 
thereof that your use of the Software, Documentation or 
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Content is unlawful or not otherwise permitted by this EULA.  
SMSI reserves the right, at its own expense, to assume the 
exclusive defense and control of any matter otherwise 
subject to indemnification hereunder.

12. U.S. Government Restricted Rights 
The Software and Documentation are provided with 
RESTRICTED RIGHTS.  The use, duplication, or disclosure by 
the United States Government is subject to restrictions as 
set forth in subparagraph (c)(1)(ii) of the Rights in Technical 
Data and Computer Software Clause at DFARS 252.227-
7013 or subparagraph (c)(1) and (2) of the Commercial 
Computer Software Restricted Rights at 48 CFR 52.227-19, 
as applicable. The Manufacturer is Smith Micro Software, 
Inc., 51 Columbia, Aliso Viejo, CA 92656 USA.

13. Applicable Law 
This EULA shall be governed by the laws of the State of 
California, without giving effect to any choice of law 
principles.  This EULA will not be governed by the United 
Nations Convention on Contracts for the International 
Sales of Goods, the application of which is expressly 
excluded.  Exclusive jurisdiction over and venue of any 
suit arising out of or relating to this EULA will be in the 
state and federal courts of Orange County, California.  

If for any reason a court of competent jurisdiction 
finds any provision, or portion thereof, to be invalid or 
unenforceable, the remainder of this EULA shall continue 
in full force and effect.  The waiver by either party of any 
default or breach of this EULA will not constitute a waiver 
of any other or subsequent default or breach.  You may 
not assign, sell, transfer, delegate or otherwise dispose of, 
whether voluntarily or involuntarily, by operation of law or 
otherwise, this EULA or any rights or obligations under this 
EULA without SMSI’s prior written consent.  Any purported 
assignment, transfer or delegation by you will be null and 
void.  This EULA constitutes the entire agreement between 
the parties and supersedes all prior or contemporaneous 
agreements or representations, written or oral, concerning 
the subject matter of this EULA.

14. Other Services and Materials
This Software may enable access to SMSI and third party 
services and websites (individually and collectively referred 
to as “Services”).  This EULA does not apply to any Services.  
You acknowledge and agree that nothing in this EULA 
guarantees availability or continued availability or uptime 
of any Services.  Any terms, conditions, warranties, or 
representations associated with any third party Services 
are solely between you and such third party.
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You understand that by using any of the Services, You 
may encounter content that may be deemed offensive, 
indecent, or objectionable, which content may or may 
not be identified as having explicit language, and that 
the results of any search or entering of a particular URL 
may automatically and unintentionally generate links or 
references to objectionable material. In addition, you 
agree not to use the Software to create content that may 
be deemed offensive, indecent, or objectionable; hateful, 
threatening, or pornographic; incites violence; or contains 
nudity or graphic or gratuitous violence.  Nevertheless, you 
agree to use the Services at your sole risk and that the SMSI 
shall not have any liability to you for content that may be 
found to be offensive, indecent, or objectionable; hateful 
threatening or pornographic; incites violence; or contains 
nudity or graphic or gratuitous violence. 

You agree that the Services contain proprietary content, 
information and material that is protected by applicable 
intellectual property and other laws, including but not 
limited to copyright, and that You will not use such 
proprietary content, information or materials in any way 
whatsoever except for permitted use of the Services.  No 
portion of the Services may be reproduced in any form 
or by any means.  You agree not to modify, rent, lease, 
loan, sell, distribute, or create derivative works based on 
the Services, in any manner, and you shall not exploit the 
Services in any unauthorized way whatsoever, including 

but not limited to, by trespass or burdening network 
capacity.  You further agree not to use the Services in 
any manner to harass, abuse, stalk, threaten, defame or 
otherwise infringe or violate the rights of any other party, 
and that SMSI is not in any way responsible for any such 
use by you, nor for any harassing, threatening, defamatory, 
offensive or illegal messages or transmissions that you may 
receive as a result of using any of the Services.

15. Contact Information 
If you have questions concerning this EULA or need 
to contact Customer Service, please contact SMSI at 
this address: Smith Micro Software, Inc., 185 Westridge 
Drive, Watsonville, CA 95076 USA (831) 761-6200 phone, 
(831) 761-6206 fax; Customer Service (returns, warranty): 
service@smithmicro.com; and Legal (EULA questions, 
illegal activity reporting): legal@smithmicro.com.

16. Copyright & Trademark Notice
Smith Micro Software, MotionArtist and other SMSI 
designated logos, marks, names and trade names are 
trademarks of Smith Micro Software, Inc. All other product 
names mentioned in the Software, Content or related 
Documentation are used for identification purposes only 
and may be trademarks or registered trademarks of 

mailto:service%40smithmicro.com?subject=
mailto:legal%40smithmicro.com?subject=
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their respective companies. Registered and unregistered 
trademarks used herein are the exclusive property of their 
respective owners.  For purposes of Japan law regarding 
unregistered trademarks (e.g., a pending trademark 
application), the right in and to a trademark in Japan may 
not be exclusive until it is validly registered.  You may not 
remove, modify, alter, cover or deface any trademark, 
trade names, product/service names, logo, copyright or 
other proprietary notices, legends, symbols or labels in the 
Software and all related Content, Documentation and 
materials (in any form). This EULA does not authorize you to 
use SMSI’s or its licensors’ names or respective trademarks 
(e.g., logos, name, etc.).  Further, any reference to any 
third party commercial products, processes or services 
by trade name, trademark, logo, and company and/
or product/service names mentioned or displayed 
in the Software (and in any of its related Content, 
Documentation and materials in any form) does not 
constitute or imply SMSI’s endorsement, recommendation 
or favoring by SMSI or any of its suppliers/licensors  This 
EULA does not authorize you to use SMSI’s or its licensors’ 
names or respective trademarks.  All rights not expressly 
granted in this EULA are reserved by SMSI and its licensors, 
respectively.

Version:  20140110 MotionArtist (Ming)

Installing MotionArtist
Installing MotionArtist is a straightforward process. Before 
you begin, be sure to save any work in progress. Having 
this “clean” environment will help the installation process 
proceed smoothly and will prevent any loss of data in the 
highly unlikely event of a problem. To install MotionArtist, 
complete the following steps:

MotionArtist Installation (Windows)
1.	 Start the Installer.

2.	 The Welcome screen appears. Click Next to continue.

3.	 The License Agreement screen prompts you to accept 
the License Agreement. Click I accept the agreement, 
and then Next to continue the installation.

4.	 The Select Destination Location screen prompts you 
to choose an installation folder. If you want to use a 
different location other than the default installation 
location, click the Browse button to locate the folder 
you want to use. Then click Next to continue.

5.	 The Select Start Menu Folder prompts you to choose a 
location in your Start Menu where the shortcuts for the 
application will appear. If you want to use a location 
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other than the default, click the Browse button to 
locate or create a folder. After you choose your folder, 
click Next to continue.

6.	 The Ready to Install screen displays the choices you 
made during the installation process. Use the Back 
button to go back and change settings if you need to 
do so. To install to the locations specified, click Install.

A desktop icon will be created for Windows 8 
installations.

A desktop icon will be created for Windows 8 
installations.

MotionArtist 1.1 now has a unified 32-bit AND 
64-bit installer on Windows.  MotionArtist will 

automatically install 32-bit components on 32-bit 
operating systems and install both 32-bit and 64-bit 
components on 64-bit operating systems. 

MotionArtist Installation (Mac)
1.	 Double-click on the Install icon.

2.	 The Welcome screen appears. Click Continue.

3.	 The ReadMe screen displays important information 
relating to the release. After you read the information, 
click Continue.

4.	 The License screen displays the End User License 
Agreement (EULA). Press Continue after you read the 
agreement. A new dialog prompts you to agree to 
the license before you continue the installation. Click 
Agree to continue the installation. If you click Disagree, 
the program will not be installed.

5.	 The Installation Type screen appears, and displays the 
amount of space that the MotionArtist application will 
need on your hard drive. Click Install to continue with 
the installation. 

As with most Mac software installations, you 
may be prompted to enter your Mac system 

administrator password to install the software.

6.	 If the installation is successful, the Summary screen 
appears after the software has been installed. Click 
Close to exit setup.
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Creating a Content Folder
When you first start MotionArtist, you will be asked to 
create a folder to store your custom MotionArtist content. 
After the content folder is created, a hierarchy of folders 
appears beneath it. You can store user-created word 
balloons, brushes, and other custom items that you can 
use in MotionArtist. 

 Choosing a content folder.

The choices are as follows:

•	 Never: Choose this option if you do not want to set up 
a folder, and no longer want to receive this prompt 
when you start MotionArtist.

If you choose to never show the dialog that 
prompts you to create a content folder, you 

can choose the  Help > Set Custom Content Folder 
command at any time to specify a content folder 
location.

•	 Not Now: Choose this option if you want to set up the 
folder at a later time. You will be prompted with this 
dialog the next time you start MotionArtist.

•	 Create: Choose this option to browse to the folder that 
you want to use for your MotionArtist content. After 
you select/create the folder, choose OK.

Use the Help > Open Custom Content Folder 
to navigate to your content folder at any 

time.

Installing Extra Project Files
MotionArtist includes additional project files that you can 
learn from. You can copy these files to a location on your 
hard drive, or add them to your MotionArtist content folder 
for easy access later.

You will find the project files in the root folder of your CD, in 
a folder called Sample Projects.

The Welcome Screen
When MotionArtist opens, a welcome screen appears with 
the following options:



MotionArtist
Reference Manual 

22

Chapter 2: Installing MotionArtist

•	 Tell Your Friends: Opens your web browser to http://
motionartist.smithmicro.com/socialB.HTML

•	 Watch the Intro Tutorial:  Opens your browser to http://
motionartist.smithmicro.com/motionartist-videos.
HTML where you can view introductory tutorials about 
MotionArtist.

•	 Register Your Bestest App: Opens your browser to 
http://store.smithmicro.com/productregistration.aspx, 
where you can register your application to qualify for 
support, updates, and more.

•	 Don’t Show Again: Choose this option to stop the 
Welcome Screen from displaying each time you start 
MotionArtist. 

You can manually display the screen at any 
time by choosing Help > Welcome Screen.

 MotionArtist Welcome screen.

Registering MotionArtist
After installation, you can choose to register your copy 
of MotionArtist via the Web. Choose Help > Register to 
navigate to the registration page on smithmicro.com.

http://motionartist.smithmicro.com/socialB.html
http://motionartist.smithmicro.com/socialB.html
http://motionartist.smithmicro.com/motionartist-videos.html
http://motionartist.smithmicro.com/motionartist-videos.html
http://motionartist.smithmicro.com/motionartist-videos.html
http://store.smithmicro.com/productregistration.aspx
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Checking for Updates
Smith Micro Software is committed to supporting all of our 
products by releasing Service Releases and other updaters 
that address issues present in earlier versions and/or 
enhance the product’s usability or functionality.

You can check for updates easily by choosing Help > 
Check for Updates from the menu bar. 



MotionArtist
Reference Manual 

24

Chapter 2: Installing MotionArtist

Part 2: MotionArtist  
Overview



MotionArtist
Reference Manual

25

Chapter 3: The MotionArtist Workspace 

Chapter 3: The 
MotionArtist 
Workspace 

The MotionArtist workspace is arranged in a simple layout 
that includes a few main areas: Menu Bar, artboard 
(project workspace), main toolbar, timeline with scene 
tabs, and library (shown undocked in the following figure). 

 MotionArtist workspace.

1.	 MotionArtist Menu Bar: Displays most commands 
available in MotionArtist. See “MotionArtist Menu Bar” 
on page 26.

2.	 View and Mode Indicators: Displays your current view 
and mode. See “View and Mode Indicators” on page 
26.

3.	 The Artboard: Displays the scenes, panels, and objects 
in your project. See “The Artboard” on page 27.

Page guides around the artboard are turned 
off by default. Choose View > Page Guides 

to display them.

4.	 The Library Window: Provides quick access to ready-
made content, as well as content in your own content 
folders. See “The Toolbars” on page 29 for an 
overview, and “Chapter 12: The Library Window” on 
page 123 for more detailed information.

5.	 Toolbars: Provides several tool sections that give 
quick access to the most frequently used MotionArtist 
features. See “The Toolbars” on page 29.

6.	 Scene Tabs: Allows you to switch between the scenes 
in your MotionArtist project. See “Scene Tabs” on 
page 30 for a quick overview, and “Chapter 9: 
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Working with Scenes” on page 87 for more detailed 
information.

7.	 Timeline: Displays an overview in time of when content 
will appear in your project,and the placement of other 
items such as Camera and Object stop points. See 
“The Timeline” on page 31 for an overview, and 
“Chapter 6: The Timeline Window” on page 60 for 
more detailed information.

8.	 Status Bar and Current Frame indication: Displays 
helpful tips relating to the usage of the MotionArtist 
interface. The right side of the status bar displays the 
current frame in both scene time, and panel time. 

This chapter gives an overview of each of these areas, 
along with links to other sections in the manual where 
more information can be obtained.

MotionArtist Menu Bar
The MotionArtist Menu Bar displays menu commands in 
eight categories: File, Edit, Arrange, Panel, Share, View, 
Window, and Help. The use of these commands are 
covered throughout the manual. For specific locations, 
refer to the index at the end of this manual.

 Menu Bar.

View and Mode Indicators
The View and Mode indication appears in the upper-left 
corner of the work area. These indicators inform you of 
the view and mode you are working in:  You can show or 
hide these view indicators by toggling the VIew > Show 
View/Mode command. A checkbox appears beside the 
command when the indicators are displayed.

•	 Director View: See “Working in Director View” on 
page 37.

•	 Camera View: See “Camera View” on page 42.

•	 Panel View: See “Panel View” on page 43.

•	 Standard Mode: See “Standard Mode” on page 38.

•	 Presentation Mode: See “Presentation Mode” on 
page 40.
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 View and Mode indication.

The Artboard
The Artboard is used to arrange one or more scenes in your 
project, with each scene containing one or more panels 
or media items. You will learn throughout this manual how 
to add scenes, panels, and content to bring your project 
together on the artboard. 

When you create a new MotionArtist project, the artboard 
appears in the center of the interface. The page guide 
around the artboard (off by default) defines an 11x17 
area, which is sized the same as a traditional comic book. 
The View > Page Guides command turns the guidelines on 
and off. 

The rectangle that surrounds the object in the center 
of the project is the camera. Anything within the red 

rectangle will be rendered in the final output. A new 
project contains one panel in the view of the camera. 

You’ll learn more about working with 
cameras in “Chapter 5: Cameras and Stop 

Points” on page 50

“Chapter 10: Working with Panels” on page 
93 goes into more detail about working 

with panels. 
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 Artboard.

The Library Window
The Library window appears when you choose the Window 
> Library command (or COMMAND/CTRL+SHIFT+L). It 
provides an easy way to access files that are in your 

project or on your hard disk. The Library window is 
discussed in more detail in “Chapter 12: The Library 
Window” on page 123.

 Library window.
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The Toolbars
The MotionArtist toolbars appear in a bar directly above 
the timeline. There are several categories of tools arranged 
in five different categories.

•	 The View Selector Tools allow you to choose the view 
that you are working in. From left to right, the choices 
are Director View, Camera View, and Panel View. 
Refer to the following sections in this manual for more 
information about each of these views:

�� “Working in Director View” on page 37

�� “Camera View” on page 42

�� “Panel View” on page 43

 View Selector tools

•	 The Panel Creation Tools allow you to create variously-
shaped panels on the artboard. The content that you 
import into MotionArtist can then be placed within 
these panels to tell a story. From left to right these 
tools are Rectangular Panel, Oval Panel, Polygon 

Panel, Insert Text., and Split Panel (with width setting). 
For more information, see “Chapter 10: Working with 
Panels” on page 93. 

 Panel Creation Tools

•	 The Selection and Workspace Tools allow you to 
move content within the artboard and pan or zoom 
within the workspace. From left to right, these tools are  
Move, Camera, Pan, and Zoom. For more information 
about these tools, see “Chapter 14: Working with 
Objects” on page 151.

 Selection and Workspace Tools

•	 The Audio Tools allow you to record and edit audio 
directly in MotionArtist. From left to right, these 
icons are Record Audio and Mute Audio. These are 
discussed in more detail in “Working with Audio” on 
page 175.
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 Audio Tools

•	 There are five Project Tools that allow you to save or 
export your MotionArtist projects in various ways. A fifth 
tool allows you to generate text and word balloons 
inside your project. From left to right, these icons are:

�� Insert Text: Opens a dialog that helps you 
generate text and word balloons that can be 
edited at any time. See “Working with Text and 
Word Balloons” on page 170.

�� Import: Opens the Import dialog, which allows 
you to select supported file formats for import 
into the selected panel (or to the artboard if no 
panel is selected). Refer to “Chapter 13: Importing 
Content” on page 131 for more information.

�� Share: Opens the Select Movie dialog, where you 
can select a file to share on YouTube or FaceBook. 
See “Publishing to YouTube or FaceBook” on 
page 184.

�� Save: Opens the Save As dialog, which allows 
you to save your project to a specified folder and 
filename. Files are saved with the .ming extension.

�� Export Movie: Opens the Export Animation dialog, 
which allows you to render your project in various 
image and movie formats. See “Exporting Movies 
and Images” on page 182.

 Project Tools

�� Preview HTML5: Click this button to generate and 
open a preview of your project in HTML5 format. 
After MotionArtist generates the content, it will 
open in your default web browser. For more 
information about HTML5 output, see “Chapter 11: 
HTML5 Export and Interactivity” on page 108.

Scene Tabs
When you first start MotionArtist, or when you create a new 
MotionArtist project, there is only one scene in the project. 
You can create as many additional scenes as you need, 
using the File > Add Scene command.
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Each scene in your project appears as a tab at the top of 
the timeline. Simply click one of the scene tabs to work on 
another scene. The timeline will then display the elements 
in that scene, arranged in time and space. 

Scene tabs, and the tools associated with 
them, are discussed in more detail in 

“Chapter 9: Working with Scenes” on page 87.

 Scene Tab Tools

The Timeline
The Timeline appears at the bottom of the MotionArtist 
workspace. The Timeline displays the contents of one 
scene at a time. You switch from scene to scene by 
clicking on one of the scene tabs that appear just 
below the MotionArtist toolbar. “Chapter 6: The Timeline 
Window” on page 60 discusses the arrangement of the 
Timeline in more detail.

 The Timeline

MotionArtist also has a standard set of transporter and 
current frame indicator controls that allow you to navigate 
through the contents in the scene. 

 Transporter and Current Frame Indicator

Setting Preferences
The Preferences dialog allows you to configure general 
options for MotionArtist. You can also specify login 
information for your YouTube account and change Editor 
and GUI colors.

To open the Preferences dialog, choose Edit > Preferences 
(Windows) or choose the Preferences command from the 
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MotionArtist menu (Mac). The Preferences dialog consists 
of four tabs which are described in the sections that follow.

Options
The Options tab allows you to set various display and 
performance options for MotionArtist. The settings in this 
tab include the following:

 Option preferences.

•	 Enable GPU accelerated drawing:  Check this option 
to enable GPU acceleration in MotionArtist. Uncheck 
the option if you do not want to use GPU acceleration.

•	 Enable export/import hardware acceleration: Allows 
specialized hardware acceleration for import/export 
of specific video codecs.

If there is instability with importing or exporting 
H.264 based video, the user should update 

their video card drivers and/or disable hardware 
acceleration. To disable hardware acceleration 
within the application, go to the MA preferences 
and uncheck the “Enable export/import hardware 
acceleration” check box.

•	 Zoom with drag box: When this option is on, allows you 
to draw a box around the area that you want to zoom 
into, rather than using a continuous zoom.

•	 Auto-scale imported vectors: Makes it easier to import 
multiple Illustrator files (for example, multiple body parts 
in a character). The imported files will all be in scale 
with each other when this option is checked. When this 
option is turned off, you may need to press the Esc key 
to automatically zoom in to the selected points after 
you import the files.
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•	 Use SMPTE timecode: Shows time in the timeline using 
SMPTE timecode instead of frame numbers. SMPTE 
timecode looks like this: 00:02:34:07 That would be 0 
hours, 2 minutes, 34 seconds, and 7 frames.

•	 Nearest neighbor sampling for new image layers: 
When an image is scaled up larger than its original size, 
MotionArtist will try to smooth out the areas in between 
pixels to create a smoother image. Turn this option off 
if you want the enlarged image to appear blocky.

•	 Auto save for crash recovery: When turned on, 
MotionArtist will automatically save your work every 
thirty seconds to a temporary file. If the application 
crashes, you can recover your work the next time you 
start the application. In the event that you are working 
on very large files and your workflow is slowed down 
by saving every thirty seconds, you can turn this option 
off to improve performance.

•	 Startup File: Use the dropdown list to select the default 
project that you want to load when MotionArtist starts 
up. The choices are:

�� Default Startup File: Uses the default file that is 
installed with MotionArtist

�� Empty Document: Starts with a blank document 
with no contents

�� Last Saved Document: Uses the document that 
was most recently saved.

�� Other File: Allows you to select a custom startup 
file that you create yourself and save to your hard 
disk.

•	 Poser Location: Click the Poser Location button to 
select the path to your Poser installation. Choose the 
folder in which the poser.exe file is located.

Web Uploads
The Web Uploads tab is used to enter your YouTube user 
account name and password. MotionArtist will log into 
this account to post YouTube videos when you select 
the Share > YouTube command to send a project file to 
another person
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 Web Upload preferences.

•	 Username: Enter your YouTube user name.

•	 Password: Enter your YouTube password.

•	 Private uploads: Check this option if you want your 
uploads to be private uploads rather than public 
uploads.

Editor Colors
The Editor Colors tab allows you to change the color 
scheme for the editor window, including various options for 
background and object colors.

 Editor Color preferences.

•	 Panel Fill: The default fill color of the panels in your 
project.



MotionArtist
Reference Manual

35

Chapter 3: The MotionArtist Workspace 

•	 Camera Outline: The color of the rectangle that shows 
the objects seen in the camera.

•	 Panel Stroke: The default outline color for the panels.

•	 Camera Shade: The color that is overlaid on the 
artboard and surrounding workspace which dims 
objects that are not in view of the camera.

•	 Selected Object: The color of the bounding box that 
surrounds the currently selected object or objects.

•	 Camera Target: The color that will overlay on top of 
the artboard when a camera target is drawn.

•	 Grid: The color of the grid when it is displayed.

•	 Guides: The color of the page guides when displayed.

•	 Default stroke width: Allows you to specify the default 
Stroke Width setting that appears in the document 
window.

•	 Reset: Press the Reset button to return to default 
application colors

GUI Colors
The GUI Colors tab allows you to change the color 
scheme for the application, including various options for 
background, text, and widget colors. A preview of your 
changes appears in the Sample Widget area as changes 
are made. 

 GUI Color preferences.
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If you make any changes to the GUI Colors, 
the changes will not appear until the next 

time you start MotionArtist.

•	 Color Theme: Click the Color Theme button at the top 
of the GUI Colors tab to choose from one of several 
different color schemes. You can then modify the 
color scheme further if desired.

•	 Press the Reset button to set the color scheme back to 
the default settings.

•	 Check the Use Large Fonts option to increase the size 
of the fonts used in the application.
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Chapter 4: MotionArtist 
Views and Modes

MotionArtist projects are hierarchical, with the elements of 
the project being as follows:

•	 The Artboard is at the top level. The artboard 
represents a traditional 11x17 comic artboard.

•	 Scenes are at the next level. Think of a scene as a 
page in a comic, or a chapter in a book. Each scene 
is shown in the timeline with a tab. The timeline displays 
the currently selected scene.

By default, the first scene is named Scene 1. 
When you add another scene to your 

project, it will be named with the next subsequent 
number (Scene 2, Scene 3, and so on). Double-click 
the scene tab in the Timeline Window to change 
the name of the scene. For more information about 
scenes, see “Chapter 9: Working with Scenes” on 
page 87.

•	 Panels are the next level down from scenes. Each 
scene can contain one or more panels contained 
within it.

•	 Floating objects are at the most basic level ...  these 
are free-floating elements that appear on the 
artboard, but are not placed in a panel. 

Working in Director View
You can view your MotionArtist projects in one of three 
different views: Director View, Panel View, or Camera View.  
When you first start your project, you work in Director View.

When you work in Director View, any tool 
that you choose from the toolbar will remain 

active until you select another tool.

In Director View, a large rectangle represents a 10,000 foot 
view of a traditional 11x17 comic artboard. There is one 
scene in the project (with the scene tab being displayed 
in the timeline), and one panel in the scene. The panel is 
designed to display graphics or movies, and can also have 
sound attached to it. 

You’ll do most of your assembling and editing work in 
Director View, and can switch to and from this view using 
one of the following methods at any time:
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•	 Choose View > Director View (or COMMAND/CTRL+1).

•	 Click the Director View icon in the MotionArtist toolbar. 

 Director View.

 A new MotionArtist project.

Director View allows you to work in two modes. The mode 
that you are currently working in appears in the upper-left 
corner of the interface:

•	 Standard Mode allows more control over how the 
camera moves through your project. In Standard 
Mode, you can use the Camera tool (shortcut C) to 
control the motion path, stop points, and timing of the 
camera in greater detail. See “Standard Mode” on 
page 38.

•	 Presentation Mode allows you to add panels or floating 
objects (free-floating content) while automatically 
animating the camera. See “Presentation Mode” on 
page 40, which follows.

Standard Mode
When you create a new scene in MotionArtist, you start in 
Standard mode. To switch to Standard Mode at any time, 
click the Presentation Mode button in the Scene tab to 
deactivate it as shown in the figure below.  
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 The Presentation Mode icon is deactivated when you are in 
Standard mode.

When you work in Standard Mode, the following conditions 
apply:

•	 When you design a scene entirely in Standard Mode, 
you’ll need to use the Camera tool (shortcut C) or the 
Auto Camera command to add camera movement 
and timing. 

For more information about using the 
Camera Tool, see “The Camera Tool” on 

page 50.

For more information about using the Auto 
Camera command, see “Using Auto 

Camera” on page 56.

•	 You will be able to enable or disable the Camera tool 
in Standard mode. When enabled, you can use it to 
control camera positions. This gives you more control 
over how the camera moves over the elements in your 
scene.

•	 When the Camera tool is activated you can see the 
motion path of the camera. Use the Camera tool to 
move the camera from panel to panel, or from object 
to object in your scene. You can change the motion 
path, add additional stop points to pause at several 
places in the same panel, and so on. 
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 Camera View in Standard Mode.

Presentation Mode
When you work in Presentation Mode, you can quickly 
assemble a scene by placing panels and content on the 
artboard. The camera will automatically move from one 
content item to another during playback, based on its 
placement in the timeline.

To switch to Presentation Mode at any time, use one of the 
following methods:

•	 Toggle the Presentation Mode icon in the Scene tab 
“on” as shown in the inset on the left in the figure 
below. 

•	 Double-click the Scene tab in the timeline to open the  
dialog. Check the Presentation Mode option in the 
Scene section of the General tab.

When you work in Presentation mode, panels and floating 
objects will appear dimmed until you reach the frames at 
which they appear in the timeline.
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The Project Settings dialog allows you to set 
the amount that panels are dimmed. 

Choose File > Project Settings (or COMMAND/
CTRL+SHIFT+P), and enter the desired setting in the 
Automatic Panel Opacity field. For more information 
about the Project Settings dialog, see “Project 
Settings” on page 83.

When you switch to Presentation mode, you 
will receive notification that doing so will 

change camera movements and timing. Click 
Continue to proceed, or Cancel to remain in 
Standard Mode.

Presentation Mode allows you to quickly and easily add 
panels and floating objects to your project. For more 
information about working with content in Presentation 
Mode, see “Camera Targets (A)” on page 97, 
“Scattering Objects on the Artboard” on page 162 and 
“Scattering Objects in a Panel” on page 165.

 Director View in Presentation Mode.
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Because the camera is animated 
automatically in Presentation Mode, the 

Camera Tool is disabled.

Camera View
When you view your project in Camera View, it fits the 
currently selected panel and all of its contents within the 
view. Camera View is stationary and does not animate. 
You can switch to Camera View using one of the following 
methods:

When you work in Camera View, the 
Camera tool becomes active.

•	 Choose View > Camera View (or COMMAND/CTRL+2).

•	 Click the Camera View icon in the MotionArtist toolbar.

 Camera View.

If you press the Play button while viewing your project in 
Camera View, you’ll be able to see what your project will 

look like to the viewer, through the eye of the camera. 
You’ll see the panels and floating objects in the scene 
move into view of the camera in sequence as the 
playhead moves through the timeline.

 Camera View.

Camera view and Panel view can be used 
to display z-depth changes, and will display 

the effects of the Arrange in 3D command (see 
“Arranging Panels in 3D Space” on page 105), 
and the effects of moving objects closer or further 
to you in 3D space (Z depth). 
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Camera view displays perspective changes. 
You may see objects in Camera view that 

you will not be able to see while playing your 
project in Director view or Panel view, which views 
your project only from the front perspective. 

Panel View
Choose View > Panel View (or COMMAND/CTRL+3) or click 
the Panel View icon to switch to panel view. The view will 
fit the currently selected panel into view.

 Panel View.

When you work in Panel View, the Move tool 
becomes active.

 A panel displayed in Panel View.

If your scene contains only floating objects 
(items that are not placed within a panel), 

choosing Panel view will be ineffective.

MotionArtist panels are similar to panels on a comic book 
page. They can display images, movies, text with word 
balloons, and sound, and the content can be animated 
over time. A panel allows you to display your content in 
a defined area. In other words, if your content exceeds 
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the size of the panel, the areas outside the boundaries of 
the panel will be masked out. This allows you to scale the 
content inside the panel without obscuring the view of 
other areas on the artboard.

When you view your scene in Panel View, the contents 
of that panel appear in the timeline. You can select an 
object in the panel, or in the timeline, and then change 
the position, scale, or rotation of the selected item over 
time to add animation to the panel.

 Panel contents displayed in the timeline.

View Helpers and Guides
While working in MotionArtist, there are a number of 
indicators that you can use to help lay out your content.

•	 Choose View > Page Guides to show or hide the 
artboard workspace guides that show the 11x17 
workspace area. The outlines will display when the this 
option is checked, and will be hidden when the option 
is not checked.

You can change the color of the page 
guides in the Editor Colors tab of the General 

Preferences dialog. See “Editor Colors” on page 
34.
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 Page guides.

•	 Choose View > Camera Frame to toggle the display of 
the camera frame guide. 

 Camera Frame.

•	 Choose View > Video Safe Zones to show or hide the 
video safe zone rectangles. This option is enabled 
when you are viewing your project in Camera View. 
These rectangles represent the areas in your project 
that will be safe for title (inner rectangle) and content 
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(outer rectangle) placement when your project is 
viewed in broadcast formats such as NTSC or PAL. 
Areas outside the video safe zones may not be visible 
due to overscanning. The rectangle is hidden when 
this option is  unchecked, and visible when the option 
is checked.

 Video Safe Zones rectangle.

•	 Choose View > Thirds Grid to divide the view seen 
through the camera into three horizontal and vertical 
sections. This option is enabled when you are working 
in Camera View.

 Thirds grid.

Displaying and Setting the Grid
MotionArtist also allows you to display a grid that you can 
use as a placement guide. 

You can change the color of the grid in the 
Editor Colors tab of the General Preferences 

dialog. See “Editor Colors” on page 34.
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1.	 To display the grid on the artboard, choose View > 
Enable Grid (or COMMAND/CTRL+G). 

2.	 Choose View > Grid Settings (or COMMAND/
CTRL+SHIFT+G) to display the Grid Settings dialog.

 Setting the grid.

3.	 Choose the type of grid you want to use from the Grid 
Style dropdown list:

�� Square: Displays a square grid, with equally 
measured horizontal and vertical lines

 Part of a scene showing the Square Grid enabled.

�� Polar: Displays a circular grid that radiates from a 
center point.
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 Part of a scene showing the Polar Grid enabled.

�� Isometric: Displays an isometric grid consisting of 
vertical and diagonal lines.

 Part of a scene showing the Isometric Grid enabled.

4.	 The default spacing of the grid is 50 pixels. Enter a new 
spacing amount in the Grid Spacing field.

5.	 Click OK to apply the new settings.

Resetting the View
To reset the view of your scene, choose View > Reset. The 
workspace view will be reset to the default settings in any 
of the views. 

•	 In Director View, the view will adjust to center the 
entire artboard.



MotionArtist
Reference Manual

49

Chapter 4: MotionArtist Views and Modes

•	 In Camera View, the view will adjust to center and fit 
the view through the camera.

•	 In Panel View, the view will adjust to center and fit the 
selected panel. 



MotionArtist
Reference Manual 

50

Chapter 5: Cameras and Stop Points

Chapter 5: Cameras 
and Stop Points

The Camera Tool
The Camera tool (shortcut C) can be used in either 
Director View (while in Standard Mode) or Camera View. 
You use the camera tool to move, scale, or rotate the 
camera view while you assemble your scene. At the same 
time, you can also make changes to the motion path as 
described in the following section.

 Camera Tool.

The Motion Path
When you have the Camera tool selected, you can see 
a spline-shaped motion path, with camera stop points 
represented as dots. The MotionArist camera moves 
along this spline-shaped motion path. When you switch to 

Camera View, you can rotate and zoom the camera as it 
travels along this path.

You can edit the motion path in the following ways:

•	 In Director view, drag and pull the path to change 
the shape of the curves. Doing so will add another 
stop point indicator that you can move to the desired 
location. The figure that follows shows a camera 
motion path in Director View. It begins at the first panel 
and successively moves over each additional panel in 
the scene. The dots on the motion path are stop points 
(areas where the camera pauses over the underlying 
area). This motion path and the position of the stop 
points are editable, using the Camera tool. 
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 Motion path and stop points in Camera view.

Editing Stop Points in Director 
View
Stop points are places along the path where the camera 
will pause to display content. You can think of a stop point 
as a key frame for camera movement. The camera moves 
between these stop points based on the settings that you 
specify in the Camera Stop Point dialog. 

MotionArtist has two different types of stop 
points, which are distinct from each other but 

work in similar ways. Camera stop points define a 
point in time at which a specific point is paused 
over an object and viewed through the camera. 
Object stop points define a point in time at which 
an object is in a specific state (position, rotation, 
scale, visible, invisible, etc.) For more information 
about Object stop points, see “Object Stop Points” 
on page 152.
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When you have multiple Stop Points on the 
timeline that have the same translation(x,y) 

values but are occurring at different points in time, 
the Stop Point displayed on the work space will be a 
diamond. If you switch to Director’s view and the 
double click with the camera selection tool on the 
displayed stop point, the scrubber will move to the 
first Stop Point on the timeline in that location.

Camera stop points are placed at the center 
of a panel or floating object by default when 

Presentation Mode or the Auto Camera command 
are used.

It is possible to have a stop point at which the 
camera does not stop. This type of stop point 

is also displayed dot on the motion path, but has a 
Hold Duration of 0 in the Camera Stop Point Dialog.

You can open the Edit Stop Point dialog with 
the Arrange > Position Camera command, or 

by double-clicking a stop point in the timeline. 

To edit stop point settings in Director View, follow these 
steps:

1.	 Click the Director View icon in the MotionArtist toolbar, 
or choose View > Director View (or COMMAND/
CTRL+1).

2.	 For the scene that you want to work on, toggle 
Presentation Mode off by clicking the Presentation 
Mode icon in the Scene tab, as shown in “Standard 
Mode” on page 38.

3.	 Click the Camera tool, or use the keyboard shortcut 
C to select it. The Motion Path and stop points will 
appear.

4.	 Double-click the desired stop point with the Camera 
tool. The timeline will advance to the location of that 
stop point. In addition, the Camera Stop Point dialog 
appears.
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 Camera Stop Point dialog.

5.	 Edit the following settings, as needed:

�� Stop Point Frame: Displays the frame in the 
timeline that the Stop Point currently appears. 
You can enter  a new frame number, if desired, 
to move the stop point to a different frame in the 
animation. 

You can drag a stop point left or right in the 
timeline to visually change the frame at 

which the stop point occurs. You can also SHIFT-
click to select multiple stop points.

�� Pause Playback (HTML only): Allows you to add a 
camera pause point for HTML 5 interaction. See 
“Pausing and Resuming Playback” on page 113 
for more information.

�� Hold Duration: Displays the number of frames that 
the camera will pause over the stop point. By 
default, this is 30 frames. You may need to adjust 
this value to allow viewers sufficient time to read 
text on screen. 

When you increase the length of a hold 
duration, you’ll need to make sure that there 

are enough frames in your animation to 
accommodate the increased hold duration. For 
example, if you are at frame 60 of a 100-frame 
animation, but you want to hold the camera for 90 
frames, you’ll need at least 150 frames in your 
animation to increase the hold duration to 90 
frames.

�� Position X, Y: Displays the current X and Y 
coordinates of the stop point. By default, a stop 
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point appears at the center of a panel that you 
create in Presentation Mode. You can adjust the 
stop point by entering offset values in the X and Y 
fields. Press the Reset button to reset back to the 
default position.

You can also adjust the stop point in Director 
View by moving it with the Camera Tool after 

you exit the Camera Stop Point dialog. See 
“Camera View” on page 42 for further 
information.

�� Zoom: Displays the zoom (or magnification) level 
of the camera when it reaches the stop point. If 
the panels were created in Presentation Mode 
or with the Auto Camera command, the zoom 
level is automatically set so that entire width (for 
landscape panels) or height (for portrait panels) 
is framed within the camera view. Smaller values 
move the camera away from the artboard, 
making the panel seem smaller. Larger values 
move the camera closer to the artboard, making 
the panel seem larger. Press the Reset button to 
reset back to the default zoom level.

�� Roll: Displays the angle or tilt of the camera. By 
default, the camera roll is set to zero. You can 
adjust the tilt of the camera by adjusting the Roll 

indicator, or by entering a Roll setting (in degrees) 
in the text box. Press the Reset button to reset back 
to the default rotation angle.

You can visually adjust the camera angle in 
Camera View by rotating it with the Camera 

Tool. See “Camera View” on page 42 for further 
information.

�� Delete Stop Point: Click this button to delete the 
currently selected stop point. 

Note that you will not be asked to confirm 
the deletion of the Camera Stop Point; 

however you can use the Edit > Undo to reverse the 
deletion.

6.	 Choose OK to apply the settings, or Cancel to exit 
without saving.

Transforming the Camera in 
Camera View
If you switch to Camera View while the Camera Tool is 
selected, you’ll see a pair of concentric circles in addition 
to the motion path and stop points. The circles are filled 
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with a semi-transparent black so that you can view them 
more easily. These concentric circles allow you to control 
the position, rotation, and zoom level of the camera. In 
Camera View, use the Camera Tool to edit the path as 
follows:

•	 Drag up, down, left, or right inside the inner circle to 
move the selected stop point. A move cursor appears 
when you can move the camera.

•	 Drag up or down in the area between the two circles 
to rotate the camera. A rotate cursor appears when 
you can rotate the camera.

•	 Drag up, down, left, or right outside the outer circle to 
zoom the camera. A zoom cursor appears when you 
can zoom the camera.

 Motion path and stop points in Camera view.

Editing Stop Points in Camera View
When you are working in Camera View, you can click on 
an empty path segment with the Camera tool to add a 
new stop point. This will allow you to adjust the curve of the 
path.
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In addition, you can move backward and forward in the 
timeline to add a stop point to move to a different part 
of an image or panel. For example, if you have a comic 
panel that has word bubbles over the illustration, you can 
bring that area into focus first. Edit the Hold Duration of 
that stop point to ensure that you have given the viewer 
enough time to read the text.

 Word bubbles brought into the view of the camera.

After advancing the timeline after enough time to read 
the text in the word balloon, you can create a new stop 
point that pans the camera down to bring the characters 

into focus. You can then edit the new stop point to pause 
the camera for a specified amount of frames.

 Characters brought into the view of the camera.

Using Auto Camera
You’ve already learned that the camera is animated for 
you automatically in Presentation Mode, and that you 
have to animate it manually if you build your scene in 
Standard Mode. You can use the Auto Camera command 
to animate the camera and build a motion path for you 



MotionArtist
Reference Manual

57

Chapter 5: Cameras and Stop Points

automatically, based on the arrangement of items that 
you have in your timeline. 

To demonstrate this, follow these steps:

1.	 Start a new MotionArtist project.

2.	 If necessary, switch to Standard Mode by toggling the 
Presentation Mode icon off.

3.	 When you create a new project, an empty panel 
appears at the center of the scene. Use the Move 
tool (keyboard shortcut V) to position it at the top-left 
corner of the current scene.

 Move tool.

4.	 Use the Panel tools (described in more detail in 
“Chapter 10: Working with Panels” on page 93) to 
create additional panels on the artboard. An example 
is shown in the following figure.   Five panels created in Standard Mode.
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 The same five panels shown in the timeline.

5.	 You will notice that the new panels appear one on 
top of the other in the timeline, playing them all in the 
same 30-frame segment of the timeline. To spread 
these panels out over time, choose Arrange > Auto 
Camera followed by one of the following options:

�� Auto Camera All: Runs auto camera on everything 
, and begins the Auto Camera movement at 

the frame that the playhead is currently on. For 
example, if the playhead is currently on frame 60 
and you choose the Auto Camera All command. 
the first object will first appear at frame 60 and 
each successive object will appear in the camera 
after that.

�� Auto Camera Selected: Runs auto camera only on 
the selected objects.

�� Auto Camera Targets: Runs auto camera only on 
designated camera targets. For more information 
about camera targets, see “Camera Targets (A)” 
on page 97.

�� Auto Camera with Pause Points: For projects 
that are exported to HTML5, or to published to 
MotionArtist.TV. Runs auto camera and places 
pause points at the end of the current panel 
duration. This causes the camera to pause at 
the end of each object that you apply the auto 
camera to. The user will have to click the scene or 
press the Enter key to continue the presentation. 
This adds automatic interactivity to your 
presentation so that the user can follow it at his or 
her own speed.
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If you need to rerun the Auto Camera with 
Pause Points command again on the same 

selected objects, it is recommended that you clear 
your animation before doing so to remove existing 
pause points that could affect the desired result. 
Select the layers that you want to change, then 
choose Arrange > Animation > Clear Camera after 
Current Frame, and then reapply the Arrange > 
Animation > Auto Camera command.

6.	  The panels will be spread out across the timeline in 
the order in which they were created. The amount 
of space between the panels represents the length 
of time that it will take to transition from one panel to 
another.

 Panels spread over time after using Auto Camera.

7.	 Press the Play button to view the camera motion, and 
use the Camera View and the Camera Tool to make 
adjustments as needed.
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Chapter 6: The Timeline 
Window

The Timeline window displays all of the elements in your 
scene. When you open MotionArtist you will initially see two 
things in the timeline: the camera, and the default panel.

The elements of the timeline are shown in the following 
figure. They are as follows:

 Timeline.

1.	 Play controls: See “Play Controls” on page 63.

2.	 Scene Tab: Select one of the scene tabs to display 
the content of that scene in the timeline. For more 
information about scenes, see “Chapter 9: Working 
with Scenes” on page 87.

3.	 Frame Numbers: Displays a numerical indication of the 
frame numbers in the timeline.

4.	 Playhead: The playhead moves across the timeline 
and serves as an indication of the current frame that is 
being played. You can drag the playhead left or right 
to scrub across the timeline.

5.	 Camera Layer: Displays content areas, transition 
areas, and stop points that exist in the current scene. 
For further information, see “Camera Layer” on page 
64.

6.	 Camera Stop Point: Camera Stop Points are 
represented by small dots in the Camera Layer. You 
can select these dots to advance to that place in the 
timeline. You can also delete stop points by clicking on 
them in the timeline and pressing the Delete key.

7.	 Transition area (shown in Camera Layer): “Blank” areas 
in the timeline indicate places where the camera is 
transitioning from one content item to another. You 
can specify different styles for each transition. For more 
information, see “Using Transitions” on page 89.

8.	 Scene Content: The contents in your scene appear 
as bars of different lengths in the timeline. The size of 
the bars determines the length at which they play. 
The default length of a panel or floating object is 



MotionArtist
Reference Manual

61

Chapter 6: The Timeline Window

30 frames. This is adjustable in the  dialog. For more 
information about scene content, see “Chapter 13: 
Importing Content” on page 131.

The Timeline will display keyframes for 
translation, rotation, scale, opacity, blur, and 

visibility.

Items are displayed in the Timeline in two ways:

•	 Items are layered such that the panels or floating 
objects that appear at the bottom of the timeline 
are in the back (or farther away from you), and the 
items at the top of the timeline are in the front (closer 
to you). This is similar to the way that layers work in a 
layered image editor such as Photoshop.

•	 The content in your scene is also displayed in time, with 
items that play first at the left side of the timeline, and 
items that play later toward the right.

The camera appears at the bottom of the 
MotionArtist workspace by default. You can 

show or hide the timeline if desired. To display or 
hide the Timeline window, choose Window > 
Timeline, or use the keyboard shortcut COMMAND/
CTRL+SHIFT+T.

Zooming In and Out of the 
Timeline
Use the View > Timeline Zoom In command (or OPTION/
ALT+Mousewheel Scroll Up to zoom in closer to the timeline 
(displaying half as many frames in the timeline window).

Use the View > Timeline Zoom Out command (or OPTION/
ALT+Mousewheel Scroll Down to zoom out from the 
timeline (displaying twice as many frames in the timeline 
window).

Use COMMAND/CTRL+Mousewheel Scroll Up to scroll left 
(earlier) in the timeline.

Use COMMAND/CTRL+Mousewheen Scroll Down to scroll 
right (later) in the timeline.

Viewing Objects in the Timeline
When viewing content in the timeline, you’ll notice the 
following states:

•	 Normal coloring during the content’s duration (as 
interpreted by the Auto Camera feature)

•	 Faded coloring when the image is visible but not being 
tracked by the Auto Camera
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•	 Blank when the image has been made invisible by the 
user.

If a layer appears before or after the visible section of the 
timeline, the name of the layer will still be visible at the left 
or right edge of the timeline. You will be able to click on 
the layer name and open the  dialog to edit the properties 
of the content.

 The names of layers that extend beyond the visible areas in 
the timeline are listed at the left and right edges of the timeline.

In cases where you have more layers in the timeline than 
can be displayed vertically, you will see a vertical scrollbar 
at the right edge of the timeline. The scrollbar allows you to 
move up or down to view the layers, allowing you to select 
the layers that you want to work with.  Alternately, you 
can click an item on the artboard, and the timeline will 
automatically scroll to show the newly selected layer.

In addition to displaying the name and type 
of layer, the timeline now shows whether or not the 
layer is visible.  Press the  icon to turn the visibility 
on or off. for that layer 

A padlock icon in the timeline provides an 
indication of whether a layer is locked or not. You 
can click the padlock to toggle between locked 
and unlocked. 

 Vertical scrollbar. 
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Camera Targets will appear in the timeline, 
and will be named Camera Target. For more 

information about Camera Targets, see “Camera 
Targets (A)” on page 97.

Minimized Timeline View
A resize handle appears in the center top of the timeline. 
Drag the handle to reduce the timeline to its minimum 
height, so that you can see more of the artboard. At 
minimum height, the layers in the timeline will not be visible, 
but a slider will be available to move through the timeline. 
The toolbars will also remain visible.

 When the height of the timeline is reduced, a slider remains 
available so that you can navigate through the timeline.

Play Controls
The Play controls are standard controls that are used in 
many animation programs. They help you move backward 

and forward in the timeline and play or pause the project 
while you work on the animation.

 Play controls.

From left to right, the controls are as follows (keyboard 
shortcuts shown in parentheses):

•	 Previous Stop Point ([): Click to move to the previous 
keyframe for the selected item.

•	 Rewind (SHIFT+ALT+Left Arrow): Rewinds to the first 
frame in the scene.

•	 Step Back (Left Arrow): Goes backward one frame at 
a time in the scene, each time you click.

•	 Play/Stop (Spacebar): Toggles between play and 
pause. 

�� When Play is pressed in Director View or Camera 
View, the scene plays in real time until it reaches 
the end of the document. Then it will stop and 
jump back to the frame that you were on when 
the Play button was pressed.  
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�� When Play is pressed in Panel view, the scene will 
play in real time and continue looping until you 
press Pause.

•	 Step Forward (Right Arrow): Goes forward one frame 
at a time in the scene, each time you click.

•	 Jump to End (SHIFT+ALT+Right Arrow): Advances to the 
last frame in the scene.

•	 Next Stop Point (]): Click to advance to the next 
keyframe for the selected item.

•	 Frame: Displays the frame number where the 
playhead currently appears, or allows you to enter a 
frame number to advance or rewind to.

Camera Layer
The Camera layer appears at the top of the timeline. This 
layer provides a visual indication of where the panels, 
transitions, and camera stop points appear in the scene.

 The Camera layer is the topmost layer in the Timeline.

•	 A stop point appears as a small dot (usually at the end 
of  a space in the timeline that designates a transition). 
You can delete a stop point by clicking on it with the 
Move tool (keyboard shortcut V), after which the stop 
point turns red. Then press the Delete key.

•	 The white bars in the camera layer designate areas 
where the camera is paused over content. 
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•	 The spaces in between the bars indicate transition 
areas, where the camera is moving from one panel or 
floating object to another.

Using Motion Assist
Choose Arrange > Motion Assist to place MotionArtist in a 
mode where it synchronizes changes across different types 
of keyframes. This mode is on by default, and is designed 
to make the process of animation easier for those who are 
new to keyframe animation.

As you become more comfortable with keyframe 
animation, and which properties are being keyframed 
at what time, you can turn the Motion Assist feature off. 
Select the Arrange > Motion Assist command to toggle the 
feature off.

Using Motion Assist with Cameras
Motion Assist is a per-object setting (not global). It also 
works with the camera, but the object in that case is the 
scene. 

You will need to make sure that there are no 
other items selected before you turn 

MotionAssist on for the camera. One way to do this 
is to click an empty space with the Move tool.

You can also turn Motion Assist off to key camera position, 
zoom, or roll individually. An example is as follows:

1.	 Switch to Camera View (or, make sure that nothing is 
selected in the scene) and choose Arrange > Motion 
Assist to uncheck it.

2.	 Click and drag outside the double-circle camera 
controls in Camera View to adjust your camera zoom 
manually. Motion Artist will create a stop point. The 
only value that is keyed here is the scale. 

3.	 You can see the indicator with a blue stop point next 
to Scale in the Camera Stop Point window. To access 
this window choose Arrange > Position Camera.
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 Camera zoom stop point.

Using Motion Assist with Objects
Motion Assist can be turned on or off for a single selected 
object.  When you make a change in your scene (such as 
rotating an object at frame 10), all of the other parameters 
of the object (translation, scale, etc.) will also get a 
keyframe at the same frame, thereby ensuring the object 
will be exactly at the desired position, rotation, and scale 
at that frame. This helps to prevent keyframes from earlier 

in the animation to affect the properties that you want at 
that current frame.

A good way to use Motion Assist is to choose 
where you want your object to start, and 

where you want it to end, including rotation or 
opacity settings that you want to include. Then you 
can change the path in any manner you choose or 
go back to each stop point to make adjustments.

When you turn Motion Assist off, you can move an object 
over time to multiple locations. For example, let’s say you 
start with an object that is on the left side of the scene.  
At frame 150, you move it to the center of the scene. 
Then at frame 225, it moves off the right side of the scene, 
making a total of three translation keyframes. Finally, you 
rotate the object at frame 300. When you play back the 
animation you will notice that the rotation slowly adjusts 
between frame 1 and frame 300, where you adjusted the 
rotation. 

If you had created a similar example with Motion Assist 
on, the rotation would only occur between frame 225 (the 
third translation stop point) and frame 300 (where you 
rotated the object).
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Part 3: Creating 
with MotionArtist
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Chapter 7: The Object 
Settings Window

In the chapters that follow, you’ll learn how to work with 
Scenes, Panels, and imported content (referred to as 
objects). As you add these items to your project, there will 
be times that you will want to change the default settings. 
The Object Settings window allows you to customize the 
settings for the content in your project.

The options you see in the Object Settings window will 
change, depending on how you open it:

•	 To apply settings for a scene: Switch to Director View if 
necessary. Click the Scene Tab for the scene that you 
want to edit, then double-click on the name of the 
scene.

•	 To apply settings for a panel: Switch to Director View 
if necessary. Then do one of the following to open the 
Object Settings dialog:

�� Double-click the desired panel on the artboard 
with the Move tool (keyboard shortcut V).

�� Click the desired panel with the Move tool and 
choose Window > Layer Settings (or COMMAND/
CTRL+SHIFT+I).

•	 To apply settings for an image or movie: Select the 
panel that contains the image or movie that you want 
to edit. Then switch to Panel view, and do one of the 
following to open the Object Settings dialog:

�� Double-click the desired image or movie that you 
want to edit.

�� Click the desired image or movie with the Move 
tool and choose Window > Layer Settings (or 
COMMAND/CTRL+SHIFT+I).

The Object Settings dialog contains three buttons at the 
bottom, which are used as follows:

•	 OK: Click this button to apply any changes that you 
have made. The Object Settings dialog will close and 
you will return to the main editing window.

•	 Apply: Click this button to apply any changes that you 
have made. The Object Settings dialog will remain 
open so that you can make changes in another tab.

•	 Cancel: Click this button to exit the Object Settings 
dialog without applying changes.
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If the Object Settings dialog has the current 
focus, you can also press the ESC key to 

close it.

The General Tab
The General tab of the Object Settings window displays 
different options, depending on whether you want to 
apply settings to a Scene, a Panel, or an Image. Open 
the Object Settings window as described in the previous 
section to view the settings that you want to change:

 General Tab options (Floating Object options shown)
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Name
The Name field in the Object Settings window allows you 
to enter a more descriptive name for your Scene, Panel, 
or Image:

•	 By default, a scene is named Scene x when created, 
where x is a numerical value based on the existing 
scenes in your project.

•	 By default, a panel is named Panel x when created, 
where x is a numerical value based on the existing 
panels in your scene.

•	 By default, the original filename for the image appears 
here.

 Name field

Motion Assist
Check this option to turn Motion Assist on for the selected 
panel or object. For more information about Motion Assist, 
see “Using Motion Assist” on page 65.

Compositing Effects
There are several settings in the Compositing Effects 
section of the General Tab that are common to Scenes, 
Panels, and Images. These options are as follows:

 Compositing Effects

•	 Visible:  When checked, the Scene, Panel, or Image is 
visible on the timeline and will be rendered in your final 
output. When  unchecked, the item will not be visible 
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on the timeline or in the render. You can turn visibility 
on or off at any frame. 

•	 Blur Radius: Lets you apply a blur (in pixels) to the 
scene to simulate such effects as camera focus. The 
blur can be animated over time to make the scene 
look like its coming in and out of focus

•	 Opacity: Allows you to modify the transparency of the 
scene, panel, or image. An opacity value of 100 will 
not affect the item at all, while a value of 0 will make 
it totally transparent. By changing the value from 0 
at frame 1 to 100 at frame 10, the scene will seem 
to gradually appear out of nowhere, which in some 
cases is more desirable than the type of on/off visibility 
provided by the Visible checkbox

•	 Blend Mode: Identifies how the scene or object will 
blend with underlying content. These are similar to 
blend modes used in Photoshop. Choices are Normal, 
Multiply, Screen, Overlay, Add, Difference, Hue, 
Saturation. Color, and Luminosity.

•	 Attached to Camera: When checked, this option 
aligns the selected object’s animation to the center of 
the camera as it moves through the art board. This is a 
global parameter, and the animation will return to its 
original orientation when unchecked.

Scene-Specific General Settings

The General tab in the Object Settings dialog displays the 
following unique options when you are applying settings to 
a selected scene:

 Additional HTML Export options for Scenes

•	 Inherits default styles from scene: Checking this box 
gives all new panels default settings, whcih can be set 
in the scene settings dialgue. 
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With Motion Artist 1.1, you can speed up 
workflow by setting a default panel style in 

the  “scene settings” window.  This way, every new 
panel will have the same stroke and fill settings.  
Unchecking this feature allows for specific tailoring 
of panel styles. 

•	 Presentation Mode: Check this option to place the 
scene in Presentation Mode. Uncheck this option to 
place the scene in Standard Mode. These modes are 
discussed in “Presentation Mode” on page 40 and 
“Standard Mode” on page 38.

•	 Scene Duration: Enter the number of frames for the 
amount of time that the scene will appear in the 
timeline. 

•	 Automatic: When this option is checked, the scene 
duration will be set automatically by MotionArtist. 
Uncheck this option if you want to extend panel 
duration beyond the last stop point in the scene, and 
enter the desired length in the Scene Duration field.

Panel-Specific General Settings

The General tab in the Object Settings window displays the 
following unique options in the Panel section when you are 
applying settings to a panel:

 General Tab options for Panels

•	 Inherits default style from scene: When checked (by 
default) the selected panel will retain the fill and stroke 
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options set in the scene settings.  Uncheck this box to 
apply unique settings to the currently selected panel.

The default panel style setting allows you to 
create all your panels with the same styles of 

fill and stroke.  Simply set the general style 
parameters in the current scene settings and every 
new panel will be created using that style.

•	 Apply default settings: Applies the default panel fill 
and stroke to the selected panel, as defined in the 
scene settings.

•	 Fill Color: Click to select a fill color for the panel. 
Uncheck the option to create a panel that has no fill.

•	 Stroke Color: Click to select a color for the panel 
outline. Uncheck the option to create a panel that has 
no outline.

•	 Stroke Width: Sets the width of the stroke in pixels.

The Stroke Width setting for panels displays 
the width of the stroke as it relates to the 

scale of the panel at Frame 0. While you cannot 
animate the stroke width, MotionArtist will 
automatically increase stroke width when you scale 
a panel. If you animate a panel size in later frames, 
the width of the stroke will increase or decrease 
proportionally. If you want the stroke widths of all 
panels to match, you should create them all 
together at the desired size.

•	 Brush: This box displays a preview of the brush used 
to draw the stroke around the panel. Click the box to 
select a brush from the Brush Settings window. Brush 
settings are discussed in more detail in “Brush Settings” 
on page 77.

•	 Panel Duration: Enter the number of frames for the 
amount of time that the panel will appear in the 
timeline. The panel duration is important for the Auto 
Camera feature in MotionArtist, and when importing 
files from Anime Studio.

•	 Automatic: When this option is checked, the panel 
duration will be set to the number of frames as set 
in the Preferences dialog. Uncheck this option if you 
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want to add a custom panel duration in the Panel 
Duration field.

Custom panel durations will not be 
automatically extended if you change the 

duration of events in the panel. You will need to 
extend the panel duration manually in the Object 
Settings dialog if you turn Automatic off.

•	 Ignore Auto Camera: Check this option if you do not 
want to change settings for the panel when the Auto 
Camera command is applied to the scene.

•	 Allow Animation:  When checked, panels can have 
keyframed translation, scale, and rotation. When 
unchecked (default), you can only edit the initial 
placement of the panel and it will not move.

Image-Specific General Settings

The General tab in the Object Settings window displays the 
following unique options in the Outline section when you 
are applying settings to an image. These settings pertain 
to the outline or border that surrounds an imported image 
or movie:

 General Tab options for Images and Movies

•	 Outline On: Check this option if you want to put an 
outline around the image.

•	 Width: Specify the width of the outline, in pixels.

•	 Color: Click the Color swatch to select a color for the 
outline.

Floating object-Specific General Settings

There are cases when you do not want your content to 
be masked within a panel. For example, you might want 
to import a background image that covers the entire 
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artboard or scene, instead of only being displayed in one 
panel. In cases such as that, you make sure that there is 
no panel selected when you import your image or movie, 
and then it is placed on the artboard as a floating object.

When you double-click a floating object on the artboard, 
the General tab displays the following settings:

 General Tab options for Floating Objects

•	 Duration: Automatic duration defaults to the duration 
setting that is specified in the Project Settings dialog 
(see “Project Settings” on page 83). To specify 
the amount of time that the camera pauses on the 
floating object, uncheck the Automatic option and 
enter the desired duration in number of frames.

•	 Ignore auto camera: When you use the Auto Camera 
feature it automatically animates the contents in your 
scene so that the camera moves over the content 

over time. For background images and similar content, 
you can check the Ignore Auto Camera option so 
that the background image remains unaffected and 
always remains in view of the camera.

The Shadows Tab
The Object Settings window provides the following options 
in the Shadows tab, whether you have a Scene, Panel, or 
Image selected.
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 Shadows panel options

•	 Layer Shadow: This section lets you apply a drop-
shadow effect to a scene.

�� Shadow On: Checking the Shadow on checkbox 
will make all objects in the layer cast shadows on 
the layers underneath.

�� Offset: Controls how far the shadow appears from 
the actual objects. A larger offset makes objects 
appear higher up above the layers below them.

�� Blur: Determines how hard or soft the edges of the 
shadow appear.

�� Expansion: Allows you to expand the reach of the 
shadow. This can be useful for halo-type effects. 
Try an Offset of 0, Blur of 8, and Expansion of 8.

�� Shadow Color: Clicking on the “Shadow color” 
swatch lets you change the color of the shadow 
that is being cast. You can also modify the 
transparency of the shadow with this control.

�� Shadow Direction: Controls the direction the 
shadow is cast. Just drag the knob in circles to 
change the direction of the shadow.

•	 Layer Shading: This section is similar to the “Layer 
Shadow” section above. However, instead of 
producing a shadow effect behind the layer, these 
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controls let you apply a shading effect on top of the 
layer.

�� Shading On: Checking the “Shading on” 
checkbox will make all objects in the layer appear 
shaded, giving them a rounded edges effect.

�� Offset: Controls how far inside the layer the 
shading appears. A larger offset makes objects 
appear to have more “rounded” edges.

�� Blur: Determines how hard or soft the edges of the 
shading appear.

�� Contraction: Allows you to pull the shading further 
into the center of the layer.

�� Shading Color: Clicking on the “Shading 
color” swatch lets you change the color of the 
shading that is applied. You can also modify the 
transparency of the shading with this control.

�� Shading Direction: Controls the direction the 
shading appears. Just drag the knob in circles to 
change the direction of the shading.

Brush Settings
Access to the Brush Settings dialog only occurs when you 
are applying settings to a Panel. This allows you to apply 

a decorative outline to a panel, rather than using a solid 
border line. 

To open the Brush Settings dialog, click the Brush icon in 
the General tab The following options will appear.

You will need to uncheck the Inherits default 
style from Scene option to assign a custom 

brush style. See “Panel-Specific General Settings” 
on page 72 for a description of this option.
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 Brush settings dialog (accessed from the General tab when a 
panel is selected)

You can set the following options for brushes:

•	 Brush Style: Click one of the thumbnails to use an 
image for a brush. If you want a standard brush, 
choose None.

•	 Align Brush with Curve: When this option is checked, 
the image that you use for the brush style will align 
with the curve of the panel outline. When the option 
is unchecked, the image will follow the stroke, but the 
angle of the image will not align to curves.

•	 Brush Jitter Angle: Causes the brush to rotate random 
amounts along the stroke. A value of zero lines up all 
the brush patterns, while a value of 360 causes each 
stamp of the brush to be rotated at a totally random 
angle. A small angle value like 60 causes the brush 
stamps to be mostly aligned, but with a little bit of 
randomness.

•	 Brush Spacing: Allows you to increase or decrease 
the amount of space between the image used for 
the brush style. Lower the percentage to decrease 
the amount of space, and raise the percentage to 
increase the amount of space between them.

•	 Minimize Frame to Frame Randomness: During the 
course of an animation, the randomness factor (jitter 
angle) of a brush can cause it to jump around to a 
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different position at each frame. You can intentionally 
use this to make an animation look hand drawn, but 
too much randomness can make the animation look 
jittery and wild. Check this box to instruct MotionArtist 
to make an attempt to minimize the randomness and 
jitter between frames of the animation.

•	 Tint Brush Using Stroke Color: Brushes that appear 
black in the Brush Settings dialog always take on the 
stroke color of the object.  This checkbox controls 
the color of the brush when colored brushes (like 
the radiation symbol brush) are used. If unchecked, 
the stroke uses the colors of the brush (such as black 
and yellow for the radiation symbol). If checked, the 
colored brush will get tinted by the object’s stroke 
color; for example, if the stroke color is green you will 
get a green-tinted radiation symbol.

The HTML Export Tab
The HTML Export tab includes settings that add interactivity 
to your MotionArtist projects, for publication to the Web. 
This tab is discussed further in “The HTML Export Tab” on 
page 108.

The Image Tab
When you are applying settings to an image or movie, 
an Image tab allows you to set specific options for the 
selected image or movie. The options are as follows:
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 Image options

•	 Image Settings: Use this section to specify various 
image display and performance settings for your 
image or movie file:

�� Source Image: Click this button to replace the 
existing image with another file on your computer. 
After you choose a new image or movie, the 
filename in the timeline will not change. You will 
need to change the filename in the General tab.

�� AVI Movie has alpha: This option is enabled only 
when you import an AVI movie. Check this option 
if your AVI file has an alpha channel and you want 
underlying content to appear behind the movie.

�� Loop movie indefinitely: Check this option to play 
a movie file in a continuous loop.

�� Play backwards: Check this option if you want the 
movie to play in reverse order (from last frame to 
first)

�� Persist first frame: Check this option to pause the 
movie at its first frame until the current panel is in 
focus. When unchecked, the movie will animate 
whether or not the panel is in the view of the 
camera.

�� Persist last frame: Check this option to pause the 
movie at its last frame after the movie has played 
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once. When unchecked, the movie will animate 
whether or not the panel is in view of the camera.

To play a movie once, and only when the 
associated panel is in view of the camera, 

check both the Persist First Frame and Persist Last 
Frame options, and make sure that the Loop Movie 
Indefinitely option is off. The first frame will be held 
until the camera reaches the panel in which the 
movie is displayed. Then the movie will play until it 
reaches the end, after which the last frame of the 
movie will remain displayed in the panel.

�� Movie FPS: Enter the frames per second for your 
original movie. MotionArtist will adjust the playback 
of the movie accordingly. In other words, you 
can take a 30FPS video and set the Movie FPS 
to 120FPS to play back the movie at 4 times its 
original speed.

�� Nearest neighbor sampling: When an image is 
scaled up larger than its original size, MotionArtist 
will try to smooth out the areas in between pixels to 
create a smoother image. Turn this option off if you 
want the enlarged image to appear blocky.

�� Unwrapped: Check this option to extend the outer 
edges of the movie outward. This is accomplished 

by flipping each edge of the movie and placing a 
flipped copy at each side (top, bottom, right, left, 
and corners). By doing so, you won’t see any white 
space when the camera displays the panel at an 
angle, such as when you use the Arrange in 3D 
command (discussed in “Arranging Panels in 3D 
Space” on page 105).

•	 Toon Settings: Use this section to apply toon effects 
and shading to the selected image or movie:

�� Toon Effect: Check this option if you want to add 
cartoon effects to the content in your scenes. 
MotionArtist will perform color reductions that give 
photographs a cartoon appearance, based on 
the other settings that you enter.

�� Edge Level: Controls the width of the edges in 
the toon effect. Increase the setting to make the 
edges wider, and decrease to make the edges 
thinner.

�� Gray Level: Darkens the middle areas of the toon 
effect.

�� Black Level: Darkens the dark areas of the toon 
effect.
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�� Saturation: Increases or decreases the amount of 
color. Negative values make the toon more black 
and white.

�� Lightness: Increase the setting to make the image 
appear more faded.

�� Quantization: Sets the number of colors in the 
image. When set to a value greater than 1, the 
value you enter is the number of colors in the 
image.
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Chapter 8: Working 
with Projects

Creating and Opening Projects
MotionArtist allows you to easily create a new project, or 
to open existing projects that are installed or saved to your 
hard disk:

•	 To create a new MotionArtist project, choose File 
> New, or use the keyboard shortcut COMMAND/
CTRL+N. A new project will appear in the project 
window, and it will be opened to Director View.

•	 Use the File > Open Recent command to select one of 
the five most recent projects that you recently worked 
on.

•	 To open a previously saved or installed project, choose 
File > Open, or use the keyboard shortcut COMMAND/
CTRL+O. Use the Open dialog to locate the folder that 
contains the file you want to open. Then click Open.

If you open a project file and MotionArtist 
cannot find some scene elements, you will 

be prompted to locate them manually.

Project Settings
To specify dimensions, frame rate, and background color 
for your project, choose File > Project Settings, or use the 
keyboard shortcut COMMAND/CTRL+SHIFT+P. The Project 
Settings dialog displays the following options:

 Project Settings Dialog
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•	 Dimensions: Use the drop-down selector to choose 
from a variety of preset project dimensions.

�� Custom: Allows you to specify a custom width, 
height, and frame rate for your project.

�� NTSC D1: Creates a 720 x 534 project.

�� NTSC D1 Widescreen: NTSC D1: Creates a 872 x 486 
project.

�� PAL D1/DV: Creates a 788 x 576 project.

�� PAL D1/DV Widescreen: Creates a 1050 x 576 
project.

�� HDV/HDTV 720p: Creates a 1440 x 1080 project.

�� HDV 1080p: Creates a 1920 x 1080 project.

�� HDTV 1080p: Creates a 1920 x 1080 project.

�� VGA: Creates a 640 x 480 project.

�� Web: Creates a 320 x 240 project.

�� Web Widescreen: Creates a 426 x 240 project.

�� YouTube: Creates a 640 x 480 project.

�� YouTube HD: Creates a 1280 x 720 project.

�� iPhone: Creates a 480 x 320 project.

�� iPhone 4: Creates a 960 x 640 project.

�� iPhone 5: Creates a 1136 x 640 project.

�� iPad: Creates a 1024 x 768 project.

�� iPad HD: Creates a 1280 x 1024 project.

�� Android: Creates a 480 x 360 project.

�� Android HD: Creates a 1280 x 1024 project.

•	 Constrain Proportions: Check this option if you want to 
resize the figure proportionally if you change either the 
Width or Height field.

•	 Width: Enter the desired width for your project.

•	 Height: Enter the desired height for your project.

•	 Frame rate: Enter the desired frame rate for your 
project. The default is 30 frames per second.

•	 Default Panel Duration: Enter the default panel 
duration in number of frames. Each time you create a 
new panel, the length will default to this duration. 

You can set the panel duration of each 
panel in your project individually, in the 

General tab of the  dialog. For more information, 
see “Chapter 13: Importing Content” on page 
131.
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•	 Automatic Panel Opacity: Panels appear dimmed until 
the playhead appears over a panel in the timeline. 
The default opacity setting is 10%. Increase the setting 
to make the panels appear brighter.

•	 Automatic Camera Tilt: Move the slider toward the left 
to reduce the amount that the camera tilts when in 
motion. Move the slider toward the right to increase 
the tilt amount. 

•	 Background Color: Click the color square to select a 
background color from your system color palette.

•	 HTML5: Specifies background and playback options for 
HTML5 output.

�� Background Audio: When checked, background 
audio will play continuously during a presentation, 
regardless of what scene is playing or if you add 
interactive elements for HTML output.

�� Transparent background: When checked, 
an exported HTML5 project will disregard the 
background color or image of the project. 

�� Auto play: When checked, your exported 
HTML5 project will bypass the play button and 
automatically play when the web page loads.

If you plan to export your MotionArtist project 
to HTML5, be aware that iOS devices (iPhone, 

iPad, etc) cannot play more than one HTML audio 
element at a time. iOS devices will not play back 
the background audio track.

•	 Save as Defaults: Click this button to save your project 
settings as the new default.

•	 Restore Defaults: Click this button to retrieve the 
original MotionArtist default settings.

Both of these new features are especially  
helpful when designing web content for 

HTML5.  A transparent background is often 
necessary to overlay on existing HTML content, and 
auto play ensures your content starts as soon as a 
user arrives at the web page. 

Saving a Project
To save your project, choose File > Save, or use the 
keyboard shortcut COMMAND/CTRL+S. 

The file will be saved with the .ming file extension.
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Saving to a New File or Folder
To save your project to a different folder or file name, 
choose File > Save As. A dialog will prompt you to choose 
the folder to which you want to save the project, and to 
enter a file name.

Closing Your Project
To close your current project, choose File > Close, or use 
the keyboard shortcut COMMAND/CTRL+W. MotionArtist 
will remain open.

Quitting MotionArtist
To quit MotionArtist and close all documents, choose File 
> Quit, or use the keyboard shortcut COMMAND/CTRL+Q. 
You will be prompted to save changes that have not yet 
been saved before MotionArtist closes.
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Chapter 9: Working 
with Scenes

All MotionArtist projects must include at least one scene. 
When you create a new MotionArtist project, it contains 
one scene by default.

MotionArtist scenes are based on the Anime 
Studio file format. Anime Studio files cannot 

be opened as a MotionArtist project, but they can 
be imported as a content object or floated in a 
scene.

One way to think of a scene is as a representation of 
one page in a comic book; or one chapter in a book. 
Therefore, if you want to create the MotionArtist equivalent 
of a 24-page comic book, your MotionArtist project would 
contain 24 scenes.

Adding Scenes
To add a scene, choose File > Add Scene. When you 
choose this command, a new scene tab appears above 
the timeline.

Each scene tab has its own set of controls, as shown in the 
following figure. 

 Scene tab.

From left to right, these controls are as follows:

•	 Scene Name: Double-click the scene name to open 
the Object Settings window, described in “Chapter 7: 
The Object Settings Window” on page 68.

•	 Scene Visibility: When toggled on, the scene will be 
played back in the timeline, and will be rendered in 
the final output. When toggled off, the scene will not 
play back in the timeline or be rendered in the final 
output.

•	 Scene Lock: Toggle the lock on to prevent accidental 
changes to the scene. Toggle the lock off to allow 
scene editing.

•	 Presentation Mode: Toggles Presentation Mode on 
or off, as discussed in “Presentation Mode” on page 
40 and “Standard Mode” on page 38.
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•	 Transitions: Opens the Transitions menu, as discussed in 
“Using Transitions” on page 89.

Changing Scenes
To change from one scene to another in your MotionArtist 
project, simply click the Scene Tab for the scene you want 
to edit.  When you change from one scene to another, the 
document will go to frame 0 in that scene.

Deleting Scenes
To delete a scene, choose File > Delete Scene. This 
command will be disabled when there is only one scene in 
the project. The scene and all its contents will be deleted 
from your project.

The Delete Scene command will not ask for 
confirmation before the scene is deleted. 

You can use the Edit > Undo command (or 
COMMAND/CTRL+Z) to undelete the scene 
immediately.

Duplicating Scenes
To duplicate a scene, choose File > Duplicate Scene. The 
new scene will appear immediately after the scene you 
duplicated. All of the content from the original scene will 
be duplicated in the new scene.

Reordering Scenes
You can easily change the order of your scenes by simply 
dragging one of the scene tabs, and dropping it into a 
new location. For example, if your project has three scenes 
named First Scene, Second Scene, and Third Scene, you 
can reposition the scene named First Scene after the Third 
Scene, as shown in the following figure.

 Reordering Scenes.
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Using Transitions
You can use scene transitions when the timeline moves 
from one scene to the next. The default transition is a 
“cut”, which simply moves to the next scene without 
any sort of transitional effect. There are seven additional 
transition effects that you can choose from the Transition 
popup menu.

The last item in the Transition selector is Duration, which 
allows you to specify the length, in frames, for the transition 
of the current scene to the next. The default duration is 
12 frames; to adjust the setting, click Duration in the flyout 
menu. The Duration is disabled only when the Cut transition 
is selected as shown in the above figure.

To create a scene transition, follow these steps:

1.	 Click the scene tab associated with the scene after 
which you want to add the transition.

2.	 Click the Transition button (the last button in the scene 
tab) to open the Transition menu.

Transitions that have an asterisk (*) after their 
name are supported in HTML5.

 Click the Transition button to display the Transition list.

3.	 The Cut transition is selected by default. When the 
Cut transition is selected, the Duration command is 
disabled. This option plays the next scene immediately 
after the currently selected scene, with no transitional 
effect.

4.	 If you choose any other transition type, the Duration 
command will enable, allowing you to set the number 
of frames for the transition. The default setting is 
12 frames. You can enter a different value in the 
Transition Duration dialog.
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 Transition duration.

5.	 Choose the transition effect that you want to add:

�� Crossfade: The current scene will fade out as the 
next scene fades in.

�� Fade to Black: The current scene fades to a black 
background, after which the next scene fades in 
from black.

�� Fade to White: The current scene fades to a white 
background, after which the next scene fades in 
from white.

�� Horizontal Wipe: The next scene wipes in from right 
to left, covering over the previous scene.

 Horizontal wipe.

�� Vertical Wipe: The next scene wipes in from 
bottom to top, covering over the previous scene.
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 Vertical wipe.

�� Iris Wipe: The current scene is wiped out by a circle 
that decreases in size; the next scene is wiped in 
by a circle that increases in size.

 Iris wipe.

�� Crumble: The current scene will reveal the next 
scene based on lightness and darkness values. It 
starts by turning the current scene into black and 
white, and then reveals the next scene in color 
gradually until the earlier scene is completely 
gone.
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 Crumble.
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Chapter 10: Working 
with Panels

Panels display the content that you import into MotionArtist 
in predefined areas. Each MotionArtist project begins with 
one rectangular panel. However, you can add several 
panels to one scene.

Panels can be rectangular, oval, or irregularly shaped. The 
Panel tools, which appear above the Timeline, allow you 
to create panels quickly and easily.

Creating New Panels
New panels have a 30-frame duration by default. New 
panels will always appear directly above a selected 
panel when you create them. For example, consider this 
example:

•	 There are five panels, numbered Panel 1 through 
Panel 5.

•	 Panel 1 appears at the bottom of the timeline, and 
plays first. Each subsequently numbered panel 
appears in the layer above, and appear in numerical 
sequence in the timeline.

•	 To place a new panel as the third panel in the 
sequence, select Panel 2. Then create your new 
panel(s). 

•	 The original panels 3, 4, and 5 will move toward the 
right in the timeline (playing after the new panels), and 
will move upward in the layer order (being closer to 
you than the new panels).

Note that the width of the stroke around the 
panel will change if you rescale the panel 

with the Move tool. If you want to create panels of 
different sizes but which have the same stroke width, 
you will need to create them at the same time and 
size them as you want to be sized when you create 
them. Alternatively, you can rescale the panel, but 
then manually enter the desired  Stroke Width in the 
General tab of the panel’s Object Settings dialog, 
as described in “Panel-Specific General Settings” 
on page 72.

There are a couple of different ways that you can create a 
new panel on the artboard:

•	 Choose Panel > New Panel, or use the keyboard 
shortcut COMMAND/CTRL+SHIFT+N to add a new 
panel to your project. This creates a rectangular panel.
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•	 Use one of the panel tools that appear above the 
timeline. From left to right these tools are: Rectangular 
Panel (shortcut R); Oval Panel (shortcut O); Polygonal 
Panel (shortcut M), Camera Target (shortcut A) and 
Split Panels (shortcut S).

  Panel tools

Use the keyboard shortcut P repeatedly to 
cycle forward through the panel tools. 

SHIFT+P will cycle backward.

You can use the TAB key to cycle to the next 
panel on the artboard, or SHIFT+TAB to cycle 

to the previous panel.

Rectangular Panels (R)
To create a Rectangular Panel, follow these steps:

 Rectangle Panel

1.	 Click the Rectangular Panel tool above the timeline, or 
use the keyboard shortcut R. 

 Rectangle Panel tool

2.	 Draw your panel on the artboard as follows:
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�� To create a rectangular panel, click to create 
the first corner, and then drag in the diagonally 
opposite direction. Release the mouse button to 
set the shape.

�� To create a square panel, hold the SHIFT key down 
while you click and drag to draw the shape.

�� To create a rectangular or square panel from 
its center point, hold the ALT key while you click 
(rectangle) or SHIFT-click (square) and drag.  

Oval Panels (O)
To create an Oval Panel, follow these steps:  Oval Panel

1.	 Click the Oval Panel tool above the timeline, or use 
the keyboard shortcut O. 

 Oval Panel tool

2.	 Draw your panel on the artboard as follows:
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�� To create an oval panel, click to create the first 
corner, and then drag in the diagonally opposite 
direction. Release the mouse button to set the 
oval shape.

�� To create a circle panel, hold the SHIFT key down 
while you click and drag to draw the shape.

�� To create an oval or circle panel from its center 
point, hold the ALT key while you click (oval) or 
SHIFT-click (circle) and drag.  

Polygon Panels (M)
To create a Polygon Panel, follow these steps:

 Polygon Panel

1.	 Click the Polygon Panel tool above the timeline, or use 
the keyboard shortcut M. 

 Polygon Panel tool
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2.	 Click to set the first point in the polygonal shape.

3.	 Click again to set the next point.

4.	 To set the last point, double click to both add the point 
and then complete the polygon panel.

Camera Targets (A)
The Camera Target tool is used to define focus points for 
the auto camera. These panels never show up in final 
output.

 Camera Target tool

To explain how the Camera Target works, assume that you 
have scanned a page from a comic and want to create 
a quick movie presentation that goes from one panel to 
the next. The quickest way to accomplish this is to import 
your scanned comic book page as a background image, 
and then create one or more Camera Targets that move 
the camera across the page.

1.	 Choose File > Import Background. Locate the scanned 
comic page that you want to import. The page 
appears as a background image that will not be 
affected by the Auto Camera command.

2.	 Choose the Camera Target tool or use the keyboard 
shortcut A, and draw a rectangle around the first 
panel in the scanned comic. The camera target 
will shade the area within it, and an object named 
Camera Target x (where x is a sequential number) 
appears in the Timeline.



MotionArtist
Reference Manual 

98

Chapter 10: Working with Panels

 A camera target is drawn over the first panel in an imported 
background image.

3.	 Draw Camera Targets over the remaining panels on 
the scanned comic page. 

 All panels on the scanned comic page have been covered 
with Camera Targets.

4.	 Switch to Standard Mode, if necessary, to adjust the 
timing of each of the camera targets to give viewers 
a sufficient amount of time to read the text in each 
comic panel.  Double-click each camera target to 
open the Object Settings window, and set the Panel 
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duration to the number of frames that are necessary 
to read the text comfortably. 

 In Standard Mode, adjust panel durations to allow sufficient 
time to read the text in each Camera Target.

5.	 Choose Arrange > Auto Camera to automatically 
animate the camera from the first to last panel in the 
order that you created them. 

You can rearrange the order of the camera 
targets in the timeline. Presentation mode will 

automatically adjust and update the timeline as 
needed when you make changes. However, if you 
rearrange the order of the camera targets in 
Standard mode you’ll need to re-run the Auto 
Camera command to pick up the changes. You will 
need to re-run the Auto Camera command after 
you clear the camera movement from the 
appropriate frames.

6.	 Switch to Camera view to preview the project before 
you render your movie.

 Preview your project in Camera view before you render it.
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Adding Panels in Presentation Mode
As mentioned in “Presentation Mode” on page 40, 
Presentation Mode allows you to quickly add content 
to your scene, and will animate the camera for you 
automatically.

To demonstrate this, try this to start:

1.	 Choose File > New (or COMMAND/CTRL+N) to create 
a new project.

2.	 Use the Panel tools (described in “Creating New 
Panels” on page 93) to create several new panels 
and add them to the workspace. 

3.	 Notice that when you add a panel, it also appears 
in the timeline. Each additional panel appears in the 
timeline with some space in between the two. 

4.	 Now press the Play button. Notice the following:

�� When the playhead appears over a panel in the 
timeline, the camera is stationary. The panel is 
displayed in full opacity, while the other panels in 
the artboard are displayed with less opacity.

Panels have a default duration of 30 frames, 
unless set otherwise in the Preferences dialog. 

If you double-click the panel in the timeline you can 
open the Object Settings window to specify a 
different panel duration. Simply uncheck the 
Automatic option and enter the desired duration in 
the Panel Duration field. When you change the 
duration of a panel, the panels that appear 
afterward will shift to accommodate the new 
length.

�� When the playhead moves over an empty space 
in the timeline, the camera transitions from the 
current panel to the next panel.

�� The gaps between the panels in the timeline vary 
in size. This is because the camera moves at a 
constant speed, and the transition between two 
panels will take less time when panels are closer 
together, and more time when they are farther 
apart.

When you are working in Presentation Mode, 
dragging a panel left or right will not increase 

or decrease the speed of the camera or the 
amount of time it takes to transition from one panel 
to the next.
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5.	 If you want to change the order of your panels, select 
a panel and move it up or down in the timeline. For 
example, if you want Panel 2 to play last instead of 
second, drag it to the top of the stack in the timeline. 
Panels that once followed Panel 2 will shift backward 
in the timeline, and Panel 2 will appear last.

Splitting Panels (S)
The Split Panel tool allows you to split a panel into two or 
more sections. To split a panel, follow these steps:

1.	 Use the Move tool (keyboard shortcut V) to select the 
panel that you want to split. You can select the panel 
by clicking in the artboard, or in the timeline.

 Use the Move tool to select the panel you want to split.

2.	 Select the Split Panel tool, or use the keyboard shortcut 
S.

 Split Panel tool
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The Width field that appears to the right of 
the Split Panel tool allows you to enter a 

gutter setting between 1 and 256 pixels.

3.	 Enter the pixel width of the gap that you want to 
appear in between the panels after they split. The 
default is 32 pixels.

4.	 Draw a line over the panel with the Split Panel tool, in 
the area where you want the panel to split. Click to 
start the line, and then release the mouse when you 
drag the tool to the other end of the split.

 Draw a line over the panel with the Split Panel tool, where you 
want the panel to split.

You can quickly create a vertical split that 
divides a panel into right and left sections by 

simply clicking the panel with the Split Panel tool in 
the area that you want the split to appear.

 The panel will split into two pieces after you release the mouse 
button.

Panels can be split in Presentation Mode, or in Standard 
Mode. The main difference is as follows:

•	 When you split a panel in Presentation Mode, the new 
panel section will appear in the layer immediately 
above the panel that you split. Subsequent panels will 
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be moved toward the right in the timeline to make 
room for the new panel section so that it plays in the 
correct sequence.

•	 When you split a panel in Standard Mode, the new 
panel section will appear in the layer immediately 
above the panel that you split, but it will not shift in 
time. You will need to reposition the timing of the new 
panel section and all subsequent panels manually.

•	 If the panel that you split uses a default panel name 
(such as Panel 2), the new panel section will use the 
next consecutive number (such as Panel 3). If your 
project already has a panel named as such, this will 
result in duplicate panel names in the project.

•	 If the panel that you split uses a custom panel name 
(such as “My First Panel”), the new panel section will 
be named the same but with a number appended to 
it (such as “My First Panel 2”).

Duplicating Panels
If you have a panel that contains a lot of content that you 
want to reuse in the scene, you can duplicate the panel. 
Follow these steps:

1.	 Select the panel that you want to duplicate, using one 
of the following methods:

�� Select the Move tool above the timeline, then 
click to select a panel from the artboard in 
Director view,

�� Click to select a panel in the timeline. Use the SHIFT 
key to select a contiguous range of panels, or the 
CTRL key to add additional panels by clicking on 
them.

2.	 Choose Panel > Duplicate Panel to duplicate the 
selected panel.

If your panels are named numerically (such as Panel 1, 
Panel 2, Panel 3, and so on), the duplicated panel will 
use the next number in sequence to the panel that you 
duplicated. For example, if you duplicate Panel 2, the new 
panel will be named Panel 3. The new panel will appear in 
the layer directly above Panel 2 (therefore being closer), 
and immediately after Panel 2 in the timeline (therefore 
playing after Panel 2).
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Double-click on a panel in the artboard or in 
the timeline to open the Object Settings 

window. You can assign a new name for your panel 
in the General tab. For more information about 
panel settings, see “Chapter 13: Importing 
Content” on page 131.

When you duplicate a panel in Presentation 
Mode, the duplicated panel will appear in 

the layer above the panel you selected for 
duplication, and will also appear immediately after 
the original panel in the timeline. The other objects 
on the timeline will shift forward in time to 
accommodate the duplicated panel.

 Duplicated panel

Deleting Panels
To delete a panel, follow these steps:

1.	 Select the panel that you want to delete, using one of 
the following methods:

�� Use the Move tool above the timeline to select a 
panel from the artboard in Director view,

�� Click to select a panel in the timeline. Use the SHIFT 
key to select a contiguous range of panels, or the 



MotionArtist
Reference Manual

105

Chapter 10: Working with Panels

CTRL key to add additional panels by clicking on 
them.

2.	 Do one of the following:

�� Choose Panel > Delete Panel to delete the 
selected panel(s).

�� Press the Delete key to delete the selected 
panel(s).

MotionArtist will not ask to confirm the 
deletion of panels. However, you can 

choose Edit > Undo (or COMMAND/CTRL+Z) to 
undo the deletion.

Arranging Panels in 3D Space
The Panel > Arrange in 3D command allows you to 
arrange selected panels in three-dimensional space. 
When you apply this command, the effect will not be 
obvious in Director View. However, when you switch to 
Camera View and play the animation, you will see the 
panels increase and decrease in size, depending on the 
position of the camera.

When you look at the 3D-arranged panels in Camera 
View, you see the panels in a parallax. The appearance 

of the panels changes depending on your line of sight. A 
good analogy is to think of the appearance as though you 
are standing in front of a house.  The panel immediately 
in front of you is the front door. Panels that are to the left 
or right of the panel are first-floor windows. Panels that are 
above the door are upper-level windows, and panels that 
are below the door are basement windows. When you 
look at the windows at the sides, above and below the 
door, they are angled based on your view. 

The Arrange > Arrange in 3D command 
allows you to perform a similar function on 

other objects besides panels.
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 Panels arranged in 3D (shown during a transition in Camera 
view)

Flattening Panels
The Panel > Flatten Panel command removes the 3D 
effect on a panel. For example, if you had previously run 

the Arrange In 3Dcommand, you can choose the Panel 
> Flatten Panel command to reverse the effect. It will 
rearrange all the objects inside the panel to be at the 
same Z depth.

Fitting Panels to Selections
The Panel > Fit Panel to Selection command allows you to 
resize a panel so that it fits to the items that are currently 
selected. In Panel view, select an item in the panel, and 
then choose the Panel > Fit Panel to Selection command 
to resize the panel to fit around it.

Animating Panels
You can animate a panel in much the same way that 
you can animate any other MotionArtist object. To make 
a panel animatable, select the panel that you want to 
animate, and open the Object Settings dialog. Then check 
the Allow Animation option discussed in “Panel-Specific 
General Settings” on page 72.

When you set the Allow Animation option, 
MotionArtist will add a stop point at the 

frame at which the option was set. 
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If you uncheck the Allow Animation option 
on a panel that has previously been 

animated, it will clear the animation on that panel. 

Animated panels allow you to accomplish some unique 
effects. For example, you can place a movie in a panel, 
and then “shatter” the panel as follows:

1.	 Select the panel that you want to shatter.

2.	 Move the timeline to the point at which you want the 
panel to shatter.

3.	 Open the Object Settings dialog for that panel, and 
enable the Allow Animation option. (See “Panel-
Specific General Settings” on page 72.)

4.	 Use the Split Panel tool to cut the panel up into smaller 
sections. (See “Splitting Panels (S)” on page 101).

5.	 Select all individual parts that were once a single 
panel, and transform them as a group.

6.	 Select all of the pieces and then run the Scatter 
command to define where the pieces will shatter to.
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Chapter 11: HTML5 
Export and Interactivity

Creating interactive presentations of your comics is one 
of the most powerful and useful features of Motion Artist.  
HTML5 Export options allow you to upload your comics to 
a web page that will display your project in the viewer’s 
default browser. You can also give your objects interactive 
scene directions and make your presentation come alive 
on tablets and computers. This section will explain in detail 
exactly how to give your MotionArtist project that extra 
interactive element to entertain your readers!

The HTML Export Tab
The HTML Export tab in the Object Settings dialog is the 
main go-to for adding interactivity to your presentation. 
This tab appears in the Object Settings dialogs relating to 
scenes, panels, and objects. 

Panel and Object Behaviors
Nearly every object or animated panel you create in 
MotionArtist can have interactive actions applied to them, 

which allows for engaging presentations. You can assign 
a multitude of actions that will trigger when the user clicks 
or taps a panel or object in the presentation in their web 
browser or tablet.

The Object Settings window provides the following options 
in the HTML Export tab when you have a panel or object 
selected:

 HTML Export options for panels and objects
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•	 Delayed animation: Delays the selected object’s 
animation indefinately, or untiled triggered by another 
HTML5 action. (Often used in conjunction with the 
“trigger:[object name]” command.)

•	 Click or Tap Action: Check this option to enable HTML5 
interactivity for the selected object. Then enter the 
desired instruction in the neighboring text box. For 
example, you can enter a target URL if you want the 
web browser to navigate to a web address when the 
panel is clicked. Or, to jump to another scene, simply 
enter the command Scene:Scene 4 to jump to the 
beginning of Scene 4. The dialog presents several 
examples for information that can be entered in this 
field, and will be used to create navigation elements 
and menu systems in your HTML output:

Interactivity directions are case-sensitive and 
space-sensitive; entering an incorrect 

command will result in no action.

�� To navigate to a web page when a panel or 
object is clicked or tapped, enter the URL for the 
web page you want to open.  Then check or 
uncheck the Open in a New Browser Window or 
Tab option, depending on whether you want the 
web page to open in the same window as your 
presentation, or to open the URL in a new page.

�� To navigate to a specific frame in your 
presentation, enter frame, followed by the frame 
number that you want to jump to (example: 
frame:217).

�� To navigate to a specific scene in your 
presentation, enter scene: followed by the exact 
scene name you want to jump to (example: 
scene:Cliffhanger).

�� To navigate to the next scene in your presentation, 
enter scene:next.

�� To navigate to the previous scene in your 
presentation, enter scene:prev.

�� To trigger a specific object animation, enter 
tigger: followed by the name of the object whose 
animation you wish to start.

By combining “Delayed animation” and the 
“trigger:[object name]” command offered in 

MotionArist 1.1, you can greatly increase the 
possibilities of interactive elements in your HTML5 
web project. Try to play and get familiar with this 
behavior, as it can be very effective, and isn’t 
limited by the number of simultaneous triggers. 
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Please note employing auto play on iOS 
devices with prevent audio from playing. This 

is a restriction of mobile Safari. 

End of Scene Behaviors
When you are using the Object Settings dialog to apply 
settings to a scene, the HTML export tab displays options 
that occur when the end of the scene is reached. While 
the End of Scene directions are not exclusively necessary 
for interactive projects, they are extremely helpful. 

When no end of scene directions are 
specified for a scene, the default behavior is 

to continue with the next scene, until the end of the 
project is reached. The project will stop and the 
viewer cannot access click or tap scene directions 
unless the viewer chooses Replay. To get around 
this, you can add one of the end of scene directions 
as described below. These options will pause or loop 
the project, and allow the viewer the opportunity to 
advance or navigate the project as he or she 
chooses. 

The end of scene behavior options are as follows:

 HTML Export options for Scenes

•	 End of scene behavior: This drop-down list allows you 
to choose one of four options that will happen when 
the end of the scene is reached:

�� Continue to Next Scene: This is the default choice. 
When the end of a scene is reached, MotionArtist 
will continue to the next scene automatically, if 
one exists. Playback will stop at the end of the last 
scene.

�� Pause at End of Scene: When the end of a scene 
is reached, playback will pause until an element 
on that scene is clicked. For example, you can use 
the Object Settings dialog to configure an image 
as a button that takes the user to another scene in 
your movie.
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When you choose Pause at End of Scene, be 
sure to also include an element on the page 

that advances to the next scene (such as a button 
or something else to click or tap). Otherwise, there 
will be no way for the user to advance any further in 
your presentation. 

�� Loop Scene: When the end of a scene is reached, 
playback will return to the first frame in the scene 
and replay continually.

�� Jump to Project Beginning: When the end of a 
scene is reached, playback will return to the 
beginning of the project.

Exporting to HTML5
The File > Export HTML5 command will export your project 
in HTML5 format, ready to be viewed directly on the web.  
A dialog appears with a few options to choose from.

When you publish your projects to the 
MotionArtist.TV portal, they are exported in 

HTML5 format before they are published online. For 
more information about MotionArtist.TV, see 
“Publishing to MotionArtistTV” on page 185. 

When you export your project to HTML5, MotionArtist 
creates a folder that contains one or more HTML files. The 
folder will use a name that is similar to the project that you 
are exporting.  The main file in that folder will be named 
index.html. If you have multiple scenes in your MotionArtist 
project, Scene 2 will be exported as index2.html, Scene 
3 will be exported as index3.html, and so on. Exported 
images and text balloons will be placed within an images 
folder, and style sheets (if used) will be placed in a CSS 
folder.

To export your comic to the web, follow these steps:

1.	 With your completed project open in MotionArtist, 
choose File > Export HTML5. The Export HTML 5 dialog 
appears.
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 Export HTML5.

2.	 Choose one or more of the following options:

�� Style Sheet: Allows you to choose a CSS style sheet 
that will format the appearance of the HTML 
pages. 

MotionArtist provides two basic style sheets 
for your web pages, in colored or black and 

white versions.  You may also choose no style sheet 
at all, which will simply load your project to a blank 
page. 

You can also create your own custom style 
sheet, and save it to your MotionArtist 

content folder, in a subfolder named HTML Export 
Styles. For more information about creating a 
content folder, see “Creating a Content Folder” on 
page 21. 

�� Scale images for the Web: When checked, 
large images (such as those used for print) will 
be downsized appropriately for display in web 
browsers. This will speed up the loading process 
and frame rate of your exported presentation.

�� Full-screen playback: When checked, the 
exported project will fill the whole screen of the 
viewing device or window.  

3.	 Click OK to export the comic. The Browser for Folder 
dialog will prompt you to choose or create a folder 
for exporting. MotionArtist will export to this folder any 
audio, images, and movies that your project contains 
in addition to HTML and CSS files.



MotionArtist
Reference Manual

113

Chapter 11: HTML5 Export and Interactivity

4.	 After exporting, the web page will open in your default 
browser where you can test it.

The window displays each panel in your scene within a 
canvas on the HTML page. A button beneath the canvas 
allows you to play or pause playback. If a scene contains 
multiple panels, PREV and NEXT buttons allow you to move 
forward or backward between those panels.

 A project as viewed in a web browser.

Pausing and Resuming Playback
Camera pause points can be used to add another level 
of user interactivity, and allow a user to interact with your 
presentation from panel to panel with clicks or taps.

Camera pause points must be configured in 
Standard Mode. Be sure that Presentation 

Mode is turned off to configure these options.

Pausing Playback
You can pause the camera at any camera stop point in 
your project and turn this feature on or off for any camera 
stop point at any time in your project.

To configure a camera pause, double-click the camera 
stop point that you want to pause to open the Camera 
Stop Point dialog. Then check the Pause Playback option. 
When checked, playback will stop at the desired stop 
point until the user responds with a click or tap action.

Camera pauses will not affect the 
background soundtrack. 
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You can also use the Arrange > Animation > Add Camera 
Pause Point command to add a camera pause point 
anywhere in the camera track.

 Add Camera Pause Point.

 Camera Pause Point on Timeline.

Resuming Playback
To resume playback after a camera is paused, the reader 
of the comic or presentation can click or tap anywhere. 
However, if they click an object that has a different HTML 
interactivity assigned to it, that object’s configuration will 
take precedence over the camera pause.

For example, if the user is on a screen that contains a 
button that says “Jump to Chapter 5”, the presentation will 
jump to Chapter 5 if he or she clicks that button; but if the 
user clicks on the background in that screen, playback will 
continue from the current screen.
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If an interactive element is assigned to the 
scene itself (a click or tap action such as 

scene:next, or frame:23, as discussed in “Panel and 
Object Behaviors” on page 108) then the scene is 
considered to be an interactive element. The user 
will be unable to continue from the pause point, as 
the scene action will take precedence.

Suggested Uses
Following are some suggested uses of camera pause 
points.

Example 1

You want playback to pause when the reader gets to 
a certain panel, until the reader clicks on something 
to continue the animation. You can accomplish this as 
follows:

1.	 Verify that Presentation Mode is turned off.

2.	 Move the playback head to the first frame of that 
panel.

3.	 Choose Arrange > Animation > Add Camera Pause 
Point.

4.	 Playback will resume anywhere the user clicks or 
taps, unless the clicked object has another HTML tag 
applied to it. 

 Camera Pause Point on Timeline.

Example 2

You want playback to pause when the animation in a 
panel finishes playing, at which point the user needs to 
click a button or tap to move to the next panel. Follow 
these steps:

1.	 Verify that Presentation Mode is turned off.

2.	 Move the timeline playback head to the last frame in 
the panel.
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3.	 Choose Arrange > Animation > Add Camera Pause 
Point.

4.	 Playback will proceed with the next panel anywhere 
the user clicks or taps, unless the clicked object has 
another HTML tag applied to it.

 Camera Pause Point at the end of a panel.

Example 3

You want to create an interactive slideshow of images.

1.	 Verify that Presentation Mode is turned off.

2.	 Import your images and select them all.

3.	 Choose Arrange > Scatter to scatter the images on the 
artboard.

4.	 Choose Arrange > Auto Camera. A camera stop point 
will automatically be created for each image.

5.	 In Director’s view, choose the Camera tool (shortcut 
C).

6.	 Double click on any Camera Stop Point to open the 
Camera Stop Point dialog.

7.	 Check the Pause Playback option.

8.	 Repeat steps 6-7 for each stop point at which you 
want the presentation to stop until the viewer clicks or 
taps.
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 Adding a Pause Point in the Camera Stop Point dialog.

Embedding a MotionArtist Project
Advanced web users can embed the MotionArtist HTML 
scripts into their own HTML files and embed the MotionArtist 
presentation directly into their web pages A small amount 
of web design knowledge is required, but the basic steps 
are described here.

1.	 Using a text editor that allows you to ignore rich text 
commands when you save a file (such as TextEditor 
or Notepad), open the index.html file that was saved 
with MotionArtist. The HTML code will look similar to the 
following:

<!DOCTYPE HTML>
<!-- This document was generated using MotionArtist 1.0 -->
<HTML lang=”en”>
<head>
	 <meta charset=”utf-8”>
	 <title>MotionArtist - 
_974ad49b16f9468aaa34258596f972dd</title>
	 <link rel=”stylesheet” type=”text/css” href=”css/
MA_style.css”>
	 <script src=”http://motionartist.smithmicro.com/
public/motionartist_1.0.js”></script>
	 <script src=”scripts/_974ad49b16f9468aaa34258596f972
dd.js”></script>
</head>
<body>

<div class=”MADoc”>
	 <canvas id=”_974ad49b16f9468aaa34258596f972dd_canvas” 
width=”780” height=”440”></canvas>
</div>
<div class=”MAButtons”>
	 <ul class=”MAButtonSet”>
		  <li><button class=”MAButton” id=”_974ad49b16f9468a
aa34258596f972dd_pauseButton”>Play</button></li>
	 </ul>
</div>

</body>
</HTML>
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2.	 Copy the CSS and script section from your MotionArtist 
index.html page (example shown below) between the 
<head> .... </head> tags of your custom web page:

	 <meta charset=”utf-8”>
	 <title>MotionArtist - 
_974ad49b16f9468aaa34258596f972dd</title>
	 <link rel=”stylesheet” type=”text/css” href=”css/
MA_style.css”>
	 <script src=”http://motionartist.smithmicro.com/
public/motionartist_1.0.js”></script>
	 <script src=”scripts/_974ad49b16f9468aaa34258596f972
dd.js”></script>

3.	 Copy the embedded content section (the section 
between the <div class ... > and </div> tags) 
from the MotionArtist index.html page into your own 
web page. This section will look similar to the following. 
You can place this section anywhere on your web 
page:

<div class=”MADoc”>
	 <canvas id=”_974ad49b16f9468aaa34258596f972dd_canvas” 
width=”780” height=”440”></canvas>
</div>
<div class=”MAButtons”>
	 <ul class=”MAButtonSet”>
		  <li><button class=”MAButton” id=”_974ad49b16f9468a
aa34258596f972dd_pauseButton”>Play</button></li>
	 </ul>
</div>

4.	 Copy the multimedia resource folders that were 
exported from MotionArtist (the audio, css, images, 
and scripts folders) into the same relative folders as 
your HTML file. 

Embedding Multiple MotionArtist 
Projects
If you want to place multiple MotionArtist projects onto 
a single web page on your site, you will need to modify 
the previous instructions described in “Embedding a 
MotionArtist Project” on page 117 as follows:

•	 In Step 2, examine the code for each of the 
MotionArtist projects that you want to embed on your 
web page. You only need to copy the following line 
into the <head> ... </head> section of your web 
page once:

	 <meta charset=”utf-8”>

•	 Continuing with Step 2, each MotionArtist project has 
a unique ID, so you will need to copy the following 
lines into the <head> ... </head> section of your web 
page for each MotionArtist project that you want to 
embed. The following example shows two projects 
that are embedded within the head section. They are 
separated here by a space for clarity:

	 <title>MotionArtist - 
_974ad49b16f9468aaa34258596f972dd</title>
	 <link rel=”stylesheet” type=”text/css” href=”css/
MA_style.css”>
	 <script src=”http://motionartist.smithmicro.com/
public/motionartist_1.0.js”></script>
	 <script src=”scripts/_974ad49b16f9468aaa34258596f972
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dd.js”></script>

	 <title>MotionArtist - 
f2dc8479c90b4769a3b8bf4c8c8c5ed5</title>
	 <link rel=”stylesheet” type=”text/css” href=”css/
MA_style.css”>
	 <script src=”http://motionartist.smithmicro.com/
public/motionartist_1.0.js”></script>
	 <script src=”scripts/f2dc8479c90b4769a3b8bf4c8c8c5ed5.
js”></script>

•	 In Step 3, you will need to copy the <div> section for 
each project into your web page, as shown in the 
following example (again, separated by a space for 
clarity):

<div class=”MADoc”>
	 <canvas id=”_974ad49b16f9468aaa34258596f972dd_canvas” 
width=”780” height=”440”></canvas>
</div>
<div class=”MAButtons”>
	 <ul class=”MAButtonSet”>
		  <li><button class=”MAButton” id=”_974ad49b16f9468a
aa34258596f972dd_pauseButton”>Play</button></li>
	 </ul>
</div>

<div class=”MADoc”>
	 <canvas id=”f2dc8479c90b4769a3b8bf4c8c8c5ed5_canvas” 
width=”872” height=”486”></canvas>
</div>
<div class=”MAButtons”>
	 <ul class=”MAButtonSet”>
		  <li><button class=”MAButton” id=”f2dc8479c90b4769a
3b8bf4c8c8c5ed5_pauseButton”>Play</button></li>
	 </ul>
</div>

•	 Finally, in Step 4, you will need to copy the multimedia 
resources from the audio, css, images, and scripts 
folders into the same relative folders as your HTML file.

Interactivity Techniques and 
Notes
MotionArtist allows you to publish your comics to the 
Internet, so that they can be viewed in web browsers that 
support HTML5. Your MotionArtist projects will be placed 
within a canvas on the HTML5 web page. 

•	 The elements of your MotionArtist scene are placed in 
a CANVAS element inside the HTML5 web page. The 
CANVAS element is supported by Internet Explorer 
9 (and later), Firefox, Opera, Chrome, and Safari 
browsers. Detailed information on the CANVAS tag 
can be found at http://www.w3schools.com/html5/
html5_ref_canvas.asp. 

•	 JavaScript is used to draw the graphics on the 
HTML page, and is contained in the file named 
motionartist_1.0.js. The HTML page references 
an external version of this file by default, located on a 
remote Smith Micro Software Inc. server.  This makes 
loading images and audio easier and faster for the 
majority of users. If you would like to download the 

http://www.w3schools.com/html5/html5_ref_canvas.asp
http://www.w3schools.com/html5/html5_ref_canvas.asp
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motionartist_1.0.js file to use on your own personal 
server, simply reference the new path in the HTML 
directions (example: <script src=”scripts/
motionartist_1.0.js”></script>

Creating a Home Scene
By creating a home scene (such as a table of contents 
scene or menu page), you enable your viewers to branch 
out to different scenes, and the return to the home scene 
with just a click.

•	 Create a home scene that includes interactive objects 
that navigate to other scenes in your project.

•	 Be sure to include interactive objects in each of the 
other scenes that return the viewer back to the home 
scene at anytime.

•	 You can also duplicate your home scene, then 
animate the objects to create an interactive page!

Supported Features in HTML5
Basic HTML5 features that are supported by MotionArtist 
are as follows:

•	 Supported image layer parameters that get baked for 
output on their first frame:

�� Opacity

�� Unwrapping image

�� Outline

�� Toon Effect

�� Shadow

�� Shading effects

�� Blur

•	 Interactive elements: Use the HTML Export tab in the 
layer settings dialog to configure the functionality of 
clickable objects, looping scenes, and so on. (See 
“The HTML Export Tab” on page 108). You can also 
add interactivity with camera pause points (choose 
Arrange > Position Camera and set the camera pause 
points in the Camera Stop Point window).

•	 Scene Transitions: Cut, Fade to Black, and Fade to 
White are supported in HTML5.

Crossfade, Horizontal Wipe, Vertical Wipe, Iris 
Wipe, and Crumble are not supported in 

HTML5.



MotionArtist
Reference Manual

121

Chapter 11: HTML5 Export and Interactivity

•	 Panel shapes, objects (images), and camera 
movement are supported.

•	 Setting the background color of the scene.

•	 Optimizing the size of the exported image for the web.

•	 The ability to place a clickable hotspot in your scene 
as a floating object, or attached to an object. This can 
be triggered by a single tap or mouse click.

To assign a hotspot to a floating object, 
image, or panel, open the Object Settings 

window to the HTML Export tab, and enter the 
hotspot destination in the Click or Tap Action field. 
For an example of this tab see “The HTML Export 
Tab” on page 108.

Unsupported Features in HTML5
Due to the challenges of supporting multiple browsers 
in HTML5, some effects that would normally work when 
exported from MotionArtist to video don’t function ideally 
in HTML export.  Here’s a list of instances that won’t export 
with HTML5:

•	 Video: Currently for version 1.x, video cannot be 
exported to HTML5 due to the variety of video support 
among web browsers.  

•	 Blur, Outline, Shadow, and Shading effects:  There is 
currently no way to support the “blur” effect in HTML5.  
Any object with animated blur will export with the blur 
value that is set at frame 0. The same goes for Outline, 
Shadow and shading effects. 

•	 Brushes on Panel Strokes.  If you choose to outline your 
panel with a brush, it will not export correctly to HTML5.  
The stroke on the panel will be the same thickness, but 
just be the basic stroke.

•	 Camera Tilt is not used in HTML-exported projects.

•	 Layer blend modes are not supported in HTML output.

•	 Imported Anime Studio file features that are not 
supported in HTML5 include:

�� Bending vectors or images with bones

�� Particle layers

�� 3D rotations

�� 3D camera movements

�� Actions
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�� Smart bones

�� 3D layers (including imported Poser layers)

�� Animated point movement.
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Chapter 12: The Library 
Window

The MotionArtist Library window provides access to all of 
the content that ships with MotionArtist such as characters, 
props, images, audio, etc. 

By default, the Library appears undocked. You can dock 
or undock the Library window as follows: 

•	 To undock a docked Library window,  choose Window 
> Library, or use the keyboard shortcut COMMAND/
CTRL+SHIFT+L. 

•	 Choose the command again to redock the Library 
window.

The Library window consists of two tabs: The Library tab 
and the Search tab. Within the Library tab are two main 
folders: 

•	 The first folder is called Current Project, and displays 
the contents that are in use in your currently opened 
project. 

•	 The second folder is called My Library. These are virtual 
folders, or shortcuts that allow you to point to content 

from anywhere on your system, allowing you to easily 
access files from multiple locations in a centralized 
location.

You can drag items from Finder or from Windows Explorer 
to place them in your library. 
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 The Library Window.

Current Project Folder
As you create scenes and add content to your opened 
project, the Current Project folder in the Library will display 
the content in each of the scenes in a Scene subfolder. 
The following image shows an expanded view of the 
Current Project folder as an example. 

When you first start MotionArtist, the default project consists 
of one scene, with one panel in the scene. The following 
screen shot shows the scene and panel expanded so that 
you can see the objects that appear within the panel. The 
currently selected item appears with a larger thumbnail.
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 Current Project folder.

My Library Folder
The My Library folder is a virtual folder hierarchy that 
provides easy, organized, and centralized access to files 
that you have stored in different locations on your system. 
You can create your own folders and add links to images, 
movies, sounds, and other content that is compatible 
with MotionArtist. The files that you link to can exist in 
any location that you can browse to in Finder (Mac) or 
Windows Explorer (Windows). 

Four buttons appear at the bottom of the Library window 
to assist in creating folders and subfolders in which to store 
the content, and to add these items to your project. From 
left to right, these buttons are:
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 Library buttons.

•	 Add to Scene: After you select an item from your My 
Library folder, click this button to add the item to your 
project.

•	 Add a Folder: Click this button to create a new folder 
beneath the folder that you currently have selected.

•	 Add to Library: Click this button to add objects to the 
currently selected My Library folder.

The Add to Library button only allows you to 
add content to folders that appear beneath 

the My Library folder. In order for content to appear 
in the Current Project folder you’ll have to add the 
content to the scenes in your currently opened 
project.

•	 Delete from Library: This button appears only when 
you have selected a folder or content item that 
you created yourself. It will not appear when you 
select content and folders that were furnished with 
MotionArtist. 

Creating New My Library Folders
To create a new folder beneath the My Library folder, 
follow these steps:
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1.	 Select the “parent” folder beneath which you want 
to create the new folder. For example, if you want to 
create a new folder beneath the My Library folder, 
highlight the My Library folder to begin.

2.	 Click the Add a Folder button at the bottom of the 
Library window.

3.	 A dialog prompts you to enter a name for the new 
folder.  

 Creating a new Library folder.

4.	 Choose OK to create the new folder. The new folder 
appears in the Library window.

 The new folder in the Library window.

Adding Content to the My Library Folder
After you create folders in the My Library folder, you can 
add content to these folders. This helps you organize your 
content in easy to find categories.

To add content to the My Library folder, proceed as 
follows:

1.	 Select the My Library folder that will store the content 
you want to add. 

2.	 Click the Add to Library button at the bottom of the 
Library window. The Add to Library dialog prompts you 
to locate the files that you want to upload.
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3.	 Navigate to the location that stores the files that you 
want to add. Select one or more files from the folder 
and click Open.

 Use the Add to Library dialog to select one or more files to add 
to the selected folder.

4.	 The items that you selected will appear in the selected 
My Library folder when you return to the library. A 
thumbnail will appear for each content item, and 
the name of the file will appear at the right of the 
thumbnail.

 Content added to the My Library subfolder.
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Deleting My Library Content and Folders
When you delete files and folders from your My Library 
folder, it will not delete the original content that is stored 
on your hard drive. Rather, it deletes the My Library 
reference links to those files.

To delete file or folder references that you created or 
added to the My Library folder, follow these steps:

1.	 From the My Library folder or subfolders, select the file 
or folder that you want to delete.

2.	 Click the Delete from Library button at the bottom of 
the Library window.

3.	 A dialog informs you that the reference for the 
selected entry will be deleted from the Library. Answer 
No to cancel the operation, or Yes to delete the 
selected file reference.

Selecting a single file will only delete the 
reference to that file. Selecting a folder will 

delete the reference to the folder and all file 
references contained within that folder.

An option in the confirmation dialog will also 
allow you to automatically delete items in 

the future, without confirmation. Check the Always 
delete without confirming option before you choose 
Yes to delete the selected file if you no longer want 
to receive a confirmation to delete the files.

Searching the Library
The Search tab in the library allows you to perform a 
search through the contents of the Library. It is particularly 
useful when you have a lot of content in your library folders 
and want to find content with a specific theme.

 Library Search tab.
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To search the contents of the library, follow these steps:

1.	 Enter a search term in the Search For field.

2.	 Click Search. MotionArtist will display the results, after 
which you can add the items to your current project. 
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Chapter 13: Importing 
Content

When you import objects into your MotionArtist project, 
you can place them on the artboard in one of two ways:

•	 To place an object inside a panel, first click the panel 
that you want to place the object into. Then choose 
the File > Import command (or COMMAND/CTRL+I), or 
use the Import button in the Project tools to select the 
file you want to import.

•	 To place an object directly on the artboard as a 
floating object, click somewhere on an empty space 
on the artboard to deselect any panels. Then choose 
the File > Import command (or COMMAND/CTRL+I), or 
use the Import button in the Project toolbar to select 
the file you want to import.

Importing Images
MotionArtist allows you to import many standard image 
formats, including layered Photoshop files. 

The steps to import an image are as follows:

1.	 Click the Scene tab to choose the scene into which 
you want to import the images.

2.	 Determine whether you want your image(s) to appear 
on the artboard as floating objects, or within one of 
the panels.

�� If you want the images to appear on the artboard 
as floating objects, make sure that there are no 
panels selected before you proceed.

�� If you want the images to appear within a panel, 
select the desired panel. 

If any of the images that you import exceed 
the size of the selected panel, those areas 

will be masked out.

3.	 Move the timeline indicator to the frame at which you 
want your image to start.

4.	 Use one of the following methods to import images: 

�� Select one or more images from Finder (Mac) or 
Windows Explorer (Windows). Then drag and drop 
them into the project. 
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�� Select one or more images from Finder (Mac) or 
Windows Explorer (Windows). Then choose File > 
Import (or COMMAND/CTRL+I).

�� Select an image that is saved to your My Library 
folder.

After you import your images, they will appear on the 
artboard or in the selected panel. 

Using Layered Photoshop Files
Layered Photoshop files serve as a powerful tool. When 
you import a Photoshop file as layers, the layer names are 
retained in MotionArtist. This feature is especially useful 
for cases where you have existing artwork (a comic, for 
example) and want to use MotionArtist to convert it to a 
motion comic. 

Preparing Your Layers
You can arrange the content in a Photoshop file into layers 
that will be reproduced, if desired, when you import the 
files into MotionArtist.

•	 If you group items in Photoshop, the top-level groups 
will be imported as a panel in MotionArtist. This allows 

you to arrange the contents of a panel into layers so 
that they can be animated in Panel view.

•	 If the Photoshop file contains any layers that have 
masks, you will receive a warning that the file will not 
import unless you turn it into a composite image. If you 
want to retain the layers, apply the masks in Photoshop 
before you import them into MotionArtist.

•	 Arrange your layers so that the layer that you want to 
display first appears at the bottom of the layer stack. 
Each successive layer should appear in the layer 
above it. This arrangement will be duplicated when 
you bring the Photoshop file into MotionArtist.

•	 For each panel, determine how you would like to layer 
the content. For example, you can place background 
elements on one layer, characters in the scene on one 
or more additional layers, text effects such as bangs, 
pows, and pops on another layer, and word balloons 
on another layer. You can also use a Photoshop 
image that has a transparent background layer, or no 
background layer at all.
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 A complete panel, before layering.

•	 As you cut out your layers from the original comic 
page, you’ll need to keep in mind that during 
animation, the camera might display your comic 
pages at an angle. As a result, when you cut your 
comic panel into layers, you’ll need to fill in the cutout 
areas on the layer below - at least enough to prevent 
holes from appearing when the camera tilts the view.

 Background (with cutout areas filled).

 Character/foreground elements separated into another layer.
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 Word balloons in the top layer.

•	 Name the layers in a way that makes sense to you, 
while also considering the order in which you want 
the panels to be read. For example, for the first panel 
on the page, you can name the layers Background, 
Hand and Card (or a description of the elements in 
the foreground), and Bubble.

 Panel 1 layers shown in Photoshop.

•	 After all the layers have been broken out, save the 
Photoshop file.
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Importing a Photoshop File
You can import a Photoshop file either as a composite 
image, or as a layered image. MotionArtist will create a link 
to the file that you import. 

When you update the original Photoshop file, the updates 
will also appear in MotionArtist automatically. This allows 
you to make changes to the layer or content in your 
Photoshop file at any time. 

Certain types of changes will cause the layer 
orders and associations to be incompatible 

with the Photoshop file that you initially imported. If 
you change the ordering, visibility, or naming of the 
layers in your Photoshop file, these changes will not 
update properly in MotionArtist.

Do not change the size of the canvas in your 
Photoshop file. This can potentially affect 

existing animation and scaling in your MotionArtist 
project.

Photoshop images are imported as described in 
“Importing Images” on page 131. If you choose one 
or more Photoshop files, MotionArtist will display a dialog 
that asks if you want to import layers individually or as a 

composite. If multiple Photoshop images are selected, you 
will be asked to confirm this choice for each file. After you 
make this selection, the image(s) will appear in the scene.

•	 Choose Cancel to exit the dialog without importing 
the file.

•	 Choose Composite to merge all of the layers into a 
single layer.

•	 Choose Individually to retain the layers as they exist in 
Photoshop. 

 Photoshop Import Options

After you import your Photoshop file into MotionArtist, click 
to select the file on the artboard, or switch to Panel view if 
you imported the file into a panel. You should see the layer 
names appear in the timeline, as they were arranged in 
the original Photoshop file.
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 Layers shown in MotionArtist timeline.

Importing Movies

To import a movie into MotionArtist:

1.	 Do one of the following:

�� To import a movie on to the artboard, click in an 
empty space on the artboard to deselect any 
panels.

�� To import a movie into a panel, click the desired 
panel with the Move tool. Then switch to Panel 
view.

2.	 Choose File > Import (or COMMAND/CTRL+I) and 
choose the desired movie file. After selecting the 

movie, it will appear on the artboard or inside the 
panel.

MotionArtist allows you to import several 
movie formats, including AVI, MOV, M4V and 

MP4.

AVI support on Mac will be dependent upon 
the codec used to create the AVI file. Basic 

codecs such as Motion JPEG are supported, but not 
all codecs are automatically supported by 
QuickTime without installing special plugins.

QuickTime installation will be required in order 
to import MOV format in Windows.

3.	 After you import your movie file, you can open the 
Object Settings dialog to change properties. See “The 
HTML Export Tab” on page 79 for more information.
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 An imported movie with available Object Settings for images 
and movies.

Importing Audio
MotionArtist allows you to import many common audio file 
formats, including AIFF, MP3, and WAV format. To import 
audio into MotionArtist, follow these steps:

MotionArtist also allows you to record audio 
from within the application. See “Recording 

Audio” on page 175.

1.	 You can import an audio file to the artboard (without 
a panel selected), or into a selected panel.

If a panel is selected while importing the 
audio file in Presentation Mode, the length of 

the panel will increase as necessary to 
accommodate the longer duration of the audio file. 

2.	 Do one of the following:

�� Choose File > Import (or COMMAND/CTRL+I) and 
select an audio file from the Import window.

�� Drag and drop an audio file from Finder (Mac) or 
Windows Explorer (Windows) into your MotionArtist 
project.

3.	 The audio file will appear in the timeline. 
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Importing OBJ Files
MotionArtist also provides a way to import a 3D object 
and create one or more snapshots (or images) that are 
imported into the project and its timeline.

MotionArtist allows you to import 3D objects using the 
Wavefront OBJ file format. You can use any 3D application 
that exports in this file format. 

After you export an OBJ file from your 3D application, you 
can use the Make Snapshots from Scene dialog to rotate, 
scale, and shade the object and then output an image 
directly into your scene and into the timeline.

To import an OBJ file into MotionArtist, follow these steps:

1.	 Do one of the following:

�� To import a movie on to the artboard, click in an 
empty space on the artboard to deselect any 
panels.

�� To import a movie into a panel, click the desired 
panel with the Movie tool. Then switch to Panel 
view.

2.	 Choose File > Import (or COMMAND/CTRL+I). 

3.	 Select the OBJ file that you exported from your 3D 
application. 

4.	 The Make Snapshots from Scene dialog appears, with 
several settings. See “Making Snapshots” on page 
146 for more information about this dialog box.

If your OBJ included textures in your 3D 
software and they do not appear in the 

Make Snapshots from Scene dialog, check the 
paths in the MTL file that was saved with the object 
to see if absolute or relative paths were written. If 
relative paths are used in the MTL file, you will need 
to locate a copy of the images in paths that are 
relative to the folder into which you saved the OBJ 
file.
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 Image options

Importing Poser Files 
MotionArtist allows you to directly import a Poser scene 
(.PZ3 file). Before you import Poser scenes, make sure that 
you have the path to your Poser application set in the 
Options tab of the Preferences dialog. This tab is described 
in “Options” on page 32.

When you choose to import a Poser file into your 
MotionArtist project, you are not actually importing the 
contents of the Poser scene. Instead, you are taking 
“snapshots” of the content in that Poser scene, which will 
be imported into your MotionArtist project as still images. 
The preview window in the Make Snapshots dialog displays 
the area of the snapshot that will be imported into the 
scene. 

The camera that is used in the Make 
Snapshots from Scene dialog is not the Poser 

camera; rather, it is pointed to the center of your 
Poser scene. If your Poser scene contains many 
large objects (buildings, landscapes, and so on), 
you may find it difficult to navigate the Make 
Snapshots from Scene camera through it. In cases 
such as these, we recommend that you simplify your 
Poser scene before you try to import it, or break it up 
into pieces so that your snapshots can be more 
targeted.
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When you import a Poser scene into the 
Make Snapshots from Scene dialog, the 

Frame slider becomes active. This allows you to 
move forward or backward through the timeline in 
your Poser project, so that you can select a specific 
frame in your animation for import. This slider is 
disabled when you choose to make snapshots from 
an imported OBJ file.

The Make Snapshots from Scene dialog 
generates images that are more stylized than 

a render that you produce in Poser’s Firefly renderer. 
You can change the styling by choosing one of the 
shading options available in the Make Snapshots 
from Scene dialog. These options are described in 
more detail in “Making Snapshots” on page 146.

To import a Poser file, follow these steps:

1.	 Do one of the following:

�� To import a Poser file on to the artboard, click in 
an empty space on the artboard to deselect any 
panels.

�� To import a Poser file into a panel, click the desired 
panel with the Move tool. Then switch to Panel 
view.

2.	 Choose File > Import (or COMMAND/CTRL+I) and 
choose a Poser file (.pz3), or choose File > Make 
Snapshots.

3.	 Highlight the file you want to use, and click Open. 

4.	 Advance the frame slider in the Make Snapshots from 
Scene dialog until you reach the frame that you want 
to use to generate your snapshots. 

5.	 Set your other import options as described in “Making 
Snapshots” on page 146. 
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 Importing a PZ3 File

Importing Anime Studio Files
MotionArtist allows you to import Anime Studio files directly 
into your project. 

When you export your MotionArtist project to 
HTML5, keep in mind that patch layers, 

particle layers, stroke exposure, bone deformations, 
and animated points/shapes will not be supported 
in HTML5 output.

To import an Anime Studio file, follow these steps:

1.	  Do one of the following:

�� To import an Anime Studio file on to the artboard, 
click in an empty space on the artboard to 
deselect any panels.

�� To import an Anime Studio file into a panel, click 
the desired panel with the Move tool.

2.	 Choose File > Import (or COMMAND/CTRL+I).

3.	 Locate the folder on your hard disk that contains the 
Anime Studio file (.anme). 

4.	 Highlight the file you want to use, and click Open. 
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You will notice the following after you import your Anime 
Studio project:

To see the contents of the Anime Studio file 
after it is imported into a panel, switch to 

Panel view.

•	 Content that was arranged in Group Layers in Anime 
Studio will appear as a single group layer in the 
MotionArtist timeline. If you switch to Panel view, you 
will have access to the individual objects in that group 
layer.

If you need individual access for one or more 
layers in your Anime Studio project, you will 

need to place them outside the group in your 
Anime Studio project before importing into 
MotionArtist.

 Contents of Anime Studio project (top); as imported into a 
MotionArtist panel (bottom).

•	 You may need to use the Object Settings dialog to 
extend the length of the panel to include the portions 
of the Anime Studio file that extend beyond the last 
stop point in your MotionArtist timeline. 
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Importing Manga Studio Files
You can use Manga Studio to assemble images and 3D 
content into panels, and then export that panel as an 
image. For complete instructions on how to use Manga 
Studio, refer to the Users Manual that is furnished with the 
software.

After you assemble your project in Manga Studio, you can 
use it within MotionArtist as follows:

1.	 With your completed project opened in Manga 
Studio, click the Visibility icon in the Guide Layer panel 
to hide it.

 Turn off the Guide layer in your Manga Studio project.

2.	 Turn on only the layers that you want to appear in your 
MotionArtist project.

 All layers that you want to export from Manga Studio are 
turned on.

3.	 Choose File > Export > Image File (in Pixels). The Export 
Image dialog appears.
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 Export Image dialog

4.	 In the Output Size area, select Specify Output Size. 
Enter the width, height, and resolution of the image 
that you want to export. 

5.	 Use the Output Area selector to choose Entire Page.

6.	 Use the Output Color Depth section to choose Color. 
Then click the Color Settings button to specify color 
options.

If you are outputting your project to a 
layered PSD file, you should choose Color 

output if your project contains any 8-bit grayscale 
layers. Otherwise, these grayscale layers will not 
show up in MotionArtist.
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 Color Settings.

7.	 Click OK to return to the Export Image dialog. Next, 
click the Raster Settings button to specify color settings. 
The default option is Conform to the Layer Settings. 
Click OK to return to the Export Image dialog.

 Raster Settings.

8.	 In the File Settings section, enter a name for the file, 
and choose Photoshop from the Type dropdown. 

 Select Photoshop file format.
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9.	 Click the Settings button to open the Photoshop 
Settings dialog. If you want to retain the layers in the 
Photoshop file, make sure that Keep Layer Structure for 
Output is selected. Also check Keep Layer Structure for 
Output, check Output Layer Set (Photoshop 6 or later), 
and Up to 5 Layers (Photoshop CS or later).

 Make Snapshots from Scene dialog.

10.	 Use the Output Destination area to select the folder 
and assign a file name for your Photoshop file.

11.	 Click OK to export the image. The file will be rendered 
and saved to the location you specified.

12.	 In MotionArtist, choose File > Import (or COMMAND/
CTRL+I) and locate the Photoshop file that you 
exported from Manga Studio. MotionArtist will ask 
if you want to import layers individually or as a 
composite image. For more information on importing 
Photoshop files, see “Using Layered Photoshop Files” 
on page 132.

Making Snapshots
The Make Snapshots dialog appears whenever you try 
to import a file format that has to be converted to an 
image before using it in MotionArtist. The Make Snapshots 
from Scene dialog allows you to scale and rotate 3D 
objects, or scale and position 2D content, so that you can 
quickly create static image files that you can add to your 
MotionArtist projects. 

The Make Snapshots from Scene dialog 
includes a Snap button that you need to 

press at least once to import a snapshot into your 
MotionArtist project. Be sure to create at least one 
snapshot before you click the Done button. 
Otherwise no snapshots will be imported into your 
project.
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 Make Snapshots from Scene dialog.

You can also use the File > Make Snapshots 
command to open the Make Snapshots from 

Scene dialog at any time, and then select the 
content that you want to import and make 
snapshots from.

The following options appear in the Make Snapshots from 
Scene dialog:

�� Preview window: Displays a preview of the 
snapshot image that will be imported into your 
MotionArtist project.

�� In/Out Slider: Appears above the preview window. 
Move the slider to the left (In) to move the object 
closer, and toward the right (Out) to move the 
object farther away.

�� Top/Bottom Slider: Appears to the right of the 
preview window. Move the slider up (T) to pan 
toward the top of the OBJ file, and down (B) to 
pan toward the bottom of the OBJ file.

�� Left/Right Slider: Appears just below the preview 
window. Move the slider toward the left to pan the 
scene toward your left, and toward the right to 
pan the scene toward your right.
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�� Scale: Move the slider toward the left to make the 
object smaller, and toward the right to make it 
larger.

�� X rotation: Move the slider toward the left to tilt 
the object backward (toward -180 degrees), 
and toward the right to tilt it forward (toward 180 
degrees). 

�� Y rotation: Move the slider toward the left to turn 
the object toward your left (toward -180 degrees) 
and toward the right to turn the object toward 
your right (toward 180 degrees)

�� Z rotation: Move the slider toward the left to tilt the 
object toward your right (toward -180 degrees), or 
toward the right to tilt the object toward your left 
(toward 180 degrees).

Pressing the Enter key after entering a 
numerical value in the X, Y, and Z Rotation 

fields will close the Make Snapshots from Scene 
dialog. If you enter a numerical value manually, 
click outside the entry field to apply the setting.

�� Frame: Allows you to scroll through the timeline of 
an animated Poser (pz3) file to select the frames 
that you want to take snapshots of.

�� Image Size: Allows you to set the width of the 
image that will be added to your project.  Width 
ranges from 128 pixels to 2048 pixels.

�� Shading selector:  Allows you to choose from None 
(no shading), Smooth (for 3D effect), Toon (solid 
colored), or Hatched (sketch effect) shading.

�� Shading Color: When Hatched shading type is 
selected, click the color swatch to select the color 
of the hatch strokes.

�� Shading Density: When Hatched shading type 
is selected, allows you to set the density of the 
hatched effect.

�� Stroke:  Toggles the outline of the OBJ file on or off, 
and allows you to choose a color for the outline.

If the outline of the object appears too thick, 
you can use the Scale slider to increase the 

size of the object to compensate for the outline 
thickness.

�� Snap: Click the Snap button to add a snapshot 
to the scene, using the current settings. You can 
change the settings and press the Snap button 
again to create a snapshot from a different angle.
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13.	 After you make your selections and snapshots, choose 
Done to exit the dialog. You will see the images in the 
workspace and in the timeline as image files. 

The Make Snapshots from Scene dialog also allows you to 
take snapshots of vector art in AI8, EPS and SVG format.  
They will show up as vector layers in your project.  

The quality of snapshots made from a vector 
format are better than raster formats when 

exported to HTML.

When you import a very large vector file, 
MotionArtist may appear unresponsive for a 

while as it loads the vector file.

When you use the File > Import command to 
import a vector file, you may receive a 

warning that says that there are too many curves 
and points in the vector file. This warning dialog 
does not appear when you use the Make Snapshots 
feature.

To import  one of these vector art formats, choose File > 
Make Snapshots, and choose  an AI8, EPS or SVG format 
image.  You can then take snapshots which appear as 
images in your project. 

 Make Snapshots from Scene dialog.
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Selecting All Content
To select all content, choose Edit > Select All, or use the 
keyboard shortcut COMMAND/CTRL+A.

Clearing Content
Choose Edit > Clear to clear the contents of the currently 
selected scene and remove it from the timeline. Note that 
MotionArtist must contain at least one scene, so if there is 
only one scene in the project, the Clear command will not 
apply.

Undo and Redo
To undo an operation, choose Edit > Undo, or use the 
keyboard shortcut COMMAND/CTRL+Z.

To reapply a previous Undo operation, choose Edit > Redo, 
or use the keyboard shortcut COMMAND/CTRL+SHIFT+Z.

Cutting, Copying, and Pasting 
Content
To cut (remove) a selection from your scene and place it 
in the clipboard, choose Edit > Cut, or use the keyboard 
shortcut COMMAND/CTRL+X.

To copy a selection from your scene and place it in the 
clipboard, choose Edit > Copy, or use the keyboard 
shortcut COMMAND/CTRL+C.

To paste a selection from your clipboard and place it 
into the scene, choose Edit > Paste, or use the keyboard 
shortcut COMMAND/CTRL+V.
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Chapter 14: Working 
with Objects

The Selection and Workspace tools allow you to select 
specific panels or content and move them to a different 
location. These tools also allow you to pan and zoom to 
view items that you work on.

MotionArtist allows you to select one or more items from 
the artboard, or from the timeline. 

 Selection and Workspace Tools

From left to right, these tools are as follows:

•	 Move (V): Use the Move tool , or keyboard shortcut 
V, to select and manipulate the panels and objects 
in your scene. When working in Director View, you 
can select panels and floating objects with this tool. 
However, if you want to scale, move, or rotate the 
content that appears within a panel, you’ll need to first 
click to select the panel that you want to edit. Then 

switch to Panel View to edit the contents within that 
panel.

•	 Camera (C): Click this icon or use keyboard shortcut 
C to switch to Camera View, which is discussed in 
“Camera View” on page 42.

•	 Pan (N): Use the Pan tool, or keyboard shortcut N,  to 
pan the view of the workspace so that you can  bring 
desired content into view.  Drag up, down, left or right 
with the Pan tool to adjust the view.

•	 Zoom (Z): Use the Zoom tool, or keyboard shortcut Z, 
to zoom into and out from the current view. Drag the 
zoom tool left to zoom outward, and right to zoom 
inward.

Floating Objects
Floating objects are items that are not attached to a 
panel. They can be displayed anywhere on a page, and 
can also be scattered in random positions and rotations 
on the artboard. Adding and scattering floating objects 
in a scene allows you to very quickly create a unique 
animated presentation. See “Scattering Objects on the 
Artboard” on page 162 and “Scattering Objects in a 
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Panel” on page 165. for examples of using and scattering 
floating objects in your project.

Animating Objects
Objects can be animated by making changes to 
translation, rotation, or scale over time. You can animate 
floating objects in Director view or Camera view. To 
animate objects in a panel, you’ll need to select the panel 
that contains the object you want to edit, and then switch 
to Panel view.

”Putting it All Together” on page 176 shows 
a brief overview of a project that uses several 

different object and text layers to create an 
animation.

Object Stop Points
When you make a change to the rotation, scale, or 
position of a selected object, a stop point appears on the 
timeline for that object. Double-click the object stop point 
in the timeline to open the Object Stop Point dialog.

 Object Stop Point dialog.

The settings in the Object Stop Point dialog are as follows:

�� Stop Point Frame: Displays the frame in the 
timeline that the Stop Point currently appears. 
You can enter  a new frame number, if desired, 
to move the stop point to a different frame in the 
animation. 
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�� Visible: When unchecked, object is not visible 
in the curent frame, and will not be seen in final 
render. 

�� Prev and Next buttons: Use the Left or Right arrow 
buttons to move to the Previous or Next stop point 
for the selected object.

You can drag a stop point left or right in the 
timeline to visually change the frame at 

which the stop point occurs. You can also SHIFT-
click to select multiple stop points.

�� Hold Duration: Displays the number of frames 
that the object will pause over the stop point. By 
default, this is 30 frames. You may need to adjust 
this value to allow viewers sufficient time to read 
text on screen. 

�� Blur radius: This is the same blur funciton as in the 
layer settings dialogue.  It is also placed here for 
convenience. 

�� Opacity: This is the same opacity function as in the 
layer settings dialogue. It is also placed here for 
convenience. 

�� Position X, Y, Z: Displays the current X, Y, and Z 
coordinates of the stop point. You can adjust the 
stop point by entering offset values in the fields. 

�� Scale: Displays the scale of the object, relative to 
its original size.

�� Angle: Displays the amount of rotation applied 
to the object. Default rotation is zero degrees. To 
adjust the rotation, enter a new value in the Angle 
field, or use the Angle rotator to rotate the object 
clockwise or counter-clockwise.

You can also visually adjust the angle in 
Panel View by rotating the selected object 

with the Move tool (keyboard shortcut V). 

�� Delete Stop Point: Press this button to delete the 
currently selected stop point..

Animation Commands
The Arrange menu contains several commands that 
will allow you to clear multiple stop points under certain 
conditions. These commands are as follows:

•	 Choose Arrange > Animation > Add Object Stop Point 
or use the keyboard shortcut COMMAND/CTRL+0 
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(zero) to add a stop point for the selected object at 
the current frame.

•	 Choose Arrange > Animation > Add Camera Stop 
Point or use the keyboard shortcut COMMAND/CTRL+9 
to add a stop point for the camera at the current 
frame.

•	 Choose Arrange > Animation > Clear Panel Animation 
to remove all object and camera stop points for the 
current panel.

•	 Choose Arrange > Animation > Clear Scene After 
Current Frame to remove all object and camera stop 
points for the current scene, starting at the current 
frame and continuing to the end of the animation. All 
stop points before the current frame will be retained.

•	 Choose Arrange > Animation > Clear Object After 
Current Frame to remove all stop points for the 
currently selected object, starting at the current frame 
and continuing to the end of the animation. All object 
stop points before the current frame will be retained.

•	 Choose Arrange > Animation > Clear Camera After 
Current Frame to remove all camera stop points, 
starting at the current frame and continuing to the 
end of the animation. All camera stop points before 
the current frame will be retained.

•	 Choose Arrange > Animation > Set Layer Start Frame 
command or use the keyboard shortcut COMMAND/
CTRL+B to move the selected layer to a specific frame.

Moving Objects
When you are working in Director View, the Move tool 
(keyboard shortcut V) allows you to select one or more 
panels, objects, or floating objects on the artboard and 
reposition the selection to another location. When you are 
in Panel View, the Move tool allows you to select objects 
within that panel.

•	 To move a panel or floating object in Director view, 
use the Move tool to click the inside of the panel or 
floating object and drag to another location. Release 
the mouse where you want to place the object.

•	 If you need to move an object within a panel, switch 
to Panel View, and click the object you want to move.
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 Click and drag an object from within the bounding box to 
move it with the Move tool.

Scaling Objects
To scale an object, use the Move tool (keyboard shortcut 
V) to select the object(s) that you want to scale. In Director 
View, you can select the object from either the artboard 
or from the timeline. 

A rectangular bounding box appears around the selected 
object(s):

•	 Click and drag from one of the corners to scale the 
object(s) uniformly.

•	 Click and drag from any side (top, bottom, left, or 
right) to scale the object(s) non-uniformly. The scale of 
the object(s) will adjust from the center point. In other 
words, if you drag the left side, the right side will adjust 
by the same amount. If you drag from the top, the 
bottom will adjust by the same amount.

•	 Click and drag any side while pressing the OPTION/
ALT key to retain the volume of the object(s) while 
you scale the selection. In other words, if you OPTION/
ALT-click with the Move tool to scale the selection, 
the height will increase as the width decreases; or the 
width will increase as the height decreases.

 Click and drag one of the square handles at the sides or 
corners of the object bounding box to scale the object.
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Rotating Objects
To rotate an object, use the Move tool (keyboard shortcut 
V) to select the object that you want to rotate. In Director 
View, you can select the object from either the artboard 
or from the timeline. 

A rectangular bounding box appears around the selected 
object:

•	 Drag upward or leftward, outside the selection 
rectangle, to rotate the object clockwise. Drag 
downward or rightward to rotate the object counter-
clockwise.

•	 Press the SHIFT key while rotating to constrain the 
angles at 45 degree steps.

 Click and drag outside the object bounding box to rotate the 
object.

Arranging Objects
Use the commands in the Arrange menu to change the 
stacking order of your items, or to align them horizontally or 
vertically. The commands are as follows:
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 Arranging objects.

•	 Choose Arrange > Bring To Front to bring the selected 
panel or floating object to the top of the layer stack. 
If you are working in Presentation Mode, this will also 
place the selected panel or floating object at the end 
of the timeline.

•	 Choose Arrange > Move Up to move the selected 
panel or floating object up one level, moving it closer 
toward the camera. This will also move the selected 
panel or floating object one step toward the end in 
the timeline.

•	 Choose Arrange > Move Down to move the selected 
panel or floating object down one level, moving 
it farther from the camera. This will also move the 
selected panel or floating object one step toward the 
beginning in the timeline.

•	 Choose Arrange > Send To Back to move the selected 
panel or floating object to the bottom of the layer 
stack. This will also place the selected panel or floating 
object at the beginning of the timeline.

Aligning Objects
Use the commands in the Arrange menu to change the 
stacking order of your items, or to align them horizontally 
or vertically.  The Align commands use the first object that 
you click to determine the alignment. You can SHIFT-click 
or COMMAND/CTRL click to select additional objects. Then 
choose the Align command that you want to apply.

 Align Object commands.

The commands are as follows:



MotionArtist
Reference Manual 

158

Chapter 14: Working with Objects

•	 Choose Arrange > Align > Left to align selected panels 
or objects at their left sides.

•	 Choose Arrange > Align > Right to align selected 
panels or objects at their right sides. 

•	 Choose Arrange > Align > Center Horizontally to align 
selected panels or objects at their horizontal centers.

 Align Left, Align Right, Center Horizontally.

•	 Choose Arrange > Align > Top to align selected 
objects at their top edges.

•	 Choose Arrange > Align > Bottom to align selected 
objects at their bottom edges.

•	 Choose Arrange > Align > Center Vertically to align 
selected panels or objects at their vertical centers.

 Align Top, Align Bottom, Center Vertically.
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Locking and Unlocking Objects
You can lock objects to prevent them from being 
accidently repositioned or changed; or unlock them to 
allow changes to be made. Use the Move tool (keyboard 
shortcut V) to select the object or objects that you want to 
lock, and then choose one of the following commands:

•	 Choose Arrange > Lock, or use the keyboard shortcut 
COMMAND/CTRL+L, to lock selected objects. 

•	 Choose Arrange > Unlock or use the keyboard 
shortcut COMMAND+OPT+L or CTRL+SHIFT+L, to unlock 
selected objects.

•	 Choose Arrange > Unlock All to unlock all objects and 
panels in the current scene that have previously been 
locked.

Camera and pause points can be moved 
even if selected layers are locked. The 

selected layers will be ignored. 

Setting Sequence Visibility
Use the Arrange > Sequence Visibility command to 
stagger the visibility of selected objects so that they 

disappear from the scene in a sequence. For example, 
you can select ten images that all appear on the screen 
at the same time, but then use the Sequence Visibility 
command to make them disappear one at a time.

After you select your objects, choose Arrange > Sequence  
Visibility to open the dialog shown in the following figure. 
Then set the options as follows:

 Sequence Visibility dialog.
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•	 Delay between layers (frames): Enter the number of 
frames that you want to occur between the time the 
previous layer has faded out to when the next image 
begins to fade out.

•	 Layer Order: Choose one of the following options to 
determine when the selected items will be invisible:

�� Bottom to top: The bottom-most layer will be the 
first one to become invisible. Layers above will 
become inviisible in sequence until the top-most 
layer is reached.

�� Top to bottom: The top-most layer will be the 
first one to become invisible. Layers below will 
become invisible in sequence until the bottom-
most layer is reached.

�� Random: Layers will become invisible in a random 
order.

•	 Fade Duration: Enter the number of frames that you 
want to apply to the end of each image for a fade-
out.

After you apply the command, the visibility of the selected 
objects will be sequenced according to your settings.  Sequence Visibility options are Bottom to Top (top example), 

Top to Bottom (middle example), and Random (bottom 
example).
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Toggling Selection Visibility
You can use the Arrange > Toggle Selection Visibility 
command or use the keyboard shortcut COMMAND/
CTRL+K to toggle the visibility of selected items. Items that 
were invisible before choosing the command will become 
visible, and objects that were visible will become invisible.

Shaking Objects
Choose Arrange > Shake Object to create animated 
keyframes that make the selected object appear to 
shake. For example, you can select text that says BOOM 
and make it shake as though something exploded.

To shake an object, follow these steps:

1.	 Select the panel that contains the object that you 
want to shake.

2.	 Switch to Panel view, and use the Move tool 
(keyboard shortcut V) to select the object that you 
want to shake.

3.	 Choose Arrange > Shake Object. The Shake Object 
dialog appears.

 Shake Object dialog.

4.	 Set the controls as desired:

�� Duration: Enter the number of frames in which the 
shake will occur.

�� Speed: Adjust the slider to the desired shake 
duration, or enter a new value in the Speed field. 
Move it toward the right to shake the object faster, 
and toward the left to shake the object more 
slowly.

�� Intensity: Controls the amount of shake. Move the 
slider toward the left to shake the object more 
slightly, and toward the right to shake the object 
more dramatically. You can also enter a numerical 
value in the Intensity field.

5.	 Choose OK to apply the shake to the object.
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Scattering Objects on the 
Artboard
The Scatter command is only available in Director’s view. 
You can use the Scatter command to arrange multiple 
selected objects in a random pattern on the artboard. The 
scatter can also be animated from a start frame to an end 
frame.

For example, you can drag several photographs into the 
scene and choose Arrange > Scatter to spread them out in 
a random order and at random angles over time.

The example that follows shows how you can add several 
free-floating images to a new scene in your project, to 
create a quick and attractive presentation.

1.	 Use the File > New command (or COMMAND/CTRL+N) 
to create a new scene.

2.	 Delete the default panel that appears in the scene 
window when you first create your new project; or, if 
your project contains panels, make sure there is no 
panel selected before you add your images to the 
project.

3.	 Locate a folder on your hard disk that contains several 
image files. 

4.	 Select several images and drag and drop them from 
Finder/Windows Explorer onto the artboard or into your 
selected panel.

5.	 Use the Edit > Select All command (or COMMAND/
CTRL+A) to select the objects that you want to scatter 
(images, movies, or panels). You can also SHIFT+Click 
or COMMAND/CTRL+Click with the Move tool to select 
objects.

The Scatter command will only scatter 
selected objects. Any unselected items will 

be left as is. The Arrange > Scatter command will be 
disabled unless three or more objects are selected.

6.	 Choose Arrange > Scatter. The Scatter dialog appears.
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 Scatter dialog.

7.	 Set the following options in the Scatter dialog as 
desired:

�� Start Frame: Enter the frame number on which 
you want the scatter to start. If the frame number 
is later than the current frame, the images will 
remain in their original positions until this frame 
number.

The start frame box is empty by default. If you 
leave this field empty, the scatter will start at 

the object’s previous stop point. 

�� End Frame: Enter the frame number at which you 
want the scattered images to reach their final 
scattered positions.

When the playhead lies between the start 
and end frames that you enter, the scatter 

will animate from the start position to the final end 
position. 

If you don’t want the scatter to animate, 
perform the scatter operation on frame 0 

and accept the default values that appear in the 
dialog when you choose the Arrange > Scatter 
command.

�� Scatter Distance: Controls the amount of distance 
between the scattered objects. You can move 
the slider to the left to decrease the amount of 
space between the scattered objects, or move it 
to the right to increase the distance. You can also 
enter a numerical value in the Scatter Distance 
field.
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�� Rotation: Enter the maximum number of degrees 
that you want the objjects to rotate. Higher values 
will cause the objects to spin while they animate to 
their final positions.

�� Randomize Rotation: Check this option to rotate 
each image by a random number of degrees. 
Uncheck this option to rotate all images by the 
amount entered in the Rotation field.

�� Fit Scatter to Panel: Check this option to resize 
the scattered objects so that they fit within the 
selected panel.

8.	 The images are scattered around the scene in random 
order. 

9.	 After you scatter the images, you can use the Arrange 
> Auto Camera command to animate the camera 
so that it moves from image to image. For more 
information about the Auto Camera command, see 
“Using Auto Camera” on page 56. 

 Photographs arranged on the artboard with the Scatter 
command.

10.	 After applying the Auto Camera command, press 
the Play button, and you can see the outline of the 
camera move from picture to picture. The camera 
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follows a path from the first image that was loaded, to 
the last image that was loaded.

11.	 Switch to Camera view by clicking the Camera View 
icon above the timeline. Press the Play button again to 
preview the animation.

 One of the photographs as viewed through Camera view 
during playback.

Scattering Objects in a Panel
The Scatter command can also be applied to objects in 
a panel. The steps to accomplish this are similar to those 
mentioned in “Scattering Objects on the Artboard” on 

page 162. For an example of how to scatter objects in a 
panel, proceed as follows:

1.	 Use the File > New command (or COMMAND/CTRL+N) 
to create a new scene.

2.	 Click the desired panel with the Move tool, or select it 
in the timeline.

3.	 Locate a folder on your hard disk that contains several 
image files. Select several images and drag and drop 
them from Finder/Windows Explorer into the selected 
panel.

4.	 Switch to Panel view to display the panel objects on 
the timeline. Then select the images as described 
previously in “Scattering Objects on the Artboard” on 
page 162.
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 Switch to Panel view to view and select the panel objects in 
the timeline.

5.	 Select three or more objects for the scatter operation.

The Scatter command will only scatter 
selected objects. Any unselected items will 

be left as is. The Arrange > Scatter command will be 
disabled unless three or more objects are selected.

6.	 Choose Arrange > Scatter. The Scatter dialog appears.

 Scatter dialog.

7.	 Set the following options in the Scatter dialog as 
desired:

�� Start Frame: Enter the frame number on which 
you want the scatter to start. If the frame number 
is later than the current frame, the images will 
remain in their original positions until this frame 
number.
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�� End Frame: Enter the frame number at which you 
want the scattered images to reach their final 
scattered positions.

If you don’t want the scatter to animate, 
move the playhead to frame 0 in the panel, 

or to the layer start frame. Accept the default 
values that appear in the dialogue when you 
choose the Arrange > Scatter command.

When the playhead lies between the start 
and end frames that you enter, the scatter 

will animate from the start position to the final end 
position.

�� Scatter Distance: Controls the amount of distance 
between the scattered objects. You can move 
the slider to the left to decrease the amount of 
space between the scattered objects, or move it 
to the right to increase the distance. You can also 
enter a numerical value in the Scatter Distance 
field.

�� Rotation: Enter the maximum number of degrees 
that you want the objjects to rotate. Higher values 
will cause the objects to spin while they animate to 
their final positions.

�� Randomize Rotation: Check this option to rotate 
each image by a random number of degrees. 
Uncheck this option to rotate all images by the 
amount entered in the Rotation field.

�� Fit Scatter to Panel: Check this option to resize 
the scattered objects so that they fit within the 
selected panel.

 Scattered objects fit inside a panel.
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Arranging Objects in a Grid
You can use the Arrange > Grid command to arrange your 
objects in a grid pattern, either on the artboard or within 
a selected panel. For example, you can select a series of 
twelve photos, and use the Arrange > Grid command to 
arrange them in a grid pattern that is four photos wide and 
three photos high.

The Arrange > Grid command works best 
when the selected items are all 

approximately the same size (such as a group of 
photographs that are the same resolution and 
dimensions).

If you choose this command while working in Presentation 
mode, or afterward use the Auto Camera command to 
arrange the objects in your scene, the camera will start 
at the first photo in the top row. When it reaches the last 
photo in the top row, it will then move to the first photo 
in the second row, and play through that row of photos. 
Each successive row will play in a similar manner.

 Photographs arranged in a Grid.

After you select your content, choose the Arrange > Grid 
command. The Grid dialog presents the following options:
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 Grid dialog.

•	 Start Frame: Enter the frame number on which you 
want the scatter to start. If the frame number is later 
than the current frame, the images will remain in their 
original positions until this frame number.

•	 End Frame: Enter the frame number at which you want 
the scattered images to reach their final scattered 
positions.

When the playhead lies between the start 
and end frames that you enter, the grid will 

animate from the start position to the final end 
position. 

If you don’t want the grid to animate, set the 
playhead to frame 0 or at the layer start 

frame before choosing the Arrange > Grid 
command, and then accept the default values that 
appear in the Grid dialog.

•	 Fit Scatter to Panel: Check this option to resize the 
scattered objects so that they fit within the selected 
panel.

Positioning Objects
After selecting an object with the Move tool while in 
Standard Mode, you can choose Arrange > Position 
Object to open the Object Stop Point dialog. This dialog 
allows you to enter X, Y, and Z coordinates for the stop 
point associated with the object. For more information, see 
“Editing Stop Points in Director View” on page 51 and 
“Editing Stop Points in Camera View” on page 55.
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You can reposition the origin point of any 
object by pressing the CMD/Ctrl+Alt keys 

and selecting the origin point.  You can change the 
origin point at any time, even after you have 
animated it. 

Working with Text and Word 
Balloons
MotionArtist allows you to enter text in your projects. While 
doing so, you have the option to automatically create a 
word balloon that encloses the text.

The following example explains how you can add text and 
a word balloon inside a panel:

1.	 Select the panel into which you want to add the text.

2.	 Switch to Panel View and position the content in the 
scene as desired.

3.	 Choose Panel > Insert Text or use the keyboard 
shortcut COMMAND/CTRL+T to add text to the current 
panel. The Insert Text dialog appears.

 Insert Text dialog.
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4.	 The Select Font list displays all of the fonts on your 
system. Select the font that you want to use from the 
list.

When entering text in MotionArtist, text 
created with the Insert Text panel will be 

drawn with characters in the selected font. If a 
desired Unicode character does not exist in the 
selected font, a box will be displayed when you 
type. To use Unicode characters that do not appear 
in the selected font, you must choose a font that 
includes the characters you need.

5.	 Enter the text in the Text field. The artboard shows the 
text as you type. 

Word balloons will automatically resize to 
accommodate the text. If you want to break 

the text into multiple lines, you will need to press the 
Enter key where you want a line break to occur.

6.	 Use the remaining settings to set additional text 
properties as follows:

�� Fill: Check this option if you want your text to be 
filled with a solid color. Uncheck the option if 
you want your text to only use an outline stroke 

(described next). For filled text, click the color 
swatch to select the fill color.

�� Stroke: Check this option if you want your text 
to have an outline. You can set the width of the 
outline (in pixels) in the Width field. Click the Color 
swatch to select the outline color.

�� Justification: Click the justification type that you 
want to apply to the text. Choices are Left, Center 
(the default), or Right. 

�� Scale: Use the Scale slider to increase or decrease 
the text size, or enter a scale value in the Scale 
field. 

�� Leading: Use the Leading slider to adjust the 
spacing that appears between multiple lines of 
text. Move toward the left to decrease space, 
and toward the right to increase space. Negative 
values are also valid.

�� Kerning: Use the Kerning slider to adjust the 
amount of space between letters. Move toward 
the left to decrease space, and toward the right 
to increase space. Negative values are also valid.

7.	 If you want to use a word balloon to enclose your 
text, select one of the word balloons from the list. 
Otherwise, choose None if you do not want to use a 
word balloon.
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 Text preview (with word balloon) that appears on the artboard 
while you type.

8.	 Use the following settings to determine the color and 
size of the word balloon:

�� Custom Fill: Check this option if you want to select 
a fill color for the word balloon. Click the color 
swatch to choose the desired fill color.

�� Custom Stroke: Check this option if you want to 
select a stroke (outline) color for the balloon. Click 

the color swatch to choose the desired stroke 
color.

�� Stroke Width: Enter the width of the stroke used for 
the word balloon in pixels.

�� Size Relative to Text: Use this slider to increase 
or decrease the amount of white space that 
appears between the text and the outer edges 
of the balloon. Move the slider toward the left to 
decrease the amount of space, and toward the 
right to increase the amount of space.

�� Flip Vertical: Check this option to flip the object 
vertically. For example, if the tail is on the bottom 
of the balloon by default, it will place the tail on 
the top.

�� Flip Horizontal: Check this option to flip the object 
horizontally. For example, if the tail is on the left 
side of the balloon by default, it will flip the balloon 
so that the tail is on the right side.

�� Constrain Proportions: Check this option if you 
want to keep an equal amount of white space 
around the width and height of the balloon. When 
unchecked,  the height of the balloon will be 
closer to the text, and the width of the balloon will 
have more white space.
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9.	 When you select a word balloon, additional options 
(custom for each word balloon) appear beneath 
the selection. These options allow you to change the 
appearance of the word balloon. For example, you 
might find options that affect the appearance and 
placement of the balloon tail, or whether the outer 
edges of the balloon are smooth or cloud-like. Each 
of these balloon morphs are set to zero, initially. You 
can move the dials in any combination to change 
the appearance of the balloon. The preview window 
updates as you make your changes.

 Balloon morphs.

Creating Word Balloons
You can use Anime Studio to create word balloons for 
MotionArtist. Briefly, the following conditions should be met 
when creating word balloons:

•	 The Anime Studio files must contain a rectangular point 
group named Text Region. If this point group is missing, 
the balloon will be considered invalid.

 When creating word balloons in Anime Studio, the project 
must contain a rectangular point group named Text Region.

•	 If you want to add morph targets to your word 
balloon, you will need to use the Window > Actions 
command to open the Actions window. Use the New 
Action button in the Actions toolbar to design single-
frame animations that you can use for your morph 
targets. For further information on this process, see the 
Creating Morphs topic in your Anime Studio Pro users 
manual (in the Character Wizard chapter). 
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•	 When you install MotionArtist, default word balloons 
appear in the Resources > Support > Word Balloons 
installation folder. It is not recommended to put 
your custom word balloons in this same folder. 
Instead, create a content folder as recommended 
in “Creating a Content Folder” on page 21, and 
place your custom word balloons in its Word Balloons 
subfolder. Your user-created word balloons will show 
up in the list the next time you choose the Text tool.

Working with Images

Reverting Images to their Original Size 
If an image has been resized manually or by other 
MotionArtist commands (such as Images > Fit Image to 
Panel), you can easily revert them back to their original 
size. After you select the image(s) you want to change, 
choose the Images > Revert to Original Size command. 
The image will stay in its current position, but will be reset to 
its original size.

Fitting Images to Panels
If an image is too large to be fully displayed within a panel, 
you can use the Images > Fit Image to Panel command to 
resize it. After you select the panel, switch to Panel view. 
Then click to select the image that you want to resize. 
Choose the Images > Fit Image to Panel command to 
resize the image appropriately for the panel. 

Resizing the image will not automatically 
center the image in the panel. If you want to 

center the image, use the Images > Center in Panel 
command, described next. 

Centering Images in Panels
You can use the Images > Center in Panel command to 
center one or more images in a selected panel.

After you select the panel, switch to Panel view. Then 
select the images that you want to center, and choose 
the Images > Center in Panel command. The selected 
image(s) will move to the center of the panel.
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Working with Audio
You can record and edit audio in MotionArtist, and 
perform simple edits such as volume adjustment, length, 
and simple cuts.

Recording Audio
To record audio, choose File > Record Audio, or use 
the keyboard shortcut COMMAND/CTRL+U. The Audio 
Recording dialog appears.

 Audio Recording dialog.
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You can display or hide the Audio Recording 
window using the Window > Audio Recording 

command.

1.	 If you have multiple recording devices on your system, 
use the dropdown list in the middle of the dialog to 
select the microphone that you want to use.

2.	 To begin recording, click the top icon with the red 
dot. When the recording is complete, click the button 
again to stop recording.

3.	 To play the recording back, click the Play icon to listen 
to the recording. 

4.	 Check the Sync with Timeline Playback option to 
record the audio at the same frame rate as that which 
is set in the Project Settings dialog.

5.	 You can use the Pitch Shifting section to raise or lower 
the pitch of the speaker. Move the slider toward the 
left to lower the pitch, and toward the right to raise it. 
The Reset button will set the Pitch back to the original 
level.

6.	 After you have completed your recording, click the 
Add to Project button. The audio file will be added 
to the project. The length of the project will be 

lengthened if necessary to include the entire length of 
the audio file. 

Putting it All Together
In this section, you’ll get a brief overview of how objects 
and sound can come together to create a MotionArtist 
project. The Area 52 project contains only one panel. 
There are several objects in that panel, including sound. 
The following visual elements appear in the timeline, with 
the total project length being 2281 frames.

•	 A panel

•	 Background layer

•	 Three text layers that appear at the introduction.

•	 Three cloud layers.

•	 A helicopter.

•	 Seven dialog layers (word balloons)

The following audio elements are also included:

•	 A music track

•	 Spoken dialog
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•	 Helicopter sound (used twice)

When the project first starts, the panel background is 
black. The music track is at full volume. This continues until 
frame 60, when the panel begins fading in from black. The 
background becomes fully visible at frame 120. 

  Frame 57.

 Fade to black keyframes for Panel 1.

Then, beginning at frame 150, the three introductory text 
layers come on in sequence, with all three of them finally 
appearing in full opacity at frame 264. They remain on 
screen until they all fade out at frame 418. The following 
screen shot shows the scene with all three text elements 
displayed. One cloud layer (Cloud 1) is slowly moving from 
the right side of the screen.
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 Frame 320.

 Keyframes for introductory text layers.

The helicopter sound begins to play just before the 
introductory text fades out. The helicopter starts to move 
into the scene at frame 480, and the front half appears at 
the left of the scene in frame 555. The helicopter reaches 
the middle of the scene at frame 628. 

 Frame 555.

 Helicopter keyframes.

After the helicopter moves to the center, it moves around 
in circular motion as though it is bouncing due to air 
currents. This circular bouncing movement continues 
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through frame 1980. At frame 721, the volume of the music 
track is reduced so that the dialog is heard more easily. 
The first word balloon appears at frame 780.

 Frame 780.

 Helicopter and word balloon keyframes.

The helicopter bounces in circular motion while several 
text balloons are synchronized with the dialog in the audio 
track. The background layer is translated to move the 
background toward the ground, while additional cloud 
layers move through the view of the camera. The last word 
balloon stops at frame 1914, as the helicopter nears the 
ground.

 Frame 1914.
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 Word balloon and helicopter keyframes.

After the dialog stops, the volume of the music track is 
increased, and the helicopter moves off the screen to the 
right as it is deceased in size. Finally, the scene fades to 
black beginning at frame 2100 and ending at frame 2160.

 Frame 2100.



MotionArtist
Reference Manual

181

Chapter 15: Distributing Your Comics

Chapter 15: Distributing 
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Previewing Your Work
To preview your work while you are designing your project, 
or before you publish your final product, choose File > 
Render Frame, or use the keyboard shortcut COMMAND/
CTRL+R. MotionArtist will render a quick JPG render of the 
current point in time, through the current view.

After you render the frame, click the Save As button at 
the bottom left corner of the Render window to save the 
render as a JPG, BMP, Targa, or PNG file. You can also 
copy the image to the clipboard by choosing Copy to 
Clipboard. 

 A rendered frame.

Gathering Content
The File > Gather Media command allows you to easily 
collect all of the media that is contained in a project, and 
save it to a single folder.

To create a gathered media folder, follow these steps:

1.	 Choose File > Gather Media. The Save As dialog 
appears.
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2.	 Locate the folder beneath which you want to create 
the gathered media folder, and enter a file name. The 
file will be saved with the .ming file extension.

3.	 Click Save. MotionArtist will save the project file in 
the selected folder. The associated media will be 
collected and saved in subfolders. For example, 
images associated with a project will be stored in a 
subfolder named images.

The ming file that is saved into the Gathered 
Media folder will reference the media files 

stored within that gathered media folder. The 
gathered project will no longer link to the original file 
locations that were brought into the project. 
Therefore, if you open the ming file in the gathered 
media folder and need to make changes to the 
media, you should edit the media stored in the 
gathered media folder.

Imported Anime Studio files are combined 
with the .ming file on import. You will not see 

a link to the original .anme file in your gathered 
project, or references its associated media (images, 
brushes, etc.) 

Exporting Movies and Images
To export your comic to a format that you can distribute, 
choose File > Export Movie, or use the keyboard shortcut 
COMMAND/CTRL+E. You can also click the Export button 
on the MotionArtist toolbar.

The Export Animation dialog allows you to export your 
MotionArtist project in several different file formats, 
including JPEG, BMP, Targa, PNG, PSD, AVI Movie, and 
QuickTime movie.

 Export Animation dialog.
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The options in the Export Animation dialog are as follows:

•	 Start Frame: By default, the first frame in the animation 
is entered here. Enter a new value if you want to start 
the export later in the timeline.

•	 End Frame: By default, the End Frame value is the 
last frame in the project. If your project has multiple 
scenes, the value entered in this box will represent the 
total number of frames in all scenes in your project.

You can toggle the scene’s Visible icon off to 
prevent a scene from being viewed or 

rendered. See “Adding Scenes” on page 87 for 
further information about this icon.

•	 Entire Animation: Click this button to reset the start and 
end frames to the length required to export the entire 
animation (all frames from all scenes in the project).

•	 Image Formats: If you choose JPEG, BMP, Targa, PNG, 
or PSD, each frame of your MotionArtist project will be 
exported as a series of sequentially-numbered images 
that you can assemble and edit in your video editing 
software.

•	 Movie Formats: Several movie format options are 
available to output video in various different frame 

sizes: The size you select here should generally 
correspond to the project size that you set in your 
project settings. For more information about project 
settings, see “Project Settings” on page 83.

�� MP4 Movie: Exports a H.264-AAC movie.

�� iPhone Movie:  Exports a 480 x 320 movie.

�� iPhone 4 Movie: Exports 1 960 x 640 movie.

�� iPhone 5 Movie: Exports a 1136 x 640 movie.

�� iPad Movie:  Exports a 1024 x 768 movie.

�� iPad HD Movie: Exports a 1280 x 1024 movie.

�� Android Movie: Exports a 480 x 360 movie.

�� Android HD Movie: Exports a 1280 x 1024 movie.

�� AVI Movie (DV): Exports a 720 x 480 movie.

�� AVI Movie (Uncompressed): Exports an 
uncompressed movie. This option is generally used 
when the exported movie is edited in a third party 
movie editor.

�� AVI Movie: Exports an AVI movie using the current 
project dimensions.
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When choosing an AVI or MOV compression 
format or codec for export, keep in mind 

that viewers must also have the same codec 
available to view the file. We recommend that you 
select a basic compression format/codec that is 
installed with Windows or Mac OS X.

QuickTime for Windows is required to export 
and view MOV format on the Windows 

operating system.

When you export in the MOV or AVI format, a dialog will 
display a progress bar as the movie is exported. After the 
export is finished you will be able to view your movie in any 
media player that supports the MOV or AVI format.

Publishing to YouTube or 
FaceBook
MotionArtist allows you to publish and share your creations 
on YouTube and FaceBook. 

On YouTube
Before you upload a video to YouTube, make sure that 
your YouTube account information is entered in the 
Preferences dialog, as mentioned in “Web Uploads” 
on page 33. If this information is not entered, the 
Preferences dialog will open to the Web Uploads tab the 
first time you try to upload to YouTube.

To share a movie file on YouTube, proceed as follows:

1.	 Choose Share > YouTube. MotionArtist will prompt you 
to locate a movie file to share. 

2.	 After you select your movie file, the Video Upload 
dialog displays the name of the movie you are 
uploading. Choose Cancel to return to MotionArtist, or 
Change Movie to select another movie. If you want to 
upload the movie, choose OK to proceed.

3.	 MotionArtist will upload the video to your YouTube 
account. Depending on the preference you set, the 
videos can be uploaded publicly or privately.
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You can use the Web Uploads tab in the 
Preferences dialog to configure your 

YouTube user name and password, and set a 
privacy option if you want your movies to be shared 
privately. For more information on the Web Upload 
preferences, see “Web Uploads” on page 33.

On FaceBook
To share your content on FaceBook, follow these steps:

1.	 Choose Share > FaceBook.  

2.	 MotionArtist will open a dialog that prompts you to 
select the movie that you want to upload. Use the 
dialog to locate the movie you want to upload.

3.	 After making the selection, MotionArtist displays the 
Video Upload dialog. The name of the movie that you 
are uploading appears in the upper section of the 
dialog. Beneath that, a preview window displays a 
preview of the first frame of the movie. 

�� Choose OK to continue with the upload. 

�� Choose Cancel to return to MotionArtist. 

�� Choose Change Movie to select another movie 
from your hard disk.

4.	 If you have not yet authorized FaceBook to use the 
video uploader app, your default browser will open to 
your FaceBook account. You will be asked if you want 
to allow video uploads from the Smith Micro Video 
Uploader. After you authorize the application, close 
your browser window and return to MotionArtist.

5.	 When you return to MotionArtist, a dialog asks you to 
confirm that you want to upload the file. Click OK to 
complete the upload to your FaceBook account.

You will need to agree to all the 
authentication requests before posting. If you 

deny the request, MotionArtist will not upload the 
video and will give you an error message as such.

Publishing to MotionArtistTV
The File > Publish to MotionArtistTV command allows you 
to publish your MotionArtist projects to the MotionArtistTV 
portal, where others can view them. 

MotionArtistTV is a public publishing portal for MotionArtist 
users. Movies are displayed in a gallery type format which 
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displays the movie name, the name of the user that 
uploaded the movie, and a record of how many times the 
movie has been viewed. 

 The MotionArtistTV Home Page.

If you have not yet signed up for a 
MotionArtistTV account, you will be 

prompted to do so before you publish your first 
movie. You will be directed to the MotionArtistTV site 
where you can set up your account. You will be 
required to enter first and last name, a username, a 
valid email address, and a password.

After you have completed your project, choose FIle 
> Publish to MotionArtist TV. MotionArtist will display 
a progress dialog while it prepares your project for 
publication, 

Next, you will be prompted to log in to your MotionArtistTV 
account. 

If you have not already created an account 
the MotionArtistTV Login dialog includes a 

Create Account button. Click this button to open 
your web browser to the MotionArtistTV web site, 
where you can set up your new account.

The MotionArtist TV dialog appears. 
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 Publish to MotionArtistTV dialog.

Complete the following options:

•	 Thumbnail: Use the slider to select the frame that you 
want to use for a movie thumbnail.

•	 Name: Assign a name to the movie. This is the name 
that will appear beside the thumbnail. Try to select a 
name that is descriptive of the movie.

•	 Series: Enter a series name, which you can use to 
categories movies that have a common theme or 
purpose. Existing series names can be selected by 
clicking the down arrow that appears at the right of 
the Series field. You can also remove a movie from a 
series by selecting None from the dropdown list.

•	 Info: In this field, you can enter descriptive informaiton 
about the movie, such as a storyline, production 
credits, and other information that might be useful for 
the readers. 

•	 Switch User: Click this button if you want to log in under 
a different MotionArtistTV user name.

•	 Cancel: Click this button to cancel the upload 
process.

•	 OK: Click this button to complete the publishing 
process.
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After you press OK, a progress bar will display as your 
project is uploaded to MotionArtistTV.

 A progress bar appears while your project is being uploaded.

To view the published movie, open your web browser 
and navigate to motionartist.tv. Log in to your account if 
necessary. Your new MotionArtist project will appear in the 
New uploads section. 

You can make changes to uploaded videos 
at any time. To do so, click on your account 

name which is located in the top right section of 
your browser window, then choose Profile. You will 
be able to view the episodes and series that you 
have uploaded. Simply select the video that you 
want to edit or delete, and make the desired 
changes.

motionartist.tv
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Part 4: 
Appendices
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Appendix A: Technical 
Support

We’ve worked hard to ensure that MotionArtist’s powerful 
features are both easy to use and available to users 
running a wide variety of computers. However, there 
may be times when you need technical support. Smith 
Micro Software is pleased to offer free technical support 
to registered users of our products. To receive technical 
support, please visit our Web site at https://support.
smithmicro.com/ and browse through our extensive 
product FAQs.

Please use the following checklist before contacting 
Technical Support:

•	 MotionArtist Reference Manual: This Reference Manual 
answers most MotionArtist questions. Before contacting 
Technical Support, please read the pertinent section(s) 
of this manual thoroughly.

•	 FAQ: Please visit the product FAQs at the above-listed 
URL.

Still don’t see your question answered? Please contact 
Technical Support by clicking the link to http://support.
smithmicro.com and completing our online support 

form. When contacting Technical Support, please fill 
out the form as completely as possible and include as 
much information as possible. This will help us resolve 
your issue faster. Once the form is complete, a Technical 
Support representative will contact you directly as soon 
as possible. Support requests are answered via e-mail in 
the order they are received. Online support is free to all 
registered MotionArtist users. MotionArtist users are strongly 
encouraged to register after installing the application on 
http://store.smithmicro.com/productregistration.aspx.

In order to receive support, we require the following 
information:

•	 Your name

•	 E-mail address

•	 Telephone number (including international dialing 
information, if applicable)

•	 Your current operating system

•	 Your computer specifications (CPU, RAM, hard drive, 
video card, etc.)

•	 MotionArtist serial number

•	 Detailed description of the problem

https://support.smithmicro.com/%20
https://support.smithmicro.com/%20
http://support.smithmicro.com
http://support.smithmicro.com
http://store.smithmicro.com/productregistration.aspx
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This information will help us isolate and resolve your issue. 
We require this information in order to provide support 
services and are unable to respond to incomplete requests 
in a timely fashion.

For international support, please contact your local 
distributor. Smith Micro Software maintains a list of our 
international distributors at http://my.smithmicro.com/
store/intlpartners.HTML.

Smith Micro Software reserves the right to 
alter our technical support policies at any 

time without advance notice.

http://my.smithmicro.com/store/intlpartners.html
http://my.smithmicro.com/store/intlpartners.html
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Appendix B: Keyboard 
Shortcuts

Keyboard shortcuts are available for many menu 
commands found in MotionArtist. The following tables 
summarize the available keyboard shortcuts for each 
menu.

File Menu

Command Windows Mac
File > New CTRL+N COMMAND+N

File > Open CTRL+O COMMAND+O

File > Close CTRL+W COMMAND+W

File > Save CTRL+S COMMAND+S

File > Project Settings CTRL+SHIFT+P COMMAND+SHIFT+P

File > Render Frame CTRL+R COMMAND+R

File > Export Movie CTRL+E COMMAND+E

File > Import CTRL+I COMMAND+I

File > Record Audio CTRL+U COMMAND+U

File > Quit CTRL+Q COMMAND+Q

Edit Menu

Command Windows Mac
Edit > Undo CTRL+Z COMMAND+Z

Edit > Redo CTRL+SHIFT+Z COMMAND+SHIFT+Z

Edit > Cut CTRL+X COMMAND+X

Edit > Copy CTRL+C COMMAND+C

Edit > Paste CTRL+V COMMAND+V

Edit > Select All CTRL+A COMMAND+A

* Preferences command is found in the MotionArtist 
application menu in Mac systems
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Arrange Menu

Command Windows Mac
Arrange > Lock CTRL+L COMMAND+L

Arrange > Unlock CTRL+ALT+L COMMAND+OPT+L

Arrange > Animation 
> Add Object Stop 
Point

CTRL+0 (zero) COMMAND+0 (zero)

Arrange > Animation 
> Add Camera Stop 
Point

CTRL+9 COMMAND+9

Arrange > Animation 
> Set Layer Start 
Frame

CTRL+B COMMAND+B

Arrange > Toggle 
Selection Visibility

CTRL+K COMMAND+K

Arrange > Position 
Object

CTRL+M COMMAND+M

Arrange > Position 
Camera

CTRL+SHIFT+M COMMAND+SHIFT+M

Panel Menu

Command Windows Mac
Panel > New Panel CTRL+SHIFT+N COMMAND+SHIFT+N

Panel > Insert Text CTRL+T COMMAND+T

View Menu

Command Windows Mac
View > Director View CTRL+1 COMMAND+1

View > Camera View CTRL+2 COMMAND+2

View > Panel View CTRL+3 COMMAND+3

View > Timeline 
Zoom In

ALT+Mousewheel 
Scroll Up

OPT+Mousewheel 
Scroll Up

View > Timeline 
Zoom Out

ALT+Mousewheel 
Scroll Down

OPT+Mousewheel 
Scroll Down

View > Enable Grid CTRL+G COMMAND+G

View > Grid Settings CTRL+SHIFT+G COMMAND+SHIFT+G
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Window Menu

Command Windows Mac
Window > Timeline CTRL+SHIFT+T COMMAND+SHIFT+T

Window > Library CTRL+SHIFT+L COMMAND+SHIFT+L

Window > Audio 
Recording

CTRL+SHIFT+A COMMAND+SHIFT+A

Window > Layer 
Settings

CTRL+SHIFT+I COMMAND+SHIFT+I

Other Hot Keys

Tools

Command Key
Rectangular Panel R

Oval Panel O

Polygon Panel M

Camera Target A

Split Panels S

Pan N

Zoom Z

Add Text T or CTRL/COMMAND+T

Move Tool V

Camera Tool C

Views

Command Key
Director View CTRL/COMMAND+1

Camera View CTRL/COMMAND+2

Panel View CTRL/COMMAND+3

Scenes and Panels

Command Key
Cycle Panel Tools P (repeat until desired tool is 

selected)

Cycle Panel Tools Backwards SHIFT+P

Next Panel TAB

Previous Panel SHIFT+TAB

Go to Frame 1 of Scene or Panel SHIFT+ALT+Left Arrow

Go to Last Frame of Scene or 
Panel

SHIFT+ALT+Right Arrow



MotionArtist
Reference Manual

195

Appendix B: Keyboard Shortcuts

Next Scene > or . (Period)

Previous Scene < or , (Comma)

Stop Points

Command Key
Previous Object Stop Point [

Next Object Stop Point ]

Previous Camera Stop Point SHIFT+[

Next Camera Stop Point SHIFT+]

Previous Stop Point (Camera or 
Object)

CTRL/COMMAND+[

Next Stop Point (Camera or 
Object)

CTRL/COMMAND+]

Create Object Stop Point CTRL/COMMAND+0 (zero)

Create Camera Stop Point CTRL/COMMAND+9

Timeline

Command Key
Navigate Timeline (Select 
objects)

Up/Down Arrow Keys

Left/Right (Jump to frame + or - 1 
second))

SHIFT+Left/Right Arrow Keys

Step backward/forward 1 frame Left/Right Arrow Keys

Move Object Priority on Timeline ALT+Up/Down Arrow Keys

Move Object Position on Timeline ALT+Left/Right Arrow Keys

Zoom in Timeline CTRL/COMMAND + Mouse 
Wheel Scroll Up

Zoom Out Timeline CTRL/COMMAND + Mouse 
Wheel Scroll Down

Objects

Command Key
Nudge Left/Right SHIFT+CTRL/COMMAND+Left/

Right Arrow Keys

Nudge Up/Down SHIFT+CTRL/COMMAND+Up/
Down Arrow Keys

Micro-Nudge COMMAND/CTRL+Left, Right, Up, 
or Down Arrow Keys
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Other

Command Key
Center Camera ESC

Minimize All Palettes ~

Zoom In =/+ (Equal or Plus Key)

Zoom Out - (Minus Key)
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Index
A

Add to Scene  126
Adobe Illustrator

Importing AI8 files  149
Animation Commands  153
Anime Studio Files

Importing  141
Application colors

Resetting to default  35
Artboard  27
Audio

Importing  137
Recording  175
Tools  29

Auto Camera  56
Ignoring  74

Automatic  72, 73
Auto-saving  33
Auto-scaling vectors  32

B

Background Audio  85
Brushes

Aligning with curves  78
Jitter angle  78
Minimizing frame to frame 

randomness  78
Settings  131
Spacing  78
Style  78
Tinting with stroke color  79

Brush Settings  77

C

Camera layer  64
Cameras

Setting outline color  35
Setting shade color  35

Camera Target
Setting color  35

Camera Tool  50
Camera View  42

Transforming camera in  54
Color themes  36
Compositing Effects  70

Content
Clearing  150
Gathering  181
Obtaining  136
Selecting All  150

Content Folder
Creating  21

Continue to Next Scene  110
Crash recovery  33
Crumble  91
Current Project Folder  124

D

Default startup file  33
Documentation  4

E

Editor Colors  34
End of Scene Behaviors  110
EPS

Importing  149
EULA  8
Exporting Images  182
Exporting Movies  182
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F

FaceBook  185
Fade to Black  90
Fade to White  90
Floating objects

Ignoring Auto Camera  75
Setting duration  75

Floating Objects  151
Naming  70

Fonts
Increasing font size  36

Frame  64
Frame rate  84

G

Gathered Media Folders  181
GPU accelerated drawing  32
Grid

Arranging Objects  168
Displaying and Setting  46
Enabling  47
Setting color  35

GUI Colors  35
Resetting  36

Guides

Setting color  35

H

Horizontal Wipe  90
HTML5

Creating a Home Scene  120
Embedding a MotionArtist 

Project  117
Embedding Multiple Motion-

Artist Projects  118
Generating Previews  30
Interactivity  119
Supported features  120
Unsupported Features  121

HTML Export Tab  79, 108

I

Images
Importing  131
Nearest neighbor sampling  81
Outlines  74
Setting outline color  74
Setting outline width  74
Settings  132
Source image  80
Toon settings  81

Unwrapping  81
Image Tab  79
Importing  143
Installation

Mac  20
Windows  19

Iris Wipe  91

J

Jump to End  64
Jump to Project Beginning  111

K

Keyboard Shortcuts  192

L

Library  28, 123
Adding a folder  126
Adding content  126, 127
Current Project folder  123
Deleting content  126, 129
Docking and undocking  123
My Library folder  123
Searching  126, 129

Locking
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Objects  159
Scenes  87

Loop Scene  111

M

Menu Bar  26
Menu Commands

Arrange
Grid  168

Arrange Menu
Align > Bottom  158
Align > Center Horizontally  

158
Align > Center Vertically  158
Align > Left  158
Align > Right  158
Align > Top  158
Animation

Add Camera Stop Point  154
Add Object Stop Point  153
Clear Camera After Current 

Frame  154
Clear Object After Current 

Frame  154
Clear Panel Animation  154
Clear Scene After Current Frame  

154
Set Layer Start Frame  154

Arrange in 3D  105
Auto Camera  58, 99

Auto Camera All  58
Auto Camera Selected  58
Auto Camera Targets  58
Auto Camera with Pause Points  

58
Bring to Front  157
Lock  159, 193
Motion Assist  65
Move Down  157
Move Up  157
Position Camera  52
Position Object  169
Scatter  162, 166
Send to Back  157
Sequence Visibility  159
Shake Object  161
Toggle Selection Visibility  

161
Unlock  159
Unlock All  159

Edit Menu
Clear  150
Copy  150, 192
Cut  150, 192

Paste  150, 192
Preferences  31
Redo  150, 192
Select All  150, 192
Undo  105, 150, 192

File Menu
Add Scene  30, 87
Close  86, 192
Delete Scene  88
Duplicate Scene  88
Export HTML5  111
Export Movie  182, 192
Gather Media  181
Import  97, 131, 132, 136, 137, 

138, 140, 141, 146, 192
Import Background  97
New  83, 100, 192
Open  83, 192
Open Recent  83
Project Settings  83, 192
Publish to MotionArtistTV  185
Quit  86, 192
Record Audio  175, 192
Render Frame  181
Save  85, 192
Save As  86

Help Menu
About MotionArtist  5
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Check for Content  23
Community  5
Help  4, 5
Open Custom Content 

Folder  21
Register  22
Set Custom Content Folder  

21
Video Tutorials  5
Welcome Screen  22

Images Menu
Center in Panel  174
Fit Image to Panel  174
Revert to Original Size  174

Panel Menu
Arrange in 3D  105
Delete Panel  105
Duplicate Panel  103
Fit Panel to Selection  106
Flatten Panel  106
Insert Text  170, 193
New Panel  93, 193

Share Menu
FaceBook  185
YouTube  184

View Menu
Camera Frame  45
Camera View  42, 193

Director View  38, 52, 193
Enable Grid  193
Grid Settings  47, 193
Page Guides  25, 27, 44
Panel View  43, 193
Reset  48
Show View/Mode  26
Thirds Grid  46
Timeline Zoom In  61, 193
Timeline Zoom Out  61, 193
Video Safe Zones  45

Window Menu
Audio Recording  176
Library  123, 194
Timeline  61, 194

MotionArtistTV  185
Motion Assist  65
Motion Path  50
Movies

AVI with alpha  80
Frames per second  81
Holding at first frame  80
Holding at last frame  80
Importing  136
Looping indefinitely  80
Playing backwards  80
Settings  132

My Library Folder  125

N

Next Stop Point  64
Null Panels  97

O

Objects
Aligning  157
Animating  152
Arranging  156
Locking and Unlocking  159
Moving  154
Naming  70
Positioning  169
Rotating  156
Scaling  155
Scattering  162
Setting color of selected  35
Shaking  161
Stop points  152

OBJ Files  138
Online Support  5

P
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Page Guides  44
Panels

Allowing animation  74
Animating  106
Arranging in 3D Space  105
Automatic tilt  85
Background color  85
Camera Target  97
Creating  93
Default duration  84
Default stroke width  35
Deleting  104
Duplicating  103
Exporting  131
In Presentation mode  100
Naming  70
Oval  95
Polygon  96
Rectangular  94
Restoring factory settings  85
Saving default settings  85
Setting Brush Style  73
Setting duration  73
Setting fill color  34
Setting Fill Color  73
Setting opacity  85
Settings  131
Setting stroke color  35

Setting Stroke Color  73
Setting Stroke Width  73
Splitting  101

Panel tools  29
Panel View  43
Pause at End of Scene:  110
Pausing Playback  113
Photoshop Files  132

Importing  135
Preparing layers  132

Playback controls  63
Play/Stop  63
Poser Files

Importing  139
Poser location  33
Preferences  31

Editor Colors  34
GUI Colors  35
Options  32

Presentation Mode  72, 87
Previewing  181
Projects

Closing  86
Constraining proportions  84
Creating  83
Dimensions  84

Saving  85
Setting frame rate  84
Setting height  84
Settings  83
Setting width  84

Project tools  30

Q

Quitting MotionArtist  86

R

Redo  150
Reference manual  4
Registration  22
Resuming Playback  114
Rewinding  63

S

Sampling by nearest neighbor  
33

Saving projects  86
Scale images for the Web  112
Scattering  162
Scene Duration  72
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Scenes
Adding  87
Changing  88
Deleting  88
Duplicating  88
Locking  87
Naming  87
Reordering  88
Settings  88
Transitions  89
Visibility  87

Scene Tabs  30
Selection tools  29
Shading  76

Blur  77
Color  77
Contraction  77
Direction  77
Offset  77
Turning on  77

Shadows
Blur  76
Color  76
Direction  76
Expansion  76
Offset  76
Turning on  76

Shadows Tab  75
Sharing

On FaceBook  185
On YouTube  184

SMPTE timecode  33
Snapshots  146
Standard Mode  38
Startup file  33
Step Back  63
Step Forward  64
Stop Points  51

In Camera view  55
Moving to Previous  63

Style Sheet  112
SVG

Importing  149
System Requirements  4

T

Technical Support  6, 190
Text

Adding  170
Thirds Grid  46
Timeline  31, 60

Minimized view  63

Viewing objects  61
Zooming In and Out  61

Toolbars  29
Toon Effect

Black Level  81
Edge Level  81
Gray Level  81
Lightness  82
Quantization  82
Saturation  82

Toon Effects  81
Toon settings  81
Transitions  88, 89

Choosing transition type  90
Setting duration  89

U

Undo  150
Updates

Obtaining  23
User stories  6

V

Vertical Wipe  90
Video Safe Zones  45
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Views
Resetting  60

W

Welcome Screen  21
Word Balloons

Adding  170
Creating  173

Workspace tools  29

Y

YouTube  33, 184

Z

Zooming with drag box  32
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