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Step-by-Step with Asssistants
This Quickstart covers five of the ten ‘Pro’ 3D Assistants. Since all of the tools operate 

in a similar way, going through these five mini-tutorials should give you a good 

understanding of how all of the 3D Assistants work. 

Turn on Advanced 3D render
Is the “Advanced 3D” error the only one you are running into? Hit Ctrl+K when in your 
project to bring up your composition settings.  When there, click on the Advanced tab 
and make sure that the Rendering Plug-In is set to “Advanced 3D.”  With this error you 
are running into, it is probably set to the wrong rendering plug-in.

Use a square pixel comp
In non-square pixel comps, 3D layers donʼt line up correctly due to the adjustment for 
the aspect ratio. In ALL the example below, use a square pixel composition. You can then 
drop the square pixel comp into a non-square pixel comp and the edges of your cube, 
cylinder, or whatever will remain aligned.

Activate the Assistants
The 3D Assistants are keyframing tools, not plugins. Therefore, you will find them listed 
in After Effectʼs ʻWindowʼ menu, not under the ʻEffectsʼ menu. The first time you use an 
Assistant, the tool may appear to be ʻgrayed outʼ, or not selectable in the Window menu. 
To activate the 3D Assistants, you will need to do these simple steps.

(1) Select the layers in your Timeline. 
(2) Turn on the 3D switch for those layers. 
(3) Go to your Window menu to select the 3D Assistant.
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Matrix Creator Quickstart
This tutorial explains how to create a 4 x 4 video wall using the 

Matrix Creator Assistant. For this project, you will want to open 

the Matrix_Creator_QS.aep.

step 01 
Create four 320x240 solid layers with different colors Select the ʻ3Dʼ 
switch for each of them in the Timeline. [ figure 1 ]

step 02
Create a new Camera (Layer>New>Camera). From the Tool Palette, 
select the Orbit Camera tool. Orbit around the layers so you get a  
3/4 view.

step 03
Press ʻCʼ to get the Track Z Tool, this allows you to zoom the camera 
out. Zoom the camera out a bit. [ figure 2 ]

step 04
This is where the ʻstartʼ Comp in the ʻMatrix_Creator_QS.aepʼ project 
is at.

step 05
By adjusting the camera like this, weʼll be able to see the whole 
video wall. Now select all 4 solid layers.

step 06
Open the Matrix Creator (Window>Matrix Creator) (Open the ʻEndʼ 
Comp to see where weʼre going with this) 

step 07
In the Dimensions parameter enter in 4 x 4. This will create a video 
wall thatʼs 4 layers wide, by 4 layers  high. Which creates a grid with 
16 spaces in it. You can make this any size you want, say 10 x 2 
would create a really long, but short, wall. 10 layers wide by 2 layers 
high. 

[ figure 1 ]

[ figure 2 ]
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However, you have to have enough layers to fill all the spaces. 
Right now we have a 4 x 4 grid with 16 spaces and only 4 layers. 
With only 4 layers, only the top row of the grid will get filled. So... 

step 08
At the bottom of the UI, turn on Repeat Layers. Set it to 3. When 
we apply the assistant this will repeat the 4 layers we have now 3 
times, giving us a total of 16 layers (3 x 4 = 12 + the original 4 
layers). The 16 layers will fill up the 16 spaces in the 4 x 4 grid. 

step 09
Set Size Of Grid Space to ʻLargest Layerʼ. This will look at the 
dimensions of all your layers and see which is largest. Since all of 
our layers are 320x240, the largest layer is 320x240. Every space 
in our 4 x 4 grid will then be 320x240. 

Some things to try to help get your head around this: set the grid 
space to say 200x200, the 320x240 layers will overlap, since each 
space in the grid would be too small. 

This might be a little hard to see with solid layers, though, so you 
might want to try it with images. Set the grid space to 640x480, 
and notice that the grid spaces are now bigger than the 320x240 
layers and there is space between them. 

Youʼll need to click Apply for any of these changes to take effect. 
Remember to turn OFF Repeat Layers after youʼve got the number 
of layers you want.) [ figure 3 ]

step 10
Click Apply. That should give you the video wall. If you want the 
layers to blink, follow the next steps. [ figure 4 ]

step 11
To make the layers blinmk, first select all 16 layers. Turn OFF 
Repeat Layers since we have as many as we need.

step 12
Turn on ʻRandom Layer Selectionʼ. This will randomly place layers 
throughout the grid. Usually theyʼre placed in an orderly fashioned, 
the first layer gets placed, then the second one, then the third 

[ figure 3 ]

[ figure 4 ]
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one, and so on. With this selected, the first layer is randomly stuck into the grid 
somewhere, as is the second one, and so on. 

step 13
In the Insert Keys section turn on ʻPositionʼ. 
This will insert a Position keyframe for all the 
layers. Click Apply and notice the layers get all 
jumbled. They also now have keyframes.

step 14
Move forward ten frames in the Timeline. Click Apply. Move forward another ten 
frames in the Timeline. Click Apply. Move forward ten more frames. Click Apply.

After every time you click ʻApplyʼ, the layers should change position.

step 15
With all the layers selected in the Timeline, hit the ʻUʼ key to show all keyframes. 
Select all the keyframes and turn them into Hold keyframes (Animation>Toggle 
Hold Keyframes). [ figure 5 ]

Now if you play the animation you should have layers jumping around, making it 
look like theyʼre blinking on and off.

[ figure 5 ]
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Cubic Distribution Quickstart
This tutorial will explain how to use the Cubic Distribution Assistant. For 

this project, you will want to open the Cubic_Distribution_QS.aep.

step 01 
Create five 3D layers that are 320x240.

step 02
If you open the ʻStartʼ comp in the ʻCubic_Distribution_QS.aepʼ project you will 
see this has already been done. Take a look at these briefly.

step 03 
Weʼve also moved the camera back a bit from itʼs default position. Youʼll need to 
get used to moving the camera around, so Iʼd recommend spending some time 
getting used to it, and maybe going through some tutorials or books on it (if 
youʼre not familiar with 3D cameras). Itʼs a bit beyond the scope of this tutorial.

step 04 
If you want to do this step by step, add a new camera (Layer>New>Camera), and 
zoom it back a little (using the Track Z Camera Tool).

step 05 
Select all five layers, and open up the Cubic Distribution assistant (Window>Cubic 
Distribution).

step 06 
The Cubic Distribution assistant will distribute layers throughout a 3D cube. You 
set the dimensions of this cube, tell it how to distribute the layers, and it takes 
care of the positioning.

step 07 
Since we want to fly through a number of layers more or less in a straight line, we 
only need to stretch the cube out over one axis. In this case weʼll stretch it over 
the Z axis, since thatʼs the axis the camera is facing anyways. Weʼll distribute the 
layers along this long cube and fly the camera right down the center of it.
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step 08
In the Dimensions section of the Cubic Distribution, set Z to be 10000, set X and 
Y to be 1500.

step 09
Even though weʼve moved the camera back a bit, itʼs still pretty much in the 
center of the scene. By default the ʻCubeʼ that everything gets distributed in will 
be created around the center of 3D space. More or less where the camera is at. 
That means half of the cube will be behind the camera. 

To fix this, lets move the cube forward 4000 units. In the Starting Value area, set 
Z to 4000. The Starting Value defines the center of the ʻCubeʼ.

step 10
Layers can be distributed two ways. 1: You can define the distance or range 
of distances that will separate each layer or 2: You can just have the Assistant 
distribute the layers randomly throughout the cube. 

In this case, weʼre going to have the layers distributed randomly so select 
the Distribute Randomly checkbox in the Starting Value area. (For a good 
understanding of how #1 works and setting up distances, see the manual).

step 11

We have a pretty large cube to distribute our layers in. We probably want more 
than 5 layers to fill the space up. Luckily thereʼs a really easy way to 
distribute more layers.

step 12

In the Options section, turn on the ʻRepeat Layersʼ checkbox. Set 
the Repeat Layers value to 5.

This will repeat our layers 5 additional times, giving us 30 layers (5 
x 5 = 25 + the original 5). These will then be distributed randomly 
throughout the cube.  
[ figure 1 ]

step 13

BIG IMPORTANT STEP: Click Apply. Wa lah! Our layers are now distributed all over 
the place. If you open up the End Comp, this is where weʼre at. [ figure 2 ]

[ figure 1 ]
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step 14

Switch the camera mode to ʻTopʼ and set the comp 
window zoom to 3.1%. You can see how the layers 
have  
been distributed over the Z axis. [ figure 3 ]

step 15

Switch back to Camera 1 and set the window to 50 
or 100%.

step 16

Letʼs quickly animate the camera. Set a Position 
keyframe for  
the camera at Time 00:00. Also set a keyframe for 
the Cameraʼs  
Point of Interest.

step 17

Move the Time Marker to 03:00. 

step 18

Change the Position Z value to 8800, and change the Point  
of Interest Z value to 8890. [ figure 4 ]

That will give you a nice fly through animation. Check out  
End+ Comp if you want to see it finished.

[ figure 3 ]

[ figure 2 ]

[ figure 4 ]
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Cylinder Distribution Quickstart
This tutorial will explain how to use the Cylinder Distribution Assistant. For 

this project, you will want to open the Cylinder_Distribution_QS.aep.

step 1

Create five 3D layers that are 320x240.

step 2

If you open the ʻStartʼ comp in the ʻCylinder_distribution.aepʼ project you will see 
this has already been done. Take a look at these briefly.

Weʼve also moved the camera back a bit from its default position. 

step 3

If you want to do this step by step, add a new camera (Layer>New>Camera), 
rotate it around a bit so you get a 3⁄4 view, and zoom it back a little (using the 
Track Z Camera Tool).

step 4

Select all five layers, and open up the Cylinder Distribution assistant 
(Window>Cylinder Distribution)

step 5

The Cylinder Distribution assistant will create a virtual cylinder and distribute 
the layers throughout it. By default, this isnʼt much different from the Cubic 
Distribution assistant, however weʼll show you how it can be VERY different.

step 6

With the Cylinder Dist. Assistant you can arrange layers in a spiral. The layers will 
rotate around the center of the cylinder as they are placed. This is what separates 
this assistant from the Cubic Dist. Assistant.

step 7

Letʼs make the virtual cylinder more elongated by setting the Y portion of the 
cylinder to 3000. This should give us plenty of space to place the layers in.

The Starting Value section is fine, so weʼll skip that.
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step 8

The Distance section is where all the fun stuff happens in this assistant. The 
Angle parameter determines how much each layer is rotated from the last one. 

For example, if Angle is set to 15, the first layer is placed, then the next layer is 
turned 15 degrees in the clockwise direction around the center of the cylinder, 
then the next layer is turned another 15 degrees, and so on.

step 9

Set the Angle Min and Max to 15. This will ensure that each layer is rotated 15 
degrees. If the Min and Max vary then a value is chosen randomly between the 
two, and the layer is turned by that amount.

step 10

Distance From Center is fine, so weʼll leave that alone. This is just how far away 
from the center of the cylinder the layer will be placed.

step 11

Y Axis is also fine. This sets how much along the Y axis every subsequent layer 
is offset. If this is set to 50, then each layer is raised 50 pixels along the Y axis 
before it is placed. 

The first layer is placed, the second layer is raised 50 pixels then placed, the next 
is raised another 50 pixels and then placed, and so on.

step 12

Set the Y Axis Min and Max to 50. This will cause every layer to be raised 50 
pixels from the last layer placed. If the Min and Max vary, a value will be chosen 
randomly between the two and the layer will be placed that many pixels above the 
previous layer.

step 13

Under Layer Orientation, select Rotate XY. This will cause the layers to be oriented 
upright as they turn around the cylinder center, like slides in a slide projector. If 
you select Rotate XZ, the layers will lie  
flat as they are rotate, kind of like blades in a fan.
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[ figure 2 ]

[ figure 1 ]

step 14

The options under Layer Orientation are best experimented with to understand what 
they do. Run the assistant with one option, then undo, run it with another option, 
undo, run it with a further option, etc., etc. The manual has more information about 
each option.

step 15

In the Option section of the Assistant, select 
Random Layer Selection. This will mix the layers up 
a little bit so they donʼt appear in order. Without 
this, our layers would be selected as they are in the 
timeline… 1, 2, 3, 4, etc. 

With it selected, they are mixed up when placed. 
Youʼll see how this works in a second. [ figure 1 ]

step 16

Also select Repeat Layers and enter ʻ5ʼ into the 
value field. This will repeat our 5 layers five times, 
giving us a total of 30 layers (the original 5 + the 25 
repeated layers). 

We use this because 5 layers isnʼt going to give 
us much of a spiral. This provides an easy way of 
duplicating as many layers as you need. [ figure 2 ]

Thatʼs it! Click Apply and see what happens!

step 17

For further adventures, try undo-ing and trying different 
values. Try 5 in the Angle Min and Max. Try ʻRotate 
Outwardʼ under Layer Orientation. Try 20 in the Y Axis 
Min and Max. Thereʼs lots of different options, so give 
them all a try.
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Box Creator Quickstart
This tutorial will explain how to use the Box Creator Assistant. For this 

project, you will want to open the Box_Creator_QS.aep.

step 1

Create six 3D layers that are 320x240.

step 2

If you open the ʻStartʼ comp in the ʻBox_Creator_QS.aepʼ project you will see this 
has already been done. Take a look at these briefly.

Weʼve also moved the camera back a bit from its default position. 

step 3

If you want to do this step by step, add a new camera (Layer>New>Camera), and 
zoom it back a little (using the Track Z Camera Tool).

step 4

Select all six layers, and open up the Box Creator assistant (Window>Box Creator)

step 5

The Box Creator assistant will attempt to create a cube out of your selected 
layers. For a real cube each side has to be square and the same size and this is 
the case with the Box Creator. 

However, if they are not the same size, the BC will attempt to arrange them as 
close to a cube as possible, but there will be gaps between some layers if your 
layers are rectangular.

step 6

Itʼs very simple to use the Box Creator. Since we have 6 layers selected, we have 
enough faces for a cube.

step 7

The first thing to do is set the Dimensions of the box. Go to the Box Dimensions 
section and enter in 320 in each of the value boxes. Since all our layers are 
320x240 weʼre going to make the sides of the box that size.
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[ figure 1 ]

step 8

Leave ʻ1 Layer Per Sideʼ selected. For a box, we only want one layer 
on each side. In other arrangements we might want to have multiple 
layers on each side, say if we were making a tunnel. [ figure 1 ]

Thatʼs it! Click Apply and see the result!

step 9

Hmm… ok, maybe thatʼs not it. Youʼll notice the sides line up pretty 
well, but thereʼs a gap in the top, and the bottom is completely 
detached from everything. 

Remember our box is 320x320x320 and our layers are 320x240. So 
thereʼs a 80 (320-240) pixel gap between the bottom of the side layers and the 
bottom of the cube.

step 10

Before we fix that, letʼs play around a bit. Weʼre all a bunch of wild and crazy 
anarchists, so itʼs time to get wild. Set the Box Dimensions to 1000x1000x1000. 
Click Apply.

step 11

Good lord, the excitement is too much to stand! Our layers are now spread out 
over a larger box, so theyʼre even farther apart. This was just to point out how 
easy it is to make adjustments. 

If you donʼt like one group of settings, make some changes, click Apply, and see 
if you like those settings. Very easy to make changes.

step 12

So now the sides of the cube are 1000x1000. That has done anything but solve 
our problem of having seams between the layers. Letʼs fix this.

step 13

Next to ʻ1 Layer Per Sideʼ, youʼll see a ʻScale To Fitʼ checkbox. Guess what this 
does? Yep, it scales the layers to fit the side of the layers. Turn on the Scale To Fit 
checkbox. Click Apply.
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step 14

Wah La! Our layers are scaled to fit the 1000x1000x1000 box, 
resulting in a perfect, happy box. Woohoo! Of course, we had to 
scale them to get them there so there may be some pixelization, but 
such is the price of perfection. [ figure 2 ]

step 15

The ideal situation is to have square layers before you start creating 
the box. This will prevent you from having to scale them and 
introducing artifacts or distortions. Of course, if you donʼt care gaps 
then you donʼt have to worry about this. Otherwise, mind the gaps. [ 
figure 3 ] [ figure 2 ]

[ figure 3, next page ]
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Cylinder Creator Quickstart
This tutorial will explain how to use the Cylinder Creator Assistant. For 

this project, you will want to open the Cylinder_Creator_QS.aep.

step 1

Create six 3D layers that are 640x480.

step 2

If you open the ʻStartʼ comp in the ʻCylinder_Creator_QS.aepʼ project you will 
see this has already been done. Take a look at these briefly.

Weʼve also moved the camera back a bit from its default position. 

step 3

If you want to do this step by step, add a new camera (Layer>New>Camera), 
and zoom it back a little (using the Track Z Camera Tool).

step 4

Select all six layers, and open up the Cylinder Creator assistant 
(Window>Box Creator). 

step 5

The Cylinder Creator assistant will attempt to create a cylinder out of your 
selected layers. The radius of the cylinder can be set in a variety of ways and 
you can create the entire cylinder or just a portion of it.

step 6

The first thing to do is set the height of the cylinder. In the Bounding Box 
section, set the Y axis to 2000. This will give us a reasonably long cylinder.

step 7

Next, letʼs take a look at the Height Min/Max values. You can think of the 
cylinder as being a stack of rings. A ring is created with your layers. Once 
the ring is completed, the Assistant moves up a given amount and creates 
another ring. 

 I ran across an 
*oops* in the last 
of the QS tutorials, 
Cylinder Creator, 
starting on page 8 of 
the .pdf file.

The AE project file 
that goes with that 
tutorial has its two 
comps named in 
reverse. The start 
comp is actually the 
end comp and vice 
versa. The switch 
can be reasoned out, 
but you might want 
to change it and 
eliminate emails such 
as this one.
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[ figure 1 ]

[ figure 2 ]

Once that ring is completed, it moves up again, and creates yet another ring. This 
goes on until you run out of layers or you reach  
the height set in the Y axis of the Bounding Box section.

step 8

Since all our layers are 480 pixels high, we want the Cylinder 
Assistant to move up 480 pixels after it completes each ring.  
So set the Height Min/Max to 480. 

With them being the same value, the Assistant will always go up 
480 pixels. If the values differ, a random value between the two 
will be chosen.

step 9

The other parameter here, the Longitude value is fine the way it 
is. This determines where subsequent layers are placed as the 
Assistant moves around the ring. Itʼs set in degrees. So every 
45 degrees a new layer will be placed around the rings.

step 10

Weʼve got six layers in the Timeline. This poses a bit of a 
problem, since thatʼs not going to be enough to create a tall 
cylinder. The solution is to turn on Repeat Layers.

step 11

Weʼre not entirely sure how many layers weʼre going to need, 
so set Repeat Layers to 10. This will repeat our 6 layers 10 
times. The nice thing about this, is that it will only repeat the 
layers as long as we need them. 

We probably wonʼt need 60 layers, but itʼll keep repeating them 
until we run out of space. So if we only need 30 layers to make 
a  
cylinder thatʼs about 2000 pixels high, itʼll stop at 30 layers.

step 12

Click on the Repeat Sequentially checkbox. By default, duplicated layers are 
placed after the original layer. This will result in your Timeline looking like this: 1, 
1, 1, 2, 2, 2, 3, 3, 3, etc. 
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[ figure 3 ]

[ figure 4 ]

You may want it to look like this: 1, 2, 3, 1, 2, 3, 1, 2, 3, etc. That  
is what Repeat Sequentially will do for you. [ figure 1 ]

Thatʼs it… click Apply! 

step 13
Now this is fine, except all the layers are intersecting each other  
on the edges. You may want this, but if not, click on the ʻRadius  
Is Set Byʼ checkbox up by the Bounding Box section. Set the value to 
8. [ figure 2 ]

step 14
This sets the circumference of the cylinder to the circumference  
of the first eight layers in your timeline. 

It puts the first eight layers side by side to form a ring and 
that becomes the circumference. This provides an easy way of 
creating a seamless cylinder. [ figure 3 ]

step 15
Now this is fine, except all the layers are intersecting each other 
on the edges. You may want this, but if not, click on the ʻRadius 
Is Set Byʼ checkbox up by the Bounding Box section. Set the 
value to 8. [ figure 4 ]

step 16
What this does is sets the circumference of the cylinder to 
the circumference of the first eight layers in your timeline. It 
puts the first eight layers side by side to form a ring and that 
becomes the circumference. This provides an easy way of 
creating a seamless cylinder.

step 17
With Radius Set By set to 8, select all your layers and click Apply 
There ya have it! A perfect cylinder.


