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1. Introduction

1.1 Blacksmith3D Overview

Welcome to the world of Blacksmith3D! This program has its roots in ExtremeMorph3D way back in 
2001, and over the years has evolved into a powerful piece of software that allows you to morph and 
paint 3D objects.

Using the analogy of a blacksmith, this software allows you to “heat up” objects and deform them, just 
as a blacksmith would heat up metal and pound it into a new shape. In conjunction with the 
deformation abilities, Blacksmith3D incorporates internal “morph” management, using sliders to 
control the transition from one shape to another using the same geometry.

In addition, Blacksmith3D has powerful 3D painting capabilities, allowing you to paint directly on your 
3D surface with a paint brush. You can also use textured brushes to create stunning detail quickly and 
easily.

Blacksmith3D even comes packaged with a series of primitive shape objects that can be imported and 
morphed into simple models from scratch, as well as a default human figure with a number of preset 
morphs including a beastie, demon, eagle, wolf, and many others!.

1.2 About the Manual

This manual is both a quick-start guide, and a reference manual. It contains information on all of the 
tools, options, and settings in Blacksmith3D, and how they work together. The first few sections of this 
manual contain basic information on the workflow of Blacksmith3D, how to get started, what the most 
common options are, and so forth. This area covers beginner, intermediate, and advanced material. The 
rest of the manual is a reference for every tool and option available in Blacksmith3D and what they do.

Using this manual to learn about the inner workings of the software, you'll be on your way to forging 
new graphics in no time with Blacksmith3D.

1.3 Terms and Concepts

The following are some common terms and concepts used with Blacksmith3D that you should 
familiarize yourself with:

Project - your Blacksmith3D work file (read only by this software)
Selection - an area of an object that has been marked for editing
Heat Up (Hot) - creating a stronger selection; a strong selection
Cool Down (Cool) - creating a weaker or no selection; weak/no selection
Deform - modify the surface shape of an object from its original shape
Paint - interactively add a color or texture to an object
Morph - modify the surface shape of an object for the purpose of creating a morph target
Morph Target - new object with the same vertex count of another object, but a different shape



Material - an area of an object separated for painting/mapping purposes
Channel - a mapping style of a material (there are 4 material channels in Blacksmith3D)
Map - an image containing colors/textures, applied to a material channel on the object
Viewport - the 3D display in Blacksmith3D
Stroke - generic term for interactive selecting or painting

2. Getting Started
This section will give you a broad overview of what Blacksmith3D is all about, and the basic workflow 
for creating projects.

2.1 Moving Around

Blacksmith3D uses a conventional 3D space for working in, called a viewport. The viewport can be 
used to look at your object from any angle, using the control buttons along the top. More information 
on this can be found in section 5.1.

Viewport Control Buttons

2.2 Selecting

Making selections is a big part of the Blacksmith3D workflow. It works in conjunction with both the 
deforming and painting aspects of the software, so getting to know the ins and outs of selecting is 
essential. Basically, you start by choosing a selection tool (6.1) from the toolbar that will work best for 
your purposes. The most common selection tool is the Round tool, which gives a round-shaped stroke.

Choosing the Round tool from the Selection Tools Menu



The next step is to adjust the tool options to meet your needs for the selection (6.4.1). The most 
common tool options are the size, strength and hardness of the stroke.

Adjust the tool options

Finally, you would actually “paint” a selection on your object. This selection will mark where any 
actions you make on the object will take place.

Heating up part of the head

The yellow area is the “hot” part of the selection and will be affected more than the red area, which is 
the “cool” part. Anything else is called “cold” and is deselected.

The next step is to “soften” the selection, so that it's a smoother transition from yellow to red. You can 
do this by choosing Soften Selection from the Edit menu, or hitting the “S” key on your keyboard.



Softening the selection

You will find yourself going through this workflow in Blacksmith3D probably more often than 
anything else, as it is a main function. Now that you've made a selection, its time to do something to it.

2.3 Deforming

Deforming is the act of modifying the shape of the object so that it looks different from the original. 
Deforming does not alter the vertex count or add geometry, rather it takes the existing geometry and 
moves it around.

To start deforming, choose a deformation tool (6.2) from the toolbar. The most common deformation 
tool is the Move In Plane tool, which will allow you to move the selection in relation to the viewing 
plane.

Choosing the Move In Plane deformation tool

Move to an appropriate viewing angle, then simply click on the selection and drag the cursor to start 
deforming.



Deforming the head from the side

After you're done deforming, you can clear your selection by clicking Edit>Clear All, or pressing 
Ctrl+U on the keyboard.

Cleared selection after deforming

This completes the basic workflow for selecting and deforming. Next, we'll look at Blacksmith3D's 
third feature, which is Painting.

2.4 Painting

Painting colors and textures on 3D objects in Blacksmith3D is a very simple process, and you can 
create great results quickly. You can paint with both solid colors and image files, right on the surface of 
the object.

To start painting, choose a paint brush (6.3) from the toolbar. The most common brush is the Round 
brush, which gives a round-shaped stroke.

Technical Note: You may find that software performance will improve if you make the Blacksmith3D window bigger 
when painting, especially if you are using a high resolution texture size.



Choosing the Round Brush from the Paint Brushes menu

It is at this point that Blacksmith3D will check to see if any color maps have been assigned to the 
object. A color map is what holds the color and texture information of the object, and is what you will 
paint on. If the object has no color map, Blacksmith3D will prompt you to create one. This map will be 
assigned to all of the materials (9.4).

The next step is to adjust the options for your brush stroke, such as the size, strength, hardness, and of 
course the color (6.4.5). Two colors can be set at once (left-click will paint with the primary color, and 
right-click will paint with the secondary color).

Adjust the paint brush options

Now you can start painting colors directly on your object.



Painting on the object

In addition to painting solid colors, you can also paint with image files. To load in a image file, click 
the "Textures" button in the tool options, and click Load. Then navigate to the image file to load it in 
(you can also drag the image file directly on top of the tool options).

Loaded file texture

Make sure to set your primary color back to white when painting with an image, if you want to use the 
image as it looks in the file (otherwise, you can use the primary or secondary color to tint the texture).

Now you can paint the texture directly onto the object. You will find that “stamping” the brush (ie. 
Clicking once to make a single brush stroke) will give you a better look than simply streaking the brush 
across the object.



Painting with an image file

This completes the basic workflow for painting in Blacksmith3D. Now that you have a base 
understanding of the main functions available to you and how they are used together, feel free to 
experiment and see how the rest of the tools work, or continue on to learn about some intermediate 
practices in Blacksmith3D.

3. Intermediate Practices
This section will go into a bit more detail on selecting, morphing and painting, covering the most 
common options that you will find yourself using.

3.1 Making Better Selections

Here are the most common options for the selection tools that you will find yourself using more often 
than not. These options are located on the Tool Options panel, and appear as check boxes to turn either 
on or off.

3.1.1 Selecting Hidden Geometry

In the previous section, you learned how to use the selection tool to paint a selection on an object. 
However, often you may find that you want to select “through” the object so that you can affect 
geometry on the back of the item, or on steeper angles or tighter creases that are not immediately 
visible.

Blacksmith3D features an Affect Hidden Geometry option that will open up a “rear view mirror” 
window to give you a view of the back of your object. With this option selected, you can select straight 
through the object to any hidden geometry. For example, if you wanted to create a selection on the nose 
of a character, grabbing all of the internal nose geometry and both sides evenly, you might paint your 
selection from a side view, with Affect Hidden Geometry turned on.



Painting a selection on the nose, using Affect Hidden Geometry

Make sure you turn off Affect Hidden Geometry if you don't wish to select through the object for your 
next selection.

3.1.2 Mirroring & Symmetry

These options allow you to automatically duplicate your selection across to the other side of the object. 
However, it is important to know the difference between mirroring and symmetry.

Mirroring is relative to the viewport angle. This means that using Mirror Horizontally or Mirror 
Vertically will place a line that runs along that axis through the middle of the viewport, no matter what 
angle the viewport is set at. You can paint on either side of the line, and it will be mirrored across.

Using the Mirror Horizontally option. Note how the mirror line always remains in the center, despite the viewing angle



Selecting symmetrically is different in that it is relative to the object itself, rather than the viewport. So 
making a selection anywhere on the right side of the object, for example, will be duplicated in that 
EXACT same position on the left side.

Using the Select Symmetrically option. Note how the selection has been duplicated in the exact same place on the other 
side.

If you find that you didn't Select Symmetrically when you should have, you can make use of the Right 
to Left and Left to Right buttons, which will copy any selections on the one side and duplicate them on 
the other.

Using the Right to Left button to duplicate any right side selections to the left side.

That covers the common options for selecting. There are more options available to you, not to mention 
a host of different tools to select with. You can learn more about these in the General Tools section of 
this manual (6.0).



3.2 Controlling Deformations

These are the more common deformation options that you will find yourself using often.

3.2.1 Limiting to an Axis

When using certain deformation tools like the Move In Plane tool, and the Push/Pinch 2D scale tool, 
you might sometimes find it useful to limit the deformation horizontally or vertically. For this, we use 
the Horizontal and Vertical options.

Using the Move In Plane tool with the Horizontal and Vertical check boxes. First is with both checked, second is with just 
Vertical, and the third is just Horizontal.

3.2.2 Deforming Symmetrically

The ability to deform symmetrically across an object is very useful if you want to deform a certain area 
that is common to both sides (for example, the ears of a character) and have them identical.

By using the Deform Symmetrically option any deformations you make on the right side of the object 
will automatically be duplicated on the left side (you can also turn on Left to Right Symmetry to make 
it go the other way).

With Deform Symmetrically turned on, the left ear deforms like the right one. No selection is required on the left ear.



There are also "Right to Left" and "Left to Right" buttons for deformations, to copy the deformations 
on one side of the object to the other (same as for selections). However, there is an additional option for 
deformations that swaps the left and right side deformations with each other. Simply click the "Swap 
Left and Right" button to copy every deformation from the left to the right, and vice versa, effectively 
“flipping” your deformations.

Using the Swap Left and Right button to swap the deformations on either side

3.3 Texturing Tricks

These are the more common painting options that you may find yourself incorporating into your 
workflow. Note that the paint tools also use the Affect Hidden Geometry option as the selection tools, 
as well as the same Mirror and Symmetry options.

3.3.1 Painting Quickly

The Paint Quickly option exists in order for you to quickly saturate the object with color. With this 
checked, you can quickly scribble a color or texture over the object, then watch it “snap” onto the 
shape.

Using Paint Quickly to paint a texture.



While Paint Quickly does allow you to do a fast paint job, you may notice that it doesn't give you the 
fine details of the texture. It's excellent for painting solid colors, but in terms of textures, it's best to 
saturate the object with the texture first, then turn Paint Quickly off to give it the fine details.

You will find that with Paint Quickly off, painting a texture will be a bit slower, because now it is 
snapping onto the shape interactively as you paint. You may also find that to get the best result with a 
texture, “stamping” the texture onto the object looks much neater (as a quick stroke might blur some 
elements of the texture).

Stamping the brush with Paint Quickly turned off to create the detailed texture.

3.3.2 Fade By Angle

If you paint from the front view, you will notice that on the side of your object, the texture is all 
stretched looking. This is because the geometry there was very steep in relation to the viewing angle at 
which the object was painted.



Texture stretching along the side of the head, resulting from the steep painting angle from the front.

To account for this, Blacksmith3D includes a Fade By Angle option. Checking this option will cause 
the stroke to grow weaker as the angle between the surface and the viewing plane becomes greater. 
This means that the painting will be limited to the viewing plane and will not stretch across the sides.

A good painting practice is to paint from the front view with Affect Hidden Geometry turned on, and 
Fade By Angle turned off. Then you can move to a side view and turn Fade By Angle on, to paint over 
the stretched area without affecting the already nice painting of the front. Do the same from the top 
view, and any other angle that needs it.

Using the Fade By Angle option to touch up stretched areas, while leaving nice areas untouched.



4. Advanced Practices
This section will go into some more advanced functions of Blacksmith3D. These features are very 
useful for managing your project, and keeping organized.

4.1 Managing Selections

In Blacksmith3D you have the ability to save any selection you make in the Selection Manager 
window, so that you can grab the same area again quickly without having to paint a new selection. This 
is great if you want to create preset selections for the different elements of, for example, the face of a 
character (nose, ears, eyes, etc.).

Controlling selections is done through the Selection Manager on the toolbar.

The Selection Manager

The first thing you will notice is that there is a default selection listed here. This selection currently 
holds the information of any selections made in the viewport.

The highlighted selection in the listing is where any selections you make will be stored. To create a 
new empty selection to work with, right click in the listing and choose Create New Selection.

Creating a new selection.



Now, with this new selection highlighted, you can select something in the viewport which will become 
a part of this new preset. You can see the results by switching between New Selection and Default 
Selection (which is currently empty).

Painting a selection on the nose with New Selection chosen

For even greater organization, right click New Selection and rename it to something fitting to it's 
contents.

Remember to keep track of which selection you are currently editing. To ensure you don't accidentally 
change one of your presets in an undesirable way,  choose the preset and check Read Only at the top of 
the window (this will “lock” the selection so it cannot be edited until you uncheck Read Only).

For all your quick selections that you don't wish to save, it is best to work in the Default Selection.

For more information on the Selection Manager, see section 9.2.

4.2 Managing Morphs

The Morph Manager is a powerful control window that allows you to create and modify morph targets 
for your object. Essentially, a morph target is an object with identical vertex count and order as your 
starting object, but with a different shape. Blacksmith3D starts to work behind the scenes with the 
morph manager from your very first deformation on your object.

The Morph Manager



You will notice that there is a Default Morph already listed here. If you do not create any of your own 
morphs, this morph will contain all of the deformations that you make to your object. It is by default set 
to a strength of 1, which is the same as saying it is 100% deformed. Any deformations made with this 
morph selected and set to 1 will become the 100% setting for the morph. The reason the slider goes 
higher is in case you want to set your morph to more than 100% (though this can give you some strange 
effects!).

If you adjust the slider back to 0 strength, you will see the transition back to your original shape.

The nose has been selected and deformed, which is now the appearance the object will have at a morph strength of 1 (100%)

The Default Morph strength set to 0.5 to show only half of the deformation.

The Default Morph strength set to 0 to show the original shape.



You can create your own separate morphs to contain separate deformations and mix them together 
using the Mix Morphs check box, creating different shapes for your object. To create a new morph, 
simply right click on the listing and choose Create New Morph. Use this as your selected morph 
(strength of 1) to contain your new deformations.

For more information on the Morph Manager, see pg. 9.3.

4.3 Controlling Multiple Objects

Eventually you might find yourself with the need to import more than one object into your 
Blacksmith3D project. In this case, you will be using the Object Manager to control which object you 
are currently editing.

The Object Manager. Two objects are currently in the project, a sphere and a cone.

The currently highlighted object in the Object Manager will be the one affected by your work in 
Blacksmith3D, be it selections, deformations or painting. All other objects will be unaffected. In 
addition, any saved selections or morphs made on an object will only show up in their respective 
windows if you have that object highlighted in the Object Manager.

For more information on the Object Manager, see section 9.1. For information on merging multiple 
objects into a single object, see section 7.3.

4.4 Using Reference Images

Blacksmith3D includes the very useful feature of being able to import a reference image to use as a 
guide for deformations, or to grab colors and textures off of.

To bring a reference image into Blacksmith3D, simply drag the appropriate image file from your drive 
into the viewport. This will create a new object that can be moved around and deformed like any other 
object.



Reference image imported into the viewport. Note that it has appeared as an object in the Object Manager.

Bring in several reference images from different angles to set up a useful deformation environment 
where you can use the images as a guide to match to. Use the deformation tools on the images 
themselves to adjust their position, size and angle.

Use several images of different angles to help guide your deformations



Set your images up in a manner that allows you to effectively use them as guides.

In addition, you can use imported reference images as sources of colors and textures to paint with. Use 
the Grab Color and Grab Texture tools to start painting on the object.

  
The Grab Color and Grab Texture tools

Use the Grab Texture tool to put the selected area on your paint brush



Paint the texture on the object

5. Interface Items
This section covers the main interface panels, buttons and menus that are found in Blacksmith3D.

5.1 The Viewport

The viewport is fully interactive, and you can move, zoom, rotate and tilt the view to see your work 
from all sides. These viewing options are controlled by clicking on the movement button on the top 
toolbar, and dragging the mouse.

Move Viewing Position
Move the view horizontally (drag left/right) and vertically (drag up/down)

Zoom
Zoom the view in (drag up) and out (drag down)

Rotate
Rotate the view around the horizontal (drag left/right) and vertical (drag up/down) axes. Hold Shift to limit the rotate to the 
horizontal axis. Hold Alt to limit it to the vertical axis.



Tilt
Tilt the view clockwise (drag right) and counter-clockwise (drag left) in the current viewing plane

Reset
Return the viewport to its default position

There are also view presets available for moving quickly to common views. You can use shortcut keys 
on the keyboard to quickly move to these presets.

Front (F)

Back (K)

Left (L)

Right (K)

Top (T)

Bottom (B)



5.1.1 Viewport Display

There are a number of ways to display the objects in the viewport to aid in editing them. You can set 
the display to one of the following, using the Viewport Display menu.

Textured

Toggles any textures assigned to the objects.

Smooth

Toggles object smoothing.

Stippled

Toggles stippled view.



Wireframe

Toggles the base wireframe of the object.

Wireframe Overlay

Toggles the wireframe overlay on top of the object's surface.

Points

Toggles the vertices.

Texture Filtering

Toggles the texture filtering. Turning off this feature lets you see individual pixels while leaving it on 
yields a smoother surface.



5.1.2 Rendering the Viewport

This option does a quick render of the objects in the viewport, allowing you to see the result of the 
applied transparency, bump and displacement maps.

Please note that this is not a high quality renderer. Some polygon artifacts may appear where 
transparency-mapped polygons overlap (this can be minimized with a higher value of depth precision) 
and bump mapping is only approximate.

Depth Precision Slider

Controls the amount of “slices” rendered when rendering a transparency map. The higher the number, 
the more precise the render (but the longer the render).

Global Displacement Strength Slider

Increases/decreases the strength of all displacement maps. Helps to compensate for different 
displacement settings in other software packages.

Global Bump Strength Slider

Increases/decreases the strength of all bump maps. Helps to compensate for different bump export 
settings in other software packages.

Mix Material Colors with Color Maps

Tints the color of the material into the color map. Mainly here to provide compatibility with other 3D 
programs that provide the same feature.

Use Color Maps

Apply the color maps to the render.

Use Bump Maps

Apply the bump maps to the render.

Use Transparency Maps

Apply the transparency maps to the render.

Use Displacement Maps

Apply the displacement maps to the render.



5.1.3 Viewport Options

The little gear button opens up the Viewport Options menu, where there are several display options.

Use Lighting

Toggles the lights/shading.

Draw Highlights

Toggles the highlights.

Show Background

Toggles the Blacksmith3D background.

Background Color Button

Sets the background color of the viewport (only visible if Show Background is turned off)

5.1.4 Multiple Viewports

You can have four viewports open at once, to keep an eye on all the angles at the same time. To choose 
different viewport settings, use the Viewport button on the toolbar, and select a configuration. You can 
have one, two (wide or tall), three, or four viewports. Each viewport can be set to the view you desire 
(front, left, top, user, etc.).

To toggle quickly between one viewport and four viewports, hit the spacebar. To head back to one big 
viewport, select the viewport that you want to enlarge, and hit the spacebar again. You can also create a 
“floating” viewport by clicking Window>Create New Viewport.

5.2 Message Window

The message window is the grey window on the left-hand side at the bottom of the viewport. Here you 
will see messages about program tasks are taking place.



5.3 Hint Window

This is the small grey window on the right-hand side at the bottom of the viewport. This window will 
provide hint messages when you put your cursor over a tool or setting, to give you some information on 
it.

5.4 The Menus

A number of options and operations are rolled up in the menus across the top of the interface, so it's a 
good idea to become familiar with what is there.

5.4.1 File Menu

This menu contains a number of project related operations. A “project” refers to your Blacksmith3D 
file, with morphs and selections, etc.

New Project

Clears the current project and creates a new, empty project.

Load Project

Clears the current project and opens a previously saved project.

Save Project

Saves the current project to a file. All objects, maps, and selections will be saved directly into the 
project file. Note that these project files can only be opened by Blacksmith3D.

Save Project As...

Saves the current project to a new file.

Import...

Imports an object for editing. Available import formats are .OBJ and .CR2 (see chapter 10 for more)

Export...

Exports the current object. Available export formats are .OBJ and .CR2. (see chapter 10 for more)

Import Morph...

Imports an object as a morph target for the current object. Note that the imported object must be 
identical in vertex count and order, or the morph will not work. (see chapter 10 for more)



General Options

Opens the General Options window, which contains various software settings.

Exit

Closes the program. If an object is currently loaded, you will be asked to confirm the exit.

5.4.2 Edit Menu

This menu contains many useful commands for editing your project. The contents of this menu will 
change depending on what you're currently doing in the project.

Undo (Ctrl+Z)

You can undo previous selections, deformations, and paint brush strokes with this option. Multiple 
undos are available and limited by the “Undo Limit” in the General Options window.

Select All (Ctrl+A)

Selects the entire surface of the current object.

Clear All (Ctrl+U)

Clears all selections on current object.

Invert Selection

Inverts the current selection on the object.

Soften Selection (S key)

Softens all selections to ensure an even transition from hot (fully selected) to cold (non-selected) areas. 
This option is extremely useful for right after creating a selection, before deforming to create a nice 
smooth deformation. Make use of the S key shortcut often!

Harden Selection (H key)

Causes all selections to harden to fully selected (no transition between hot and cold areas).

Normalize Selection

This will take the strongest area of your selection and make it the absolute strongest possible (pure 
yellow) and adjust the rest of the selection accordingly. Good for strengthening up weak selections.



Fix Texture Seams

This option is only seen when using the Paint Brush tools. Some objects are UV mapped in such a way 
that there may be seams  in the textures, which may appear on the object as you paint. Use this option 
to fill in those seams so they are undetectable (in most cases).

5.4.3 Window Menu

This menu allows you to bring up various control windows in Blacksmith3D.

Create New Viewport

Creates a new “floating” viewport, which can be adjusted to any view you desire.

Object Manager

Brings up the Object Manager, which allows you to control the various objects in your project. This is 
explained in detail on page [#].

Selection Manager

Opens the Selection Manager, which allows you to create, save, and otherwise organize selections on 
your objects. This is explained in detail on page [#].

Morph Manager

Opens the Morph Manager, where you control the various morphs embedded in the project. This is 
explained in detail on page [#].

Material Editor

Brings up the Material Editor, which is used to manage the various materials assigned to the object. 
This is explained in detail on page [#].

5.4.4 Help Menu

This menu contains a few help options if you're having trouble with Blacksmith3D, or just want to 
learn more.

On-line Help

Launches your browser and connects to Blacksmith3D's on-line help pages.



Tutorials

Launches your browser and connects to Blacksmith3D's on-line tutorial pages, where you can find 
step-by-step instructions for many procedures.

Submit OpenGL Info to Blacksmith3D Quality Control

This option creates a file on your Desktop with your video card information, which can be sent to 
Blacksmith3D if you are having any technical problems. Be sure to post about your problem on the 
forums first, as there might be a quick solution. If not, you may be requested to use this option so we 
can better help.

About...

Opens an informative window to let you know all kinds of stuff about Blacksmith3D!

5.5 The Toolbar

The buttons in the lefthand toolbar contain the various tools and options that you'll be using to select, 
deform, and paint the objects in your project file, as well as open up the common control windows.

Blacksmith3D Link

Launches your browser and connects to the Blacksmith3D home page, where you can check for 
updates, information, and free stuff

Viewport Manager

Opens a side-menu with the various viewport configurations.



Object Manager

Brings up the Object Manager, which allows you to control the various objects in your project. This is 
explained in detail in section 9.1.

Selection Manager

Opens the Selection Manager, which allows you to create, save, and otherwise organize selections on 
your objects. This is explained in detail in section 9.2.

Morph Manager

Opens the Morph Manager, where you control the various morphs embedded in the project. This is 
explained in detail in section 9.3.

Selection Tools

Opens a side-menu displaying the various tools for creating selections on your object in different ways, 
and by different methods. These tools are explained in detail in section 6.1.

Deformation Tools

Opens a side-menu displaying the various tools for deforming your object in different ways. These 
tools are explained in detail in section 6.2.



Paint Brushes

Opens a side-menu displaying the various brushes for painting objects in your project. These brushes 
are explained in detail in section 6.3.

More Tools

Opens a side-menu displaying several other tools that don't fit into the above categories. These tools are 
explained in detail in section 7.0.

Maps

This button is only visible when in Paint mode. It opens a side-menu containing the various maps 
which can be painted on. These maps are explained in detail in section 8.0.

Grab Color

This button is only visible when in Paint mode. It functions like the Eyedropper tool in other programs. 
After clicking the button, click on a color on a surface in the viewport to load that color into your paint 
brush (right-click to load the secondary color).



Grab Texture

This button is only visible when in Paint mode. Click the button and then drag a square over a textured 
surface in the viewport, to load that area of the texture into your paint brush.

Trash

Not technically a button, useful nonetheless! Drag items such as morphs, selections, groups and 
textures onto this icon to delete them from the project. This action is not undoable.

6. General Tools
Blacksmith3D has a number of tools for editing objects. Here you will learn about the general tools that 
are available for use, and what options exist for each (options are listed on page [#]).

6.1 Selection Tools

The selection tools are used to create selections on the objects in your project. These selections can 
then be deformed in various ways. The selection tools are highly interactive, allowing you to “paint” 
your selection directly on the surface of the object. Left-clicking will paint the selection, and right-
clicking will erase it.

Round

This is a simple round selection tool, the most commonly used. Interactively paint your selection 
directly on the surface of the object.



Texture

This tool allows you to load various selection shapes to select with. Click the Load Texture button in 
the Tool Options to load one of the preset shapes.

Soften

Use this tool to interactively soften your selection by painting directly on it.

Harden

Use this tool to interactively harden your selection by painting directly on it.



Random

Paints a random, uneven selection, perfect for bumpy deformations.

Select Element

When you click on the surface with this tool, all of the connected points on the surface will be selected 
as well. Good for easily selecting small separate parts.

Select Groups

Use this tool to select entire groups on the object. This can be done by clicking in the viewport, or by 
choosing the group in the listbox in the Tool Options and clicking the Select By Group button (you can 
also Deselect By Group in this manner).



Select Materials

This tool is similar to the Select Groups tool, only it selects the materials assigned to the object. This 
can be done by clicking in the viewport, or by choosing a material from the listbox in the Tool Options 
and clicking the Select By Material button (you can also Deselect By Material in this manner).

Select Artifacts

This tool will select any artifacts (imperfections) in the surface of your object that were created as a 
result of a morphing process. You can then use the Smooth tool to fix these areas.

Select Sharp Points

This tool will select points on the object based on their sharpness. The sharpest points will have hotter 
selections, while the duller points will have cooler selections.



Select Open Vertices

This allows you to select points that are on an open edge (such as the four edges of a flat plane). This is 
a useful tool if you want to select the open edges and lock them so that the remain unchanged while 
you deform the rest of the object.

6.2 Deformation Tools

The deformation tools are used to deform the selected portions of surfaces to create new shapes. The 
hardness of the selection will have a direct effect on how the deformations will look, as the hottest 
portions will deform more than the cooler portions. A smooth selection is essential for a smooth 
deformation.

Move In Plane

This tool allows you to move the selected portion of the surface in the plane of the viewport. Simply 
click anywhere in the viewport and drag the mouse to move the selection.



Rotate

This tool allows you to rotate the selection. Please note that the center of the rotation is determined by 
the point you click on in the viewport, and the axis of rotation is determined by the viewing plane.

Push/Pinch (2D Scale)

This tool will perform a 2D scale in the plane of the viewport (X,Y). Please note that the point that you 
click on becomes the center of the scaling.

Expand/Shrink (3D Scale)

This tool will perform a 3D scale (X,Y,Z). Click and drag the mouse up to expand the selection, and 
drag down to shrink it. Please note that the point that you click on becomes the center of the scaling.



Bulge/Dent

This tool allows you to bulge or dent the selected surface. Click and drag the mouse up to bulge 
outwards, and down to dent inwards.

Smooth

With this tool, you can go over bumpy or uneven areas and make them smooth. Click and drag the 
mouse up to increase the smooth, and drag down to reduce it again.

Flatten

This tool will flatten the selection in relation to the general surface direction (normals) of the area.



Unmorph

This tool will unmorph the selected surface, returning it to the original shape. Please note that this will 
only unmorph the current morph target.

6.3 Paint Brushes

The various paint brushes allow you to interactively paint directly on the surface in the viewport with 
colors and textures.

Round Brush

This brush is round in shape. It will match the height/width ratio of any loaded textures.

Square Brush

This brush is square in shape. It will match the height/width ratio of any loaded textures.



Blur

This brush is used to paint blurry areas on the map. Great for blurring across texture seams.

Smudge

This brush is used to “push” a bit of the color/texture in the direction you drag the mouse.

Line

Click and drag to draw a straight line.

Rectangle

Click and drag to draw a rectangle.



Ellipse

Click and drag to draw an ellipse.

6.4 Tool Options

These are the various options found in the Tool Options on the right-hand side of the interface. May of 
these are shared across the various tools. Adjusting these options will give different results in how the 
tools will look and operate.

6.4.1 General Options

Size Slider
Select, Paint

Determines the size of the tool in the current viewport.

Strength Slider
Select, Paint

Determines how strong each stroke will be.



Hardness Slider
Select, Paint

Determines how hard or soft the edges of the tool will be.

6.4.2 Advanced Options

Affect Hidden Geometry
Select, Paint

If this option is checked, portions of the surface that are not visible (ie. backfaces and obscured 
surfaces) will still be affected by the tool. This can be seen through the “rear view mirror” that will be 
displayed.

Display Quickly
Select, Deform

When this option is checked, only the portions of the surface that are being changed will be 
redisplayed. Some artifacts may appear around the edges of the selection while you are using a tool 
with this option checked. When this option is unchecked, the object appears exactly as it should as you 
select the object.



Fade By Angle
Select, Paint

Checking this option will cause the stroke to grow weaker as the angle between the surface and the 
viewing plane becomes greater. This can help prevent “stretching” in texture painting, which is caused 
by painting a texture from an angle that is not straight on.

Mirror Horizontally
Select, Paint

Checking this option will duplicate the stroke horizontally across the object. You can paint on either 
the left or right side. Note that this mirror is relative to the viewport angle.

Mirror Vertically
Select, Paint

Checking this option will duplicate the stroke vertically on the object. You can paint on either the top 
or bottom. Note that this mirror is relative to the viewport angle.



Extra Soft
Select

This option will make each selection extra soft, blending the new selection with the surrounding 
surface. You may wish to disable it if you want a rigid selection for precise editing.

6.4.3 Symmetry Options

Select Symmetrically, Deform Symmetrically, Paint Symmetrically

Any selections/deformations/painting you do when this option is checked will be duplicated across the 
axis of symmetry (which can be changed using the Symmetry Axis button). Note that this option is 
different from the Mirror options, in that it is object relative rather than viewport angle relative.

Left to Right Symmetry
Select, Deform, Paint

By default, the symmetry of the object goes from the right side to the left side. When this option is 
checked it will be reversed, from left to right.

Right to Left Button
Select, Deform

This button copies any selections or deformations on the right side of the object to the left side.



Left to Right Button
Select, Deform

The opposite of the Right to Left button, this button copies any selections or deformations on the left 
side of the object to the right side.

Symmetry Axis Button
Select, Deform, Paint

This button allows you to set which axis will serve as the symmetry axis (X, Y, or Z). In most cases, 
the symmetry axis will be X.

Swap Left and Right Button
Deform

This button will cause the deformations on the right and left of the surface to swap with one another, 
resulting in a "mirror image" of the original morph.

6.4.4 Extra Deformation Options

Horizontal

If checked, the surface will deform horizontally. If unchecked, it will not.

Vertical

If checked, the surface will deform vertically. If unchecked, it will not.

Prevent Spreading
(Smooth)

The option helps to prevent the vertices from spreading when you smooth the surface.

Prevent Shrinking
(Smooth)

The option helps to prevent the vertices from shrinking when you smooth the surface.



Multiplier Slider
(Smooth)

Sets how strong the smooth will be.

6.4.5 Extra Paint Options

Primary Color Button

This sets the color of the resulting brush stroke when the left mouse button is clicked. If you have a 
brush texture loaded, this color will "tint" the texture (make this white to use the texture as is).

Secondary Color Button

This sets the color of the resulting brush stroke when the right mouse button is clicked. If you have a 
brush texture loaded, this color will "tint" the texture.

Fill Color Button
(Rectangle, Ellipse)

This sets the color that will fill the drawn shape.



Outline Color Button
(Line, Rectangle, Ellipse)

This sets the color of the line drawn.

Textures Button

This button opens a side menu which allows you to either load a new texture (image file), or select 
between textures that you've already loaded.

Anti-Alias

When this option is checked, even your hard paint strokes will be smooth around the edges.

Paint Quickly

When this option is checked, paint brush strokes are much faster and are smoothly connected as you 
drag the mouse. The quality of the brush stroke is dependent on how large the brush and object appear 
in the viewport. If you zoom out of the viewport so the object appears very small and then you paint on 
it, the quality of the resulting texture will be poor. When this option is unchecked, the quality of the 
paint brush stroke is much better as it is not affected by the object viewport zoom or the brush size. It 
will provide the best possible texture for each brush stroke.

Paint On Selection Only

If you have a selection made on the object, checking this will cause your paint strokes to only affect the 
selected area. The non-paintable area will darken, indicating that you cannot paint on it. Uncheck this 
option to return to normal painting.



Fade to Secondary Color

This option will set your brush so that the secondary color will be used as a “border” for the main 
stroke, which is your primary color. This is useful for simulating depth by having the secondary color a 
darker version of the primary color. Note that the Hardness slider for the brush will determine the 
thickness of the secondary color.

Fix Texture Seams Automatically

This option will automatically fix any seams in the texture as you paint. If unchecked while painting, 
seams might be visible, in which case you can click Edit>Fix Texture Seams to get rid of them.

Flip Texture Horizontally

This option will flip the currently loaded texture horizontally.

Flip Texture Vertically

This option will flip the currently loaded texture vertically.

Randomly Shuffle Textures

When this option is enabled, the current brush texture will be changed randomly to another brush 
texture that has been loaded.

Tile Brush Texture

If the brush texture(s) that you have loaded are tileable (repeat smoothly when drawn in a grid), then 
you can enable this option so that when you paint, the resulting brush strokes will properly 'tile' the 
texture, rather than “stamping” the texture on the spot that you clicked. The Tile Size slider will 
determine how large or small the tiles will appear.



7. More Tools

Blacksmith3D has several other tools that are grouped together in the More Tools button on the toolbar. 
These are tools that are separate from the above general tools.

7.1 HeadForge

This feature allows you to automatically re-shape character heads to generate full head morphs with the 
click of a button. It uses a predefined HeadForge Selection Set, which can be imported/exported as a 
SelSet file. These files define various selections all over the head, which are then deformed by the 
HeadForge. There are a number of options here:

Symmetry

Adjust this slider to set the symmetry of the generated heads (or parts of the head). A setting of 1 is 
completely symmetrical. Settings lower than one result in more and more asymmetrical heads as you 
move towards 0 symmetry. Click the Update button to see any changes you make.

The first head was morphed with a symmetry value of 0, while the second has a symmetry value of 1.



Strength

This slider adjusts the strength of the deformations in the generated heads. A setting of 1 is the default 
setting, and will generate many different heads with reasonable deformations. Settings lower than one 
will result in less dramatic changes to the head. Settings more than 1 will result in more dramatic 
changes that can generate some very neat cartoon-like heads (though not all heads will deform nicely at 
extreme strength). Click the Update button to see any changes you make.

The first head was morphed with a strength value of 1, while the second was boosted past normal to a value of 2.

Touchup

This determines the relative strength of extra smooth operations to fix up any bad areas that might 
occur. Higher resolution meshes might require a higher touchup setting. In general, you need not worry 
about this slider if your heads are looking fine.

Update

Click this button to apply any changes made to the Symmetry, Strength and Touchup sliders.

Reset

This button will reset the head to it's original form, clearing any deformations made by the HeadForge.



Control Buttons

These buttons control the deformations of the various parts of the head. In addition to the Random 
Head button (which deforms the entire head at once) there are individual buttons which will randomly 
deform the area in question.

Use the control buttons to deform different parts of the face independently.

Load Selection Set

This will allow you to import a SelSet file for use on the character in question. This can also be done by 
clicking File>Import and choosing SelSet Files from the dropdown.

Create Empty Selections

If you are working with a character currently unsupported by the HeadForge (ie. there is no existing 
Selection Set that works with the character), this button will automatically create the appropriately 
named empty HeadForge selections in the Selection Manager. This is just the initial setup, as you will 
have to manually paint the selections before the HeadForge will work on your character. For more 
information on how to paint the correct selections, see below.



7.1.1 Setting Up HeadForge Selections

If there is no preset Selection Set for your character, then you will be required to set up the selections 
manually in order to use the HeadForge on it. The first step is to click the Create Empty Selections 
button in the HeadForge options to set up the selections that will be required. Then open up the 
Selection Manager.

The appropriately named selections appear in the selection manager under HeadForge

To paint the selections on the head, choose an empty selection from the selection manager and paint the 
appropriate area. Guidelines for where to paint for each selection are below. Note that none of these 
selections includes any part of the eyes except for Visibility (which just defines the whole head, but 
doesn't deform it). Also, only those marked “includes inner mouth” should have the internal mouth 
geometry selected as well (ie. inner mouth, teeth, tongue, gums, etc.).

noseTip



noseBump

noseWhole

noseNostrils



jawWhole (includes inner mouth)

jawChin

mouthWhole (includes inner mouth)



mouthLips

browWhole

cheekBones



cheekSkin

earsWhole

earLobes



skullWhole

skullBack

skullCrown



skullForehead

headLowerFace (includes inner mouth)

headSmooth



eyeEnds

eyeTop

eyeUnder



headAll (includes inner mouth)

visibility (includes inner mouth)

7.2 UV Map

This tool allows you to add/change the UV mapping of the selected surface. There are several options 
available here:

Map the Selected Surface

Click on this button to remap the selected portions of the surface. The result is a planar map, defined by 
the current viewport.

Auto UV Mapping

This feature allows you to automatically UV map just about any object. The resulting maps can only be 
edited in a 3D paint program (such as this). Only the currently selected area of the surface will be 
remapped. Unless you really know what you are doing, you should select the entire surface before 
using this feature. Please note that for this feature to work well, there should be a high "pixel-to-
polygon" ratio. That is, the resolution of the texture map should be high enough, such that each 
polygon "has enough space" on the map.



7.3 Weld Vertices

This tool is essential for Poser(R) users who wish to create a morph target that spans multiple body 
parts. Also note, that when exporting OBJ file(s), the groups are saved unwelded by default.  You need 
not worry about using this tool to unweld the object beforehand, unless you have a specific situation 
that requires you to.

Technical Note: All of the vertices that are discarded from the welding process are kept in sync with morphing process. 
This is essential for morph targets that span multiple body parts (full body morphs). So, when the object is unwelded, the 
formerly discarded vertices will have the same positions as those that they were welded to.

Precision Slider

The precision determines how close that two points should have to be considered for welding. A larger 
number represents greater precision when welding (vertices need to be closer together).  A smaller 
number can be used for lower precision (catches all nearby vertices).  Typically, a value of '8' is best, 
but if the seams fail to weld properly, you may wish to lower the value.

Weld Button

Allows you to perform the actual welding, given the options that are set.

Unweld Button

The "Unweld" button allows you to reverse the welding process, revealing any seams that were 
originally in the object.

7.4 Merge Objects

This tool allows you to merge all of the objects in the project into a single object. There are several 
options here.

One Material Per Object

This will create only one material per source object.

Auto-Rename Materials

This will rename the materials so they also contain the source object's name. If there is only one 
material in the source object, then the material name will be the same as the object's name. If there are 
multiple materials, then the material name will be like [Object Name]-[Material Name].

One Group Per Object

This will create only one group per source object.



Auto-Rename Groups

This will rename the groups so they also contain the source object's name. If there is only one group in 
the source object, then the group name will be the same as the object's name. If there are multiple 
groups, then the group name will be like [Object Name]-[Group Name].

Re-map Object (UV)

This option will resize and re-arrange the UV maps for each source object such that they will all fit 
together on the destination object's UV map without overlapping (on a per material basis).

Merge All Objects Button

Merges all of the objects in the project into one object, using the options defined above.

8. Maps
Maps are images that contain any color and texture information that has been painted on the object. In 
Blacksmith3D, there are four channels that contain maps that can be painted on. You can select the 
different maps for painting from the Maps button on the toolbar.

8.1 Color Map

This is the “main” map for the object. It contains all of the color and texture information. This is where 
you will all of your basic painting and texturing.

8.2 Transparency Map

This map is only to be used if you wish to apply transparency to certain parts of your object. The 
transparency map contains only the colors black and white. Anything that is completely black will 
render as transparent, while anything completely white will be opaque. Anything in between (ie. shades 
of grey) will render with partial transparency. Note that transparency is only viewable at render time.

8.3 Bump Map

This map is only to be used if you wish to apply a bump to areas of your object. This map uses only 
black, white and shades of grey. Anything white will bump up, while anything black will bump down. 
Anything grey will be in the middle somewhere.

8.4 Displacement Map

This map is only to be used if you wish to apply displacement to areas of your object. This map uses 
only black, white and shades of grey. Anything white will displace up, while anything black will 
displace down. Anything grey will be in the middle somewhere.



9. Project Management
Blacksmith3D offers management windows for keeping track of objects, selections, morphs, and 
materials. With simple projects, you might not use them as much, but as your projects grow more 
complicated these windows will become invaluable for keeping organized.

9.1 Object Manager

The window lists all of the objects currently in the project. These objects remain separate from one 
another, and the object of focus must be selected in the Object Manager in order to perform operations 
on it.

NOTE: You can also merge all of the objects in one object (7.3)

Two objects in a project.

Right click to get the following options  (with the exception of the Read Only option which is located 
on the window interface).

Read Only

Checking this box will make the currently selected object read only, so that it can not be edited. 
Uncheck the box to turn read only off for the selected object.

Rename

Rename the selected object.



Create Object Group

Make a new object group for organizing your objects. You can rename the group to whatever you like, 
and drag objects in and out of it. You can also drag a group into another group, effectively creating 
sub-groups.

Created a new group, and added the cone object to it.

Delete

Delete the selected object. If you delete an object group, everything in the group will be deleted as 
well. You can also do this by dragging things out of the Object Manager and into the Trash.

9.2 Selection Manager

This window allows you to organize and save multiple selections. You can create selections for 
commonly used parts of the object. For example, if you are morphing a human head, you may wish to 
create selections for the nose, chin, cheek bone, etc. rather than re-painting selections each time you 
want to adjust them again.

NOTE: If you have multiple objects in the scene, only the active object in the Object Manager will be selectable, and only 
its saved selections will show up in the Selection Manager. You have to change which is your current object of focus in 
order to perform selection operations on it. Conversely, you can merge all of the objects in the scene into one object (pg. #).

A saved selection for half of the sphere



Right click to get the following options  (with the exception of the Read Only option which is located 
on the window interface).

Read Only

Checking this box will make the current selection read only, so that it can not be edited. Uncheck the 
box to turn read only off for the selection.

Rename

Rename the selection.

Create New Selection

With this option, you can create a new selection and edit it separately from the other selections 
currently in the project.

Created a new selection for the top tip of the sphere

Create Selection Group

Create a new selection group for organizing your selections. Simply drag and drop selections in the list 
into the group. You can also drag the groups into other groups, effectively creating sub-groups.

Created a group called “sphere tips” to hold the top selection, and a new bottom selection



Duplicate Selection

This option creates a duplicate of the current selection. This is useful if you want to create a new 
selection that expands upon (or is a reduced version) of an existing selection.

Duplicated the top selection and added a stroke across the middle. The original top selection remains untouched and 
functions as normal.

Delete

Delete the selected selection. If you delete a selection group, everything in the group will be deleted as 
well. You can also do this by dragging things out of the Selection Manager and into the Trash.

9.3 Morph Manager

This window allows you to organize multiple morphs on your object. A morph is the transition between 
the original object shape and a newly deformed object shape.

The sliders on the Morph Manager control the strength of the morph. A setting of 0 is no strength, 0.5 
is half strength, 1 is full strength, and anything above that is “extra” strength, which will result in 
“double” the morph, as it is being set to more than maximum.

Essentially, your object starts with the Default Morph, set to 1. This means that any deformations you 
make on the object will automatically become the maximum morph appearance on this slider (moving 
the slider back to 0 will show you the transition).



Head bulge deformation (Default Morph set to 1, full strength)

Default Morph reduced to 0 strength to show original shape

You can create many different morphs in your project, and export them all together in a CR2 file, or in 
separate OBJ files.

Right click to get the following options  (with the exception of the Read Only and Mix Morphs options 
which are located on the window interface).

Read Only

Checking this box will make the current morph read only, so that it can not be edited. Uncheck the box 
to turn read only off for the morph.

Mix Morphs

When this option is checked, all of the morphs will be mixed together, according to their strength 
settings (default setting). When it is unchecked, only the current morph is displayed (at full strength).



Rename

Rename the morph.

Create New Morph

With this option, you can create a new morph target and edit it separately from the other morph targets 
currently in the project.

Created a new morph to control a 3D scale on the nose

NOTE: If you have multiple morphs, make sure to keep track of the one you're currently working on. The morph that is 
selected in the Morph manager will be the one that your deformations will be applied to. Also, keep in mind that the morph 
strength that is set for the morph you're deforming on will be the maximum setting for that deformation. It is a good practice 
to use 1 as the maximum strength.

Create Morph Group

Create a new selection group for organizing your morphs. Simply drag and drop morph targets in the 
list into the group. You can also drag the groups into other groups, effectively creating sub-groups.

Created a group called “head morphs” to hold the big nose morph, and a new big ears morph



Delete

Delete the selected morph target. If you delete a morph group, everything in the group will be deleted 
as well. You can also do this by dragging things out of the Morph Manager and into the Trash.

Duplicate Morph

This option allows you to create a duplicate of the current morph. This is handy if you want to create a 
new morph that expands upon an existing morph. Also handy if you want to make changes to a morph 
but want to keep a copy of the original untouched.

Duplicated the big ears morph to create a new morph that has the same size deformation, but adds a pointy-eared 
deformation to it. The original big ears morph functions remains untouched and functions as normal

Spawn Morph

This option will create a new morph target based on how the current state of the object. If you have the 
Mix Morphs option enabled, and you have several morphs blended together, then the spawned morph 
will combine those morphs into single morph.

Spawned a new morph that incorporates both the big nose and the big pointy ears. Note how all of the other morphs are set 
back to 0 strength, because they will still function in relation to the current shape of the object (causing “double” morphs)



9.4 Material Editor

The Material Editor allows you to control the texture maps in the project, and how they are assigned to 
the different materials of the object. The Material Editor can be opened by clicking Window>Material 
Editor.

Material Listing

The material listing in the upper left shows all of the materials on the object (if there are no pre-existing 
materials on the object, Blacksmith3D will use a “default” material for the whole thing). Each material 
will have its own independent map associations and other options, so make sure you have the desired 
material selected when you are working in the editor.

Set All Materials to White Button

Click this button to automatically set the color of all of the materials to white. This is useful if you are 
painting an object that has colored materials, but you do not want the colors to be blended with the 
texture maps.



Select By Material Button

Choose a material from the list and click this button to select the entire material in the viewport.

Deselect By Material Button

Choose a material from the list and click this button to deselect the entire material the viewport.

9.4.1 Channels

There are four channels for each material in Blacksmith3D: color (the main painting channel), 
transparency, bump, and displacement.

Color Button

This button will change the color of the material. Generally, all of your materials will be white, though 
some imported characters may have different colors assigned to various materials.

Map Button

This button will open a dropdown menu that contains all the maps currently in the project. Select one 
of them to assign it to the appropriate channel.

9.4.2 Maps

This area is used to manage the texture maps in the project. The basic display for the maps in the 
project shows the map name and size which can be changed using the right-click menu, as well as these 
two options:

Enabled

This check box toggles whether the map is enabled or disabled. This is useful if you have many large 
maps loaded into the project that you are not editing and would like to temporarily hide. Disabled maps 
will have the words “Map Disabled” written on them in the viewport to indicate such.



Format

This dropdown will change the default image format for the map in question. This will be used when 
exporting. It's handy when you have a lot of maps that you want to export as different formats, but don't 
want to set them all at export time.

The maps can also be dragged to the Map button and to the Trash. Right-click for these next options:

Create New Map

This will allow you to create a new blank map in Blacksmith3D. You will be prompted by the Create 
New Map dialog, which will allow you to choose what kind of map you'd like to create, and what size 
it will be.

In general, you will be creating color maps to paint textures on. However, you may also choose 
transparency, bump, or displacement maps from this window to create a new map that is already set up 
with the appropriate colors (ie. these maps function in shades of grey). You can also choose values for 
the height and width here (in pixels) with 256 being smallest and 2048 being biggest. Keep in mind that 
larger maps will take more up more memory space, and many large maps might slow performance.

Import

This will let you choose an external image file and bring it into Blacksmith3D as a texture map.

Export

This will let you save out the texture map to an external image file. It will take your file format preset 
for the map in question as the default setting for saving (it can still be changed here, however). Note 
that this only exports the single map in question. If you want to export all maps at once, use Export 
from the File Menu, and choose Maps (the file format settings for each will be remembered).



Change Default Color

This will allow you to change the solid color of the map. By default, this color is set to white. If you 
change it to something else, it will be indicated by a border around the map display. If you clear this 
map, it will flood to the default color.

Map set to default color of orange, then cleared

Resize

This will allow you to resize the map.

Rename

This will allow you to rename the map.

Clear

This will clear the map to the default color.

Delete

This will delete the map from the project. Be careful, as this is not undoable.

Copy

This will copy the map to the clipboard, so that it can be pasted elsewhere. You can even paste it into 
another program.

Paste

This will paste whatever image is on the clipboard into the maps area. If you have an existing map 
selected, the pasted map will replace it (this is undoable if you make a mistake). To paste as a new 
map, select the Empty map at the far right and paste it there.



9.5 Layer Manager

The Layer Manager allows you to specify various layers to organize your project. You can add 
selections to layers to break up your objects, allowing you to isolate certain parts without accidentally 
affecting others. This works great in conjunction with painting.

Each layer has a Layer Mode button that determines how the layer is displayed. By default, each layer 
is visible (eye icon). Click once to lock the layer (lock icon). Click again to hide the layer (crossed-out 
eye icon). Click once more to make it visible again.

Visible

Locked

Hidden

9.5.1 Layer Operations

This button contains a sub-menu for various layer operations.



Add Selection to Layer

This will add whatever is selected in the viewport to the layer. This selection will then be affected by 
the layer settings.

The top half of this sphere was selected and assigned to Layer 1. Now, when this layer is locked or hidden, the selection will 
be affected.

Remove Selection from Layer

This option will remove the current selection from the layer, causing it to no longer be affected by the 
layer settings.

Add Object to Layer

This will add the entire active object to the layer.

Sphere object added to layer and locked.

Remove Object from Layer

This will remove the entire active object from the layer.



Select Layer

This will paint a hot selection over everything assigned to the layer. This can be used in conjunction 
with Remove Selection from Layer in order to empty the layer entirely.

The top of the sphere assigned to the layer is given a hot selection.

Deselect Layer

This will deselect everything assigned to the layer.

9.5.2 Layer Options

Layer Name

Here you can type in a name for the layer to better define its contents.

Layer Color

Click the color button to assign a color to the layer. This is not a painted color, but rather a 
distinguishing color for telling your layers apart in the viewport (only visible when textures are turned 
off).



Layer Display

This button is identical to the viewport display options, except for the Use Viewport Settings option. If 
this is checked, the layer will take on the same display options as the viewport. If it is unchecked, you 
can specify different display options for that individual layer.

Three spheres with their top halves assigned to three separate layers. Each layer is set to display its contents differently 
(stippled, wireframe, points). The bottom halves which are not assigned to any layers, take on the display settings of the 
viewport.

Layer Brush

This tool allows you to interactively add to a layer by painting directly in the viewport.

A layer created by painting directly on the object.



9.6 General Options

In the General Options window, you can adjust a number of project settings to customize 
Blacksmith3D for yourself.

Undo Limit (MB)

This option allows you specify the maximum amount of memory (in megabytes) that can be used for 
the undo buffer. Please note that once the undo buffer has been filled, the older changes that you made 
cannot not be undone, in favor of the most recent changes.

Minimum Texture Size

This option sets the minimum size that an imported texture is allowed to be. If a texture is smaller than 
this size, it will be stretched out to fit.

Default Texture Size

This option sets the maximum size that an imported texture is allowed to be. If the texture is greater 
than this size, it will be shrunk down to fit. Please note that Blacksmith3D works very closely with the 
OpenGL drivers of your video card. If you use very large texture maps, and you do not have enough 
RAM on your video card to hold them, then the textures will be stored in conventional memory, 
causing the program to slow down significantly, especially while painting textures. If you experience 
this, please reduce the 'Maximum Texture Size', and re-import the object.

Maximum Texture Size

This option sets the maximum size that an imported texture is allowed to be. If a texture is larger than 
this size, it will be shrunk down to fit.

Auto-Backup Frequency

This is the frequency that Blacksmith3D will auto-save your project. Moving the slider all the way to 
the left will disable auto-save.

Cache Viewports

When this option is checked, an image of each 3D viewport is cached after a change has been made. 
This helps speed up the interface dramatically. However, some video cards may not be able to do this 
correctly. In that case, disable this option.



Texture Compression

When this option is checked, texture maps that are not currently being edited are compressed (if 
supported by your video card driver) to save valuable video RAM. This can speed up the performance 
of the 3D painting feature if your video RAM is limited, however, switching between objects may be 
slower.

Fonts

This listing allows you to change the font that is used for Blacksmith3D's interface text. Changes made 
here will take effect the next time you launch Blacksmith3D.

Color Schemes

This listing allows you to change the color scheme that is used for Blacksmith3D's interface. Changes 
made here will take effect the next time you launch Blacksmith3D.

10. Importing & Exporting
Blacksmith3D can import OBJ and CR2 files that were created with other software, and likewise, it can 
export OBJ and CR2 files that will be compatible with other software. Blacksmith3D can also export 
MOR and MAT files for use with Poser. In terms of images, Blacksmith3D works with JPG, TIF, 
TGA, PNG and BMP image file formats for texture maps, file textures for painting, and image 
references. Finally, you can also export the Blacksmith3D SelSet and MorSet specialty files.

10.1 OBJ & CR2 Files

Click File>Import and navigate to an OBJ or CR2 file to load it into your project. You can load 
multiple files.

10.1.1 Exporting OBJ Files

Click File>Export to load up the Export OBJ File dialog. There are a number of export options 
available here.

Vertices Only (for morph targets)

Only the vertices will be saved to the OBJ file. To create a morph target in some programs, only the 
vertices are required. The resulting object will NOT be visible if you simply import it as a stand alone 
object.

Export Groups

If this option is checked, each group will be distinguished by the 'g' identifier in the OBJ file.



Export Groups as Separate Files

If this option is checked, and you enter the file name MyModel.OBJ when prompted, the resulting 
objects will be named: MyModel_Head.OBJ,  MyModel_Chest.OBJ, etc.

Export Changed Groups Only

This option allows you to only export the groups that have been changed. For example, if you morphed 
a character's nose, then only the “head” group will be exported.

Export Maps

If this option is enabled, then texture, bump and transparency maps will be exported along side the OBJ 
file. You can also do this independently from the File menu.

10.1.2 Exporting CR2 Files

Click File>Export to open the export dialog, then choose CR2 as the file type. There are a number of 
export options available here, which may be daunting if you aren't sure what your project requires. In 
this case, you can skip ahead to the section on the CR2 Export Wizard (10.1.3) which will give you a 
better understanding of what's going on. Otherwise, here are the available options:

Auto-Adjust Joint Parameters

This feature will adjust the joints in the CR2 file to match the state of the new object being exported. 

If you started off with a regular human male figure and then morphed him to super huge proportions, 
then normally, the joints would no longer bend the object properly. This option will adjust the joints so 
they (in most cases) work perfectly. It is especially good at adjusting hands and fingers.

In some cases, minor adjustments may be required after the CR2 file is exported. This option will not 
work properly if you change the "orientation" of a body part. For example, if the right arm was pointing 
straight out to the side and it was then morphed to point forwards, then the joints will not be adjusted 
properly.

Create New OBJ File

This option will allow you to export a new base object for the character, rather than simply morphing 
the original base object. This is especially useful, if the morph has drastically the changed size and 
positions of the limbs. This option used in conjunction with the "Auto-Adjust Joint Parameters" feature 
allow you to create new characters easily without having to adjust the joints (which is a slow and 
tedious process).

Setup Full Body Morphs

Full body morphs are a collection of smaller body parts. This option sets them up for you.



Export Morphs

Use this option to export all of the morphs in this project into the CR2 file.

Export Maps

If this option is enabled, then texture, bump and transparency maps will be exported along side the CR2 
(and OBJ) files. You can also do this independently from the file menu.

10.1.3 CR2 Export Wizard

This wizard provides information on what your CR2 output settings should be, depending on your 
project. The wizard can be opened by clicking the red CR2 Export Wizard button on the Export CR2 
File dialog.

Clicking on any of these three settings will automatically set the appropriate CR2 output options for your project.



10.2 Maps

Maps can be easily imported and exported. Blacksmith3D supports  JPG, TIF, TGA, PNG and BMP 
image file formats.

Importing Maps

To import a map, click Window>Material Editor. Right-click in the Maps section and choose Import.

Exporting Maps

To export single maps, right click the desired map in the Material Editor and choose Export. To export 
ALL maps, use File>Export and choose Maps.

10.3 Morphs

If you are just creating morphs, you can import and export them separately. Morphs are dealt with in 
OBJ file format.

Importing Morphs

Click File>Import Morphs to import an OBJ file as a morph target. Make sure that the vertex count and 
order is the same, or the morph will not work correctly.

Exporting Morphs

Make sure that your object looks exactly as you want it to in the viewport, then click File>Export to 
open the Export OBJ dialog and export the morph.

Exporting Morph Sets

To export the morph information in the Morph Manager, click File>Export and choose Morph Set 
(MorSet file). You can also import MorSet files by choosing that format from the dropdown in the 
Import dialog. Note that these will only work properly on the same geometry they were saved out from.

10.4 Selections

To export the selection information in the Selection Manager, click File>Export and choose Selection 
Set (SelSet file). You can also import SelSet files by choosing that format from the dropdown in the 
Import dialog. Note that these will only work properly on the same geometry they were saved out from.



10.5 MOR and MAT Files

Blacksmith3D can also export Poser-specific MOR (morph) and MAT (material) files. Some CR2 files 
have blank/hidden morphs set up so that you can dynamically “inject” morphs into those slots. The 
MOR file is a file that contains a morph that can be injected into one of those slots. The Channel text 
box is where you specify the internal name of the slot the morph will go into. The MAT file is used to 
assign the appropriate material/channel/map settings. There is also the option to export the maps along 
with the MAT file. This is a more advanced feature, so if you are unfamiliar with the inner workings of 
these, export a CR2 instead.

10.6 Reference Images

Blacksmith3D also includes the ability to import a reference image, to use as a guide for things like 
facial and body morphs, as well as for grabbing colors and textures off of.

Importing A Reference Image

To bring a reference image into Blacksmith3D, simply drag it from wherever it's located on your drive 
directly into the viewport. The image will instantly appear as a new object in the project.

Moving an Image

You can use the Move In Plane and Rotate deformation tools to move the reference image around the 
viewport. There is no need to make a selection, because the whole thing is considered to be a selection. 
All you have to do is make sure that the image object is the active object in the Object Manager, and it 
will be ready to move.

Setting Up A Work Area

It is recommended that you use at least two reference images for your work, one from the front and one 
from the side. Using the Move In Plane and Rotate deformation tools, you can position these two 
images so that they serve as straight on references in the front and side views.

Additionally, it might be a good idea to assign the images to a layer, so that they can be turned off or 
on, if you want to preview your work with them hidden.

11. Final Notes
If you find any errors or omissions in this manual, please visit http://www.blacksmith3d.com and click 
“Contact” to tell us about it, or visit the forums at http://www.blacksmith3d.com/forums.

Thanks for using Blacksmith3D!

http://www.blacksmith3d.com/
http://www.blacksmith3d.com/forums

